Instalacja i administracja SOLIDWORKS

W tym przewodniku opisano instalację, licencjonowanie, uaktualnianie oraz administrowanie produktami SOLIDWORKS zarówno dla instalacji indywidualnych, jak i instalacji wielostanowiskowych.

Indywidualne instalacje | Rozmieszczanie instalacji wielostanowiskowych
Instalacja Instalacja na jednym lub na kilku komputerach. | Instalacja Tworzenie obrazu administracyjnego, który jest rozmieszczany na wielu komputerach klientów.
Licensing Aktywacja komputera lub licencjonowanie sieciowe. | Licensing Aktywacja komputera lub licencjonowanie sieciowe.
Uaktualnienie Przechodzenie na nowe wersje na indywidualnych komputerach. | Uaktualnienie Przechodzenie na nowe wersje na wielu komputerach poprzez aktualizację obrazu administracyjnego używanego do instalowania na tych komputerach.
Administracja Modyfikowanie, naprawianie i usuwanie instalacji, uaktualnianie do nowych wersji. | Administracja Uaktualnianie obrazów administracyjnych i klientów oraz zarządzanie licencjami sieciowymi.

Menedżer instalacji SOLIDWORKS pozwala na skonfigurowanie ustawień elementów składowych produktów SOLIDWORKS, w tym SOLIDWORKS, SOLIDWORKS Toolbox, SOLIDWORKS Electrical, SOLIDWORKS Manage, SOLIDWORKS PDM, SOLIDWORKS Visualize oraz SOLIDWORKS SolidNetWork License Manager.

Program SolidNetWork License Manager obsługuje wielu klientów licencji poprzez dystrybucję licencji do klientów za pośrednictwem sieci. Dzięki temu liczba użytkowników może przekraczać liczbę licencji poprzez użycie licencji ruchomych.

Spis treści

  • Instalacja indywidualna czy obraz administracyjny

    Czy należy instalować produkty SOLIDWORKS indywidualnie na każdym komputerze, czy też utworzyć obraz administracyjny i rozmieścić tę instalację na wszystkich klientach jednym poleceniem?

  • Sprawdzanie wymagań systemowych i dotyczących oprogramowania

    Przed rozpoczęciem instalacji należy sprawdzić, czy system spełnia wymagania w zakresie sprzętu, systemu operacyjnego i produktów firmy Microsoft. Dodatki, takie jak SOLIDWORKS Electrical, SOLIDWORKS Visualize i eDrawings, mają dodatkowe wymagania.

  • Pobieranie nośników instalacyjnych

    Wszystkie nośniki instalacyjne są dostępne na stronie pobierania SOLIDWORKS.

  • Instalowanie aplikacji 3DEXPERIENCE

    W przypadku zarządzania danymi przy użyciu platformy 3DEXPERIENCE Platform można zakupić rolę Collaborative Designer for SOLIDWORKS, aby połączyć środowisko pulpitu z platformą.


Instalacja indywidualna czy obraz administracyjny

Czy należy instalować produkty SOLIDWORKS indywidualnie na każdym komputerze, czy też utworzyć obraz administracyjny i rozmieścić tę instalację na wszystkich klientach jednym poleceniem?

W przypadku instalowania tylko na jednym komputerze lub zarządzania dziesiątkami lub setkami komputerów, wybór jest oczywisty. W pozostałych, mniej jasnych sytuacjach, należy uwzględnić poniższe porównania.

Indywidualna instalacja | Obraz administracyjny
Użytkownicy mogą samodzielnie dokonać administracji SOLIDWORKS. | Administrator systemu może dostosować wiele instalacji przy użyciu Edytora opcji, określając opcje instalacji takie jak tworzenie nowej instalacji lub aktualizacja istniejącej instalacji, uruchamianie instalacji jako użytkownik administracyjny, uruchamianie poleceń zewnętrznych przed lub po instalacji, różne grupowania produktów, itd.
Osoba wykonująca instalację musi mieć fizyczny dostęp do komputerów. | Komputery klienci mogą być zlokalizowane odlegle pod warunkiem ze jest do nich dostęp z tej samej sieci.
Można zainstalować różne wersje, pakiety Service Pack lub produkty na różnych komputerach, z niezależnymi ustawieniami. | Przy użyciu Edytora opcji, obrazy administracyjne mogą zachować spójność wersji, pakietów Service Pack, produktów oraz ustawień dla wielu instalacji.
Komputery muszą mieć dostęp do sieci lub poczty e-mail. Połączenie z siecią lub pocztą e-mail jest wymagane do aktywacji SOLIDWORKS i pobrania plików. Dostęp do sieci jest również wymagany podczas pobierania licencji z serwera licencji sieciowych.

Wymagane jest połączenie z siecią lokalną, w celu rozmieszczenia aplikacji. Nośniki nie są wymagane na komputerach klienta.

Klienci mogą być aktualizowani automatycznie. Wszyscy klienci pochodzący z jednego obrazu administracyjnego maja ten sam pakiet Service Pack. Aby zachować wiele wersji, można utworzyć wiele obrazów administracyjnych.

Aktywacja licencji może być zautomatyzowana.

Obraz administracyjny wymaga dodatkowego miejsca na serwerze; klienci wymagają takiej samej ilości miejsca co instalacje indywidualne.

Temat nadrzędny Instalacja i administracja SOLIDWORKS
Sprawdzanie wymagań systemowych i dotyczących oprogramowania
Pobieranie nośników instalacyjnych
Instalowanie aplikacji 3DEXPERIENCE


Sprawdzanie wymagań systemowych i dotyczących oprogramowania

Przed rozpoczęciem instalacji należy sprawdzić, czy system spełnia wymagania w zakresie sprzętu, systemu operacyjnego i produktów firmy Microsoft. Dodatki, takie jak SOLIDWORKS Electrical, SOLIDWORKS Visualize i eDrawings, mają dodatkowe wymagania.

Aby zapewnić pomyślną instalację oraz optymalną wydajność, patrz: Wymagania systemowe.

Temat nadrzędny Instalacja i administracja SOLIDWORKS
Instalacja indywidualna czy obraz administracyjny
Pobieranie nośników instalacyjnych
Instalowanie aplikacji 3DEXPERIENCE


Pobieranie nośników instalacyjnych

Wszystkie nośniki instalacyjne są dostępne na stronie pobierania SOLIDWORKS.

W razie problemów z uzyskaniem dostępu do strony pobierania SOLIDWORKS należy się skontaktować ze sprzedawcą VAR, aby uzyskać płyty DVD.

Aby pobrać nośnik instalacyjny:

  1. Zalogować się na stronie pobierania SOLIDWORKS jako klient usługi subskrypcji przy użyciu adresu e-mail i hasła lub numeru seryjnego SOLIDWORKS.
  2. Na stronie Materiały do pobrania, w sekcji Wybierz wersję, wybrać rok.
  3. Wybrać kartę SOLIDWORKS dla kategorii Produkty SOLIDWORKS .
  4. W obszarze Produkt wybrać pakiet Service Pack.
    W przypadku najnowszej wersji głównej wybrać Produkty SOLIDWORKS w wersji 0.0.
  5. Kliknąć opcję Akceptuj umowę i kontynuuj, aby zaakceptować warunki umowy licencyjnej.
  6. Kliknąć Download (Pobierz).
    Przeglądarka pobierze plik SolidworksSetup.exe do lokalizacji domyślnej C:\Users\Username\Downloads.
  7. Rozpakować plik SolidworksSetup.exe do folderu Downloads.
    Można również rozpakować plik SolidworksSetup.exe do preferowanej lokalizacji.
  8. Uruchomić plik setup.exe z uprawnieniami administracyjnymi.
  9. W Menedżerze instalacji kliknąć Pobierz i udostępnij wszystkie pliki.
    Utworzyć pojedyncze instalacje lub obrazy administracyjne na wielu komputerach za pomocą jednego pobrania, a następnie postępować zgodnie z instrukcjami, aby zakończyć proces.

    Menedżer instalacji pobiera nośnik instalacyjny.

    Opcja ta jest użyteczna do następujących celów:
    • Instalacja oprogramowania na niewielkiej liczbie komputerów
    • Pobieranie za pomocą dysku przenośnego lub dysku sieciowego
    • Instalowanie pakietów Service Pack
    Aby pobrać wybrane pliki instalacyjne, należy postępować zgodnie z instrukcjami i wybrać metodę pobrania ręcznego.
Temat nadrzędny Instalacja i administracja SOLIDWORKS
Instalacja indywidualna czy obraz administracyjny
Sprawdzanie wymagań systemowych i dotyczących oprogramowania
Instalowanie aplikacji 3DEXPERIENCE


Instalowanie aplikacji 3DEXPERIENCE

W przypadku zarządzania danymi przy użyciu platformy 3DEXPERIENCE Platform można zakupić rolę Collaborative Designer for SOLIDWORKS, aby połączyć środowisko pulpitu z platformą.

Rola Collaborative Designer for SOLIDWORKS udziela dostępu do aplikacji 3DEXPERIENCE, które pozwalają produktom SOLIDWORKS Desktop na zapisywanie i wyszukiwanie danych przechowywanych na platformie oraz zarządzanie nimi.

Instalacja oraz licencjonowanie tych aplikacji odbywa się poprzez platformę 3DEXPERIENCE Platform, a nie Menedżera instalacji SOLIDWORKS. Instrukcje instalacji można znaleźć w Pomocy SOLIDWORKS, patrz Praca z 3DEXPERIENCE Platform i aplikacjami 3DEXPERIENCE > Instalowanie aplikacji 3DEXPERIENCE.

Temat nadrzędny Instalacja i administracja SOLIDWORKS
Instalacja indywidualna czy obraz administracyjny
Sprawdzanie wymagań systemowych i dotyczących oprogramowania
Pobieranie nośników instalacyjnych
https://help.solidworks.com


Indywidualne instalacje

Spis treści

  • Instalacja na indywidualnych komputerach

    SOLIDWORKS można zainstalować na indywidualnym komputerze wykorzystując kilka metod instalacji.

  • Administracja indywidualnymi instalacjami

    Zwykle administracja indywidualnymi instalacjami polega na modyfikowaniu, naprawianiu, usuwaniu i uaktualnianiu instalacji.


Instalacja na indywidualnych komputerach

SOLIDWORKS można zainstalować na indywidualnym komputerze wykorzystując kilka metod instalacji.

Menedżera instalacji SOLIDWORKS wykonuje instalację, dopasowując instalację do nabytych produktów. Przed rozpoczęciem instalacji, należy:

  • W przypadku instalacji autonomicznego stanowiska SOLIDWORKS należy przygotować numery seryjne SOLIDWORKS.
  • Zweryfikować, czy istnieje funkcjonujące połączenie internetowe. Połączenie jest wymagane w celu sprawdzenia uprawnień.
  • Utworzyć identyfikator 3DEXPERIENCE ID. Szczegółowe informacje na temat tworzenia identyfikatora 3DEXPERIENCE ID można znaleźć w https://www.3ds.com/support.
  • Sprawdź, czy jesteś wyznaczonym administratorem konta lub czy Twój administrator wskazał Cię jako kontakt.

Menedżer instalacji SOLIDWORKS instaluje różne komponenty Microsoft, takie jak Microsoft Visual Studio Tools for Applications, Visual Basic oraz .NET Framework. Jeżeli na komputerze nie ma zainstalowanych prawidłowych wersji wszystkich wymaganych wstępnie komponentów, Menedżer instalacji SOLIDWORKS instaluje je automatycznie przed zainstalowaniem produktów SOLIDWORKS.

SOLIDWORKS Chromium Embedded Framework (CEF) jest kolejnym komponentem instalowanym przez Menedżera instalacji SOLIDWORKS. Jego celem jest wyświetlanie treści dla aplikacji SOLIDWORKS i 3DEXPERIENCE Platform.

SOLIDWORKS Login Manager jest również instalowany przez Menedżera instalacji SOLIDWORKS. Umożliwia zalogowanie się do 3DEXPERIENCE Marketplace i aplikacji 3DEXPERIENCE.

Metoda instalacji opis ogólny procesu
Pobieranie ze strony pobierania SOLIDWORKS

Wszystkie nośniki instalacyjne są dostępne na stronie pobierania SOLIDWORKS.

  1. Przejść do strony pobierania SOLIDWORKS.
  2. Zaloguj się za pomocą identyfikatora 3DEXPERIENCE ID.
  3. Na stronie Downloads (Materiały do pobrania), w sekcji wybierz wersję, wybrać rok.
  4. Wybrać kartę SOLIDWORKS dla produktów SOLIDWORKS i w części Produkt wybrać pakiet Service Pack.
  5. Kliknąć opcję Akceptuj umowę i kontynuuj, aby zaakceptować warunki umowy licencyjnej.
  6. Kliknąć Download (Pobierz).
Użytkownik musi mieć działające połączenie z Internetem i mieć dostęp do strony pobierania.

W razie problemów z uzyskaniem dostępu do strony pobierania należy się skontaktować ze sprzedawcą VAR, aby uzyskać nośnik instalacyjny.
Użycie katalogu pobierania na serwerze W katalogu pobierania kliknij dwukrotnie setup.exe.

Katalog pobierania musi być dostępny z komputera, na którym instalowane są produkty SOLIDWORKS i musi zawierać wszystkie pliki instalacyjne SOLIDWORKS, aby możliwe było rozpoczęcie instalacji. Menedżer instalacji SOLIDWORKS może pomóc w odnalezieniu brakujących plików, jeżeli istnieje dostęp do Internetu i uprawnienia do zapisu w katalogu pobierania.
Aktualizacja istniejącej instalacji SOLIDWORKS przy użyciu narzędzia Sprawdź, czy istnieją aktualizacje Wykonać jedną z następujących czynności:
  • W SOLIDWORKS kliknąć [image] > Sprawdź, czy istnieją aktualizacje.
  • W systemie Windows kliknąć Start > Menedżer instalacji SOLIDWORKS > Sprawdź dostępność aktualizacji.
Można również kliknąć Start > Menedżer instalacji SOLIDWORKS > Pobieracz w tle SOLIDWORKS. W obszarze powiadomień systemu Windows kliknąć prawym przyciskiem myszy pozycję Pobieracz w tle SOLIDWORKS i kliknąć Sprawdź dostępność aktualizacji.
Na komputerze wymagane jest działające połączenie internetowe i uprawnienia administratora.

W Menedżerze instalacji SOLIDWORKS można również wybrać opcję Pobierz i udostępnij wszystkie pliki, która obejmuje także wymagane oprogramowanie. Ta opcja przydaje się w przypadku instalacji oprogramowania na kilku komputerach i kopiowania pobranych plików z dysku przenośnego lub dysku sieciowego. Pomocne jest również zainstalowanie pakietów Service Pack, ponieważ pełna wersja i pakiet Service Pack są zawarte w jednej instalacji.

Po zakończeniu instalacji należy uruchomić aplikację SOLIDWORKS i aktywować licencję.

Aby wyświetlić listę produktów, dla których dostępna jest licencja na danym komputerze, w głównym menu SOLIDWORKS:
  • Kliknąć [image] > Moje produkty
  • Kliknąć Strona główna w okienku zadań, Zasoby SOLIDWORKS > Moje produkty
  • Kliknąć Start > Narzędzia SOLIDWorks Wersja > Moje produkty.

Znaki zaznaczenia w polu dialogowym wskazują produkty w oparciu o aktywacje i licencje sieciowe, które użytkownik lub jego organizacja posiadają. Klikając łącze u góry każdej kategorii produktów, można uzyskać więcej informacji na temat produktów SOLIDWORKS.

Jeśli masz licencję SOLIDWORKS i chcesz sprawdzić, które licencje są w użyciu, należy w systemie Windows kliknąć kolejno Start > Narzędzia SOLIDWORKS <wersja> > Klient SolidNetWork License Manager > Użycie licencji.

Temat nadrzędny Indywidualne instalacje
Administracja indywidualnymi instalacjami


Administracja indywidualnymi instalacjami

Zwykle administracja indywidualnymi instalacjami polega na modyfikowaniu, naprawianiu, usuwaniu i uaktualnianiu instalacji.

Spis treści

  • Modyfikowanie instalacji

    Można modyfikować instalację, aby zainstalować produkty, które nie zostały zainstalowane, albo usunąć produkty, pod warunkiem że poprzednia instalacja została wykonana z pełnego zestawu plików instalacji. Opcja ta nie jest dostępna w przypadku uaktualnienia poprzedniej instalacji przy użyciu pakietu service pack.

  • Naprawianie instalacji

    Jeżeli napotkamy na problemy z zainstalowanym produktem SOLIDWORKS, można użyć Menedżera instalacji SOLIDWORKS, aby naprawić instalację.

  • Przywracanie indywidualnej instalacji do poprzedniego pakietu Service Pack

  • Usuwanie instalacji

    Można usunąć instalację na indywidualnym komputerze lub w środowisku klient/serwer.

  • Uaktualnianie do nowej wersji

    Istnieje kilka metod uaktualniania indywidualnej instalacji do nowej wersji SOLIDWORKS.

  • Zasady współistnienia produktów

    Poniższe zasady współistnienia produktów określają jak nowe produkty są instalowane i istniejące produkty są uaktualniane.

Temat nadrzędny Indywidualne instalacje
Instalacja na indywidualnych komputerach


Modyfikowanie instalacji

Można modyfikować instalację, aby zainstalować produkty, które nie zostały zainstalowane, albo usunąć produkty, pod warunkiem że poprzednia instalacja została wykonana z pełnego zestawu plików instalacji. Opcja ta nie jest dostępna w przypadku uaktualnienia poprzedniej instalacji przy użyciu pakietu service pack.

Jeśli zainstalowano SOLIDWORKS i zakupiono dodatek w późniejszym terminie, można zmodyfikować instalację, aby uwzględnić nowy dodatek. Należy zainstalować dodatek na wszystkich komputerach.

  1. Należy upewnić się, że nie są aktywne żadne sesje SOLIDWORKS.
  2. Otworzyć Aplikacje Windows i kliknąć opcję Zainstalowane aplikacje.
  3. Wybrać instalację SOLIDWORKS, którą należy zmodyfikować, a następnie kliknąć Zmień.
  4. Na ekranie Witamy w Menedżerze instalacji SOLIDWORKS kliknąć Modyfikuj instalację.
  5. Sprawdzić, czy na ekranie Numer seryjny wyszczególnione są odpowiednie numery seryjne.
  6. Wybrać produkty do zainstalowania lub usunięcia na ekranie Wybór produktu.
    Podczas modyfikowania instalacji:
    • Domyślnie nie są instalowane ani usuwane żadne produkty, nawet jeżeli określony zostanie nowy numer seryjny. Konieczna jest zmiana czynności instalacji dla każdego produktu lub komponentu funkcji.
    • Aby zobaczyć przewidywaną akcję dla konkretnego komponentu, należy kliknąć nazwę komponentu (nie klikać pola wyboru). Przewidywana akcja instalacyjna pojawi się w polu informacji poniżej listy produktów.
    • Można kliknąć pole wyboru obok komponentu produktu, aby zmienić akcję instalacyjną dla tego komponentu. (Na przykład: w przypadku instalowania lub usuwania komponentów, zaznaczenie pola wyboru określa, czy dany komponent ma być zainstalowany lub usunięty, a odznaczenie pola wyboru oznacza, że komponent ma nie być instalowany lub usuwany.)
    • W przypadku zmiany akcji instalacji produktu w stosunku do początkowej specyfikacji, obok tego komponentu na liście pojawi się gwiazdka (*).
    • Jeżeli komponent zawiera opcjonalne podkomponenty, obok niego jest wyświetlana ikona [image] . Aby zobaczyć dostępne podkomponenty w danym komponencie, należy kliknąć ikonę [image] .
    • Jeżeli komponent został rozwinięty, aby pokazać opcjonalne podkomponenty, obok niego jest wyświetlana ikona [image] . Aby zwinąć listę podkomponentów, należy kliknąć ikonę [image] .
  7. Na ekranie Podsumowanie kliknąć Modyfikuj teraz.
  8. Na ekranie Ukończono instalację, kliknąć Zakończ.
Temat nadrzędny Administracja indywidualnymi instalacjami
Naprawianie instalacji
Przywracanie indywidualnej instalacji do poprzedniego pakietu Service Pack
Usuwanie instalacji
Uaktualnianie do nowej wersji
Zasady współistnienia produktów


Naprawianie instalacji

Jeżeli napotkamy na problemy z zainstalowanym produktem SOLIDWORKS, można użyć Menedżera instalacji SOLIDWORKS, aby naprawić instalację.

Aby naprawić instalację, na komputerze muszą znajdować się wszystkie pliki źródłowe z poprzedniej instalacji i wszelkie zastosowane pakiety Service Pack. Muszą one znajdować się w miejscu, w którym zostały pierwotnie zainstalowane.

Można naprawić indywidualną instalację. Nie można naprawić obrazu administracyjnego, Konieczne jest odinstalowanie, a następnie ponowne zainstalowanie obrazu administracyjnego.
  1. Otworzyć Panel sterowania systemu Windows i kliknąć Programy > Programy i funkcje.
  2. Kliknąć prawym przyciskiem myszy wersję SOLIDWORKS do naprawienia i kliknąć Zmień.
  3. Na ekranie Witamy w Menedżerze instalacji SOLIDWORKS kliknąć Napraw instalację, a następnie kliknąć Dalej.
  4. Na ekranie Produkty do naprawienia wybrać produkt do naprawienia.
  5. Usunąć zaznaczenia pozostałych produktów na ekranie.
  6. Kliknąć Napraw.
Temat nadrzędny Administracja indywidualnymi instalacjami
Temat nadrzędny Błędy instalacji / Anulowano instalację
Modyfikowanie instalacji
Przywracanie indywidualnej instalacji do poprzedniego pakietu Service Pack
Usuwanie instalacji
Uaktualnianie do nowej wersji
Zasady współistnienia produktów
Przywracanie normalnego stanu po nieudanej lub anulowanej instalacji
Kontaktowanie się z dystrybutorem SOLIDWORKS


Przywracanie indywidualnej instalacji do poprzedniego pakietu Service Pack

Aby przywrócić indywidualną instalację do poprzedniego pakietu Service Pack w bieżącej rodzinie wersji głównej, należy odinstalować aktualnie zainstalowaną w komputerze wersję Service Pack, a następnie zainstalować ponownie wcześniejszą wersję.
Temat nadrzędny Administracja indywidualnymi instalacjami
Modyfikowanie instalacji
Naprawianie instalacji
Usuwanie instalacji
Uaktualnianie do nowej wersji
Zasady współistnienia produktów


Usuwanie instalacji

Można usunąć instalację na indywidualnym komputerze lub w środowisku klient/serwer.

  1. Należy upewnić się, że nie są aktywne żadne sesje SOLIDWORKS.
  2. W celu przeniesienia licencji SOLIDWORKS do innego komputera należy ją dezaktywować przed usunięciem oprogramowania SOLIDWORKS z pierwotnego komputera.
    Więcej informacji zawiera temat Przenoszenie licencji.
  3. Otworzyć Panel sterowania systemu Windows i kliknąć Programy i Funkcje.
  4. Wybrać komponent produktu do usunięcia i kliknąć Odinstaluj.
    W niektórych przypadkach może występować wiele komponentów Service Pack SOLIDWORKS dla danej wersji głównej. Aby usunąć wersję główną SOLIDWORKS, należy usunąć wszystkie elementy Service Pack dla tej wersji głównej.
  5. Na ekranie Odinstaluj:
    1. Należy wybrać produkty do usunięcia.
      Domyślnie wybrane są wszystkie komponenty produktów.
    2. Usunąć zaznaczenie produktów, które nie mają być odinstalowywane.
    3. Kliknij Zaawansowane opcje w Zmień.
      Zostanie wyświetlony ekran Opcje zaawansowane i wybrana zostanie opcja Pliki i foldery programu.
    4. Wybrać jedną lub więcej opcji, aby przeprowadzić niestandardową dezinstalację, lub wybrać wszystkie opcje, aby przeprowadzić pełną dezinstalację.
      Domyślnie Menedżer instalacji SOLIDWORKS przeprowadza pełną dezinstalację i usuwa wszystkie pliki i foldery dodane podczas instalacji.
    5. Kliknąć Powrót do podsumowania.
    6. Na ekranie Podsumowanie rozwinąć Opcje zaawansowane, aby wyświetlić metodę dezinstalacji i wpisy.
    7. Kliknąć Usuń elementy.
Temat nadrzędny Administracja indywidualnymi instalacjami
Temat nadrzędny Administracja wieloma instalacjami
Modyfikowanie instalacji
Naprawianie instalacji
Przywracanie indywidualnej instalacji do poprzedniego pakietu Service Pack
Uaktualnianie do nowej wersji
Zasady współistnienia produktów
Uaktualnianie obrazów administracyjnych do nowej wersji
Zarządzanie aktualizacjami produktów Service Pack
Przenoszenie licencji


Uaktualnianie do nowej wersji

Istnieje kilka metod uaktualniania indywidualnej instalacji do nowej wersji SOLIDWORKS.

Można uaktualnić do nowej wersji, gdy:
  • Otrzymano nowy nośnik instalacyjny
  • Otrzymano powiadomienie o uaktualnieniach podczas uruchamiania SOLIDWORKS
  • Ręcznie sprawdzono, czy istnieją aktualizacje
  • Uruchomiono nowe wystąpienie Menedżera instalacji SOLIDWORKS

Podczas instalowania nowej wersji głównej można uaktualnić poprzednio zainstalowaną wersję główną lub równolegle zainstalować nową wersję. W przypadku instalowania wersji Service Pack dla poprzednio zainstalowanej wersji głównej, tamta wersja jest aktualizowana automatycznie.

Temat nadrzędny Administracja indywidualnymi instalacjami
Modyfikowanie instalacji
Naprawianie instalacji
Przywracanie indywidualnej instalacji do poprzedniego pakietu Service Pack
Usuwanie instalacji
Zasady współistnienia produktów

Ręczne sprawdzanie, czy istnieją aktualizacje

W przypadku posiadania uprawnienia administratora na urządzeniu można sprawdzić aktualizacje dla zainstalowanej wersji SOLIDWORKS za pomocą jednej z tych metod.

  • W SOLIDWORKS kliknąć [image] > Sprawdź, czy istnieją aktualizacje.
  • W systemie Windows kliknąć Start > Menedżer instalacji SOLIDWORKS > Sprawdź, czy istnieją aktualizacje.
Można również kliknąć Start > Menedżer instalacji SolidWorks > Pobieracz w tle SOLIDWOR KS. W obszarze powiadomień systemu Windows kliknąć prawym przyciskiem myszy pozycję Pobieracz w tle SOLIDWORKS i kliknąć Sprawdź dostępność aktualizacji.

Zastrzeżenia aktualizacji

Produkty, które mogą mieć wiele instalacji o różnych wersjach głównych nie zawsze obsługują główne uaktualnienia czy też możliwość uaktualnień pomiędzy głównymi wersjami w jednej operacji.

W takim przypadku, Menedżer instalacji SOLIDWORKS symuluje uaktualnienie poprzez najpierw zainstalowanie nowej wersji a następnie usunięcie starej. Obecnie główne produkty SOLIDWORKS obsługują główne uaktualnienia; pozostałe produkty nie.

Konsekwencje:
  • Podczas uaktualniania głównego produktu SOLIDWORKS pomiędzy głównymi wersjami:
    • Istniejące zainstalowane lokalizacje nie ulegną zmianie.
    • Uaktualnienie może być przywrócone do poprzedniej wersji, jeżeli w jego trakcie wystąpi błąd lub anulowanie.
  • Kiedy inne produkty są uaktualniane pomiędzy głównymi wersjami:
    • Każdy produkt jest najpierw instalowany jako nowy produkt do nowej lokalizacji a następnie usunięta jest oryginalna instalacja.
    • Po rozpoczęciu, uaktualnienie nie może być przywrócone do poprzedniej wersji jeżeli wystąpi błąd lub anulowanie podczas aktualizacji.


Zasady współistnienia produktów

Poniższe zasady współistnienia produktów określają jak nowe produkty są instalowane i istniejące produkty są uaktualniane.

Zasada | Przykłady
Dozwolona jest równoległa obecność wielu wersji głównego produktu SOLIDWORKS, z wyjątkiem produktów wymienionych poniżej. | SOLIDWORKS 2024 SP3.0 i SOLIDWORKS 2025 SP0.0 mogą współistnieć na jednym komputerze.
Równoległa obecność wielu dodatków Service Pack z tej samej wersji głównej nie jest dozwolona. | SOLIDWORKS 2025 SP0.0 i 2025 SP1.0 nie mogą współistnieć na jednym komputerze. W przypadku próby zainstalowania programu SOLIDWORKS 2025 SP1.0 na komputerze, gdzie jest już zainstalowany program SOLIDWORKS 2025 SP0.0 Menedżer instalacji SOLIDWORKS zastąpi dodatek SP0.0 dodatkiem SP1.0.
Tylko jedna wersja poniższych produktów jest dozwolona na danym komputerze:
  • SolidNetWork License Manager
 Jeśli zainstalowano SolidNetWork License Manager 2024 SP3.0, SolidNetWork License Manager zostanie uaktualniony do 2025 SP0.0, nawet jeśli wcześniejsza główna wersja SOLIDWORKS nadal istnieje na danym komputerze.
Tylko jedna wersja poniższego produktu jest dozwolona na danym komputerze:
  • SOLIDWORKS Electrical
 Jeśli tworzona jest nowa instalacja programu SOLIDWORKS Electrical 2025 SP1.0, Menedżer instalacji SOLIDWORKS automatycznie usunie z komputera wcześniejsze wersje oprogramowania SOLIDWORKS Electrical. Przed uaktualnieniem należy wykonać kopię zapasową środowiska SOLIDWORKS Electrical.
Tylko jedna wersja poniższych produktów jest dozwolona na danym komputerze:
  • Klient programu SOLIDWORKS PDM
  • Serwer programu SOLIDWORKS PDM

W przypadku zainstalowania programu SOLIDWORKS 2025 SP0.0 lub SP1.0 należy również uaktualnić serwer i klienta programu SOLIDWORKS PDM do wersji 2025.

W przypadku zainstalowania serwera SOLIDWORKS PDM 2025 należy skorzystać z procesu instalacji tego serwera, aby zainstalować klienta SOLIDWORKS PDM Client. Nie należy instalować klienta SOLIDWORKS PDM Client osobno za pomocą procesu instalacji klienta.

Klient programu SOLIDWORKS PDM musi być w tej samej wersji i z tym samym dodatkiem Service Pack co serwer programu SOLIDWORKS PDM na tym samym komputerze.

Patrz SOLIDWORKS PDM i SOLIDWORKS Manage, aby uzyskać więcej informacji.

Dla każdej wersji głównej programu SOLIDWORKS może być zainstalowana tylko jedna wersja zawartego produktu. Jednak wersje zawartych produktów z różnych wersji głównych programu SOLIDWORKS mogą współistnieć. | Jeśli oprogramowanie SOLIDWORKS 2025 SP0.0 zostanie uaktualnione do wersji 2025 SP1.0 oprogramowanie SOLIDWORKS Composer 2025 SP0.0, zostanie automatycznie uaktualnione do wersji 2025 SP1.0. Jednak oprogramowanie SOLIDWORKS Composer 2024 SP4.0 może współistnieć z oprogramowaniem SOLIDWORKS Composer 2025 SP0.0, lub SOLIDWORKS Composer 2025 SP1.0.
Temat nadrzędny Administracja indywidualnymi instalacjami
Modyfikowanie instalacji
Naprawianie instalacji
Przywracanie indywidualnej instalacji do poprzedniego pakietu Service Pack
Usuwanie instalacji
Uaktualnianie do nowej wersji


Instalacje na wielu klientach

Spis treści

  • Rozmieszczanie do wielu klientów

    Można instalować produkt SOLIDWORKS na wielu klientach poprzez utworzenie obrazu administracyjnego a następnie rozmieszczenie instalacji na klientach.

  • Używanie obrazów administracyjnych

    Obraz administracyjny pozwala na konfigurację instalacji produktów SOLIDWORKS z jednej lokalizacji sieciowej.

  • Wiersz polecenia - Rozmieszczanie

    Można automatycznie uruchomić obraz administracyjny przy użyciu wiersza polecenia lub pliku wsadowego (dyskretna instalacja).

  • Administracja wieloma instalacjami

    W przypadku wielu instalacji, zadania administracyjne obejmują uaktualnianie obrazów administracyjnych do nowych wersji, zastosowanie aktualizacji pakietów Service Pack oraz usuwanie instalacji.


Rozmieszczanie do wielu klientów

Można instalować produkt SOLIDWORKS na wielu klientach poprzez utworzenie obrazu administracyjnego a następnie rozmieszczenie instalacji na klientach.

Proces rozmieszczania do wielu klientów przebiega następująco:
  1. Tworzenie obrazu administracyjnego.
    • Tworzenie obrazu administracyjnego z Menedżera instalacji SOLIDWORKS
  2. Rozmieszczanie obrazu administracyjnego na klientach.
    • Rozmieszczanie obrazu administracyjnego na klientach za pośrednictwem metody ręcznej (poczty elektronicznej) / pull
    • Rozmieszczanie obrazy administracyjnego na klientach za pośrednictwem metody automatycznej / push
    • Instalowanie z obrazu administracyjnego przy użyciu wiersza polecenia
  3. Wdrażanie licencji.
    • Administrowanie indywidualnymi licencjami
    • Administrowanie licencjami przy użyciu programu SolidNetWork License Manager
Temat nadrzędny Instalacje na wielu klientach
Używanie obrazów administracyjnych
Wiersz polecenia - Rozmieszczanie
Administracja wieloma instalacjami


Używanie obrazów administracyjnych

Obraz administracyjny pozwala na konfigurację instalacji produktów SOLIDWORKS z jednej lokalizacji sieciowej.

Obraz administracyjny można zainstalować z dowolnego komputera w sieci, z komputerem klientem włącznie.
  • Obraz administracyjny musi znajdować się we współużytkowanym folderze.
  • Jeżeli uwzględnione są wszystkie produkty, ilość miejsca na dysku wymagana przez obraz administracyjny może wynosić 17 GB lub więcej.
  • Jeżeli podczas uaktualniania obrazu administracyjnego, uaktualniana jest nazwa udziału, klient jest uaktualniany automatycznie przy następnym uruchomieniu aplikacji. Szczegółowe informacje zawiera temat Uaktualnianie obrazu administracyjnego.
  • W przypadku wdrażania obrazu administracyjnego ścieżka do obrazu musi się składać z mniej niż 58 znaków.
  • Klienci muszą posiadać przywileje administracyjne na swoich komputerach Jeśli klient ma niewystarczające uprawnienia, może uruchomić instalację jako inny użytkownik. Przydaje się to, gdy indywidualny użytkownik nie ma lokalnych uprawnień administracyjnych na komputerze — a takie uprawnienia są potrzebne do zainstalowania produktów SOLIDWORKS.

    Patrz Rozmieszczanie instalacji z Edytora opcji. Znajduje się tam również opis alternatywnego sposobu instalowania obrazów, kiedy klient ma niewystarczające uprawnienia.

  • Jeśli jest włączone logowanie systemu Windows albo używana jest funkcja stanu w Edytorze opcji obrazu administracyjnego, konieczne są uprawnienia do odczytu/zapisu do folderu: {Administrative image directory}\x64\Logs.

Po utworzeniu obrazu administracyjnego, Edytor opcji obrazu administracyjnego może zarządzać ustawieniami opcji instalacji dla użytkowników i grup instalujących z tego obrazu. Szczegółowe informacje zawiera temat Edytor opcji obrazu administracyjnego.

Spis treści

  • Typy obrazów administracyjnych

    W Edytorze opcji obrazu administracyjnego można tworzyć różne typy obrazów dla użytkowników zdalnych oraz korzystających z lokalnej sieci.

  • Tworzenie obrazu administracyjnego z Menedżera instalacji SOLIDWORKS

    Jeżeli SOLIDWORKS instalowany jest na wielu komputerach, można utworzyć obraz administracyjny a następnie rozmieścić aplikację do innych komputerów.

  • Edytor opcji obrazu administracyjnego

    Edytor opcji obrazu administracyjnego pozwala na dostosowanie ustawień parametrów instalacji w obrazu administracyjnym dla komputerów indywidualnych oraz grup komputerów.

  • Narzędzie Administration Tool

Temat nadrzędny Instalacje na wielu klientach
Rozmieszczanie do wielu klientów
Wiersz polecenia - Rozmieszczanie
Administracja wieloma instalacjami
Uaktualnianie klientów z obrazów administracyjnych


Typy obrazów administracyjnych

W Edytorze opcji obrazu administracyjnego można tworzyć różne typy obrazów dla użytkowników zdalnych oraz korzystających z lokalnej sieci.

Typ obrazu administracyjnego Opis
Standard

Domyślny typ ustawiany przy tworzeniu wszystkich nowych obrazów administracyjnych.

Jest to standardowy obraz administracyjny instalatora systemu Windows, idealny dla użytkowników mogących się pewnie łączyć z firmową siecią. We wspólnym folderze obrazu zawiera wszystkie pliki niezbędne do zainstalowania wybranych produktów SOLIDWORKS.

Podczas uaktualniania do nowego dodatku Service Pack użytkownicy mogą pobrać i zainstalować pliki poprawek, bez konieczności pobierania całego obrazu.
Klient zdalny

Ten obraz jest przeznaczony dla zdalnych użytkowników pozbawionych możliwości niezawodnego dostępu do firmowej sieci.

Podczas instalowania tego rodzaju obrazu zdalni użytkownicy dziedziczą wszystkie opcje instalacji określone przez administratora, takie jak numer seryjny oraz wybór produktów do zainstalowania.

Użytkownicy pobierają wymagane pliki przez Internet ze strony Pliki do pobrania SOLIDWORKS. Przechodzenie do tych plików w Internecie i instalowanie ich z tego źródła jest bardziej niezawodne niż pobieranie ich z sieci firmowej oraz odciąża wewnętrzne sieci firmy.

Użytkownicy zdalni instalują ten obraz takimi samymi metodami, jak przy instalowaniu standardowego obrazu administracyjnego. Za pomocą narzędzi sldim.exe i startwinstall.exe można tworzyć skrypty instalacyjne.

Pliki instalacyjne są pobierane do ścieżki wskazanej w Edytorze opcji obrazu administracyjnego przez rozpoczęciem instalacji. Aby rozpocząć instalację, użytkownicy muszą przejść do folderu obrazu administracyjnego, a następnie uruchomić wszelkie umieszczone tam pliki wsadowe lub pliki ustawień.

Użytkownicy zdalni muszą mieć na swoich komputerach wystarczającą ilość miejsca na wszystkie pliki znajdujące się w obrazie, natomiast po zakończeniu instalacji mogą usunąć obraz.
Skompresowany

Skompresowany obraz administracyjny jest przeznaczony dla organizacji, które muszą skopiować obrazy administracyjne do wielu lokalizacji lub zdalnych komputerów klienckich, a chciałyby przy instalacji zminimalizować obciążenie sieci.

Ten obraz jest 60% mniejszy niż standardowy obraz administracyjny, ale instaluje się w takim samym czasie. Obsługuje wszystkie operacje towarzyszące instalacji, w tym modyfikowanie i naprawę.

Skompresowane obrazy administracyjne mają również krótkie ścieżki plików. Pomaga to uniknąć problemów, gdy obrazy są zapisywane głęboko w wielopoziomowej strukturze folderów.

Podczas uaktualniania do nowego dodatku Service Pack użytkownicy muszą pobrać cały obraz, nie tylko pliki poprawek.
Temat nadrzędny Używanie obrazów administracyjnych


Tworzenie obrazu administracyjnego z Menedżera instalacji SOLIDWORKS

Jeżeli SOLIDWORKS instalowany jest na wielu komputerach, można utworzyć obraz administracyjny a następnie rozmieścić aplikację do innych komputerów.

  1. Uruchom Menedżer instalacji SOLIDWORKS.

    Patrz Pobieranie nośników instalacyjnych.

  2. Na ekranie Witamy wybrać Aby zainstalować na wielu komputerach, utwórz obraz administracyjny i wybrać jedną z następujących opcji:
    Opcja | Opis
    Utwórz nowy obraz używając ustawień domyślnych. | Tworzy obraz przy użyciu domyślnych ustawień konfiguracji (tzn. nie w oparciu o ustawienia wprowadzone dla istniejącego obrazu administracyjnego w danym miejscu).
    Utwórz nowy obraz używając ustawień i plików z istniejącego obrazu. | Tworzy obraz używając ustawień konfiguracji określonych dla istniejącego obrazu administracyjnego w danym miejscu. Należy kliknąć Przeglądaj, aby określić katalog instalacyjny dla istniejącego obrazu administracyjnego.
  3. Wprowadzić numery seryjne SOLIDWORKS.
  4. Kliknąć Zmień, aby zmodyfikować produkty lub opcje domyślne, które obejmują następujące elementy:
    • Lokalizacja obrazu administracyjnego
    • Typ obrazu administracyjnego
  5. Zaakceptować umowę licencyjną i kliknąć Utwórz teraz.
  6. Kliknąć Dostosuj obraz, aby otworzyć i wyświetlić ustawienia w Edytorze opcji obrazu administracyjnego.
  7. Opcjonalne: Kliknąć Utwórz skrót na pulpicie, aby uzyskać dostęp do obrazu na pulpicie.
Temat nadrzędny Używanie obrazów administracyjnych


Edytor opcji obrazu administracyjnego

Edytor opcji obrazu administracyjnego pozwala na dostosowanie ustawień parametrów instalacji w obrazu administracyjnym dla komputerów indywidualnych oraz grup komputerów.

Po utworzeniu obrazu administracyjnego, Menedżer instalacji SOLIDWORKS pyta czy uruchomić Edytor opcji. Można również uruchomić Edytor opcji za pomocą dwukrotnego kliknięcia pliku sldAdminOptionEditor.exe w folderze obrazu administracyjnego.

Aby określić różne konfiguracje instalacji dla grup komputerów lub poszczególnych komputerów, w Edytorze opcji wybrać komputery. Następnie należy określić opcje instalacji dla tych komputerów.

Wszystkie okna dialogowe, w których są wyświetlane monity o ścieżkę pliku lub folderu, zawierają opcję mapowania wybranego folderu do zmiennej środowiskowej. Na przykład, jeżeli wybierzemy C:\Program Files\SOLIDWORKS Corp, ścieżka pliku zostanie zmapowana do %ProgramFiles%\SOLIDWORKS Corp. Najczęstszymi zmiennymi są %ProgramFiles% i %SystemDrive%.

Nie można mapować wszystkich ścieżek do zmiennych środowiskowych. Na przykład nie można mapować Z:\SOLIDWORKS Data do zmiennej środowiskowej.

Spis treści

  • Dodawanie i usuwanie grup i komputerów

    Edytor opcji obrazu administracyjnego pozwala na określenie różnych konfiguracji instalacji dla grup komputerów oraz dla indywidualnych komputerów.

  • Przeglądanie i edytowanie ustawień opcji

    Edytor opcji obrazu administracyjnego SOLIDWORKS pozwala na przeglądanie i zmienianie ustawień opcji dla grup i komputerów określonych dla danego obrazu.

  • Rozmieszczanie instalacji z Edytora opcji

    Instalacje bezpośrednio z Edytora opcji można rozmieścić metodą ręczną lub wymuszoną.

  • Wychodzenie z Edytora opcji

    Można kliknąć OK lub Zamknij, aby zastosować zmiany i wyjść z Edytora opcji.

  • Tworzenie na pulpicie skrótu do Edytora opcji

    Na pulpicie Windows można utworzyć skrót do Edytora opcji dla konkretnego obrazu administracyjnego z poziomu aplikacji.

  • Rozmieszczanie obrazy administracyjnego do klientów za pośrednictwem poczty elektronicznej

    Po utworzeniu i udostępnieniu katalogu obrazu administracyjnego, można powiadomić klientów za pomocą poczty elektronicznej.

Temat nadrzędny Używanie obrazów administracyjnych


Dodawanie i usuwanie grup i komputerów

Edytor opcji obrazu administracyjnego pozwala na określenie różnych konfiguracji instalacji dla grup komputerów oraz dla indywidualnych komputerów.

Można, na przykład, skonfigurować kilka komputerów do korzystania z podzbioru komponentów produktów dostępnych w obrazie, a inną grupę do korzystania z innego podzbioru komponentów. Pomimo korzystania z jednego obrazu administracyjnego, ustawienia grupy Edytora opcji pozwalają instalować różne podzbiory produktów w różnych grupach komputerów. Można przenosić ustawienia między grupami oraz edytować grupy komputerów.

Grupy komputerów można również podzielić na podgrupy. Podgrupy dziedziczą ustawienia z grupy nadrzędnej, ale można zmieniać poszczególne ustawienia dla każdej z podgrup.

Aby dodać grupę, należy:
  1. Kliknąć prawym przyciskiem myszy Ustawienia globalne, a następnie kliknąć Dodaj grupę.
  2. Wprowadzić nazwę grupy.

Aby dodać komputery, należy:
  1. Kliknąć prawym przyciskiem myszy istniejącą grupę lub Ustawienia globalne, a następnie kliknąć Dodaj komputer.
    W przypadku kliknięcia prawym przyciskiem myszy istniejącej grupy, komputery są dodawane do tej grupy. W przeciwnym razie są one dodawane na najwyższym poziomie.
  2. Wykonać jedną z następujących czynności:
    • Wybrać Wg nazwy komputera i wprowadzić nazwę komputera.
      Nazwa komputera nie może zawierać kwalifikatorów domeny. Na przykład pluto.solidworks.com jest nieprawidłową nazwą.
    • Wybrać Wg adresu IP i wprowadzić adres IP komputera.
    • Wybrać Wg zakresu adresów IP i wprowadzić początkowy adres IP oraz końcowy adres IP zakresu.
    • Kliknąć Dodaj wiele komputerów, aby wprowadzić nazwy komputerów. Nazwy komputerów można oddzielić, używając znaku podziału linii, spacji, tabulatora, przecinka, kropki, dwukropka lub średnika. Można również skopiować listę nazw komputerów z pliku rozdzielonego znakami, takiego jak *.xls or *.cvs i wkleić w oknie dialogowym.

    Jeśli zostaną dodane komputery według nazwy, adresu IP i zakresu adresów IP, komputer instalujący będzie szukał zgodności w następującej kolejności: Nazwa komputera, Adres IP, a następnie Zakres adresów IP. Opcje instalacji zostaną zastosowane do komputera instalacji na podstawie pierwszego znalezionego dopasowania.

Aby przenieść istniejący komputer do grupy lub podgrupy, należy:

Przeciągnąć komputer do grupy lub podgrupy.

Aby przenieść komputer z grupy lub podgrupy, należy:

Przeciągnąć komputer do grupy Ustawienia globalne lub do innej grupy bądź podgrupy.

Aby usunąć grupę, podgrupę lub komputer, należy:

Kliknąć prawym przyciskiem myszy grupę, podgrupę lub komputer, a następnie kliknąć Usuń grupę lub Usuń komputer.

Jeżeli grupa zostanie usunięta, wszystkie komputery w obrębie tej grupy zostaną usunięte.

Aby usunąć wszystkie grupy i komputery, należy:

Kliknąć prawym przyciskiem myszy Ustawienia globalne, a następnie kliknąć Usuń wszystkie.

Temat nadrzędny Edytor opcji obrazu administracyjnego
Przeglądanie i edytowanie ustawień opcji
Rozmieszczanie instalacji z Edytora opcji
Wychodzenie z Edytora opcji
Tworzenie na pulpicie skrótu do Edytora opcji
Rozmieszczanie obrazy administracyjnego do klientów za pośrednictwem poczty elektronicznej


Przeglądanie i edytowanie ustawień opcji

Edytor opcji obrazu administracyjnego SOLIDWORKS pozwala na przeglądanie i zmienianie ustawień opcji dla grup i komputerów określonych dla danego obrazu.

  • Przy pierwszym uruchomieniu Edytora opcji, ustawienia opcji są wyświetlane w trybie tylko do odczytu. Ikona Zmień [image] nie jest zacieniowana.

    Kliknięcie opcji Ustawienia globalne, grupy lub komputera wyświetla podsumowanie ustawień opcji dla tego elementu:

    Zakres | Wyświetlane ustawienia opcji
    Ustawienia globalne | Wszystkie ustawienia opcji określone dla danego obrazu administracyjnego
    Grupa | Zmiany w ustawieniach grupy w stosunku do ustawień globalnych
    Maszyna | Zmiany w ustawieniach komputera w stosunku do ustawień grupy
  • Aby wprowadzić zmiany w ustawieniach opcji, kliknąć Zmień [image]. Ikona zostanie zacieniowana i pojawi się bardziej szczegółowa lista ustawień opcji.

    Kliknięcie opcji Ustawienia globalne, grupy lub komputera pozwala zmieniać ustawienia opcji dla danego elementu. Po dokonaniu zmiany w ustawieniu opcji, które różni się od dziedziczonych ustawień globalnych lub ustawień grupy, to ustawienie opcji jest podświetlone.

    Ponowne kliknięcie ikony Zmień [image] powoduje przywrócenie wyświetlania w trybie tylko do odczytu.

    Jeśli dokonano zmian, Edytor opcji wyświetli monit o ich zapisanie lub porzucenie podczas wychodzenia.

Spis treści

  • Określanie ustawień opcji dla grup i komputerów

    Można określić ustawienia opcji dla wszystkich komputerów (ustawienia globalne), grup komputerów oraz komputerów indywidualnych.

  • Ustawienia opcji obrazu administracyjnego

    Edytor opcji umożliwia określenie ustawień opcji dla indywidualnych klientów lub grup, łącznie z numerem seryjnym, opcjami instalacji klienta, komponentami oprogramowania, które mają zostać zainstalowane, oraz lokalizacją Toolbox.

  • Dziedziczenie ustawień opcji grup i globalnych

    Ustawienia opcji dla Ustawień globalnych lub grup są dziedziczone przez elementy znajdujące się poniżej.

  • Dostosowanie ustawień dla poszczególnych komputerów

    Można również zmodyfikować ustawienia, które zostały zastosowane do określonych komputerów, klikając prawym przyciskiem myszy nazwę komputera.

Temat nadrzędny Edytor opcji obrazu administracyjnego
Dodawanie i usuwanie grup i komputerów
Rozmieszczanie instalacji z Edytora opcji
Wychodzenie z Edytora opcji
Tworzenie na pulpicie skrótu do Edytora opcji
Rozmieszczanie obrazy administracyjnego do klientów za pośrednictwem poczty elektronicznej


Określanie ustawień opcji dla grup i komputerów

Można określić ustawienia opcji dla wszystkich komputerów (ustawienia globalne), grup komputerów oraz komputerów indywidualnych.

  1. W edytorze opcji kliknąć obiekt do zmodyfikowania (Ustawienia globalne, grupę lub komputer).
  2. Po prawej stronie kliknąć przycisk Zmień [image].
    Ikona zostanie zacieniowana i pojawi się bardziej szczegółowa lista ustawień opcji.
  3. Dokonać zmian ustawień opcji klikając ustawienia opcji po prawej stronie dla elementu wybranego po lewej.
    Zmiany ustawień opcji, które zastępują Ustawienia globalne lub ustawienia grupy są podświetlone.
  4. Kliknąć OK lub Zamknij, aby zapisać zmiany.
    Opcja | Opis
    OK | Edytor opcji zapisze zmiany i zostanie zamknięty.
    Zamknij | Edytor opcji zapyta, czy należy zapisać zmiany, a następnie zostanie zamknięty.
Temat nadrzędny Przeglądanie i edytowanie ustawień opcji
Ustawienia opcji obrazu administracyjnego
Dziedziczenie ustawień opcji grup i globalnych
Dostosowanie ustawień dla poszczególnych komputerów


Ustawienia opcji obrazu administracyjnego

Edytor opcji umożliwia określenie ustawień opcji dla indywidualnych klientów lub grup, łącznie z numerem seryjnym, opcjami instalacji klienta, komponentami oprogramowania, które mają zostać zainstalowane, oraz lokalizacją Toolbox.

Numery seryjne

Należy wprowadzić numery seryjne, aby zainstalować produkty na komputerach klienckich.
Ponieważ istnieje wiele metod zakupu produktów SOLIDWORKS, niektóre numery seryjne mogą obejmować dwa lub więcej produktów. Na przykład numer seryjny SOLIDWORKS może umożliwić instalację SOLIDWORKS Simulation bez wprowadzania numeru seryjnego SOLIDWORKS Simulation. Dodatkowo niektóre produkty, nie wymagają numeru seryjnego. W razie pojawienia się jakichkolwiek pytań dotyczących numerów seryjnych należy się skontaktować z dystrybutorem VAR.
W przypadku zarządzania licencjami przy użyciu licencji SolidNetWork, należy:
  • W pierwszym polu numeru seryjnego wprowadzić numer seryjny SolidNetWork.
  • W polu Port serwera SNL@serwer wprowadzić nazwę serwera menedżera licencji SolidNetWork License Manager i portu w formacie nnnnn@nazwaserwera. Wiele wpisów należy oddzielić za pomocą średników.

Szczegóły dotyczące licencji SolidNetWork zawiera temat Informacje ogólne o instalowaniu licencji SolidNetWork.

Opcje instalacji klienta

Jak chcesz przeprowadzić instalacje klientów wersji głównych? Można określić sposób, w jaki instalacje klienta postępują z istniejącą instalacją poprzedniej wersji głównej:
  • Uaktualnij istniejącą wersję główną (jeżeli takowa istnieje).

    Opcję tę należy określić, aby zastąpić poprzednią instalację wersji głównej instalacją nowej wersji.

  • Utwórz nową wersję główną.

    Opcję tę należy określić, aby zachować poprzednią instalację wersji głównej i utworzyć nową instalację dla nowej wersji głównej. Aby określić lokalizację dla instalacji nowej wersji, należy kliknąć Przeglądaj.
Czy chcesz odinstalować najnowszą poprzednią wersję przed zainstalowaniem nowej wersji głównej? Można wybrać, czy poprzednia wersja główna ma zostać odinstalowana:
  • Nie odinstalowywuj.

    Należy wybrać tę opcję w celu zachowania instalacji poprzedniej głównej wersji.

  • Odinstaluj najnowszą wersję.
  • Odinstaluj wszystkie wersje.
Jak zastosować ustawienia SOLIDWORKS? Przy uruchamianiu oprogramowania można wskazać plik ustawień. Instalacje klienckie odnoszą się do pliku ustawień. Plik ustawień (*.sldsettings) należy przechowywać we współużytkowanej ścieżce UNC, która jest widoczna dla wszystkich instalacji. Określić ścieżkę pliku *.sldsettings przed zainstalowaniem SOLIDWORKS. Instalacje klienta wykrywają ścieżkę pliku *.sldsettings podczas instalacji.
Zabezpieczyć plik *.sldsettings poprzez ustawienie uprawnień Windows do pliku, aby umożliwić dostęp do zapisu tylko wskazanym użytkownikom.

Aby utworzyć plik *.sldsettings lub przeprowadzić jego edycję, kliknąć Uruchom narzędzie Settings Administrator. Narzędzie SOLIDWORKS Settings Administrator pozwala zdefiniować, które opcje systemowe SOLIDWORKS mają zostać zastosowane, a które (opcjonalnie) zablokowane dla użytkowników końcowych. Można również zdefiniować sposób i okoliczności, w których ustawienia będą stosowane do poszczególnych instalacji, a także zmodyfikować plik *.sldsettings w dowolnym momencie poprzez uruchomienie narzędzia Settings Administrator i zastąpienie istniejącego pliku.

Można użyć różnych plików *.sldsettings dla poszczególnych komputerów lub grup.

Ścieżka pliku *.sldsettings jest określana w czasie instalacji. Po instalacji i rozmieszczeniu nie należy przenosić pliku *.sldsettings ani zmieniać jego nazwy.

Do uruchomienia narzędzia Settings Administrator jest potrzebna istniejąca instalacja SOLIDWORKS [aktualna wersja główna].
Jak chcesz aktywować instalacje klienta? Można określić, czy należy automatycznie przeprowadzić aktywację produktu po uruchomieniu instalacji, czy też wymagać aby użytkownik przeprowadził aktywację produktu ręcznie po instalacji.
  • Aktywuj automatycznie po zakończeniu instalacji każdego klienta.

    Wybranie ustawienia tej opcji wskazuje, że aktywacja produktu ma być przeprowadzana automatycznie. Wprowadzić adres e-mail, który zostanie podany podczas przeprowadzania konfiguracji na komputerze klienta.

  • Nie aktywuj automatycznie.

    Wybranie tego ustawienia opcji określa że nie następuje automatyczna aktywacja produktu. Użytkownik klient przeprowadza aktywację produktu po instalacji.

Opcje administracyjne

Utwórz dziennik diagnostyki podczas każdej instalacji. | Instalacja klienta może utworzyć dziennik diagnostyki, aby ułatwić rozwiązanie problemów z instalacją. Tworzenie tego dziennika może spowolnić instalację klienta. Plik dziennika jest zapisany w pliku Katalog obrazu administracyjnego}\x64\Logs\<nazwa_komputera>.
Uruchom instalację jako inny użytkownik.

Można określić innego użytkownika z uprawnieniami administracyjnymi, aby uruchomić instalację zamiast zalogowanego użytkownika. To przydatne, gdy indywidualni użytkownicy nie mają lokalnych uprawnień administracyjnych na swoich komputerach — a takie uprawnienia są potrzebne do zainstalowania produktów SOLIDWORKS.

Gdy klienci nie mają uprawnień administracyjnych, dostępna jest alternatywna metoda wdrażania i instalacji. Patrz Rozmieszczanie instalacji z Edytora opcji.
Uruchom program przed instalacją lub po niej. | Można określić, że przed instalacją klienta lub po jego instalacji ma zostać uruchomiony niestandardowy program.
Czy chcesz aby klienci uczestniczyli w Programie doświadczeń klientów SOLIDWORKS? | Można określić, że komputery klienta będą uczestniczyć w Programie doświadczeń klientów SOLIDWORKS. Informacje o wydajności są wysyłane do SOLIDWORKS Corporation celem pomocy w opracowywaniu ulepszeń produktu. Proces ten jest transparentny i poufny. Aby uzyskać szczegółowe informacje, patrz strona internetowa Programu udoskonalenia doświadczeń klientów.

Ograniczenia dotyczące opcji Uruchom program przed lub po instalacji

Opcje te pozwalają na uruchamianie innych programów lub skryptów instalacyjnych na komputerach klienckich przed lub po zainstalowaniu SOLIDWORKS — na przykład skryptu, który instaluje pakiet Microsoft Office.

Istnieje ograniczenie dotyczące korzystania z tych opcji. Błąd występuje, gdy używamy którejkolwiek z opcji do rozmieszczenia programu instalacyjnego lub skryptu wyświetlającego interfejs użytkownika, na przykład skryptu, który wyświetla okna dialogowe. Po uruchomieniu automatycznego wdrażania SOLIDWORKS nie uda się zainstalować SOLIDWORKS na komputerach docelowych.

Aby użyć opcji Uruchom program przed instalacją i Uruchom program po instalacji, należy wybrać wyłącznie programy, które można zainstalować w trybie cichym.

Oprogramowanie do zainstalowania

Można określić jakie komponenty produktu SOLIDWORKS należy zainstalować.
  • Zaznaczenie pola wyboru obok komponentu produktu oznacza, że komponent ten jest instalowany podczas instalacji klienta.
  • W przypadku usunięcia zaznaczenia komponent nie jest instalowany.
  • Jeżeli komponent zawiera opcjonalne podkomponenty, obok niego jest wyświetlana ikona +. Aby zobaczyć dostępne podkomponenty w danym komponencie, należy kliknąć ikonę +.
  • Jeżeli komponent został rozwinięty, aby pokazać opcjonalne podkomponenty, obok niego jest wyświetlana ikona -. Aby zwinąć listę podkomponentów, należy kliknąć ikonę -.
Ustawienie Języki ogranicza języki, które są instalowane tylko dla produktu SOLIDWORKS. Specyfikacja ta nie ma wpływu na instalacje innych produktów. Na przykład eDrawings® instaluje wszystkie języki.

Opcje Toolbox

Można określić standardy, które mają być obsługiwane, a także domyślną lokalizację Toolbox dla instalacji klienckich.

Zwykle wielu użytkowników ma dostęp do współużytkowanej biblioteki Toolbox, typowo za pośrednictwem lokalizacji sieciowej (na przykład: ścieżka UNC, folder udostępniony lub określenie wspólnego dysku sieciowego).

Jeżeli dana lokalizacja zawiera starszą wersję główną biblioteki Toolbox, instalacja klienta uaktualnia tę bibliotekę Toolbox do nowej wersji głównej. Pliki nie będą już kompatybilne z poprzednimi wersjami głównymi SOLIDWORKS.
Jeżeli na niektórych komputerach klienckich jest nadal używana starsza wersja SOLIDWORKS, konieczne jest określenie innej lokalizacji sieciowej biblioteki Toolbox dla komputerów klienckich uaktualnianych do nowszej wersji.

Szczegółowe informacje dotyczące administrowania biblioteką SOLIDWORKS Toolbox zawiera temat Toolbox w Pomocy SOLIDWORKS.

Instalowanie oprogramowania Toolbox bez danych Toolbox

Jeżeli w środowisku istnieje lokalizacja PDM lub wspólna lokalizacja Toolbox/Kreatora otworów, można tak skonfigurować instalacje klienta, aby dane Toolbox nie były instalowane ani aktualizowane w tej lokalizacji.

Należy to zrobić w następujących przypadkach:
  • Nie określono widoku lokalnego SOLIDWORKS PDM przed zainstalowaniem SOLIDWORKS.
  • Pliki w danej lokalizacji są w użyciu i mogą uniemożliwić ukończenie instalacji oprogramowania SOLIDWORKS.
  • Lokalizacja jest niedostępna i może uniemożliwiać ukończenie instalacji oprogramowania SOLIDWORKS.

Kiedy instalacje klienta są skonfigurowane tak, aby nie instalować danych Toolbox, SOLIDWORKS i ustawienia wskazują lokalizację Toolbox/Kreatora otworów, ale należy w późniejszym czasie zainstalować dane w lokalizacji centralnej.

Aby zainstalować oprogramowanie SOLIDWORKS bez uwzględniania danych Toolbox/Kreatora otworów:
  • Kiedy pojawi się pytanie, czy klient ma zainstalować/uaktualnić pliki Toolbox, wybierz Nie, zainstaluj oprogramowanie Toolbox bez uwzględniania plików danych.

Co najmniej jedna osoba, zwykle administrator CAD, musi zainstalować lub uaktualnić dane Toolbox/Kreatora otworów w lokalizacji centralnej, ponieważ w przeciwnym razie oprogramowanie nie będzie działać prawidłowo. Każda osoba w organizacji może wykonać to zadanie przy pojedynczej ręcznej instalacji oprogramowania SOLIDWORKS. W przypadku zarządzania programem Toolbox w środowisku SOLIDWORKS PDM należy postępować zgodnie z instrukcjami opisanymi w części Toolbox Podręcznika administratora SOLIDWORKS PDM, aby zainstalować lub uaktualnić dane Toolbox.

Opcje klienta programu SOLIDWORKS PDM

Można wybrać następujące opcje wdrażania klientów i dodatków programu SOLIDWORKS PDM:

  • Typ produktu PDM
  • Typ klienta PDM
  • Operacje
  • Widok przechowalni

    Aby otworzyć Kreatora konfiguracji widoku, należy uruchomić Edytor opcji obrazu administracyjnego na komputerze z zainstalowanym klientem SOLIDWORKS PDM.

    Aby utworzyć widok przechowalni na komputerze klienckim, potrzebny jest plik konfiguracji widoku Conisio (.cvs), który określa parametry konfigurowania widoku przechowalni na komputerze klienckim. Można użyć odniesienia do istniejącego pliku .cvs lub utworzyć ten plik w Edytorze opcji obrazu administracyjnego.

Patrz część dotycząca programu SOLIDWORKS PDM w obszarze Pomoc SOLIDWORKS, aby uzyskać więcej informacji na temat tych klientów i dodatków.

Opcje programu Electrical

Można określić poniższe parametry dla komponentów administracyjnych SOLIDWORKS Electrical:
  • Ścieżka danych
  • Nazwa i numer portu komputera, na którym jest zainstalowany Collaborative Server
  • Nazwa i hasło komputera, na którym jest zainstalowany program SQL Server

Patrz SOLIDWORKS Electrical , aby uzyskać więcej informacji na temat tych komponentów.

Temat nadrzędny Przeglądanie i edytowanie ustawień opcji
Określanie ustawień opcji dla grup i komputerów
Dziedziczenie ustawień opcji grup i globalnych
Dostosowanie ustawień dla poszczególnych komputerów
Informacje ogólne o instalowaniu licencji SolidNetWork
Rozmieszczanie instalacji z Edytora opcji
SOLIDWORKS Electrical


Dziedziczenie ustawień opcji grup i globalnych

Ustawienia opcji dla Ustawień globalnych lub grup są dziedziczone przez elementy znajdujące się poniżej.

Na przykład:
  • Ustawienia zdefiniowane jako Ustawienia globalne są dziedziczone przez wszystkie grupy i komputery.
  • Ustawienia zdefiniowane dla grupy są dziedziczone przez wszystkie podgrupy i komputery w obrębie tej grupy.

Można zmienić ustawienia opcji dla grupy, podgrupy lub komputera, aby zastąpić ustawienia domyślne lub odziedziczone. Kiedy zmienione zostaną ustawienia opcji z wartości domyślnej lub odziedziczonej, opcja ta jest podświetlona.

Aby przywrócić pierwotne wartości dziedziczone ustawień opcji, kliknąć prawym przyciskiem myszy grupę, podgrupę lub komputer, a następnie kliknąć jedną z następujących opcji:
  • Przywróć do ustawień globalnych (dla grupy, podgrupy lub komputera, który nie jest członkiem grupy)
  • Przywróć do ustawień grupy (dla komputera będącego członkiem grupy)
  • Przywróć wszystkich członków do ustawień grupy (dla wszystkich członków tej grupy jednocześnie)
Temat nadrzędny Przeglądanie i edytowanie ustawień opcji
Określanie ustawień opcji dla grup i komputerów
Ustawienia opcji obrazu administracyjnego
Dostosowanie ustawień dla poszczególnych komputerów


Dostosowanie ustawień dla poszczególnych komputerów

Można również zmodyfikować ustawienia, które zostały zastosowane do określonych komputerów, klikając prawym przyciskiem myszy nazwę komputera.

W menu podręcznym są dostępne następujące polecenia, których można użyć dla każdego komputera:
  • Zmień nazwę
  • Usuń komputer
  • Przywróć do ustawień globalnych
  • Edytuj notatki
  • Opcje edycji

Opcje edycji umożliwiają modyfikowanie wszystkich opcji dla komputera, takich jak opcje instalacji klienta oraz opcje administracyjne.

Temat nadrzędny Przeglądanie i edytowanie ustawień opcji
Określanie ustawień opcji dla grup i komputerów
Ustawienia opcji obrazu administracyjnego
Dziedziczenie ustawień opcji grup i globalnych


Rozmieszczanie instalacji z Edytora opcji

Instalacje bezpośrednio z Edytora opcji można rozmieścić metodą ręczną lub wymuszoną.

  • Strona Rozmieszczanie ręczne Edytora opcji umożliwia wysłanie do użytkowników wiadomości e-mail zawierających instrukcje dotyczące rozpoczęcia instalacji. Tej metody należy użyć, gdy użytkownicy mają uprawnienia administracyjne na komputerach klienckich.
    W części Opcje administracyjnemożna przypisać użytkownikom uprawnienia administracyjne, wybierając Uruchom instalację jako inny użytkownik.
  • Strona Rozmieszczanie automatyczne Edytora opcji umożliwia wymuszenie automatycznej instalacji na komputerach docelowych. Nie jest konieczne posiadanie przez użytkowników uprawnień administracyjnych do instalowania oprogramowania na swoich komputerach. Przy użyciu tej metody można również przeprowadzić instalację niestandardową.

W celu uruchomienia ręcznego lub automatycznego należy zapisać katalog instalacyjny obrazu administracyjnego we współużytkowanym katalogu Windows, aby był dostępny z lokalizacji sieciowej, na przykład \\machine\shared_directory. Obraz można również udostępnić, kopiując go do katalogu lokalnego na każdym komputerze, na przykład C:\SOLIDWORKS Admin\SOLIDWORKS 2025 SP0.

Spis treści

  • Używanie ścieżki UNC do rozmieszczenia obrazu administracyjnego

    Zamiast mapowania lokalizacji dysku sieciowego należy użyć ścieżki UNC (\\machine_name\share_name) podczas określania lokalizacji sieciowej dla katalogu instalacyjnego obrazu administracyjnego.

  • Używanie programu StartSWInstall.exe do rozmieszczenia obrazu administracyjnego

  • Ręczne uruchamianie

    Tej metody można użyć, jeśli użytkownicy mają uprawnienia wymagane do przeprowadzania instalacji na swoich komputerach.

  • Wymagania wstępne do automatycznego rozmieszania

    Automatyczne wdrażanie jest skuteczne dla użytkowników bez uprawnień administracyjnych, ponieważ zapewnia bezproblemową instalację oprogramowania.

  • Instalacja automatyczna

  • Testowanie konfiguracji wdrożenia typu push

    Karta Rozmieść automatycznie w Edytorze opcji obrazu administracyjnego zawiera funkcję testowania.

Temat nadrzędny Edytor opcji obrazu administracyjnego
Dodawanie i usuwanie grup i komputerów
Przeglądanie i edytowanie ustawień opcji
Wychodzenie z Edytora opcji
Tworzenie na pulpicie skrótu do Edytora opcji
Rozmieszczanie obrazy administracyjnego do klientów za pośrednictwem poczty elektronicznej


Używanie ścieżki UNC do rozmieszczenia obrazu administracyjnego

Zamiast mapowania lokalizacji dysku sieciowego należy użyć ścieżki UNC (\\machine_name\share_name) podczas określania lokalizacji sieciowej dla katalogu instalacyjnego obrazu administracyjnego.

Zmapowane dyski sieciowe nie są zgodne z metodą „push” i „Automatic install”, a także z metodą „Run as different User” w trybie „pull” i „Manual”.

Temat nadrzędny Rozmieszczanie instalacji z Edytora opcji


Używanie programu StartSWInstall.exe do rozmieszczenia obrazu administracyjnego

Można zainstalować lub odinstalować obraz administracyjny na klientach poprzez uruchomienie polecenia katalog_instalacyjny_obrazu_administracyjnego\ StartSWInstall.exe. Metoda ta zainstaluje SOLIDWORKS przy użyciu opcji, komputerów i grup zdefiniowanych w Edytorze opcji obrazu administracyjnego.

Do polecenia StartSWInstall.exe można dołączyć następujące przełączniki:
Przełącz | Opis
/install | Instaluje obraz administracyjny na komputerach klientach.
/uninstall Odinstalowuje program z komputerów klientów, z dwoma opcjonalnymi przełącznikami:

/removedata

Dostępny tylko podczas odinstalowywania. Usuwa pliki i foldery danych SOLIDWORKS podczas odinstalowywania.

/removeregistry

Dostępny tylko podczas odinstalowywania. Usuwa wpisy rejestru SOLIDWORKS podczas odinstalowywania.
/showui | Wyświetla okno z paskiem postępu dla Menedżera instalacji SOLIDWORKS. W przeciwnym razie Menedżer instalacji SOLIDWORKS jest ukryty przed użytkownikiem.
/now | Rozpoczyna natychmiast instalowanie lub odinstalowywanie. Nie pojawia się na 5 minut okno dialogowe z ostrzeżeniem.

W przypadku, gdy planuje się przeprowadzenie instalacji bez ingerencji użytkownika, ale nie zamierza się używać automatycznego rozmieszczania z Edytora opcji obrazu administracyjnego, zaleca się wybranie StartSWInstall.exe zamiast StartSWInstall.hta.

Temat nadrzędny Rozmieszczanie instalacji z Edytora opcji


Ręczne uruchamianie

Tej metody można użyć, jeśli użytkownicy mają uprawnienia wymagane do przeprowadzania instalacji na swoich komputerach.

Aby uruchomić instalację ręcznie przy użyciu wiadomości e-mail:

  1. Kliknąć Rozmieść w Edytorze opcji.
    Pojawi się stan i dostępność instalacji dla każdego komputera.
  2. Kliknąć Wyślij email.
  3. Określić ścieżkę sieciową do katalogu instalacyjnego obrazu administracyjnego.
    Zwykle ścieżka dostępu do katalogu instalacyjnego obrazu administracyjnego jest początkowo ukazana jako ścieżka pliku Windows (na przykład: C:\SOLIDWORKS Admin\SOLIDWORKS 2025 SP0). Okno dialogowe poinformuje Ścieżka ta nie jest ścieżką sieciową.
    1. Kliknąć Przeglądaj, aby określić lokalizację sieciową dla tego katalogu instalacyjnego obrazu administracyjnego.
    2. Przejść do komputera, gdzie zainstalowany jest obraz administracyjny i wybrać udostępniony katalog Windows, określony dla katalogu instalacyjnego obrazu administracyjnego.
      Nie należy nawigować wewnątrz udostępnionego katalogu obrazu administracyjnego (na przykład do podkatalogów 64bit).
    3. Kliknąć OK.
      Okno dialogowe poinformuje Ścieżka ta jest ścieżką sieciową.
    Zostanie utworzona wiadomość email zawierająca instrukcje dla właściciela komputera odnośnie sposobu zainstalowania obrazu administracyjnego przy użyciu lokalizacji sieciowej dla pliku StartSWInstall.hta w obrazie administracyjnym.
  4. Wysłać wiadomość email do użytkowników odpowiedzialnych za instalowanie SOLIDWORKS.

Użytkownicy mogą kliknąć dwukrotnie w wiadomości e-mail łącze do lokalizacji sieciowej dla pliku StartSWInstall.hta, aby zainstalować SOLIDWORKS z obrazu administracyjnego.

W Edytorze opcji Stan instalacji pokazuje:
Oczekujące | Użytkownik nie przeprowadził jeszcze instalacji na tym komputerze.
Powodzenie | Użytkownik zakończył z powodzeniem instalację na tym komputerze.
Niepowodzenie | Użytkownik uruchomił instalację na tym komputerze, lecz nie została ona zakończona z powodzeniem.
Inne komunikaty o stanie, które mogą zostać wyświetlone: Zainstalowano pomyślnie, Odinstalowano pomyślnie, Instalowanie, Odinstalowywanie, Wymaga ponownego uruchomienia, Instalacja nie powiodła się i Odinstalowanie nie powiodło się.
W górnej części kolumny Status kliknąć zieloną strzałkę, aby odświeżyć i wyświetlić zaktualizowane informacje.
Temat nadrzędny Rozmieszczanie instalacji z Edytora opcji


Wymagania wstępne do automatycznego rozmieszania

Automatyczne wdrażanie jest skuteczne dla użytkowników bez uprawnień administracyjnych, ponieważ zapewnia bezproblemową instalację oprogramowania.

Aby korzystać z automatycznego wdrażania, zarówno klient, jak i serwer muszą należeć do tej samej domeny usługi Active Directory. Ta konfiguracja umożliwia przesyłanie zadań instalacyjnych do komputerów docelowych, gdzie są one wykonywane przez Harmonogram zadań firmy Microsoft bez konieczności podejmowania jakichkolwiek czynności przez użytkownika.

W przypadku instalacji typu push Harmonogram zadań uruchamia zadanie, które uruchamia Menedżera instalacji SOLIDWORKS na komputerze klienckim przy użyciu danych logowania określonych przez administratora w Edytorze opcji. Harmonogram zadań działa na koncie SystemLokalny w komputerze. To konto jest reprezentowane w sieci jako komputer z zasadami zabezpieczenia. Reguła zabezpieczeń komputera musi zapewniać następujący dostęp:
  • Dostęp do odczytu w folderze obrazów administracyjnych.
  • Dostęp do odczytu i zapisu w folderze obrazów administracyjnych\x64\logi.

W Active Directory podczas dodawania komputera do grupy Folder udostępniony wybrać Typy obiektów i Komputery.

Ponadto komputer obsługujący obraz administracyjny oraz docelowe komputery klienckie muszą należeć do tej samej domeny Active Directory.

Temat nadrzędny Rozmieszczanie instalacji z Edytora opcji


Instalacja automatyczna

Aby automatycznie uruchamiać wymuszanie instalacji na komputerach użytkowników, należy:

  1. W Edytorze opcji kliknąć kartę Uruchom automatycznie.
    Pojawi się stan i dostępność instalacji dla każdego komputera.
  2. W kolumnie Rozmieszczanie wybrać docelowe komputery klienckie i grupy w kolumnie Rozmieszczanie.
    Przed rozpoczęciem procesu instalacji automatycznej należy wybrać co najmniej jeden komputer lub jedną grupę w obszarze kolumny Rozmieszczanie.
  3. W obszarze Czas instalacji wybrać Teraz, aby uruchomić instalację natychmiast, lub Później, aby zaplanować rozpoczęcie instalacji o określonej porze.
  4. W obszarze Opcje klienta wybrać właściwą z poniższych opcji:
    • Zainstaluj lub uaktualnij do SOLIDWORKS 2025
    • Odinstaluj SOLIDWORKS 2025
      Jeśli wybrano opcję odinstalowania, można określić, czy mają zostać usunięte także wpisy rejestru i pliki danych oraz foldery, wraz z plikami programu i folderami.
  5. Aby podczas rozmieszczenia lub po nim co najmniej jeden komputer docelowy uruchomił się ponownie, należy wybrać Automatyczne ponowne uruchomienie komputera.
  6. Wprowadzić Poświadczenia klienta co najmniej jednej maszyny docelowej.
  7. Kliknąć Rozmieść, aby rozpocząć proces instalacji automatycznej.
W Edytorze opcji, Stan instalacji zostanie wyświetlony jako:
Oczekujące | Instalacja nie została jeszcze uruchomiona na tym komputerze.
Powodzenie | Instalacja została zakończona pomyślnie na tym komputerze.
Niepowodzenie | Instalacja nie powiodła się na tym komputerze.

Inne komunikaty o stanie, które mogą zostać wyświetlone: Zainstalowano pomyślnie, Odinstalowano pomyślnie, Planowanie, Łączenie, Instalowanie, Odinstalowywanie, Wymaga ponownego uruchomienia, Zaplanowano instalację, Zaplanowano odinstalowanie, Instalacja nie powiodła się, Odinstalowanie nie powiodło się, Nie nawiązano połączenia i Planowanie nie powiodło się.

Temat nadrzędny Rozmieszczanie instalacji z Edytora opcji


Testowanie konfiguracji wdrożenia typu push

Karta Rozmieść automatycznie w Edytorze opcji obrazu administracyjnego zawiera funkcję testowania.

Można uruchomić instalację pozorną, która sprawdza działanie systemów używanych do wdrożenia, na przykład:
  • Łączenie z komputerem docelowym
  • Tworzenie zadania instalacji na danym komputerze
  • Kończenie zadania instalacji na danym komputerze
  • Aktualizacja stanu i dzienników w obrazie administracyjnym
  • Wykrywanie programu do uruchomienia przed instalacją lub po niej

Test sprawdza ścieżki plików, weryfikuje uprawnienia i zgłasza, że instalacja zakończyła się pomyślnie. Nie instaluje żadnego oprogramowania ani nie modyfikuje rejestru w systemie docelowym. Jeżeli system nie działa na którymkolwiek z komputerów docelowych, test wskazuje, który system uległ awarii.

Etykietki narzędzi dostarczają więcej informacji na temat błędów. Wyniki można wyeksportować do arkusza kalkulacyjnego w formacie .xml lub .csv, co ułatwi przeglądanie wielu błędów lub udostępnienie wyników innym pracownikom pomocy technicznej.

Aby przetestować konfigurację wdrożenia typu push:

  1. Używając Menedżera instalacji, utwórz obraz administracyjny.
  2. Uruchom Edytora opcji obrazu administracyjnego.

    Można uruchomić opcję po zakończeniu tworzenia obrazu administracyjnego przez Menedżera instalacji lub kliknąć dwukrotnie plik sldAdminOptionEditor.exe w folderze obrazu administracyjnego.

  3. Na karcie Konfiguracja dodaj co najmniej jeden komputer.
  4. Kliknij Rozmieść automatycznie:
    1. Podaj nazwę użytkownika i hasło administratora domeny.
    2. Wybierz co najmniej jeden komputer do przetestowania.
    3. Kliknij Test.
  5. Po wyświetleniu ekranu testu konfiguracji kliknij przycisk Uruchom test.
  6. Poczekaj kilka minut na zakończenie testu lub kliknij przycisk Anuluj test w dowolnym momencie.
  7. Przejrzyj i rozwiąż problemy z instalacją.
Temat nadrzędny Rozmieszczanie instalacji z Edytora opcji


Wychodzenie z Edytora opcji

Można kliknąć OK lub Zamknij, aby zastosować zmiany i wyjść z Edytora opcji.

  • Kliknąć OK, aby zastosować zmiany opcji i wyjść z Edytora opcji.
  • Kliknąć przycisk Zamknij aplikacji systemu Windows, aby zamknąć Edytor opcji. Jeśli oprogramowanie wykryje niezapisane zmiany, wyświetli monit o zapisanie.
Temat nadrzędny Edytor opcji obrazu administracyjnego
Dodawanie i usuwanie grup i komputerów
Przeglądanie i edytowanie ustawień opcji
Rozmieszczanie instalacji z Edytora opcji
Tworzenie na pulpicie skrótu do Edytora opcji
Rozmieszczanie obrazy administracyjnego do klientów za pośrednictwem poczty elektronicznej


Tworzenie na pulpicie skrótu do Edytora opcji

Na pulpicie Windows można utworzyć skrót do Edytora opcji dla konkretnego obrazu administracyjnego z poziomu aplikacji.

  1. Uruchomić Edytor opcji.
    Na przykład: w Eksploratorze plików przejść do katalogu instalacyjnego obrazu administracyjnego i kliknąć dwukrotnie plik sldAdminOptionEditor.exe.
  2. Kliknąć Utwórz na pulpicie skrót do tego Edytora opcji.
    Na pulpicie Windows pojawi się skrót do Edytora opcji dla obrazu administracyjnego.
Temat nadrzędny Edytor opcji obrazu administracyjnego
Dodawanie i usuwanie grup i komputerów
Przeglądanie i edytowanie ustawień opcji
Rozmieszczanie instalacji z Edytora opcji
Wychodzenie z Edytora opcji
Rozmieszczanie obrazy administracyjnego do klientów za pośrednictwem poczty elektronicznej


Rozmieszczanie obrazy administracyjnego do klientów za pośrednictwem poczty elektronicznej

Po utworzeniu i udostępnieniu katalogu obrazu administracyjnego, można powiadomić klientów za pomocą poczty elektronicznej.

Skonfigurować katalog obrazu administracyjnego do udostępniania na komputerze, do którego dostęp mają inne komputery (na przykład z wykorzystaniem ścieżki UNC).

Można wysłać wiadomość e-mail zawierającą łącze do pliku katalog_instalacyjny_obrazu_administracyjneg\StartSWInstall.hta do wszystkich klientów. Klienci mogą następnie kliknąć to łącze i kliknąć Zainstaluj teraz produkty SOLIDWORKS, aby rozpocząć instalację z obrazu administracyjnego.

Jeżeli uaktualniamy obraz administracyjny do nowej wersji SOLIDWORKS, można skonfigurować lokalizację obrazu administracyjnego i współużytkować właściwości tak, aby zainstalowani wcześniej klienci używający tego obrazu zostali uaktualnieni automatycznie. Szczegółowe informacje zawiera temat Uaktualnianie klientów z obrazów administracyjnych.
Temat nadrzędny Edytor opcji obrazu administracyjnego
Dodawanie i usuwanie grup i komputerów
Przeglądanie i edytowanie ustawień opcji
Rozmieszczanie instalacji z Edytora opcji
Wychodzenie z Edytora opcji
Tworzenie na pulpicie skrótu do Edytora opcji


Narzędzie Administration Tool

Narzędzia Settings Administrator Tool można użyć, aby określić opcje systemu, które są stosowane podczas wdrażania lub uaktualniania oprogramowania SOLIDWORKS i aby uniemożliwić użytkownikom zmienianie tych opcji. Narzędzie to zastępuje Kreatora ustawień SOLIDWORKS dla wdrażania ustawień, choć ten kreator jest nadal dostępny do kopiowania ustawień.

Praca z narzędziem Settings Administrator Tool w połączeniu z Edytorem opcji obrazu administracyjnego dzieli się na trzy etapy:
  1. Utworzyć obraz administracyjny, aby uzyskać dostęp do narzędzia.
  2. Użyć narzędzia Settings Administrator Tool w celu wygenerowania pliku *.sldsettings zawierającego wybrane opcje SOLIDWORKS.
  3. Dodać plik *.sldsettings do instalacji SOLIDWORKS.
Jeśli używany jest dodatek 3DEXPERIENCE, można również wdrożyć plik *.sldsettings poza obrazem administracyjnym. Zaletą tej metody jest automatyczne wdrażanie ustawień przy logowaniu.
  1. Aby uzyskać dostęp do Narzędzia administratora ustawień, należy wykonać czynności opisane w Uzyskiwanie dostępu do narzędzia Administration Tool.
  2. Postępować zgodnie z instrukcjami, aby zastosować i zablokować ustawienia.
  3. Z poziomu 3DEXPERIENCE Compass rozwinąć pozycję Moje role i kliknąć aplikację Platform Manager. Przejść do Zawartość > Centrum konfiguracji obszarów współpracy > Współpraca z CAD > SOLIDWORKS > Ustawienia > Zasoby > Ustawienia CAD.
  4. W sekcji Ustawienia CAD przejrzeć, przesłać i pobrać plik *.sldsettings.

Spis treści

  • Uzyskiwanie dostępu do narzędzia Administration Tool

    Aby uzyskać dostęp do narzędzia Administrator ustawień, trzeba najpierw utworzyć obraz administracyjny.

  • Korzystanie z narzędzia Administration Tool

  • Stosowanie i blokowanie opcji

  • Kończenie konfigurowania opcji

  • Włączanie pliku sldsettings do instalacji SOLIDWORKS

Temat nadrzędny Używanie obrazów administracyjnych


Uzyskiwanie dostępu do narzędzia Administration Tool

Aby uzyskać dostęp do narzędzia Administrator ustawień, trzeba najpierw utworzyć obraz administracyjny.

Narzędzie Settings Administrator można uruchomić z poziomu obrazu administracyjnego.

Aby uzyskać dostęp do narzędzia Administration Tool:

  1. Uruchomić plik sldAdminOptionEditor.exe w folderze obrazu administracyjnego.
  2. W Edytorze opcji obrazu administracyjnego kliknąć Zmień [image].
  3. W obszarze Opcje instalacji klienta wykonać następujące czynności:
    1. Kliknąć Użyj pliku ustawień wyeksportowanego z SOLIDWORKS Administration Tool.
    2. Kliknąć Uruchom Administration Tool.
      Aby uzyskać dostęp do narzędzia Administrator ustawień uruchamiania, program SOLIDWORKS <version> musi być zainstalowany na komputerze z zainstalowanym programem sldAdminOptionEditor.exe.
Temat nadrzędny Narzędzie Administration Tool


Korzystanie z narzędzia Administration Tool

Aby użyć narzędzia Administrator ustawień:

  1. Na karcie Witamy wybrać spośród poniższych opcji:
    • Domyślny zestaw opcji, aby uruchomić narzędzie dla tej wersji SOLIDWORKS.
    • Importuj opcje SOLIDWORKS 2025 z tego komputera.
    • Przejdź do istniejącego pliku sldreg.
    • Przejdź do istniejącego pliku .sldsettings.
    Plik *.sldreg jest generowany przez Kreatora ustawień SOLIDWORKS, a plik *.sldsettings przez narzędzie Administrator ustawień.
  2. Kliknąć Dalej.
Temat nadrzędny Narzędzie Administration Tool


Stosowanie i blokowanie opcji

Na karcie Opcje systemu dwie kolumny pól wyboru pozwalają zadecydować, które z tych opcji mają zostać zastosowane i które z zastosowanych opcji mają zostać zablokowane, aby użytkownicy nie mogli ich zmieniać.

Kiedy użytkownicy będą wyświetlać okno dialogowe Opcje systemu w oprogramowaniu SOLIDWORKS, zablokowane opcje będą widoczne jako niedostępne, z ikoną blokady [image]. Można jednak utworzyć hasło, które pozwalałoby użytkownikom na odblokowywanie opcji. Kiedy użytkownik zatrzyma wskaźnik myszy nad zablokowaną opcją, pojawi się etykietka narzędziowa z imieniem i nazwiskiem oraz adresem e-mail tego, kto ją zablokował, dzięki czemu użytkownik będzie mógł skontaktować się z autorem i poprosić o hasło.

Aby stosować i blokować opcje:

  1. Na karcie Opcje systemu wykonać następujące czynności:
    1. Aby zastosować opcję systemu, wybrać żądaną opcję i zaznaczyć odpowiednie pole w kolumnie Zastosuj.
    2. Aby zablokować opcję systemu, wybrać żądaną opcję i zaznaczyć odpowiednie pola w obu kolumnach, Zastosuj i Zablokuj.
      Kiedy użytkownicy będą wyświetlać kartę Opcje systemu, te opcje będą widoczne z blokadą [image].
  2. Może zaistnieć konieczność określenia dodatkowych parametrów niektórych opcji.
  3. Można również zablokować użytkownikom możliwość odrzucania komunikatów, stosując narzędzia kontroli w sekcji Komunikaty/Błędy/Ostrzeżenia.
    1. Kliknąć Komunikaty/Błędy/Ostrzeżenia.
    2. Zaznaczyć opcję Zastosuj i ewentualnie zaznaczyć pole Zablokuj dla żądanych komunikatów.
    3. Dla komunikatu wybrać ustawienie Pokaż lub Nie pokazuj.

      W przypadku wybrania opcji Pokaż komunikat zostanie usunięty z listy wiadomości odrzucanych przez użytkownika i będzie wyświetlany w odpowiednim momencie. W przypadku wybrania opcji Nie Pokazuj komunikat jest automatycznie dodawany do listy komunikatów odrzuconych użytkownika i nie będzie wyświetlany, gdy użytkownik pracuje na modelu.

      W poniższej tabeli przedstawiono zachowanie oprogramowania:
      Zastosuj | Zablokuj | Pokaż | Nie pokazuj | Zachowanie
      X | X | Wymusza wyświetlanie komunikatu.
      X | X | Odrzuca komunikat i dodaje go do listy odrzuconych.
      X | X | X | Wymusza wyświetlanie komunikatu i wyłącza opcję Nie pokazuj ponownie w oknie komunikatu.
      X | X | X | Odrzuca komunikat i uniemożliwia użytkownikowi jego włączenie w części Narzędzia > Opcje > Komunikaty/Błędy/Ostrzeżenia.
  4. Na karcie Opcje systemu kliknąć Dalej.
Temat nadrzędny Narzędzie Administration Tool


Kończenie konfigurowania opcji

Aby zakończyć konfigurowanie opcji:

  1. Na karcie Zakończ zaznaczyć, kiedy opcje systemu mają mieć zastosowanie:
    • gdy użytkownik po raz pierwszy uruchamia oprogramowanie.
    • przy każdym uruchomieniu oprogramowania.
    • oraz czy dostosowania mają mieć równocześnie zastosowanie.
  2. Można wybrać stosowanie zablokowanych opcji, gdy użytkownicy nie są połączeni z siecią i zezwolenie na zastępowanie zablokowanych opcji przez API.
  3. Dla zablokowanych opcji systemu trzeba podać nazwę użytkownika i adres e-mail. Oprogramowanie SOLIDWORKS wyświetla te informacje w etykietce narzędzia, gdy użytkownicy zatrzymują kursor nad zablokowaną opcją.
  4. Można również zezwolić użytkownikom na zastępowanie zablokowanych opcji. W takiej sytuacji trzeba określić hasło, które można podać użytkownikom.
  5. Kliknąć Zapisz, aby wygenerować plik *.sldsettings do wdrożenia.
Temat nadrzędny Narzędzie Administration Tool


Włączanie pliku sldsettings do instalacji SOLIDWORKS

Aby dodać plik *.sldsettings do instalacji, należy:

  1. Kliknąć dwukrotnie plik sldAdminOptionEditor.exe w folderze obrazu administracyjnego.
  2. W Edytorze opcji obrazu administracyjnego kliknąć Zmień.
  3. W części Opcje instalacji klienta wykonać następujące czynności:
    1. Kliknąć Użyj pliku ustawień wyeksportowanego z SOLIDWORKS Settings Administrator.
    2. Kliknąć Edytuj ścieżkę i przejść do pliku *.sldsettings.
    Dla poszczególnych grup lub komputerów można utworzyć i zastosować różne pliki *.sldsettings.
  4. Rozmieścić i zainstalować oprogramowanie SOLIDWORKS.

Po wdrożeniu można w dowolnym momencie powtórzyć krok 2, aby zmodyfikować istniejący plik *.sldsettings. SOLIDWORKS odczytuje zmodyfikowany plik *.sldsettings przy kolejnym uruchomieniu.

Temat nadrzędny Narzędzie Administration Tool


Wiersz polecenia - Rozmieszczanie

Można automatycznie uruchomić obraz administracyjny przy użyciu wiersza polecenia lub pliku wsadowego (dyskretna instalacja).

Aby zainstalować obraz administracyjny przy użyciu wiersza poleceń na klientach programu SOLIDWORKS PDM, należy się zapoznać z Przewodnikiem instalacji SOLIDWORKS PDM.

Spis treści

  • Przygotowywanie klientów do instalacji z obrazu administracyjnego przy użyciu wiersza polecenia

    Po utworzeniu obrazu administracyjnego i przed powiadomieniem klientów, konieczne jest zainstalowanie komponentów Microsoft Windows, które nie mogą być zainstalowane przez obrazy administracyjne przy użyciu wiersza polecenia lub Microsoft Active Directory.

  • Instalowanie z obrazu administracyjnego przy użyciu wiersza polecenia

    Można rozmieścić instalacje z obrazu administracyjnego, używając wiersza polecenia.

  • Właściwości wiersza polcenia

    Opisane tutaj właściwości wiersza polecenia obejmują właściwości funkcji, właściwości globalne, właściwości specyficzne dla produktu oraz konwencje lokalizacji Windows.

  • Rozmieszczanie obrazu administracyjnego przy użyciu Microsoft Active Directory

    Rozmieszczanie przy użyciu Microsoft Active Directory jest obsługiwane dla głównego produktu SOLIDWORKS do klientów.

Temat nadrzędny Instalacje na wielu klientach
Rozmieszczanie do wielu klientów
Używanie obrazów administracyjnych
Administracja wieloma instalacjami


Przygotowywanie klientów do instalacji z obrazu administracyjnego przy użyciu wiersza polecenia

Po utworzeniu obrazu administracyjnego i przed powiadomieniem klientów, konieczne jest zainstalowanie komponentów Microsoft Windows, które nie mogą być zainstalowane przez obrazy administracyjne przy użyciu wiersza polecenia lub Microsoft Active Directory.

Ręczna instalacja tych komponentów Windows jest wymagana tylko w przypadku instalowania z obrazu administracyjnego przy użyciu wiersza poleceń lub za pośrednictwem Microsoft Active Directory. W przypadku użycia Menedżera instalacji SOLIDWORKS do utworzenia i zainstalowania obrazu administracyjnego, te komponenty Windows są instalowane automatycznie.
Poniżej zestawiono pliki wymagane przez SOLIDWORKS w komponentach Windows:
Windows Performance Toolkit | Włącza rozszerzone logowanie w SOLIDWORKS Rx.
Visual C++ 2022 Redistributable Package | Zawiera komponenty wykonawcze dla Microsoft Visual C++. Konieczna jest instalacja wersji 2022.
Visual Basic for Applications 7.1 | Umożliwia obsługę makr Visual Basic.
Visual Studio Tools for Application 2022 | Opcjonalne. Zawiera zestaw narzędzi obsługujących aplikacje Visual Studio 2022 (VSTA17).
.NET Framework 4,8 | Zawiera środowisko uruchomieniowe języka wspólnego oraz komponenty .NET Framework, które są niezbędne do uruchamiania aplikacji .NET Framework 4.8.
SWCEF | System Chromium Embedded Framework (CEF) jest używany do wyświetlania zawartości w środowisku 3DEXPERIENCE platform.
Microsoft Edge Web View2 | Wymagane do wyświetlenia zawartości internetowej.
SOLIDWORKS Login Manager | Umożliwia zalogowanie się do 3DEXPERIENCE Marketplace i innych aplikacji 3DEXPERIENCE.
Visual C++ Redistributable Package oraz .NET Framework 4.8 są wymagane dla wszystkich produktów SOLIDWORKS, a nie tylko dla głównego produktu SOLIDWORKS.

Komponenty te muszą być uwzględnione w podkatalogach katalogu obrazu administracyjnego.

Następująca tabela identyfikuje określone pliki, które są wymagane dla każdego obsługiwanego systemu operacyjnego.
System operacyjny: Windows Server 2019 64-bitowy i Windows Server 2022 64-bitowy
Instalacja w systemie Windows Server 2019 lub 2022 jest obsługiwana dla SOLIDWORKS PDM Server i SOLIDWORKS SolidNetWork License Manager.
Windows Performance Toolkit: | WPTx64-x86_en-us.msi
Visual C++ 2022 Redistributable Package: | vc_redist.x86.exe vc_redist.x64.exe Obydwa muszą być zainstalowane.
Visual Basic 7.1: | vba71_1033.msi Plus opcjonalny pakiet językowy.
.NET Framework 4,8: | ndp48-x86-x64-allos-enu.exe
SWCEF | CEF for SOLIDWORKS Applications.msi
Microsoft Edge Web View2 | MicrosoftEdgeWebView2RuntimeInstallerX64.exe
System operacyjny: Windows 10 i Windows 11 64-bitowy
Windows Performance Toolkit: | WPTx64-x86_en-us.msi
Visual C++ 2022 Redistributable Package: | vc_redist.x86.exe vc_redist.x64.exe Obydwa muszą być zainstalowane.
Visual Basic 7.1: | vba71_1033.msi Plus opcjonalny pakiet językowy.
.NET Framework 4,8: | Środowisko .NET 4.8 jest częścią systemu operacyjnego, który spełnia to wymaganie.
SWCEF | CEF for SOLIDWORKS Applications.msi
Microsoft Edge Web View2 | MicrosoftEdgeWebView2RuntimeInstallerX64.exe

Spis treści

  • Instalowanie wymagań wstępnych Windows z wiersza polecenia w 64-bitowych systemach operacyjnych

    Poniższa procedura pozwala zainstalować wymagane składniki Windows dla instalacji obrazu administracyjnego przy użyciu wiersza polecenia w 64-bitowych wersjach systemu Windows.

Temat nadrzędny Wiersz polecenia - Rozmieszczanie
Instalowanie z obrazu administracyjnego przy użyciu wiersza polecenia
Właściwości wiersza polcenia
Rozmieszczanie obrazu administracyjnego przy użyciu Microsoft Active Directory


Instalowanie wymagań wstępnych Windows z wiersza polecenia w 64-bitowych systemach operacyjnych

Poniższa procedura pozwala zainstalować wymagane składniki Windows dla instalacji obrazu administracyjnego przy użyciu wiersza polecenia w 64-bitowych wersjach systemu Windows.

Aby zainstalować wiele komponentów w jednej operacji instalacji, należy utworzyć plik wsadowy z poleceniami podanymi w następujących procedurach i użyć ich, aby przesłać komponenty do klientów.

  1. Upewnić się, że docelowy komputer ma co najmniej 620 MB dostępnego miejsca na dysku oraz prawidłowy katalog TEMP.
  2. Zainstalować Visual C++ WERSJA Redistributable Packages. Należy zainstalować zarówno wersję 32-bitową, jak i 64-bitową każdego pakietu.
    Zainstalować pakiet, gdzie WERSJA = 2022.

    administrative_image_directory\Microsoft_C++_RELEASE_Redistributable_(x64)\vc_redist.x64.exe /Q

    administrative_image_directory\Microsoft_C++_RELEASE_Redistributable\vc_redist.x86.exe /Q

  3. Zainstalować Microsoft .NET Framework 4,8:
    administrative_image_directory\.Net_Framework_4.8\ndp48-x86-x64-allos-enu.exe
  4. Zainstalować Visual Studio Tools for Application 2022:
    administrative_image_directory\Microsoft_VSTA17\vsta_setup.exe
  5. Zainstalować Visual Basic 7,1:
    Katalogi administrative_image_directory\Microsoft_VBA\vba71.msi and administrative_image_directory\Microsoft_VBA\vba71_1033.msi są wymagane dla wszystkich języków.
    Należy zainstalować jedynie 64-bitową wersję tego pakietu.

    Ponadto dla wybranego języka należy zainstalować poniższy pakiet:

    vba71_1028.msi | Chiński
    vba71_1031.msi | Niemiecki
    vba71_1036.msi | Francuski
    vba71_1040.msi | Włoski
    vba71_1041.msi | Japoński
    vba71_1042.msi | Koreański
    vba71_1046.msi | Portugalski (Brazylia)
    vba71_2052.msi | Chiński uproszczony
    vba71_3082.msi | Hiszpański
    Języki angielski, czeski, polski, rosyjski i turecki nie wymagają dodatkowych pakietów językowych.
    Zainstalować dodatkowy warunek wstępny: Msiexec.exe /p vba71-kb27832-x64.msp.
  6. Instalacja SOLIDWORKS Chromium Embedded Framework (SWCEF):
    administrative_image_directory\swcef\CEF for SOLIDWORKS Applications.msi.
  7. Instalacja programu SOLIDWORKS Login Manager:
    administrative_image_directory\swloginmgr\SOLIDWORKS Login Manager.msi.
Temat nadrzędny Przygotowywanie klientów do instalacji z obrazu administracyjnego przy użyciu wiersza polecenia


Instalowanie z obrazu administracyjnego przy użyciu wiersza polecenia

Można rozmieścić instalacje z obrazu administracyjnego, używając wiersza polecenia.

Aby dokonać dyskretnej instalacji, należy:

  1. Otworzyć okno Wiersz poleceń (w systemie Windows kliknąć Start > Uruchom).
  2. Wpisać polecenie msiexec.exe z przełącznikami /i i /qb oraz określić właściwości dla wszelkich opcji, które nie są wartościami domyślnymi, zgodnie z poniższym opisem.

    msiexec /i "administrative_image_directory\64bit\SWFileUtilities\SOLIDWORKS File Utilities.msi" INSTALLDIR="C:\Program Files\your_folder /qb

Właściwości instalacji indywidualnego komponentu przy użyciu wiersza polecenia obejmują:
  • Wiersz polecenia - Właściwości funkcji
  • Wiersz polecenia - Właściwości globalne
  • eDrawings Właściwości wiersza polecenia
  • SOLIDWORKS Flow Simulation - Właściwości wiersza polecenia

Jako szablonów dla dyskretnej instalacji należy użyć poniższych przykładów.

Klient SOLIDWORKS

  • SOLIDWORKS — główny produkt (angielski)
  • Dodatek Toolbox
  • Uczestnictwo w programie raportu błędów
  • Język francuski

SOLIDWORKS:

msiexec /i "administrative_image_directory\64bit\SOLIDWORKS\SOLIDWORKS.Msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=4 ADDLOCAL=SolidWorks, SolidWorksToolbox TOOLBOXFOLDER="toolbox path for example C:\SolidWorks Data\" /qb

Komponent instalacji języka francuskiego SOLIDWORKS musi być instalowany oddzielnie:

msiexec /i "administrative_image_directory\64bit\SOLIDWORKS French\french.msi" /qb

Podczas określania poleceń instalacji komponentu języka SOLIDWORKS nie należy określać argumentów wiersza polecenia.

Klient eDrawings

  • Wszystkie operacje

msiexec /i
            "administrative_image_directory\64bit\eDrawings\eDrawings.msi"
          INSTALLDIR="C:\Program Files\your_folder"
            SNLSERVER=eDrawings_SNL_server TRANSFORMS=1040.mst
          ADDLOCAL=All /qb

SOLIDWORKS Electrical

Ze względu na złożoność techniczną instalacji SOLIDWORKS Electrical z programem Microsoft SQL Server, dokumentacja nie zawiera przykładów użycia wiersza poleceń dla SOLIDWORKS Electrical.

SOLIDWORKS Visualize i Visualize Boost

SOLIDWORKS Visualize:

msiexec. /i “administrative_image_directory\64bit\SOLIDWORKS Visualize.msi” ACTIVSERIALNUMBER=”1234123412341234ABCDEFGH” INSTALLDIR=”C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS Visualize” /qb

SOLIDWORKS Visualize Boost:

msiexec /i “administrative_image_directory\64bit\SOLIDWORKS Visualize Boost.msi” ACTVISERIALNUMBER=”1234123412341234ABCDEFGH” INSTALLDIR=”C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS Visualize Boost” /qb

Temat nadrzędny Wiersz polecenia - Rozmieszczanie
Przygotowywanie klientów do instalacji z obrazu administracyjnego przy użyciu wiersza polecenia
Właściwości wiersza polcenia
Rozmieszczanie obrazu administracyjnego przy użyciu Microsoft Active Directory


Właściwości wiersza polcenia

Opisane tutaj właściwości wiersza polecenia obejmują właściwości funkcji, właściwości globalne, właściwości specyficzne dla produktu oraz konwencje lokalizacji Windows.

Spis treści

  • Wiersz polecenia - Właściwości funkcji

    Instalacja SOLIDWORKS obsługuje poniższe właściwości ADDLOCAL dla rozmieszczania przy użyciu wiersza polecenia.

  • Wiersz polecenia - Właściwości globalne

    Każda właściwość jest zdefiniowana dla instalacji administracyjnej lub indywidualnej, chyba że odnotowano inaczej. Numer seryjny może być przekazany zarówno do instalacji administracyjnej jak i indywidualnej przy użyciu właściwości globalnych.

  • eDrawings Właściwości wiersza polecenia

    Poniższe właściwości wiersza polecenia są specyficzne dla eDrawings ®.

  • Właściwości wiersza polecenia SOLIDWORKS Composer/Composer Player

    Poniższe właściwości wiersza polecenia są specyficzne dla SOLIDWORKS Composer i SOLIDWORKS Composer Player.

  • SOLIDWORKS Flow Simulation - Właściwości wiersza polecenia

    Poniższe właściwości wiersza polecenia są specyficzne dla SOLIDWORKS Flow Simulation.

  • SOLIDWORKS Inspection Wiersz polecenia - Właściwości

    Poniższe właściwości wiersza polecenia są specyficzne dla aplikacji SOLIDWORKS Inspection.

  • Właściwości wiersza polecenia programu SOLIDWORKS Visualize

    Poniższe właściwości wiersza polecenia są specyficzne dla aplikacji SOLIDWORKS Visualize.

  • Lokalizacje plików MSI dla obrazów administracyjnych

    Aby utworzyć obrazy administracyjne z wiersza polecenia, pliki .msi komponentu produktu są przechowywane w poniższych lokalizacjach na nośnikach SOLIDWORKS.

Temat nadrzędny Wiersz polecenia - Rozmieszczanie
Przygotowywanie klientów do instalacji z obrazu administracyjnego przy użyciu wiersza polecenia
Instalowanie z obrazu administracyjnego przy użyciu wiersza polecenia
Rozmieszczanie obrazu administracyjnego przy użyciu Microsoft Active Directory


Wiersz polecenia - Właściwości funkcji

Instalacja SOLIDWORKS obsługuje poniższe właściwości ADDLOCAL dla rozmieszczania przy użyciu wiersza polecenia.

  • CircuitWorks
  • CoreSolidWorksTaskScheduler
  • ExampleFiles
  • FeatureWorks
  • HelpFiles
  • Manuals
  • Motion
  • ScanTo3D
  • Simulation
  • SolidWorksCosting
  • SolidWorksDesignChecker
  • SolidWorksRoutedsystems
  • SolidWorksToolbox
  • SolidWorksUtilities
  • TolAnalyst
Podczas określania właściwości dla instalacji przy użyciu wiersza polecenia:
  • SOLIDWORKS nie obsługuje instalacji produktu przy użyciu opcji ADDSOURCE.
  • Właściwości uwzględniają wielkość liter, nie mogą zawierać odstępów ani kresek i muszą być oddzielone przecinkami.
Temat nadrzędny Właściwości wiersza polcenia
Wiersz polecenia - Właściwości globalne
eDrawings Właściwości wiersza polecenia
Właściwości wiersza polecenia SOLIDWORKS Composer/Composer Player
SOLIDWORKS Flow Simulation - Właściwości wiersza polecenia
SOLIDWORKS Inspection Wiersz polecenia - Właściwości
Właściwości wiersza polecenia programu SOLIDWORKS Visualize
Lokalizacje plików MSI dla obrazów administracyjnych


Wiersz polecenia - Właściwości globalne

Każda właściwość jest zdefiniowana dla instalacji administracyjnej lub indywidualnej, chyba że odnotowano inaczej. Numer seryjny może być przekazany zarówno do instalacji administracyjnej jak i indywidualnej przy użyciu właściwości globalnych.

Właściwość | Opis
ENABLEPERFORMANCE Określa, czy aplikacja powinna automatycznie wysyłać raport błędów do SOLIDWORKS Corporation.

1

Wyślij dane dotyczące wydajności.

0

Nie wysyłaj danych dotyczących wydajności.
INSTALLDIR | Określa folder instalacji dla SOLIDWORKS.
MBDSERIALNUMBER | Numer seryjny dla produktu SOLIDWORKS MDB.
MOTIONSERIALNUMBER | Numer seryjny dla produktu SOLIDWORKS Motion.
OFFICEOPTION Należy określić pakiet produktu do zainstalowania:
0 | SOLIDWORKS Standard
1 | SOLIDWORKS Office
2 | SOLIDWORKS Professional
3 | SOLIDWORKS Premium
4 | SOLIDWORKS Ultimate
REINSTALL Określić Określić, aby aktualizować wszystkie już zainstalowane operacje.
Określić tę właściwość tylko podczas aktualizowania do wersji pakietu Service Pack w ramach istniejącej wersji głównej (na przykład: aktualizacja istniejącej instalacji SOLIDWORKS 2025 SP01 do wersji SOLIDWORKS 2025 SP02).
REINSTALLMODE Opcje ponownej instalacji Instalatora Microsoft.

Na przykład: podczas uaktualniania instalacji z wersji jednego pakietu Service Pack do innego w ramach tej samej wersji głównej należy określić REINSTALLMODE=vomus.

Szczegóły dotyczące ustawień REINSTALLMODE zawiera dokumentacja Instalatora Windows na stronie www.microsoft.com.

Określić tę właściwość tylko podczas aktualizowania do wersji pakietu Service Pack w ramach istniejącej wersji głównej (na przykład: aktualizacja istniejącej instalacji SOLIDWORKS 2025 SP01 do wersji SOLIDWORKS 2025 SP02). Nie określać tej właściwości przy pierwszej instalacji nowej wersji głównej SOLIDWORKS.
SERVERLIST Lista serwerów licencji SolidNetWork.
Lista serwerów SolidNetWork jest listą ciągów rozdzielonych, z których każdy odnosi się do numeru portu na serwerze w formacie:
  • Triady (rozdzielenie przecinkami) =xxxxx@nazwa_serwera1,yyyyy@nazwa_serwera2,zzzzz@nazwa_serwera3
  • Nie triady (rozdzielenie średnikami) = xxxxx@nazwa_serwera1;yyyyy@nazwa_serwera2;zzzzz@nazwa_serwera3
X i Y są pojedynczymi cyframi. Po ostatnim serwerze na liście nie należy wstawiać znaku rozdzielenia.
SIMULATIONSERIALNUMBER | Numer seryjny dla produktu SOLIDWORKS Simulation.
SOLIDWORKSSERIALNUMBER | Określa numer seryjny dla produktu SOLIDWORKS, który zawiera wszystkie dodatki.
SWMIGRATE Określa wersję SOLIDWORKS do uaktualnienia, która będzie pokazana na liście w oknie dialogowym Wybór instalacji SOLIDWORKS. Na przykład:

SWMIGRATE="SOLIDWORKS 2025 x64 Edition SP01"

Opcję tę należy określić tylko podczas instalowania nowej wersji głównej, gdy aktualnie zainstalowana jest poprzednia wersja główna. Nie należy określać tej właściwości podczas uaktualniania od wersji jednego pakietu Service Pack do innego pakietu w ramach tej samej wersji głównej.
TOOLBOXFOLDER Określa folder instalacji dla plików SOLIDWORKS Toolbox.

Na przykład: TOOLBOXFOLDER = "C:\SOLIDWORKS Data"

Jeśli w środowisku istnieje lokalizacja PDM lub wspólna lokalizacja Toolbox/Kreatora otworów, można tak określić instalację klienta, aby dane Toolbox nie były umieszczane ani aktualizowane w tej lokalizacji przy użyciu właściwości NOTTOOLBOXSETUP. Wybrać:

0 | Instalacja plików Toolbox.
1 | Brak instalacji plików Toolbox.
TRANSFORMS Zawiera elementy formularza specyficzne dla języka:
TRANSFORMS liczba.mst
  • Chiński (1028)
  • Chiński uproszczony (2052)
  • Czeski (1029)
  • Angielski (1033)
  • Francuski (1036)
  • Niemiecki (1031)
  • Włoski (1040)
  • Japoński (1041)
  • Koreański (1042)
  • Polski (1045)
  • Portugalski (brazylijski) (1046)
  • Rosyjski (1049)
  • Hiszpański (1034)
  • Turecki (1055)
UPGRADESWINSTALL
Określa, czy należy uaktualnić istniejącą wersję SOLIDWORKS do bieżącej wersji.
0 | Nowa instalacja, nie aktualizuj.
1 | Aktualizuj
Opcję tę należy określić tylko podczas instalowania nowej wersji głównej, gdy aktualnie zainstalowana jest poprzednia wersja główna. Nie należy określać tej właściwości podczas uaktualniania od wersji jednego pakietu service pack do innego pakietu w ramach tej samej wersji głównej.
Temat nadrzędny Właściwości wiersza polcenia
Wiersz polecenia - Właściwości funkcji
eDrawings Właściwości wiersza polecenia
Właściwości wiersza polecenia SOLIDWORKS Composer/Composer Player
SOLIDWORKS Flow Simulation - Właściwości wiersza polecenia
SOLIDWORKS Inspection Wiersz polecenia - Właściwości
Właściwości wiersza polecenia programu SOLIDWORKS Visualize
Lokalizacje plików MSI dla obrazów administracyjnych


eDrawings Właściwości wiersza polecenia

Poniższe właściwości wiersza polecenia są specyficzne dla eDrawings ®.

Właściwość | Opis
ADDLOCAL Określa, która część aplikacji eDrawings ma zostać zainstalowana.
All jest zalecaną opcją.
Składnia wiersza polecenia | Operacja
All | Instaluje wszystkie funkcje. Aplikacja eDrawings szuka zainstalowanych aplikacji publikatora SOLIDWORKS i AutoCAD, aby sprawdzić poprawność instalacji.
CALS | Przeglądanie plików CAL w eDrawings Viewer
Inventor | Tworzenie plików eDrawings z aplikacji Autodesk Inventor.
eDrawingsViewer | Przeglądanie plików eDrawings i innych.
ProE | Przeglądanie plików ProE w eDrawings Viewer
DXFDWGTranslator | Przeglądanie plików DXF/DWG w eDrawings Viewer.
Shortcuts | Instalowanie skrótu pulpitu.
XML3D | Przeglądanie plików 3DXML w eDrawings Viewer.
INSTALLDIR | Określa folder instalacyjny eDrawings
SNLSERVER Należy wprowadzić port@nazwaserwera dla serwera licencji SolidNetWork License. Użyć średników, aby oddzielić wiele kombinacji port@nazwa_serwera .

Nazwa serwera portu dla SNLSERVER i SERVERLIST jest wymagana jedynie dla konfiguracji serwera SOLIDWORKS SNL.

Lista serwerów SolidNetWork jest listą ciągów rozdzielonych, z których każdy odnosi się do numeru portu na serwerze w formacie:
  • Triada (rozdzielana przecinkami)

    = xxxx@server_name1,yyyy@server_name2,zzzz@server_name3

  • Nie-triada (rozdzielana średnikami)

    = xxxx@server_name1,yyyy@server_name2,zzzz@server_name3

X i Y są pojedynczymi cyframi. Po ostatnim serwerze na liście nie należy wstawiać średnika.
Temat nadrzędny Właściwości wiersza polcenia
Wiersz polecenia - Właściwości funkcji
Wiersz polecenia - Właściwości globalne
Właściwości wiersza polecenia SOLIDWORKS Composer/Composer Player
SOLIDWORKS Flow Simulation - Właściwości wiersza polecenia
SOLIDWORKS Inspection Wiersz polecenia - Właściwości
Właściwości wiersza polecenia programu SOLIDWORKS Visualize
Lokalizacje plików MSI dla obrazów administracyjnych


Właściwości wiersza polecenia SOLIDWORKS Composer/Composer Player

Poniższe właściwości wiersza polecenia są specyficzne dla SOLIDWORKS Composer i SOLIDWORKS Composer Player.

Dla SOLIDWORKS Composer:

Właściwość | Opis
ACTIVSERIALNUMBER | Numer seryjny SOLIDWORKS Composer.
ACTIVSERIALNUMBERPLAYERPRO | Opcjonalne. Numer seryjny programu SOLIDWORKS Composer Player Pro.
ADDLOCAL Opcjonalne. Jeżeli zainstalowana zostanie pełna aplikacja, nie potrzeba określać właściwości ADDLOCAL.
W przypadku instalacji niestandardowej należy użyć ADDLOCAL z następującymi wymaganymi elementami:
  • Licencjonowanie
  • CLOSA
  • InterOps
  • LicenseSupportFiles
  • PlugIns
  • SWComposerCommon
  • SWPlayer
Można również użyć ADDLOCAL z Sync3Dvia, ale nie jest to wymagane.
INSTALLDIR | Określa folder instalacji dla oprogramowania SOLIDWORKS Composer.

Dla SOLIDWORKS Composer Player:

Właściwość | Opis
ACTIVSERIALNUMBERPLAYERPRO | Opcjonalne. Numer seryjny programu SOLIDWORKS Composer Player Pro.
INSTALLDIR | Określa folder instalacji dla oprogramowania SOLIDWORKS Composer Player.
Na komputerach bez zainstalowanego oprogramowania SOLIDWORKS należy użyć programu SOLIDWORKS Translator do importu plików SOLIDWORKS do aplikacji SOLIDWORKS Composer. Aby uruchomić program SOLIDWORKS Translator, należy użyć Menedżera instalacji SOLIDWORKS (nie można skorzystać z wiersza polecenia).
Temat nadrzędny Właściwości wiersza polcenia
Wiersz polecenia - Właściwości funkcji
Wiersz polecenia - Właściwości globalne
eDrawings Właściwości wiersza polecenia
SOLIDWORKS Flow Simulation - Właściwości wiersza polecenia
SOLIDWORKS Inspection Wiersz polecenia - Właściwości
Właściwości wiersza polecenia programu SOLIDWORKS Visualize
Lokalizacje plików MSI dla obrazów administracyjnych


SOLIDWORKS Flow Simulation - Właściwości wiersza polecenia

Poniższe właściwości wiersza polecenia są specyficzne dla SOLIDWORKS Flow Simulation.

Właściwość | Opis
ACTIVSERIALNUMBER Numer seryjny autonomicznego produktu SOLIDWORKS Flow Simulation.

(Instalacje indywidualne oraz instalacje klienta z obrazu administracyjnego.)
CWUPGRADEINSTALL Uaktualnia istniejącą wersję konkretnego programu aplikacji SOLIDWORKS Flow Simulation.
1 | Aktualizuj
2 | Nowa instalacja; zainstaluj w nowym katalogu

(Instalacje indywidualne oraz instalacje klienta z obrazu administracyjnego.)
INSTALLDIR Określa folder instalacji dla konkretnego programu aplikacji SOLIDWORKS Flow Simulation.

(Tylko indywidualne instalacje.)
SERVERLIST | Lista ciągów rozgraniczonych średnikami, z których każdy odnosi się do numeru portu na serwerze w formacie: xxxxx@nazwa_serwera1; yyyyy@nazwa_serwera2;& gdzie x i y są pojedynczymi cyframi. Po ostatnim serwerze na liście nie należy wstawiać średnika.
SOLIDWORKSPATH Określa folder, gdzie zainstalowane jest oprogramowanie SOLIDWORKS.

(Instalacje indywidualne oraz instalacje klienta z obrazu administracyjnego.)
Temat nadrzędny Właściwości wiersza polcenia
Wiersz polecenia - Właściwości funkcji
Wiersz polecenia - Właściwości globalne
eDrawings Właściwości wiersza polecenia
Właściwości wiersza polecenia SOLIDWORKS Composer/Composer Player
SOLIDWORKS Inspection Wiersz polecenia - Właściwości
Właściwości wiersza polecenia programu SOLIDWORKS Visualize
Lokalizacje plików MSI dla obrazów administracyjnych


SOLIDWORKS Inspection Wiersz polecenia - Właściwości

Poniższe właściwości wiersza polecenia są specyficzne dla aplikacji SOLIDWORKS Inspection.

Właściwość | Description
ACTIVSERIALNUMBER | Numer seryjny SOLIDWORKS Inspection. (Instalacje indywidualne oraz instalacje klienta z obrazu administracyjnego.)
INSTALLDIR | Określa folder instalacji dla oprogramowania SOLIDWORKS Inspection. (Tylko indywidualne instalacje.)
SERVERLIST | Lista ciągów rozgraniczonych średnikami, z których każdy odnosi się do numeru portu na serwerze w formacie: xxxxx@nazwa_serwera1; yyyyy@nazwa_serwera2;& gdzie x i y są pojedynczymi cyframi. Po ostatnim serwerze na liście nie należy wstawiać średnika.
Temat nadrzędny Właściwości wiersza polcenia
Wiersz polecenia - Właściwości funkcji
Wiersz polecenia - Właściwości globalne
eDrawings Właściwości wiersza polecenia
Właściwości wiersza polecenia SOLIDWORKS Composer/Composer Player
SOLIDWORKS Flow Simulation - Właściwości wiersza polecenia
Właściwości wiersza polecenia programu SOLIDWORKS Visualize
Lokalizacje plików MSI dla obrazów administracyjnych


Właściwości wiersza polecenia programu SOLIDWORKS Visualize

Poniższe właściwości wiersza polecenia są specyficzne dla aplikacji SOLIDWORKS Visualize.

Właściwość | Opis
ACTIVSERIALNUMBER | Numer seryjny programu SOLIDWORKS Visualize. (Instalacje indywidualne oraz instalacje klienta z obrazu administracyjnego.)
INSTALLDIR | Określa folder instalacyjny oprogramowania SOLIDWORKS Visualize. (Tylko indywidualne instalacje.)
SERVERLIST | Lista ciągów rozgraniczonych średnikami, z których każdy odnosi się do numeru portu na serwerze w formacie: xxxxx@nazwa_serwera1; yyyyy@nazwa_serwera2;& gdzie x i y są pojedynczymi cyframi. Po ostatnim serwerze na liście nie należy wstawiać średnika.
Temat nadrzędny Właściwości wiersza polcenia
Wiersz polecenia - Właściwości funkcji
Wiersz polecenia - Właściwości globalne
eDrawings Właściwości wiersza polecenia
Właściwości wiersza polecenia SOLIDWORKS Composer/Composer Player
SOLIDWORKS Flow Simulation - Właściwości wiersza polecenia
SOLIDWORKS Inspection Wiersz polecenia - Właściwości
Lokalizacje plików MSI dla obrazów administracyjnych


Lokalizacje plików MSI dla obrazów administracyjnych

Aby utworzyć obrazy administracyjne z wiersza polecenia, pliki .msi komponentu produktu są przechowywane w poniższych lokalizacjach na nośnikach SOLIDWORKS.

SOLIDWORKS (główny produkt, angielski)

swwi\data\SOLIDWORKS.msi

SOLIDWORKS (komponenty języków innych niż angielski)

Chiński tradycyjny | swwi\lang\chinese\chinese.msi
Uproszczony chiński | swwi\lang\chinese-simplified\chinese-simplified.msi
Czeski | swwi\lang\czech\czech.msi
Francuski | swwi\lang\french\french.msi
Niemiecki | swwi\lang\german\german.msi
Włoski | swwi\lang\italian\italian.msi
Japoński | swwi\lang\japanese\japanese.msi
Koreański | swwi\lang\korean\korean.msi
Polski | swwi\lang\polish\polish.msi
Portugalski (brazylijski) | swwi\lang\portuguese-brazilian\portuguese-brazilian.msi
Rosyjski | swwi\lang\russian\russian.msi
Hiszpański | swwi\lang\spanish\spanish.msi
Turecki | swwi\lang\turkish\turkish.msi

DocManager API

swdocmgr\SOLIDWORKS Document Manager API.msi

eDrawings

eDrawings\eDrawings.msi

eDrawingsAPI SDK

eDrwAPISDK\eDrawings API SDK.msi

Flow Simulation

Flow Simulation\SOLIDWORKS Flow Simulation.msi

3DExperience Marketplace dla SOLIDWORKS

marketplace\3dexperience marketplace.msi

Menedżer licencji SolidNetWork

swlicmgr\SOLIDWORKS SolidNetWork License Manager.msi

SOLIDWORKS API SDK

apisdk\SOLIDWORKS API SDK.msi

SOLIDWORKS CAM

cam\SOLIDWORKS CAM.msi

SOLIDWORKS Composer

swComposer\SOLIDWORKS Composer.msi

SOLIDWORKS Composer Player

swComposerPlayerSOLIDWORKS Composer Player.msi

SOLIDWORKS Electrical

swelectric\SOLIDWORKS Electrical.msi

SOLIDWORKS File Utilities

SWFileUtilities\SOLIDWORKS File Utilities.msi

SOLIDWORKS Inspection

Inspection\SOLIDWORKS Inspection.msi

SOLIDWORKS Manage Client

SWManageClient\SOLIDWORKS Manage Client.msi

SOLIDWORKS PDM

Program SOLIDWORKS PDM Professional zapewnia interfejs API, ale jest on dostępny wyłącznie dla klienta i nie jest dostępny w formie pliku .msi. Aby uzyskać więcej informacji, należy zapoznać się z API guide w katalogu katalog_instalacyjny\API klienta programu SOLIDWORKS PDM.

SOLIDWORKS Plastics

plastics\SOLIDWORKS Plastics.msi

SOLIDWORKS Visualize

visualize\SOLIDWORKS Visualize.msi

SOLIDWORKS Visualize Boost

visualizeboost\SOLIDWORKS Visualize Boost.msi
Temat nadrzędny Właściwości wiersza polcenia
Wiersz polecenia - Właściwości funkcji
Wiersz polecenia - Właściwości globalne
eDrawings Właściwości wiersza polecenia
Właściwości wiersza polecenia SOLIDWORKS Composer/Composer Player
SOLIDWORKS Flow Simulation - Właściwości wiersza polecenia
SOLIDWORKS Inspection Wiersz polecenia - Właściwości
Właściwości wiersza polecenia programu SOLIDWORKS Visualize


Rozmieszczanie obrazu administracyjnego przy użyciu Microsoft Active Directory

Rozmieszczanie przy użyciu Microsoft Active Directory jest obsługiwane dla głównego produktu SOLIDWORKS do klientów.

Microsoft Active Directory jest usługą służącą do zarządzania klientami i serwerami w środowiskach sieciowych. Upraszcza on zarządzanie, migrację i rozmieszczanie.

Aby uzyskać informacje na temat instalowania programu SOLIDWORKS za pośrednictwem usługi Microsoft Active Directory, skontaktuj się ze sprzedawcą.

Temat nadrzędny Wiersz polecenia - Rozmieszczanie
Przygotowywanie klientów do instalacji z obrazu administracyjnego przy użyciu wiersza polecenia
Instalowanie z obrazu administracyjnego przy użyciu wiersza polecenia
Właściwości wiersza polcenia


Administracja wieloma instalacjami

W przypadku wielu instalacji, zadania administracyjne obejmują uaktualnianie obrazów administracyjnych do nowych wersji, zastosowanie aktualizacji pakietów Service Pack oraz usuwanie instalacji.

Spis treści

  • Uaktualnianie obrazów administracyjnych do nowej wersji

    Aby zaktualizować klientów, którzy przeprowadzili instalację z obrazu administracyjnego, najpierw należy zaktualizować obraz administracyjny, a następnie skonfigurować klientów tak, by odnosili się do nowej kopii obrazu.

  • Zarządzanie aktualizacjami produktów Service Pack

    Aktualizacje produktu Service Pack mogą zawierać aktualizacje zwiększające niezawodność systemu, kompatybilności programów, bezpieczeństwo itd.

  • Usuwanie instalacji

    Można usunąć instalację na indywidualnym komputerze lub w środowisku klient/serwer.

Temat nadrzędny Instalacje na wielu klientach
Rozmieszczanie do wielu klientów
Używanie obrazów administracyjnych
Wiersz polecenia - Rozmieszczanie


Uaktualnianie obrazów administracyjnych do nowej wersji

Aby zaktualizować klientów, którzy przeprowadzili instalację z obrazu administracyjnego, najpierw należy zaktualizować obraz administracyjny, a następnie skonfigurować klientów tak, by odnosili się do nowej kopii obrazu.

Uruchomić Menedżera instalacji SOLIDWORKS ze strony pobierania SOLIDWORKS, aby odniesienie dotyczyło prawidłowych plików.

Po aktualizacji obrazu administracyjnego (co tworzy nową kopię obrazu), można aktualizować klientów poprzez nakierowanie ich na odwoływanie się do nowej kopii obrazu administracyjnego.

Jeżeli klienci mieli odniesienia do poprzedniej wersji obrazu administracyjnego za pomocą udostępnianego katalogu, można zmienić definicję przy użyciu lokalizacji zaktualizowanego obrazu administracyjnego.

Spis treści

  • Pobieranie zaktualizowanych plików instalacyjnych dla obrazów administracyjnych

    Menedżer instalacji SOLIDWORKS może wykryć, kiedy potrzebne są zaktualizowane pliki instalacyjne podczas uaktualniania obrazu administracyjnego.

  • Uaktualnianie obrazu administracyjnego

    Aby uaktualnić obraz administracyjny, Menedżer instalacji SOLIDWORKS tworzy nowy katalog obrazu. Można skierować klientów do korzystania z nowego katalogu obrazu administracyjnego, aby uaktualnić do danej wersji produktu.

  • Uaktualnianie klientów z obrazów administracyjnych

    Menedżer instalacji SOLIDWORKS może automatycznie uaktualnić komputery klientów zainstalowanych z obrazu administracyjnego.

Temat nadrzędny Administracja wieloma instalacjami
Zarządzanie aktualizacjami produktów Service Pack
Usuwanie instalacji


Pobieranie zaktualizowanych plików instalacyjnych dla obrazów administracyjnych

Menedżer instalacji SOLIDWORKS może wykryć, kiedy potrzebne są zaktualizowane pliki instalacyjne podczas uaktualniania obrazu administracyjnego.

  1. Uruchom Menedżer instalacji SOLIDWORKS.
  2. Na ekranie Witamy wybrać Obraz administracyjny.
  3. Na ekranie Numer seryjny wprowadzić numer seryjny SOLIDWORKS.
    Menedżer instalacji SOLIDWORKS sprawdza stronę sieci Web SOLIDWORKS, aby zweryfikować licencjonowane produkty oraz dostępne pakiety Service Pack.
  4. Jeżeli pojawi się ekran Dostępna nowsza wersja, wybrać Tak, pobierz i zainstaluj nowszą wersję: wersja.
    Menedżer instalacji SOLIDWORKS rozpocznie nową sesję, aby zainstalować nowszą wersję.
  5. Jeżeli występuje problem z folderem pobierania, mogą pojawić się Opcje pobierania. W takim przypadku należy zaakceptować katalog domyślny dla nowych plików instalacji lub wprowadzić nową nazwę katalogu.
    Jeżeli pojawi się komunikat że katalog nie istnieje, kliknąć Tak, aby go utworzyć.
  6. Na ekranie Ukończono pobieranie, kliknąć Zamknij, aby zamknąć bieżący instalator i uruchomić instalator dla nowej wersji.
Temat nadrzędny Uaktualnianie obrazów administracyjnych do nowej wersji
Uaktualnianie obrazu administracyjnego
Uaktualnianie klientów z obrazów administracyjnych


Uaktualnianie obrazu administracyjnego

Aby uaktualnić obraz administracyjny, Menedżer instalacji SOLIDWORKS tworzy nowy katalog obrazu. Można skierować klientów do korzystania z nowego katalogu obrazu administracyjnego, aby uaktualnić do danej wersji produktu.

Proces ten zakłada, że pobrano wszelkie zaktualizowane pliki instalacyjne dla obrazu administracyjnego. Aby uzyskać szczegółowe informacje, należy zapoznać się z tematem Pobieranie zaktualizowanych plików instalacyjnych dla obrazów administracyjnych.

  1. Uruchom Menedżer instalacji SOLIDWORKS.
  2. Na ekranie Witamy wybrać Obraz administracyjny.
    Pojawią się opcje tworzenia obrazu administracyjnego.
    Opcja | Opis
    Utwórz nowy obraz używając ustawień domyślnych. | Tworzy obraz przy użyciu domyślnych ustawień konfiguracji (tzn. nie w oparciu o ustawienia wprowadzone dla istniejącego obrazu administracyjnego w danym miejscu).
    Utwórz nowy obraz używając ustawień i plików z istniejącego obrazu. | Tworzy obraz używając ustawień konfiguracji określonych dla istniejącego obrazu administracyjnego w danym miejscu. Należy kliknąć Przeglądaj, aby określić katalog instalacyjny dla istniejącego obrazu administracyjnego.
  3. Na ekranie Numer seryjny, sprawdzić numer seryjny.
  4. Na ekranie Podsumowanie (Gotowy do utworzenia obrazu) należy sprawdzić, czy opcje obrazu administracyjnego są prawidłowe.
    Aby uzyskać szczegółowe informacje na temat indywidualnego obrazu administracyjnego i opcji instalacji, należy kliknąć ZMIEŃ i przejść do strony opcji, a następnie kliknąć Pomoc.
  5. Aby utworzyć nową wersję obrazu administracyjnego, należy kliknąć Utwórz teraz.

Można teraz uaktualnić klientów do tej nowej wersji obrazu administracyjnego. Szczegółowe informacje zawiera temat Uaktualnianie klientów z obrazów administracyjnych.

Temat nadrzędny Uaktualnianie obrazów administracyjnych do nowej wersji
Pobieranie zaktualizowanych plików instalacyjnych dla obrazów administracyjnych
Uaktualnianie klientów z obrazów administracyjnych


Uaktualnianie klientów z obrazów administracyjnych

Menedżer instalacji SOLIDWORKS może automatycznie uaktualnić komputery klientów zainstalowanych z obrazu administracyjnego.

Typowo obrazy administracyjne są zorganizowane w folderach na serwerze. Aby obsługiwać automatyczne aktualizacje klientów, obraz administracyjny musi być zlokalizowany w udostępnionym folderze.

Po uaktualnieniu obrazu administracyjnego, pierwotna instalacja będzie znajdować się w jednym folderze, a uaktualniona instalacja w innym folderze. Aby użyć uaktualnionej instalacji, należy najpierw usunąć opcję udostępniania z folderu oryginalnego obrazu administracyjnego a następnie dodać opcję udostępniania do folderu uaktualnionego obrazu administracyjnego.

Kiedy oprogramowanie SOLIDWORKS jest uruchamiane na komputerze kliencie, na którym dokonano instalacji z oryginalnego obrazu administracyjnego, widzi ono nową wersję i aktualizuje klienta.
Ponadto gdy SOLIDWORKS wyzwala aktualizację, pozostałe produkty zainstalowane z obrazu administracyjnego automatycznie się aktualizują.
Temat nadrzędny Uaktualnianie obrazów administracyjnych do nowej wersji
Pobieranie zaktualizowanych plików instalacyjnych dla obrazów administracyjnych
Uaktualnianie obrazu administracyjnego

Usuwanie opcji udostępniania z pierwotnego folderu obrazu administracyjnego

Podczas uaktualniania obrazu administracyjnego, do którego dostęp odbywa się z folderu udostępnianego, konieczne jest usunięcie opcji udostępniania z pierwotnego folderu.

  1. Przejść do folderu gdzie zlokalizowane są pierwotne pliki obrazu administracyjnego.
  2. Kliknąć folder prawym przyciskiem myszy i wybrać Właściwości.
  3. Na karcie Udostępnianie wybrać Nie udostępniaj tego folderu, a następnie kliknąć OK.

Teraz należy dodać opcję udostępniania do uaktualnionego folderu obrazu administracyjnego, jak opisano w temacie Dodawanie opcji udostępniania do pierwotnego folderu obrazu administracyjnego.

Dodawanie opcji udostępniania do pierwotnego folderu obrazu administracyjnego

Po utworzeniu i aktualizacji folderu obrazu administracyjnego i wyłączeniu udostępniania dla pierwotnego folderu obrazu administracyjnego, konieczne jest dodanie opcji udostępniania do nowego folderu, aby ponownie uaktywnić obraz administracyjny.

  1. Przejść do folderu gdzie zlokalizowane są pliki uaktualnionego obrazu administracyjnego.
  2. Kliknąć folder prawym przyciskiem myszy i wybrać Właściwości.
  3. Na karcie Udostępnianie, określić właściwości udostępniania odpowiednie dla danej firmy lub grupy i zmienić nazwę udziału na nazwę używaną dla folderu oryginalnego obrazu administracyjnego.
Komputery, które zainstalowano z pierwotnej lokalizacji udziału obrazu administracyjnego zostaną uaktualnione do nowej wersji automatycznie podczas uruchamiania SOLIDWORKS.


Zarządzanie aktualizacjami produktów Service Pack

Aktualizacje produktu Service Pack mogą zawierać aktualizacje zwiększające niezawodność systemu, kompatybilności programów, bezpieczeństwo itd.

Aktualizacje produktów można uzyskać na dwa sposoby:
  • Poprzez użycie Menedżera instalacji SOLIDWORKS, aby sprawdzić czy istnieją aktualizacje, pobrać je i zainstalować.

    Można zainicjować Menedżera instalacji SOLIDWORKS ręcznie lub zaplanować okresowe sprawdzanie czy istnieją aktualizacje.

  • Poprzez ręczne pobranie pakietów Service Pack ze strony pomocy technicznej SOLIDWORKS.

    Pakiety Service Pack stosowane są jako poprawki do istniejącej wersji oprogramowania. Na przykład: SOLIDWORKS 2025 SP1.0 jest pakietem Service Pack dla SOLIDWORKS 2025 SP0.0. Pakiety te można zainstalować przy użyciu Menedżera instalacji SOLIDWORKS 2025. Nie można zainstalować ich przy użyciu Menedżera instalacji SOLIDWORKS w SOLIDWORKS 2024.

    Aby uzyskać pomoc dotyczącą pobierania i instalowania pakietów Service Pack, proszę się odwołać do dokumentacji dla wersji SOLIDWORKS, która ma być aktualizowana.

Spis treści

  • Przywracanie pakietów Service Pack w obrazie administracyjnym

    Można przywrócić obraz administracyjny do wcześniej zainstalowanego pakietu Service Pack. Jeżeli zainstalowano oprogramowanie SOLIDWORKS przy użyciu dysków, dla przywrócenia pakietu Service Pack niezbędne są pierwotne dyski. Konieczne jest zapisanie kopii wcześniejszego obrazu administracyjnego.

Temat nadrzędny Administracja wieloma instalacjami
Uaktualnianie obrazów administracyjnych do nowej wersji
Usuwanie instalacji


Przywracanie pakietów Service Pack w obrazie administracyjnym

Można przywrócić obraz administracyjny do wcześniej zainstalowanego pakietu Service Pack. Jeżeli zainstalowano oprogramowanie SOLIDWORKS przy użyciu dysków, dla przywrócenia pakietu Service Pack niezbędne są pierwotne dyski. Konieczne jest zapisanie kopii wcześniejszego obrazu administracyjnego.

Obrazy administracyjne, które zostały uaktualnione nie mogą zostać przywrócone do poprzedniego pakietu Service Pack. Obrazy administracyjne utworzone przy pomocy jakiejkolwiek metody innej niż Menedżer instalacji SOLIDWORKS nie mogą zostać przywrócone do poprzedniej wersji. Klienty zainstalowane z tych obrazów administracyjnych muszą zostać odinstalowane, a następnie ponownie zainstalowane przy użyciu obrazu administracyjnego utworzonego z poprzedniej wersji.
  1. Usunąć folder zawierający bieżącą wersję obrazu administracyjnego. W tym celu należy otworzyć okno Wiersz polecenia i wpisać:
    rmdir /s/qścieżka_do_bieżącego_obrazu_administracyjnego
  2. Przenieść kopię zapasową obrazu administracyjnego do lokalizacji, z której usunęliśmy bieżący obraz administracyjny. W tym celu należy otworzyć okno Wiersz polecenia i wpisać:
    moveścieżka_do_zapasowego_obrazu_administracyjnego ścieżka_do_bieżącego_obrazu_administracyjnego
    Po przywróceniu poprzedniego obrazu administracyjnego, komputery klienty są przywracane automatycznie przy najbliższym uruchomieniu oprogramowania SOLIDWORKS.
Temat nadrzędny Zarządzanie aktualizacjami produktów Service Pack


SOLIDWORKS PDM i SOLIDWORKS Manage

SOLIDWORKS PDM to produkt do zarządzania dokumentami oparty na tej samej architekturze klient/serwer co program znany wcześniej pod nazwą SOLIDWORKS Enterprise PDM. Program SOLIDWORKS PDM jest dostępny w dwóch wersjach:
  • SOLIDWORKS PDM Standard
  • SOLIDWORKS PDM Professional

Program SOLIDWORKS PDM używa bazy danych Microsoft SQL Server do zarządzania przechowalnią plików.

Tabela ta zawiera listę systemów baz danych, składników serwera i opcji klienta dostępnych dla każdej wersji.
 | PDM Standard | PDM Professional
Przeznaczenie | Małe i średnie sieci biurowe, z reguły do 20 jednoczesnych użytkowników. | Duże sieci biurowe, duża liczba jednoczesnych użytkowników
Ograniczenia | O parametrach nie wyższych niż 1 procesor lub 4 rdzenie, 1 GB pamięci RAM, baza danych o wielkości 10 GB | Ograniczenia Standardu SQL: O parametrach nie wyższych niż 4 procesory lub 16 rdzeni, 128 GB pamięci RAM, baza danych o wielkości 524 PB
System zarządzania bazą danych | Microsoft SQL Server Express 2019 lub nowszy, do wersji 2022. | Microsoft SQL Server 2019 lub nowszy, do wersji 2022,.
Wymaga SolidNetWork License Manager? | Tak | Tak
Zawiera serwer archiwum i serwer bazy danych? | Tak | Tak
Czy obejmuje serwer Web2 i serwer WebAPI SOLIDWORKS PDM? | Nie | Tak
Typy klientów | Natywny | Natywny, oparty na przeglądarce
Dodatki klienta dla konfiguracji CAD Editor | SOLIDWORKS, DraftSight | SOLIDWORKS DraftSight, Integracja z Microsoft Office
Dodatki klienta dla konfiguracji Contributor | DraftSight | DraftSight, Integracja z Microsoft Office
Dodatki klienta dla konfiguracji Viewer |  | Integracja z Microsoft Office

Program SOLIDWORKS Manage Professional zawiera zaawansowane narzędzia do zarządzania danymi dla programu SOLIDWORKS PDM Professional. Oferuje funkcje zaawansowanej kontroli wersji, obsługi projektu, procesu i zarządzania elementami. Interaktywne pulpity nawigacyjne i raporty pozwalają śledzić elementy, czynności i postępy w realizacji projektów.

Program SOLIDWORKS Manage Professional ma podobną architekturę jak SOLIDWORKS PDM Professional. Wykorzystuje architekturę klient-serwer z bazą danych Microsoft SQL Server do zarządzania danymi elementów i projektów. Istnieją trzy usługi dla funkcji bazy danych, serwera plików i serwera sieci Web, które obsługują zarówno klientów pełnych, jak i klientów przeglądarki internetowej. Te trzy usługi mogą znajdować się na tym samym serwerze lub na oddzielnych serwerach. Użytkownicy z licencją SOLIDWORKS Manage Professional Editor mogą użyć dodatku SOLIDWORKS Manage, aby uzyskać dostęp do danych składnika Manage bezpośrednio z poziomu oprogramowania SOLIDWORKS.

Aby zainstalować serwer i klienta SOLIDWORKS Manage Professional, można użyć menedżera instalacji SOLIDWORKS.

Instrukcje dotyczące instalacji SOLIDWORKS Manage Professional można znaleźć w Przewodniku instalacji SOLIDWORKS PDM/SOLIDWORKS Manage.

Spis treści

  • Lista składników serwera PDM

  • Różnice pomiędzy klientami PDM

    Przed zainstalowaniem oprogramowania klienckiego trzeba określić, jakie klienty będą potrzebne w danym środowisku PDM.

  • Przed zainstalowaniem programu PDM Server

    Wymagania, które muszą zostać spełnione, aby można było zainstalować składniki serwera PDM:

  • Instalowanie serwera PDM za pomocą Menedżera instalacji SOLIDWORKS

    W przypadku instalacji serwera PDM dla oprogramowania PDM Standard można zainstalować na tym samym komputerze serwer archiwum, serwer bazy danych oraz klienta PDM CAD Editor. Nie jest konieczne oddzielne uruchamianie instalacji klienta.

  • Instalowanie klienta PDM za pomocą Menedżera instalacji SOLIDWORKS


Lista składników serwera PDM

Ta tabela zawiera zestawienie składników serwera SOLIDWORKS PDM.

Serwer | Function | Instalacja
Microsoft SQL Server Express dla PDM Standard | Zarządza danymi w przechowalni danych SOLIDWORKS PDM. | Można zainstalować ten program wraz z PDM Standard albo skorzystać z wersji wcześniej licencjonowanej i zainstalowanej.
Microsoft SQL Server dla PDM Professional | Zarządza danymi w przechowalni danych SOLIDWORKS PDM. | Wymagane. Można również użyć wersji wcześniej licencjonowanej i zainstalowanej.
Klient SolidNetWork License Manager | Zarządza licencjami SOLIDWORKS PDM. | Zainstalowanie tego produktu jest warunkiem tworzenia nowych przechowalni. W przypadku użycia Menedżera instalacji SOLIDWORKS może zostać zainstalowany wraz z komponentami serwera SOLIDWORKS PDM.
Serwer archiwum | Zarządza transferami plików pomiędzy klientami i archiwum przechowalni plików oraz użytkownikami i ich danymi uwierzytelniania. | Wymagane. Instalacja wraz z PDM Standard lub Professional.
Serwer bazy danych | Sprawdza bazy danych PDM pod kątem aktualizacji, zarządza regułami importowania i eksportowania danych, zarządza systemem komunikatów i planuje replikację oraz działanie chłodni. | Wymagane. Instalacja wraz z PDM Standard lub Professional.
Serwer Web2 | Zapewnia dostęp do przechowalni plików przez Internet z klientów opartych na przeglądarkach. | Opcjonalne. Instalacja tylko z PDM Professional.
Serwer Web API | Użytkownicy programu EXALEAD OnePart mogą korzystać z serwera Web API w celu indeksowania i pobierania danych SOLIDWORKS PDM. | Opcjonalne. Instalacja tylko z PDM Professional.

Serwery archiwum uruchamiają się jako usługi na koncie systemowym komputera, na którym są zainstalowane. Na jednym serwerze archiwum (na tym samym komputerze) może znajdować się wiele przechowalni plików.

W środowisku autonomicznym serwer archiwum, serwer bazy danych, serwer licencji i serwer Web API, jak również SQL Express lub bazę danych SQL Server, można zainstalować na tym samym komputerze.

W środowisku rozproszonym komponenty serwera mogą znajdować się na różnych komputerach. SOLIDWORKS PDM Professional obsługuje również replikację archiwów przechowalni plików i bazy danych serwera SQL w celu poprawy wydajności w odległych lokalizacjach. Aby uzyskać więcej informacji, patrz: Przewodnik replikacji SOLIDWORKS PDM Professional.

Temat nadrzędny SOLIDWORKS PDM i SOLIDWORKS Manage


Różnice pomiędzy klientami PDM

Przed zainstalowaniem oprogramowania klienckiego trzeba określić, jakie klienty będą potrzebne w danym środowisku PDM.

Ta tabela zawiera zestawienie klientów programu SOLIDWORKS PDM Standard:
Klient typu Standard | Opis
CAD Editor | Wspiera pracę z plikami SOLIDWORKS, DWG/DXF, Microsoft Word i Microsoft Excel. Wszystkie formaty plików obsługiwane przez wtyczkę pakietu Office zachowują się w ten sam sposób w programie SOLIDWORKS PDM Standard; wyjątek stanowi funkcja Podgląd.
Contributor | Wspiera pracę z plikami SOLIDWORKS, DWG/DXF, Microsoft Word i Microsoft Excel.
Viewer | Zapewnia dostęp w trybie „tylko do odczytu” do przechowalni plików. Użytkownik może wykonywać przejścia plików w toku prac, ale nie może dodawać ani modyfikować plików (dokonywać ich wyewidencjonowania, zaewidencjonowania czy aktualizacji wartości).
Ta tabela zawiera zestawienie klientów programu SOLIDWORKS PDM Professional:
Klient typu Professional | Opis
CAD Editor & Web | Wspiera pracę z plikami wszystkich typów, w tym zaawansowane zarządzanie i przegląd formatów CAD, takich jak SOLIDWORKS. Dodatki CAD zapewniają użytkownikom dostęp do oprogramowania SOLIDWORKS PDM Professional z aplikacji CAD. Zdalni użytkownicy mogą przeszukiwać przechowalnie i wykonywać podstawowe funkcje poprzez Internet za pośrednictwem klientów Web2.
Contributor & Web | Wspiera pracę ze wszystkimi typami plików, w tym plikami CAD. Jednakże ten typ klienta nie ma wsparcia dla dodatków CAD. Zdalni użytkownicy mogą przeszukiwać przechowalnie i wykonywać podstawowe funkcje poprzez Internet za pośrednictwem klientów Web2.
Viewer | Zapewnia dostęp w trybie „tylko do odczytu” do przechowalni plików. Użytkownik może wykonywać przejścia plików w toku prac, ale nie może dodawać i modyfikować plików (dokonywać ich wyewidencjonowania, zaewidencjonowania czy aktualizacji wartości) ani używać dodatków CAD.
Temat nadrzędny SOLIDWORKS PDM i SOLIDWORKS Manage


Przed zainstalowaniem programu PDM Server

Wymagania, które muszą zostać spełnione, aby można było zainstalować składniki serwera PDM:

  • Uzyskać pełne uprawnienia administracyjne do komputerów, na których mają zostać zainstalowane serwery i klienty.
  • Upewnić się, że serwer bazy danych ma dostęp do serwera archiwum za pośrednictwem portu TCP 3030 oraz do serwera SQL za pośrednictwem portu TCP 1433.
  • Jeśli ma zostać użyta istniejąca baza danych SQL Server Express lub SQL Server, należy uzyskać nazwę bazy danych SQL Server oraz identyfikator konta i hasło administratora programu SQL Server lub właściciela bazy danych z dostępem do odczytu/zapisu do bazy danych. Nie można użyć użytkownika tew.
  • Jeśli klient PDM jest już zainstalowany w systemie, należy go odinstalować. W przypadku, gdy serwer PDM i klient PDM mają się znajdować w tym samym systemie, można je oba zainstalować ze strony Produkty serwera w Menedżerze instalacji SOLIDWORKS.
Temat nadrzędny SOLIDWORKS PDM i SOLIDWORKS Manage


Instalowanie serwera PDM za pomocą Menedżera instalacji SOLIDWORKS

W przypadku instalacji serwera PDM dla oprogramowania PDM Standard można zainstalować na tym samym komputerze serwer archiwum, serwer bazy danych oraz klienta PDM CAD Editor. Nie jest konieczne oddzielne uruchamianie instalacji klienta.

W przypadku instalacji serwera PDM dla oprogramowania PDM Professional można uwzględnić te składniki, a także serwer Web2 i serwer Web API.

Aby zainstalować serwer PDM i jego składniki:

  1. Uruchomić Menedżera instalacji SOLIDWORKS.
  2. Na Stronie powitalnej wybrać Zainstaluj komponenty serwera i kliknąć następujące opcje:
    • Instalowanie składników serwera programu SOLIDWORKS PDM na tym komputerze.
    • Instalowanie SolidNetWork License Manager na tym komputerze.

      Jeżeli na tym lub innym komputerze zainstalowano oprogramowanie SolidNetWork License Manager, opcja ta nie jest dostępna.

  3. Jeśli zostanie wyświetlona strona Opcje SolidNetwork License Manager, wpisać numer seryjny oraz określić lokalizację katalogu, a następnie kliknąć Dalej.
  4. Zastosować się do instrukcji dotyczących ostrzeżeń systemowych i kliknąć Dalej.
  5. Na stronie Podsumowanie, w obszarze Serwer SOLIDWORKS PDM, kliknąć Zmień.
  6. Na stronie Opcje serwera SOLIDWORKS PDM:
    1. W obszarze Wybierz produkt serwerowy kliknąć SOLIDWORKS PDM Standard lub Professional.
    2. W obszarze Lokalizacja instalacji kliknąć Przeglądaj, aby określić ścieżkę pliku.
    3. W obszarze Wybierz operacje:
      1. Kliknąć Serwer archiwum, Serwer bazy danych i Klient, aby zainstalować te składniki na tym samym komputerze. W środowisku rozproszonym można zainstalować serwer archiwum i serwer bazy danych przez uruchomienie Menedżera instalacji na innym komputerze.
        • Jeśli klient PDM jest już zainstalowany na komputerze, anulować instalację i odinstalować klienta. Następnie można uruchomić Menedżera instalacji SOLIDWORKS w celu zainstalowania serwera PDM wraz z klientem.
        • Komponent klienta SOLIDWORKS PDM, włączony w wersję SOLIDWORKS PDM instalowaną z serwera, zawiera narzędzie Eksplorator elementów, które również należy zainstalować.
      2. W przypadku instalacji oprogramowania w wersji PDM Professional można również kliknąć Serwer Web2 i Serwer Web API.
        Jeśli instalowany jest serwer Web API, można w polu Numer portu HTTP podać wartość z zakresu od 0 do 65535. Wartość domyślna to 65453.
    4. W obszarze Serwer SQL można zainstalować nowe wystąpienie narzędzi bazy danych dostarczonych wraz z serwerem PDM (SQL Server Express dla PDM Standard). Alternatywnie można określić nazwę bazy danych, nazwę użytkownika i hasło dla istniejącego wystąpienia.
      Pełna wersja programu SQL Server musi zostać zainstalowana w przypadku SOLIDWORKS PDM Professional.
    5. Kliknąć Powrót do podsumowania.
  7. Na stronie Podsumowanie zaakceptować warunki umowy licencyjnej SOLIDWORKS i kliknąć Zainstaluj teraz.

    Po zakończeniu instalacji przez Menedżera instalacji SOLIDWORKS uruchamiane jest narzędzie Konfiguracja serwera archiwum. Postępować zgodnie z monitami kreatora w celu skonfigurowania serwera archiwum.

Aby ustawić, skonfigurować lub rozwiązywać problemy związane z serwerem archiwum, serwerem bazy danych, serwerem Web2 i bazami danych SQL Server, należy zapoznać się z odpowiednimi tematami w Podręczniku instalacji SOLIDWORKS PDM.

Spis treści

  • Modyfikowanie instalacji oprogramowania SOLIDWORKS PDM Server

Temat nadrzędny SOLIDWORKS PDM i SOLIDWORKS Manage


Modyfikowanie instalacji oprogramowania SOLIDWORKS PDM Server

Aby zmodyfikować instalację oprogramowania SOLIDWORKS PDM Server i jej składniki, należy użyć opcji Programy i funkcje z Panelu sterowania systemu Windows. Nie można modyfikować instalacji przy użyciu Menedżera instalacji SOLIDWORKS (SLDIM), nawet wówczas, gdy sposób ten wykorzystano do instalacji oprogramowania SOLIDWORKS PDM Server.

Temat nadrzędny Instalowanie serwera PDM za pomocą Menedżera instalacji SOLIDWORKS


Instalowanie klienta PDM za pomocą Menedżera instalacji SOLIDWORKS

Wersja główna klienta SOLIDWORKS PDM musi odpowiadać wersji głównej serwera SOLIDWORKS PDM. Podczas instalowania lub uaktualniania klienta SOLIDWORKS PDM należy się upewnić, że wersje są zgodne.

Aby zainstalować klienta PDM:

  1. Uruchomić Menedżera instalacji SOLIDWORKS.
  2. Na stronie Powitalnej wybrać Zainstaluj na tym komputerze.
  3. Na stronie Numer seryjny kliknąć Dalej.
    Klienty SOLIDWORKS PDM nie wymagają osobnego numeru seryjnego.
  4. Zastosować się do instrukcji dotyczących ostrzeżeń systemowych i kliknąć Dalej.
  5. Na stronie Podsumowanie, w obszarze Produkty, kliknąć Zmień.
  6. Na stronie Wybór produktu kliknąć Wybierz różne pakiety lub produkty.
  7. W oknie dialogowym Wybierz pakiet, który chcesz pokazać wybrać odpowiednią wersję oprogramowania SOLIDWORKS. Następnie kliknąć OK.
  8. Na stronie Wybór produktu wybrać Klient programu SOLIDWORKS PDM. Następnie wybrać eDrawings, aby włączyć funkcję podglądu PDM. Jeżeli używana jest wersja SOLIDWORKS PDM Professional, można również wybrać pozycję Eksplorator elementów.
  9. Na stronie Podsumowanie rozwinąć Opcje SOLIDWORKS PDM i kliknąć Zmień.
  10. Na stronie Opcje klienta programu SOLIDWORKS PDM wybrać następujące elementy i kliknąć Powrót do podsumowania:
    • Typ produktu PDM
    • Typ klienta PDM
    • Dodatki
  11. Na stronie Podsumowanie zaakceptować warunki umowy licencyjnej SOLIDWORKS i kliknąć Zainstaluj teraz.
Administratorzy mogą również użyć Edytora opcji obrazu administracyjnego, aby utworzyć i rozmieścić obrazy klientów PDM. Szczegółowe informacje zawiera temat Używanie obrazów administracyjnych.
Temat nadrzędny SOLIDWORKS PDM i SOLIDWORKS Manage


SOLIDWORKS Electrical

Menedżer instalacji SOLIDWORKS umożliwia zainstalowanie wszystkich komponentów SOLIDWORKS Electrical w trybie autonomicznym lub w trybie klient/serwer.

SOLIDWORKS Electrical używa kilku komponentów. Podczas instalacji należy wybrać te komponenty zgodnie z żądanym typem instalacji.
  • SOLIDWORKS Electrical Schematic - aplikacja 2D do tworzenia schematów elektrycznych i zarządzania nimi.
  • SOLIDWORKS Electrical 3D - dodatek SOLIDWORKS do integrowania schematów 2D z modelami 3D. SOLIDWORKS Electrical 3D umożliwia zarządzanie rozmieszczeniem aparatów elektrycznych oraz wyznaczanie tras przewodów, kabli i wiązek.
  • Dane — Dane grupują wszystkie dane wymagane przez oprogramowanie. Są to dane graficzne (na przykład pliki przedstawiające symbole i tabelki rysunkowe) lub techniczne (na przykład katalogi producenta i dane związane z symbolami). Dane można udostępniać, aby były dostępne dla wszystkich użytkowników.
  • Collaborative Server — Program narzędziowy do zarządzania otwieraniem i aktualizowaniem rysunków elektrycznych.
  • SQL Server — SOLIDWORKS Electrical wymaga bazy danych programu Microsoft SQL Server. Podczas instalacji należy utworzyć nową bazę danych lub użyć istniejącej.

Typ instalacji

Można zainstalować wszystkie komponenty SOLIDWORKS Electrical na tym samym komputerze. Jest to instalacja autonomiczna. Wszystkie dane programu, takie jak rysunki projektu i raporty, są przechowywane na stacji roboczej.

Można również zainstalować komponenty SOLIDWORKS Electrical jako aplikacje typu klient/serwer. Ten typ instalacji umożliwia przechowywanie danych na serwerze sieciowym. Instalacja klient/serwer pozwala kilku użytkownikom pracować nad tym samym projektem. Systemy klienckie muszą mieć dostęp sieciowy do serwera i uprawnienia do odczytu/zapisu w celu tworzenia projektów, bibliotek i symboli.

Informacje

Niezależnie od typu instalacji (autonomiczna lub klient/serwer) należy uruchomić sesję systemu Windows z pełnymi uprawnieniami, aby zainstalować SOLIDWORKS Electrical.

Na danym komputerze można zainstalować tylko jedną wersję SOLIDWORKS Electrical. W przypadku instalowania SOLIDWORKS i wybrania SOLIDWORKS Electrical jako jednego z produktów do zainstalowania, program instalacyjny usunie starą wersję SOLIDWORKS Electrical.

Po uruchomieniu menedżer instalacji SOLIDWORKS automatycznie wykrywa istniejące wersje SOLIDWORKS Electrical zainstalowane na stacji roboczej lub na serwerze.

Przed zainstalowaniem nowej wersji należy zawsze utworzyć kopię zapasową istniejącego środowiska SOLIDWORKS Electrical. W SOLIDWORKS Electrical Schematic należy wybrać Plik > Archiwizuj środowisko, lub w SOLIDWORKS Electrical 3D SOLIDWORKS Electrical > Narzędzia > Archiwizuj środowisko:.

Spis treści

  • Wymagania dotyczące instalacji SOLIDWORKS Electrical

  • Instalacja autonomiczna lub instalacja klient/serwer

    SOLIDWORKS Electrical można zainstalować w dwóch trybach. W trybie autonomicznym oprogramowanie zostanie zainstalowane na stacji roboczej. W trybie klient/serwer użytkownicy współużytkują dane.

  • Konfigurowanie usługi Collaborative Server

  • Konfigurowanie programu Microsoft SQL Server

  • Określenie lokalizacji danych


Wymagania dotyczące instalacji SOLIDWORKS Electrical

Aby uzyskać dostęp do aktualnych ustawień systemu, patrz sekcja Wymagania systemu.

Temat nadrzędny SOLIDWORKS Electrical
Instalacja autonomiczna lub instalacja klient/serwer
Konfigurowanie usługi Collaborative Server
Konfigurowanie programu Microsoft SQL Server
Określenie lokalizacji danych


Instalacja autonomiczna lub instalacja klient/serwer

SOLIDWORKS Electrical można zainstalować w dwóch trybach. W trybie autonomicznym oprogramowanie zostanie zainstalowane na stacji roboczej. W trybie klient/serwer użytkownicy współużytkują dane.

SOLIDWORKS Electrical musi zawsze łączyć się z wystąpieniem SQL Server.

Temat nadrzędny SOLIDWORKS Electrical
Wymagania dotyczące instalacji SOLIDWORKS Electrical
Konfigurowanie usługi Collaborative Server
Konfigurowanie programu Microsoft SQL Server
Określenie lokalizacji danych

Stand-Alone: Instalacja

Przy pierwszej instalacji KONIECZNE jest zainstalowanie wszystkich komponentów na stacji roboczej.

  • SOLIDWORKS Electrical Schematic
  • SOLIDWORKS Electrical 3D
  • Collaborative Server
  • Dane aplikacji
  1. Na karcie Podsumowanie kliknąć Zmień w sekcji Wybór produktu i zaznaczyć wszystkie komponenty SOLIDWORKS Electrical.
  2. Aby zmodyfikować opcje instalacji, na karcie Podsumowanie, kliknąć Zmień w sekcji Opcje programu Electrical. Możliwe jest utworzenie nowego wystąpienia programu SQL Server lub użycie istniejącego. Szczegółowe informacje można znaleźć w poszczególnych rozdziałach niniejszego dokumentu dotyczących danych i Microsoft SQL Server. W przeciwnym razie należy zachować opcje domyślne.
  3. Kliknąć Zainstaluj teraz, aby kontynuować.
Jeżeli program SOLIDWORKS Electrical jest już zainstalowany na stacji roboczej, Menedżer instalacji SOLIDWORKS automatycznie znajdzie go i wyświetli monit o jego aktualizację. Zainstalować wszystkie komponenty bez zmieniania menu Opcje programu Electrical.

Instalacja klient/serwer

Instalacja klient/serwer umożliwia współużytkowanie danych przez wielu użytkowników.

Na serwerze należy zainstalować następujące komponenty:
  • Collaborative Server
  • Dane aplikacji
  • SQL Server
Na urządzeniach klienckich należy zainstalować następujące komponenty:
  • SOLIDWORKS Electrical Schematic
  • SOLIDWORKS Electrical 3D
  1. Na serwerze należy zainstalować komponenty serwera:
  2. Na karcie Witamy w Menedżerze instalacji SOLIDWORKS kliknąć Zainstaluj komponenty serwera.
  3. Wybrać opcję SOLIDWORKS Electrical.
  4. Na karcie Podsumowanie można zmodyfikować opcje instalacji. Szczegółowe informacje można znaleźć w poszczególnych rozdziałach niniejszego dokumentu dotyczących danych i Microsoft SQL Server. W przeciwnym razie należy zachować opcje domyślne.
  5. Kliknąć Zainstaluj teraz, aby kontynuować.
  6. Na urządzeniach klienckich należy zainstalować aplikacje.
  7. Na karcie Witamy w Menedżerze instalacji SOLIDWORKS kliknąć Zainstaluj na tym komputerze.
  8. Na karcie Podsumowanie kliknąć Zmień w sekcji Wybór produktu i usunąć zaznaczenie opcji Serwer Electrical.
  9. Na karcie Podsumowanie kliknąć Zmień w sekcji Opcje programu Electrical i zmienić ustawienia połączenia z serwerem.
  10. Kliknąć Zainstaluj teraz, aby kontynuować.
Jeżeli program SOLIDWORKS Electrical jest już zainstalowany na stacji roboczej lub na serwerze, Menedżer instalacji SOLIDWORKS automatycznie znajdzie go i wyświetli monit o jego aktualizację. Aby zaktualizować oprogramowanie, należy wykorzystać ten sam proces, co przy pierwszej instalacji.


Konfigurowanie usługi Collaborative Server

Collaborative Server jest usługą systemu Windows, która musi być uruchomiona przez cały czas i mieć zapewnioną stałą, nieprzerwaną komunikację dwukierunkową z klientami przez zapory i skanery antywirusowe.

Aby skonfigurować usługę Collaborative Server w trybie indywidualnym lub serwerowym, należy określić następujące parametry:
  • Nazwa komputera (na przykład LOCALHOST lub MójKomputer) lub jego adres IP (na przykład 127.0.0.1 lub 192.168.999.999).
  • Numer portu (domyślnie 26666).

Usługę Collaborative Server można skonfigurować podczas instalacji lub później, korzystając z polecenia Narzędzia > Ustawienia aplikacji.

Aby zapewnić nieprzerwaną komunikację dwukierunkową, należy upewnić się, że numery portów od 26666 do 26676 (gdy jednocześnie podłączonych jest 10 użytkowników) są dostępne w systemie, na którym jest zainstalowany Collaborative Server. W przeciwnym razie należy poprosić administratora systemu o znalezienie innego portu dla SOLIDWORKS Electrical.

Temat nadrzędny SOLIDWORKS Electrical
Wymagania dotyczące instalacji SOLIDWORKS Electrical
Instalacja autonomiczna lub instalacja klient/serwer
Konfigurowanie programu Microsoft SQL Server
Określenie lokalizacji danych


Konfigurowanie programu Microsoft SQL Server

Upewnić się, że wystąpienie bazy danych programu SQL Server jest dostępna dla dowolnego typu instalacji SOLIDWORKS Electrical. Można użyć istniejącej bazy danych programu SQL Server, jeżeli jest już zainstalowana w systemie, lub zainstalować nowe wystąpienie jako część instalacji SOLIDWORKS Electrical.

Podczas instalowania nowej instancji programu SQL Server instalacja SOLIDWORKS udostępnia bezpłatną wersję programu Microsoft SQL Express 2022. Ta wersja jest ograniczona do 1 procesora, 1 GB pamięci i 10 GB danych. Ograniczenia związane z pamięcią i procesorem są wystarczające do obsługi 10 jednoczesnych użytkowników.

Jeżeli jest instalowana wersja SQL Express 2022, należy upewnić się, że oprogramowanie serwera i sprzęt spełniają wymagania wymienione w sekcji Wymagania systemowe.

Najlepszą praktyką jest zakup i instalacja pełnej wersji programu SQL Server, jeśli na tym samym serwerze pracuje więcej niż 10 użytkowników jednocześnie. Należy użyć przepływu pracy opisanego dla instalacji SOLIDWORKS Electrical z istniejącym wystąpieniem programu SQL Server.

Aby uzyskać informacje na temat programu SQL Express 2022, należy zapoznać się z dokumentacją Microsoft SQL Server.

Temat nadrzędny SOLIDWORKS Electrical
Wymagania dotyczące instalacji SOLIDWORKS Electrical
Instalacja autonomiczna lub instalacja klient/serwer
Konfigurowanie usługi Collaborative Server
Określenie lokalizacji danych

Zarządzanie danymi w SOLIDWORKS Electrical

Wiele programów używa pojedynczej bazy danych, która zawiera wszystkie dane programu. Nie jest tak w przypadku SOLIDWORKS Electrical. Każdy projekt w SOLIDWORKS Electrical ma przypisany unikalny numer identyfikacyjny i każdy projekt posiada skojarzoną bazę danych, która może być zidentyfikowana na podstawie unikalnego numeru identyfikacyjnego. Na przykład jeśli w menedżerze projektu SOLIDWORKS Electrical znajduje się projekt o identyfikatorze 112, wówczas skojarzona baza danych ma nazwę „tew_project_data_112”.

Powodem wprowadzenia unikatowych baz danych dla każdego projektu jest to, że znacząco skraca to czas przetwarzania. Również w przypadku krytycznej awarii bazy danych tylko jeden projekt podlega usterce, a większość informacji o programie zachowuje integralność.

Jednak w niektórych firmach obowiązują zasady zabraniające tworzenia nowych baz danych. Aby uruchomić SOLIDWORKS Electrical, nie mogą występować żadne ograniczenia dotyczących tworzenia nowych baz danych przez użytkowników. Należy sprawdzić za pomocą systemu lub administratora bazy danych, aby upewnić się, że żadne ustawienia konfiguracyjne nie uniemożliwiają użytkownikom tworzenia nowych baz danych.

Nowe wystąpienia programu SQL Server

W przypadku instalowania nowego wystąpienia programu SQL Server należy posiadać pełne uprawnienia administracyjne do serwera, jak również do wszystkich systemów klientów. Należy również upewnić się, że klienty mają uprawnienia do odczytu/zapisu do bazy danych, dzięki czemu mogą tworzyć i modyfikować projekty, biblioteki symboli i inne dane projektów.

Podczas instalacji nowej wystąpienia programu SQL Server należy wybrać nazwę inną niż domyślna.

Istniejące wystąpienia programu SQL Server

Wymagane jest konto, które ma pełne uprawnienia administracyjne do bazy danych programu SQL Server w celu zainstalowania nowych baz danych SOLIDWORKS Electrical lub do łączenia się z SOLIDWORKS Electrical w istniejącym wystąpieniu programu SQL Server.

Aby SOLIDWORKS Electrical działał prawidłowo, należy włączyć uwierzytelnianie programu SQL Server dla trybu mieszanego. Uwierzytelnianie dla trybu mieszanego umożliwia używanie poświadczeń systemu Windows lub programu SQL Server.

Aby połączyć się z istniejącą bazą danych programu SQL Server, można użyć uwierzytelniania systemu Windows lub programu SQL Server. Należy wprowadzić nazwę użytkownika i hasło dla systemu Windows lub login programu SQL Server dające pełne uprawnienia administracyjne w programie SQL Server.

Nie można użyć użytkownika „tew”, aby połączyć się z serwerem SQL Server w celu dokonania instalacji. Skontaktuj się z administratorem programu SQL Server lub administratorem systemu, aby uzyskać pomoc w uzyskaniu loginu z odpowiednimi poświadczeniami dla programu SQL Server.

Bazy danych SOLIDWORKS Electrical

Po zainstalowaniu SOLIDWORKS Electrical program instalacyjny utworzy następujące bazy danych w instancji SQL Server.

  • TEW_APP_DATA
  • TEW_APP_MACRO
  • TEW_APP_PROJECT
  • TEW_CATALOG
  • TEW_CLASSIFICATION


Określenie lokalizacji danych

Dla lokalizacji danych należy wybrać katalog, w którym mają być przechowywane dane programu, takie jak części, szablony, symbole 2D i 3D. Lokalizacja ta musi być dedykowanym katalogiem. Nie może to być katalog główny ani katalog używany do przechowywania danych SOLIDWORKS.

Domyślny katalog to C:\ProgramData\SOLIDWORKS Electrical.

W przypadku instalacji klient/serwer należy udostępnić katalog Data.

Program instalacyjny tworzy nowy folder o nazwie Update w katalogu domyślnym, w którym przechowywane są wszystkie nowe dane.

Przy pierwszym uruchomieniu SOLIDWORKS Electrical program automatycznie scala dane przechowywane w folderze Update z istniejącymi danymi. Kreator Aktualizacja danych umożliwia wybranie danych do dodania do aplikacji i do bazy danych SQL Server.

Temat nadrzędny SOLIDWORKS Electrical
Wymagania dotyczące instalacji SOLIDWORKS Electrical
Instalacja autonomiczna lub instalacja klient/serwer
Konfigurowanie usługi Collaborative Server
Konfigurowanie programu Microsoft SQL Server


SOLIDWORKS Visualize i SOLIDWORKS Visualize Boost

SOLIDWORKS® Visualize zawiera pakiet autonomicznych narzędzi, które łączą w sobie zaawansowane możliwości renderowania z funkcjami wizualizacji i tokami prac zorientowanymi na projektowanie, dzięki czemu umożliwiają tworzenie bardzo realistycznych obrazów modeli CAD 3D.

Produkty SOLIDWORKS Visualize są dostępne w dwóch pakietach:
  • Standard
  • Professional

Bezpłatna licencja na narzędzie SOLIDWORKS Visualize Standard jest częścią każdej licencji w ramach aktywnej subskrypcji SOLIDWORKS Professional i Premium. W przypadku klientów posiadających aktywację autonomiczną SOLIDWORKS potrzebny jest dodatkowy numer seryjny. Jeśli nie znasz numeru seryjnego SOLIDWORKS Visualize, skontaktuj się z administratorem SOLIDWORKS lub sprzedawcą.

Program SOLIDWORKS Visualize obsługuje również modele licencjonowania SolidNetWork Licensing (SNL), np. z licencjami ruchomymi, i aktywacje w trybie offline.

Przy użyciu Menedżera instalacji SOLIDWORKS (SLDIM) można zainstalować SOLIDWORKS Visualize w ramach instalacji Indywidualnej (Zainstaluj na tym komputerze). Można zainstalować program jako aplikację autonomiczną, co przydaje się, gdy do modelowania i renderowania mają być używane różne komputery. Nie używa ono licencji SOLIDWORKS.

SOLIDWORKS Visualize Boost to usługa, która umożliwia przydzielenie zadania renderowania jednemu lub wielu komputerom w tej samej sieci, w której znajduje się komputer z oprogramowaniem SOLIDWORKS Visualize Professional. Na komputerze można wykonywać inne zadania w trakcie renderowania obrazu, a ostatecznie zrenderowane obrazy będą dostępne wcześniej. Narzędzie Visualize Boost można także zainstalować w ramach indywidualnej instalacji (Zainstaluj na tym komputerze) z użyciem menedżera instalacji SOLIDWORKS.

Bezpłatna licencja na narzędzie SOLIDWORKS Visualize Boost jest częścią każdej aktywnej subskrypcji SOLIDWORKS Visualize Professional.
Narzędzie Visualize Boost jest dodatkiem tylko do produktu Visualize Professional. Narzędzie Visualize Boost nie działa w przypadku wersji Visualize Standard.

Spis treści

  • Wymagania systemowe dla SOLIDWORKS Visualize

  • Instalowanie SOLIDWORKS Visualize za pomocą Menedżera instalacji SOLIDWORKS

  • Instalowanie Visualize Boost za pomocą Menedżera instalacji SOLIDWORKS


Wymagania systemowe dla SOLIDWORKS Visualize

Aby uzyskać optymalną wydajność i konfigurację oprogramowania SOLIDWORKS Visualize i SOLIDWORKS Visualize Boost, przed instalacją należy wykonać następujące czynności:
  • Przed zainstalowaniem oprogramowania SOLIDWORKS Visualize i SOLIDWORKS Visualize Boost należy upewnić się, że dla każdego produktu istnieje osobny numer seryjny.
  • Upewnić się, że każdy komputer, na którym pracuje SOLIDWORKS Visualize lub SOLIDWORKS Visualize Boost, spełnia wymagania określone w sekcji Wymagania systemowe.
  • Zainstalować aplikację SOLIDWORKS Visualize Boost na dedykowanych komputerach renderowania w tej samej sieci. Powinny to być inne komputery niż te, na których pracuje oprogramowanie SOLIDWORKS Visualize Professional, w celu odciążenia zadań renderowania.
  • Jeśli nie zostanie znaleziony odpowiedni procesor graficzny, SOLIDWORKS Visualize oraz SOLIDWORKS Visualize Boost domyślnie ustawią się na jednostkę centralną (CPU). Aby uzyskać więcej informacji na temat określonych kart graficznych i sterowników, należy zapoznać się z tematem Certyfikacja sprzętu SOLIDWORKS.

Obsługa GPU z wykorzystaniem 3DS Stellar Physically Correct

Tryb dokładnego renderowania Stellar:
  • Karta graficzna NVIDIA oparta przynajmniej na mikroarchitekturze Maxwell
  • Zalecana wersja sterownika 538.78 z obsługą CUDA 12.2.
  • Co najmniej 4 GB pamięci wideo
Tryb szybkiego renderowania Stellar:
  • Karta graficzna NVIDIA oparta przynajmniej na mikroarchitekturze Turing (z rdzeniami RT)
  • Używa tej samej wersji sterownika i wymaganej pamięci co tryb Dokładny

Obsługa GPU z wykorzystaniem AMD ProRender

Tryb Szybki i Tryby renderowania dokładnego AMD ProRender:
  • GPU i sterownik obsługujący standard Vulkan
  • Obsługa OpenCL w wersji 1.2 lub nowszej
Temat nadrzędny SOLIDWORKS Visualize i SOLIDWORKS Visualize Boost


Instalowanie SOLIDWORKS Visualize za pomocą Menedżera instalacji SOLIDWORKS

Aby zainstalować SOLIDWORKS Visualize:

  1. Uruchomić Menedżera instalacji SOLIDWORKS.
  2. Na stronie Powitalnej wybrać Zainstaluj na tym komputerze.
  3. Wykonać następujące czynności:
    1. Na stronie Numer seryjny rozwinąć Visualization.
    2. Wybrać SOLIDWORKS Visualize i wpisać numer seryjny.
    3. Kliknąć Dalej.
  4. Zastosować się do instrukcji dotyczących ostrzeżeń systemowych i kliknąć Dalej.
  5. Na stronie Podsumowanie zaakceptować warunki umowy licencyjnej SOLIDWORKS i kliknąć Zainstaluj teraz.
Postępować zgodnie z instrukcjami kreatora aktywacji produktu, aby aktywować swój produkt.

Po aktywacji kliknąć dwukrotnie ikonę skrótu SOLIDWORKS Visualize na pulpicie, aby uruchomić aplikację lub z menu Start systemu Windows kliknąć SOLIDWORKS wersja > SOLIDWORKS Visualize wersja.

Spis treści

  • Po zakończeniu instalacji

Temat nadrzędny SOLIDWORKS Visualize i SOLIDWORKS Visualize Boost


Po zakończeniu instalacji

Po zainstalowaniu programu SOLIDWORKS Visualize należy wykonać kilka czynności, aby skonfigurować program.

Więcej informacji zawiera temat Podstawowe funkcje SOLIDWORKS Visualize w menu Pomoc programu SOLIDWORKS Visualize.

Spis treści

  • Tworzenie folderu zawartości

  • Uzyskiwanie dostępu do pomocy, samouczków, informacji o systemie oraz licencjonowaniu

Temat nadrzędny Instalowanie SOLIDWORKS Visualize za pomocą Menedżera instalacji SOLIDWORKS


Tworzenie folderu zawartości

Podczas pierwszego uruchomienia program SOLIDWORKS Visualize prosi o podanie lokalizacji do tworzenia folderu Content.

Folder Content zawiera następujące podfoldery, w których można przechowywać zasoby dla własnych projektów:
Podfolder | Przechowuje
Kamery | Kamery domyślne i zapisane przez użytkownika
Środowiska | Obrazy o szerokim zakresie dynamiki (HDR)
Palety | Obrazy płyty tylnej
Obrazy | Wizualizacje i migawki
Wyglądy | Materiały w bibliotece wyglądów Zawartość jest aktualizowana po dodaniu wyglądu do biblioteki.
Modele | Pliki modeli Domyślnie program SOLIDWORKS Visualize wyszukuje najpierw w tym folderze, gdy wobec modelu zostanie użyta opcja Plik > Importuj.
Płyty | Standardowe obrazy 2D do użycia w płytach tylnych
Projekty | Macierzyste pliki projektów w formacie .SVPJ
Tekstury | Tekstury 2D do użycia w wyglądach
Temat nadrzędny Po zakończeniu instalacji


Uzyskiwanie dostępu do pomocy, samouczków, informacji o systemie oraz licencjonowaniu

Menu Pomoc zawiera dokumentację i opcje umożliwiające aktualizację oprogramowania oraz rozwiązywanie problemów z systemem.

Pomoc Visualize | Otwiera pomoc online programu SOLIDWORKS Visualize.
Tutoriale Visualize | Otwiera MySolidWorks i umożliwia dostęp do samouczków SOLIDWORKS Visualize.
Uwagi o wersji | Wyświetla online uwagi o wersji dla bieżącej wersji.
Nowości | Wyświetla nowe funkcje produktów SOLIDWORKS.
Informacje systemowe | Dokonuje systemowego sprawdzenia oprogramowania SOLIDWORKS Visualize na komputerze i sugeruje uaktualnienia w razie potrzeby.
Sprawdź dostępność aktualizacji | Sprawdza serwer pod kątem najnowszych aktualizacji oprogramowania SOLIDWORKS Visualize.
Aktywuj licencję | (Licencje na stanowisko) Korzysta z kreatora Aktywacja produktu SOLIDWORKS w celu aktywacji produktu.
Dezaktywuj licencję | (Licencje na stanowisko) Korzysta z kreatora Aktywacja produktu SOLIDWORKS w celu dezaktywacji produktu.
SolidNetWork License Manager | Korzysta z kreatora Aktywacja produktu SOLIDWORKS w celu dezaktywacji produktu.
Informacje o Visualize | Wyświetla numer wersji i dane licencji używanej kopii programu SOLIDWORKS Visualize.
Temat nadrzędny Po zakończeniu instalacji


Instalowanie Visualize Boost za pomocą Menedżera instalacji SOLIDWORKS

Narzędzie Visualize Boost instaluje się za pomocą Menedżera instalacji SOLIDWORKS. Wymagany jest osobny numer seryjny.

Narzędzie Visualize Boost powinno być instalowane na innym komputerze niż ten, który obsługuje narzędzie SOLIDWORKS Visualize Professional. Można zmaksymalizować wydajność renderowania, instalując Visualize Boost na komputerach z wieloma jednostkami graficznymi (GPU).

Aby zainstalować SOLIDWORKS Visualize Boost:

  1. Uruchomić Menedżera instalacji SOLIDWORKS.
  2. Na stronie Powitalnej wybrać Zainstaluj na tym komputerze.
  3. Wykonać następujące czynności:
    1. Na stronie Numer seryjny rozwinąć Visualization.
    2. Wybrać SOLIDWORKS Visualize Boost i wpisać numer seryjny.
    3. Kliknąć Dalej.
  4. Zastosować się do instrukcji dotyczących ostrzeżeń systemowych i kliknąć Dalej.
  5. Na stronie Podsumowanie zaakceptować warunki umowy licencyjnej SOLIDWORKS i kliknąć Zainstaluj teraz.
Postępować zgodnie z instrukcjami kreatora aktywacji produktu, aby aktywować swój produkt.

Po aktywacji należy otworzyć aplikację, klikając dwukrotnie skrót na pulpicie SOLIDWORKS Visualize Boost [image].

Spis treści

  • Konfigurowanie Visualize Boost

    Podstawową maszynę Visualize Boost można skonfigurować jako koordynatora, a dodatkowe maszyny w klastrze renderowania jako węzły.

Temat nadrzędny SOLIDWORKS Visualize i SOLIDWORKS Visualize Boost


Konfigurowanie Visualize Boost

Podstawową maszynę Visualize Boost można skonfigurować jako koordynatora, a dodatkowe maszyny w klastrze renderowania jako węzły.

Funkcja Visualize Boost umożliwia renderowanie obrazów na jednym komputerze lub w klastrze komputerów. Konfiguracja jest prosta i intuicyjna. Główna maszyna, Koordynator, zarządza klastrem i rozprowadza zadania renderowania z SOLIDWORKS Visualize. Dodatkowe maszyny o nazwie Węzły łączą się z koordynatorem, aby pomóc w realizacji tych zadań w sieci. W farmie renderowania każda maszyna w klastrze pracuje w trybie ciągłym z funkcją Visualize Boost.

Aby skonfigurować narzędzie Visualize Boost:

  1. Otworzyć okno Visualize Boost:
    • Kliknąć dwukrotnie skrót Visualize Boost na pulpicie [image].
    • W menu Start systemu Windows kliknąć SOLIDWORKS < wersja> > SOLIDWORKS Visualize Boost <wersja>.
    Po aktywacji okno Visualize Boost identyfikuje i pokazuje nazwę i adres IP licencjonowanej maszyny.
  2. W oknie Visualize Boost kliknąć Plik > Ustawienia.
  3. W oknie dialogowym Ustawienia należy:
    1. Wybrać jedną maszynę jako Koordynatora. Podczas konfigurowania wszystkich innych Węzłów należy pozostawić pole Koordynator puste.
    2. Zaakceptować wartości domyślne 8001 dla Portu Boost i 8002 dla portu DStellar Port.
      Porty te można zaktualizować, aby spełnić wymagania sieciowe. Należy pamiętać o dodaniu wyjątków zapory dla komunikacji węzła. W przypadku pytań skontaktować się z administratorem sieci.
  4. Opcjonalne: Dodatkowe parametry obejmują:
    Opcja | Opis
    Język | Urządzenie automatycznie używa języka systemu operacyjnego.
    Motyw | Wybrać Jasne lub Ciemne tło w pozycji Motyw. To ustawienie ma wpływ na SOLIDWORKS Visualize, jeśli jest zainstalowane na tym samym urządzeniu co Visualize Boost.
    Powiadomienia włączone | Wyświetla komunikaty z DStellar.Boost w obszarze powiadomień systemu Windows.
    Eksportuj | Zapisuje ustawienia konfiguracji Visualize Boost w pliku .json.
    Import | Ładuje istniejące ustawienia do wystąpienia Visualize Boost w pliku .json.
  5. Kliknij Zastosuj.
Aby zakończyć konfigurację, zapoznać się z instrukcjami Obsługa funkcji Visualize Boost.
Temat nadrzędny Instalowanie Visualize Boost za pomocą Menedżera instalacji SOLIDWORKS


Administracja licencji

Po zainstalowaniu aplikacji SOLIDWORKS licencje można aktywować poprzez aktywowanie indywidualnych komputerów (aktywacja komputera) lub poprzez zainstalowanie i uaktywnienie ruchomych licencji na serwerze (licencje SolidNetWork).

Zwykle instalacje na indywidualnych komputerach używają aktywacji licencji, aczkolwiek można zainstalować oprogramowanie indywidualnie a następnie kontrolować licencje za pomocą programu SolidNetWork License Manager. I odwrotnie, pomimo że użytkownicy mający wiele stanowisk pracy typowo używają ruchomych licencji sieciowych, mogą oni rozmieszczać instalacje z obrazu administracyjnego a następnie aktywować numery seryjne z indywidualnych komputerów.

Spis treści

  • Administrowanie indywidualnymi licencjami

    Można określić licencję indywidualną, która będzie używała aktywacji komputera.

  • Administrowanie licencjami przy użyciu programu SolidNetWork License Manager

    Program SolidNetWork License Manager obsługuje wielu klientów licencji poprzez dystrybucję licencji do klientów za pośrednictwem sieci. Dzięki temu liczba użytkowników może przekraczać liczbę licencji poprzez użycie licencji ruchomych.


Administrowanie indywidualnymi licencjami

Można określić licencję indywidualną, która będzie używała aktywacji komputera.

Zwykle administrowanie indywidualnymi licencjami polega na aktywowaniu i dezaktywowaniu licencji bezpośrednio z oprogramowania SOLIDWORKS.

Aktywacja jest procesem licencjonowania i rejestracji licencji autonomicznego oprogramowania SOLIDWORKS (nie licencji sieciowych SolidNetWork). Zwykle, jeżeli nie aktywowano licencji dla danego produktu, oprogramowanie SOLIDWORKS podejmuje próbę jego aktywowania podczas uruchamiania tego produktu.

Wersję Co się tyczy wersji SOLIDWORKS 2022 i nowszych, jeżeli zakupiono wieczystą licencję SOLIDWORKS, należy również raz w roku reaktywować licencję. Licencja wieczysta nigdy nie wygasa, ale musi być reaktywowana. SOLIDWORKS monituje o ponowną aktywację licencji wieczystej przed wymaganą datą reaktywacji.

Pojedyncze licencje można dezaktywować, klikając [image] > Licencje > Dezaktywuj w SOLIDWORKS.

Temat nadrzędny Administracja licencji
Administrowanie licencjami przy użyciu programu SolidNetWork License Manager

Aktywowanie licencji

Przed uruchomieniem produktów SOLIDWORKS na danym komputerze, konieczne jest aktywowanie licencji dla tego komputera.

Aktywacja wymaga dostępu do Internetu lub poczty e-mail. Po zakończeniu procesu aktywacji, dla samego korzystania z produktów, nie jest konieczne połączenie z Internetem. Jeżeli nie masz dostępu do poczty e-mail na komputerze, na którym korzystasz z tego produktu, możesz zapisać plik aktywacji i wysłać go z innego komputera.

Proces ten:
  • Aktywuje wszystkie licencje oprogramowania produktów SOLIDWORKS.
  • Pozwala na przeniesienie praw licencyjnych z jednego komputera na drugi.
  • Może być przeprowadzony natychmiast (zalecane) lub w przeciągu 30 dni od instalacji.
  • Eliminuje potrzebę posiadania klucza sprzętowego. Należy jednak pamiętać, że dla poprzednich wersji produktów SOLIDWORKS, które nie używają aktywacji, należy nadal używać klucza sprzętowego.

Administratorzy systemu, którzy mają do zarządzania wiele numerów seryjnych, mogą wykorzystać Edytor opcji obrazu administracyjnego. Szczegółowe informacje zawiera temat Edytor opcji obrazu administracyjnego.

Aby aktywować licencję, należy:

  1. Uruchomić SOLIDWORKS.
  2. Uruchomić narzędzie Aktywacja produktu SOLIDWORKS przy użyciu jednej z poniższych metod:
    • Jeżeli nie aktywowano jeszcze licencji dla tego komputera, okno dialogowe Aktywacja produktu SOLIDWORKS pojawia się automatycznie podczas uruchamiania oprogramowania SOLIDWORKS.
    • Jeżeli okno Aktywacja produktu SOLIDWORKS nie pojawi się automatycznie, należy uruchomić aktywację, klikając [image] > Licencje > Aktywuj.
  3. Wybrać pozycję na liście Produkt, aby określić produkt, którego licencja ma zostać aktywowana.
  4. Określić automatyczną aktywację przez Internet lub ręczną aktywację przy użyciu poczty e-mail.
  5. Podać informacje kontaktowe poczty elektronicznej.
  6. Kliknąć Dalej.
    • Internet: Aktywacja zachodzi automatyczne.
    • E-mail: Kliknąć Zapisz, aby utworzyć plik żądania, a następnie wysłać ten plik na adres activation@solidworks.com. Po otrzymaniu wiadomości e-mail zawierającej plik odpowiedzi wyodrębnić ten plik z wiadomości e-mail, a następnie kliknąć Otwórz, aby go załadować.
      Jeśli to konieczne, można zamknąć i ponownie uruchomić procedurę aktywacji, aby otworzyć plik odpowiedzi.
  7. Kliknąć Zakończ.
Edytor opcji obrazu administracyjnego

Reaktywacja licencji

Osoby posiadające wieczystąlicencjękomercyjnąlub edukacyjną na produkty SOLIDWORKS 2022 i nowsze, zobowiazane są raz w roku reaktywować te licencje. SOLIDWORKS Product Activation podpowiada, że należy to zrobić przed wymaganą datą reaktywacji.

W celu reaktywowania licencji:

  1. Uruchomić SOLIDWORKS.
    SOLIDWORKS Product Activation zwraca się z prośbą o ponowną aktywację. Dla każdej licencji produktu SOLIDWORKS wyświetla następujące informacje:
    • Data, gdy aktualna Aktywacja wygasa
    • Czynność wymagana do dalszego użytkowania produktu, jak np. reaktywacja licencji wieczystej lub odnowienie i reaktywacja licencji okresowej lub ewaluacyjnej.
  2. Kliknąć przycisk Reaktywuj teraz, aby uruchomić kreatora aktywacji produktu.

    Jeśli użytkownik nie chce natychmiast reaktywować licencji, kliknąć Przypomnij mi później. Na przykład w SOLIDWORKS należy kliknąć [image] > Licencje > Aktywuj, aby uruchomić Kreator aktywacji produktu. Patrz Aktywowanie licencji.

Przenoszenie licencji

Aby przenieść licencję SolidNetWork na nowy lub zmodernizowany komputer, w pierwszej kolejności należy dezaktywować ją z serwera kluczy licencyjnych w Dassault Systèmes SOLIDWORKS Corporation. Następnie należy reaktywować ją na innym komputerze.

Nawet jeśli nie powiedzie się dezaktywacja licencji z Dassault Systèmes SOLIDWORKS Corporation (na przykład z powodu awarii twardego dysku), w większości przypadków reaktywacja i tak przebiegnie pomyślnie. Jeśli nie, proszę skontaktować się z Value Added Reseller w celu uzyskania pomocy.

Aby przenieść licencję, należy:

  1. W SOLIDWORKS kliknąć [image] > Licencje > Dezaktywuj i postępować zgodnie z instrukcjami.
  2. Aby reaktywować, należy przejść do nowego lub uaktualnionego komputera i aktywować licencję tak jak podczas początkowej aktywacji. Aby uzyskać szczegółowe informacje, należy zapoznać się z tematem Aktywowanie licencji.


Administrowanie licencjami przy użyciu programu SolidNetWork License Manager

Program SolidNetWork License Manager obsługuje wielu klientów licencji poprzez dystrybucję licencji do klientów za pośrednictwem sieci. Dzięki temu liczba użytkowników może przekraczać liczbę licencji poprzez użycie licencji ruchomych.

Obraz ten przedstawia typową instalację licencjonowania SolidNetWork:

Obraz ten ilustruje:
  • Oprogramowanie SolidNetWork License Manager jest zainstalowane i aktywowane tylko na komputerze menedżera licencji.
  • Komputery klientów licencji nie posiadają zainstalowanego żadnego dodatkowego oprogramowania specyficznego dla SolidNetWork.

    W przypadku określenia numeru seryjnego licencji SolidNetWork podczas instalowania, menedżer instalacji SOLIDWORKS identyfikuje ten komputer jako klienta licencji SolidNetWork. SolidNetWork License Manager wyświetla monit o podanie nazwy komputera menedżera licencji SolidNetWork i numeru portu służącego do łączenia klienta z menedżerem licencji.

  • Menedżer licencji i wszyscy klienci licencji muszą obsługiwać połączenia TCP/IP (Transmission Control Protocol/Internet Procotcol).

Spis treści

  • Informacje ogólne o instalowaniu licencji SolidNetWork

    Przed zainstalowaniem oprogramowania klienckiego SOLIDWORKS na którymkolwiek komputerze należy za pomocą Menedżera instalacji SOLIDWORKS zainstalować program SolidNetWork License Manager Server na co najmniej jednym komputerze. Kreator aktywacji produktu pozwala dodawać i aktywować numery seryjne dla licencji wieczystych i okresowych.

  • Uruchamianie programu SolidNetWork License Manager

    Program SolidNetWork License Manager można uruchomić z menu Start systemu Windows.

  • Uaktualnianie programu SolidNetWork License Manager

    Dla głównych wersji SOLIDWORKS, uaktualnienie menedżera licencji polega na odinstalowaniu starego menedżera licencji, zainstalowaniu nowego i reaktywowaniu licencji SolidNetWork.

  • Przenoszenie licencji SolidNetWork

    Aby przenieść licencję SolidNetWork na nowy lub zmodernizowany komputer, należy ją najpierw zdezaktywować (zwrócić do serwera kluczy licencji w firmie Dassault Systèmes SOLIDWORKS Corporation), a następnie aktywować ją na innym komputerze.

  • Usuwanie plików licencji SolidNetWork

    Przed uaktualnieniem do nowych licencji można usunąć wygasłe pliki licencji SolidNetWork.

  • Pożyczanie i zwracanie licencji SolidNetWork

    Można pożyczyć licencję SolidNetWork, aby używać oprogramowanie z lokalizacji zdalnej. Ponieważ licencja ta jest usuwana z puli dostępnych licencji, pożyczona licencja musi zostać zwrócona, aby być ponownie dostępną.

  • Zarządzanie dostępem do wersji oprogramowania SOLIDWORKS

    Można zablokować możliwość korzystania z konkretnej wersji oprogramowania SOLIDWORKS w środowisku SolidNetWork. To rozwiązanie pozwala zarządzać wersjami oprogramowania SOLIDWORKS używanymi przez różne osoby, przez różne jednostki biznesowe i w ramach różnych projektów.

  • Monitorowanie czasu bezczynności licencji

    SOLIDWORKS może rejestrować czas bezczynności przy użyciu programu SolidNetWork License Manager, dzięki czemu licencje, które były nieużywane przez pewien okres, są zwracane do puli wolnych licencji.

  • Używanie licencji tymczasowej

    Jeśli oryginalna licencja SolidNetWork nie jest dostępna, można tymczasowo użyć licencji „any”.

  • Używanie licencji SolidNetWork z produktami dodatków

    Można używać programu SolidNetWork License Manager, aby dystrybuować licencje dla głównych produktów dodatków SOLIDWORKS.

  • Wybieranie licencji SOLIDWORKS Simulation za pomocą programu SolidNetWork License

    Użytkownicy programu SolidNetWork License mogą kontrolować, które licencje SOLIDWORKS Simulation® z ich puli licencji mają być używane przy stosowaniu dodatku SOLIDWORKS Simulation. Mogą również zmienić licencję SOLIDWORKS Simulation bez zwalniania dodatku na wypadek, gdyby potrzebowali licencji wyższego typu dla bardziej zaawansowanych badań.

  • Ładowanie modułów Flow Simulation

    Użytkownik będący klientem korzystającym z produktów SolidNetWork License może kontrolować sposób ładowania modułów HVAC oraz Electronics Cooling dla dodatku Flow Simulation przy użyciu dwóch metod.

  • Limit czasu braku aktywności SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation i SOLIDWORKS Plastics

    Podczas uruchamiania badań SOLIDWORKS Simulation, Plastics lub Flow Simulation licencje sieciowe pozostają cały czas aktywne. SOLIDWORKS korzysta z licencji w procesie obliczania, który jest uważany za działanie.

  • Używanie tego samego komputera do instalacji menedżera licencji i obrazu administracyjnego

    Można skonfigurować jeden komputer w sieci, który będzie działał zarówno jako menedżer licencji dystrybuujący licencje SolidNetWork, jak i lokalizacja obrazu administracyjnego, z której użytkownicy mogą instalować oprogramowanie SOLIDWORKS.

  • Odinstalowywanie programu SolidNetWork License Manager

    Podczas uaktualniania programu SolidNetWork License Manager, przed zainstalowaniem nowego menedżera licencji konieczne jest odinstalowanie starego.

  • Zarządzanie licencjami FlexNet Publisher

    Licencjonowanie SolidNetWork jest oparte na zarządzaniu licencjami FlexNet Publisher®.

Temat nadrzędny Administracja licencji
Administrowanie indywidualnymi licencjami


Informacje ogólne o instalowaniu licencji SolidNetWork

Przed zainstalowaniem oprogramowania klienckiego SOLIDWORKS na którymkolwiek komputerze należy za pomocą Menedżera instalacji SOLIDWORKS zainstalować program SolidNetWork License Manager Server na co najmniej jednym komputerze. Kreator aktywacji produktu pozwala dodawać i aktywować numery seryjne dla licencji wieczystych i okresowych.

Podczas instalacji oprogramowania klienckiego SOLIDWORKS na komputerze należy podać numer seryjny licencji SolidNetWork. Menedżer instalacji SOLIDWORKS zidentyfikuje ten komputer jako klienta licencji SolidNetWork i wyświetli monit o podanie nazwy komputera i numeru portu programu SolidNetWork License Manager Server. Menedżer wyświetli błąd, jeśli program SolidNetWork License Manager Server nie został zainstalowany albo jeśli nazwa lub numer portu są błędne.

Proces aktywacji

Zanim użytkownicy będą mogli uruchamiać produkty SOLIDWORKS na swoich indywidualnych komputerach, konieczne jest aktywowanie licencji SolidNetWork na komputerze z programem SolidNetWork License Manager Server.

Aktywacja wymaga dostępu do aktywnego połączenia internetowego lub poczty e-mail. Po zakończeniu procesu aktywacji, dla samego korzystania z produktów, nie jest konieczne połączenie z Internetem. Jeżeli nie masz dostępu do poczty e-mail na komputerze, na którym korzystasz z tego produktu, możesz zapisać plik aktywacji i wysłać go z innego komputera.

Proces ten:
  • Aktywuje SOLIDWORKS SolidNetWork License Manager wraz z licencjami SolidNetWork dla wszystkich produktów SOLIDWORKS.
  • Umożliwia przeniesienie praw licencyjnych SolidNetWork z jednego komputera z menedżerem SolidNetWork License Manager na inny.
  • Pozwala na instalowanie i aktywowanie praw licencyjnych SolidNetWork na komputerze Menedżera licencji SolidNetWork License Manager.
  • Musi zostać wykonany zanim możliwe będzie korzystanie z licencji SolidNetWork.
  • Eliminuje potrzebę posiadania klucza sprzętowego. W przypadku aktywowania licencji SolidNetWork dla tej wersji SOLIDWORKS, licencje SolidNetWork dla poprzednich wersji SOLIDWORKS są aktywowane. Nie ma konieczności zachowywania klucza sprzętowego.

Spis treści

  • Instalowanie programu SolidNetWork License Manager Server

    Program SolidNetWork License Manager Server obsługuje wiele klientów licencji. Dystrybuuje on licencje do klientów w sieci.

  • Aktywowanie licencji SolidNetWork

    Zanim użytkownicy będą mogli uruchamiać produkty SOLIDWORKS na swoich indywidualnych komputerach, konieczne jest aktywowanie licencji SolidNetWork na komputerze SolidNetWork License Manager.

  • Ręczna aktywacja za pomocą programu SolidNetWork License Manager Server

    Podczas instalowania lub aktualizowania programu SolidNetWork License Manager Server należy aktywować lub reaktywować licencję. Licencję można aktywować lub reaktywować przez Internet lub ręcznie.

  • Instalowanie klientów licencji SolidNetWork

  • Używanie licencji SolidNetWork z zaporami

    Jeżeli komputer używa zapory, konieczne jest skonfigurowanie portów do obsługi licencji SolidNetWork.

  • Reaktywowanie licencji SolidNetWork

    Reaktywacja dotyczy produktów SolidNetWork License po przeprowadzeniu przez organizację aktualizacji serwera SolidNetWork License Manager do wersji 2022 lub nowszej. Nawet jeśli zainstalowane produkty pochodzą z wcześniejszej wersji, licencje 2022 i przyszłe wersje na serwerze wymagają reaktywacji raz w roku.

  • Instalacja triady menedżerów instalacji

    Triady menedżerów licencji wykorzystują trzy komputery dla zapewnienia dodatkowej stabilności. Jeżeli komputer zarządzający plikiem licencji nie jest dostępny, jego funkcję przejmuje jeden z pozostałych dwóch komputerów.

Temat nadrzędny Administrowanie licencjami przy użyciu programu SolidNetWork License Manager
Uruchamianie programu SolidNetWork License Manager
Uaktualnianie programu SolidNetWork License Manager
Przenoszenie licencji SolidNetWork
Usuwanie plików licencji SolidNetWork
Pożyczanie i zwracanie licencji SolidNetWork
Zarządzanie dostępem do wersji oprogramowania SOLIDWORKS
Monitorowanie czasu bezczynności licencji
Używanie licencji tymczasowej
Używanie licencji SolidNetWork z produktami dodatków
Wybieranie licencji SOLIDWORKS Simulation za pomocą programu SolidNetWork License
Ładowanie modułów Flow Simulation
Limit czasu braku aktywności SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation i SOLIDWORKS Plastics
Używanie tego samego komputera do instalacji menedżera licencji i obrazu administracyjnego
Odinstalowywanie programu SolidNetWork License Manager
Zarządzanie licencjami FlexNet Publisher


Instalowanie programu SolidNetWork License Manager Server

Program SolidNetWork License Manager Server obsługuje wiele klientów licencji. Dystrybuuje on licencje do klientów w sieci.

Jeśli aktualizujesz z poprzedniej wersji serwera menedżera licencji SolidNetWork License Manager Server, która używała kluczy sprzętowych dla aktywacji licencji, należy usnąć klucz sprzętowy przed zainstalowaniem nowej wersji programu SolidNetWork License Manager Server.

  1. Uruchomić Menedżera Instalacji SOLIDWORKS zgodnie z opisem w części Pobierz nośnik instalacyjny.
  2. Dla typu instalacji wybrać opcję Zainstaluj komponenty serwera i kliknąć Zainstaluj na tym komputerze SolidNetWork License Manager (dystrybuowane licencje).
  3. Na stronie Podsumowanie sprawdzić lokalizację instalacji i ustawienia Pobieracza w tle, zaakceptować warunki licencji i kliknąć przycisk Zainstaluj teraz.
  4. W Kreatorze aktywacji produktu SOLIDWORKS uruchomionym z poziomu programu SolidNetWork License Manager Server dodać numer seryjny i aktywować co najmniej jedną licencję. Zapoznać się z tematem Dodawanie numerów seryjnych i aktywowanie licencji SolidNetWork.
Temat nadrzędny Informacje ogólne o instalowaniu licencji SolidNetWork
Aktywowanie licencji SolidNetWork
Ręczna aktywacja za pomocą programu SolidNetWork License Manager Server
Instalowanie klientów licencji SolidNetWork
Używanie licencji SolidNetWork z zaporami
Reaktywowanie licencji SolidNetWork
Instalacja triady menedżerów instalacji


Aktywowanie licencji SolidNetWork

Zanim użytkownicy będą mogli uruchamiać produkty SOLIDWORKS na swoich indywidualnych komputerach, konieczne jest aktywowanie licencji SolidNetWork na komputerze SolidNetWork License Manager.

Aby aktywować licencję SolidNetWork, należy:

  1. Uruchomić SolidNetWork License Manager, klikając Start > Narzędzia SOLIDWORKS wersja > SolidNetWork License Manager Serverwersja.
  2. Opcjonalne: Jeśli licencja SolidNetWork nie została jeszcze aktywowana, zostanie wyświetlony monit z prośbą o jej aktywację. Kliknąć Tak.
    Uruchomiony zostanie kreator Aktywacja produktu SOLIDWORKS.
  3. Opcjonalne: Jeżeli zainstalowano zaporę, wybrać Na serwerze tym używana jest zapora firewall.
  4. Wprowadzić numery portów na stronie Informacje serwera licencji SolidNetWork, a następnie kliknąć Dalej.
  5. W obszarze Numer seryjny: wybrać określone numery seryjne lub kliknąć Wybierz wszystkie, aby podświetlić i aktywować wszystkie numery seryjne SOLIDWORKS.
    1. Wybrać opcję aktywacji Automatycznie używając Internetu (zalecane).
    2. W części Informacje kontaktowe wprowadzić adres poczty elektronicznej.
    Okno dialogowe Aktywacja/reaktywacja powiodła się wyświetla produkty, które zostały aktywowane.
  6. Kliknąć Zakończ.
Temat nadrzędny Informacje ogólne o instalowaniu licencji SolidNetWork
Instalowanie programu SolidNetWork License Manager Server
Ręczna aktywacja za pomocą programu SolidNetWork License Manager Server
Instalowanie klientów licencji SolidNetWork
Używanie licencji SolidNetWork z zaporami
Reaktywowanie licencji SolidNetWork
Instalacja triady menedżerów instalacji


Ręczna aktywacja za pomocą programu SolidNetWork License Manager Server

Podczas instalowania lub aktualizowania programu SolidNetWork License Manager Server należy aktywować lub reaktywować licencję. Licencję można aktywować lub reaktywować przez Internet lub ręcznie.

Ręczna aktywacja:
  • W przypadku nowego wystąpienia aplikacji SolidNetWork License Manager Server w celu poprawnego skonfigurowania serwera aktywację trzeba przeprowadzić dwukrotnie. Inicjowanie systemu licencji na serwerze odbywa się przy pierwszej aktywacji. Podczas wykonywania procedury po raz drugi następuje właściwa aktywacja licencji.
  • W przypadku uaktualniania programu SolidNetWork License Manager Server należy ponownie aktywować istniejącą licencję. Jeśli serwer nie ma aktywowanych licencji, aktywację należy przeprowadzić przy użyciu opcji Modyfikuj na karcie Administracja serwera.
Temat nadrzędny Informacje ogólne o instalowaniu licencji SolidNetWork
Instalowanie programu SolidNetWork License Manager Server
Aktywowanie licencji SolidNetWork
Instalowanie klientów licencji SolidNetWork
Używanie licencji SolidNetWork z zaporami
Reaktywowanie licencji SolidNetWork
Instalacja triady menedżerów instalacji


Instalowanie klientów licencji SolidNetWork

Podczas instalacji oprogramowania SOLIDWORKS CAD na komputerze należy podać numer seryjny licencji SolidNetWork. Menedżer instalacji SOLIDWORKS identyfikuje ten komputer jako klienta licencji SolidNetWork i wyświetla monit o podanie nazwy i numeru komputera zawierającego oprogramowanie SolidNetWork License Manager. Menedżer wyświetli błąd, jeśli program SolidNetWork License Manager Server nie został zainstalowany albo jeśli nazwa lub numer portu są błędne.

Aby zainstalować oprogramowanie SOLIDWORKS z licencją SolidNetWork, należy:

  1. Uruchomić Menedżera Instalacji SOLIDWORKS zgodnie z opisem w części Pobierz nośnik instalacyjny.
  2. Na stronie Witamy kliknąć Zainstaluj na tym komputerze, jeśli jest to pierwsza instalacja SOLIDWORKS na danym komputerze dla tej wersji głównej.
    W przypadku uaktualniania istniejącej wersji i zmiany z indywidualnej licencji na licencję SolidNetWork należy kliknąć Modyfikuj instalację indywidualną (na tym komputerze). Szczegółowe informacje zawiera temat Uaktualnianie od licencji indywidualnych do licencji SolidNetWork .
  3. W oknie dialogowym Dodaj serwer wpisać adres Menedżera licencji SolidNetWork w postaci:

    port@NazwaKomputera

    Numer portu musi być taki sam jak ten, którego użyto dla komputera menedżera licencji. Wartość domyślna to 25734.

    Menedżer instalacji SOLIDWORKS podejmie próbę sprawdzenia, czy ten Menedżer licencji SolidNetWork jest dostępny. Jeżeli nie zainstalowano jeszcze menedżera licencji, to sprawdzenie zakończy się niepowodzeniem, jednakże można kontynuować instalację klienta licencji.
  4. Dokończyć instalację SOLIDWORKS, postępując zgodnie z instrukcjami Menedżera instalacji SOLIDWORKS.
Temat nadrzędny Informacje ogólne o instalowaniu licencji SolidNetWork
Instalowanie programu SolidNetWork License Manager Server
Aktywowanie licencji SolidNetWork
Ręczna aktywacja za pomocą programu SolidNetWork License Manager Server
Używanie licencji SolidNetWork z zaporami
Reaktywowanie licencji SolidNetWork
Instalacja triady menedżerów instalacji


Używanie licencji SolidNetWork z zaporami

Jeżeli komputer używa zapory, konieczne jest skonfigurowanie portów do obsługi licencji SolidNetWork.

W oprogramowaniu zapory należy dodać do listy wyjątków zapory dwa porty licencji SolidNetWork (na przykład SNL-in-port i SNL-out-port). Aby uzyskać szczegółowe informacje na temat konfigurowania tych portów, należy skonsultować się z administratorem systemu.

Użytkownicy Zapory systemu Windows w obsługiwanych systemach operacyjnych Windows muszą zmodyfikować porty w komputerze menedżera SolidNetWork License Manager i zmodyfikować plik licencji SolidNetWork, aby dystrybuować licencje do komputerów klientów licencji.

Modyfikowanie portów komputera Menedżera licencji SolidNetWork pod kątem Zapory systemu Windows

  1. Kliknąć Start i otworzyć Zabezpieczenia Windows.
  2. Wybrać Zapora i ochrona sieci > Ustawienia zaawansowane i kliknąć Tak, aby potwierdzić zmiany.
  3. W oknie dialogowym Zapora programu Windows Defender z zabezpieczeniami zaawansowanymi wybrać Reguły ruchu przychodzącego > Nowa reguła.
  4. W Kreatorze nowej reguły ruchu przychodzącego wybrać typ reguły Port, a następnie kliknąć Dalej.
  5. Wprowadzić numer portu w polu Określone porty lokalne: (na przykład 80, 25734, 443), a następnie kliknąć Dalej.
  6. Wybrać Nazwa. Wprowadzić Nazwę (na przykład SNL-in-port).
  7. Kliknąć Zakończ.

Modyfikowanie ustawień menedżera SolidNetWork License Manager pod kątem Zapory systemu Windows

  1. Uruchomić SolidNetWork License Manager, klikając Start > Narzędzia SOLIDWORKS wersja > SolidNetWork License Manager Server wersja.
  2. Na karcie Administracja serwera w części Serwer licencji kliknąć Zatrzymaj. Kliknąć Tak, aby potwierdzić i OK, aby zatrzymać serwer licencji.
  3. W części Informacje o licencji kliknąć Modyfikuj.
  4. W części Typ serwera wybrać konfigurację serwera dla danej sieci (Pojedynczy lub Triada), a następnie kliknąć Dalej.
  5. W części Informacje serwera:
    1. Wybrać Na serwerze tym używana jest zapora firewall.
    2. Pola Numer portu i Numer portu demona dostawcy powinny zawierać numery portów określonych przez Zaporę systemu Windows) (szczegółowe informacje zawiera powyższa procedura).
    3. Wybrać Plik opcji i kliknąć Przeglądaj, aby zlokalizować plik. Kliknąć Edycja, aby zmienić dowolne z jego parametrów.
    Plik opcji pozwala administratorowi licencji kontrolować różne parametry użytkowe licencji FlexNet Licensing.

    Zalecenie: Zlokalizować plik opcji w katalogu instalacyjnym menedżera SolidNetWork License Manager (SolidNetWork_License_Manager_install_dir\Licenses \sw_d.opt). Plik ten musi znajdować się w tym samym katalogu, co plik sw_d.lic.

    Aby uzyskać więcej informacji na temat pliku opcji, należy zapoznać się z Przewodnikiem administracji licencjami FlexNet Publisher w katalogu instalacyjnym SolidNetWork License Manager:

    C:\Program Files\SOLIDWORKS SolidNetWork License Manager\Docs\flexuser\fnp_LicAdmin.pdf

Temat nadrzędny Informacje ogólne o instalowaniu licencji SolidNetWork
Instalowanie programu SolidNetWork License Manager Server
Aktywowanie licencji SolidNetWork
Ręczna aktywacja za pomocą programu SolidNetWork License Manager Server
Instalowanie klientów licencji SolidNetWork
Reaktywowanie licencji SolidNetWork
Instalacja triady menedżerów instalacji


Reaktywowanie licencji SolidNetWork

Reaktywacja dotyczy produktów SolidNetWork License po przeprowadzeniu przez organizację aktualizacji serwera SolidNetWork License Manager do wersji 2022 lub nowszej. Nawet jeśli zainstalowane produkty pochodzą z wcześniejszej wersji, licencje 2022 i przyszłe wersje na serwerze wymagają reaktywacji raz w roku.

W ciągu 30 dni od daty reaktywacji produkty SOLIDWORKS w sieci powiadamiają użytkowników, że licencje wygasną. Administratorzy muszą być świadomi wygaśnięcia, aby w porę reaktywować licencje.

Aby reaktywować licencję SolidNetWork:

  1. Uruchomić SolidNetWork License Manager Server, klikając Start > Narzędzia SOLIDWORKS wersja > SolidNetWork License Manager Server wersja.
  2. Na karcie Administracja serwera w obszarze Informacje o licencji kliknąć opcję Reaktywuj.

  3. W obszarze Szeregowy wybrać opcję Wszystkie dla wszystkich licencji lub wprowadzić numer licencji, aby wyszukać konkretną licencję.

    Okno dialogowe Reaktywuj licencje wyszczególnia na czerwono wszystkie daty wygaśnięcia i reaktywacji licencji w okresie 30 dni. Gwiazdki oznaczają licencje wymagające odnowienia.

  4. Kliknij Reaktywuj
Temat nadrzędny Informacje ogólne o instalowaniu licencji SolidNetWork
Instalowanie programu SolidNetWork License Manager Server
Aktywowanie licencji SolidNetWork
Ręczna aktywacja za pomocą programu SolidNetWork License Manager Server
Instalowanie klientów licencji SolidNetWork
Używanie licencji SolidNetWork z zaporami
Instalacja triady menedżerów instalacji


Instalacja triady menedżerów instalacji

Triady menedżerów licencji wykorzystują trzy komputery dla zapewnienia dodatkowej stabilności. Jeżeli komputer zarządzający plikiem licencji nie jest dostępny, jego funkcję przejmuje jeden z pozostałych dwóch komputerów.

Wymagania związane z użyciem triady menedżerów licencji:
  • Menedżery licencji triady należy instalować tylko na stabilnych komputerach, które nie są często wyłączane.
  • Trzy komputery menedżerów licencji powinny znajdować się w tej samej podsieci. Nigdy nie należy konfigurować menedżerów licencji triady z powolnym systemem komunikacji ani połączeniami telefonicznymi.
  • Administrator systemu powinien wykryć, gdy komputer menedżera licencji jest wyłączony i uruchomić go ponownie w jak najkrótszym czasie.
    Jeżeli działają tylko dwa komputery menedżera licencji, sytuacja jest gorsza niż w przypadku jednego menedżera licencji, ponieważ mamy dwa punkty uszkodzenia.

Spis treści

  • Instalowanie pierwszego menedżera licencji triady

    Poniższa procedura dotyczy instalacji oprogramowania SolidNetWork License Manager na pierwszym komputerze w triadzie.

  • Instalowanie triady menedżera licencji na kolejnych komputerach

    Aby zainstalować oprogramowanie SolidNetWork License Manager na drugim i trzecim komputerze w triadzie, należy postępować zgodnie z poniższymi instrukcjami. Procedura ta jest prawie taka sama, jak w przypadku instalowania oprogramowania na pierwszym komputerze, z wyjątkiem kroków 2(f) i 2(i).

Temat nadrzędny Informacje ogólne o instalowaniu licencji SolidNetWork
Instalowanie programu SolidNetWork License Manager Server
Aktywowanie licencji SolidNetWork
Ręczna aktywacja za pomocą programu SolidNetWork License Manager Server
Instalowanie klientów licencji SolidNetWork
Używanie licencji SolidNetWork z zaporami
Reaktywowanie licencji SolidNetWork


Instalowanie pierwszego menedżera licencji triady

Poniższa procedura dotyczy instalacji oprogramowania SolidNetWork License Manager na pierwszym komputerze w triadzie.

  1. Na pierwszym komputerze triady menedżera licencji należy zainstalować menedżera SolidNetWork License Manager przy użyciu Menedżera instalacji SOLIDWORKS.
    1. Uruchomić Menedżera Instalacji SOLIDWORKS zgodnie z opisem w części Pobierz nośnik instalacyjny.
    2. Dla typu instalacji wybrać Zainstaluj komponenty serwera i kliknąć Zainstaluj na tym komputerze SolidNetWork License Manager (dystrybuowane licencje).
    3. Na stronie Podsumowanie sprawdzić lokalizację instalacji SolidNetWork License Manager, Opcje pobierania i kliknąć Zainstaluj teraz, aby zakończyć proces Menedżera instalacji SOLIDWORKS.
  2. Wykorzystując Menedżer licencji SolidNetWork, skonfigurować pierwszy komputer triady menedżera licencji:
    1. Uruchomić menedżera SolidNetWork License Manager. Kliknąć kolejno Start > Narzędzia SOLIDWORKS wersja > SolidNetWork License Manager Server wersja.

      Ponieważ jest to pierwsze uruchomienie SolidNetWork License Manager na tym komputerze, pojawia się pytanie, czy należy dokonać aktywacji teraz.

    2. Kliknąć Nie.

      Pojawi się karta „Administracja serwera” SolidNetWork License Manager.

    3. Na karcie Administracja serwera w obszarze Zaawansowane opcje kliknąć Opcje.
    4. W części Tryb serwera licencji SolidNetWork w kliknąć Użyj pliku licencji i kliknąć OK.
    5. W części Informacje o licencji kliknąć Modyfikuj.
      Pojawi się Kreator pliku licencji SolidNetWork.
    6. W części Typ serwera wybrać Triada i kliknąć Dalej.
    7. W okienku Informacje serwera zweryfikować, czy nazwa komputera i numer portu dla pierwszego komputera triady menedżera licencji są prawidłowe, a potem kliknąć Dalej.

      Sprawdzić, czy adres karty sieciowej (NIC) jest zgodny z informacjami zawartymi w pliku licencji otrzymanym od SOLIDWORKS i czy numer portu dla komputera triady menedżera licencji jest prawidłowy. Adres NIC nazywany jest również adresem MAC (Media Access Control Address). Następnie kliknąć przycisk Dalej.

      Aby znaleźć adres NIC, otworzyć okno Wiersz polecenia i wpisać:

      ipconfig/all

      Ponadto jeżeli komputer używa zapory, może być konieczne określenie dodatkowych informacji na tym ekranie. Aby uzyskać więcej informacji, patrz Używanie licencji SolidNetWork z zaporami.

    8. Na ekranie Informacje serwera partnera triady wprowadzić nazwę komputera i identyfikator hosta dla dwóch pozostałych komputerów triady menedżera licencji i kliknąć Dalej.
      To spowoduje, że nawet jeśli jeden menedżer licencji triady będzie niedostępny, komputery klienta będą mogły uzyskać licencję z pozostałych dwóch serwerów.
    9. Na ekranie Licencje, kliknąć Odczytaj, aby przejść do pliku licencji SolidNetWork i otworzyć go.
      Licencje te pojawią się w kreatorze Plik licencji SolidNetWork. Dla tego komputera użyć pliku licencji otrzymanego od sprzedawcy VAR lub z Centrum Obsługi Klienta Dassault Systèmes SOLIDWORKS.
    10. Kliknąć Zakończ.
    11. Kliknąć OK, aby wyjść z okna, a następnie kliknąć Zakończ, aby zamknąć menedżera SolidNetWork License Manager.
Temat nadrzędny Instalacja triady menedżerów instalacji
Instalowanie triady menedżera licencji na kolejnych komputerach
Używanie licencji SolidNetWork z zaporami


Instalowanie triady menedżera licencji na kolejnych komputerach

Aby zainstalować oprogramowanie SolidNetWork License Manager na drugim i trzecim komputerze w triadzie, należy postępować zgodnie z poniższymi instrukcjami. Procedura ta jest prawie taka sama, jak w przypadku instalowania oprogramowania na pierwszym komputerze, z wyjątkiem kroków 2(f) i 2(i).

Zakłada się że użytkownik zainstalował już co najmniej jeden menedżer licencji w triadzie na innym komputerze.

  1. Na komputerze triady menedżera licencji należy zainstalować menedżera SolidNetWork License Manager przy użyciu Menedżera instalacji SOLIDWORKS.
    1. Uruchomić Menedżera Instalacji SOLIDWORKS zgodnie z opisem w części Pobierz nośnik instalacyjny.
    2. Dla typu instalacji wybrać opcję Zainstaluj komponenty serwera i kliknąć Zainstaluj SolidNetWork License Manager (dystrybuowane licencje) na tym komputerze.
    3. Na stronie Podsumowanie sprawdzić lokalizację instalacji menedżera SolidNetWork License Manager, Opcje pobierania i kliknąć Zainstaluj teraz, aby zakończyć proces Menedżera instalacji SOLIDWORKS.
  2. Za pomocą programu SolidNetWork License Manager skonfigurować komputer triady menedżera licencji:
    1. Uruchomić menedżera SolidNetWork License Manager. Kliknąć kolejno Start > Narzędzia SOLIDWORKS wersja > SolidNetWork License Manager Server wersja.
      Ponieważ jest to pierwsze uruchomienie programu SolidNetWork License Manager na tym komputerze, pojawia się pytanie, czy należy dokonać aktywacji teraz.
    2. Kliknąć Nie.
      Pojawi się karta Administracja programu SOLIDWORKS SolidNetWork License Manager.
    3. W części Zaawansowane opcje, kliknąć Opcje.
      Pojawi się okno dialogowe Zaawansowane opcje.
    4. W części Tryb serwera licencji SolidNetWork w kliknąć Użyj pliku licencji i kliknąć OK.
      Okno dialogowe Zaawansowane opcje zostanie zamknięte.
    5. W części Informacje o licencji kliknąć Modyfikuj.
      Pojawi się Kreator pliku licencji SolidNetWork.
    6. W części Typ serwera wybrać Triada oraz Synchronizuj informacje serwera/licencji, a następnie kliknąć Dalej.
    7. Na ekranie Informacje serwera triady należy wprowadzić nazwę komputera i identyfikator hosta. Następnie kliknąć przycisk Dalej.
      Dzięki temu, jeżeli jeden menedżer licencji jest niedostępny, komputery klienta mogą uzyskać licencję z pozostałych dwóch serwerów.
    8. Na ekranie Licencje, kliknąć Odczytaj, aby przejść do pliku licencji SolidNetWork i otworzyć go.
      Licencje te pojawią się w kreatorze Plik licencji SolidNetWork.
    Plik licencji jest generowany przez pierwszy komputer triady menedżera licencji, który skonfigurowano. Zwykle plik licencji znajduje się w lokalizacji \licenses\sw_d.lic. Na przykład: C:\Program Files\SOLIDWORKS SolidNetWork License Manager\licenses\sw_d.lic
    1. Kliknąć Zakończ.
      Pojawi się ostrzeżenie Kreatora pliku licencji SolidNetWork.
    2. Kliknąć OK, aby zamknąć kreator Plik licencji SolidNetWork, a następnie Zakończ, aby zamknąć SolidNetWork License Manager.

Powtórzyć ten proces dla trzeciego komputera triady menedżera licencji.

Temat nadrzędny Instalacja triady menedżerów instalacji
Instalowanie pierwszego menedżera licencji triady


Uruchamianie programu SolidNetWork License Manager

Program SolidNetWork License Manager można uruchomić z menu Start systemu Windows.

W systemie Windows kliknąć Start > SOLIDWORKS Tools wersja > SolidNetWork License Manager Server wersja.

Można użyć tej samej ścieżki z menu Start systemu Windows, aby otworzyć aplikację SolidNetWork License Manager Client wersja.

Temat nadrzędny Administrowanie licencjami przy użyciu programu SolidNetWork License Manager
Informacje ogólne o instalowaniu licencji SolidNetWork
Uaktualnianie programu SolidNetWork License Manager
Przenoszenie licencji SolidNetWork
Usuwanie plików licencji SolidNetWork
Pożyczanie i zwracanie licencji SolidNetWork
Zarządzanie dostępem do wersji oprogramowania SOLIDWORKS
Monitorowanie czasu bezczynności licencji
Używanie licencji tymczasowej
Używanie licencji SolidNetWork z produktami dodatków
Wybieranie licencji SOLIDWORKS Simulation za pomocą programu SolidNetWork License
Ładowanie modułów Flow Simulation
Limit czasu braku aktywności SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation i SOLIDWORKS Plastics
Używanie tego samego komputera do instalacji menedżera licencji i obrazu administracyjnego
Odinstalowywanie programu SolidNetWork License Manager
Zarządzanie licencjami FlexNet Publisher


Uaktualnianie programu SolidNetWork License Manager

Dla głównych wersji SOLIDWORKS, uaktualnienie menedżera licencji polega na odinstalowaniu starego menedżera licencji, zainstalowaniu nowego i reaktywowaniu licencji SolidNetWork.

Menedżer licencji nowszej wersji może również dystrybuować licencje dla komputerów klientów pozostających przy wersjach wcześniejszych.

  1. Uruchomić SolidNetWork License Manager, klikając Start > Narzędzia SOLIDWORKS wersja > SolidNetWork License Manager Server wersja.
  2. Na karcie Użycie licencji zweryfikować, że na żadnym komputerze klienta w sieci nie jest uruchomiona aplikacja SOLIDWORKS.
  3. Odinstalować stary menedżer licencji. Szczegółowe informacje zawiera temat Odinstalowywanie programu SolidNetWork License Manager.
  4. Zainstalować nowy menedżer licencji i reaktywować licencję SolidNetWork na komputerze menedżera licencji. Szczegółowe informacje zawiera temat Instalowanie programu SolidNetWork License Manager Server.

W przypadku uaktualniania SolidNetWork License Manager na komputerze, na którym działa również aplikacja SOLIDWORKS, uaktualnić aplikacje SolidNetWork License Manager i klienty przed zainstalowaniem jakichkolwiek nowych pakietów serwisowych aplikacji SOLIDWORKS.

W przypadku uaktualniania menedżera licencji na komputerze, który jest hostem obrazów administracyjnych, należy uaktualnić menedżera licencji przed uaktualnieniem obrazów administracyjnych. Szczegółowe informacje zawiera temat Używanie tego samego komputera do instalacji menedżera licencji i obrazu administracyjnego.

Temat nadrzędny Administrowanie licencjami przy użyciu programu SolidNetWork License Manager
Informacje ogólne o instalowaniu licencji SolidNetWork
Uruchamianie programu SolidNetWork License Manager
Przenoszenie licencji SolidNetWork
Usuwanie plików licencji SolidNetWork
Pożyczanie i zwracanie licencji SolidNetWork
Zarządzanie dostępem do wersji oprogramowania SOLIDWORKS
Monitorowanie czasu bezczynności licencji
Używanie licencji tymczasowej
Używanie licencji SolidNetWork z produktami dodatków
Wybieranie licencji SOLIDWORKS Simulation za pomocą programu SolidNetWork License
Ładowanie modułów Flow Simulation
Limit czasu braku aktywności SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation i SOLIDWORKS Plastics
Używanie tego samego komputera do instalacji menedżera licencji i obrazu administracyjnego
Odinstalowywanie programu SolidNetWork License Manager
Zarządzanie licencjami FlexNet Publisher


Przenoszenie licencji SolidNetWork

Aby przenieść licencję SolidNetWork na nowy lub zmodernizowany komputer, należy ją najpierw zdezaktywować (zwrócić do serwera kluczy licencji w firmie Dassault Systèmes SOLIDWORKS Corporation), a następnie aktywować ją na innym komputerze.

Jeżeli przeniesienie licencji do Dassault Systèmes SOLIDWORKS Corporation nie powiedzie się (na przykład z powodu awarii dysku twardego), reaktywacja w większości przypadków będzie wciąż możliwa. Jeśli nie, proszę skontaktować się z Value Added Reseller w celu uzyskania pomocy.

Aby przenieść licencję SolidNetWork:

  1. Uruchomić SolidNetWork License Manager Server, klikając Start > Narzędzia SOLIDWORKS wersja > SolidNetWork License Manager Server wersja.
  2. Na karcie Administracja serwera, w obszarze Informacje o licencji , kliknąć Modyfikuj. Uruchomiony zostanie kreator Aktywacja produktu SOLIDWORKS.
  3. W obszarze Co chcesz zrobić? wybrać Przenieś licencję(-e) produktu na nowy/zmodernizowany komputer, a następnie kliknąć Dalej.
  4. Na liście Numer seryjny: wybrać numery seryjne lub kliknąć Wybierz wszystkie, aby aktywować wszystkie numery seryjne SOLIDWORKS.
    1. Wybrać opcję Automatycznie używając Internetu (zalecane).
    2. W części Informacje kontaktowe (wymagane): określić adres poczty elektronicznej.
  5. Zostanie wyświetlony komunikat Dezaktywacja powiodła się.
    Zakończono dezaktywację licencji produktu.
  6. Kliknąć Zakończ.
Temat nadrzędny Administrowanie licencjami przy użyciu programu SolidNetWork License Manager
Informacje ogólne o instalowaniu licencji SolidNetWork
Uruchamianie programu SolidNetWork License Manager
Uaktualnianie programu SolidNetWork License Manager
Usuwanie plików licencji SolidNetWork
Pożyczanie i zwracanie licencji SolidNetWork
Zarządzanie dostępem do wersji oprogramowania SOLIDWORKS
Monitorowanie czasu bezczynności licencji
Używanie licencji tymczasowej
Używanie licencji SolidNetWork z produktami dodatków
Wybieranie licencji SOLIDWORKS Simulation za pomocą programu SolidNetWork License
Ładowanie modułów Flow Simulation
Limit czasu braku aktywności SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation i SOLIDWORKS Plastics
Używanie tego samego komputera do instalacji menedżera licencji i obrazu administracyjnego
Odinstalowywanie programu SolidNetWork License Manager
Zarządzanie licencjami FlexNet Publisher


Usuwanie plików licencji SolidNetWork

Przed uaktualnieniem do nowych licencji można usunąć wygasłe pliki licencji SolidNetWork.

  1. Uruchomić SolidNetWork License Manager, klikającStart > Narzędzia SOLIDWORKS wersja > SolidNetWork License Manager Server.
  2. Na karcie Administracja serwera, w obszarze Informacje o licencji, kliknąć Modyfkuj, a następnie kliknąć Dalej.
  3. Na stronie Aktywuj/dezaktywuj produkt SOLIDWORKS zaznaczyć wygasłe pliki licencji SolidNetWork i kliknąć Usuń.
  4. Kliknąć kolejno przyciski Zakończ i OK, aby wyjść.
Temat nadrzędny Administrowanie licencjami przy użyciu programu SolidNetWork License Manager
Informacje ogólne o instalowaniu licencji SolidNetWork
Uruchamianie programu SolidNetWork License Manager
Uaktualnianie programu SolidNetWork License Manager
Przenoszenie licencji SolidNetWork
Pożyczanie i zwracanie licencji SolidNetWork
Zarządzanie dostępem do wersji oprogramowania SOLIDWORKS
Monitorowanie czasu bezczynności licencji
Używanie licencji tymczasowej
Używanie licencji SolidNetWork z produktami dodatków
Wybieranie licencji SOLIDWORKS Simulation za pomocą programu SolidNetWork License
Ładowanie modułów Flow Simulation
Limit czasu braku aktywności SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation i SOLIDWORKS Plastics
Używanie tego samego komputera do instalacji menedżera licencji i obrazu administracyjnego
Odinstalowywanie programu SolidNetWork License Manager
Zarządzanie licencjami FlexNet Publisher


Pożyczanie i zwracanie licencji SolidNetWork

Można pożyczyć licencję SolidNetWork, aby używać oprogramowanie z lokalizacji zdalnej. Ponieważ licencja ta jest usuwana z puli dostępnych licencji, pożyczona licencja musi zostać zwrócona, aby być ponownie dostępną.

Licencje wypożyczone mogą być używane jedynie przez bieżącego użytkownika i na komputerze, na którym zostały wypożyczone. Nie można ich przenieść.

Licencja jest wypożyczana na określony czas, maksymalnie 30 dni (lub zdefiniowany przez administratora systemu) i jest usuwana z puli dostępnych licencji.

Wypożyczanie i zwracanie licencji nie działa, kiedy licencja SOLIDWORKS jest używana.

Administrator systemu może dostosować pożyczanie, aby:
  • Zdefiniować, którzy użytkownicy lub grupy mogą pożyczać licencje
  • Ustawiać liczbę licencji, których nie można wypożyczyć

Szczegóły zawiera dokument katalog_instalacyjny_Menedżera_licencji_SolidNetWork\Docs\flexuser\licensingenduserguide.pdf.

Spis treści

  • Pożyczanie licencji SolidNetWork

  • Zwracanie pożyczonej licencji SolidNetWork

    Ponieważ pożyczona licencja SolidNetWork jest usuwana z puli dostępnych licencji, ta pożyczona licencja musi zostać zwrócona, aby być ponownie dostępną.

Temat nadrzędny Administrowanie licencjami przy użyciu programu SolidNetWork License Manager
Informacje ogólne o instalowaniu licencji SolidNetWork
Uruchamianie programu SolidNetWork License Manager
Uaktualnianie programu SolidNetWork License Manager
Przenoszenie licencji SolidNetWork
Usuwanie plików licencji SolidNetWork
Zarządzanie dostępem do wersji oprogramowania SOLIDWORKS
Monitorowanie czasu bezczynności licencji
Używanie licencji tymczasowej
Używanie licencji SolidNetWork z produktami dodatków
Wybieranie licencji SOLIDWORKS Simulation za pomocą programu SolidNetWork License
Ładowanie modułów Flow Simulation
Limit czasu braku aktywności SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation i SOLIDWORKS Plastics
Używanie tego samego komputera do instalacji menedżera licencji i obrazu administracyjnego
Odinstalowywanie programu SolidNetWork License Manager
Zarządzanie licencjami FlexNet Publisher


Pożyczanie licencji SolidNetWork

SolidNetWork License Manager należy zawsze uruchamiać z menu Start systemu Windows. W celu pożyczenia licencji wymagane jest połączenie z SolidNetWork License Manager.

Czynności te mogą się różnić w zależności od konfiguracji systemu. Należy zapoznać się dokumentacją systemu Microsoft Windows, aby uzyskać dodatkowe instrukcje i opcje.
  1. Uruchomić SolidNetWork License Manager na komputerze klienckim, klikając Start > Narzędzia SOLIDWORKS wersja > SolidNetWork License Manager Client wersja.
  2. Na karcie Pożyczanie licencji:
    1. Wybrać datę w części Pożycz do.
    2. W obszarze Dostępne licencje produktuwybrać produkty do wypożyczenia i kliknąć Pożycz.
    3. W oknie dialogowym Wybierz produkt wybrać produkt z listy i kliknąć OK,, aby potwierdzić.
    4. W dolnej części okna dialogowego kliknąć Odśwież.
      Kolumna Pożycz do wskazuje, kiedy licencje muszą być zwrócone.
  3. Kliknąć OK.

Na karcie Użycie licencji można również wyświetlić Całkowitą liczbę licencji, Licencje nieużywane i Licencje używane przez użytkownika, a także daty ważności wypożyczenia Pożyczony do.

Wybrać opcję Korzystaj tylko z pożyczonych licencji (szybsze uruchamianie) w przypadku pracy zdalnej i powolnego uruchamiania aplikacji SOLIDWORKS.

Ta opcja blokuje wysyłanie zapytań do serwerów licencji, które mogą spowalniać prace w niektórych środowiskach. Aplikacje mogą uruchamiać się szybciej dzięki pomijaniu zapytań i korzystaniu jedynie z pożyczonych licencji.

Aby ta opcja zaczęła działać, należy uruchomić aplikację ponownie.

Temat nadrzędny Pożyczanie i zwracanie licencji SolidNetWork
Zwracanie pożyczonej licencji SolidNetWork


Zwracanie pożyczonej licencji SolidNetWork

Ponieważ pożyczona licencja SolidNetWork jest usuwana z puli dostępnych licencji, ta pożyczona licencja musi zostać zwrócona, aby być ponownie dostępną.

  1. Uruchomić SolidNetWork License Manager na komputerze klienckim, klikając Start > Narzędzia SOLIDWORKS wersja > SolidNetWork License Manager Client wersja.
  2. Na karcie Pożyczanie licencji:
    1. W obszarze Pożyczone licencje produktu wybrać produkty do zwrotu i kliknąć Zwróć.
    2. Kliknąć przycisk Odśwież. Kolumna Pożyczony do staje się pusta, co oznacza, że licencje zostały zwrócone.
  3. Kliknąć OK.

Na karcie Użycie licencji można również wyświetlić liczbę licencji: Całkowita liczba licencji.

Nie ma potrzeby zwracania licencji po upływie daty ważności. Licencja zostanie zwrócona do puli licencji w SolidNetWork License Manager o północy w dniu wygaśnięcia, a aplikacje na zdalnym systemie nie będą mogły zostać uruchomione.
Temat nadrzędny Pożyczanie i zwracanie licencji SolidNetWork
Pożyczanie licencji SolidNetWork


Zarządzanie dostępem do wersji oprogramowania SOLIDWORKS

Można zablokować możliwość korzystania z konkretnej wersji oprogramowania SOLIDWORKS w środowisku SolidNetWork. To rozwiązanie pozwala zarządzać wersjami oprogramowania SOLIDWORKS używanymi przez różne osoby, przez różne jednostki biznesowe i w ramach różnych projektów.

W celu zarządzania dostępem do wersji oprogramowania SOLIDWORKS przy użyciu pliku opcji FlexNet:

  1. W katalogu instalacyjnym SolidNetWork License Manager należy utworzyć plik tekstowy:
    katalog_instalacyjny_SolidNetWork_License_Manager\Licenses\sw_d.opt
  2. W celu zarządzania dostępem do konkretnej wersji oprogramowania SOLIDWORKS w pliku licencji należy dodać następującą składnię obok pozycji SOLIDWORKS:
    :SWVERSION=xx Gdzie xx to wersja produktu SOLIDWORKS do objęcia zarządzaniem
  3. Aby zarządzać wieloma wersjami oprogramowania SOLIDWORKS, dodać osobny wiersz dla każdej wersji, która ma zostać uwzględniona.

    Nie wszystkie opcje FlexNet są obsługiwane. Obsługiwane są następujące opcje filtrów wersji:

    INCLUDE | Zapewniaj tylko użytkownikowi lub grupie możliwość uruchomienia określonej wersji. Wszyscy pozostali użytkownicy nie będą mogli uruchomić tej wersji.
    INCLUDE_BORROW | Zapewniaj tylko użytkownikowi lub grupie możliwość wypożyczania określonej wersji. Wszyscy pozostali użytkownicy nie będą mogli wypożyczyć tej wersji.
    EXCLUDE | Nie zezwalaj użytkownikom ani grupom znajdującym się na liście na uruchamianie konkretnych wersji oprogramowania SOLIDWORKS. EXCLUDE zastępuje INCLUDE.
    EXCLUDE_BORROW | Nie zezwalaj użytkownikom ani grupom znajdującym się na liście na wypożyczanie konkretnych wersji oprogramowania SOLIDWORKS. EXCLUDE zastępuje INCLUDE.
    Przykłady:
    1 | SWVERSION=32.0 dotyczy oprogramowania SOLIDWORKS 2025
    SWVERSION=31.0 dotyczy oprogramowania SOLIDWORKS 2024
    2 | INCLUDE solidworks:SWVERSION=32.0 USER jane
    INCLUDE_BORROW solidworks:SWVERSION=32.0 USER jane
    Te wiersze w pliku opcji umożliwiają uruchamianie oprogramowania SOLIDWORKS 2025 jedynie użytkowniczce jane. Inni użytkownicy nie mogą uruchamiać ani wypożyczać oprogramowania SOLIDWORKS 2025, ale mogą uruchamiać i wypożyczać inne wersje produktu SOLIDWORKS. Użytkowniczka jane również może uruchamiać i wypożyczać inne wersje oprogramowania SOLIDWORKS.
    3 | GROUP chicago USER john robert eva
    EXCLUDE solidworks:SWVERSION=32.0 GROUP chicago
    EXCLUDE solidworks:SWVERSION=31.0 GROUP chicago
    EXCLUDE solidworks USER don
    Te wiersze definiują GROUP użytkowników o nazwie chicago i blokują jej dostęp zarówno do oprogramowania SOLIDWORKS 2025 jak i oprogramowania SOLIDWORKS 2024. Jednak użytkownicy ci mogą uruchomić dowolną inną wersję oprogramowania SOLIDWORKS. Użytkownik don nie może uruchamiać dowolnej wersji oprogramowania SOLIDWORKS.
    4 | EXCLUDE swinspection_std:SWVERSION=32.0 HOST machine1
    Ten wiersz zabrania wszystkim na komputerze machine1 uruchamiania SOLIDWORKS Inspection 2025.

    Aby uzyskać informacje na temat FlexNet, należy zapoznać się z Przewodnikiem administracji licencjami FlexNet Publisher w katalogu instalacyjnym menedżera SolidNetWork License Manager: \Docs\flexuser\fnp_LicAdmin.pdf.

Temat nadrzędny Administrowanie licencjami przy użyciu programu SolidNetWork License Manager
Informacje ogólne o instalowaniu licencji SolidNetWork
Uruchamianie programu SolidNetWork License Manager
Uaktualnianie programu SolidNetWork License Manager
Przenoszenie licencji SolidNetWork
Usuwanie plików licencji SolidNetWork
Pożyczanie i zwracanie licencji SolidNetWork
Monitorowanie czasu bezczynności licencji
Używanie licencji tymczasowej
Używanie licencji SolidNetWork z produktami dodatków
Wybieranie licencji SOLIDWORKS Simulation za pomocą programu SolidNetWork License
Ładowanie modułów Flow Simulation
Limit czasu braku aktywności SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation i SOLIDWORKS Plastics
Używanie tego samego komputera do instalacji menedżera licencji i obrazu administracyjnego
Odinstalowywanie programu SolidNetWork License Manager
Zarządzanie licencjami FlexNet Publisher


Monitorowanie czasu bezczynności licencji

SOLIDWORKS może rejestrować czas bezczynności przy użyciu programu SolidNetWork License Manager, dzięki czemu licencje, które były nieużywane przez pewien okres, są zwracane do puli wolnych licencji.

  1. W katalogu instalacyjnym programu SolidNetWork License Manager należy utworzyć plik tekstowy:
    katalog_instalacyjny_SolidNetWork_License_Manager\Licenses\sw_d.opt
  2. Dodać następujący wiersz do pliku:
    TIMEOUTALL sekundy

    Gdzie sekundy stanowią liczbę większą lub równą 900 (15 minut), co jest minimalna dopuszczalna wartoscia czasu.

Temat nadrzędny Administrowanie licencjami przy użyciu programu SolidNetWork License Manager
Informacje ogólne o instalowaniu licencji SolidNetWork
Uruchamianie programu SolidNetWork License Manager
Uaktualnianie programu SolidNetWork License Manager
Przenoszenie licencji SolidNetWork
Usuwanie plików licencji SolidNetWork
Pożyczanie i zwracanie licencji SolidNetWork
Zarządzanie dostępem do wersji oprogramowania SOLIDWORKS
Używanie licencji tymczasowej
Używanie licencji SolidNetWork z produktami dodatków
Wybieranie licencji SOLIDWORKS Simulation za pomocą programu SolidNetWork License
Ładowanie modułów Flow Simulation
Limit czasu braku aktywności SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation i SOLIDWORKS Plastics
Używanie tego samego komputera do instalacji menedżera licencji i obrazu administracyjnego
Odinstalowywanie programu SolidNetWork License Manager
Zarządzanie licencjami FlexNet Publisher


Używanie licencji tymczasowej

Jeśli oryginalna licencja SolidNetWork nie jest dostępna, można tymczasowo użyć licencji „any”.

Domyślnie menedżer SolidNetWork License Manager może aktywować tylko jeden serwer naraz. Aby pracować w środowisku testowym, można uzyskać plik licencji tymczasowej z działu pomocy technicznej i załadować licencję „any” do menedżera SolidNetWork License Manager na innym serwerze. Jeśli użytkownik pracuje z serwerem offline, można za pomocą tych samych instrukcji załadować licencję zwolnioną z konieczności aktywacji.

Używając pliku licencji „any”, klient zobowiązuje się do wprowadzenia licencji po otrzymaniu licencji SolidNetWork od firmy Dassault Systèmes SOLIDWORKS Corporation. Przestrzeganie ograniczeń licencji nadal jest wymagane.

Aby użyć licencji „any”, należy:

  1. Uruchomić SolidNetWork License Manager, klikając Start > Narzędzia SOLIDWORKS wersja > SolidNetWork License Manager Server wersja.
  2. Jeśli oprogramowanie zażąda aktywacji, należy kliknąć Nie.
  3. W karcie Administracja serwera kliknąć Zaawansowane opcje > Opcje.
  4. W części Tryb serwera licencji SolidNetWork kliknąć Użyj pliku licencji i OK.
  5. Na karcie Administracja serwera, w obszarze Informacje o licencji, kliknąć Modyfikuj.
    Pojawi się Kreator pliku licencji SolidNetWork.
  6. W części Typ serwera wybrać Pojedynczy i kliknąć Dalej.
  7. Wybrać Identyfikator klucza sprzętowego i wprowadzić Any lub Adres NIC w polu informacje o serwerze. Następnie kliknąć przycisk Dalej.

    Kliknąć Anuluj po zapoznaniu się z tym komunikatem: Nie można odczytać numeru klucza sprzętowego.

    Jeżeli komputer używa zapory, może zachodzić konieczność określenia dodatkowych informacji na tym ekranie. Więcej informacji zawiera temat Używanie licencji SolidNetWork z zaporami.
  8. W obszarze Licencje kliknąć Przeczytaj, aby zapoznać się z plikiem licencji.
  9. W oknie dialogowym Przeczytaj przejść do pliku SNL_ANY.txt lub SNL_(NIC Card Number).txt przekazanego przez dział pomocy technicznej i kliknąć Otwórz. Następnie kliknąć OK.
    Kreator pliku licencji SolidNetWork zawiera listę licencji dostępną w pliku tekstowym.
    Kliknąć Usuń, aby usunąć z listy pozycje licencji tymczasowych, które wygasły.
  10. Kliknąć Zakończ, aby zamknąć kreatora pliku licencji SolidNetWork.
  11. Aktywować licencję „any”:
    1. W karcie Administracja serwera kliknąć Zaawansowane opcje > Opcje.
    2. W części Tryb serwera licencji SolidNetWork wybrać opcję Użyj pliku licencji i kliknąć OK.
    3. Na karcie Administracja serwera kliknąć kolejno opcje Modyfikuj > Aktywuj/dezaktywuj swoje licencje produktowe.
    4. Wypełnić ustawienia Numer seryjny i Informacje kontaktowe , po czym wybrać metodę aktywacji. W przypadku wybrania aktywacji ręcznej postępować zgodnie z instrukcjami.
    5. Kliknąć przycisk Zakończ, aby potwierdzić aktywację.
Temat nadrzędny Administrowanie licencjami przy użyciu programu SolidNetWork License Manager
Informacje ogólne o instalowaniu licencji SolidNetWork
Uruchamianie programu SolidNetWork License Manager
Uaktualnianie programu SolidNetWork License Manager
Przenoszenie licencji SolidNetWork
Usuwanie plików licencji SolidNetWork
Pożyczanie i zwracanie licencji SolidNetWork
Zarządzanie dostępem do wersji oprogramowania SOLIDWORKS
Monitorowanie czasu bezczynności licencji
Używanie licencji SolidNetWork z produktami dodatków
Wybieranie licencji SOLIDWORKS Simulation za pomocą programu SolidNetWork License
Ładowanie modułów Flow Simulation
Limit czasu braku aktywności SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation i SOLIDWORKS Plastics
Używanie tego samego komputera do instalacji menedżera licencji i obrazu administracyjnego
Odinstalowywanie programu SolidNetWork License Manager
Zarządzanie licencjami FlexNet Publisher


Używanie licencji SolidNetWork z produktami dodatków

Można używać programu SolidNetWork License Manager, aby dystrybuować licencje dla głównych produktów dodatków SOLIDWORKS.

  • Nie jest wymagana taka sama ilość licencji oprogramowania SOLIDWORKS i licencji dodatków SOLIDWORKS.
  • Aby wyewidencjonować licencję dla produktu dodatku, najpierw konieczne jest wyewidencjonowanie licencji dla oprogramowania SOLIDWORKS.
  • Aby pożyczyć licencję produktu dodatku, należy pożyczyć zarówno licencję oprogramowania SOLIDWORKS jak i licencję produktu SOLIDWORKS zawierającego dodatek. Licencja SOLIDWORKS Standard zostanie pożyczona domyślnie, jednak aby włączyć dodatek, użytkownik będzie musiał pożyczyć licencję produktu SOLIDWORKS Professional, SOLIDWORKS Premium lub SOLIDWORKS Ultimate.
  • Aby zwolnić licencję produktu dodatku, należy:
    • W SOLIDWORKS kliknąć Narzędzia > Dodatki i usunąć zaznaczenie dodatku.
    • Wyjść z aplikacji SOLIDWORKS.
Temat nadrzędny Administrowanie licencjami przy użyciu programu SolidNetWork License Manager
Informacje ogólne o instalowaniu licencji SolidNetWork
Uruchamianie programu SolidNetWork License Manager
Uaktualnianie programu SolidNetWork License Manager
Przenoszenie licencji SolidNetWork
Usuwanie plików licencji SolidNetWork
Pożyczanie i zwracanie licencji SolidNetWork
Zarządzanie dostępem do wersji oprogramowania SOLIDWORKS
Monitorowanie czasu bezczynności licencji
Używanie licencji tymczasowej
Wybieranie licencji SOLIDWORKS Simulation za pomocą programu SolidNetWork License
Ładowanie modułów Flow Simulation
Limit czasu braku aktywności SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation i SOLIDWORKS Plastics
Używanie tego samego komputera do instalacji menedżera licencji i obrazu administracyjnego
Odinstalowywanie programu SolidNetWork License Manager
Zarządzanie licencjami FlexNet Publisher


Wybieranie licencji SOLIDWORKS Simulation za pomocą programu SolidNetWork License

Użytkownicy programu SolidNetWork License mogą kontrolować, które licencje SOLIDWORKS Simulation® z ich puli licencji mają być używane przy stosowaniu dodatku SOLIDWORKS Simulation. Mogą również zmienić licencję SOLIDWORKS Simulation bez zwalniania dodatku na wypadek, gdyby potrzebowali licencji wyższego typu dla bardziej zaawansowanych badań.

  1. Aby użyć konkretnej licencji SOLIDWORKS Simulation:
    1. W oprogramowaniu SOLIDWORKS kliknij kolejno Narzędzia > Dodatki i w oknie dialogowym Dodatki wybierz SOLIDWORKS Simulation.
    2. W oknie SOLIDWORKS Simulation (CommandManager) kliknij strzałkę w dół [image], aby wyświetlić listę licencji dostępnych na serwerze, które obsługują dodatek Simulation.

    3. Wybierz odpowiednią licencję SOLIDWORKS Simulation.
  2. Aby sprawdzić lub zmienić bieżącą licencję SOLIDWORKS Simulation, kliknij strzałkę w dół [image] w oknie SOLIDWORKS Simulation (CommandManager).

    Obok używanej licencji wyświetlany jest znacznik wyboru. Jeżeli dostępne są bardziej zaawansowane typy licencji, można dokonać zmiany.
    Nie można obniżyć poziomu licencji SOLIDWORKS Simulation. Trzeba wyłączyć dodatek SOLIDWORKS Simulation i ponownie dodać licencję niższego poziomu.
  3. Opcjonalne: Aby wyłączyć dodatek, kliknij opcję SOLIDWORKS Simulation (CommandManager) lub usuń jej zaznaczenie w menu Narzędzia > Dodatki.
W następujących przypadkach nadal stosowany jest dany poziom licencji:
  • Gdy program SOLIDWORKS Simulation został uruchomiony.
  • Jeżeli dodano SOLIDWORKS Simulation w menu Narzędzia > Dodatki.
  • Jeżeli kliknięto SOLIDWORKS Simulation bez wybrania licencji z listy rozwijanej.
Temat nadrzędny Administrowanie licencjami przy użyciu programu SolidNetWork License Manager
Informacje ogólne o instalowaniu licencji SolidNetWork
Uruchamianie programu SolidNetWork License Manager
Uaktualnianie programu SolidNetWork License Manager
Przenoszenie licencji SolidNetWork
Usuwanie plików licencji SolidNetWork
Pożyczanie i zwracanie licencji SolidNetWork
Zarządzanie dostępem do wersji oprogramowania SOLIDWORKS
Monitorowanie czasu bezczynności licencji
Używanie licencji tymczasowej
Używanie licencji SolidNetWork z produktami dodatków
Ładowanie modułów Flow Simulation
Limit czasu braku aktywności SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation i SOLIDWORKS Plastics
Używanie tego samego komputera do instalacji menedżera licencji i obrazu administracyjnego
Odinstalowywanie programu SolidNetWork License Manager
Zarządzanie licencjami FlexNet Publisher


Ładowanie modułów Flow Simulation

Użytkownik będący klientem korzystającym z produktów SolidNetWork License może kontrolować sposób ładowania modułów HVAC oraz Electronics Cooling dla dodatku Flow Simulation przy użyciu dwóch metod.

Pierwsza metoda pozwala określić domyślne zachowanie dotyczące modułów podczas ładowania dodatku Flow Simulation. Opcja Automatycznie załaduj moduły dodatku Flow Simulation, jeśli są one dostępne znajduje się na karcie SolidNetWork License Manager Client > Kolejność licencji tab. Jeśli moduły dodatku Flow Simulation nie są konieczne, należy usunąć zaznaczenie tej opcji. Moduły dodatku HVAC and Electronics Cooling nie są ładowane w przypadku dodania Flow Simulation wraz z istniejącymi metodami.

Druga metoda umożliwia zastąpienie domyślnego zachowania i uwzględnienie modułów dodatków HVAC i Electronic Cooling podczas ładowania Flow Simulation. Kliknąć strzałkę w dół [image] w SOLIDWORKS Flow Simulation (pasek narzędzi dodatków SOLIDWORKS®) lub SOLIDWORKS Flow Simulation wraz z jednym lub dwoma modułami dodatku do załadowania.

Niezastosowanie tych metod spowoduje wykorzystanie licencji na te moduły dodatku, niezależnie od tego, czy użytkownik ich potrzebuje czy nie, przez co inni użytkownicy należący do tej samej sieci mogą nie mieć do nich dostępu.

Temat nadrzędny Administrowanie licencjami przy użyciu programu SolidNetWork License Manager
Informacje ogólne o instalowaniu licencji SolidNetWork
Uruchamianie programu SolidNetWork License Manager
Uaktualnianie programu SolidNetWork License Manager
Przenoszenie licencji SolidNetWork
Usuwanie plików licencji SolidNetWork
Pożyczanie i zwracanie licencji SolidNetWork
Zarządzanie dostępem do wersji oprogramowania SOLIDWORKS
Monitorowanie czasu bezczynności licencji
Używanie licencji tymczasowej
Używanie licencji SolidNetWork z produktami dodatków
Wybieranie licencji SOLIDWORKS Simulation za pomocą programu SolidNetWork License
Limit czasu braku aktywności SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation i SOLIDWORKS Plastics
Używanie tego samego komputera do instalacji menedżera licencji i obrazu administracyjnego
Odinstalowywanie programu SolidNetWork License Manager
Zarządzanie licencjami FlexNet Publisher


Limit czasu braku aktywności SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation i SOLIDWORKS Plastics

Podczas uruchamiania badań SOLIDWORKS Simulation, Plastics lub Flow Simulation licencje sieciowe pozostają cały czas aktywne. SOLIDWORKS korzysta z licencji w procesie obliczania, który jest uważany za działanie.

Okresy braku aktywności, zdefiniowane w opcji LIMITU CZASU, mają zastosowanie dopiero po zakończeniu obliczeń w badaniach.

Temat nadrzędny Administrowanie licencjami przy użyciu programu SolidNetWork License Manager
Informacje ogólne o instalowaniu licencji SolidNetWork
Uruchamianie programu SolidNetWork License Manager
Uaktualnianie programu SolidNetWork License Manager
Przenoszenie licencji SolidNetWork
Usuwanie plików licencji SolidNetWork
Pożyczanie i zwracanie licencji SolidNetWork
Zarządzanie dostępem do wersji oprogramowania SOLIDWORKS
Monitorowanie czasu bezczynności licencji
Używanie licencji tymczasowej
Używanie licencji SolidNetWork z produktami dodatków
Wybieranie licencji SOLIDWORKS Simulation za pomocą programu SolidNetWork License
Ładowanie modułów Flow Simulation
Używanie tego samego komputera do instalacji menedżera licencji i obrazu administracyjnego
Odinstalowywanie programu SolidNetWork License Manager
Zarządzanie licencjami FlexNet Publisher


Używanie tego samego komputera do instalacji menedżera licencji i obrazu administracyjnego

Można skonfigurować jeden komputer w sieci, który będzie działał zarówno jako menedżer licencji dystrybuujący licencje SolidNetWork, jak i lokalizacja obrazu administracyjnego, z której użytkownicy mogą instalować oprogramowanie SOLIDWORKS.

Komputery klienta mogą uzyskać licencje z menedżera licencji, a następnie zainstalować SOLIDWORKS z tego samego komputera.

Konfiguracja ta wymaga instalacji menedżera licencji i obrazu administracyjnego na tym samym komputerze. Zainstalować menedżer licencji w pierwszej kolejności, a następnie utworzyć i rozmieścić obraz administracyjny.
Aby uzyskać szczegółowe informacje, patrz:
  • Instalowanie programu SolidNetWork License Manager Server
  • Rozmieszczanie do wielu klientów
Temat nadrzędny Administrowanie licencjami przy użyciu programu SolidNetWork License Manager
Informacje ogólne o instalowaniu licencji SolidNetWork
Uruchamianie programu SolidNetWork License Manager
Uaktualnianie programu SolidNetWork License Manager
Przenoszenie licencji SolidNetWork
Usuwanie plików licencji SolidNetWork
Pożyczanie i zwracanie licencji SolidNetWork
Zarządzanie dostępem do wersji oprogramowania SOLIDWORKS
Monitorowanie czasu bezczynności licencji
Używanie licencji tymczasowej
Używanie licencji SolidNetWork z produktami dodatków
Wybieranie licencji SOLIDWORKS Simulation za pomocą programu SolidNetWork License
Ładowanie modułów Flow Simulation
Limit czasu braku aktywności SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation i SOLIDWORKS Plastics
Odinstalowywanie programu SolidNetWork License Manager
Zarządzanie licencjami FlexNet Publisher


Odinstalowywanie programu SolidNetWork License Manager

Podczas uaktualniania programu SolidNetWork License Manager, przed zainstalowaniem nowego menedżera licencji konieczne jest odinstalowanie starego.

  1. Uruchomić SolidNetWork License Manager, klikając Start > Narzędzia SOLIDWORKS wersja > SolidNetWork License Manager Server wersja.
  2. Zweryfikować, czy na żadnym komputerze klienta w sieci nie jest uruchomiona aplikacja SOLIDWORKS.
    Karta Użycie licencji pokazuje uruchomionych klientów oprogramowania SOLIDWORKS.
  3. Aby przenieść licencję SolidNetWork na inny komputer, należy ją aktywować na tym komputerze przed usunięciem menedżera SolidNetWork License Manager.
    Informacje na temat przenoszenia licencji SolidNetWork zawiera temat Przenoszenie licencji SolidNetWork.
  4. Na karcie Administracja serwera w części Serwer licencji kliknąć Zatrzymaj.
  5. Kliknąć OK, aby wyjść z menedżera licencji.
  6. W systemie Windows otworzyć Panel sterowania > Programy i funkcje.
  7. Wybrać SOLIDWORKS SolidNetWork License Manager, kliknąć Odinstaluj i potwierdzić odinstalowanie.
  8. W Eksploratorze plików usunąć folder SOLIDWORKS SolidNetWork License Manager.
    (Zwykle folder ten znajduje się w katalogu Program Files (x86) w katalogu instalacyjnym SOLIDWORKS).

Jesteśmy teraz gotowi do zainstalowania nowej wersji menedżera licencji. Aby uzyskać szczegółowe informacje, należy zapoznać się z tematem Instalowanie programu SolidNetWork License Manager Server.

Jeżeli komputer menedżera licencji SolidNetWork License Manager ma dołączony klucz sprzętowy, należy usunąć klucz sprzętowy przed zainstalowaniem nowej wersji menedżera licencji SolidNetWork License Manager.
Temat nadrzędny Administrowanie licencjami przy użyciu programu SolidNetWork License Manager
Informacje ogólne o instalowaniu licencji SolidNetWork
Uruchamianie programu SolidNetWork License Manager
Uaktualnianie programu SolidNetWork License Manager
Przenoszenie licencji SolidNetWork
Usuwanie plików licencji SolidNetWork
Pożyczanie i zwracanie licencji SolidNetWork
Zarządzanie dostępem do wersji oprogramowania SOLIDWORKS
Monitorowanie czasu bezczynności licencji
Używanie licencji tymczasowej
Używanie licencji SolidNetWork z produktami dodatków
Wybieranie licencji SOLIDWORKS Simulation za pomocą programu SolidNetWork License
Ładowanie modułów Flow Simulation
Limit czasu braku aktywności SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation i SOLIDWORKS Plastics
Używanie tego samego komputera do instalacji menedżera licencji i obrazu administracyjnego
Zarządzanie licencjami FlexNet Publisher
Instalowanie programu SolidNetWork License Manager Server


Zarządzanie licencjami FlexNet Publisher

Licencjonowanie SolidNetWork jest oparte na zarządzaniu licencjami FlexNet Publisher®.

Aby uzyskać informacje na temat zarządzania licencjami FlexNet Publisher, należy zapoznać się z Przewodnikiem administracji licencjami FlexNet Publisher w katalogu instalacyjnym SolidNetWork License Manager: C:\Program Files\SOLIDWORKS SolidNetWork License Manager\Docs\flexuser\fnp_LicAdmin.pdf

Aby uzyskać najnowsze informacje na temat zarządzania licencjami FlexNet Publisher, należy skontaktować się z firmą Flexera® Software.

Wersję FlexNet można sprawdzić, przeglądając dziennik na serwerze licencji. Otworzyć SolidNetwork License Manager Server i kliknąć Administracja serwera > Wyświetl dziennik. W dzienniku wyświetlana jest wersja FlexNet Licensing w nawiasie.

Temat nadrzędny Administrowanie licencjami przy użyciu programu SolidNetWork License Manager
Informacje ogólne o instalowaniu licencji SolidNetWork
Uruchamianie programu SolidNetWork License Manager
Uaktualnianie programu SolidNetWork License Manager
Przenoszenie licencji SolidNetWork
Usuwanie plików licencji SolidNetWork
Pożyczanie i zwracanie licencji SolidNetWork
Zarządzanie dostępem do wersji oprogramowania SOLIDWORKS
Monitorowanie czasu bezczynności licencji
Używanie licencji tymczasowej
Używanie licencji SolidNetWork z produktami dodatków
Wybieranie licencji SOLIDWORKS Simulation za pomocą programu SolidNetWork License
Ładowanie modułów Flow Simulation
Limit czasu braku aktywności SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation i SOLIDWORKS Plastics
Używanie tego samego komputera do instalacji menedżera licencji i obrazu administracyjnego
Odinstalowywanie programu SolidNetWork License Manager


Rozwiązywanie problemów

Podczas rozwiązywania problemów instalacji pomocne będzie zapoznanie się z poniższymi tematami.

Spis treści

  • Użytkowanie licencji sieciowej

  • Pliki dziennika menedżera instalacji SOLIDWORKS

    Pliki dziennika Menedżera instalacji SOLIDWORKS są dostępne i pomagają w rozwiązywaniu problemów instalacji.

  • Folder pobrania Menedżera instalacji SOLIDWORKS

    Menedżer instalacji SOLIDWORKS może pobrać wymagane pliki instalacji do określonego folderu. Poniżej znajdują się odpowiedzi na często zadawane pytania dotyczące folderu pobierania.

  • Rozwiązywanie problemów licencji SolidNetWork

    Jeżeli instalacja programu SolidNetWork License Manager nie powiedzie się, należy sprawdzić poniższe prawdopodobne wyjaśnienia.

  • Rozwiązywanie problemów aktualizacji

    Jeżeli wystąpią problemy podczas uaktualniania do nowej wersji SOLIDWORKS, należy sprawdzić poniższe prawdopodobne wyjaśnienia.

  • Sprawdzanie kart graficznych podczas instalowania lub uaktualniania produktu

    Po zakończeniu instalowania lub uaktualniania produktu SOLIDWORKS na komputerze należy uruchomić program SOLIDWORKS Rx, aby upewnić się, że w komputerze są zainstalowane obsługiwane karty graficzne oraz sterownik karty graficznej.


Użytkowanie licencji sieciowej

To okno dialogowe pojawia się, gdy serwer posiada zbyt mało licencji na produkt.

Kliknąć strzałkę w polu Produkt, aby wyświetlić wszystkie możliwości wyboru produktu. Możliwości te obejmują oprogramowanie SOLIDWORKS i wszelkie dodatki, które można nabyć.

Całkowita liczba licencji to całkowita liczba nabytych licencji.

Licencje nie używane to liczba licencji, które nie są aktualnie w użyciu.

Pole Licencje używane przez podaje informacje o każdej osobie używającej licencji.

Temat nadrzędny Rozwiązywanie problemów
Pliki dziennika menedżera instalacji SOLIDWORKS
Folder pobrania Menedżera instalacji SOLIDWORKS
Rozwiązywanie problemów licencji SolidNetWork
Rozwiązywanie problemów aktualizacji
Sprawdzanie kart graficznych podczas instalowania lub uaktualniania produktu


Pliki dziennika menedżera instalacji SOLIDWORKS

Pliki dziennika Menedżera instalacji SOLIDWORKS są dostępne i pomagają w rozwiązywaniu problemów instalacji.

Te pliki dziennika są zlokalizowane tam, gdzie pozostałe pliki dziennika aplikacji SOLIDWORKS.

  • C:\Users\username\AppData\Roaming\SOLIDWORKS\Installation Logs\installed_version

Jeśli menedżer instalacji został uruchomiony z konta systemowego, dzienniki znajdują się w następującym folderze:
  • C:\Windows\SysWOW64\config\systemprofile\AppData\Roaming\SOLIDWORKS\Installation Logs\installed_version
Aby zobaczyć katalogi plików dziennika, może zachodzić konieczność skonfigurowania opcji folderów Windows na Pokaż ukryte pliki i foldery.

Jeśli dane aplikacji są zlokalizowane na dysku innym niż C:, należy odpowiednio skorygować ścieżkę katalogu.

Katalog ten zawiera plik SummaryIMLog_nnnnn_nnnnn_nnnn_nnnnn.txt, ogólny dziennik postępu Menedżera instalacji SOLIDWORKS.

Podkatalog Other Logs (Inne dzienniki) zawiera bardziej szczegółowe informacje dziennika instalacji.

Temat nadrzędny Rozwiązywanie problemów
Użytkowanie licencji sieciowej
Folder pobrania Menedżera instalacji SOLIDWORKS
Rozwiązywanie problemów licencji SolidNetWork
Rozwiązywanie problemów aktualizacji
Sprawdzanie kart graficznych podczas instalowania lub uaktualniania produktu


Folder pobrania Menedżera instalacji SOLIDWORKS

Menedżer instalacji SOLIDWORKS może pobrać wymagane pliki instalacji do określonego folderu. Poniżej znajdują się odpowiedzi na często zadawane pytania dotyczące folderu pobierania.

Pytanie Odpowiedź
Jak zainstalować pliki w tym folderze?

Uruchomić program setup.exe. Może wystąpić konieczność pobrania niektórych plików, jeżeli wybrano instalację elementów, które nie były poprzednio pobrane.

Nie należy dokonywać instalacji za pomocą msiexec (patrz poniżej).
Czy mogę ręcznie zainstalować pliki MSI z tego folderu przy użyciu msiexec lub innej aplikacji?

Nie. Menedżer instalacji nie pobiera niektórych plików, które byłyby wymagane w przypadku uruchomienia msiexec.
Czy mogę wybrać ten sam folder pobrania dla każdej instalowanej wersji?

Foldery pobierania są specyficzne dla wersji. Menedżer instalacji SOLIDWORKS automatycznie tworzy podfolder specyficzny dla wersji w określonym folderze.

Pobrałem ręcznie niektóre produkty ze strony sieci Web Dassault Systèmes SOLIDWORKS Corporation. Czy Menedżer instalacji może je zainstalować?
Pliki pobrane ręcznie mogą być użyte przez Menedżera instalacji SOLIDWORKS. Lepiej jednak uruchomić Menedżer instalacji SOLIDWORKS, wybierając opcję pobrania plików. Menedżer instalacji SOLIDWORKS pokazuje które pliki są potrzebne w oparciu o to co jest instalowane, podając łącza do pobrania każdego pliku. Można użyć tej opcji, kiedy nie działa strona pobierania (najprawdopodobniej z powodu ograniczeń pobierania narzuconych przez serwer proxy).
Jeżeli okno dialogowe pyta, czy należy zapisać, czy też uruchomić pliki podczas pobierania lub instalacji, należy zawsze określać Zapisywanie.
Czy pobrane przeze mnie pliki mogą być współużytkowane przez innych?

Tak. Aby było to możliwe, należy je pobrać do udziału sieciowego. Każdy klient może następnie uruchomić Menedżer instalacji SOLIDWORKS z udziału, aby dokonać instalacji.

Nie będzie wymagane żadne dalsze pobieranie, chyba że użytkownik wybierze do zainstalowania jakieś elementy, które nie były wybrane podczas początkowego pobrania, lub jeżeli komputer wykorzystujący te pobrane pliki do instalacji ma inny zbiór wymagań wstępnych niż komputer, na który pobrano pliki.

Przy pobieraniu dla innych i nie instalowaniu, podczas instalacji należy wybrać opcję Tylko pobierz. Opcja ta pozwala na wybranie produktów bez względu na to, czy są one zainstalowane na danym systemie, czy nie. Opcji tej nie można jednak używać do pobierania poprawek ani tworzenia obrazów administracyjnych.
Skąd mogę się dowiedzieć kiedy dostępna jest nowa wersja produktów SOLIDWORKS?
Użytkownik jest informowany o pojawieniu się nowej wersji w następujących sytuacjach:
  • W przypadku uruchomienia narzędzia Sprawdź, czy istnieją aktualizacje (Start > Menedżer instalacji SOLIDWORKS > Sprawdź, czy istnieją aktualizacje)
  • Jeśli Pobieracz w tle SOLIDWORKS jest włączony.
  • Jeżeli wybrano zainstalowaną wersję SOLIDWORKS w części Dodaj/usuń programy Windows i kliknięto Zmień.
  • Jeżeli uruchomiono starszą wersję Menedżera instalacji (sldIM.exe) z folderu pobierania.
W tych sytuacjach, można wybrać pobranie nowszej wersji. Menedżer instalacji SOLIDWORKS pobierze i uruchomi nowszą wersję samego siebie i nie pobierze żadnych plików instalacyjnych. Po uruchomieniu nowszej wersji Menedżera instalacji SOLIDWORKS można wybrać zbiór czynności instalacji. Menedżer instalacji SOLIDWORKS określa następnie, które pliki instalacji są wymagane (i niepobrane poprzednio) i oferuje pobranie tych plików.
Dlaczego Menedżer instalacji SOLIDWORKS nie pozwala mi wybrać innego pakietu Service Pack danego produktu do zainstalowania?

Każda wersja Menedżera instalacji SOLIDWORKS jest zaprojektowana tylko do instalacji określonej wersji produktów SOLIDWORKS. Aby zainstalować inny pakiet Service Pack, konieczne jest uruchomienie tej wersji Menedżera instalacji SOLIDWORKS. Aby odnaleźć najnowszą dostępną wersję, należy zapoznać się z poprzednim tematem.
Dlaczego Menedżer instalacji SOLIDWORKS nie może pobrać plików?

Jeżeli ograniczenia serwera proxy uniemożliwiają pobieranie plików przez aplikacje, Menedżer instalacji SOLIDWORKS nie może automatycznie pobrać plików.

Można pobrać pliki ręcznie a następnie zainstalować je przy użyciu Menedżera instalacji SOLIDWORKS. Należy wybrać opcję pobierania indywidualnych plików w Menedżerze instalacji SolidWorks (na przykład: metoda pobrania ręcznego na stronie Opcje pobierania). W oparciu o wybrane przez użytkownika produkty oraz wymagania systemowe, w oddzielnym oknie pojawi się strona sieci Web zawierająca łącza do ręcznego pobrania wszystkich wymaganych plików.
Nie wszystkie moje produkty SOLIDWORKS są uaktualnione do najnowszego pakietu Service Pack. Dlaczego narzędzie Sprawdź czy istnieją aktualizacje informuje, że mam najnowszą wersję?

Narzędzie Sprawdź, czy istnieją aktualizacje informuje tylko, czy zainstalowano (lub uruchomiono) najnowszą wersję Menedżera instalacji SOLIDWORKS.

Jeżeli użytkownik chce uaktualnić wszystkie produkty do najnowszej wersji zainstalowanej w obszarze Panel sterowania > Programy > Programy i operacje, należy wybrać najnowszą zainstalowaną wersję SOLIDWORKS i kliknąć Zmień.
Czy mogę skopiować DVD do folderu pobrania?

Tak, ale instalacje mogą się nie powieść, chyba że skopiowana zostanie cała zawartość każdej płyty DVD wydanej dla danej platformy. Menedżer instalacji SOLIDWORKS szuka plików swdata*.id, aby określić wersję. Jeżeli pliki te nie są obecne, nie powiedzie się rozpoznanie żadnego ze skopiowanych plików instalacji i wymagane jest ich pobranie.
Temat nadrzędny Rozwiązywanie problemów
Użytkowanie licencji sieciowej
Pliki dziennika menedżera instalacji SOLIDWORKS
Rozwiązywanie problemów licencji SolidNetWork
Rozwiązywanie problemów aktualizacji
Sprawdzanie kart graficznych podczas instalowania lub uaktualniania produktu


Rozwiązywanie problemów licencji SolidNetWork

Jeżeli instalacja programu SolidNetWork License Manager nie powiedzie się, należy sprawdzić poniższe prawdopodobne wyjaśnienia.

Temat nadrzędny Rozwiązywanie problemów
Użytkowanie licencji sieciowej
Pliki dziennika menedżera instalacji SOLIDWORKS
Folder pobrania Menedżera instalacji SOLIDWORKS
Rozwiązywanie problemów aktualizacji
Sprawdzanie kart graficznych podczas instalowania lub uaktualniania produktu

Dostęp do plików dziennika licencji SolidNetWork

Kiedy pojawiają się błędy, odpowiedź często można znaleźć w pliku katalog_instalacyjny_menedżera_SNL\lmgrd.log.

Nie udało się uzyskać licencji dla SOLIDWORKS. Nie można połączyć się z serwerem licencji.

Zwykle ten problem jest spowodowany ustawieniami portu.

  • Ustawienia portu pomiędzy menedżerem licencji SolidNetWork a klientem licencji mogą sobie nie odpowiadać.
  • Możliwe, że nie określono dodatkowych ustawień portu dla wielu wersji menedżerów licencji SolidNetWork.
  • Sprawdzić, czy komputer klienta może precyzyjnie rozwiązać i wyznaczyć trasę do serwera na podstawie jego nazwy.
Szczegółowe informacje dotyczące ustawień portu dla menedżerów licencji SolidNetWork i klientów zawiera temat Używanie licencji SolidNetWork z zaporami.
Używanie licencji SolidNetWork z zaporami


Rozwiązywanie problemów aktualizacji

Jeżeli wystąpią problemy podczas uaktualniania do nowej wersji SOLIDWORKS, należy sprawdzić poniższe prawdopodobne wyjaśnienia.

Temat nadrzędny Rozwiązywanie problemów
Użytkowanie licencji sieciowej
Pliki dziennika menedżera instalacji SOLIDWORKS
Folder pobrania Menedżera instalacji SOLIDWORKS
Rozwiązywanie problemów licencji SolidNetWork
Sprawdzanie kart graficznych podczas instalowania lub uaktualniania produktu

Modyfikowanie lub naprawianie źródła, które zostało przeniesione

Kiedy instalowane jest oprogramowanie SOLIDWORKS, Menedżer instalacji SOLIDWORKS zapamiętuje lokalizację źródeł instalacji (płyta, obraz w sieci itd.). Podczas modyfikacji lub naprawy zakłada, że źródło będzie dostępne w tej samej lokalizacji.

Jeżeli źródło jest przeniesione lub usunięte, bądź jeżeli zmianie ulega nośnik źródłowy, Menedżer instalacji SOLIDWORKS wyświetli komunikat o błędzie. Można jednak kontynuować modyfikację lub naprawę źródła instalacji, przechodząc do innej lokalizacji, o ile zawiera ona te same pliki i tę samą strukturę folderów.


Sprawdzanie kart graficznych podczas instalowania lub uaktualniania produktu

Po zakończeniu instalowania lub uaktualniania produktu SOLIDWORKS na komputerze należy uruchomić program SOLIDWORKS Rx, aby upewnić się, że w komputerze są zainstalowane obsługiwane karty graficzne oraz sterownik karty graficznej.

W celu sprawdzenia kart graficznych podczas instalowania lub uaktualniania produktu:

  1. Po zakończeniu działania Menedżera instalacji i wyświetleniu strony Zakończ, w obszarze Sprawdź system, kliknąć Uruchom diagnostykę systemu.

    Zostanie uruchomiony program SOLIDWORKS Rx, który wykona diagnostykę.

  2. Program SOLIDWORKS Rx sprawdzi, czy karta graficzna i sterownik karty graficznej są obsługiwane.
    Jeżeli karta graficzna jest obsługiwana, a sterownik nie, w komunikacie o stanie może być podana informacja o konieczności zaktualizowania sterownika.

Po każdym co dziesiątym uruchomieniu oprogramowania SOLIDWORKS zostanie wyświetlony komunikat Sprawdź system. Zaleca się wtedy ponowne uruchomienie diagnostyki systemu. Aby wygasić te powiadomienia, należy kliknąć prawym przyciskiem myszy SOLIDWORKS Resource Monitor [image] w obszarze powiadomień systemu Windows i wybrać polecenie Odrzuć powiadomienia o grafice.

Zgodność karty graficznej i sterownika można sprawdzić w dowolnej chwili, klikając prawym przyciskiem myszy SOLIDWORKS Resource Monitor w obszarze powiadomień systemu Windows. Menu umożliwia także:
  • Przejście do Pomocy dla modułu SOLIDWORKS Resource Monitor
  • Użycie opcji Uruchom diagnostykę systemu
  • Odrzucenie powiadomień o grafikach
  • Odrzucenie powiadomień o subskrypcji
  • Wyświetlenie certyfikowanych sterowników graficznych
Temat nadrzędny Rozwiązywanie problemów
Użytkowanie licencji sieciowej
Pliki dziennika menedżera instalacji SOLIDWORKS
Folder pobrania Menedżera instalacji SOLIDWORKS
Rozwiązywanie problemów licencji SolidNetWork
Rozwiązywanie problemów aktualizacji


Pomoc aplikacji Menedżer instalacji SOLIDWORKS

Menedżer instalacji SOLIDWORKS jest autonomiczną aplikacją, która instaluje i aktualizuje produkty SOLIDWORKS.

Menedżer instalacji SOLIDWORKS jest podstawowym narzędziem do pobierania, instalowania, modyfikowania, aktualizowania, naprawiania i usuwania programów SOLIDWORKS.

Menedżer instalacji SOLIDWORKS można uruchomić:
  • Z dysku DVD SOLIDWORKS, bądź ze współużytkowanego folderu źródłowego lub folderu pobierania (podczas instalowania nowej wersji).
  • Ze strony Dodaj lub usuń programy Panelu sterowania (podczas modyfikowania lub usuwania istniejącej wersji)
  • Poprzez zaplanowane lub ręczne sprawdzanie aktualizacji (podczas wykrywania, pobierania i instalowania nowych wersji)

Każda wersja SOLIDWORKS ma Menedżera instalacji SOLIDWORKS określonego dla tej wersji SOLIDWORKS.

Spis treści

  • SOLIDWORKS Pobieracz w tle

    Pobieracz w tle SOLIDWORKS wykonuje automatyczne pobrania pliku (na przykład po znalezieniu nowej wersji pakietu Service Pack) przy użyciu procesów w tle, pozwalając na kontynuowanie innych prac podczas pobierania. Kiedy pobieranie zostanie ukończone, użytkownik może zadecydować, czy chce wykonać instalację od razu, odroczyć ją, czy też usunąć pobrane pliki.

  • Określanie opcji Menedżera instalacji

    Opcje te obejmują ustawienia rejestrowania, dostępu do Internetu oraz języka używanego w Menedżerze instalacji.

  • Wyniki sprawdzenia czy istnieją aktualizacje

    Narzędzie Sprawdź, czy istnieją aktualizacje wyszukuje nowsze wersje oprogramowania SOLIDWORKS.

  • Lokalizacja obrazu administracyjnego

    Można określić lokalizację instalacji obrazu administracyjnego.

  • Opcje pobierania

    Należy określić szczegóły dotyczące dokończenia operacji pobierania, takie jak lokalizacja pobieranych plików, sposób pobierania plików oraz to, czy należy zainstalować pobrane pliki.

  • Opcje pobierania dla plików Menedżera instalacji SOLIDWORKS

    Wybrano pobranie późniejszej wersji Menedżera instalacji SOLIDWORKS. Należy użyć tego ekranu, aby określić gdzie i jak ma on zostać pobrany.

  • Pobierz pliki instalacji produktów

    Należy określić gdzie i jak pobrane maja być brakujące pliki dla określonego produktu.

  • Pobieranie w toku

    Menedżer instalacji SOLIDWORKS pobiera, weryfikuje i wyodrębnia wszystkie pliki równolegle w tym procesie.

  • Wyniki pobrania

    Informują, czy pobieranie zostało ukończone z powodzeniem, czy czynność ta zakończyła się niepowodzeniem, czy też została anulowana.

  • Błędy instalacji / Anulowano instalację

    Instalacja napotkała błąd lub została anulowana.

  • Ukończono instalację

    Menedżer instalacji SOLIDWORKS zakończył pracę.

  • Lokalizacja instalacji

  • Opcje uaktualniania

    Na tym komputerze jest zainstalowana co najmniej jedna starsza wersja główna SOLIDWORKS. Można utworzyć nową instalację, która będzie współistnieć ze starszą wersją, lub dokonać uaktualnienia, co spowoduje usunięcie starszej wersji.

  • Postęp instalacji

    Ekran ten pokazuje postęp instalacji.

  • Typ instalacji

    Można określić operację instalacji, która ma zostać uruchomiona. Przykłady to: tworzenie nowej instalacji, modyfikowanie lub naprawianie istniejącej instalacji, tworzenie obrazu administracyjnego, instalowanie produktów serwera administracyjnego lub pobieranie plików, aby można je było współużytkować i zainstalować na innych komputerach.

  • Instalowanie i zarządzanie wieloma komputerami

    Menedżer instalacji SOLIDWORKS dostarcza następujące narzędzia do instalowania i zarządzania wieloma komputerami SOLIDWORKS.

  • Ręczne pobieranie

    Wybrano ręczne pobieranie plików (lub wybrano ręczne pobieranie podczas ostatniego uruchomienia Menedżera instalacji SOLIDWORKS).

  • Dostępna nowsza wersja

    Menedżer instalacji wykrył nowszą wersję produktów SOLIDWORKS. Można wybrać instalację wersji zawartej w oryginalnej instalacji z dysku DVD lub z pobrania lub można wybrać pobranie i zainstalowanie nowszej wersji.

  • Brak dostępnych nowych wersji

    Nie istnieją nowsze wersje dostępne do pobrania. Należy kontynuować instalowanie określonej wersji.

  • Wykryte procesy

    Menedżer instalacji SOLIDWORKS wykrył w tym komputerze procesy, które mogą uniemożliwić pomyślną instalację.

  • Wybór produktu

    Można wybrać składniki produktu do zainstalowania, zmodyfikowania, pobrania lub usunięcia.

  • Produkty do pobrania

    Należy wybrać produkty SOLIDWORKS, które mają zostać pobrane do określonej lokalizacji.

  • Produkty do naprawienia

    Jeżeli określono Produkty do naprawienia, na tym ekranie wyświetlane są produkty SOLIDWORKS, których numery wersji mogą zostać naprawione przez tę wersję Menedżera instalacji SOLIDWORKS.

  • Numery seryjne

    Numery seryjne kojarzą komputer z nabytymi produktami SOLIDWORKS.

  • Instalacja serwera

    Wyszczególnione są produkty serwera, które próbowano zainstalować, wraz z wynikami instalacji.

  • Podsumowanie

    Menedżer instalacji SOLIDWORKS posiada wszystkie informacje niezbędne do dokończenia operacji instalacji.

  • Ostrzeżenia sprawdzenia systemu

    Sprawdzenie systemu zgłosiło problemy, które mogą wpływać na dalszy proces instalacji. W większości przypadków kontynuacja powinna być możliwa przy użyciu Menedżera instalacji SOLIDWORKS.

  • Opcje Kreatora otworów/Toolbox

    Jeżeli zainstalowany jest SOLIDWORKS Toolbox, SOLIDWORKS uwzględnia standardową bibliotekę typów otworów oraz sprzętu.

  • Odinstalowywanie produktów

    Po wybraniu opcji Usuń lub Odinstaluj programy z Panelu sterowania ekran ten wyświetla produkty SOLIDWORKS (wraz z numerami wersji), które mogą być odinstalowane przez tę wersję Menedżera instalacji SOLIDWORKS. Można wybrać opcję, aby przeprowadzić standardowe, dostosowane lub całkowite odinstalowanie.


SOLIDWORKS Pobieracz w tle

Pobieracz w tle SOLIDWORKS wykonuje automatyczne pobrania pliku (na przykład po znalezieniu nowej wersji pakietu Service Pack) przy użyciu procesów w tle, pozwalając na kontynuowanie innych prac podczas pobierania. Kiedy pobieranie zostanie ukończone, użytkownik może zadecydować, czy chce wykonać instalację od razu, odroczyć ją, czy też usunąć pobrane pliki.

Pobieracz w tle jest domyślnie włączony podczas instalacji SOLIDWORKS.

Gdy Menedżer instalacji, wykonując operacje instalacji lub pobierania, Pobieracz w tle jest wstrzymany. Na przykład: wstrzyma on wszelkie biegnące pobrania, nie zezwoli na rozpoczęcie żadnych nowych pobrań i nie zezwoli na zmianę określenia foldera pobrań.

Pobieracz w tle można wyłączyć podczas instalacji. Na stronie Podsumowanie, w obszarze Opcje pobierania, usunąć zaznaczenie opcji Użyj Pobieracza w tle dla przyszłych pakietów Service Pack.

Gdy opcja jest włączona, w obszarze powiadomień paska narzędzi Windows pojawia się ikona:

Kliknięcie tej ikony powoduje włączenie następujących operacji:
  • Pomoc Pobieracza w tle
  • Wstrzymaj pobieranie
  • Wznów pobieranie
  • Anuluj pobieranie
  • Opcje instalacji
  • Zmień ustawienia pobrania
  • Sprawdź dostępność aktualizacji
  • Automatycznie sprawdź, czy istnieją aktualizacje
  • Automatycznie pobierz aktualizacje
  • Wyłącz Pobieracz w tle

Pomoc Pobieracza w tle

Otworzyć ten temat pomocy dla Pobieracza w tle w Przewodniku instalacji SOLIDWORKS.

Wstrzymaj/wznów pobieranie

Jeżeli pobieranie trwa w tle, należy kliknąć Wstrzymaj pobieranie, aby wstrzymać to pobieranie, zachowując możliwość późniejszego wznowienia poprzez kliknięcie Wznów pobieranie.

Anuluj pobieranie

Jeżeli trwa pobieranie, jest ono zatrzymywane i następuje usunięcie wszystkich plików już pobranych przez Pobieracz w tle.
Nie można wznowić anulowanego pobierania.

Opcje instalacji

Po zakończeniu pobierania można wybrać spośród następujących opcji:
  • Zainstaluj teraz: Instaluje pobrane pliki.
  • Przypomnij mi później: Nie instaluje pobranych plików, lecz konfiguruje komunikat późniejszego przypomnienia.
  • Usuń to pobranie: Nie instaluje pobranych plików i usuwa je. (Jest to użyteczne, jeżeli użytkownik zdecydował, że jednak nie chce instalować pobranych plików).

Zmień ustawienia pobrania

Zmienia lokalizację folderu, do której Pobieracz w tle pobiera pliki.

Ta opcja nie jest dostępna jeśli pobieranie trwa lub zostało wstrzymane.
Można również określić Liczbę dni pomiędzy kontrolami aktualizacji.

Sprawdź czy istnieją aktualizacje

Uruchamia funkcję Sprawdź czy istnieją aktualizacje Menedżera instalacji SOLIDWORKS.

Automatyczne sprawdzanie, czy istnieją aktualizacje

Okresowo uruchamia narzędzie Sprawdź czy istnieją aktualizację, informując, gdy aktualizacje są dostępne do pobrania.

Automatycznie pobierz aktualizacje

Okresowo uruchamia narzędzie Sprawdź czy istnieją aktualizacje, pobierając aktualizacje gdy są dostępne.

Wyłączanie i ponowne włączanie Pobieracza w tle SOLIDWORKS

Pobieranie w tle można wyłączyć, klikając ikonę w pasku zadań systemu Windows, a następnie wybierając Wyłącz pobieranie w tle.

Aby włączyć ponownie Pobieracz w tle, należy kliknąć Start > Menedżer instalacji SOLIDWORKS > Pobieracz w tle SOLIDWORKS.

Temat nadrzędny Pomoc aplikacji Menedżer instalacji SOLIDWORKS


Określanie opcji Menedżera instalacji

Opcje te obejmują ustawienia rejestrowania, dostępu do Internetu oraz języka używanego w Menedżerze instalacji.

Aby określić opcje Menedżera instalacji przed zainstalowaniem oprogramowania:

  1. W Menedżerze instalacji kliknąć prawym przyciskiem myszy ikonę SOLIDWORKS na pasku tytułowym i wybrać:
    Opcja | Opis
    Poziomy tworzenia pliku dziennika instalacji Określa poziom rejestracji jako wysoki, średni lub niski. W przypadku wyższych poziomów zbieranych jest więcej danych na potrzeby rozwiązywania problemów, ale może to spowolnić instalację. Domyślna jest opcja Niski (najszybsza), która zapewnia najlepszą wydajność i stabilność.

    Opcja Utwórz pliki dziennika instalacji Windows (wolno) zapisuje dzienniki w tym samym folderze co inne dzienniki instalacji.
    Opcje obrazu administracyjnego | Wybrać opcję Użyj krótkich nazw plików (format 8.3) lub Użyj pełnych nazw folderów lub plików.
    Zbieranie dzienników instalacji | Określa lokalizację zapisu dzienników instalacji. Menedżer instalacji zapisuje te pliki w archiwum IM_Logs.zip.
    Wyłącz dostęp do internetu
    Język | Określa język używany w Menedżerze instalacji. Domyślnie jest to język angielski.
  2. Kliknąć Zamknij.
Temat nadrzędny Pomoc aplikacji Menedżer instalacji SOLIDWORKS


Wyniki sprawdzenia czy istnieją aktualizacje

Narzędzie Sprawdź, czy istnieją aktualizacje wyszukuje nowsze wersje oprogramowania SOLIDWORKS.

Jeśli użytkownik ma uprawnienia administratora na danym komputerze, może ręcznie uruchomić funkcję Sprawdź, czy istnieją aktualizacje:
  • W systemie Windows kliknąć Start > Menedżer instalacji SOLIDWORKS > Sprawdź, czy istnieją aktualizacje.
  • W SOLIDWORKS kliknąć [image] > Sprawdź, czy istnieją aktualizacje.
Narzędzie Sprawdź, czy istnieją aktualizacje nie jest dostępne w klientach zainstalowanych z obrazu administracyjnego.

Dostępna nowa wersja

Menedżer instalacji SOLIDWORKS wykrył nowszą wersję produktów SOLIDWORKS. Można aktualizować do nowszej wersji poprzez wybranie Menedżera instalacji SOLIDWORKS dla tej wersji.

Nowsza wersja może pobierać pliki instalacyjne na podstawie produktów określonych w instalacji. Można współużytkować pobrane pliki z innymi użytkownikami dokonującymi instalacji za pomocą Menedżera instalacji SOLIDWORKS.

Pobrania te są do użycia tylko za pomocą Menedżera instalacji SOLIDWORKS.
Dostępne opcje:
  • Jeżeli dostępnych jest wiele wersji, można wybrać wersję z listy.
  • Aby uzyskać szczegółowe informacje na temat tej wersji, należy kliknąć Sprawdź co obejmuje to uaktualnienie.
Kliknięcie Dalej uzyskuje i uruchamia wybraną wersję Menedżera instalacji SOLIDWORKS.

Brak dostępnych nowych pobrań/Nie można sprawdzić, czy istnieją nowe wersje

Menedżer instalacji SOLIDWORKS nie znalazł nowszej wersji produktów SOLIDWORKS ponieważ instalowana jest najnowsza dostępna wersja, bądź nie mógł połączyć się ze stroną internetową SOLIDWORKS w celu sprawdzenia dostępności.

Temat nadrzędny Pomoc aplikacji Menedżer instalacji SOLIDWORKS


Lokalizacja obrazu administracyjnego

Można określić lokalizację instalacji obrazu administracyjnego.

Podczas tworzenia obrazu administracyjnego zastosowanie mają poniższe opcje:
Lokalizacja nowego obrazu | Jest to lokalizacja katalogu, w którym Menedżer instalacji SOLIDWORKS utworzy nowy obraz. | Lokalizacja ta nie może zawierać istniejącego obrazu administracyjnego. Obraz administracyjny musi znajdować się w folderze, który może być współużytkowany, aby rozmieścić klientów.
Szacowane miejsce wymagane dla utworzenia obrazu | Jest to dodatkowe miejsce wymagane dla obrazu administracyjnego. | Należy sprawdzić, czy dysk, na którym odbywa się instalacja, posiada wystarczającą ilość miejsca, spełniającą wymogi obrazu.
Utwórz obraz z | Jest to lokalizacja katalogu, z którego instalowane są produkty SOLIDWORKS. Opcja ta pojawia się tylko jeżeli określono opcję Tylko zainstaluj. Szczegółowe informacje zawiera temat Opcje pobierania.
Temat nadrzędny Pomoc aplikacji Menedżer instalacji SOLIDWORKS


Opcje pobierania

Należy określić szczegóły dotyczące dokończenia operacji pobierania, takie jak lokalizacja pobieranych plików, sposób pobierania plików oraz to, czy należy zainstalować pobrane pliki.

Menedżer instalacji SOLIDWORKS obsługuje elektroniczną dystrybucję oprogramowania (Electronic Software Distribution — ESD). Jeżeli instalacja nie odbywa się z płyty SOLIDWORKS DVD, pojawi się monit o określenie źródła instalacji dla instalowanych produktów SOLIDWORKS.

Odpowiedzi na pytania dotyczące folderu pobierania zawiera temat Folder pobrania Menedżera instalacji SOLIDWORKS.

Co chcesz zrobić?

Należy wybrać jedną z poniższych opcji:

Pobierz i zainstaluj/Zainstaluj i utwórz obraz

Po zakończeniu pobierania, Menedżer instalacji SOLIDWORKS uruchamia instalację z wykorzystaniem pobranych plików.

Tylko pobierz. Pliki można pobrać raz a następnie udostępnić pobrane pliki wielu komputerom.

Menedżer instalacji SOLIDWORKS nie uruchamia instalacji po zakończeniu pobierania.

Zwykle opcja ta jest wybierana, jeżeli pobierane są pliki w celu skonfigurowania zbioru plików instalacyjnych celem udostępnienia ich wielu komputerom.

Jeżeli opcja ta zostanie wybrana, pojawi się monit o wybranie jednego z dwóch zbiorów plików do pobrania:
  • Pliki dla TEGO komputera: Pobranie będzie zawierać tylko te pliki, których brak w zbiorze plików instalacyjnych na tym komputerze.
    Pobranie to powinno być mniejsze, ponieważ zawiera ono:
    • Tylko pliki dla produktów wybranych na stronie Wybór produktu
    • Tylko wstępnie wymagane pliki, które są konieczne dla tego komputera, lecz nie są jeszcze zainstalowane

    Jednakże w przypadku próby użycia tego zbioru pobranych plików na innym komputerze w celu wykonania instalacji, niektóre pliki mogą brakować (ponieważ zbiór plików instalacyjnych na innym komputerze może różnić się od tego zbioru). Można użyć tych plików w celu instalacji na innym komputerze, jednak po uruchomieniu instalacji może zachodzić konieczność pobrania dodatkowych plików, aby uzupełnić zbiór plików instalacyjnych w danym komputerze.

  • Pliki do udostępnienia DOWOLNEMU komputerowi: Pobranie będzie zawierać pełny zbiór plików instalacyjnych, który można wykorzystać do zainstalowania danej wersji na dowolnym komputerze.

    Pobranie to będzie większe, ponieważ zawiera ono pełny zbiór plików, który można wykorzystać do zainstalowania danej wersji dowolnego produktu na dowolnym komputerze.

    Jeżeli określono ograniczony zbiór produktów do pobrania, ta opcja ignoruje tamtą specyfikację i pobiera wszystkie produkty zawarte w danej wersji produktu.

    Pobranie będzie zawierać wszystkie pliki wymagane do utworzenia obrazu administracyjnego, a nie tylko pliki wymagane do wykonania indywidualnej instalacji.

Tylko zainstaluj/Tylko utwórz obraz. Mam już wszystkie potrzebne pliki instalacyjne.

Menedżer instalacji SOLIDWORKS nie pobiera żadnych plików, lecz wykorzystuje pliki z wybranego katalogu.

Kliknąć Przeglądaj, aby przejść do innej lokalizacji. Na przykład: można przejść do instalacyjnego dysku DVD lub folderu pobierania, pod warunkiem, że ta lokalizacja zawiera wszystkie wymagane pliki.

Jeżeli pojawi się komunikat o błędzie informujący, że folder jest niekompletny, a oczekiwano wszystkich plików instalacyjnych w tej lokalizacji, przyczyny mogą być następujące:
  • Wybrano komponent, który nie został poprzednio pobrany lub był on wybrany domyślnie.
  • Pliki zostały pobrane na innym komputerze o innym zbiorze wymagań systemowych.
  • Poprzednio wykonano instalację klienta a teraz tworzony jest obraz administracyjny, co wymaga większego zbioru plików.

Można przejść do folderu zawierającego wszystkie pliki (np. na dysku DVD) lub wybrać jedną z opcji pobierania.

Gdzie chcesz pobrać wymagane pliki?

Jest to lokalizacja folderu pobierania.

W niektórych przypadkach opcja ta może być widoczna, lecz nieaktywna. Na przykład: jeżeli wybrano opcję Tylko zainstaluj, Menedżer instalacji SOLIDWORKS zainstaluje wszelkie pobrane pliki z katalogu określonego dla tej opcji, zamiast wykorzystywać oddzielny folder pobierania.

Wszystkie pliki muszą być pobrane do tego samego folderu pobierania niezależnie od tego czy są one pobierane, czy uzyskiwany jest do nich dostęp z własnej lokalizacji.

Szacowany rozmiar pobrania

Szacowane zapotrzebowanie pobierania na miejsce na dysku jest oparte na kompletnej liście wybranych komponentów, niezależnie od tego czy jest to nowe pobranie czy kontynuacja poprzedniej sesji.

Na przykład jeżeli wznawiane jest poprzednie pobranie, Menedżer instalacji SOLIDWORKS przetwarza tylko te pliki które nie zostały jeszcze pobrane. Czas pobierania może być krótszy niż podano.

Jeżeli pobieranie pliku zostało ukończone w poprzedniej sesji pobierania, jego rozmiar nie jest uwzględniany w tym oszacowaniu. Dlatego też oszacowanie może być wyższe niż rzeczywisty rozmiar pobrania.

Jak chcesz pobrać?

Przeprowadź pobranie ręczne

W niektórych przypadkach serwer proxy może nie zezwalać na automatyczne pobieranie z Menedżera instalacji SOLIDWORKS.

Wybranie tej opcji pozwala na ręczne pobieranie plików za pośrednictwem strony internetowej, a następnie kontynuowanie operacji instalacji w Menedżerze instalacji SOLIDWORKS w celu jej dokończenia. Ta strona internetowa jest dostosowywana przez Menedżer instalacji SOLIDWORKS tak, by pobrać tylko te pliki, które są wymagane do ukończenia instalacji.

Używanie programu Pobieracz w tle SOLIDWORKS

Można użyć Pobieracza w tle SOLIDWORKS, aby ukończyć tą operację pobrania lub pobrać przyszłe pakiety Service Pack SOLIDWORKS kiedy staną się one dostępne.

SOLIDWORKS Pobieracz w tle może automatycznie wykryć i pobrać nowe aktualizacje pakietów Service Pack w tle, powiadamiając użytkownika kiedy pobranie jest ukończone i pliki są gotowe do instalacji. Szczegółowe informacje zawiera temat SOLIDWORKS Pobieracz w tle.

Temat nadrzędny Pomoc aplikacji Menedżer instalacji SOLIDWORKS


Opcje pobierania dla plików Menedżera instalacji SOLIDWORKS

Wybrano pobranie późniejszej wersji Menedżera instalacji SOLIDWORKS. Należy użyć tego ekranu, aby określić gdzie i jak ma on zostać pobrany.

Odpowiedzi na pytania dotyczące folderu pobierania zawiera temat Folder pobrania Menedżera instalacji SOLIDWORKS.

Ten ekran pojawia się tylko wtedy, jeżeli występuje problem z domyślnym folderem pobierania (na przykład: brak dostępu do zapisu lub dostępu sieciowego). Zwykle wystarczy określić alternatywny katalog pobierania, aby kontynuować.

Katalog pobierania

Należy przejść do katalogu docelowego plików Menedżera instalacji SOLIDWORKS.

Pokazany jest rozmiar pobrania oraz ilość potrzebnego miejsca. Potrzebna ilość miejsca uwzględnia dodatkowe miejsce wymagane do rozpakowania pewnych pobrań i jest większa niż rzeczywisty rozmiar pobrania.

Temat nadrzędny Pomoc aplikacji Menedżer instalacji SOLIDWORKS


Pobierz pliki instalacji produktów

Należy określić gdzie i jak pobrane maja być brakujące pliki dla określonego produktu.

Menedżer instalacji SOLIDWORKS, weryfikuje i wyodrębnia wszystkie pliki równolegle podczas procesu pobrania.

Anulowanie tego ekranu anuluje resztę sekwencji instalacji.

Aby uzyskać informacje na temat anulowania i instrukcje dotyczące dokończenia przerwanych instalacji, patrz Błędy instalacji / Anulowano instalację.

Katalog pobierania

Należy przejść do katalogu docelowego dla pobieranych plików.

Podawany jest rozmiar pobieranych plików i wymagana ilość miejsca. Wymagana ilość miejsca uwzględnia dodatkowe miejsce wymagane do rozpakowania pewnych pobieranych plików i jest większa niż rzeczywisty rozmiar pobieranych plików.

Odpowiedzi na pytania dotyczące folderu pobierania zawiera temat Folder pobrania Menedżera instalacji SOLIDWORKS.

Temat nadrzędny Pomoc aplikacji Menedżer instalacji SOLIDWORKS
Błędy instalacji / Anulowano instalację
Folder pobrania Menedżera instalacji SOLIDWORKS


Pobieranie w toku

Menedżer instalacji SOLIDWORKS pobiera, weryfikuje i wyodrębnia wszystkie pliki równolegle w tym procesie.

Aby anulować pobieranie po jego rozpoczęciu, należy kliknąć Anuluj.

W przypadku anulowania lub niepowodzenia pobrania, ekran Anulowano pobranie lub Problem z pobraniem informuje, które pobrania nie zostały zakończone i pozwala na wznowienie pobierania lub zamknięcie aplikacji.

Odpowiedzi na pytania dotyczące folderu pobierania zawiera temat Folder pobrania Menedżera instalacji SOLIDWORKS.
Temat nadrzędny Pomoc aplikacji Menedżer instalacji SOLIDWORKS


Wyniki pobrania

Informują, czy pobieranie zostało ukończone z powodzeniem, czy czynność ta zakończyła się niepowodzeniem, czy też została anulowana.

Problem z pobraniem/Anulowano pobieranie

Pojawienie się komunikatu Problem z pobieraniem oznacza, że Menedżer instalacji SOLIDWORKS napotkał problemy, które uniemożliwiły dokończenie pobierania.

Pojawienie się komunikatu Anulowano pobieranie oznacza, że anulowano pobieranie przed jego zakończeniem.

Aby kontynuować:

Spróbuj ponownie/Wznów automatyczne pobrania | Aby wznowić automatyczne pobieranie od miejsca, w którym nastąpiło jego anulowanie, należy wybrać tę opcję i kliknąć Ponów próbę pobrania lub Wznów pobranie.
Pobierz pliki indywidualnie w przeglądarce sieci Web | W niektórych przypadkach serwer proxy może nie zezwalać na automatyczne pobieranie z Menedżera instalacji SOLIDWORKS. | Wybranie tej opcji pozwala na ręczne pobieranie plików za pośrednictwem strony internetowej, a następnie kontynuowanie operacji instalacji w Menedżerze instalacji SOLIDWORKS w celu jej dokończenia. Ta strona internetowa jest dostosowywana przez Menedżer instalacji SOLIDWORKS tak, by pobrać tylko te pliki, które są wymagane do ukończenia instalacji.

Ukończono pobieranie

Ekran Ukończono pobieranie pojawia się po zakończeniu pobierania, jeżeli wybrano opcję Tylko pobierz.

Kliknąć Zakończ, aby wyjść z Menedżera instalacji SOLIDWORKS.

Nie podejmować prób instalowania któregokolwiek z tych produktów ręcznie. Do zainstalowania pobranych plików należy zawsze używać Menedżera instalacji SOLIDWORKS.
Temat nadrzędny Pomoc aplikacji Menedżer instalacji SOLIDWORKS


Błędy instalacji / Anulowano instalację

Instalacja napotkała błąd lub została anulowana.

Jeżeli wystąpi błąd lub anulowanie, należy:
  • Produkty zainstalowane przed błędem lub anulowaniem, pozostają na komputerze.
  • Produkt, który był instalowany podczas anulowania jest przywrócony do poprzedniego stanu, tak że nie ma częściowych instalacji.
  • Pozostałe produkty nie są zainstalowane ani odinstalowane. Odpowiednia lista znajduje się w części Jeszcze nie próbowano.

    Aby wznowić instalowanie lub odinstalowywanie tych produktów, należy kliknąć podane łącze.

Menedżer instalacji SOLIDWORKS instaluje najpierw wszelkie wymagane wstępnie produkty, które nie są zainstalowane na danym komputerze, takie jak .NET Framework.

Spis treści

  • Przywracanie normalnego stanu po nieudanej lub anulowanej instalacji

    Jeżeli podczas instalacji wystąpi błąd lub anulowanie, można powrócić do normalnego stanu w tej sytuacji poprzez ponowne uruchomienie instalacji.

  • Naprawianie instalacji

    Jeżeli napotkamy na problemy z zainstalowanym produktem SOLIDWORKS, można użyć Menedżera instalacji SOLIDWORKS, aby naprawić instalację.

  • Kontaktowanie się z dystrybutorem SOLIDWORKS

    Jeżeli modyfikowanie lub naprawianie instalacji nie powiedzie się, należy skontaktować się z lokalnym dystrybutorem SOLIDWORKS i przedstawić mu informacje pokazane na ekranie. Może być również konieczne przygotowanie pliku zip plików dziennika Menedżera instalacji SOLIDWORKS.

Temat nadrzędny Pomoc aplikacji Menedżer instalacji SOLIDWORKS


Przywracanie normalnego stanu po nieudanej lub anulowanej instalacji

Jeżeli podczas instalacji wystąpi błąd lub anulowanie, można powrócić do normalnego stanu w tej sytuacji poprzez ponowne uruchomienie instalacji.

  1. Zarejestrować komunikat o błędzie oraz kod produktu dla instalacji, która się nie powiodła (patrz ekran Błędy instalacji lub Anulowano instalację).
    Jeżeli oprogramowanie wyświetli monit o wskazanie pliku źródłowego, a istniejąca instalacja SOLIDWORKS nie jest modyfikowana, instalacja lub komputer mogą być uszkodzone. Należy skontaktować się z dystrybutorem SOLIDWORKS.
  2. Ponownie uruchomić komputer.
  3. Aby upewnić się, że żadne produkty SOLIDWORKS nie są uruchomione w systemie Windows, nacisnąć Ctr+Alt+Del, aby otworzyć Menedżer zadań.
  4. Na karcie Procesy, jeżeli którekolwiek z poniższych procesów pojawiają się w części Nazwa obrazu, należy je wybrać i kliknąć Zakończ proces.
    • SLDWORKS.exe
    • EModelViewer.exe
    • PDMworks.exe
    • pdmwVault.exe
    • SWViewer.exe
    • swlmwiz.exe
    • SWBoengine.exe
    • SWVBAServer.exe
    • Sldshellextserver.exe
  5. Jeżeli aplikacja jest już zainstalowana i próbowano ją zmodyfikować lub usunąć, należy spróbować naprawić instalację. Aby uzyskać więcej informacji, patrz Naprawianie instalacji.
  6. W systemie Windows kliknąć Start > Panel sterowania > Programy i funkcje.
  7. Wybrać wersję SOLIDWORKS, której instalacja się nie powiodła.
    Jeżeli nie ma wpisu dla wersji SOLIDWORKS, którą próbujemy zainstalować, należy powtórzyć proces instalacji.
  8. Wykonać jedną z poniższych czynności:
    • Aby spróbować ponownie, należy kliknąć Zmień i wybrać wszystkie produkty, których instalacja nie powiodła się lub zostały pominięte podczas instalacji.

    • Aby pominąć instalację, która się nie powiodła, należy kliknąć Zmień i wybrać wszystkie produkty, które zostały pominięte podczas instalacji. Wyczyścić produkty, których instalacja nie powiodła się.

    • Aby porzucić instalację, należy kliknąć Usuń i wybrać wszystkie produkty, które zostały zainstalowane.
    Nie przywróci to poprzedniej wersji żadnego z aktualizowanych produktów.
Temat nadrzędny Błędy instalacji / Anulowano instalację
Naprawianie instalacji
Kontaktowanie się z dystrybutorem SOLIDWORKS


Kontaktowanie się z dystrybutorem SOLIDWORKS

Jeżeli modyfikowanie lub naprawianie instalacji nie powiedzie się, należy skontaktować się z lokalnym dystrybutorem SOLIDWORKS i przedstawić mu informacje pokazane na ekranie. Może być również konieczne przygotowanie pliku zip plików dziennika Menedżera instalacji SOLIDWORKS.

  1. Zlokalizować pliki dziennika. Dla Windows:
    C:\Users\nazwaużytkownika\AppData\Roaming\SOLIDWORKS\Installation Logs\zainstalowana_wersja\.
    Jeżeli nie można znaleźć folderu może to oznaczać że jest on ukryty. W Eksploratorze plików kliknąć Narzędzia > Opcje folderu. Na karcie Widok, w części Ustawienia zaawansowane, wybrać Pokaż ukryte pliki, foldery i napędy dla opcji Ukryte pliki i foldery.
  2. Spakować całą zawartość tego folderu włącznie z podfolderami.
Temat nadrzędny Błędy instalacji / Anulowano instalację
Przywracanie normalnego stanu po nieudanej lub anulowanej instalacji
Naprawianie instalacji


Ukończono instalację

Menedżer instalacji SOLIDWORKS zakończył pracę.

Może zostać wyświetlona jedna z poniższych opcji.

Nowe funkcje

Dla indywidualnych instalacji, po zakończeniu procesu instalacji, pojawi się dokument opisujący nowe funkcje w SOLIDWORKS oraz dodatkach.

Dla instalacji obrazu administracyjnego, dokument pojawi się na komputerach klientach po ukończeniu ich instalacji.

Przyłącz się do Programu udoskonalenia doświadczeń klientów SOLIDWORKS

Informacje o wydajności są wysyłane do SOLIDWORKS Corporation celem pomocy w opracowywaniu ulepszeń produktu. Proces ten jest transparentny i poufny. Wybrać jedną z następujących opcji:
  • Tak, chcę się przyłączyć
  • Nie, dziękuję
  • Przypomnij mi później
Aby uzyskać więcej informacji, należy odwiedzić stronę internetową Programu udoskonalenia doświadczeń klientów.

Ukończono tworzenie obrazu administracyjnego

Po zakończeniu tworzenia obrazu administracyjnego, można kliknąć Dostosuj obraz, aby uruchomić Edytor opcji obrazu administracyjnego i dostosować obraz.

Kliknąć Pokaż mi jak zainstalować ten obraz na kliencie, aby pokazać instrukcje dotyczące używania Edytora opcji.

Aby uzyskać szczegółowe informacje na temat konfigurowania obrazu administracyjnego przy użyciu Edytora opcji, należy zapoznać się z tematem Edytor opcji obrazu administracyjnego.

Kliknąć Dostosuj obraz, aby uruchomić Edytor opcji obrazu administracyjnego i dostosować ustawienia opcji dla tego obrazu administracyjnego.
Można uruchomić Edytor opcji później, klikając dwukrotnie sldAdminOptionEditor.exe w folderze SOLIDWORKS Admin.

Spis treści

  • Sprawdzanie czy istnieją aktualizacje dla SOLIDWORKS

    Jeżeli masz uprawnienia administratora na danym komputerze, możesz użyć Menedżera instalacji SOLIDWORKS do ręcznego sprawdzania dostępności aktualizacji lub skonfigurowania automatycznego okresowego sprawdzania ich dostępności.

  • Program udoskonalenia doświadczeń klientów SOLIDWORKS

    Podczas instalowania SOLIDWORKS można określić, że informacje dotyczące wydajności będą wysyłane do SOLIDWORKS Corporation, aby pomóc w udoskonalaniu produktu.

Temat nadrzędny Pomoc aplikacji Menedżer instalacji SOLIDWORKS
Edytor opcji obrazu administracyjnego


Sprawdzanie czy istnieją aktualizacje dla SOLIDWORKS

Jeżeli masz uprawnienia administratora na danym komputerze, możesz użyć Menedżera instalacji SOLIDWORKS do ręcznego sprawdzania dostępności aktualizacji lub skonfigurowania automatycznego okresowego sprawdzania ich dostępności.

  1. Uruchomić Menedżer instalacji SOLIDWORKS, wykonując jedną z poniższych czynności:

    • W aplikacji SOLIDWORKS kliknąć Pomoc > Sprawdź, czy istnieją aktualizacje.

    • W systemie Windows kliknąć Start > Programy > Menedżer instalacji SOLIDWORKS > Sprawdź, czy istnieją aktualizacje.

    Można również kliknąć Start > Menedżer instalacji SOLIDWORKS > Pobieracz w tle SOLIDWORKS. W obszarze powiadomień systemu Windows kliknąć prawym przyciskiem myszy pozycję Pobieracz w tle SOLIDWORKS i kliknąć Sprawdź dostępność aktualizacji.
    Menedżer instalacji SOLIDWORKS poinformuje, czy dostępne są jakiekolwiek aktualizacje.
  2. Jeżeli aktualizacje są dostępne, należy wybrać czy mają one zostać pobrane i zainstalowane.
  3. Aby włączyć automatyczne okresowe sprawdzanie aktualizacji, po zakończeniu przetwarzania przez Menedżer instalacji SOLIDWORKS należy wybrać Sprawdź czy istnieją aktualizacje co __ dni i określić częstotliwość sprawdzania.
Temat nadrzędny Ukończono instalację
Program udoskonalenia doświadczeń klientów SOLIDWORKS


Program udoskonalenia doświadczeń klientów SOLIDWORKS

Podczas instalowania SOLIDWORKS można określić, że informacje dotyczące wydajności będą wysyłane do SOLIDWORKS Corporation, aby pomóc w udoskonalaniu produktu.

SOLIDWORKS używa zebranych informacji, aby określić trendy dotyczące użycia produktu oraz jego jakości. Naszym celem jest dostarczenie produktu o jak najwyższej jakości i dzienniki wydajności są narzędziem, które może nam pomóc w tym procesie.

Proces ten jest transparentny. Wszystkie informacje zawarte w plikach dziennika są traktowane jako poufne. Nie są one używane w żadnym innym celu i nikt nie będzie kontaktował się z użytkownikiem.

Aby uzyskać więcej informacji, należy odwiedzić stronę internetową Programu udoskonalenia doświadczeń klientów.

Temat nadrzędny Ukończono instalację
Sprawdzanie czy istnieją aktualizacje dla SOLIDWORKS


Lokalizacja instalacji

Do instalacji innych od tworzenia obrazu administracyjnego, zastosowanie mają poniższe opcje:
Zainstaluj wybrane produkty w | Jest to lokalizacja katalogu, w którym instalowana jest aplikacja SOLIDWORKS. Przy uaktualnianiu lub modyfikowaniu instalacji, wszystkie pliki muszą być zainstalowane do istniejącej lokalizacji dla tej instalacji. W tym przypadku nie można zmieniać lokalizacji istniejącej instalacji SOLIDWORKS.
Szacowane miejsce wymagane dla instalacji | Jest to dodatkowe miejsce wymagane dla produktów wybranych do instalacji lub modyfikacji. | Należy sprawdzić, czy dysk, na którym odbywa się instalacja, posiada wystarczającą ilość miejsca, spełniającą wymogi instalacji.
Zainstaluj z | Jest to lokalizacja katalogu, z którego instalowana jest aplikacja SOLIDWORKS. Opcja ta pojawia się tylko jeżeli określono opcję Tylko zainstaluj. Aby uzyskać szczegółowe informacje, należy zapoznać się z tematem Opcje pobierania.
Przed zmianą którejkolwiek z lokalizacji instalacji SOLIDWORKS należy skonsultować się ze swoim administratorem systemu.

Lokalizacje obrazu administracyjnego

Podczas tworzenia obrazu administracyjnego zastosowanie mają poniższe opcje:
Lokalizacja nowego obrazu | Jest to lokalizacja katalogu, w którym Menedżer instalacji SOLIDWORKS utworzy nowy obraz. | Lokalizacja ta nie może zawierać istniejącego obrazu administracyjnego.
Szacowane miejsce wymagane dla utworzenia obrazu | Jest to dodatkowe miejsce wymagane dla obrazu administracyjnego. | Należy sprawdzić, czy dysk, na którym odbywa się instalacja, posiada wystarczającą ilość miejsca, spełniającą wymogi obrazu.
Utwórz obraz z | Jest to lokalizacja katalogu, z którego instalowane są produkty SOLIDWORKS. Opcja ta pojawia się tylko jeżeli określono opcję Tylko zainstaluj. Aby uzyskać szczegółowe informacje, należy zapoznać się z tematem Opcje pobierania.
Lokalizacja istniejącego obrazu | Przy uaktualnianiu istniejącego obrazu administracyjnego, Menedżer instalacji SOLIDWORKS tworzy nowy obraz w oparciu o ustawienia dla tego istniejącego obrazu. Istniejący obraz nie jest modyfikowany. Ukazuje to lokalizację pierwotnego obrazu określoną na ekranie Witamy.

Unikanie ścieżek katalogów specyficznych dla wersji

W przypadku określenia numeru wersji w lokalizacji katalogu instalacyjnego (na przykład C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS 2023\), a następnie uaktualnienia tej instalacji do wersji SOLIDWORKS 2024, będzie istniał katalog instalacyjny wersji SOLIDWORKS 2024 z oznaczeniem SOLIDWORKS 2023.

Temat nadrzędny Pomoc aplikacji Menedżer instalacji SOLIDWORKS
Opcje pobierania


Opcje uaktualniania

Na tym komputerze jest zainstalowana co najmniej jedna starsza wersja główna SOLIDWORKS. Można utworzyć nową instalację, która będzie współistnieć ze starszą wersją, lub dokonać uaktualnienia, co spowoduje usunięcie starszej wersji.

Utworzyć nową instalację SOLIDWORKS wersja.

Przy tworzeniu nowej instalacji można wybrać produkty SOLIDWORKS do zainstalowania.

Dla każdego z wybranych produktów tworzona jest nowa instalacja tej wersji głównej. Starsze wersje główne pozostają na komputerze (z wyjątkiem SOLIDWORKS Electrical i SOLIDWORKS PDM Client).

Usunięcie zaznaczenia produktu spowoduje, że nowa wersja nie zostanie zainstalowana.

Tworzenie nowej instalacji jest użyteczne, jeżeli zachodzi potrzeba dostępu do starszej wersji SOLIDWORKS nawet po zainstalowaniu nowej wersji. Na przykład: w przypadku współużytkowania plików z innymi użytkownikami, którzy nadal korzystają ze starszej wersji, można uniknąć niezgodności wersji z plikami zapisanymi przy użyciu nowszej wersji.

Uaktualnij SOLIDWORKS poprzednia_wersja_główna do SOLIDWORKS bieżąca_wersja_główna.

W przypadku wybrania opcji uaktualnienia można wybrać produkty SOLIDWORKS do uaktualnienia. Dla każdego z wybranych produktów tworzona jest nowa instalacja, a starsze wersje są usuwane.

Usunięcie zaznaczenia produktu spowoduje, że nowa wersja nie zostanie zainstalowana, a starsza pozostanie na komputerze.

Objaśnienia dotyczące SOLIDWORKS Electrical i klienta SOLIDWORKS PDM

Na danym komputerze można zainstalować tylko jedną wersję SOLIDWORKS Electrical. W przypadku tworzenia nowej instalacji SOLIDWORKS i wybrania SOLIDWORKS Electrical jako jednego z produktów do zainstalowania stara wersja SOLIDWORKS Electrical jest usuwana.

Przed zainstalowaniem nowej wersji należy utworzyć kopię zapasową istniejącego środowiska SOLIDWORKS Electrical. W SOLIDWORKS Electrical Schematic wybrać kolejno Plik Archiwizuj środowisko lub w SOLIDWORKS Electrical 3D wybrać kolejno SOLIDWORKS Electrical > Narzędzia > Archiwizuj środowisko.

Wersja główna klienta SOLIDWORKS PDM musi odpowiadać wersji głównej serwera SOLIDWORKS PDM. Jeśli serwer SOLIDWORKS PDM nie ma zostać uaktualniony, nie należy wybierać klienta SOLIDWORKS PDM do uaktualnienia.

Aby usunąć produkt z systemu Windows, należy użyć narzędzia Dodaj/Usuń programy. Szczegółowe informacje zawiera temat Usuwanie instalacji.
Temat nadrzędny Pomoc aplikacji Menedżer instalacji SOLIDWORKS
Usuwanie instalacji


Postęp instalacji

Ekran ten pokazuje postęp instalacji.

Aby anulować instalację po jej rozpoczęciu, należy kliknąć Anuluj.

Aby uzyskać informacje na temat anulowania i instrukcje dotyczące dokończenia przerwanych instalacji, patrz Błędy instalacji.

Temat nadrzędny Pomoc aplikacji Menedżer instalacji SOLIDWORKS


Typ instalacji

Można określić operację instalacji, która ma zostać uruchomiona. Przykłady to: tworzenie nowej instalacji, modyfikowanie lub naprawianie istniejącej instalacji, tworzenie obrazu administracyjnego, instalowanie produktów serwera administracyjnego lub pobieranie plików, aby można je było współużytkować i zainstalować na innych komputerach.

Jeżeli najnowsza wersja oprogramowania SOLIDWORKS jest już zainstalowana na danym komputerze, dostępne są opcje jego modyfikacji lub naprawy.

Indywidualna

Instaluje produkty SOLIDWORKS na tym komputerze.

Ta opcja pojawia się tylko wtedy, gdy dana wersja nie jest zainstalowana na komputerze.

Modyfikuj instalację indywidualną

Modyfikuje istniejącą instalację SOLIDWORKS na tym komputerze.

Ta opcja pojawia się tylko wtedy, gdy dana wersja jest zainstalowana na komputerze.
Modyfikacje obejmują:
  • Dodawanie lub usuwanie komponentów produktów SOLIDWORKS
  • Zmienianie pakietu SOLIDWORKS na inny (na przykład: SOLIDWORKS Professional, SOLIDWORKS Premium, SOLIDWORKS Ultimate itd.)
  • Zmienianie ustawienia numeru seryjnego SOLIDWORKS
    Jeżeli podano już numer seryjny SOLIDWORKS podczas wcześniejszej instalacji, to Menedżer instalacji SOLIDWORKS może nie wyświetlać ponownie monitu o jego podanie. Aby zmienić numer seryjny, należy wybrać tę opcję.

Napraw instalację indywidualną

Naprawia istniejącą instalację SOLIDWORKS na tym komputerze.

Ta opcja pojawia się tylko wtedy, gdy dana wersja jest zainstalowana na komputerze.
Opcja naprawiania weryfikuje czy wszystkie pliki są obecne oraz prawidłowo zarejestrowane oraz naprawia wszelkie znalezione problemy. Nie ma ona wpływu na dane utworzone przez użytkownika.
  • Aby naprawić produkt, należy się upewnić że jest on wybrany.
  • Należy wyczyścić pola wyborów dla produktów, które nie mają być naprawiane.
Można naprawić indywidualną instalację. Nie można naprawić instalacji obrazu administracyjnego. Konieczne jest ponowne zainstalowanie przy użyciu obrazu administracyjnego.

Obraz administracyjny

Aby wykonać instalację na wielu komputerach, należy utworzyć lub zaktualizować obraz administracyjny.

Szczegóły na temat instalowania SOLIDWORKS na wielu klientach z wykorzystaniem obrazu administracyjnego, patrz Wykorzystanie obrazu administracyjnego.

Podczas tworzenia lub aktualizowania obrazów administracyjnych:
  • Można wykorzystać ustawienia instalacji z istniejącego obrazu, aby skonfigurować nowy lub zaktualizowany obraz. Można również użyć domyślnych ustawień instalacji SOLIDWORKS.
  • W przypadku aktualizowania istniejącego obrazu:
    • Menedżer instalacji SOLIDWORKS tworzy nową kopię obrazu, nawet w przypadku aktualizowania. Pierwotny obraz nie jest modyfikowany.
    • Można utworzyć zaktualizowany obraz przy użyciu plików z istniejącego obrazu, który jest aktualizowany. Wynikiem tego jest mniejsze pobranie.
    Jeśli nie zostanie określony obraz, dla którego dostępna jest wersja Service Pack w celu aktualizacji poprzedniego obrazu, nie można uzyskać korzyści w postaci mniejszego pliku do pobrania.

Produkty serwera

Produkty serwera SOLIDWORKS obejmują SOLIDWORKS Electrical, SOLIDWORKS PDM oraz SolidNetWork License Manager.

W przypadku produktów SOLIDWORKS Electrical oraz SOLIDWORKS PDM można wybrać instalację klienta i serwera na tym samym komputerze lub na innych komputerach.

Aby uzyskać szczegółowe informacje na temat instalowania tych serwerów, należy zapoznać się z odpowiednimi tematami pomocy.

Pobierz i udostępnij wszystkie pliki

Pobiera pliki instalacyjne dla wybranych produktów SOLIDWORKS bez instalowania produktów.

Ta opcja nie pojawia się w przypadku instalowania z dysku DVD.
Zawartość pobranych plików jest taka sama, jak plików, które są dostępne na instalacyjnych dyskach DVD SOLIDWORKS. Wybranie tej opcji pobiera pełen zbiór plików instalacyjnych, niezależnie od tego, jakie pliki są już zainstalowane na danym komputerze. Następnie można skopiować pliki do urządzenia przenośnego lub katalogu sieciowego i użyć ich do zainstalowania oprogramowania SOLIDWORKS na innych komputerach. Można również użyć tej metody, aby skonfigurować serwer, z którego użytkownicy mają dokonywać instalacji.
Metoda ta różni się od tworzenia obrazu administracyjnego.
Temat nadrzędny Pomoc aplikacji Menedżer instalacji SOLIDWORKS
Używanie obrazów administracyjnych
Administrowanie licencjami przy użyciu programu SolidNetWork License Manager
SOLIDWORKS Electrical


Instalowanie i zarządzanie wieloma komputerami

Menedżer instalacji SOLIDWORKS dostarcza następujące narzędzia do instalowania i zarządzania wieloma komputerami SOLIDWORKS.

Obrazy administracyjne SOLIDWORKS

Jeżeli SOLIDWORKS instalowany jest na wielu komputerach, można utworzyć obraz administracyjny a następnie rozmieścić aplikację do innych komputerów.

SOLIDWORKS PDM

SOLIDWORKS PDM to produkt do zarządzania dokumentami oparty na tej samej architekturze co program SOLIDWORKS Enterprise PDM. Jest dostępny w dwóch wersjach: Standard i Professional. Program SOLIDWORKS PDM używa bazy danych Microsoft SQL Server do zarządzania przechowalnią plików.

SolidNetWork License Manager

Program SolidNetWork License Manager pozwala na to, aby liczba użytkowników przekraczała liczbę licencji, poprzez dystrybuowanie użycia licencji. Kiedy licencja klienta nie jest w użyciu, jest ona dostępna dla innego użytkownika SOLIDWORKS.

Można również używać programu SolidNetWork License Manager, aby dystrybuować licencje dla głównych produktów dodatków SOLIDWORKS (np. FeatureWorks).

Temat nadrzędny Pomoc aplikacji Menedżer instalacji SOLIDWORKS


Ręczne pobieranie

Wybrano ręczne pobieranie plików (lub wybrano ręczne pobieranie podczas ostatniego uruchomienia Menedżera instalacji SOLIDWORKS).

Kliknięcie łącza otwiera automatycznie generowaną stronę internetową, która zawiera pełną listę plików potrzebnych do dokończenia pobierania.

Konieczne jest pobieranie do folderu określonego na stronie Podsumowanie. Nie można rozpocząć instalacji do czasu pobrania wszystkich plików do tego folderu.

Po zakończeniu pobierań ręcznych, należy kliknąć Dalej, aby kontynuować.

Aby pobierać automatycznie, można zmienić tę opcję wracając do strony Podsumowanie i zmieniając Opcje pobierania.

Temat nadrzędny Pomoc aplikacji Menedżer instalacji SOLIDWORKS


Dostępna nowsza wersja

Menedżer instalacji wykrył nowszą wersję produktów SOLIDWORKS. Można wybrać instalację wersji zawartej w oryginalnej instalacji z dysku DVD lub z pobrania lub można wybrać pobranie i zainstalowanie nowszej wersji.

Jeżeli instalujesz z pobrania

Należy wybrać jedną z poniższych opcji:
  • Kontynuuj instalowanie wersja.

    Należy wybrać tą opcję, aby kontynuować instalowanie wersji zawartej w początkowym pobraniu.

  • Pobierz i zainstaluj nową wersję: wersja.

    Wybrać tę opcję, aby pobrać i zainstalować nową wersję. Jeżeli dostępnych jest kilka nowych wersji, można wybrać wersję do pobrania i zainstalowania.

Jeżeli instalujesz z dysku DVD

W części Czy chcesz użyć nowszej wersji?, należy wybrać jedną z poniższych opcji:
  • Nie, kontynuuj instalowanie wersji z tego dysku DVD. Możesz potem dokonać aktualizacji.

    Należy wybrać tę opcję, aby kontynuować instalowanie przy użyciu bieżącego Menedżera instalacji.

    Po zakończeniu instalacji można sprawdzić czy istnieją i zainstalować aktualizacje przy użyciu Menedżera instalacji. Aby sprawdzić, czy istnieją aktualizacje, kliknąć kolejno Start > Menedżer instalacji SOLIDWORKS > Sprawdź, czy istnieją aktualizacje.
    Opcja Sprawdź, czy istnieją aktualizacje jest dostępna, gdy użytkownik ma uprawnienia administracyjne na danym komputerze.

    Zaletą tej opcji jest to, że pobranie jest mniejsze. Wadą jest to, że proces jest dwustopniowy, a pobrane pliki są specyficzne dla wersji (i nie mogą być współdzielone z innymi użytkownikami korzystającymi z innych wersji).

  • Tak, przeprowadź instalację przy użyciu tego dysku DVD a następnie pobierz i uaktualnij do wersja.

    Należy wybrać tą opcję, aby pobrać i uruchomić późniejszą wersję Menedżera instalacji w celu zainstalowania produktów SOLIDWORKS dla tej wersji.

    Jeżeli dostępna jest mała wersja Service Pack do aktualizacji wersji DVD, Menedżer instalacji najpierw instaluje pierwotną wersję z dysku DVD, a następnie stosuje aktualizację Service Pack. Wynikiem tego jest mniejsze pobranie.

    Ten sam rezultat można osiągnąć wybierając opcję kontynuowania instalacji z dysku DVD, a następnie stosując aktualizację w późniejszym czasie.

    Zaletą tej opcji jest to, że jest ona procesem jednoetapowym.

Temat nadrzędny Pomoc aplikacji Menedżer instalacji SOLIDWORKS


Brak dostępnych nowych wersji

Nie istnieją nowsze wersje dostępne do pobrania. Należy kontynuować instalowanie określonej wersji.

Aby kontynuować instalację, należy kliknąć Dalej.

Temat nadrzędny Pomoc aplikacji Menedżer instalacji SOLIDWORKS


Wykryte procesy

Menedżer instalacji SOLIDWORKS wykrył w tym komputerze procesy, które mogą uniemożliwić pomyślną instalację.

  • Aby kontynuować instalację, należy wykonać jedną z poniższych czynności:
    • Zamknąć te procesy (np. przy użyciu Menedżera zadań Microsoft Windows ), a następnie nacisnąć Ponów próbę.
    • Kliknąć Ignoruj, aby kontynuować bez zamykania procesów.
  • Nacisnąć Anuluj, aby zatrzymać instalację.
Temat nadrzędny Pomoc aplikacji Menedżer instalacji SOLIDWORKS


Wybór produktu

Można wybrać składniki produktu do zainstalowania, zmodyfikowania, pobrania lub usunięcia.

Na liście produktów:
  • Lista produktów stanowi pełny wykaz produktów, które są dostępne w pakiecie określonym powyżej listy produktów.
  • Aby zobaczyć przewidywaną akcję dla konkretnego komponentu, należy kliknąć nazwę komponentu (nie klikać pola wyboru). Przewidywana akcja instalacyjna pojawi się w polu informacji poniżej listy produktów.
  • Można kliknąć pole wyboru obok komponentu produktu, aby zmienić akcję instalacyjną dla tego komponentu. (Na przykład: w przypadku instalowania lub usuwania komponentów, zaznaczenie pola wyboru określa, czy dany komponent ma być zainstalowany lub usunięty, a odznaczenie pola wyboru oznacza, że komponent ma nie być instalowany lub usuwany.)
  • Jeżeli wykonywana jest modyfikacja instalacji, gdy dokonane zostaną jakiekolwiek zmiany w wyborze produktu, na lewo od komponentów pojawi się gwiazdka (*).
  • Jeżeli komponent zawiera opcjonalne podkomponenty, obok niego jest wyświetlana ikona +. Aby zobaczyć dostępne podkomponenty w danym komponencie, należy kliknąć ikonę +.
  • Jeżeli komponent został rozwinięty, aby pokazać opcjonalne podkomponenty, obok niego jest wyświetlana ikona -. Aby zwinąć listę podkomponentów, należy kliknąć ikonę -.

W przypadku stosowania pakietu Service Pack nie można wybierać funkcji SOLIDWORKS (na przykład FeatureWorks), które pojawiają się w SOLIDWORKS. Jest tak ponieważ nie można dodawać ani usuwać funkcji podczas dokonywania tego typu aktualizacji.

Czynności wykonywane przez Menedżer instalacji SOLIDWORKS są kontrolowane przez zbiór zasad współistnienia produktów Szczegółowe informacje zawiera temat Zasady współistnienia produktów.

Menedżer instalacji SOLIDWORKS domyślnie wybiera następujące komponenty produktów:
  • W przypadku wykonywania uaktualnienia lub aktualizacji Service Pack, Menedżer instalacji SOLIDWORKS wybiera aktualnie zainstalowane produkty.
  • W przeciwnym razie Menedżer instalacji SOLIDWORKS wybiera wszystkie produkty, do których użytkownik ma prawo.
Aby zredukować czas instalacji lub pobierania oraz wymaganą ilość miejsca na dysku, należy rozwinąć komponenty produktów i usunąć zaznaczenia pól wyboru dla tych komponentów, które nie są potrzebne.

Jeżeli Menedżer instalacji SOLIDWORKS nie może zweryfikować produktów do których użytkownik ma prawo, można kliknąć Wybierz różne pakiety lub produkty, aby zmienić listę pakietów produktów (jak np. SOLIDWORKS Professional, SOLIDWORKS Premium lub SOLIDWORKS Ultimate) do zainstalowania lub zmodyfikowania. Menedżer instalacji SOLIDWORKS wyszczególnia na nośniku instalacji użytkownika wszystkie produkty SOLIDWORKS, które są kompatybilne z wybranym pakietem. Można wybrać dowolne produkty, które nabyto lub do których ma się prawa do oceny.

Wyszukiwanie SOLIDWORKS

Wyszukiwanie SOLIDWORKS umożliwia zaawansowane wyszukiwanie tekstu w dokumentach SOLIDWORKS. Wyszukiwanie wyświetla podgląd oraz lokalizację i nazwę pliku.

Po instalacji, Wyszukiwanie SOLIDWORKS indeksuje dokumenty SOLIDWORKS, aby umożliwić szybsze wyszukiwania. Domyślnie indeksowane są jedynie pliki SOLIDWORKS.

Obsługa językowa

Należy rozwinąć produkt SOLIDWORKS i komponent Języki, aby zobaczyć w jakich językach można dokonać instalacji.

Ustawienie Języki ogranicza języki, które są instalowane tylko dla produktu SOLIDWORKS. Specyfikacja ta nie ma wpływu na instalacje innych produktów. Na przykład eDrawings® i SOLIDWORKS PDM instalują wszystkie języki.

Potrzebne miejsce

Menedżer instalacji SOLIDWORKS zgłasza albo całkowity rozmiar instalacji albo całkowity rozmiar pobrania na dole strony.

  • Jeżeli wybrano opcję Tylko pobierz, pojawi się rozmiar pobrania. Rozmiar pobrania to całkowita ilość miejsca na dysku wymagana dla wszystkich plików pobrania (nie uwzględniając miejsca wymaganego dla rozpakowania plików po ukończeniu pobrania). Jest to tylko wartość szacunkowa.
    W całkowitym rozmiarze pobrania uwzględnione są wszystkie pliki wymagane dla instalacji. Jeżeli niektóre pliki zostały już pobrane do bieżącego folderu pobrania, nie zostaną pobrane ponownie. W związku z tym rzeczywisty rozmiar pobrania może być mniejszy niż pokazany całkowity rozmiar pobrania, bądź nie będą potrzebne żadne pliki do pobrania.
  • W przeciwnym razie pojawi się rozmiar instalacji. Rozmiar instalacji to zmiana w ilości użycia miejsca na dysku, która nastąpi po zakończeniu instalacji. Ze względu na kompresję plików wartości te są wartościami przybliżonymi.

    W przypadku uaktualniania lub usuwania istniejącej instalacji, rozmiar instalacji może wynosić zero.

    Pokazana liczba nie uwzględnia miejsca wymaganego dla pobrania lub wyodrębnienia plików, jeżeli jest to wymagane dla instalacji.

    Jeżeli wymagane są pobrania i pobieranie odbywa się na ten sam dysk, rzeczywiste wymagania miejsca mogą być znacznie większe niż pokazany rozmiar instalacji.

    Aby zredukować czas pobrania lub instalacji dla przyszłych modyfikacji, nie należy usuwać pobranych plików po instalacji. Kolejne aktualizacje i łaty typowo wymagają dostępu do ostatniego pełnego zestawu plików instalacji.

Temat nadrzędny Pomoc aplikacji Menedżer instalacji SOLIDWORKS
Zasady współistnienia produktów


Produkty do pobrania

Należy wybrać produkty SOLIDWORKS, które mają zostać pobrane do określonej lokalizacji.

Produkty dostępne do pobrania są określone na podstawie określonego numeru seryjnego:

  • Czynność do wykonania dla każdego komponentu jest wyświetlona po jego prawej stronie.
  • Jeżeli komponent zawiera opcjonalne podkomponenty, obok niego jest wyświetlana ikona +. Aby zobaczyć dostępne podkomponenty w danym komponencie, należy kliknąć ikonę +.
  • Jeżeli komponent został rozwinięty, aby pokazać opcjonalne podkomponenty, obok niego jest wyświetlana ikona -. Aby zwinąć listę podkomponentów, należy kliknąć ikonę -.
  • Należy kliknąć pole wyboru po lewej stronie każdego komponentu, aby wybrać jak jest on traktowany przez Menedżera instalacji SOLIDWORKS.
Menedżer instalacji SOLIDWORKS pobiera komponenty wszystkich produktów do których użytkownik ma prawo, chyba że określono inaczej. Aby zredukować czas pobrania oraz wymaganą ilość miejsca na dysku, należy rozwinąć komponenty produktu i określić niepotrzebne komponenty.

Jeżeli Menedżer instalacji SOLIDWORKS nie może zweryfikować produktów do których użytkownik ma prawo, można wybrać pakiet SOLIDWORKS do pobrania. Menedżer instalacji SOLIDWORKS wyszczególnia wszystkie produkty SOLIDWORKS, które są kompatybilne z wybranym pakietem.

Jeżeli Menedżer instalacji SOLIDWORKS nie może zweryfikować produktów do których użytkownik ma prawo, można kliknąć Wybierz różne pakiety lub produkty, aby zmienić listę pakietów produktów (jak np. SOLIDWORKS Professional, SOLIDWORKS Premium lub SOLIDWORKS Ultimate) do zainstalowania lub zmodyfikowania. Menedżer instalacji SOLIDWORKS wyszczególnia na nośniku instalacji użytkownika wszystkie produkty SOLIDWORKS, które są kompatybilne z wybranym pakietem. Można wybrać dowolne produkty, które nabyto lub do których ma się prawa do oceny.

Obsługa językowa

Specyfikacja Języki ogranicza języki, które są zainstalowane tylko dla produktu SOLIDWORKS Specyfikacja ta nie ma wpływu na instalacje innych produktów. Na przykład eDrawings® instaluje wszystkie języki.

Potrzebne miejsce

W oparciu o wybrane produkty, pokazane jest miejsce wymagane do wykonania pobrania. Rozmiar pobrania to całkowita ilość miejsca na dysku wymagana dla wszystkich plików pobrania (nie uwzględniając miejsca wymaganego dla rozpakowania plików po ukończeniu pobrania). Jest to tylko wartość szacunkowa.

Aby zredukować czas pobrania lub instalacji dla przyszłych pobrań i łat, nie należy usuwać pobranych plików po dokonaniu instalacji. Kolejne aktualizacje i łaty typowo wymagają dostępu do ostatniego pełnego zestawu plików instalacji.
Temat nadrzędny Pomoc aplikacji Menedżer instalacji SOLIDWORKS


Produkty do naprawienia

Jeżeli określono Produkty do naprawienia, na tym ekranie wyświetlane są produkty SOLIDWORKS, których numery wersji mogą zostać naprawione przez tę wersję Menedżera instalacji SOLIDWORKS.

Opcja naprawiania weryfikuje czy wszystkie pliki są obecne oraz prawidłowo zarejestrowane oraz naprawia wszelkie znalezione problemy. Nie ma ona wpływu na dane utworzone przez użytkownika.
  • Aby naprawić produkt, należy się upewnić że jest on wybrany.
  • Należy wyczyścić pola wyborów dla produktów, które nie mają być naprawiane.

Kliknąć Napraw, aby rozpocząć naprawianie wybranych produktów.

Można naprawić indywidualną instalację. Nie można naprawić instalacji obrazu administracyjnego. Konieczne jest ponowne zainstalowanie obrazu administracyjnego.
Temat nadrzędny Pomoc aplikacji Menedżer instalacji SOLIDWORKS


Numery seryjne

Numery seryjne kojarzą komputer z nabytymi produktami SOLIDWORKS.

Jeśli produkty SOLIDWORKS są już zainstalowane na danym komputerze, numery seryjne są wyświetlane domyślnie:
  • Jeśli numer seryjny SOLIDWORKS nie jest jeszcze wyświetlany, należy go wprowadzić.
  • Numery seryjne produktów, które nie zostały uwzględnione w licencji SOLIDWORKS, należy wprowadzić w odpowiednich polach.

Jeśli podczas procesu instalacji dostępne jest połączenie internetowe, podane numery seryjne określą produkty, do których użytkownik ma prawo.

Ponieważ istnieje wiele metod zakupu produktów SOLIDWORKS, niektóre numery seryjne mogą obejmować dwa lub więcej produktów. Na przykład numer seryjny SOLIDWORKS może umożliwić instalację SOLIDWORKS Simulation bez wprowadzania numeru seryjnego SOLIDWORKS Simulation. Dodatkowo niektóre produkty, nie wymagają numeru seryjnego. W razie pojawienia się jakichkolwiek pytań dotyczących numerów seryjnych, należy skontaktować się z dystrybutorem.

Temat nadrzędny Pomoc aplikacji Menedżer instalacji SOLIDWORKS


Instalacja serwera

Wyszczególnione są produkty serwera, które próbowano zainstalować, wraz z wynikami instalacji.

Stan instalacji serwera

Instalacje produktów serwera są wykonywane przez zewnętrzną aplikację instalacji. Jeżeli ta aplikacja nie jest aktywna, konieczne jest przełączenie się na nią, aby dokończyć instalację.

Kliknąć Anuluj, aby zatrzymać instalacje produktów serwera.

Zakończono instalację serwera

Zewnętrzna aplikacja instalacji pomyślnie zakończyła działanie.

Należy kliknąć Zakończ lub Dalej.
  • W przypadku instalowania innych produktów administracyjnych (na przykład obrazu administracyjnego SOLIDWORKS), ta instalacja jest kontynuowana.
  • Jeżeli instalacje produktów serwera były jedyną operacją instalacji, to Menedżer instalacji SOLIDWORKS zostanie zamknięty.

Instalacja serwera anulowana lub nie powiodła się

Jeżeli instalacja produktu serwera nie powiodła się lub została anulowana po jej rozpoczęciu, wyszczególnione zostaną serwery, które nie zostały zainstalowane.

Należy kliknąć Zamknij lub Dalej.
  • Jeżeli określono inne instalacje produktów administracyjnych, Menedżer instalacji SOLIDWORKS wznowi działanie.
  • Jeżeli instalacje produktów serwera były jedyną operacją instalacji, to Menedżer instalacji SOLIDWORKS zostanie zamknięty.

Aby uzyskać więcej informacji

Szczegółowe informacje dotyczące instalowania, konfigurowania i korzystania z SolidNetWork License Manager zawiera temat Administrowanie licencjami przy użyciu programu SolidNetWork License Manager.

Temat nadrzędny Pomoc aplikacji Menedżer instalacji SOLIDWORKS


Podsumowanie

Menedżer instalacji SOLIDWORKS posiada wszystkie informacje niezbędne do dokończenia operacji instalacji.

Aby kontynuować, należy: | Kliknąć Czynność teraz, aby zainicjować operację instalacji (na przykład: Instaluj teraz, Utwórz teraz, Pobierz teraz, Modyfikuj teraz).
Aby zmienić ustawienia instalacji, należy: | Kliknąć ZMIEŃ [image] dla sekcji, którą należy zmienić (na przykład: Produkty, Lokalizacja instalacji, Opcje Toolbox).
Aby anulować, należy: | Kliknąć Anuluj, aby zamknąć Menedżera instalacji SOLIDWORKS bez zmieniania składników instalacji.
Aby przywrócić poprzednią stronę, należy: | Kliknąć Wstecz, aby powrócić do poprzedniej strony w Menedżerze instalacji SOLIDWORKS.
Aby uzyskać informacje na temat konkretnego zbioru opcji instalacji (na przykład Produkty, Lokalizacja instalacji czy Opcje Toolbox):
  1. Kliknąć ZMIEŃ [image] obok sekcji, dla której potrzebne są informacje.
  2. Na wyświetlonej stronie szczegółów kliknąć Pomoc, aby uzyskać informacje na temat tych ustawień opcji instalacji.
Temat nadrzędny Pomoc aplikacji Menedżer instalacji SOLIDWORKS


Ostrzeżenia sprawdzenia systemu

Sprawdzenie systemu zgłosiło problemy, które mogą wpływać na dalszy proces instalacji. W większości przypadków kontynuacja powinna być możliwa przy użyciu Menedżera instalacji SOLIDWORKS.

Poniżej wyszczególniono ostrzeżenia, jakie mogą się pojawić, wraz z sugerowanym sposobem postępowania.

Problemy walidacji numeru seryjnego

Menedżer instalacji nie mógł sprawdzić czy istnieją nowe wersje, ponieważ nie mógł dokonać walidacji numeru seryjnego. Jeżeli połączenie jest ustanowione i wprowadzono poprawny numer seryjny, może to oznaczać tymczasowy problem na naszym serwerze. Spróbuj ponownie później.

Walidacja numeru seryjnego: Menedżer instalacji nie mógł dokonać walidacji numeru seryjnego, aby określić do których produktów masz prawa do instalacji. Nadal będziesz mógł wybrać produkty, które chcesz zainstalować ale nie będziesz mógł pobrać żadnych plików instalacji. Musisz dostarczyć pełen zestaw źródłowych plików pobrania lub dysk DVD, z którego ma zostać dokonana instalacja.

Rozdzielczość:
  • Sprawdzić połączenie internetowe. Sprawdzenie numeru seryjnego wymaga poprawnego połączenia internetowego.
  • Sprawdzić, czy wprowadzony numer seryjny jest poprawny dla produktów, które są instalowane.
  • Niektóre instalacje wymagają posiadania poprawnej subskrypcji w chwili wprowadzenia danej wersji. Szczegółowych informacji udzieli dystrybutor SOLIDWORKS.
  • W większości przypadków można kontynuować instalację, pod warunkiem instalowania z dysku DVD lub uprzednio pobranego zestawu plików.

Dostępna nowsza wersja

Dostępna nowsza wersja

Dostępne nowe wersje

Nowsza wersja tego produktu jest dostępna do pobrania.

Rozdzielczość: Podczas wykonywania operacji sprawdzania czy istnieją aktualizacje, instalator może wyświetlić monit o zainstalowanie późniejszej wersji, która jest dostępna do pobrania z SOLIDWORKS. Operację tę można kontynuować przy użyciu wersji, którą określono na początku, bądź można pobrać nową wersję i kontynuować operację przy użyciu tej wersji.

Najnowsza dostępna wersja

Jest to najnowsza dostępna wersja. Kliknij Dalej, aby kontynuować.

Brak dostępnych nowych pobrań

Rozwiązanie: Komunikat ten może pojawić się podczas sprawdzania, czy istnieją aktualizacje podczas instalacji lub modyfikacji. Oznacza to, że aktualnie jest instalowana (lub została zainstalowana) najnowsza dostępna wersja.

Problemy z połączeniem internetowym

Połączenie internetowe: Menedżer instalacji nie mógł się połączyć z serwerem SOLIDWORKS i stwierdzić które produkty mogą zostać zainstalowane. Nadal będziesz mógł wybrać produkty, które chcesz zainstalować ale nie będziesz mógł pobrać żadnych plików instalacji. Musisz dostarczyć pliki źródłowe na dysku DVD lub jako uprzednio pobrany zestaw plików.

Nie można sprawdzić czy istnieją nowe wersje

Menedżer instalacji nie mógł sprawdzić czy istnieją nowe wersje, ponieważ nie mógł się połączyć z serwerem.

Rozwiązanie:
  • Sprawdzić połączenie internetowe.
  • Można kontynuować instalację, pod warunkiem instalowania z dysku DVD lub uprzednio pobranego zestawu plików.

Temat nadrzędny Pomoc aplikacji Menedżer instalacji SOLIDWORKS


Opcje Kreatora otworów/Toolbox

Jeżeli zainstalowany jest SOLIDWORKS Toolbox, SOLIDWORKS uwzględnia standardową bibliotekę typów otworów oraz sprzętu.

Aby uzyskać szczegółowe informacje na temat konfigurowania, rozbudowywania i używania SOLIDWORKS Toolbox, należy kliknąć Pomoc w oprogramowaniu SOLIDWORKS, patrz sekcja Toolbox.

Przed użyciem SOLIDWORKS Toolbox, należy się upewnić, czy konfiguracja jest zgodna z wymaganiami firmy lub grupy. W wielu przypadkach to grupa konfiguruje i utrzymuje centralną bibliotekę Toolbox. Aby uzyskać wskazówki odnośnie skonfigurowania Toolbox podczas instalacji SOLIDWORKS, należy skonsultować się z administratorem SOLIDWORKS.

Można zmieniać wybraną bibliotekę SOLIDWORKS Toolbox po zainstalowaniu. W SOLIDWORKS kliknąć Narzędzia > Opcje. Na karcie Opcje systemu kliknąć Kreator otworów/Toolbox.

Poniższe fragmenty opisują wszystkie opcje, jakie można napotkać na tym ekranie dla wszystkich konfiguracji. Faktycznie widoczne opcje Toolbox uzależnione są od wcześniej istniejących konfiguracji SOLIDWORKS i Toolbox na danym komputerze oraz od wyborów określonych dotychczas w Menedżerze instalacji SOLIDWORKS.

Utwórz nowy Toolbox nowa wersja

Tworzy nową wersję SOLIDWORKS Toolbox na tym komputerze.

Aby utworzyć nową wersję, na ekranie Wybór produktu należy rozwinąć pozycję SOLIDWORKS > SOLIDWORKS Toolbox i wybrać obsługiwane standardy w Toolbox. Domyślnie wybrane są wszystkie standardy.

Wszelkie istniejące biblioteki Toolbox na tym komputerze nie są modyfikowane.

Utwórz odniesienie lub uaktualnij istniejący Toolbox

Używa istniejącej biblioteki Toolbox. Kliknąć Przeglądaj, aby określić lokalizację biblioteki Toolbox, która ma zostać użyta dla tej instalacji.

  • Jeżeli biblioteka Toolbox jest skonfigurowana dla poprzedniej wersji głównej SOLIDWORKS, to zostanie ona uaktualniona do tej wersji. Wszelkie dostosowania dokonane w tej bibliotece Toolbox są zachowywane w uaktualnionej bibliotece Toolbox.
    Uaktualnienie dodatku Toolbox do nowej, głównej wersji SOLIDWORKS powoduje, że dodatek Toolbox jest niekompatybilny z komputerami, na których działają wcześniejsze główne wersje SOLIDWORKS.
  • Jeżeli dodatek Toolbox jest skonfigurowany dla tej wersji SOLIDWORKS (co może mieć miejsce, jeżeli określono współużytkowaną bibliotekę sieciową Toolbox, która została już uaktualniona), nie zachodzi żadne uaktualnienie Toolbox.
  • W przypadku uaktualniania dodatku Toolbox w środowisku SOLIDWORKS PDM wymagane są dodatkowe procedury. Szczegółowe informacje zawiera temat Uwagi dotyczące konfigurowania SOLIDWORKS Toolbox.

Opcja ta pojawia się we wszystkich scenariuszach instalacji, za wyjątkiem tworzenia obrazu administracyjnego.

Uaktualnij Toolbox poprzednia-wersja

Należy skopiować bibliotekę Toolbox skonfigurowaną dla poprzedniej wersji głównej do nowej lokalizacji i uaktualnić tę kopię do tej wersji.

Opcja ta pojawia się, jeżeli na tym komputerze zainstalowana jest poprzednia główna wersja SOLIDWORKS, lecz wybrano opcję nie uaktualniania tej instalacji do tej wersji.
Zadaniem tej opcji jest uaktualnienie biblioteki Toolbox dla poprzedniej wersji głównej SOLIDWORKS, która jest zainstalowana, bez wpływu na użytkowników starszej wersji Toolbox.

W przypadku uaktualniania dodatku Toolbox w środowisku SOLIDWORKS PDM wymagane są dodatkowe procedury. Szczegółowe informacje zawiera temat Uwagi dotyczące konfigurowania SOLIDWORKS Toolbox.

Uaktualnij ten zainstalowany Toolbox poprzednia-wersja

Uaktualnia ten dodatek Toolbox do nowszej wersji.
Uaktualnienie dodatku Toolbox do nowej, głównej wersji SOLIDWORKS powoduje, że dodatek Toolbox jest niekompatybilny z komputerami, na których działają wcześniejsze główne wersje SOLIDWORKS.

Opcja ta pojawia się, jeżeli uaktualniana jest poprzednia główna wersja SOLIDWORKS do tej wersji i znaleziono na tym komputerze bibliotekę Toolbox skonfigurowaną dla tamtej wersji.

W przypadku uaktualniania dodatku Toolbox w środowisku SOLIDWORKS PDM wymagane są dodatkowe procedury. Szczegółowe informacje zawiera temat Uwagi dotyczące konfigurowania SOLIDWORKS Toolbox.

Użyj zainstalowanego Toolbox bieżąca-wersja

Menedżer instalacji SOLIDWORKS wykrył w tym komputerze dodatek Toolbox skonfigurowany dla tej wersji głównej SOLIDWORKS.

W przypadku wybrania tej opcji, SOLIDWORKS użyje tego dodatku Toolbox. Nie nastąpi żadne uaktualnienie.

Opcja ta pojawia się, jeżeli na tym komputerze zainstalowana jest poprzednia główna wersja SOLIDWORKS, lecz biblioteka Toolbox jest skonfigurowana dla tej wersji. Może to nastąpić, jeżeli współużytkowana biblioteka Toolbox jest utworzona na komputerze, na którym nadal działa starsza wersja SOLIDWORKS.

Określ lokalizację Toolbox dla komputera klienta

Należy określić lokalizację sieciową lub katalog jako domyślną lokalizację Toolbox podczas instalacji klientów z obrazu administracyjnego.
Jeżeli lokalizacja zawiera bibliotekę Toolbox skonfigurowaną dla poprzedniej wersji głównej SOLIDWORKS w chwili wykonywania instalacji klienta, to Menedżer instalacji SOLIDWORKS uaktualni tę bibliotekę Toolbox.

Opcja ta pojawia się podczas tworzenia nowego obrazu administracyjnego.

Uaktualnij lub użyj Toolbox, do którego istnieje odniesienie w istniejącym obrazie dla komputera klienta

Należy użyć lokalizacji Toolbox określonej w istniejącym obrazie administracyjnym, który jest uaktualniany.
Jeżeli lokalizacja zawiera bibliotekę Toolbox skonfigurowaną dla poprzedniej wersji głównej SOLIDWORKS w chwili wykonywania instalacji klienta, to Menedżer instalacji SOLIDWORKS uaktualni tę bibliotekę Toolbox.

Wybierz inną lokalizację Toolbox dla komputera klienta

Należy określić lokalizację Toolbox inną od określonej w istniejącym obrazie administracyjnym, który jest uaktualniany.
Jeżeli lokalizacja zawiera bibliotekę Toolbox skonfigurowaną dla poprzedniej wersji głównej SOLIDWORKS w chwili wykonywania instalacji klienta, to Menedżer instalacji SOLIDWORKS uaktualni tę bibliotekę Toolbox.

Spis treści

  • Uwagi dotyczące konfigurowania SOLIDWORKS Toolbox

    Dodatek SOLIDWORKS Toolbox jest potężnym i skomplikowanym narzędziem. Ten temat podsumowuje pewne zagadnienia, które należy rozważyć przed skonfigurowaniem dodatku Toolbox przy użyciu Menedżera instalacji SOLIDWORKS.

  • Format UNC

    Format w konwencji nazewnictwa UNC (Universal Naming Convention) określa format składni nazwy pliku opisujący udostępnioną lokalizację plików.

Temat nadrzędny Pomoc aplikacji Menedżer instalacji SOLIDWORKS
Uwagi dotyczące konfigurowania SOLIDWORKS Toolbox


Uwagi dotyczące konfigurowania SOLIDWORKS Toolbox

Dodatek SOLIDWORKS Toolbox jest potężnym i skomplikowanym narzędziem. Ten temat podsumowuje pewne zagadnienia, które należy rozważyć przed skonfigurowaniem dodatku Toolbox przy użyciu Menedżera instalacji SOLIDWORKS.

Uzyskiwanie dalszych informacji na temat SOLIDWORKS Toolbox

Aby uzyskać szczegółowe informacje na temat konfigurowania, rozbudowywania i używania dodatku SOLIDWORKS Toolbox, należy kliknąć [image] Pomoc w oprogramowaniu SOLIDWORKS i zapoznać się z sekcją Toolbox.

Korzystanie ze współużytkowanego Toolbox

Podczas instalacji Toolbox, można zdecydować o przechowywaniu danych Toolbox na lokalnym komputerze lub we współużytkowanej lokalizacji sieciowej. Zaleca się przechowywanie danych Toolbox w lokalizacji sieciowej. Dzięki użyciu wspólnej lokalizacji, wszyscy użytkownicy SOLIDWORKS współużytkują spójny zbiór informacji o łącznikach.

Jeżeli jest to pierwsza instalacja, należy przejść do nowej współużytkowanej lokalizacji gdzie chcesz zainstalować Toolbox.

Uaktualnianie istniejącego Toolbox

Uaktualnienie dodatku Toolbox do nowej, głównej wersji SOLIDWORKS powoduje, że dodatek Toolbox jest niekompatybilny z komputerami, na których działają wcześniejsze główne wersje SOLIDWORKS.

Jeżeli na innych komputerach pozostaje wcześniejsza główna wersja, i nadal potrzebny jest dodatek Toolbox skonfigurowany dla tej wersji, należy wykonać kopię tego dodatku Toolbox i uaktualnić tę kopię. Nowa instalacja SOLIDWORKS uaktualni kopię dodatku Toolbox, a poprzednie instalacje SOLIDWORKS będą nadal używać starego dodatku Toolbox.

Konfigurowanie dostępu do Toolbox

Po instalacji, kiedy uzyskujemy dostęp do komponentów Toolbox, SOLIDWORKS sprawdza konfigurację Toolbox i podaje sugestie dotyczące udoskonalenia dostępu i wydajności.

Aby uzyskać dostęp do współużytkowanej lokalizacji sieciowej Toolbox (zalecane), należy użyć ścieżki UNC do serwera, na którym zainstalowano współużytkowany dodatek Toolbox. Szczegółowe informacje zawiera temat Format UNC.

Administrator może utworzyć hasło dla biblioteki Toolbox oraz ustanowić uprawnienia i preferencje dla grupy roboczej. Ograniczenie dostępu do konfiguracji i ustawianie powszechnych preferencji zapewnia spójność danych Toolbox.

Uaktualnianie Toolbox w środowisku SOLIDWORKS PDM

Podczas aktualizacji oprogramowania SOLIDWORKS, dodatek Toolbox jest aktualizowany, jeśli zostały dodane części. Jeśli folder główny Toolbox znajduje się w przechowalni SOLIDWORKS PDM, przed rozpoczęciem uaktualniania produktu SOLIDWORKS należy przygotować folder Toolbox.

W przypadku aktualizacji pierwszego systemu, należy użyć polecenia Pobierz najnowszą wersję, aby pobrać pliki Toolbox do pamięci podręcznej i wyewidencjonować plik bazy danych Toolbox. W przypadku kolejnych aktualizowanych systemów jedynym wymaganiem jest pobranie plików Toolbox.

Przed aktualizacją należy:
  • Upewnić się, że wykonano nową kopię zapasową bazy danych przechowalni i archiwum.
  • Upewnić się, że części Toolbox nie się wyewidencjonowane lub użytkowane przez aktualnie wyewidencjonowane złożenia.

Aby dokonać aktualizacji Toolbox:

  1. W Eksploratorze plików zalogować się do przechowalni jako użytkownik z pełnią uprawnień (wyewidencjonowywanie, zaewidencjonowywanie, dodawanie, usuwanie).
  2. Kliknij folder Toolbox prawym przyciskiem myszy i kliknij Pobierz najnowszą wersję, aby skopiować do lokalnej pamięci podręcznej wszystkie piki Toolbox wraz z bazą danych Toolox.
    Jeśli serwer archiwum znajduje się w lokalizacji zdalnej, może to zająć kilka minut.
  3. Wyewidencjonować plik bazy danych Toolbox (SWBrowser.mdb) lub (swbrowser.sldedb) z \Toolbox_folder_name\lang\your_lang.
  4. Uruchomić menedżera instalacji SOLIDWORKS, aby dokonać aktualizacji.
  5. Będąc w oknie Podsumowanie należy upewnić się, że lokalizacja instalacji Opcji Toolbox jest lokalizacją wewnątrz przechowalni.

    Jeśli tak nie jest, należy kliknąć Zmień i wybrać Utwórz odniesienie lub aktualizuj istniejący Toolbox a następnie przejść do lokalizacji Toolbox w przechowalni.

  6. Po zakończeniu aktualizacji w Eksploratorze plików zaewidencjonować folder Toolbox, aby dodać wszelkie nowe lub zaktualizowane pliki do przechowalni, tak aby inni użytkownicy mogli współpracować z dodatkiem Toolbox.
  7. W celu uaktualnienia przejść do folderu Toolbox w przechowalni i upewnić się, że obecne są następujące elementy:
    • \Toolbox_folder_name\Updates
    • \Toolbox_folder_name\ToolboxStandards.xml
    • \Toolbox_folder_name\Browser\ToolboxFiles.index

      Jeśli ich brakuje, należy skontaktować się z Dystrybutorem.

  8. Przeprowadzić uaktualnienie na pozostałych komputerach korzystających z funkcji integracji programu SOLIDWORKS PDM z Toolbox:
    1. W Eksploratorze plików należy zalogować się do przechowalni jako użytkownik, mający przynajmniej uprawnienia do odczytu folderu Toolbox.
    2. Kliknąć prawym przyciskiem myszy folder Toolbox i kliknąć Pobierz najnowszą wersję, aby skopiować pliki Toolbox do lokalnej pamięci podręcznej.
    3. Uruchomić menedżera instalacji SOLIDWORKS, aby dokonać aktualizacji.

      Instalator wykryje, czy dodatek Toolbox został już zaktualizowany.

Aby uzyskać szczegółowe informacje na temat konfiguracji Toolbox w środowisku SOLIDWORKS PDM, należy zapoznać się z tematem Konfiguracja Toolbox w pomocy narzędzia Administracja SOLIDWORKS PDM.

Temat nadrzędny Opcje Kreatora otworów/Toolbox
Format UNC


Format UNC

Format w konwencji nazewnictwa UNC (Universal Naming Convention) określa format składni nazwy pliku opisujący udostępnioną lokalizację plików.

\\serwer\wolumin\ścieżka

Na przykład:

\\Disk_Server\SOLIDWORKS\AdminImage

Temat nadrzędny Opcje Kreatora otworów/Toolbox
Uwagi dotyczące konfigurowania SOLIDWORKS Toolbox


Odinstalowywanie produktów

Po wybraniu opcji Usuń lub Odinstaluj programy z Panelu sterowania ekran ten wyświetla produkty SOLIDWORKS (wraz z numerami wersji), które mogą być odinstalowane przez tę wersję Menedżera instalacji SOLIDWORKS. Można wybrać opcję, aby przeprowadzić standardowe, dostosowane lub całkowite odinstalowanie.

Standardowe odinstalowanie usuwa pliki i foldery produktu SOLIDWORKS. Domyślnie wszystkie produkty SOLIDWORKS dla wybranej wersji są określone do standardowego odinstalowania.

Dostosowane odinstalowanie usuwa jeden lub kilka z poniższych elementów: Pliki i foldery programu, klucze rejestru i foldery zawierające dane, takie jak SOLIDWORKS Toolbox oraz pliki i foldery z oryginalnej lokalizacji pobrania.

Pełne odinstalowanie powoduje usunięcie katalogów, kluczy rejestrów i folderów danych.

Aby odinstalować produkt, należy:
  1. Upewnić się, że produkt jest wybrany na ekranie Odinstaluj.

    W przypadku dezinstalacji wszystkich produktów zostanie odinstalowany również Menedżer instalacji Solidworks.

  2. Usunąć zaznaczenie produktów, których nie należy usuwać.

    W przypadku zachowania dowolnego produktu, Menedżer instalacji SOLIDWORKS nie zostanie usunięty.

  3. Wybrać pełne lub dostosowane odinstalowanie.
    1. W sekcji Zaawansowane opcje kliknąć Zmień.

      Pojawi się ekran Zaawansowane opcje. Opcja Pliki i foldery programu będzie zaznaczona.

    2. Wybrać co najmniej jedną opcję w celu przeprowadzenia dostosowanego odinstalowania albo wybrać wszystkie opcje w celu przeprowadzenia pełnego odinstalowania.
    3. Kliknąć Powrót do podsumowania.
    4. Na ekranie Podsumowanie rozwinąć Zaawansowane opcje, aby wyświetlić metody odinstalowania i dostępne pozycje.
  4. Kliknąć Usuń elementy.
Kliknięcie opcji Usuń elementy powoduje natychmiastowe rozpoczęcie usuwania produktów przez Menedżer instalacji SOLIDWORKS.
Temat nadrzędny Pomoc aplikacji Menedżer instalacji SOLIDWORKS


SOLIDWORKS Visualize Boost

SOLIDWORKS Visualize Boost to aplikacja, która umożliwia przydzielenie zadania renderowania jednemu lub wielu komputerom w tej samej sieci, w której znajduje się komputer z oprogramowaniem SOLIDWORKS Visualize Professional.

Można wykonywać inne zadania na komputerze, gdy renderowanie odbywa się w tle, a końcowe renderowane obrazy zostaną ukończone szybciej Obrazy można renderować na pojedynczym komputerze lub w klastrze kilku komputerów z uruchomionym oprogramowaniem Visualize Boost.

Każda aktywna subskrypcja SOLIDWORKS Visualize Professional obejmuje jedną bezpłatną licencję SOLIDWORKS Visualize Boost.

Przyrost wydajności, na przykład krótszy czas renderowania, zależy od wydajności komputerów Visualize Boost. Maszyny z lepszymi procesorami graficznymi zapewnią lepsze osiągi.


Uaktualnianie od licencji indywidualnych do licencji SolidNetWork

Komputer można uaktualnić od indywidualnej licencji SOLIDWORKS do licencji SolidNetWork poprzez określenie numeru seryjnego licencji SolidNetWork w Menedżerze instalacji SOLIDWORKS.

Jeżeli na komputerze nie ma zainstalowanej aplikacji SOLIDWORKS, to można określić numer licencji SolidNetWork poprzez wprowadzenie numeru seryjnego SolidNetWork podczas instalacji przy użyciu Menedżera instalacji SOLIDWORKS.

Jeżeli na komputerze jest już zainstalowane oprogramowanie SOLIDWORKS i następuje przełączanie z licencji indywidualnej na licencję SolidNetWork, można zmodyfikować instalację dla komputera klienta i określić numer seryjny licencji SolidNetWork zamiast indywidualnego numeru seryjnego licencji podczas uruchamiania Menedżera instalacji SOLIDWORKS. Aby uzyskać więcej informacji, zobacz temat Modyfikowanie instalacji.
W przypadku zainstalowania SOLIDWORKS z obrazu administracyjnego, opcja modyfikacji nie jest dostępna. Należy dokonać zmian w obrazie administracyjnym przy użyciu Edytora opcji obrazu administracyjnego, odinstalować klienta i ponownie uruchomić instalację.


Praca z funkcją Visualize Boost

Aby włączyć renderowanie rozprowadzone, należy połączyć SOLIDWORKS Visualize z Visualize Boost po skonfigurowaniu.

Połączenie Boost wymaga wartości Adres IP konfiguratora i Port Boost w SOLIDWORKS Visualize.

Visualize Boost i SOLIDWORKS Visualize muszą być otwarte dla następujących kroków.

Aby połączyć SOLIDWORKS Visualize z Visualize Boost, należy:

  1. Otworzyć Visualize Boost, klikając dwukrotnie skrót na pulpicie [image].
  2. Kliknąć dwukrotnie Adres IP koordynatora w oknie Visualize Boost, aby skopiować go do schowka.
  3. W SOLIDWORKS Visualize kliknąć Narzędzia > Opcje > Boost i nacisnąć CTRL+V, aby wkleić Adres IP koordynatora.
  4. Powtórzyć kroki 2 i 3, aby skopiować Port Boost z Visualize Boost do SOLIDWORKS Visualize.
    Port Boost określony w Visualize Boost i w SOLIDWORKS Visualize Boost musi być taki sam.
    Kontrolka Stan usługi Boost pojawi się w SOLIDWORKS Visualize.
  5. Kliknąć OK, aby zamknąć okno dialogowe Opcje.
  6. Aby połączyć się z funkcją Boost, kliknąć kontrolkę Stan usługi Boost [image] lub rozłączyć [image] w następujących interfejsach:
    • Wyświetlacz przezroczysty
    • Strona Jakość kreatora renderowania
    • Narzędzia Opcje karta Boost

Aby uzyskać szczegółowe informacje na temat konfiguracji funkcji Boost, patrz temat SOLIDWORKS Visualize Boost.


Inicjowanie nowego serwera licencji SolidNetWork

Aby zainicjować nowy serwer licencji SolidNetWork:

  1. Po zainstalowaniu i otwarciu SolidNetWork License Manager Server w odpowiedzi na monit o aktywację kliknąć Tak.
  2. W oknie dialogowym Informacje serwera licencji SolidNetWork sprawdzić zawartość sekcji Zapora i Porty, a następnie kliknąć Dalej.
  3. W Kreatorze aktywacji produktu wybrać Numery seryjne, które mają zostać aktywowane, jako metodę aktywacji wybrać opcję Ręcznie pocztą e-mail, a następnie wypełnić sekcję Informacje kontaktowe poczty elektronicznej.

    Metoda ręczna wymaga utworzenia pliku wniosku i wysłania go pocztą e-mail na adres activation@solidworks.com. Po otrzymaniu wiadomości e-mail zawierającej plik odpowiedzi z licencją należy wyodrębnić plik i kliknąć Otwórz, aby załadować plik do serwera.

    W celu otwarcia i załadowania pliku odpowiedzi można zamknąć okno i ponownie uruchomić Kreator aktywacji produktu.

  4. Gdy pojawi się okno z komunikatem informującym o powodzeniu inicjalizacji, kliknąć OK, a następnie w Kreatorze aktywacji produktu kliknąć Zakończ.


Ręczna aktywacja nowego wystąpienia programu SolidNetWork License Manager Server

Po zainicjowaniu programu SolidNetWork License Manager Server otworzyć go i utworzyć drugie żądanie w celu ukończenia aktywacji.

Aby ręcznie aktywować nową instalację programu SolidNetWork License Manager Server:

  1. Wykonać jedną z następujących czynności:
    • Jeśli zostanie wyświetlony monit o aktywację, kliknąć Tak.
    • Jeśli monit nie pojawi się, kliknąć opcję Modyfikuj na karcie Administracja serwera.
    Domyślnie w obszarze Zaawansowane opcje zaznaczony jest tryb Użyj aktywacji.
  2. W oknie dialogowym Informacje serwera licencji SolidNetWork sprawdzić zawartość sekcji Zapora i Porty, a następnie kliknąć Dalej.
  3. W Kreatorze aktywacji produktu wybrać Numery seryjne, które mają zostać aktywowane, wypełnić sekcję Informacje kontaktowe poczty elektronicznej, a jako metodę aktywacji wybrać Ręcznie pocztą e-mail.
  4. Wykonać czynności opisane poniżej, aby utworzyć plik żądania i wysłać go na adres activation@solidworks.com. Po otrzymaniu pliku odpowiedzi z licencją kliknąć Otwórz, aby załadować plik.
  5. Po zakończeniu aktywacji kliknąć Zakończ.


Ręczna aktywacja uaktualnionego programu SolidNetWork License Manager Server

Po uaktualnieniu programu SolidNetWork License Manager Server za pomocą Menedżera instalacji SOLIDWORKS otworzyć program SolidNetWork License Manager Server.

Aby ręcznie aktywować uaktualniony program SolidNetWork License Manager Server, należy:

  1. Na karcie Administracja serwera w obszarze Informacje o licencji kliknąć opcję Reaktywuj.
    Jeśli licencje zdezaktywowano przed odinstalowaniem i uaktualnieniem programu SolidNetWork License Manager Server, należy kliknąć opcję Modyfikuj zamiast karty Administracja serwera. Opcja Reaktywuj jest dostępna tylko wtedy, gdy na serwerze istnieją aktywowane licencje.

    Przejść do kroku 3.

  2. W oknie dialogowym Reaktywuj zaznaczyć zainstalowane numery seryjne, aby obejrzeć powiązane z nimi licencje, a następnie kliknąć opcję Reaktywuj.
  3. Sprawdzić zawartość obszarów Zapora i Porty w oknie dialogowym Informacje serwera licencji SolidNetWork, a następnie kliknąć Dalej.
  4. W Kreatorze aktywacji produktu wybrać Numery seryjne, które mają zostać aktywowane, wypełnić sekcję Informacje kontaktowe poczty elektronicznej, a jako metodę aktywacji wybrać Ręcznie pocztą e-mail.
    Ręczna aktywacja jest prostym procesem. Instrukcje w Kreatorze aktywacji produktu przeprowadzą Cię przez procedurę.
  5. Po zakończeniu aktywacji kliknąć Zakończ.