SOLIDWORKS 설치 및 관리

이 안내서는 개별 설치와 여러 시트 설치 모두에 대한 SOLIDWORKS 제품 설치, 사용권 발급, 업그레이드에 대한 내용을 설명합니다.

개별 설치 | 여러 시트 배포
설치 하나 또는 몇 개의 컴퓨터에 설치. | 설치 많은 수의 클라이언트 컴퓨터에 배포되는 관리자 이미지 작성.
사용권 발급 컴퓨터 활성화 또는 네트워크 사용권. | 사용권 발급 컴퓨터 활성화 또는 네트워크 사용권.
업그레이드 개별 설치를 새 릴리즈로 업그레이드. | 업그레이드 다른 컴퓨터에서의 설치에 사용된 관리 이미지를 업데이트하여 여러 컴퓨터를 새 릴리즈로 이동.
관리 설치의 수정, 복구, 제거, 새 릴리즈로 업그레이드. | 관리 관리 이미지, 클라이언트 및 네트워크 사용권 관리 업그레이드.

SOLIDWORKS 설치 관리자를 사용하여 SOLIDWORKS, SOLIDWORKS Toolbox, SOLIDWORKS Electrical, SOLIDWORKS Manage, SOLIDWORKS PDM, SOLIDWORKS Visualize 및 SOLIDWORKS SolidNetWork License Manager를 포함한 SOLIDWORKS 제품 구성 요소에 대한 설정을 구성할 수 있습니다.

SolidNetWork License Manager는 사용권을 네트워크 상의 클라이언트에 배포하여 여러 개의 사용권 클라이언트를 지원합니다. 따라서 사용자는 사용권 부동화를 사용하여 사용권 수를 초과하여 사용할 수 있습니다.

목차

  • 개별 설치 또는 관리 이미지

    컴퓨터에 개별적으로 SOLIDWORKS 제품을 설치해야 합니까? 혹은 관리 이미지를 작성해 하나의 명령으로 모든 클라이언트에 설치를 배포해야 합니까?

  • 시스템 및 소프트웨어 요구 사항 확인

    설치하기 전에 시스템이 하드웨어, 운영 체제 및 Microsoft 제품 요구 사항을 충족하는지 확인하십시오. SOLIDWORKS Electrical, SOLIDWORKS Visualize 및 eDrawings 같은 애드인에는 추가 요구 사항이 있습니다.

  • 설치 미디어 다운로드

    모든 설치 미디어는 SOLIDWORKS 다운로드 페이지에서 사용할 수 있습니다.

  • 3DEXPERIENCE 앱 설치

    3DEXPERIENCE Platform을 사용하여 데이터를 관리하는 경우 Collaborative Designer for SOLIDWORKS 역할을 구입하여 데스크톱 환경을 플랫폼에 연결할 수 있습니다.


개별 설치 또는 관리 이미지

컴퓨터에 개별적으로 SOLIDWORKS 제품을 설치해야 합니까? 혹은 관리 이미지를 작성해 하나의 명령으로 모든 클라이언트에 설치를 배포해야 합니까?

한 컴퓨터에만 설치할 경우이거나 여러 대의 컴퓨터를 관리하는 경우, 선택은 명백합니다. 그렇지 않은 경우, 다음 비교를 참고하십시오.

개별 설치 | 관리 이미지
사용자가 SOLIDWORKS 관리를 직접할 수 있습니다. | 시스템 관리자가 옵션 편집기를 사용하고 다음과 같은 설치 옵션을 정해서 여러 설치를 사용자 정의할 수 있습니다 : 새 설치 만들기, 기존 설치 업데이트하기, 관리 사용자로 설치 실행하기, 설치 전후에 외부 명령 실행하기, 다른 제품 그루핑 등.
컴퓨터는 설치 작업을 하는 사람이 물리적으로 직접 액세스 할 수 있어야 합니다. | 클라이언트 컴퓨터를 같은 네트워크에서 액세스 할 수 있다면 멀리 위치해 있을 수 있습니다.
개별 설정으로 다른 버전, 서비스 팩이나 제품을 다른 컴퓨터에 설치할 수 있습니다. | 옵션 편집자를 사용하면 관리 이미지가 여러 설치의 버전, 서비스 팩, 제품, 설정간의 일관성을 유지할 수 있습니다.
컴퓨터에서 네트워크나 전자메일에 액세스가 가능해야 합니다. 네트워크 또는 전자메일 연결은 SOLIDWORKS를 활성화하고 파일을 다운로드하는 데 필요합니다. 네트워크 액세스는 네트워크 사용권 서버에서 사용권을 수집할 때도 필요합니다. | 로컬 네트워크 연결이 응용 프로그램 배포에 필요합니다; 미디어 드라이브가 클라이언트 컴퓨터에 필요하지 않습니다. 클라이언트가 자동으로 업데이트 될 수 있습니다. 같은 관리자 이미지에서 배포된 모든 클라이언트에 같은 서비스 팩이 적용됩니다. 여러 버전을 관리 유지하기 위해 여러 개의 관리 이미지를 작성할 수 있습니다. 사용권 활성을 자동화 할 수 있습니다. 관리자 이미지는 서버에서 추가 디스크 공간을 필요로 하고, 클라이언트는 개별 설치와 같은 공간이 필요합니다.
상위 주제 SOLIDWORKS 설치 및 관리
시스템 및 소프트웨어 요구 사항 확인
설치 미디어 다운로드
3DEXPERIENCE 앱 설치


시스템 및 소프트웨어 요구 사항 확인

설치하기 전에 시스템이 하드웨어, 운영 체제 및 Microsoft 제품 요구 사항을 충족하는지 확인하십시오. SOLIDWORKS Electrical, SOLIDWORKS Visualize 및 eDrawings 같은 애드인에는 추가 요구 사항이 있습니다.

성공적인 설치와 최적의 성능을 보장하려면 시스템 요구 사항을 참조하십시오.

상위 주제 SOLIDWORKS 설치 및 관리
개별 설치 또는 관리 이미지
설치 미디어 다운로드
3DEXPERIENCE 앱 설치


설치 미디어 다운로드

모든 설치 미디어는 SOLIDWORKS 다운로드 페이지에서 사용할 수 있습니다.

SOLIDWORKS 다운로드 페이지에 액세스할 수 없는 경우 공인 리셀러에게 문의하여 DVD를 받으십시오.

설치 미디어를 다운로드하는 방법:

  1. 이메일 주소와 암호 또는 SOLIDWORKS 제품 번호를 사용하여 SOLIDWORKS 다운로드 페이지에 서브스크립션 서비스 고객으로 로그인합니다.
  2. 다운로드 페이지의 버전 선택에서 연도를 선택합니다.
  3. SOLIDWORKS 제품에 대해 SOLIDWORKS 탭을 선택합니다.
  4. 제품 영역에서 서비스 팩을 선택합니다.
    최신 주요 릴리즈인 경우 SOLIDWORKS 제품 버전 0.0을 선택합니다.
  5. 사용권 계약에 동의하려면 계약에 동의하고 계속을 클릭합니다.
  6. 다운로드를 클릭합니다.
    웹 브라우저가 SolidworksSetup.exe를 기본 위치 C:\Users\Username\Downloads로 다운로드합니다.
  7. Downloads 폴더에 SolidworksSetup.exe의 압축을 풉니다.
    원하는 위치에 SolidworksSetup.exe의 압축을 풀 수도 있습니다.
  8. setup.exe를 관리자 권한으로 실행합니다.
  9. 설치 관리자에서 모든 파일 다운로드 및 공유를 클릭합니다.
    한 번의 다운로드로 여러 컴퓨터에 개별 설치 또는 관리 이미지를 생성한 후 표시되는 메시지에 따라 프로세스를 완료합니다.

    설치 관리자가 설치 미디어를 자동으로 다운로드합니다.

    이 옵션은 다음에 유용합니다.
    • 소수의 컴퓨터에 소프트웨어 설치
    • 휴대용 드라이브 또는 네트워크 드라이브를 사용하여 다운로드
    • Service Pack 설치
    설치 파일을 선택적으로 다운로드하려면 화면의 지시에 따라 수동 다운로드 방법을 선택합니다.
상위 주제 SOLIDWORKS 설치 및 관리
개별 설치 또는 관리 이미지
시스템 및 소프트웨어 요구 사항 확인
3DEXPERIENCE 앱 설치


3DEXPERIENCE 앱 설치

3DEXPERIENCE Platform을 사용하여 데이터를 관리하는 경우 Collaborative Designer for SOLIDWORKS 역할을 구입하여 데스크톱 환경을 플랫폼에 연결할 수 있습니다.

Collaborative Designer for SOLIDWORKS 역할은 3DEXPERIENCE 앱에 대한 액세스 권한을 부여하며, 이를 통해 SOLIDWORKS Desktop 제품은 플랫폼에 저장된 데이터를 저장, 검색, 관리할 수 있습니다.

SOLIDWORKS 설치 관리자가 아닌 3DEXPERIENCE Platform에서 이러한 앱을 설치하고 사용권을 부여합니다. 설치 지침은 SOLIDWORKS 도움말에서 3DEXPERIENCE Platform 및 3DEXPERIENCE 앱 작업 > 3DEXPERIENCE 앱 설치를 참조하십시오.

상위 주제 SOLIDWORKS 설치 및 관리
개별 설치 또는 관리 이미지
시스템 및 소프트웨어 요구 사항 확인
설치 미디어 다운로드
https://help.solidworks.com


개별 설치

목차

  • 개별 컴퓨터에 설치

    몇 가지 설치 방법을 사용하여 개별 컴퓨터에 SOLIDWORKS를 설치할 수 있습니다.

  • 개별 설치 관리

    대개, 개별 설치 관리는 설치 수정, 복구, 제거, 업그레이드로 이루어집니다.


개별 컴퓨터에 설치

몇 가지 설치 방법을 사용하여 개별 컴퓨터에 SOLIDWORKS를 설치할 수 있습니다.

SOLIDWORKS 설치 관리자는 구입한 제품에 대한 설치에 맞게 설치를 수행합니다. 설치를 시작하기 전:

  • SOLIDWORKS의 독립 실행형 시트를 설치하는 경우 SOLIDWORKS 제품 번호를 확인해 두십시오.
  • 인터넷 연결을 확인합니다. 연결은 권한을 확인하는 데 필요합니다.
  • 3DEXPERIENCE ID를 생성합니다. 3DEXPERIENCE ID 생성에 대한 자세한 내용은 https://www.3ds.com/support을(를) 참조하십시오.
  • 사용자가 계정에 지정된 관리자이거나 관리자가 사용자를 담당자로 기재했는지 확인합니다.

SOLIDWORKS 설치 관리자는 Microsoft Visual Studio Tools for Applications, Visual Basic, .NET Framework 등 다양한 Microsoft 구성 요소를 설치합니다. 올바른 버전의 모든 필요한 Windows 구성 요소가 컴퓨터에 설치되어 있지 않을 경우 SOLIDWORKS 설치 관리자는 SOLIDWORKS 제품을 설치하기 전에 해당 구성 요소를 자동으로 설치합니다.

SOLIDWORKS CEF(Chromium Embedded Framework)는 SOLIDWORKS 설치 관리자가 설치하는 또 다른 구성 요소입니다. SOLIDWORKS 앱 및 3DEXPERIENCE Platform용 콘텐츠를 표시하는 것이 목적입니다.

SOLIDWORKS Login Manager는 SOLIDWORKS 설치 관리자에 의해 설치됩니다. 이를 통해 3DEXPERIENCE Marketplace 및 3DEXPERIENCE 앱에 로그인할 수 있습니다.

설치 방법 프로세스 요약
SOLIDWORKS 다운로드 페이지에서 다운로드

모든 설치 미디어는 SOLIDWORKS 다운로드 페이지에서 사용할 수 있습니다.

  1. SOLIDWORKS 다운로드 페이지로 이동합니다.
  2. 3DEXPERIENCE ID로 로그인합니다.
  3. 다운로드 페이지의 버전 선택에서 연도를 선택합니다.
  4. SOLIDWORKS 제품의 SOLIDWORKS 탭을 클릭하고 제품 아래에서 Service Pack을 선택합니다.
  5. 사용권 계약에 동의하려면 계약에 동의하고 계속을 클릭합니다.
  6. 다운로드를 클릭합니다.
다운로드 페이지에 대한 로그인 액세스 권한을 가진 인터넷 연결이 있어야 합니다.

다운로드 페이지에 액세스할 수 없는 경우 공인 리셀러에게 문의하여 설치 미디어를 받으십시오.
서버에서 다운로드 디렉터리 사용 다운로드 디렉터리에서 setup.exe을 더블 클릭합니다.

다운로드 디렉터리는 SOLIDWORKS 제품을 설치하는 컴퓨터에서 액세스할 수 있어야 하고 모든 SOLIDWORKS 설치 파일이 포함되어 있어야 설치를 시작할 수 있습니다. 사용자 컴퓨터가 인터넷에 연결되어 있고 다운로드 디렉터리에 대한 쓰기 권한이 있을 경우 SOLIDWORKS 설치 관리자가 누락된 파일을 찾는 과정을 도와줍니다.
업데이트 확인을(를) 사용하여 기존 SOLIDWORKS 설치 업데이트하기 다음 중 하나를 수행합니다.
  • SOLIDWORKS에서 [image] > 업데이트 확인을 클릭합니다.
  • Windows에서 시작 > SOLIDWORKS 설치 관리자 > 업데이트 확인을 클릭합니다.
시작 > SOLIDWORKS 설치 관리자 > SOLIDWORKS 백그라운드 다운로더를 클릭할 수도 있습니다. Windows 알림 영역에서 SOLIDWORKS 백그라운드 다운로더를 오른쪽 클릭하고 업데이트 확인을 클릭합니다.
컴퓨터의 관리자 권한이 필요하며 인터넷에 연결되어 있어야 합니다.

SOLIDWORKS 설치 관리자에서 필수 구성 요소 소프트웨어를 포함한 모든 파일 다운로드 및 공유 옵션을 선택할 수도 있습니다. 이 옵션은 소프트웨어를 일부 시스템에 설치하고 휴대용 드라이브 또는 네트워크 드라이브를 사용하여 다운로드를 복사하려는 경우에 유용합니다. 정식 버전과 서비스 팩이 하나의 설치에 포함되어 있기 때문에 서비스 팩을 설치하는 데에도 유용합니다.

설치가 완료되면, SOLIDWORKS 응용 프로그램을 시작하고 사용권을 활성화을(를) 활성화합니다.

컴퓨터에 사용권이 부여된 제품 목록을 표시하려면 SOLIDWORKS 주 메뉴에서
  • > 내 제품을 클릭합니다.
  • 작업 창에서 홈을 클릭하고 SOLIDWORKS 리소스 > 내 제품을 클릭합니다.
  • 시작 > SOLIDWorks Tools버전 > 내 제품을 클릭합니다.

대화 상자의 확인 표시는 활성화 및 네트워크 사용권을 기준으로 본인 또는 본인이 속한 조직이 소유하고 있는 제품을 나타냅니다. 또한 각 제품 종류 맨 위에 있는 링크를 클릭하여 SOLIDWORKS 제품 정보를 볼 수도 있습니다.

SOLIDWORKS 사용권이 있는 경우 사용 중인 사용권을 보려면 Windows에서 시작 > SOLIDWORKS Tools <버전> > SolidNetWork License Manager Client > 사용권 사용 탭을 클릭합니다.

상위 주제 개별 설치
개별 설치 관리


개별 설치 관리

대개, 개별 설치 관리는 설치 수정, 복구, 제거, 업그레이드로 이루어집니다.

목차

  • 설치 수정

    모든 설치 파일을 사용하여 이전 설치를 완료했다면 설치를 수정하여 설치되지 않은 제품을 설치하거나 제품을 제거할 수 있습니다. 이 옵션은 서비스 팩으로 이전 버전을 업그레이드한 경우 사용할 수 없습니다.

  • 설치 복구

    설치된 SOLIDWORKS 제품에 문제가 있을 경우, SOLIDWORKS 설치 관리자를 사용해서 설치를 복구할 수 있습니다.

  • 개별 설치를 이전 서비스 팩으로 롤백

  • 설치 제거

    개별 컴퓨터나 클라이언트/서버 환경에서 설치를 제거할 수 있습니다.

  • 새 릴리즈로 업그레이드

    개별 설치를 SOLIDWORKS 새 릴리즈로 업그레이드하는 방법은 몇 가지가 있습니다.

  • 제품 공존 규칙

    새 제품의 설치와 기존 제품의 업그레이드 시 공존 규칙은 다음과 같습니다.

상위 주제 개별 설치
개별 컴퓨터에 설치


설치 수정

모든 설치 파일을 사용하여 이전 설치를 완료했다면 설치를 수정하여 설치되지 않은 제품을 설치하거나 제품을 제거할 수 있습니다. 이 옵션은 서비스 팩으로 이전 버전을 업그레이드한 경우 사용할 수 없습니다.

SOLIDWORKS를 이미 설치한 후 나중에 애드인 제품을 구매한 경우 설치를 수정해서 새 애드인을 포함할 수 있습니다. 개별 컴퓨터 각각에 애드인을 설치해야 합니다.

  1. 활성 상태인 SOLIDWORKS 세션이 없는지 확인합니다.
  2. Windows 앱을 열고 설치된 앱을 클릭합니다.
  3. 수정할 SOLIDWORKS 설치를 선택한 후 변경을(를) 클릭합니다.
  4. SOLIDWORKS 설치 관리자 시작 화면에서 설치 수정을 클릭합니다.
  5. 제품 번호 화면에서 적합한 제품 번호가 지정되었는지 확인합니다.
  6. 제품 선택 화면에서 설치하거나 제거할 제품을 선택합니다.
    설치를 수정하는 경우,
    • 새 제품 번호를 지정하더라도 기본적으로 설치되거나 제거된 제품이 없습니다. 반드시 각 제품이나 구성 요소 설치 작업을 변경시켜야 합니다.
    • 특정 구성 요소에 대해 적용되는 작업을 보려면 확인란이 아닌, 구성 요소 이름을 클릭합니다. 계획된 설치 작업이 제품 목록 아래 정보 필드에 나타납니다.
    • 제품 구성 요소 옆에 있는 확인란을 클릭하여 해당 구성 요소에 대한 설치 작업을 변경할 수 있습니다. (예를 들어, 구성 요소를 설치하거나 제거할 경우 해당 확인란을 선택하면 구성 요소가 설치되거나 제거되도록 지정되고 확인란을 선택 취소하면 구성 요소가 설치되거나 제거되지 않도록 지정됩니다.)
    • 최초 스팩에서 구성 요소 설치 작업을 변경하면 목록에서 해당 구성 요소 옆에 별표(*)가 나타납니다.
    • 구성 요소에 설치 하위 구성 요소 선택 항목이 포함되어 있으면 해당 구성 요소 옆에 [image] 아이콘이 표시됩니다. 구성 요소에 포함된 하위 구성 요소를 보려면 [image] 아이콘을 클릭합니다.
    • 하위 구성 요소 선택 항목이 보이게 구성 요소가 확장되어 있으면 해당 구성 요소 옆에 [image] 아이콘이 표시됩니다. 하위 구성 요소 목록을 축소하려면 [image] 아이콘을 클릭합니다.
  7. 요약 화면에서 지금 수정을(를) 클릭합니다.
  8. 설치 완료 화면에서 마침을(를) 클릭합니다.
상위 주제 개별 설치 관리
설치 복구
개별 설치를 이전 서비스 팩으로 롤백
설치 제거
새 릴리즈로 업그레이드
제품 공존 규칙


설치 복구

설치된 SOLIDWORKS 제품에 문제가 있을 경우, SOLIDWORKS 설치 관리자를 사용해서 설치를 복구할 수 있습니다.

설치를 복구하려면 컴퓨터에 이전 설치의 모든 소스 파일과 적용된 모든 서비스 팩이 있어야 합니다. 이것은 원래 설치한 위치에 있어야 합니다.

개별 설치를 복구할 수 있습니다. 관리 이미지를 수정할 수 없습니다; 반드시 관리 이미지를 설치해제 한 다음 재설치합니다.
  1. Windows 제어판을 열고 프로그램 > 프로그램 및 기능을 클릭합니다.
  2. 복구할 SOLIDWORKS 버전을 마우스 오른쪽 버튼으로 클릭하고 변경을 클릭합니다.
  3. SOLIDWORKS 설치 관리자 시작 화면에서 설치 복구를 클릭하고 다음을 클릭합니다.
  4. 복구할 제품 화면에서 복구할 제품을 선택합니다.
  5. 화면에서 나머지 제품은 선택 취소합니다.
  6. 복구를 클릭합니다.
상위 주제 개별 설치 관리
상위 주제 설치 오류/취소된 설치
설치 수정
개별 설치를 이전 서비스 팩으로 롤백
설치 제거
새 릴리즈로 업그레이드
제품 공존 규칙
실패하거나 취소된 설치에서 복구
SOLIDWORKS 리셀러에 문의


개별 설치를 이전 서비스 팩으로 롤백

개별 설치를 현재 주요 버전 제품군의 이전 서비스 팩으로 롤백하려면 컴퓨터에 현재 설치된 서비스 팩을 제거한 후 이전 버전을 다시 설치합니다.
상위 주제 개별 설치 관리
설치 수정
설치 복구
설치 제거
새 릴리즈로 업그레이드
제품 공존 규칙


설치 제거

개별 컴퓨터나 클라이언트/서버 환경에서 설치를 제거할 수 있습니다.

  1. 활성 상태인 SOLIDWORKS 세션이 없는지 확인합니다.
  2. SOLIDWORKS 사용권을 다른 컴퓨터로 이동하려면 이 컴퓨터에서 SOLIDWORKS 설치를 제거하기 전에 사용권을 비활성화합니다.
    자세한 내용은 사용권 이동을 참고합니다.
  3. Windows 제어판을 열고 프로그램 및 기능을 클릭합니다.
  4. 제거할 제품 부품을 선택하고 제거를 클릭합니다.
    경우에 따라 특정 주요 릴리즈 버전에 대해 여러 개의 SOLIDWORKS 서비스 팩이 있습니다. SOLIDWORKS 주요 릴리즈를 제거하려면 해당 주요 릴리즈에 대한 모든 서비스 팩 요소를 제거합니다.
  5. 제거 화면에서 다음을 수행합니다.
    1. 제거할 제품을 선택합니다.
      기본적으로 모든 구성 요소가 선택되어 있습니다.
    2. 제거하지 않으려는 제품은 선택 취소합니다.
    3. 변경에서 고급 옵션을(를) 클릭합니다.
      고급 옵션 화면이 나타나고 프로그램 파일 및 폴더 옵션이 선택되어 있습니다.
    4. 사용자 정의 제거를 수행하려면 하나 이상의 옵션을 선택하고, 전체 제거를 수행하려면 모든 옵션을 선택합니다.
      기본적으로 SOLIDWORKS 설치 관리자는 전체 제거를 수행하고 설치 시 추가된 모든 파일과 폴더를 제거합니다.
    5. 요약으로 돌아가기를 클릭합니다.
    6. 요약 화면에서 고급 옵션을 확장하여 제거 방법 및 항목을 표시합니다.
    7. 항목 제거를 클릭합니다.
상위 주제 개별 설치 관리
상위 주제 여러 시트 설치 관리
설치 수정
설치 복구
개별 설치를 이전 서비스 팩으로 롤백
새 릴리즈로 업그레이드
제품 공존 규칙
관리 이미지를 새 버전으로 업그레이드
서비스 팩 제품 업데이트 관리
사용권 이동


새 릴리즈로 업그레이드

개별 설치를 SOLIDWORKS 새 릴리즈로 업그레이드하는 방법은 몇 가지가 있습니다.

다음 경우 새 릴리즈로 업그레이드할 수 있습니다.
  • 새 설치 매체 수령
  • SOLIDWORKS 시작 시 업그레이드 알림 메시지를 받은 경우
  • 직접 업데이트 확인
  • SOLIDWORKS 설치 관리자의 새 인스턴스를 시작하는 경우

새 주요 릴리즈를 설치하면 이전에 설치된 주요 릴리즈를 업그레이드하거나 새 릴리즈를 한 곳에 같이 설치할 수 있습니다. 이전에 설치된 주요 릴리즈에 대한 서비스 팩 릴리즈를 설치하는 경우 해당 릴리즈가 자동으로 업데이트됩니다.

상위 주제 개별 설치 관리
설치 수정
설치 복구
개별 설치를 이전 서비스 팩으로 롤백
설치 제거
제품 공존 규칙

직접 업데이트 확인

컴퓨터에 대한 관리자 권한이 있는 경우 설치된 SOLIDWORKS 릴리즈의 업데이트를 다음 방법 중 하나로 확인할 수 있습니다.

  • SOLIDWORKS에서 [image] > 업데이트 확인을 클릭합니다.
  • Windows에서 시작 > SOLIDWORKS 설치 관리자 > 업데이트 확인을 클릭합니다.
시작 > Solidworks 설치 관리자 > SOLIDWORKS 백그라운드 다운로더를 클릭할 수도 있습니다. Windows 알림 영역에서 SOLIDWORKS 백그라운드 다운로더를 오른쪽 클릭하고 업데이트 확인을 클릭합니다.

업그레이드 주의사항

다른 주요 버전으로 여러 번 설치된 제품에는 항상 주요 업그레이드 또는 한번의 작업으로 주요 버전으로 업그레이드를 하는 기능이 지원되지 않습니다.

이 경우, SOLIDWORKS 설치 관리자가 새 버전을 먼저 설치한 다음 오래된 버전을 제거해서 업그레이드합니다. 이때 다른 제품과는 달리, 주요 SOLIDWORKS 제품은 주요 업그레이드를 지원합니다.

결과는 다음과 같습니다.
  • 주요 버전 간 SOLIDWORKS 제품을 업그레이드하는 경우:
    • 사용자의 기존 설치 위치가 변경되지 않습니다.
    • 업그레이드 중 오류가 있거나 취소할 경우 업그레이드를 되돌릴 수 있습니다.
  • 다른 제품이 주요 버전 간 업그레이드 될 경우:
    • 각 제품이 새 위치에 새 제품으로 먼저 설치된 다음, 원래 설치가 제거됩니다.
    • 일단 시작되면, 업그레이드 중 오류가 있거나 취소할 경우 업그레이드를 되돌릴 수 없습니다.


제품 공존 규칙

새 제품의 설치와 기존 제품의 업그레이드 시 공존 규칙은 다음과 같습니다.

규칙 | 예
아래 언급한 제품을 제외하고 핵심 SOLIDWORKS 제품의 주요 릴리즈 버전 다수가 허용됩니다. | SOLIDWORKS 2024 SP3.0과 SOLIDWORKS 2025 SP0.0은 같은 컴퓨터에서 함께 사용할 수 있습니다.
같은 주요 릴리즈 버전의 서비스 팩 다수가 허용되지 않습니다. | SOLIDWORKS 2025 SP0.0과 2025 SP1.0은 같은 컴퓨터에서 함께 사용할 수 없습니다. SOLIDWORKS 2025 SP0.0이 이미 설치되어 있는 컴퓨터에 SOLIDWORKS 2025 SP1.0을 설치하는 경우 SOLIDWORKS 설치 관리자가 SP0.0을 SP1.0으로 바꿉니다.
컴퓨터에 한 버전만이 허용되는 제품:
  • SolidNetWork License Manager
 SOLIDWORKS의 이전 주요 릴리즈가 컴퓨터에 남아 있더라도 SolidNetWork License Manager 2024 SP3.0이 설치되면 SolidNetWork License Manager가 2025 SP0.0으로 업그레이드됩니다.
컴퓨터에 한 버전만이 허용되는 제품:
  • SOLIDWORKS Electrical
 SOLIDWORKS Electrical 2025 SP1.0의 새 설치를 생성하는 경우 SOLIDWORKS 설치 관리자는 컴퓨터에서 SOLIDWORKS Electrical의 이전 버전을 자동으로 제거합니다. 업그레이드하기 전에 SOLIDWORKS Electrical 환경을 백업합니다.
컴퓨터에 한 버전만이 허용되는 제품:
  • SOLIDWORKS PDM Client
  • SOLIDWORKS PDM Server

SOLIDWORKS 2025 SP0.0 또는 SP1.0을 설치할 경우 SOLIDWORKS 2025 PDM Server 및 PDM Client로도 업그레이드해야 합니다.

SOLIDWORKS 2025 PDM Server를 설치할 경우 PDM Server 설치 프로세스를 사용하여 SOLIDWORKS PDM Client를 설치해야 합니다. 클라이언트 설치 프로세스를 사용해 SOLIDWORKS PDM Client를 따로 설치하지 마십시오.

SOLIDWORKS PDM Client는 동일한 컴퓨터에서 SOLIDWORKS PDM Server와 같은 릴리즈 버전 및 서비스 팩이어야 합니다.

자세한 내용은 SOLIDWORKS PDM 및 SOLIDWORKS Manage를 참조하십시오.

SOLIDWORKS의 주요 릴리즈 버전으로 포함된 제품의 한 버전만 설치할 수 있습니다. 그러나 SOLIDWORKS의 다른 주요 릴리즈 버전에서 포함된 제품의 버전을 함께 사용할 수 있습니다. | SOLIDWORKS 2025 SP0.0이 2025 SP1.0으로 업그레이드되면 SOLIDWORKS Composer 2025 SP0.0은 2025 SP1.0으로 자동 업그레이드됩니다. 그러나 SOLIDWORKS Composer 2024 SP4.0은 SOLIDWORKS Composer 2025 SP0.0 또는 SOLIDWORKS Composer 2025 SP1.0과 함께 사용할 수 있습니다.
상위 주제 개별 설치 관리
설치 수정
설치 복구
개별 설치를 이전 서비스 팩으로 롤백
설치 제거
새 릴리즈로 업그레이드


여러 시트 설치

목차

  • 여러 클라이언트에 배포

    관리자 이미지를 작성한 다음, 설치를 클라이언트에 배포해서 여러 클라이언트에 SOLIDWORKS 제품을 설치할 수 있습니다.

  • 관리 이미지 사용

    관리 이미지를 사용하여 단일 네트워크 위치에서 SOLIDWORKS 제품의 설정 가능한 설치를 지원합니다.

  • 명령줄 배포

    명령 프롬프트 또는 배치 파일(자동 설치)을 사용하여 관리 이미지를 자동으로 배포할 수 있습니다.

  • 여러 시트 설치 관리

    여러 시트 설치 시의 관리 작업으로는 관리 이미지를 새 버전으로 업그레이드, 서비스 팩 업데이트 적용, 설치 제거 등이 있습니다.


여러 클라이언트에 배포

관리자 이미지를 작성한 다음, 설치를 클라이언트에 배포해서 여러 클라이언트에 SOLIDWORKS 제품을 설치할 수 있습니다.

여러 클라이언트에 배포하는 절차:
  1. 관리자 이미지를 작성합니다.
    • SOLIDWORKS 설치 관리자로부터 관리 이미지 만들기
  2. 관리 이미지를 클라이언트에 배포합니다.
    • (이메일) 수동/풀 방법을 통해 클라이언트에 관리 이미지 배포
    • 자동/푸시 방법을 통해 클라이언트에 관리 이미지 배포
    • 명령줄을 사용하여 관리 이미지로부터 설치
  3. 사용권 절차를 수행합니다.
    • 개별 사용권 관리
    • SolidNetWork License Manager를 사용하여 사용권 관리
상위 주제 여러 시트 설치
관리 이미지 사용
명령줄 배포
여러 시트 설치 관리


관리 이미지 사용

관리 이미지를 사용하여 단일 네트워크 위치에서 SOLIDWORKS 제품의 설정 가능한 설치를 지원합니다.

클라이언트 컴퓨터를 포함한 네트워크 상의 컴퓨터로부터 관리 이미지를 설치할 수 있습니다.
  • 관리 이미지가 공유 폴더에 있어야 합니다.
  • 모든 제품을 포함시키면 관리 이미지 디스크 필수 공간이 17GB 이상이 될 수 있습니다.
  • 관리 이미지를 업그레이드할 때 공유이름을 업데이트하는 경우 응용 프로그램 시작시 클라이언트 업그레이드가 자동으로 이루어집니다. 자세한 내용은 관리 이미지 업그레이드의 내용을 참조하십시오.
  • 관리 이미지를 배포하는 경우 이미지에 대한 경로는 58자 미만이어야 합니다.
  • 클라이언트가 컴퓨터에 관리자 권한이 있어야 합니다. 클라이언트에 충분한 권한이 없으면 클라이언트는 다른 사용자로 설치를 실행할 수 있습니다. 이 옵션은 개별 사용자가 컴퓨터에 대해 SOLIDWORKS 제품 설치 시 필요한 로컬 관리자 권한을 갖고 있지 않을 경우 유용할 수 있습니다.

    옵션 편집기에서 설치 배포하기 항목을 참조하십시오. 클라이언트에 충분한 권한이 없는 경우 이미지를 설치하는 다른 방법도 설명합니다.

  • Windows 로깅을 사용하거나 관리 이미지 옵션 편집기에서 상태 기능을 사용하는 경우 다음 폴더에 대한 읽기/쓰기 권한이 있어야 합니다. {Administrative image directory}\x64\Logs.

관리 이미지를 작성하고 나면 관리 이미지 옵션 편집기가 해당 이미지에서 사용자 및 그룹 설치에 대한 설치 옵션 설정을 관리할 수 있습니다. 자세한 내용은 관리 이미지 옵션 편집기의 내용을 참조하십시오.

목차

  • 관리 이미지 유형

    관리 이미지 옵션 편집기를 사용하여 원격 사용자 및 네트워크 사용자를 위해 여러 유형의 이미지를 작성할 수 있습니다.

  • SOLIDWORKS 설치 관리자로부터 관리 이미지 만들기

    여러 대 컴퓨터에 SOLIDWORKS를 설치할 경우, 관리 이미지를 사용한 다음 다른 컴퓨터에 설치된 프로그램을 배포할 수 있습니다.

  • 관리 이미지 옵션 편집기

    관리 이미지 옵션 편집기로 개별 컴퓨터와 컴퓨터 그룹의 관리 이미지 내 설치 변수 설정을 사용자 정의할 수 있습니다.

  • 설정 관리자 도구

상위 주제 여러 시트 설치
여러 클라이언트에 배포
명령줄 배포
여러 시트 설치 관리
관리 이미지에서 클라이언트 업그레이드


관리 이미지 유형

관리 이미지 옵션 편집기를 사용하여 원격 사용자 및 네트워크 사용자를 위해 여러 유형의 이미지를 작성할 수 있습니다.

관리 이미지 유형 설명
표준

이 이미지는 모든 새 관리 이미지의 기본값입니다.

회사 네트워크에 안정적으로 액세스하는 사용자에게 적합한 표준 Windows Installer 관리 이미지입니다. 선택한 SOLIDWORKS 제품을 공유 이미지 폴더에 설치하는 데 필요한 모든 파일을 저장합니다.

사용자가 새 서비스 팩으로 업그레이드하는 경우 패치 파일을 다운로드하고 적용할 수 있으며, 전체 이미지를 다운로드하지 않아도 됩니다.
원격 클라이언트

이 이미지는 회사 네트워크에 안정적으로 액세스하지 못하는 원격 사용자를 위해 설계되었습니다.

이 유형의 이미지를 설치하는 경우 원격 사용자는 제품 번호 및 설치할 제품과 같이 지정된 설치 옵션을 모두 상속합니다.

사용자는 인터넷을 통해 SOLIDWORKS 다운로드 페이지에서 필요한 파일을 다운로드합니다. 인터넷에서 이러한 파일에 액세스하고 설치하는 방법이 회사 네트워크에서 다운로드하는 것보다 안정적이며, 네트워크에 대한 로드를 줄일 수 있습니다.

원격 사용자는 표준 관리 이미지에서 지원되는 동일한 방식으로 이 이미지를 설치합니다. sldim.exe 및 startwinstall.exe 파일을 사용하여 설치를 스크립트로 수행할 수도 있습니다.

설치 파일은 설치 전에 관리 이미지 옵션 편집기에서 지정한 경로에 다운로드됩니다. 사용자는 설치를 시작하고 여기에 호스팅된 배치 또는 설정 파일을 실행하려면 관리 이미지 폴더에 액세스할 수 있어야 합니다.

원격 사용자는 설치가 완료되면 사용자가 이미지를 삭제할 수는 있지만 이미지의 모든 파일을 저장할 충분한 디스크 공간을 확보해야 합니다.
Compressed

압축된 관리 이미지는 관리 이미지를 여러 사이트 또는 클라이언트 컴퓨터에 복사해야 하는 조직에게 필요한 것으로, 네트워크에 미치는 영향을 최소화하려는 경우에 사용합니다.

이 이미지는 표준 관리 이미지보다 60% 정도 작지만, 설치 시간은 동일합니다. 수정 및 복구와 같은 모든 설치 작업을 지원합니다.

압축된 관리 이미지에도 짧은 파일 경로가 있습니다. 이미지가 깊은 폴더 구조에 저장된 경우 문제를 방지합니다.

사용자가 새 서비스 팩으로 업그레이드하는 경우 패치가 아니라, 전체 이미지를 다운로드해야 합니다.
상위 주제 관리 이미지 사용


SOLIDWORKS 설치 관리자로부터 관리 이미지 만들기

여러 대 컴퓨터에 SOLIDWORKS를 설치할 경우, 관리 이미지를 사용한 다음 다른 컴퓨터에 설치된 프로그램을 배포할 수 있습니다.

  1. SOLIDWORKS 설치 관리자를 시작합니다.

    설치 미디어 다운로드을 참조하십시오.

  2. 시작 화면에서 여러 컴퓨터에 배포할 관리 이미지 생성을 선택하고 다음 옵션 중 하나를 선택합니다.
    옵션 | 설명
    기본 설정을 사용하여 새 이미지를 작성합니다. | 기본 구성 설정을 사용하여 관리 이미지를 작성합니다(즉, 사이트의 기존 관리 이미지에 대해 지정된 설정을 기반으로 하는 것이 아님).
    기존 이미지의 설정과 파일을 사용하여 새 이미지를 작성합니다. | 사이트의 기존 관리 이미지에 지정된 구성 설정을 사용하여 이미지를 작성합니다. 찾아보기를 클릭하여 기존 관리 이미지의 설치 디렉터리를 지정합니다.
  3. SOLIDWORKS 제품 번호를 입력합니다.
  4. 다음 항목이 포함된 제품 또는 기본 옵션을 수정하려면 변경을 클릭합니다.
    • 관리 이미지 위치
    • 관리 이미지 유형
  5. 사용권 계약에 동의하고 지금 작성을 클릭합니다.
  6. 이미지 사용자 정의를 클릭하여 관리 이미지 옵션 편집기에서 설정을 열고 표시합니다.
  7. 옵션: 바탕 화면 바로 가기 만들기를 클릭하여 바탕 화면의 이미지에 액세스합니다.
상위 주제 관리 이미지 사용


관리 이미지 옵션 편집기

관리 이미지 옵션 편집기로 개별 컴퓨터와 컴퓨터 그룹의 관리 이미지 내 설치 변수 설정을 사용자 정의할 수 있습니다.

관리 이미지를 만들고 나면 SOLIDWORKS 설치 관리자가 옵션 편집기 시작 여부를 묻습니다. 관리 이미지 폴더에 있는 sldAdminOptionEditor.exe을(를) 더블 클릭하여 옵션 편집기를 시작할 수 있습니다.

개별 컴퓨터 또는 컴퓨터 그룹에 대해 서로 다른 설치 설정을 지정하려면 옵션 편집기에서 컴퓨터를 선택합니다. 그런 다음, 해당 컴퓨터의 설치 옵션을 지정합니다.

파일 또는 폴더 경로 메시지가 표시되는 모든 대화 상자에는 선택한 폴더를 환경 변수에 매핑하는 옵션이 포함되어 있습니다. 예를 들어, C:\Program Files\SOLIDWORKS Corp를 선택할 경우 파일 경로는 %ProgramFiles%\SOLIDWORKS Corp에 매핑됩니다. 가장 일반적인 변수는 %ProgramFiles% 및 %SystemDrive%입니다.

모든 경로를 환경 변수에 매핑할 수 있는 것은 아닙니다. 예를 들어 Z:\SOLIDWORKS Data는 환경 변수에 매핑할 수 없습니다.

목차

  • 그룹과 컴퓨터 추가 및 삭제

    관리 이미지 옵션 편집기로 컴퓨터 그룹과 개별 컴퓨터에 다른 설치 구성을 지정할 수 있습니다.

  • 옵션 설정 보기 및 편집하기

    SOLIDWORKS 관리 이미지 옵션 편집기를 사용하여 이미지에 대해 지정된 그룹과 컴퓨터의 옵션 설정을 보고 변경할 수 있습니다.

  • 옵션 편집기에서 설치 배포하기

    수동 또는 강제 방법을 사용하여 옵션 편집기에서 직접 설치를 배포할 수 있습니다.

  • 옵션 편집기 종료

    확인 또는 닫기를 클릭하여 변경 사항을 적용하고 옵션 편집기를 종료할 수 있습니다.

  • 옵션 편집기에 대한 바탕 화면 바로 가기 만들기

    응용 프로그램 내의 특정 관리 이미지에 대한 옵션 편집기의 Windows 바탕 화면 바로 가기를 만들 수 있습니다.

  • 관리 이미지를 전자우편을 통해 클라이언트에 배포

    공유 관리 이미지 디렉터리를 작성한 후에는 전자우편으로 클라이언트에 통지할 수 있습니다.

상위 주제 관리 이미지 사용


그룹과 컴퓨터 추가 및 삭제

관리 이미지 옵션 편집기로 컴퓨터 그룹과 개별 컴퓨터에 다른 설치 구성을 지정할 수 있습니다.

예를 들어, 이미지에서 사용 가능한 제품 구성 요소의 서브세트를 사용하도록 여러 컴퓨터를 구성할 수 있지만 다른 그룹은 다른 구성 요소 서브세트를 사용할 수 있습니다. 하나의 관리 이미지를 사용하는 경우에도 옵션 편집기 그룹 설정을 사용하여 다른 제품 서브세트를 다른 컴퓨터 그룹에 설치할 수 있습니다. 그룹 사이에서 설정을 이동하거나 컴퓨터의 그룹을 편집할 수 있습니다.

컴퓨터의 그룹을 하위 그룹으로 나눌 수도 있습니다. 하위 그룹은 상위 그룹의 설정을 상속하지만, 각 하위 그룹에 대한 개별 설정을 변경할 수 있습니다.

그룹 추가 방법
  1. 전체 설정을 오른쪽 클릭한 후 그룹 추가를 클릭합니다.
  2. 그룹 이름을 입력합니다.

컴퓨터 추가하기:
  1. 기존 그룹이나 전체 설정을 오른쪽 클릭한 후 컴퓨터 추가를 클릭합니다.
    기존 그룹을 오른쪽 클릭하는 경우 컴퓨터가 그 그룹에 추가됩니다. 그렇지 않으면 최상위 레벨에 추가됩니다.
  2. 다음 중 하나를 수행합니다.
    • 내 컴퓨터 이름을 선택하고 컴퓨터 이름을 입력합니다.
      컴퓨터 이름에 도메인 한정자가 포함되어서는 안 됩니다. 예를 들어 pluto.solidworks.com은 타당치 않습니다.
    • IP 주소로를 선택하여 컴퓨터의 IP 주소를 입력합니다.
    • IP 주소 범위로를 선택하여 범위의 시작 IP 주소와 종료 IP 주소를 입력합니다.
    • 여러 대의 컴퓨터 추가를 클릭하여 컴퓨터 이름을 입력합니다. 컴퓨터 이름을 줄 바꿈, 공백, 탭, 쉼표, 마침표, 콜론 또는 세미콜론으로 구분할 수 있습니다. *.xls 또는 *.cvs 파일과 같은 구분된 파일의 컴퓨터 이름 목록을 복사하여 대화 상자에 붙여 넣을 수도 있습니다.

    이름, IP 주소, IP 주소 범위별로 컴퓨터를 추가하면 설치 컴퓨터에서 다음 순서로 일치하는 항목을 찾습니다. 컴퓨터 이름, IP 주소, IP 주소 범위. 설치 옵션은 발견된 첫 번째 일치 항목을 기반으로 설치 컴퓨터에 적용됩니다.

기존 컴퓨터를 그룹 또는 하위 그룹으로 이동하기:

컴퓨터를 그룹 또는 하위 그룹으로 끕니다.

그룹 또는 하위 그룹에서 컴퓨터 이동하기:

컴퓨터를 일반 설정이나 다른 그룹 또는 하위 그룹으로 끕니다.

그룹, 하위 그룹 또는 컴퓨터 삭제하기:

그룹, 하위 그룹 또는 컴퓨터를 오른쪽 클릭한 후 그룹 삭제나 컴퓨터 삭제를 클릭합니다.

그룹을 삭제할 경우 그 그룹안의 모든 컴퓨터가 삭제됩니다.

모든 그룹과 컴퓨터 삭제하기:

전체 설정을 오른쪽 클릭한 후 그룹 삭제를 클릭합니다.

상위 주제 관리 이미지 옵션 편집기
옵션 설정 보기 및 편집하기
옵션 편집기에서 설치 배포하기
옵션 편집기 종료
옵션 편집기에 대한 바탕 화면 바로 가기 만들기
관리 이미지를 전자우편을 통해 클라이언트에 배포


옵션 설정 보기 및 편집하기

SOLIDWORKS 관리 이미지 옵션 편집기를 사용하여 이미지에 대해 지정된 그룹과 컴퓨터의 옵션 설정을 보고 변경할 수 있습니다.

  • 옵션 편집기를 처음 시작하면 옵션 설정이 읽기 전용 모드로 표시됩니다. 변경 아이콘 [image] 이 음영 모드로 표시되어 있지 않습니다.

    전체 설정, 그룹 또는 컴퓨터를 클릭하면 해당 항목에 대한 옵션 설정의 요약이 표시됩니다.

    범위 | 표시되는 옵션 설정
    전체 설정 | 관리 이미지에 대해 지정된 모든 옵션 설정
    그룹 | 전체 설정과 관련해 그룹 설정에서의 변경 사항
    컴퓨터 | 그룹과 관련해 컴퓨터 설정에서의 변경 사항
  • 옵션 설정을 변경하려면 변경 [image] 을 클릭합니다. 아이콘이 음영 모드로 표시되고 더 상세한 설정 목록이 나타납니다.

    전체 설정, 그룹 또는 컴퓨터를 클릭하면 해당 항목에 대한 옵션 설정을 변경할 수 있습니다. 상속된 전체 설정 또는 그룹 설정과 다른 옵션 설정을 변경하면 해당 옵션 설정이 강조 표시됩니다.

    변경 [image] 을 다시 클릭하면 표시가 읽기 전용 모드로 다시 바뀝니다.

    설정을 변경하면 옵션 편집기를 마칠 때 변경 사항을 저장할 것인지, 무시할 것인지를 묻는 메시지가 나타납니다.

목차

  • 그룹과 컴퓨터의 옵션 설정 지정

    모든 컴퓨터(전체 설정), 컴퓨터 그룹, 개별 컴퓨터의 옵션 설정을 지정할 수 있습니다.

  • 관리 이미지 옵션 설정

    옵션 편집기를 사용하여 개별 클라이언트나 그룹에 대해 제품 번호, 클라이언트 설치 옵션, 설치할 소프트웨어 구성 요소, Toolbox 위치와 같은 옵션 설정을 지정할 수 있습니다.

  • 전체 및 그룹 옵션 설정 이어받기

    전체 설정 또는 그룹의 옵션 설정은 그 아래 항목들이 이어받습니다.

  • 각 컴퓨터의 설정 사용자 정의

    컴퓨터 이름을 오른쪽 클릭하여 특정 컴퓨터에 적용한 설정을 수정할 수도 있습니다.

상위 주제 관리 이미지 옵션 편집기
그룹과 컴퓨터 추가 및 삭제
옵션 편집기에서 설치 배포하기
옵션 편집기 종료
옵션 편집기에 대한 바탕 화면 바로 가기 만들기
관리 이미지를 전자우편을 통해 클라이언트에 배포


그룹과 컴퓨터의 옵션 설정 지정

모든 컴퓨터(전체 설정), 컴퓨터 그룹, 개별 컴퓨터의 옵션 설정을 지정할 수 있습니다.

  1. 옵션 편집기에서 수정할 개체를 클릭합니다(전체 설정, 그룹 또는 컴퓨터).
  2. 오른쪽에서 변경 [image] 을 클릭합니다.
    아이콘이 음영 모드로 표시되고 더 상세한 설정 목록이 나타납니다.
  3. 왼쪽에서 선택한 항목에 대해 오른쪽에 있는 옵션 설정을 클릭하여 옵션 설정을 변경합니다.
    전체 설정 또는 그룹 설정을 무시하는 옵션 설정의 변경 사항이 하이라이트됩니다.
  4. 확인 또는 닫기를 클릭하여 변경 사항을 저장합니다.
    옵션 | 설명
    확인 | 변경 사항이 저장되고 옵션 편집기가 종료됩니다.
    닫기 | 옵션 편집기에 변경 사항을 저장한 후 종료할 것인지를 묻는 메시지가 나타납니다.
상위 주제 옵션 설정 보기 및 편집하기
관리 이미지 옵션 설정
전체 및 그룹 옵션 설정 이어받기
각 컴퓨터의 설정 사용자 정의


관리 이미지 옵션 설정

옵션 편집기를 사용하여 개별 클라이언트나 그룹에 대해 제품 번호, 클라이언트 설치 옵션, 설치할 소프트웨어 구성 요소, Toolbox 위치와 같은 옵션 설정을 지정할 수 있습니다.

제품 번호

클라이언트 컴퓨터에 제품을 설치하려면 제품 번호를 입력합니다.
SOLIDWORKS 제품을 구입하는 여러 방법이 있으므로 일부 제품 번호로 두 개나 그 이상의 제품을 포괄할 수 있습니다. 예를 들어, SOLIDWORKS 제품 번호로 개별 SOLIDWORKS Simulation 제품 번호를 입력하지 않고 SOLIDWORKS Simulation을 설치할 수 있습니다. 또한, 일부 제품은 제품 번호를 필요로 하지 않습니다. 제품 번호에 관한 질문은 공인 리셀러(VAR)에게 문의하십시오.
SolidNetWork 사용권을 사용하여 사용권을 관리하는 경우:
  • 첫 번째 제품 번호 필드에 SolidNetWork 제품 번호를 입력합니다.
  • SNL Server port@server 필드에서 SolidNetWork License Manager 서버 이름과 포트 이름을 nnnnn@서버이름 형식으로 입력합니다. 여러 항목 입력 시 세미콜론으로 분리합니다.

SolidNetWork 사용권에 대한 자세한 내용은 SolidNetWork 사용권 설치 개요을(를) 참조하십시오.

클라이언트 설치 옵션

주요 버전의 클라이언트 설치 실행을 어떻게 진행하겠습니까? 클라이언트 설치 시 기존의 이전 주요 버전 설치를 어떻게 처리할지 지정할 수 있습니다.
  • 기존의 주요 버전 업그레이드 하기(기존 버전이 있는 경우)

    이전 주요 버전 설치를 새 버전 설치로 대체하려면 이 옵션을 지정합니다.

  • 새로운 주요 버전 만들기

    이전 주요 버전을 유지하며 새 주요 버전의 새 설치를 생성하려면 이 옵션을 지정합니다. 새 버전을 설치할 위치를 지정하려면 찾아보기를 클릭합니다.
새 주요 버전을 설치하기 전에 최근에 설치된 버전을 제거하시겠습니까? 기존에 있던 이전 주요 버전 설치를 제거할지 여부를 지정할 수 있습니다.
  • 설치하지 않습니다.

    이전 주요 버전 설치를 유지하려는 경우 이 옵션을 지정합니다.

  • 최근 버전을 제거합니다.
  • 모든 버전을 제거합니다.
SOLIDWORKS 설정을 어떻게 적용하시겠습니까? 소프트웨어를 시작할 때 설정 파일을 지정할 수 있습니다. 클라이언트 설치는 설정 파일을 참조합니다. 모든 설치에 표시되는 공유 UNC 경로에 설정(*.sldsettings) 파일을 저장합니다. SOLIDWORKS를 설치하기 전에 *.sldsettings 경로를 지정합니다. 클라이언트 설치에서 설치 도중 *.sldsettings 파일 경로를 탐지합니다.
지정된 사용자에게만 쓰기 권한을 허용하도록 Windows 파일 권한을 지정하여 *.sldsettings 파일을 보호합니다.

*.sldsettings를 작성하거나 편집하려면 설정 관리자 시작을 클릭합니다. SOLIDWORKS 설정 관리자 도구를 사용하여 적용할 SOLIDWORKS 시스템 옵션을 정의하고 선택적으로 최종 사용자에 대한 잠금을 정의할 수 있습니다. 또한 개별 설치에 설정을 적용하는 방법 및 시점을 정의하고, 언제든지 설정 관리자 도구를 실행해 기존 파일을 덮어써서 *.sldsettings 파일을 수정할 수도 있습니다.

컴퓨터 또는 그룹마다 다른 *.sldsettings 파일을 사용할 수 있습니다.

*.sldsettings의 경로는 설치 시 설정됩니다. 배포된 후에는 *.sldsettings 파일을 이동하거나 이름을 바꾸면 안 됩니다.

설정 관리자 도구를 실행하려면 기존 SOLIDWORKS [현재 주요 버전]이 설치되어 있어야 합니다.
클라이언트 설치 활성을 어떤 방식으로 하겠습니까? 설치를 실행한 후 제품 활성화를 자동으로 완료할지, 아니면 설치 후 사용자가 수동으로 제품 활성화를 수행해야 하는지를 지정할 수 있습니다.
  • 각 클라이언트의 설치가 완료될 때마다 자동으로 활성화합니다.

    이 옵션 설정을 선택하면 제품 활성화가 자동으로 실행되도록 지정됩니다. 클라이언트 컴퓨터에서 활성화가 실행될 때 제공될 이메일 주소를 입력합니다.

  • 자동으로 활성화하지 않습니다.

    이 옵션 설정을 선택하면 제품 활성화가 자동으로 실행되지 않습니다. 클라이언트 사용자가 설치 작업 이후에 직접 제품 활성화를 수행합니다.

관리자 옵션

모든 설치 중 진단 로그를 작성합니다. | 클라이언트 설치 시 설치 문제를 해결하기 위해 진단 로그를 작성할 수 있습니다. 이 로그를 작성하면 클라이언트 설치가 느리게 실행될 수 있습니다. 로그 파일은 Administrative image directory}\x64\Logs\<machine_name>에 저장됩니다.
다른 사용자 이름으로 설치를 실행합니다. | 관리자 권한을 가진 다른 사용자를 지정하여 로그인한 사용자 대신 설치를 실행할 수 있습니다. 이 옵션은 개별 사용자가 컴퓨터에 대해 SOLIDWORKS 제품 설치 시 필요한 로컬 관리자 권한을 갖고 있지 않을 경우 유용할 수 있습니다. 클라이언트에 관리 권한이 없는 경우 다른 배포 및 설치 방법을 사용할 수 있습니다. 옵션 편집기에서 설치 배포하기을 참조하십시오.
설치 전후 프로그램을 실행합니다. | 클라이언트 설치 전이나 후에 사용자 정의 프로그램을 실행하도록 지정할 수 있습니다.
클라이언트가 SOLIDWORKS 고객 피드백 프로그램에 참여하기를 원하십니까? | 클라이언트 컴퓨터가 SOLIDWORKS 고객 피드백 프로그램에 참여하도록 지정할 수 있습니다. 작업 수행 정보를 SOLIDWORKS에 보내면 제품 향상에 도움이 됩니다. 이 절차는 명확하며 기밀로 처리됩니다. 자세한 내용은 고객 피드백 프로그램 웹 사이트를 참고하십시오.

설치 옵션 전후 프로그램 실행에 대한 제약 요소

이러한 옵션을 사용하면 SOLIDWORKS 배포 전후에 클라이언트 컴퓨터에서 다른 설치 프로그램이나 스크립트(예: Microsoft Office를 설치하는 스크립트)를 실행할 수 있습니다.

이러한 옵션의 사용에는 제한이 따릅니다. 옵션을 사용하여 사용자 인터페이스를 표시하는 설치 프로그램이나 스크립트를 배포할 경우 오류가 발생합니다(예: 대화 상자를 표시하는 스크립트). SOLIDWORKS 자동 배포를 실행하면 대상 컴퓨터에 SOLIDWORKS를 설치하지 못합니다.

설치 전 프로그램 실행과 설치 후 프로그램 실행 옵션을 사용하려면 자동 모드에서 설치할 수 있는 프로그램만 선택합니다.

설치할 소프트웨어

설치할 SOLIDWORKS 제품 구성 요소를 지정할 수 있습니다.
  • 제품 구성 요소 옆에 있는 확인란을 선택하면 클라이언트 설치 시 해당 구성 요소가 설치되도록 지정됩니다.
  • 확인란을 선택 취소하면 해당 구성 요소가 설치되지 않도록 지정됩니다.
  • 구성 요소에 설치 하위 구성 요소 선택 항목이 포함되어 있으면 해당 구성 요소 옆에 + 아이콘이 표시됩니다. 구성 요소에 포함된 하위 구성 요소를 보려면 + 아이콘을 클릭합니다.
  • 하위 구성 요소 선택 항목이 보이게 구성 요소가 확장되어 있으면 해당 구성 요소 옆에 - 아이콘이 표시됩니다. 하위 구성 요소 목록을 축소하려면 - 아이콘을 클릭합니다.
언어 스펙에 따라 SOLIDWORKS 제품에만 설치되는 언어가 제한됩니다. 타 제품의 경우 해당 스펙에 영향을 받지 않습니다. 예를 들어 eDrawings®는 모든 언어를 설치합니다.

Toolbox 옵션

지원할 표준 및 클라이언트 설치의 기본 Toolbox 위치를 지정할 수 있습니다.

여러 사용자가 대개 네트워크 위치(예: UNC 경로, 공유 폴더 또는 공통 네트워크 드라이브 스팩)를 통해 공유 Toolbox에 액세스하는 것이 일반적입니다.

이 위치에 기존의 주요 버전 Toolbox가 있으면 클라이언트 설치 시 해당 Toolbox가 새 주요 버전으로 업그레이드됩니다. 그러면 파일이 더 이상 SOLIDWORKS의 이전 주요 버전과 호환되지 않습니다.
일부 클라이언트가 이전 버전의 SOLIDWORKS를 계속 사용하는 경우 최신 버전으로 업그레이드하는 클라이언트에 대해 다른 Toolbox 네트워크 위치를 지정해야 합니다.

SOLIDWORKS Toolbox 관리에 대한 자세한 내용은 SOLIDWORKS 도움말에서 SolidWorks 도움말 정보를 참조하십시오.

Toolbox 데이터를 설치하지 않고 Toolbox 소프트웨어 설치

사용자 환경에 PDM 또는 공유 Toolbox/구멍 가공 마법사 위치가 있는 경우 해당 위치에 Toolbox 데이터를 설치하거나 업그레이드하지 않도록 클라이언트 설치를 지정할 수 있습니다.

다음 경우에 이 작업을 수행합니다.
  • SOLIDWORKS를 설치하기 전에 SOLIDWORKS PDM 로컬 보기를 아직 지정하지 않았습니다.
  • 이 위치의 파일이 사용 중이므로 SOLIDWORKS 설치가 완료되지 못할 수 있습니다.
  • 이 위치를 사용할 수 없으므로 SOLIDWORKS 설치가 완료되지 못할 수 있습니다.

Toolbox 데이터를 설치하지 않도록 클라이언트 설치를 지정하는 경우 SOLIDWORKS 소프트웨어 및 설정은 Toolbox/구멍 가공 마법사 위치를 가리키지만 나중에 데이터를 중앙 위치에 설치해야 합니다.

Toolbox/구멍 가공 마법사 데이터를 포함하지 않고 SOLIDWORKS 소프트웨어를 설치하는 방법:
  • 이 클라이언트에서 Toolbox 파일을 설치/업그레이드할지 묻는 메시지가 나타나면 아니요, 데이터 파일을 포함하지 않고 Toolbox 소프트웨어를 설치합니다를 선택합니다.

최소한 한 명(일반적으로 CAD 관리자)이 Toolbox/구멍 가공 마법사 데이터를 중앙 위치에서 설치 또는 업그레이드해야 합니다. 그렇지 않으면 소프트웨어가 제대로 작동하지 않습니다. 조직의 모든 사용자가 SOLIDWORKS 소프트웨어를 수동으로 한 번 설치하여 이 작업을 처리할 수 있습니다. SOLIDWORKS PDM 내에서 Toolbox를 관리하는 경우 SOLIDWORKS PDM 관리자 안내서의 Toolbox 섹션에 설명된 단계를 수행하여 Toolbox 데이터를 설치 또는 업그레이드합니다.

SOLIDWORKS PDM 클라이언트 옵션

SOLIDWORKS PDM 클라이언트 및 애드인 배포에 대한 다음 옵션을 선택할 수 있습니다.

  • PDM 제품 유형
  • PDM 클라이언트 유형
  • 피처
  • 볼트 보기

    보기 설정 마법사를 열려면 SOLIDWORKS PDM 클라이언트가 설치된 컴퓨터에서 관리 이미지 옵션 편집기를 실행해야 합니다.

    클라이언트 컴퓨터에서 볼트 보기를 작성하려면 클라이언트 컴퓨터에서 볼트 보기를 설정할 파라미터를 정의하는 Conisio 보기 설정(.cvs) 파일이 필요합니다. 기존 .cvs 파일을 참조하거나 관리 이미지 옵션 편집기에서 이 파일을 작성할 수 있습니다.

이러한 클라이언트와 애드인에 대한 자세한 내용은 SOLIDWORKS 도움말의 SOLIDWORKS PDM 섹션을 참조하십시오.

Electrical 옵션

SOLIDWORKS Electrical의 관리 부품에 다음과 같은 파라미터를 지정할 수 있습니다.
  • 데이터 경로
  • Collaborative Server 컴퓨터 이름 및 포트 번호
  • SQL Server 컴퓨터 이름 및 비밀번호

이러한 부품에 대한 자세한 내용은 SOLIDWORKS Electrical 을(를) 참고하십시오.

상위 주제 옵션 설정 보기 및 편집하기
그룹과 컴퓨터의 옵션 설정 지정
전체 및 그룹 옵션 설정 이어받기
각 컴퓨터의 설정 사용자 정의
SolidNetWork 사용권 설치 개요
옵션 편집기에서 설치 배포하기
SOLIDWORKS Electrical


전체 및 그룹 옵션 설정 이어받기

전체 설정 또는 그룹의 옵션 설정은 그 아래 항목들이 이어받습니다.

예:
  • 전체 설정에 대해 정의된 설정은 모든 그룹과 컴퓨터에 상속됩니다.
  • 그룹에 대해 정의된 설정은 해당 그룹 내의 모든 하위 그룹과 컴퓨터에 상속됩니다.

그룹, 하위 그룹 또는 컴퓨터의 옵션 설정을 변경하여 기본 설정 또는 상속된 설정을 재정의할 수 있습니다. 옵션 설정을 기본값이나 상속된 값에서 변경하면 해당 옵션이 강조 표시됩니다.

옵션 설정을 원래 상속된 값으로 되돌리려면 그룹, 하위 그룹 또는 컴퓨터를 오른쪽 클릭하고 다음 중 하나를 클릭합니다.
  • 전체 설정으로 되돌리기(그룹 멤버가 아닌 그룹, 하위 그룹 또는 컴퓨터의 경우)
  • 그룹 설정으로 되돌리기(그룹 멤버인 컴퓨터의 경우)
  • 모든 멤버를 그룹 설정으로 되돌리기(해당 그룹의 모든 멤버에 대해 한 번에)
상위 주제 옵션 설정 보기 및 편집하기
그룹과 컴퓨터의 옵션 설정 지정
관리 이미지 옵션 설정
각 컴퓨터의 설정 사용자 정의


각 컴퓨터의 설정 사용자 정의

컴퓨터 이름을 오른쪽 클릭하여 특정 컴퓨터에 적용한 설정을 수정할 수도 있습니다.

바로가기 메뉴에서 각 컴퓨터에 다음 작업을 수행할 수 있습니다.
  • 이름 바꾸기
  • 컴퓨터 삭제
  • 전체 설정으로 되돌리기
  • 노트 편집
  • 편집 옵션

편집 옵션을 사용하면 클라이언트 설치 옵션 및 관리 옵션과 같은 컴퓨터에 대한 모든 옵션을 수정할 수 있습니다.

상위 주제 옵션 설정 보기 및 편집하기
그룹과 컴퓨터의 옵션 설정 지정
관리 이미지 옵션 설정
전체 및 그룹 옵션 설정 이어받기


옵션 편집기에서 설치 배포하기

수동 또는 강제 방법을 사용하여 옵션 편집기에서 직접 설치를 배포할 수 있습니다.

  • 옵션 편집기의 직접 배포하기 페이지를 사용하여 사용자에게 설치 지침을 전자우편으로 전송합니다. 사용자에게 클라이언트 컴퓨터에 대한 관리자 권한이 있는 경우 이 방법을 사용합니다.
    관리자 옵션 아래에서 다른 사용자로 설치 실행을 선택하여 사용자에게 관리 권한을 할당할 수 있습니다.
  • 대상 컴퓨터에 자동으로 강제 설치하려면 옵션 편집기의 자동 배포 페이지를 사용합니다. 사용자가 자신의 시스템에 소프트웨어를 설치할 관리 권한이 없는 경우에 이 방식을 사용합니다. 이 방법으로 사용자 정의 설치를 수행할 수도 있습니다.

수동 또는 자동으로 배포하려면 관리 이미지 설치 디렉터리를 Windows 공유 디렉터리로 변경하여 네트워크 위치에서도 사용할 수 있습니다(예: \\machine\shared_directory). 또한, 각 컴퓨터의 로컬 디렉터리로 복사하여 이미지를 사용할 수도 있습니다(예: C:\SOLIDWORKS Admin\SOLIDWORKS 2025 SP0).

목차

  • UNC 경로를 사용하여 관리 이미지 배포

    관리 이미지 설치 디렉터리의 네트워크 위치를 지정할 때 네트워크 드라이브 위치를 매핑하는 대신 UNC 경로 (\\machine_name\share_name)를 사용합니다.

  • StartSWInstall.exe를 사용하여 관리 이미지 배포하기

  • 직접 배포하기

    사용자가 시스템에 설치하는 데 필요한 권한을 가진 경우 이 방법을 사용할 수 있습니다.

  • 자동 배포 필수 구성 요소

    자동 배포는 소프트웨어 설치가 원활하게 진행될 수 있도록 관리 권한이 없는 사용자에게 효과적입니다.

  • 자동 배포하기

  • 강제 배포를 위한 설정 테스트

    관리 이미지 옵션 편집기의 자동 배포 탭에는 테스트 기능이 있습니다.

상위 주제 관리 이미지 옵션 편집기
그룹과 컴퓨터 추가 및 삭제
옵션 설정 보기 및 편집하기
옵션 편집기 종료
옵션 편집기에 대한 바탕 화면 바로 가기 만들기
관리 이미지를 전자우편을 통해 클라이언트에 배포


UNC 경로를 사용하여 관리 이미지 배포

관리 이미지 설치 디렉터리의 네트워크 위치를 지정할 때 네트워크 드라이브 위치를 매핑하는 대신 UNC 경로 (\\machine_name\share_name)를 사용합니다.

매핑된 네트워크 드라이브는 푸시 및 자동 설치 방법과 호환되지 않으며 풀 및 수동 방법의 다른 사용자로 실행과도 호환되지 않습니다.

상위 주제 옵션 편집기에서 설치 배포하기


StartSWInstall.exe를 사용하여 관리 이미지 배포하기

클라이언트에서 admin_image_install_dir\ StartSWInstall.exe 명령을 실행하여 관리 이미지를 설치하거나 설치 제거할 수 있습니다. 이 방법은 관리 이미지 옵션 편집기에 정의된 옵션, 컴퓨터 및 그룹을 사용하여 SOLIDWORKS를 설치합니다.

StartSWInstall.exe 명령에 다음 스위치를 추가할 수 있습니다.
스위치 | 설명
/install | 클라이언트 컴퓨터에 관리 이미지를 설치합니다.
/uninstall 다음 두 가지 옵션 스위치를 사용하여 클라이언트 컴퓨터에서 소프트웨어를 제거합니다.

/removedata

제거에만 사용할 수 있습니다. 제거 중에 SOLIDWORKS 데이터 파일 및 폴더를 제거합니다.

/removeregistry

제거에만 사용할 수 있습니다. 제거 중에 SOLIDWORKS 레지스트리 항목을 제거합니다.
/showui | SOLIDWORKS 설치 관리자의 진행 창을 표시합니다. 이 옵션을 사용하지 않으면 SOLIDWORKS 설치 관리자가 사용자에게 표시되지 않습니다.
/now | 설치 또는 제거를 즉시 시작합니다. 5분 경고 대화 상자가 나타나지 않습니다.

사용자 조작 없이 설치를 진행하고 싶으나 관리 이미지 옵션 편집기에서 자동 배포되는 것은 원치 않는 경우 StartSWInstall.hta보다 StartSWInstall.exe을(를) 사용하는 것이 좋습니다.

상위 주제 옵션 편집기에서 설치 배포하기


직접 배포하기

사용자가 시스템에 설치하는 데 필요한 권한을 가진 경우 이 방법을 사용할 수 있습니다.

전자우편을 사용하여 직접 설치를 배포하는 방법

  1. 옵션 편집기에서 배포를 클릭합니다.
    각 컴퓨터에 적절한 설치 및 상태가 나타납니다.
  2. 전자우편 보내기을(를) 클릭합니다.
  3. 관리 이미지 설치 디렉터리에 대한 네트워크 경로를 지정합니다.
    일반적으로 관리 이미지 설치 디렉터리의 경로는 처음에 Windows 파일 경로로 표시됩니다(예: C:\SOLIDWORKS Admin\SOLIDWORKS 2025 SP0). 대화 상자에 이 경로는 네트워크 경로가 아닙니다라고 나타납니다.
    1. 찾아보기를 클릭하여 해당 관리 이미지 설치 디렉터리에 대한 네트워크 위치를 지정합니다.
    2. 관리 이미지가 설치된 컴퓨터를 탐색하여 관리 이미지 설치 디렉터리로 지정된 Windows 공유 디렉터리를 선택합니다.
      관리 이미지 공유 디렉터리 내에서 찾지 않도록 합니다(예: 64bit 하위 디렉터리).
    3. 확인을(를) 클릭합니다.
      대화 상자에 이 경로는 네트워크 경로입니다라고 나타납니다.
    컴퓨터 사용자에게 관리 이미지의 StartSWInstall.hta 파일이 있는 네트워크 위치를 사용하여 관리 이미지로 설치하는 방법을 안내하는 전자우편이 작성됩니다.
  4. SOLIDWORKS 설치를 담당하는 사용자에게 이메일은 보냅니다.

사용자는 이메일에서 StartSWInstall.hta의 네트워크 위치 링크를 더블 클릭하여 관리 이미지로부터 SOLIDWORKS를 설치할 수 있습니다.

옵션 편집기에서 설치 상태이(가) 표시됩니다.
보류 | 사용자가 해당 컴퓨터에서 아직 설치를 실행하지 않았습니다.
성공 | 사용자가 해당 컴퓨터에서 설치를 성공적으로 완료했습니다.
실패함 | 사용자가 해당 컴퓨터에서 설치를 실행했지만 실패했습니다.
표시될 수 있는 기타 상태 메시지: 설치 완료, 설치 제거 완료, 설치 중, 설치 제거 중, 다시 부팅 필요, 설치 실패, 설치 제거 실패
상태 열의 맨 위에 있는 녹색 화살표를 클릭하여 새로 고치고 업데이트된 정보를 표시합니다.
상위 주제 옵션 편집기에서 설치 배포하기


자동 배포 필수 구성 요소

자동 배포는 소프트웨어 설치가 원활하게 진행될 수 있도록 관리 권한이 없는 사용자에게 효과적입니다.

자동 배포를 사용하려면 클라이언트와 서버가 모두 동일한 Active Directory 도메인에 속해야 합니다. 이 설정을 사용하면 설치 작업을 대상 컴퓨터로 푸시할 수 있으며, 이 경우 사용자 조치가 없어도 Microsoft 작업 스케줄러가 설치 작업을 수행할 수 있습니다.

강제 설치를 사용하는 경우 작업 스케줄러가 관리자가 옵션 편집기에서 지정한 자격 증명을 사용하여 클라이언트 컴퓨터에서 SOLIDWORKS 설치 관리자를 시작하는 작업을 실행합니다. 작업 스케줄러는 컴퓨터의 LocalSystem 계정으로 실행됩니다. 이 계정은 컴퓨터 보안 계정으로 네트워크에 표시됩니다. 컴퓨터 보안 계정에는 다음과 같은 액세스 권한이 있어야 합니다.
  • 관리 이미지 폴더에 대한 읽기 권한.
  • Admin Images folder\x64\logs 폴더에 대한 읽기 및 쓰기 권한.

Active Directory에서 공유 폴더 그룹에 컴퓨터를 추가하는 경우 개체 유형 및 컴퓨터를 선택합니다.

또한 관리 이미지를 제공하는 컴퓨터 및 대상 클라이언트 컴퓨터가 동일한 Microsoft Active Directory 도메인의 멤버여야 합니다.

상위 주제 옵션 편집기에서 설치 배포하기


자동 배포하기

사용자 시스템에 설치를 푸시하여 자동으로 배포하는 방법

  1. 옵션 편집기에서 자동 배포하기 탭을 클릭합니다.
    각 컴퓨터에 적절한 설치 및 상태가 나타납니다.
  2. 배포 열 아래에서 대상 클라이언트 컴퓨터를 선택하고 배포 열에서 그룹을 선택합니다.
    배포 프로세스를 시작하기 전에 배포 열 아래에서 하나 이상의 컴퓨터 또는 그룹을 선택합니다.
  3. Install Time(설치 시간) 아래에서 Now(지금)를 클릭하여 즉시 배포하거나 Later(나중에)를 클릭하여 배포를 수행할 특정 날짜와 시간을 예약합니다.
  4. 클라이언트 옵션 아래에서 다음을 선택합니다.
    • SOLIDWORKS 2025 설치 또는 업그레이드
    • SOLIDWORKS 2025 제거
      설치 제거를 선택하는 경우, 프로그램 파일 및 폴더와 함께 레지스트리 항목과 데이터 파일 및 폴더도 삭제할지 여부를 지정할 수 있습니다.
  5. 배포 중 또는 배포 후 필요한 경우 하나 이상의 대상 컴퓨터를 재부팅하려면 자동으로 컴퓨터 재부팅을 선택합니다.
  6. 하나 이상의 대상 컴퓨터에 대한 클라이언트 자격 증명을 입력합니다.
  7. 배포를 클릭하여 배포 프로세스를 시작합니다.
옵션 편집기에 다음과 같은 설치 상태가 표시됩니다.
보류 | 이 컴퓨터에 아직 설치를 실행하지 않았습니다.
성공 | 이 컴퓨터에 설치가 완료되었습니다.
실패함 | 이 컴퓨터에 설치하는 데 실패했습니다.

표시될 수 있는 기타 상태 메시지: 설치 완료, 설치 제거 완료, 예약 중, 연결 중, 설치 중, 설치 제거 중, 다시 부팅 필요, 예약된 항목 설치, 예약된 항목 설치 제거, 설치 실패, 설치 제거 실패, 연결 실패 및 예약 실패

상위 주제 옵션 편집기에서 설치 배포하기


강제 배포를 위한 설정 테스트

관리 이미지 옵션 편집기의 자동 배포 탭에는 테스트 기능이 있습니다.

다음과 같이 배포에 사용되는 시스템을 검사하는 모의 설치를 실행할 수 있습니다.
  • 대상 컴퓨터에 연결합니다.
  • 해당 컴퓨터에서 설치 작업을 생성합니다.
  • 해당 컴퓨터에서 설치 작업을 완료합니다.
  • 관리 이미지에서 상태 및 로그를 업데이트합니다.
  • 설치 전후 실행할 프로그램을 감지합니다.

이 테스트에서는 파일 경로를 확인하고, 권한을 검증하고, 설치가 성공적으로 종료되었음을 보고합니다. 소프트웨어를 설치하거나 대상 시스템에서 레지스트리를 수정하지는 않습니다. 대상 컴퓨터에서 시스템에 오류가 발생하면 테스트에서 오류가 발생한 시스템이 명시됩니다.

도구 설명에서는 오류에 대한 자세한 내용을 제공합니다. 결과는 .xml 스프레드시트 또는 .csv로 내보낼 수 있습니다. 그러면 여러 오류를 검토하거나 다른 지원 담당자와 결과를 공유하는 데 유용합니다.

강제 배포를 위한 설정을 테스트하는 방법

  1. 설치 관리자를 사용하여 관리 이미지를 생성합니다.
  2. 관리 이미지 옵션 편집기를 시작합니다.

    설치 관리자가 관리 이미지 생성을 완료한 후 옵션을 시작하거나 관리 이미지 폴더에서 sldAdminOptionEditor.exe를 더블 클릭할 수 있습니다.

  3. 설정 탭에서 하나 이상의 컴퓨터를 추가합니다.
  4. 자동 배포를 클릭합니다.
    1. 도메인 관리자의 사용자 이름 및 암호를 제공합니다.
    2. 테스트하려는 하나 이상의 컴퓨터를 선택합니다.
    3. 테스트를 클릭합니다.
  5. 설정 테스트가 나타나면 테스트 실행을 클릭합니다.
  6. 테스트가 완료될 때까지 몇 분 정도 기다리거나 언제라도 테스트 취소를 클릭합니다.
  7. 설정 문제를 검토하고 수정합니다.
상위 주제 옵션 편집기에서 설치 배포하기


옵션 편집기 종료

확인 또는 닫기를 클릭하여 변경 사항을 적용하고 옵션 편집기를 종료할 수 있습니다.

  • 옵션 설정 변경 사항을 적용하고 옵션 편집기를 종료하려면 확인을 클릭합니다.
  • 옵션 편집기를 종료하려면 Windows 애플리케이션 닫기 버튼을 클릭합니다. 저장되지 않은 변경 사항이 있는 것으로 감지되면 저장하라는 메시지가 표시됩니다.
상위 주제 관리 이미지 옵션 편집기
그룹과 컴퓨터 추가 및 삭제
옵션 설정 보기 및 편집하기
옵션 편집기에서 설치 배포하기
옵션 편집기에 대한 바탕 화면 바로 가기 만들기
관리 이미지를 전자우편을 통해 클라이언트에 배포


옵션 편집기에 대한 바탕 화면 바로 가기 만들기

응용 프로그램 내의 특정 관리 이미지에 대한 옵션 편집기의 Windows 바탕 화면 바로 가기를 만들 수 있습니다.

  1. 옵션 편집기를 시작합니다
    예를 들어, 파일 탐색기에서 관리 이미지 설치 디렉터리로 이동하여 sldAdminOptionEditor.exe를 더블 클릭합니다.
  2. 이 옵션 편집기에 대한 바탕 화면 바로 가기 만들기를 클릭합니다.
    관리 이미지에 대한 해당 옵션 편집기의 바로 가기가 Windows 바탕 화면에 나타납니다.
상위 주제 관리 이미지 옵션 편집기
그룹과 컴퓨터 추가 및 삭제
옵션 설정 보기 및 편집하기
옵션 편집기에서 설치 배포하기
옵션 편집기 종료
관리 이미지를 전자우편을 통해 클라이언트에 배포


관리 이미지를 전자우편을 통해 클라이언트에 배포

공유 관리 이미지 디렉터리를 작성한 후에는 전자우편으로 클라이언트에 통지할 수 있습니다.

관리 이미지 디렉터리를 다른 컴퓨터에서 액세스할 수 있는 컴퓨터에서 공유되도록 구성합니다(예: UNC 경로 사용).

관리_이미지_설치_디렉터리\StartSWInstall.hta에 대한 링크가 포함된 전자우편을 모든 클라이언트에 보낼 수 있습니다. 클라이언트는 이 링크를 클릭한 후 SOLIDWORKS 제품 지금 설치를 클릭하여 관리 이미지에서 설치를 시작할 수 있습니다.

새 SOLIDWORKS 버전으로 관리 이미지를 업그레이드하는 경우 이전에 해당 이미지로 설치한 클라이언트가 자동으로 업그레이드하도록 관리 이미지 위치와 공유 속성을 구성할 수 있습니다. 자세한 사항은 관리 이미지에서 클라이언트를 업그레이드하기를 참조하십시오.
상위 주제 관리 이미지 옵션 편집기
그룹과 컴퓨터 추가 및 삭제
옵션 설정 보기 및 편집하기
옵션 편집기에서 설치 배포하기
옵션 편집기 종료
옵션 편집기에 대한 바탕 화면 바로 가기 만들기


설정 관리자 도구

설정 관리자 도구를 사용하여 SOLIDWORKS 소프트웨어를 배포하거나 업그레이드할 때 적용되는 시스템 옵션을 지정하고 사용자가 이러한 옵션을 변경하는 것을 방지할 수 있습니다. 설정 배포에는 이 도구를 SOLIDWORKS 설정 마법사 대신 사용하지만 설정 복사에는 이 마법사를 계속 사용할 수 있습니다.

관리 이미지 옵션 편집기에서 설정 관리자 도구를 사용하는 데에는 다음 세 단계가 있습니다.
  1. 도구에 액세스하도록 관리자 이미지를 작성합니다.
  2. 설정 관리자 도구를 사용하여 선택한 SOLIDWORKS 옵션이 들어 있는 *.sldsettings 파일을 생성합니다.
  3. SOLIDWORKS 설치에 *.sldsettings 파일을 포함합니다.
3DEXPERIENCE 애드인을 사용하는 경우 관리 이미지 외부에 *.sldsettings 파일을 배포할 수도 있습니다. 이 방법을 사용하면 로그인 시 설정이 자동으로 배포된다는 장점이 있습니다.
  1. 설정 관리자 도구에 액세스하려면 설정 관리자 도구 액세스에 나와 있는 단계를 따르십시오.
  2. 지침에 따라 설정을 적용하고 잠급니다.
  3. 3DEXPERIENCE Compass에서 부여된 Role을 확장하고 Platform Manager 앱을 클릭합니다. 콘텐츠 > Collaboration Spaces Configuration Center > CAD 협업 > SOLIDWORKS > 설정 > 리소스 > CAD 설정으로 이동합니다.
  4. CAD 설정에서 *.sldsettings 파일을 찾고 업로드하고 다운로드합니다.

목차

  • 설정 관리자 도구 액세스

    설정 관리 도구에 액세스하려면 먼저 관리 이미지를 작성해야 합니다.

  • 설정 관리자 도구 사용

  • 옵션 적용 및 잠금

  • 마침 설정 옵션

  • SOLIDWORKS 설치에 sldsettings 파일 포함

상위 주제 관리 이미지 사용


설정 관리자 도구 액세스

설정 관리 도구에 액세스하려면 먼저 관리 이미지를 작성해야 합니다.

관리 이미지 내에서 설정 관리자 도구를 시작할 수 있습니다.

설정 관리자 도구에 액세스하는 방법

  1. 관리 이미지 폴더에서 sldAdminOptionEditor.exe를 실행합니다.
  2. 관리 이미지 옵션 편집기에서 변경 [image] 을 클릭합니다.
  3. 클라이언트 설치 옵션 섹션에서 다음과 같이 합니다.
    1. SOLIDWORKS 설정 관리자에서 내보낸 설정 파일을 사용합니다를 클릭합니다.
    2. 설정 관리자 시작을 클릭합니다.
      설정 관리자 시작에 액세스하려면 sldAdminOptionEditor.exe를 실행하는 컴퓨터에 SOLIDWORKS <버전>이(가) 설치되어 있어야 합니다.
상위 주제 설정 관리자 도구


설정 관리자 도구 사용

설정 관리자 도구를 사용하는 방법

  1. 시작 탭에서 다음 옵션을 선택합니다.
    • 해당 릴리즈의 SOLIDWORKS에 대해 시작할 기본 옵션 세트
    • 이 컴퓨터에서 SOLIDWORKS 2025 옵션 불러오기.
    • 기존 sldreg 파일 찾아보기.
    • 기존 sldsettings 파일 찾아보기.
    *.sldreg 파일은 SOLIDWORKS 설정 마법사를 통해 생성되고 *.sldsettings 파일은 설정 관리자 도구를 통해 생성됩니다.
  2. 다음을 클릭합니다.
상위 주제 설정 관리자 도구


옵션 적용 및 잠금

시스템 옵션 탭에서 2개 열 확인란을 사용하면 이러한 옵션 중 적용할 옵션과 적용된 옵션을 잠글 옵션을 선택할 수 있기 때문에 사용자는 이를 변경할 수 없습니다.

사용자가 SOLIDWORKS 소프트웨어의 시스템 옵션 대화 상자에 액세스하면 잠금 아이콘( [image])과 함께 사용할 수 없는 잠긴 옵션이 나타납니다. 하지만 사용자가 옵션을 잠금 해제할 수 있는 암호를 작성할 수 있습니다. 사용자가 마우스를 잠긴 옵션 위에 놓으면 도구 정보에 귀하의 이름과 이메일이 표시되기 때문에 사용자는 귀하에게 문의하여 암호를 요청할 수 있습니다.

옵션을 적용하고 잠그는 방법

  1. 시스템 옵션 탭에서 다음을 수행합니다.
    1. 시스템 옵션을 적용하려면 이 옵션을 선택하고 적용 열에서 해당 확인란을 선택합니다.
    2. 시스템 옵션을 잠그려면 이 옵션을 선택하고 적용 및 잠금 열 모두에서 해당 확인란을 선택합니다.
      사용자가 시스템 옵션 탭에 액세스하면 해당 옵션이 잠금 [image] 으로 표시됩니다.
  2. 옵션에 따라 옵션에 대한 추가 파라미터를 지정해야 할 수도 있습니다.
  3. 또한 메시지/오류/경고에 대한 컨트롤을 적용하여 메시지를 해제하지 못하도록 차단할 수 있습니다.
    1. 메시지/오류/경고를 클릭합니다.
    2. 적용을 선택하고 필요에 따라 관리하려는 메시지에 대해 잠금을 선택합니다.
    3. 메시지를 표시 또는 표시 안 함으로 설정합니다.

      표시를 선택하면 사용자의 닫은 메시지 목록에서 해당 메시지가 제거되고 적절한 시간에 사용자에게 표시합니다. 표시 안 함을 선택하면 사용자의 닫은 메시지 목록에 해당 메시지가 자동으로 추가되고 사용자가 모델에서 작업할 때 표시되지 않습니다.

      다음 테이블에서는 소프트웨어의 동작을 설명합니다.
      적용 | 잠금 | 표시 | 표시 안 함 | 동작
      X | X | 메시지를 강제로 표시합니다.
      X | X | 메시지를 닫고 해당 메시지를 닫은 메시지 목록에 추가합니다.
      X | X | X | 메시지를 강제로 표시하고 메시지 상자에서 다시 표시 안 함 옵션을 비활성화합니다.
      X | X | X | 메시지를 닫고 사용자가 도구 > 옵션 > 메시지/오류/경고에서 이를 활성화할 수 없도록 합니다.
  4. 시스템 옵션 탭에서 다음을 클릭합니다.
상위 주제 설정 관리자 도구


마침 설정 옵션

설정 옵션을 마치는 방법:

  1. 마침 탭에서 시스템 옵션을 적용할 시점을 선택합니다.
    • 사용자가 소프트웨어를 처음 시작할 때
    • 소프트웨어가 시작될 때마다
    • 사용자 정의를 동시에 적용할지 여부
  2. 사용자가 네트워크에 연결되지 않은 경우 잠긴 옵션을 적용하고 API가 잠긴 옵션을 재정의할 수 있도록 허용할 것을 선택합니다.
  3. 잠긴 시스템 옵션에는 이름 및 이메일 주소를 제공해야 합니다. SOLIDWORKS 소프트웨어에서 사용자가 잠긴 옵션 위로 마우스를 이동하면 도구 정보에 이 정보가 표시됩니다.
  4. 사용자가 잠긴 옵션을 재정의할 수 있도록 허용할 수도 있습니다. 이 경우 사용자에게 제공할 수 있는 암호를 지정해야 합니다.
  5. 저장을 클릭하여 배포할 *.sldsettings 파일을 생성합니다.
상위 주제 설정 관리자 도구


SOLIDWORKS 설치에 sldsettings 파일 포함

설치에 *.sldsettings 파일을 포함하는 방법:

  1. 관리 이미지 폴더에서 sldAdminOptionEditor.exe를 더블 클릭합니다.
  2. 관리 이미지 옵션 편집기에서 변경을 클릭합니다.
  3. 클라이언트 설치 옵션 섹션에서 다음과 같이 합니다.
    1. SOLIDWORKS 설정 관리자에서 내보낸 설정 파일을 사용합니다를 클릭합니다.
    2. 경로 편집을 클릭하고 *.sldsettings 파일을 찾아봅니다.
    그룹 또는 컴퓨터마다 다른 *.sldsettings 파일을 작성하고 적용할 수 있습니다.
  4. SOLIDWORKS 소프트웨어를 배포하고 설치합니다.

배포 후에는 언제든지 2단계를 반복하여 기존 *.sldsettings를 수정할 수 있습니다. 다음에 SOLIDWORKS 소프트웨어가 시작될 때 수정된 *.sldsettings를 읽습니다.

상위 주제 설정 관리자 도구


명령줄 배포

명령 프롬프트 또는 배치 파일(자동 설치)을 사용하여 관리 이미지를 자동으로 배포할 수 있습니다.

SOLIDWORKS PDM 클라이언트 명령줄을 사용하여 관리 이미지를 배포하려면 SOLIDWORKS PDM 설치 가이드를 참조하십시오.

목차

  • 관리 이미지로부터 명령줄 설치를 하기 위해 클라이언트 준비

    관리 이미지를 작성한 후, 클라이언트에 통보하기 전에 명령줄이나 Microsoft Active Directory를 사용하여 작성한 관리 이미지로 설치할 수 없는 Microsoft Windows 구성 요소를 설치해야 합니다.

  • 명령줄을 사용하여 관리 이미지로부터 설치

    명령줄을 사용하여 관리 이미지로부터 설치를 배포할 수 있습니다.

  • 명령줄 속성

    여기에 설명된 명령줄 속성에는 피처 속성, 글로벌 속성, 제품 특정 속성 및 Windows 위치 규칙 등이 포함됩니다.

  • Microsoft Active Directory를 사용하여 관리 이미지 배포

    클라이언트에 SOLIDWORKS 주요 제품을 배포할 때 Microsoft Active Directory 배포가 지원됩니다.

상위 주제 여러 시트 설치
여러 클라이언트에 배포
관리 이미지 사용
여러 시트 설치 관리


관리 이미지로부터 명령줄 설치를 하기 위해 클라이언트 준비

관리 이미지를 작성한 후, 클라이언트에 통보하기 전에 명령줄이나 Microsoft Active Directory를 사용하여 작성한 관리 이미지로 설치할 수 없는 Microsoft Windows 구성 요소를 설치해야 합니다.

이러한 Windows 구성 요소를 직접 설치하는 과정은 명령줄이나 Microsoft Active Directory를 사용하여 관리 이미지로 설치할 경우에만 필요합니다. SOLIDWORKS 설치 관리자를 사용하여 관리 이미지를 만들고 설치하는 경우 이러한 Windows 구성 요소가 자동으로 설치됩니다.
다음은 Windows 구성 요소에서 SOLIDWORKS에 필요한 파일 요약입니다.
Windows Performance Toolkit | SOLIDWORKS Rx에서 확장된 로깅을 활성화합니다.
Visual C++ 2022 재배포 가능 패키지 | Microsoft Visual C++의 런타임 구성 요소가 포함되어 있습니다. 2022 버전이 설치되어 있어야 합니다.
Visual Basic for Applications 7.1 | Visual Basic 매크로를 지원합니다.
Visual Studio Tools for Application 2022 | 선택. Visual Studio 2022 애플리케이션(VSTA17)을 지원하는 도구 세트가 포함되어 있습니다.
.NET Framework 4.8 | .NET Framework 4.8 애플리케이션 실행에 필요한 공용 언어 런타임과 .NET Framework 구성 요소가 포함되어 있습니다.
SWCEF | CEF(Chromium Embedded Framework)는 3DEXPERIENCE platform 콘텐츠를 표시하는 데 사용됩니다.
Microsoft Edge Web View2 | 웹 콘텐츠를 표시하는 데 필요합니다.
SOLIDWORKS Login Manager | 3DEXPERIENCE Marketplace 및 기타 3DEXPERIENCE 앱에 로그인할 수 있습니다.
Visual C++ 재배포 가능 패키지와 .NET Framework 4.8은 주요 SOLIDWORKS 제품뿐만 아니라 모든 SOLIDWORKS 제품에 필요합니다.

관리 이미지 디렉터리의 하위 폴더에 이들 구성 요소가 포함되어 있어야 합니다.

다음 표에서 지원되는 각 운영 체제에 필요한 특정 파일을 확인할 수 있습니다.
운영 체제: Windows Server 2019 64비트 및 Windows Server 2022 64비트
SOLIDWORKS PDM Server 및 SOLIDWORKS SolidNetWork License Manager는 Windows Server 2019 및 2022에 설치할 수 있습니다.
Windows Performance Toolkit: | WPTx64-x86_en-us.msi
Visual C++ 2022 재배포 가능 패키지: | vc_redist.x86.exe vc_redist.x64.exe 둘 다 설치되어야 합니다.
Visual Basic 7.1: | vba71_1033.msi 언어 팩(선택 사항)이 추가됩니다.
.NET Framework 4.8: | ndp48-x86-x64-allos-enu.exe
SWCEF | CEF for SOLIDWORKS Applications.msi
Microsoft Edge Web View2 | MicrosoftEdgeWebView2RuntimeInstallerX64.exe
운영 체제: Windows 10 및 Windows 11 64비트
Windows Performance Toolkit: | WPTx64-x86_en-us.msi
Visual C++ 2022 재배포 가능 패키지: | vc_redist.x86.exe vc_redist.x64.exe 둘 다 설치되어야 합니다.
Visual Basic 7.1: | vba71_1033.msi 언어 팩(선택 사항)이 추가됩니다.
.NET Framework 4.8: | .NET 4.8는 이 요구 사항을 충족하는 운영 체제의 일부로 포함되어 있습니다.
SWCEF | CEF for SOLIDWORKS Applications.msi
Microsoft Edge Web View2 | MicrosoftEdgeWebView2RuntimeInstallerX64.exe

목차

  • 64-bit 운영 체제의 명령줄에서 Windows 구성 요소 설치

    이 프로세스에 따라 64비트 버전 Windows에서 명령줄을 사용하여 관리 이미지 설치에 필요한 Windows 구성 요소를 설치할 수 있습니다.

상위 주제 명령줄 배포
명령줄을 사용하여 관리 이미지로부터 설치
명령줄 속성
Microsoft Active Directory를 사용하여 관리 이미지 배포


64-bit 운영 체제의 명령줄에서 Windows 구성 요소 설치

이 프로세스에 따라 64비트 버전 Windows에서 명령줄을 사용하여 관리 이미지 설치에 필요한 Windows 구성 요소를 설치할 수 있습니다.

한 번의 설치 작업으로 여러 구성 요소를 설치하려면 다음 절차의 명령으로 배치 파일을 작성해서 클라이언트 컴퓨터에 구성 요소를 설치합니다.

  1. 대상 컴퓨터에 적어도 620MB의 사용가능한 디스크 공간과 Temp 디렉터리가 있어야 합니다.
  2. Visual C++ RELEASE 재배포 가능 패키지를 설치합니다. 각 패키지의 32비트와 64비트 버전을 설치해야 합니다.
    RELEASE = 2022용 패키지를 설치합니다.

    administrative_image_directory\Microsoft_C++_RELEASE_Redistributable_(x64)\vc_redist.x64.exe /Q

    administrative_image_directory\Microsoft_C++_RELEASE_Redistributable\vc_redist.x86.exe /Q

  3. Microsoft .NET Framework 4.8를 설치합니다.
    관리_이미지_디렉터리\.Net_Framework_4.8\ndp48-x86-x64-allos-enu.exe
  4. Visual Studio Tools for Applications 2022를 설치합니다.
    administrative_image_directory\Microsoft_VSTA17\vsta_setup.exe
  5. Visual Basic 7.1을 설치합니다.
    관리_이미지_디렉터리\Microsoft_VBA\vba71.msi 및 관리_이미지_디렉터리\Microsoft_VBA\vba71_1033.msi는 모든 언어에 필요한 패키지입니다.
    이 패키지의 64비트 버전만 설치해야 합니다.

    추가적으로 원하는 언어가 있으면 다음 중에서 패키지를 선택하여 설치해야 합니다.

    vba71_1028.msi | 중국어
    vba71_1031.msi | 독일어
    vba71_1036.msi | 프랑스어
    vba71_1040.msi | 이탈리아어
    vba71_1041.msi | 일본어
    vba71_1042.msi | 한국어
    vba71_1046.msi | 포르투갈어(브라질)
    vba71_2052.msi | 중국어-간체
    vba71_3082.msi | 스페인어
    영어, 체코어, 폴란드어, 러시아어, 터키어는 언어 패키지를 추가로 설치할 필요가 없습니다.
    추가 필수 구성 요소 설치: Msiexec.exe /p vba71-kb27832-x64.msp.
  6. SWCEF(SOLIDWORKS Chromium Embedded Framework) 설치:
    administrative_image_directory\swcef\CEF for SOLIDWORKS Applications.msi.
  7. SOLIDWORKS Login Manager 설치:
    administrative_image_directory\swloginmgr\SOLIDWORKS Login Manager.msi.
상위 주제 관리 이미지로부터 명령줄 설치를 하기 위해 클라이언트 준비


명령줄을 사용하여 관리 이미지로부터 설치

명령줄을 사용하여 관리 이미지로부터 설치를 배포할 수 있습니다.

자동으로 설치하기:

  1. 명령 프롬프트 창을 엽니다(Windows에서 시작 > 실행 클릭).
  2. msiexec.exe 명령을 /i 및 /qb 스위치와 함께 입력하고 아래에 표시된 대로 기본값이 아닌 옵션의 속성을 지정합니다.

    msiexec /i "administrative_image_directory\64bit\SWFileUtilities\SOLIDWORKS File Utilities.msi" INSTALLDIR="C:\Program Files\your_folder /qb

개별 설치 구성 요소 명령줄 속성:
  • 명령줄 피처 속성
  • 명령줄 글로벌 속성
  • eDrawings 명령줄 속성
  • SOLIDWORKS Flow Simulation 명령줄 속성

자동 설치의 템플릿으로 다음 예를 사용합니다.

SOLIDWORKS Client

  • SOLIDWORKS 주요 제품(영어)
  • Toolbox 애드인
  • 피드백 프로그램에 참여
  • 프랑스어

SOLIDWORKS:

msiexec /i "administrative_image_directory\64bit\SOLIDWORKS\SOLIDWORKS.Msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=4 ADDLOCAL=SolidWorks, SolidWorksToolbox TOOLBOXFOLDER="toolbox path for example C:\SolidWorks Data\" /qb

SOLIDWORKS 프랑스어 설치 구성 요소는 별도로 설치해야 합니다.

msiexec /i "administrative_image_directory\64bit\SOLIDWORKS French\french.msi" /qb

SOLIDWORKS 언어 구성 요소 설치 명령을 지정할 때 명령줄 인수를 지정하지 마십시오.

eDrawings 클라이언트

  • 모든 피처

msiexec /i
            "administrative_image_directory\64bit\eDrawings\eDrawings.msi"
          INSTALLDIR="C:\Program Files\your_folder"
            SNLSERVER=eDrawings_SNL_server TRANSFORMS=1040.mst
          ADDLOCAL=All /qb

SOLIDWORKS Electrical

Microsoft SQL Server에서 SOLIDWORKS Electrical을 사용할 경우 기술적으로 복잡하기 때문에 SOLIDWORKS Electrical에 대한 명령줄 예제는 문서에서 제외되었습니다.

SOLIDWORKS Visualize 및 Visualize Boost

SOLIDWORKS Visualize:

msiexec. /i “administrative_image_directory\64bit\SOLIDWORKS Visualize.msi” ACTIVSERIALNUMBER=”1234123412341234ABCDEFGH” INSTALLDIR=”C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS Visualize” /qb

SOLIDWORKS Visualize Boost:

msiexec /i “administrative_image_directory\64bit\SOLIDWORKS Visualize Boost.msi” ACTVISERIALNUMBER=”1234123412341234ABCDEFGH” INSTALLDIR=”C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS Visualize Boost” /qb

상위 주제 명령줄 배포
관리 이미지로부터 명령줄 설치를 하기 위해 클라이언트 준비
명령줄 속성
Microsoft Active Directory를 사용하여 관리 이미지 배포


명령줄 속성

여기에 설명된 명령줄 속성에는 피처 속성, 글로벌 속성, 제품 특정 속성 및 Windows 위치 규칙 등이 포함됩니다.

목차

  • 명령줄 피처 속성

    SOLIDWORKS 설치는 명령줄 배포에 대한 다음 ADDLOCAL 속성을 지원합니다.

  • 명령줄 글로벌 속성

    각 속성은 개별 설치나 관리자 설치로 지정되었습니다(특별히 표시되어 있지 않는한). 글로벌 속성을 사용하여 제품 번호를 관리자 설치와 개별 설치에 모두 전달할 수 있습니다.

  • eDrawings 명령줄 속성

    다음 명령줄 속성은 eDrawings ®에 특정한 속성입니다.

  • SOLIDWORKS Composer/Composer Player 명령줄 속성

    다음 명령줄 속성은 SOLIDWORKS Composer와 SOLIDWORKS Composer Player에 특정한 속성입니다.

  • SOLIDWORKS Flow Simulation 명령줄 속성

    다음 명령줄 속성은 SOLIDWORKS Flow Simulation에 특정한 속성입니다.

  • SOLIDWORKS Inspection 명령줄 속성

    다음 명령줄 속성은 SOLIDWORKS Inspection에 특정한 속성입니다.

  • SOLIDWORKS Visualize 명령줄 속성

    다음 명령줄 속성은 SOLIDWORKS Visualize에 특정한 속성입니다.

  • 관리 이미지의 MSI 파일 위치

    명령줄에서 관리 이미지를 작성할 경우 제품 구성 요소 .msi 파일이 SOLIDWORKS 매체의 다음 위치에 저장되어 있습니다.

상위 주제 명령줄 배포
관리 이미지로부터 명령줄 설치를 하기 위해 클라이언트 준비
명령줄을 사용하여 관리 이미지로부터 설치
Microsoft Active Directory를 사용하여 관리 이미지 배포


명령줄 피처 속성

SOLIDWORKS 설치는 명령줄 배포에 대한 다음 ADDLOCAL 속성을 지원합니다.

  • CircuitWorks
  • CoreSolidWorksTaskScheduler
  • ExampleFiles
  • FeatureWorks
  • HelpFiles
  • Manuals
  • Motion
  • ScanTo3D
  • Simulation
  • SolidWorksCosting
  • SolidWorksDesignChecker
  • SolidWorksRoutedsystems
  • SolidWorksToolbox
  • SolidWorksUtilities
  • TolAnalyst
명령줄 설치의 속성을 지정할 때:
  • SOLIDWORKS는 ADDSOURCE 옵션을 사용하는 제품 설치를 지원하지 않습니다.
  • 속성은 대/소문자를 구분하며, 공백과 대시(-)를 포함할 수 없으며 쉼표로 구분되어야 합니다.
상위 주제 명령줄 속성
명령줄 글로벌 속성
eDrawings 명령줄 속성
SOLIDWORKS Composer/Composer Player 명령줄 속성
SOLIDWORKS Flow Simulation 명령줄 속성
SOLIDWORKS Inspection 명령줄 속성
SOLIDWORKS Visualize 명령줄 속성
관리 이미지의 MSI 파일 위치


명령줄 글로벌 속성

각 속성은 개별 설치나 관리자 설치로 지정되었습니다(특별히 표시되어 있지 않는한). 글로벌 속성을 사용하여 제품 번호를 관리자 설치와 개별 설치에 모두 전달할 수 있습니다.

Property | 설명
ENABLEPERFORMANCE SOLIDWORKS에 작업 수행 정보를 자동으로 보내는 옵션 선택 여부를 지정합니다.

1

작업 성능 데이터 전송

0

작업 성능 데이터를 전송하지 마십시오.
INSTALLDIR | SOLIDWORKS의 설치 폴더
MBDSERIALNUMBER | SOLIDWORKS Simulation 제품의 제품 번호.
MOTIONSERIALNUMBER | SOLIDWORKS Motion 제품의 제품 번호.
OFFICEOPTION 설치할 제품 패키지를 지정합니다.
0 | SOLIDWORKS Standard
1 | SOLIDWORKS Office
2 | SOLIDWORKS Professional
3 | SOLIDWORKS Premium
4 | SOLIDWORKS Ultimate
REINSTALL 현재 설치된 기능을 모두 업데이트하려면 ALL을 지정합니다.
기존 주요 릴리즈 내에서 Service Pack 릴리즈로 업데이트할 때만 이 속성을 지정합니다. 예를 들어, 기존 SOLIDWORKS 2025 SP01 설치를 SOLIDWORKS 2025 SP02로 업데이트할 경우 지정하면 됩니다.
REINSTALLMODE Microsoft Installer 재설치 옵션.

예를 들어, 같은 주요 릴리즈 내에서 한 Service Pack 릴리즈를 다른 Service Pack 릴리즈로 업그레이드할 때 REINSTALLMODE=vomus를 지정해야 합니다.

REINSTALLMODE 설정에 대한 자세한 내용은 www.microsoft.com에서 Windows Installer 문서를 참고하십시오.

기존 주요 릴리즈 내에서 Service Pack 릴리즈로 업데이트할 때만 이 속성을 지정합니다. 예를 들어, 기존 SOLIDWORKS 2025 SP01 설치를 SOLIDWORKS 2025 SP02로 업데이트할 경우 지정하면 됩니다. SOLIDWORKS의 새 최신 주요 릴리즈를 처음으로 설치할 때는 이 속성을 지정하지 마십시오.
SERVERLIST SolidNetWork 서버 목록.
SolidNetWork 서버 목록은 구분되는 스트링 목록으로, 각 스트링은 서버 포트 번호를 다음 형식으로 참조합니다.
  • 트라이어드(쉼표로 구분) =xxxxx@server_name1,yyyyy@server_name2,zzzzz@server_name3
  • 비-트라이어드(세미콜론으로 구분) = xxxxx@server_name1;yyyyy@server_name2;zzzzz@server_name3
X와 Y는 한 자리 수입니다. 목록에 있는 마지막 서버 뒤에는 구분 기호를 붙이지 않습니다.
SIMULATIONSERIALNUMBER | SOLIDWORKS Simulation 제품의 제품 번호.
SOLIDWORKSSERIALNUMBER | 모든 애드인을 포함하는 SOLIDWORKS 제품의 제품 번호.
SWMIGRATE SOLIDWORKS 설치 선택 대화 상자에 표시된 목록에서 업그레이드할 SOLIDWORKS 버전을 지정합니다. 예:

SWMIGRATE="SOLIDWORKS 2025 x64 Edition SP01"

이전 주요 릴리즈가 현재 설치되어 있는 상태에서 새 주요 릴리즈를 설치할 때만 이 속성을 지정합니다. 같은 주요 릴리즈 내에서 한 Service Pack 릴리즈에서 다른 Service Pack 릴리즈로 업그레이드할 때는 이 속성을 지정하지 마십시오.
TOOLBOXFOLDER SOLIDWORKS Toolbox 파일의 설치 폴더.

예: TOOLBOXFOLDER = "C:\SOLIDWORKS Data"

사용자 환경에 PDM 또는 공유 Toolbox/구멍 가공 마법사 위치가 있는 경우 NOTTOOLBOXSETUP 속성을 사용하여 해당 위치에서 Toolbox 데이터를 설치하거나 업그레이드하지 않도록 클라이언트 설치를 지정할 수 있습니다. 다음을 지정합니다.

0 | Toolbox 파일을 설치합니다.
1 | Toolbox 파일을 설치하지 않습니다.
TRANSFORMS 다음 형식의 언어별 항목이 포함되어 있습니다.
TRANSFORMS 번호.mst
  • Chinese (1028)
  • Chinese-Simplified (2052)
  • Czech (1029)
  • English (1033)
  • French (1036)
  • German (1031)
  • Italian (1040)
  • Japanese (1041)
  • Korean (1042)
  • Polish (1045)
  • Portuguese-Brazilian (1046)
  • Russian (1049)
  • Spanish (1034)
  • Turkish (1055)
UPGRADESWINSTALL
SOLIDWORKS 기존 버전을 현재 버전으로 업그레이드할지를 지정합니다.
0 | 새 설치, 업데이트하지 않습니다.
1 | 업데이트
이전 주요 릴리즈가 현재 설치되어 있는 상태에서 새 주요 릴리즈를 설치할 때만 이 속성을 지정합니다. 같은 주요 릴리즈 내에서 한 서비스 팩 릴리즈에서 다른 서비스 팩 릴리즈로 업그레이드할 때는 이 속성을 지정하지 마십시오.
상위 주제 명령줄 속성
명령줄 피처 속성
eDrawings 명령줄 속성
SOLIDWORKS Composer/Composer Player 명령줄 속성
SOLIDWORKS Flow Simulation 명령줄 속성
SOLIDWORKS Inspection 명령줄 속성
SOLIDWORKS Visualize 명령줄 속성
관리 이미지의 MSI 파일 위치


eDrawings 명령줄 속성

다음 명령줄 속성은 eDrawings ®에 특정한 속성입니다.

속성 | 설명
ADDLOCAL 설치할 eDrawings 응용 프로그램 부분을 지정합니다.
All 권장 옵션입니다.
명령줄 구문 | 기능
All | 모든 구성 요소를 설치합니다. eDrawings 응용 프로그램이 설치된 SOLIDWORKS와 AutoCAD Publisher 응용 프로그램 설치를 확인합니다.
CALS | eDrawings Viewer에서 CAL 파일 보기
Inventor | Autodesk Inventor 응용 프로그램에서 eDrawings 파일을 작성합니다.
eDrawingsViewer | eDrawings 파일과 기타 파일을 봅니다.
ProE | eDrawings Viewer를 사용하여 ProE 파일 보기
DXFDWGTranslator | eDrawings Viewer에서 DXF/DWG 파일을 봅니다.
Shortcuts | 바탕화면 바로가기를 설치합니다.
XML3D | eDrawings Viewer에서 3DXML 파일을 봅니다.
INSTALLDIR | 다음의 설치 폴더를 지정합니다. eDrawings
SNLSERVER SolidNetWork License 서버의 포트@서버이름 를 입력합니다. 여러 개의 포트@서버이름 을(를) 구분할 때는 세미콜론(;)을 사용합니다.

SNLSERVER 및 SERVERLIST의 포트 서버 이름은 SOLIDWORKS SNL 서버 설정에만 필요합니다.

SolidNetWork 서버 목록은 구분되는 스트링 목록으로, 각 스트링은 서버 포트 번호를 다음 형식으로 참조합니다.
  • 트라이어드(쉼표로 구분)

    = xxxx@server_name1,yyyy@server_name2,zzzz@server_name3

  • 비-트라이어드(세미콜론으로 구분)

    = xxxx@server_name1,yyyy@server_name2,zzzz@server_name3

X와 Y는 한 자리 수입니다. 목록에 있는 마지막 서버 뒤에는 세미콜론(;)을 붙이지 않습니다.
상위 주제 명령줄 속성
명령줄 피처 속성
명령줄 글로벌 속성
SOLIDWORKS Composer/Composer Player 명령줄 속성
SOLIDWORKS Flow Simulation 명령줄 속성
SOLIDWORKS Inspection 명령줄 속성
SOLIDWORKS Visualize 명령줄 속성
관리 이미지의 MSI 파일 위치


SOLIDWORKS Composer/Composer Player 명령줄 속성

다음 명령줄 속성은 SOLIDWORKS Composer와 SOLIDWORKS Composer Player에 특정한 속성입니다.

SOLIDWORKS Composer:

속성 | 설명
ACTIVSERIALNUMBER | SOLIDWORKS Composer의 제품 번호입니다.
ACTIVSERIALNUMBERPLAYERPRO | 선택 사항. SOLIDWORKS Composer Player Pro의 제품 번호입니다.
ADDLOCAL 선택. 전체 애플리케이션을 설치할 경우 ADDLOCAL 속성을 지정하지 않아도 됩니다.
사용자 정의 설치의 경우 다음과 같은 필수 항목과 함께 ADDLOCAL을 사용합니다.
  • 사용권
  • CLOSA
  • InterOps
  • LicenseSupportFiles
  • PlugIns
  • SWComposerCommon
  • SWPlayer
Sync3Dvia와 함께 ADDLOCAL을 사용할 수도 있지만, 반드시 사용해야 하는 것은 아닙니다.
INSTALLDIR | SOLIDWORKS Composer 소프트웨어를 설치할 폴더를 지정합니다.

SOLIDWORKS Composer Player:

속성 | 설명
ACTIVSERIALNUMBERPLAYERPRO | 선택 사항. SOLIDWORKS Composer Player Pro의 제품 번호입니다.
INSTALLDIR | SOLIDWORKS Composer Player 소프트웨어를 설치할 폴더를 지정합니다.
SOLIDWORKS가 설치되지 않은 컴퓨터에서는 SOLIDWORKS Translator를 사용하여 SOLIDWORKS 파일을 SOLIDWORKS Composer로 불러와야 합니다. SOLIDWORKS Translator를 배포하려면 SOLIDWORKS 설치 관리자를 사용해야 하며, 명령줄은 사용할 수 없습니다.
상위 주제 명령줄 속성
명령줄 피처 속성
명령줄 글로벌 속성
eDrawings 명령줄 속성
SOLIDWORKS Flow Simulation 명령줄 속성
SOLIDWORKS Inspection 명령줄 속성
SOLIDWORKS Visualize 명령줄 속성
관리 이미지의 MSI 파일 위치


SOLIDWORKS Flow Simulation 명령줄 속성

다음 명령줄 속성은 SOLIDWORKS Flow Simulation에 특정한 속성입니다.

속성 | 설명
ACTIVSERIALNUMBER SOLIDWORKS Flow Simulation 스탠드얼론 제품 번호.

(관리 이미지로 개별 설치와 클라이언트 설치)
CWUPGRADEINSTALL SOLIDWORKS Flow Simulation 응용 프로그램의 기존 버전을 업그레이드합니다.
1 | 업데이트
2 | 새 설치; 새 디렉터리에 설치

(관리 이미지로 개별 설치와 클라이언트 설치)
INSTALLDIR 특정 SOLIDWORKS Flow Simulation 응용 프로그램 소프트웨어에 대한 설치를 지정합니다.

(개별 설치에만)
SERVERLIST | 세미콜론(;)으로 구분되는 스트링 목록이며, 각 스트링은 서버 포트 번호를 다음 형식으로 사용합니다: xxxxx@서버_이름1; yyyyy@서버_이름2;& 여기서 x와 y는 한 자리 수입니다. 목록에 있는 마지막 서버 뒤에는 세미콜론(;)을 붙이지 않습니다.
SOLIDWORKSPATH SOLIDWORKS 소프트웨어가 설치된 폴더를 지정합니다.

(관리 이미지로 개별 설치와 클라이언트 설치)
상위 주제 명령줄 속성
명령줄 피처 속성
명령줄 글로벌 속성
eDrawings 명령줄 속성
SOLIDWORKS Composer/Composer Player 명령줄 속성
SOLIDWORKS Inspection 명령줄 속성
SOLIDWORKS Visualize 명령줄 속성
관리 이미지의 MSI 파일 위치


SOLIDWORKS Inspection 명령줄 속성

다음 명령줄 속성은 SOLIDWORKS Inspection에 특정한 속성입니다.

속성 | Description
ACTIVSERIALNUMBER | SOLIDWORKS Inspection의 제품 번호입니다. (관리 이미지로 개별 설치와 클라이언트 설치)
INSTALLDIR | SOLIDWORKS Inspection 응용 프로그램 소프트웨어 설치를 지정합니다. (개별 설치에만)
SERVERLIST | 세미콜론(;)으로 구분되는 스트링 목록이며, 각 스트링은 서버 포트 번호를 다음 형식으로 사용합니다: xxxxx@서버_이름1; yyyyy@서버_이름2;& 여기서 x와 y는 한 자리 수입니다. 목록에 있는 마지막 서버 뒤에는 세미콜론(;)을 붙이지 않습니다.
상위 주제 명령줄 속성
명령줄 피처 속성
명령줄 글로벌 속성
eDrawings 명령줄 속성
SOLIDWORKS Composer/Composer Player 명령줄 속성
SOLIDWORKS Flow Simulation 명령줄 속성
SOLIDWORKS Visualize 명령줄 속성
관리 이미지의 MSI 파일 위치


SOLIDWORKS Visualize 명령줄 속성

다음 명령줄 속성은 SOLIDWORKS Visualize에 특정한 속성입니다.

속성 | 설명
ACTIVSERIALNUMBER | SOLIDWORKS Visualize 제품 번호입니다. (관리 이미지로 개별 설치와 클라이언트 설치)
INSTALLDIR | SOLIDWORKS Visualize 응용 프로그램 소프트웨어 설치를 지정합니다. (개별 설치에만)
SERVERLIST | 세미콜론(;)으로 구분되는 스트링 목록이며, 각 스트링은 서버 포트 번호를 다음 형식으로 사용합니다: xxxxx@서버_이름1; yyyyy@서버_이름2;& 여기서 x와 y는 한 자리 수입니다. 목록에 있는 마지막 서버 뒤에는 세미콜론(;)을 붙이지 않습니다.
상위 주제 명령줄 속성
명령줄 피처 속성
명령줄 글로벌 속성
eDrawings 명령줄 속성
SOLIDWORKS Composer/Composer Player 명령줄 속성
SOLIDWORKS Flow Simulation 명령줄 속성
SOLIDWORKS Inspection 명령줄 속성
관리 이미지의 MSI 파일 위치


관리 이미지의 MSI 파일 위치

명령줄에서 관리 이미지를 작성할 경우 제품 구성 요소 .msi 파일이 SOLIDWORKS 매체의 다음 위치에 저장되어 있습니다.

SOLIDWORKS(주요 제품, 영어)

swwi\data\SOLIDWORKS.msi

SOLIDWORKS 주요 제품(영어가 아닌 구성 요소)

중국어 번체 | swwi\lang\chinese\chinese.msi
중국어 간체 | swwi\lang\chinese-simplified\chinese-simplified.msi
체코어 | swwi\lang\czech\czech.msi
프랑스어 | swwi\lang\french\french.msi
독일어 | swwi\lang\german\german.msi
이태리어 | swwi\lang\italian\italian.msi
일본어 | swwi\lang\japanese\japanese.msi
한국어 | swwi\lang\korean\korean.msi
폴란드어 | swwi\lang\polish\polish.msi
포르투갈어(브라질) | swwi\lang\portuguese-brazilian\portuguese-brazilian.msi
러시아어 | swwi\lang\russian\russian.msi
스페인어 | swwi\lang\spanish\spanish.msi
Turkish | swwi\lang\turkish\turkish.msi

DocManager API

swdocmgr\SOLIDWORKS Document Manager API.msi

eDrawings

eDrawings\eDrawings.msi

eDrawingsAPI SDK

eDrwAPISDK\eDrawings API SDK.msi

Flow Simulation

Flow Simulation\SOLIDWORKS Flow Simulation.msi

3DExperience Marketplace for SOLIDWORKS

marketplace\3dexperience marketplace.msi

SolidNetWork License Manager

swlicmgr\SOLIDWORKS SolidNetWork License Manager.msi

SOLIDWORKS API SDK

apisdk\SOLIDWORKS API SDK.msi

SOLIDWORKS CAM

cam\SOLIDWORKS CAM.msi

SOLIDWORKS Composer

swComposer\SOLIDWORKS Composer.msi

SOLIDWORKS Composer Player

swComposerPlayerSOLIDWORKS Composer Player.msi

SOLIDWORKS Electrical

swelectric\SOLIDWORKS Electrical.msi

SOLIDWORKS 파일 유틸리티

SWFileUtilities\SOLIDWORKS File Utilities.msi

SOLIDWORKS Inspection

Inspection\SOLIDWORKS Inspection.msi

SOLIDWORKS Manage Client

SWManageClient\SOLIDWORKS Manage Client.msi

SOLIDWORKS PDM

SOLIDWORKS PDM Professional에서는 API를 제공하지만 이는 클라이언트에서만 사용할 수 있으며 .msi 파일에서 사용할 수 없습니다. 자세한 내용은 SOLIDWORKS PDM 클라이언트 install\API 디렉터리의 API 설명서를 참조하십시오.

SOLIDWORKS Plastics

plastics\SOLIDWORKS Plastics.msi

SOLIDWORKS Visualize

visualize\SOLIDWORKS Visualize.msi

SOLIDWORKS Visualize Boost

visualizeboost\SOLIDWORKS Visualize Boost.msi
상위 주제 명령줄 속성
명령줄 피처 속성
명령줄 글로벌 속성
eDrawings 명령줄 속성
SOLIDWORKS Composer/Composer Player 명령줄 속성
SOLIDWORKS Flow Simulation 명령줄 속성
SOLIDWORKS Inspection 명령줄 속성
SOLIDWORKS Visualize 명령줄 속성


Microsoft Active Directory를 사용하여 관리 이미지 배포

클라이언트에 SOLIDWORKS 주요 제품을 배포할 때 Microsoft Active Directory 배포가 지원됩니다.

Microsoft Active Directory란 네트워크 환경에서 클라이언트와 서버 관리에 사용되는 디렉터리 서비스 입니다. 관리, 이동, 배포 과정을 단순화합니다.

Microsoft Active Directory를 통해 SOLIDWORKS를 설치하는 것에 대한 자세한 내용은 리셀러에게 문의하십시오.

상위 주제 명령줄 배포
관리 이미지로부터 명령줄 설치를 하기 위해 클라이언트 준비
명령줄을 사용하여 관리 이미지로부터 설치
명령줄 속성


여러 시트 설치 관리

여러 시트 설치 시의 관리 작업으로는 관리 이미지를 새 버전으로 업그레이드, 서비스 팩 업데이트 적용, 설치 제거 등이 있습니다.

목차

  • 관리 이미지를 새 버전으로 업그레이드

    관리 이미지로부터 설치할 클라이언트를 업데이트 하려면, 먼저 관리 이미지를 업데이트한 후 클라이언트를 구성하여 이미지의 새 복사본을 참조합니다.

  • 서비스 팩 제품 업데이트 관리

    서비스 팩 제품 업데이트에 시스템 신뢰성, 프로그램 호환성, 보안 등의 업데이트가 포함될 수 있습니다.

  • 설치 제거

    개별 컴퓨터나 클라이언트/서버 환경에서 설치를 제거할 수 있습니다.

상위 주제 여러 시트 설치
여러 클라이언트에 배포
관리 이미지 사용
명령줄 배포


관리 이미지를 새 버전으로 업그레이드

관리 이미지로부터 설치할 클라이언트를 업데이트 하려면, 먼저 관리 이미지를 업데이트한 후 클라이언트를 구성하여 이미지의 새 복사본을 참조합니다.

올바른 파일이 참조되도록 SOLIDWORKS 다운로드 페이지에서 SOLIDWORKS 설치 관리자를 실행합니다.

관리 이미지를 업데이트하여 이미지의 새 복사본이 생성되면 클라이언트가 관리 이미지의 새 복사본을 참조하도록 하여 클라이언트를 업데이트할 수 있습니다.

클라이언트가 공유 디렉터리를 사용하여 이전 버전의 관리 이미지를 참조한 경우 업데이트된 관리 이미지의 위치를 사용하여 해당 공유 디렉터리를 재정의할 수 있습니다.

목차

  • 관리 이미지의 업데이트된 설치 파일 다운로드

    SOLIDWORKS 설치 관리자는 관리 이미지를 업그레이드할 때 업데이트된 설치 파일이 필요하면 이를 감지합니다.

  • 관리 이미지 업그레이드

    관리 이미지를 업그레이드하기 위해 SOLIDWORKS 설치 관리자는 새 이미지 디렉터리를 작성합니다. 그러면 사용자는 새 관리 이미지 디렉터리를 사용하는 클라이언트를 지정하여 해당 제품 버전을 업그레이드합니다.

  • 관리 이미지에서 클라이언트 업그레이드

    SOLIDWORKS 설치 관리자는 관리 이미지로부터 설치한 클라이언트 컴퓨터를 자동으로 업데이트할 수 있습니다.

상위 주제 여러 시트 설치 관리
서비스 팩 제품 업데이트 관리
설치 제거


관리 이미지의 업데이트된 설치 파일 다운로드

SOLIDWORKS 설치 관리자는 관리 이미지를 업그레이드할 때 업데이트된 설치 파일이 필요하면 이를 감지합니다.

  1. SOLIDWORKS 설치 관리자를 시작합니다.
  2. 시작 화면에서 관리 이미지를 선택합니다.
  3. 제품 번호 화면에서 SOLIDWORKS 제품 번호를 입력합니다.
    SOLIDWORKS 설치 관리자가 SOLIDWORKS 웹 사이트에서 사용 허가를 받은 제품과 사용 가능한 서비스팩을 확인합니다.
  4. 최신 버전이 있음이 화면에 나타나면 예, 새로운 버전 다운로드 및 설치를 선택합니다. 버전.
    SOLIDWORKS 설치 관리자가 새 버전을 설치하기 위해 새 세션을 시작합니다.
  5. 다운로드 폴더에 문제가 있으면 다운로드 옵션이 나타나 이 경우, 새 설치 파일의 기본 디렉터리를 그대로 사용하거나 새 디렉터리 이름을 입력합니다.
    디렉터리가 없다는 메시지가 나타나면 예를 클릭하여 만듭니다.
  6. 다운로드 완료 화면에서 닫기를 클릭하여 현재 설치 프로그램을 닫고 새 버전의 설치 프로그램을 시작합니다.
상위 주제 관리 이미지를 새 버전으로 업그레이드
관리 이미지 업그레이드
관리 이미지에서 클라이언트 업그레이드


관리 이미지 업그레이드

관리 이미지를 업그레이드하기 위해 SOLIDWORKS 설치 관리자는 새 이미지 디렉터리를 작성합니다. 그러면 사용자는 새 관리 이미지 디렉터리를 사용하는 클라이언트를 지정하여 해당 제품 버전을 업그레이드합니다.

이 과정은 관리 이미지의 업데이트된 설치 파일을 다운로드한 것을 전제로 합니다. 자세한 내용은 관리 이미지의 업데이트된 설치 파일 다운로드를 참조하십시오.

  1. SOLIDWORKS 설치 관리자를 시작합니다.
  2. 시작 화면에서 관리 이미지를 선택합니다.
    관리 이미지 작성 옵션이 나타납니다.
    옵션 | 설명
    기본 설정을 사용하여 새 이미지를 작성합니다. | 기본 구성 설정을 사용하여 관리 이미지를 작성합니다(즉, 사이트의 기존 관리 이미지에 대해 지정된 설정을 기반으로 하는 것이 아님).
    기존 이미지의 설정과 파일을 사용하여 새 이미지를 작성합니다. | 사이트의 기존 관리 이미지에 지정된 구성 설정을 사용하여 이미지를 작성합니다. 찾아보기를 클릭하여 기존 관리 이미지의 설치 디렉터리를 지정합니다.
  3. 제품 번호 화면에서 제품 번호를 확인합니다.
  4. 요약(이미지 작성 준비완료) 화면에서 관리 이미지 옵션이 올바른지 확인합니다.
    개별 관리 이미지와 설치 옵션에 대한 자세한 내용을 보려면 변경을 클릭하여 옵션 페이지로 이동한 후 도움말을 클릭합니다.
  5. 관리 이미지의 새 버전을 작성하려면 지금 작성을 클릭합니다.

이제 관리 이미지의 새 버전으로 클라이언트를 업그레이드할 준비가 됩니다. 자세한 내용은 관리 이미지에서 클라이언트를 업그레이드하기를 참조하십시오.

상위 주제 관리 이미지를 새 버전으로 업그레이드
관리 이미지의 업데이트된 설치 파일 다운로드
관리 이미지에서 클라이언트 업그레이드


관리 이미지에서 클라이언트 업그레이드

SOLIDWORKS 설치 관리자는 관리 이미지로부터 설치한 클라이언트 컴퓨터를 자동으로 업데이트할 수 있습니다.

일반적으로 관리 이미지가 서버의 폴더에 구성됩니다. 클라이언트의 자동 업그레이드를 지원하려면 관리 이미지가 반드시 공유 폴더에 있어야 합니다.

관리 이미지를 업그레이드한 이후 원본 설치와 업그레이드된 설치가 다른 폴더에 위치합니다. 업그레이드된 설치를 사용하려면 먼저 원본 관리 이미지 폴더에서 공유 옵션을 제거한 다음, 업그레이드한 관리 이미지 폴더에 공유 옵션을 추가해야 합니다.

SOLIDWORKS가 원본 관리 이미지로부터 설치한 클라이언트 컴퓨터에서 시작되면 새 버전을 감지하고 클라이언트를 업그레이드합니다.
또한 SOLIDWORKS에서 업데이트가 트리거되면 관리 이미지로 설치된 다른 제품도 자동으로 업데이트됩니다.
상위 주제 관리 이미지를 새 버전으로 업그레이드
관리 이미지의 업데이트된 설치 파일 다운로드
관리 이미지 업그레이드

원본 관리 이미지 폴더에서 공유 옵션 제거

공유 폴더에서 액세스되는 관리 이미지를 업그레이드할 때 원본 폴더에서 공유 옵션을 제거해야 합니다.

  1. 원본 관리 이미지 파일이 있는 폴더를 찾습니다.
  2. 폴더를 오른쪽 클릭하고 등록 정보를 선택합니다.
  3. 공유 탭에서 이 폴더를 공유하지 않음을 선택한 후 확인을 클릭합니다.

이제 업그레이드된 관리이미지 폴더에 공유 옵션 추가에서 설명한 것처럼 업그레이드된 관리 이미지 폴더에 공유 옵션을 추가합니다.

업그레이드된 관리이미지 폴더에 공유 옵션 추가

업데이트된 관리 이미지 폴더를 작성하고 원본 관리 이미지 폴더를 비활성화하고 나면 공유 옵션을 새 폴더에 추가하여 관리 이미지를 다시 사용할 수 있도록 해야 합니다.

  1. 업그레이드된 관리 이미지 파일이 있는 폴더를 찾습니다.
  2. 폴더를 오른쪽 클릭하고 등록 정보를 선택합니다.
  3. 공유 탭에서 사용자 조직이나 그룹에 적합한 공유 속성을 지정하고 공유 이름을 원본 관리 이미지 폴더에 사용된 이름으로 변경합니다.
원본 관리 이미지 공유 위치에서 설치한 컴퓨터가 SOLIDWORKS를 시작할 때 자동으로 새 버전으로 업그레이드됩니다.


서비스 팩 제품 업데이트 관리

서비스 팩 제품 업데이트에 시스템 신뢰성, 프로그램 호환성, 보안 등의 업데이트가 포함될 수 있습니다.

사용자가 제품 업데이트를 얻는 두 가지 방법
  • SOLIDWORKS 설치 관리자를 사용해 업데이트를 확인 및 다운로드하고 설치합니다.

    SOLIDWORKS 설치 관리자를 직접 시작하거나 정기적인 업데이트 확인을 예약할 수 있습니다.

  • SOLIDWORKS 지원 웹 사이트에서 수동으로 서비스 팩을 다운로드합니다.

    서비스 팩이 기존 소프트웨어에 패치되면서 적용됩니다. 예를 들어, SOLIDWORKS 2025 SP1.0은 SOLIDWORKS 2025 SP0.0의 Service Pack입니다. SOLIDWORKS 2025 설치 관리자를 사용하여 이러한 Service Pack을 설치할 수 있지만 SOLIDWORKS 2024의 SOLIDWORKS 설치 관리자를 사용해서는 설치할 수 없습니다.

    Service Pack의 다운로드 및 설치에 관한 도움말은 업데이트하려는 SOLIDWORKS 버전에 대한 설치 설명서를 참조하십시오.

목차

  • 관리 이미지의 서비스 팩 롤백

    관리 이미지를 이전에 설치된 서비스 팩으로 롤백할 수 있습니다. SOLIDWORKS 소프트웨어를 디스크로 설치할 경우, 서비스 팩을 회복하려면 원본 디스크가 필요합니다. 이전 관리 이미지의 사본을 저장해야만 합니다.

상위 주제 여러 시트 설치 관리
관리 이미지를 새 버전으로 업그레이드
설치 제거


관리 이미지의 서비스 팩 롤백

관리 이미지를 이전에 설치된 서비스 팩으로 롤백할 수 있습니다. SOLIDWORKS 소프트웨어를 디스크로 설치할 경우, 서비스 팩을 회복하려면 원본 디스크가 필요합니다. 이전 관리 이미지의 사본을 저장해야만 합니다.

이미 업그레이드된 관리 이미지는 이전 서비스 팩으로 롤백 할 수 없습니다. SOLIDWORKS 설치 관리자 이외의 방법으로 작성된 관리자 이미지를 이전 버전으로 롤백할 수 없습니다. 이러한 관리 이미지에서 설치된 클라이언트는 제거한 후 이전 버전에서 작성된 관리 이미지를 사용하여 다시 설치해야 합니다.
  1. 현재 관리 이미지가 있는 폴더를 삭제합니다. 폴더를 삭제하기 위해, 명령 프롬프트 창을 열고 다음을 입력합니다:
    rmdir /s/q 현재_관리_이미지_경로
  2. 관리 이미지의 백업 사본을 현재 관리 이미지를 삭제한 폴더 위치로 이동합니다. 폴더를 삭제하기 위해, 명령 프롬프트 창을 열고 다음을 입력합니다:
    move 관리_이미지_백업_경로 현재_관리_이미지_경로
    관리 이미지를 롤백하면, 다음에 SOLIDWORKS 소프트웨어를 실행 할 때 클라이언트 컴퓨터가 자동으로 롤백됩니다.
상위 주제 서비스 팩 제품 업데이트 관리


SOLIDWORKS PDM 및 SOLIDWORKS Manage

SOLIDWORKS PDM은 기존에 SOLIDWORKS Enterprise PDM으로 알려졌던 클라이언트/서버 아키텍처를 기반으로 하는 문서 관리 제품입니다. SOLIDWORKS PDM은 두 가지 유형으로 제공됩니다.
  • SOLIDWORKS PDM Standard
  • SOLIDWORKS PDM Professional

SOLIDWORKS PDM은 Microsoft SQL Server 데이터베이스를 사용하여 파일 볼트를 관리합니다.

이 표에는 각 제품 유형에 사용할 수 있는 데이터베이스 시스템, 서버 구성 요소 및 클라이언트 옵션이 나열됩니다.
 | PDM Standard | PDM Professional
사용 영역 | 중소규모 사무실 네트워크(일반적으로 20명 미만의 동시 사용자) | 대규모 사무실 네트워크, 다수의 동시 사용자
한계 | 1소켓 또는 4코어 중 작은 쪽, 1GB RAM 및 10GB 데이터베이스 크기 | SQL Standard 한계: 4소켓 또는 16코어 중 작은 쪽, 128GB RAM 및 524PB 데이터베이스 크기
데이터베이스 관리 시스템 | Microsoft SQL Server Express 2019 이상 ~ 2022. | Microsoft SQL Server 2019 이상 ~ 2022.
SolidNetWork License Manager가 필요합니까? | 예 | 예
보관 서버와 데이터베이스 서버가 포함됩니까? | 예 | 예
SOLIDWORKS PDM Web2 서버 및 WebAPI 서버가 포함됩니까? | 아니요 | 예
클라이언트 유형 | 고유 | 고유, 브라우저 기반
CAD 편집기용 클라이언트 애드인 | SOLIDWORKS, DraftSight | SOLIDWORKS, DraftSight, Microsoft Office Integration
기여 피처용 클라이언트 애드인 | DraftSight | DraftSight, Microsoft Office Integration
뷰어용 클라이언트 애드인 |  | Microsoft Office 통합

SOLIDWORKS Manage Professional에서는 SOLIDWORKS PDM Professional에 대한 고급 데이터 관리 도구를 제공합니다. 그리고 고급 버전 관리 및 프로젝트, 프로세스, 항목 관리에 대한 기능도 제공합니다. 대화형 대시보드 및 보고서는 프로젝트를 종료할 때까지 항목, 활동 및 진행 상황을 추적하는 데 도움이 됩니다.

SOLIDWORKS Manage Professional의 아키텍처는 SOLIDWORKS PDM Professional과 유사합니다. 이 제품은 Microsoft SQL Server 데이터베이스와 함께 클라이언트-서버 아키텍처를 사용하여 항목과 프로젝트 데이터를 관리합니다. 그리고 씨크 클라이언트 및 웹 브라우저 클라이언트 모두를 지원하는 데이터베이스, 파일 서버 및 웹 서버 기능에 대한 세 가지 서비스를 제공합니다. 이 세 개의 서비스는 동일한 서버 또는 별도의 서버에 호스팅할 수 있습니다. SOLIDWORKS Manage Professional Editor 사용권이 있는 사용자는 SOLIDWORKS Manage 애드인을 사용하여 SOLIDWORKS에서 직접 Manage 데이터에 액세스할 수 있습니다.

SOLIDWORKS Installation Manager를 사용하여 SOLIDWORKS Manage Professional 서버 및 클라이언트를 설치할 수 있습니다.

SOLIDWORKS Manage Professional 설치에 대한 자세한 내용은 SOLIDWORKS PDM/SOLIDWORKS Manage 설치 안내서를 참조하십시오.

목차

  • PDM 서버 부품 나열

  • PDM 클라이언트 간의 차이점 이해하기

    클라이언트 소프트웨어를 설치하기 전에 PDM 환경에 따라 어떤 클라이언트가 필요한지 확인해야 합니다.

  • PDM Server 설치 전에 해야 할 작업

    PDM 서버 구성 요소를 설치하기 전에 다음 요구 사항에 주의하십시오.

  • SOLIDWORKS 설치 관리자로 PDM 서버 설치

    PDM Standard PDM 서버 설치 시 동일한 컴퓨터에 보관 서버, 데이터베이스 서버 및 PDM CAD Editor 클라이언트를 설치할 수 있습니다. 별도로 클라이언트 설치를 실행할 필요가 없습니다.

  • SOLIDWORKS 설치 관리자로 PDM 클라이언트 설치


PDM 서버 부품 나열

이 표에는 SOLIDWORKS PDM 서버의 서버 부품이 요약되어 있습니다.

서버 | 함수 | 설치
PDM Standard용 Microsoft SQL Server Express | SOLIDWORKS PDM 데이터 볼트에서 데이터를 관리합니다. | PDM Standard를 설치하거나 이전에 사용권을 구입하고 설치한 버전을 사용할 수 있습니다.
PDM Professional용 Microsoft SQL Server | SOLIDWORKS PDM 데이터 볼트에서 데이터를 관리합니다. | - 필수 또한 이전에 사용권을 구입하고 설치한 버전을 사용할 수도 있습니다.
SolidNetWork License Manager Client | SOLIDWORKS PDM 사용권을 관리합니다. | 새 볼트를 구성하려면 먼저 설치해야 합니다. SOLIDWORKS 설치 관리자를 사용하는 경우 SOLIDWORKS PDM 서버 구성 요소를 설치할 수 있습니다.
보관 서버 | 클라이언트와 파일 볼트 보관 간에 파일 전송을 관리하고 사용자와 자격 증명을 관리합니다. | - 필수 PDM Standard 또는 Professional을 설치합니다.
데이터베이스 서버 | 업데이트를 위해 PDM 데이터베이스를 폴링, 데이터 불러오기 및 내보내기 규칙을 관리, 메시지 시스템 관리, 복제 및 콜드 스토리지 일정을 예약합니다. | - 필수 PDM Standard 또는 Professional을 설치합니다.
Web2 서버 | 브라우저 기반 클라이언트에서 인터넷을 통해 파일 볼트에 대한 액세스를 제공합니다. | 선택 사항. PDM Professional만 설치합니다.
웹 API 서버 | EXALEAD OnePart 사용자는 웹 API 서버를 사용하여 SOLIDWORKS PDM 데이터를 인덱싱하고 검색할 수 있습니다. | 선택. PDM Professional만 설치합니다.

보관 서버는 설치된 컴퓨터의 시스템 계정에서 서비스로 실행됩니다. 한 보관 서버에서 같은 컴퓨터의 여러 파일 볼트를 호스팅할 수 있습니다.

독립 실행형 설치에서 보관 서버, 데이터베이스 서버, 사용권 서버, 웹 API 서버는 물론 SQL Express 또는 SQL Server 데이터베이스를 모두 같은 컴퓨터에 설치할 수 있습니다.

분산 환경에서는 서버 부품을 다른 컴퓨터에 둘 수 있습니다. SOLIDWORKS PDM Professional은 또한 원격 위치에서의 성능을 높이기 위해 파일 볼트 보관과 SQL Server 데이터베이스의 복제를 지원합니다. 자세한 내용은 SOLIDWORKS PDM Professional 복제 안내서를 참조하십시오.

상위 주제 SOLIDWORKS PDM 및 SOLIDWORKS Manage


PDM 클라이언트 간의 차이점 이해하기

클라이언트 소프트웨어를 설치하기 전에 PDM 환경에 따라 어떤 클라이언트가 필요한지 확인해야 합니다.

이 표에 SOLIDWORKS PDM Standard용 클라이언트가 요약되어 있습니다.
표준 클라이언트 유형 | 설명
CAD 편집기 | SOLIDWORKS, DWG/DXF 형식, Microsoft Word, Microsoft Excel 파일 작업을 지원합니다. Office 플러그 인에서 처리하는 모든 파일 형식은 미리보기를 제외하고 SOLIDWORKS PDM Standard와 같은 방식으로 동작합니다.
제공자 | SOLIDWORKS, DWG/DXF 형식, Microsoft Word, Microsoft Excel 파일 작업을 지원합니다.
뷰어 | 파일 볼트에 대한 읽기 전용 액세스만 허용합니다. 사용자는 워크플로를 통해 파일을 전환할 수는 있지만 파일을 추가하거나 수정(체크아웃, 체크인, 업데이트)할 수는 없습니다.
이 표에 SOLIDWORKS PDM Professional용 클라이언트가 요약되어 있습니다.
Professional 클라이언트 유형 | 설명
CAD 편집기 및 Web | SOLIDWORKS와 같은 CAD 형식을 미리 보거나 관리할 수 있도록 모든 파일 유형을 지원합니다. CAD 애드인은 CAD 응용 프로그램 내에서 사용자가 SOLIDWORKS PDM Professional에 액세스할 수 있도록 허용합니다. 원격 사용자는 Web2 클라이언트를 사용하여 인터넷을 통해 볼트를 검색하고 기본 기능을 수행할 수 있습니다.
Contributor & Web | CAD 파일을 포함한 모든 파일 유형 작업을 지원합니다. 그러나 CAD 애드인의 경우 이 클라이언트 유형에서 지원되지 않습니다. 원격 사용자는 Web2 클라이언트를 사용하여 인터넷을 통해 볼트를 검색하고 기본 기능을 수행할 수 있습니다.
뷰어 | 파일 볼트에 대한 읽기 전용 액세스만 허용합니다. 사용자는 워크플로를 통해 파일을 전환할 수는 있지만 파일을 추가하거나 수정(체크아웃, 체크인, 업데이트)하거나 CAD 애드인을 사용할 수는 없습니다.
상위 주제 SOLIDWORKS PDM 및 SOLIDWORKS Manage


PDM Server 설치 전에 해야 할 작업

PDM 서버 구성 요소를 설치하기 전에 다음 요구 사항에 주의하십시오.

  • 서버와 클라이언트를 설치하려는 컴퓨터에서 모든 관리 권한을 얻습니다.
  • 데이터베이스 서버가 TCP 포트 3030으로 관리 서버에 액세스할 권한과 TCP 포트 1433으로 SQL Server에 액세스할 권한이 있는지 확인합니다.
  • 기존 SQL Server Express 또는 SQL Server 데이터베이스를 사용하려는 경우 SQL Server 데이터베이스 이름 및 데이터베이스에 대한 읽기/쓰기 액세스 권한이 있는 SQL Server 관리자 또는 데이터베이스 소유자의 계정 ID와 암호가 있어야 합니다. TEW 사용자는 사용할 수 없습니다.
  • PDM 클라이언트가 시스템에 이미 설치되어 있는 경우 이를 다시 삭제합니다. PDM 서버와 PDM 클라이언트를 동일한 시스템에 설치하려면 SOLIDWORKS 설치 관리자에서 서버 제품 페이지에 있는 두 제품을 모두 설치할 수 있습니다.
상위 주제 SOLIDWORKS PDM 및 SOLIDWORKS Manage


SOLIDWORKS 설치 관리자로 PDM 서버 설치

PDM Standard PDM 서버 설치 시 동일한 컴퓨터에 보관 서버, 데이터베이스 서버 및 PDM CAD Editor 클라이언트를 설치할 수 있습니다. 별도로 클라이언트 설치를 실행할 필요가 없습니다.

PDM Professional PDM 서버 설치 시 이러한 구성 요소와 Web2 서버 및 웹 API 서버도 포함할 수 있습니다.

PDM Server 및 해당 구성 요소 설치 방법:

  1. SOLIDWORKS 설치 관리자를 시작합니다.
  2. 시작 페이지에서 서버 구성 요소 설치를 선택하고 다음을 클릭합니다.
    • SOLIDWORKS PDM 서버 구성 요소를 설치합니다.
    • SolidNetWork License Manager를 설치합니다..

      이 컴퓨터 또는 다른 컴퓨터에 SolidNetWork License Manager가 설치되어 있으면 이 옵션은 표시되지 않습니다.

  3. SolidNetWork License Manager 옵션 페이지가 표시되면 제품 번호를 입력하고 디렉터리 위치를 지정하고 다음을 클릭합니다.
  4. 시스템 경고의 지침을 따르고 다음을 클릭합니다.
  5. 요약 페이지의 SOLIDWORKS PDM 서버에서 변경을 클릭합니다.
  6. SOLIDWORKS PDM Server 옵션 페이지에서
    1. 서버 제품을 선택하려면 SOLIDWORKS PDM Standard 또는 Professional을 클릭합니다.
    2. 설치 위치의 경우 찾아보기를 클릭하여 파일 경로를 지정하십시오.
    3. 피처 선택에서
      1. 보관 서버, 데이터베이스 서버 및 클라이언트를 클릭하여 동일한 컴퓨터에 해당 구성요소를 설치합니다. 분산 환경에서는 다른 컴퓨터에서 설치 관리자를 실행하여 보관 서버 및 데이터베이스 서버를 설치할 수 있습니다.
        • PDM 클라이언트가 이미 컴퓨터에 설치된 경우 설치를 취소하고 클라이언트를 제거해야 합니다. 그런 후 SOLIDWORKS 설치 관리자를 실행하여 클라이언트와 함께 PDM 서버를 설치할 수 있습니다.
        • SOLIDWORKS PDM 서버 설치에 포함된 SOLIDWORKS PDM 클라이언트 구성 요소에는 제외할 수 없는 항목 탐색기가 포함되어 있습니다.
      2. PDM Professional을 설치하는 경우 Web2 Server 및 웹 API 서버를 클릭할 수도 있습니다.
        웹 API 서버를 설치하는 경우 HTTP 포트 번호에 대해 0과 65535 사이의 값을 지정할 수 있습니다. 기본값은 65453입니다.
    4. SQL Server에서는 PDM 서버(PDM Standard용 SQL Server Express)와 함께 제공되는 데이터베이스 도구의 새 인스턴스를 설치하거나 기존 인스턴스의 데이터베이스 이름, 사용자 이름 및 비밀번호를 지정할 수 있습니다.
      SOLIDWORKS PDM Professional을 사용하려면 SQL Server의 정식 버전을 설치해야 합니다.
    5. 요약으로 돌아가기를 클릭합니다.
  7. 요약 페이지에서 SOLIDWORKS 사용권 계약의 조건에 동의하고 지금 설치를 클릭합니다.

    SOLIDWORKS 설치 관리자에서 설치가 완료되면 보관 서버 설정 도구를 시작합니다. 마법사의 메시지에 따라 보관 서버를 구성합니다.

보관 서버, 데이터베이스 서버, Web2 서버 및 SQL Server 데이터베이스를 설정, 구성하고 문제를 해결하는 방법은 SOLIDWORKS PDM 설치 안내서의 관련 항목을 참조하십시오.

목차

  • SOLIDWORKS PDM 서버 설치 수정하기

상위 주제 SOLIDWORKS PDM 및 SOLIDWORKS Manage


SOLIDWORKS PDM 서버 설치 수정하기

SOLIDWORKS PDM 서버와 해당 구성 요소의 설치를 수정하려면 Windows 제어판에서 프로그램 및 기능을 사용합니다. SOLIDWORKS PDM 서버를 설치할 때 사용되는 SOLIDWORKS 설치 관리자(SLDIM)에서는 설치를 수정할 수 없습니다.

상위 주제 SOLIDWORKS 설치 관리자로 PDM 서버 설치


SOLIDWORKS 설치 관리자로 PDM 클라이언트 설치

SOLIDWORKS PDM 클라이언트의 주요 버전은 SOLIDWORKS PDM 서버의 주요 버전과 동일해야 합니다. SOLIDWORKS PDM 클라이언트를 설치하거나 업그레이드하는 경우 버전이 일치하는지 확인합니다.

PDM 클라이언트 설치하는 방법:

  1. SOLIDWORKS 설치 관리자를 시작합니다.
  2. 시작 페이지에서 이 컴퓨터에 설치를 선택합니다.
  3. 제품 번호 페이지에서 다음을 클릭합니다.
    SOLIDWORKS PDM 클라이언트는 별도의 제품 번호를 요구하지 않습니다.
  4. 시스템 경고의 지침을 따르고 다음을 클릭합니다.
  5. 요약 페이지의 제품 아래에서 변경을 클릭합니다.
  6. 제품 선택 페이지에서 다른 패키지나 제품을 선택합니다를 클릭합니다.
  7. 표시할 패키지를 선택합니다 대화 상자에서 SOLIDWORKS의 버전을 선택합니다. 선택을 마치면 확인을 클릭합니다.
  8. 제품 선택 페이지에서 SOLIDWORKS PDM 클라이언트를 선택합니다. 그런 다음 eDrawings를 선택하여 PDM 미리보기 기능을 활성화합니다. SOLIDWORKS PDM Professional을 사용하는 경우 항목 탐색기를 선택할 수도 있습니다.
  9. 요약 페이지에서 SOLIDWORKS PDM 옵션을 확장하고 변경을 클릭합니다.
  10. SOLIDWORKS PDM 클라이언트 옵션 페이지에서 다음 사항을 선택하고 요약으로 돌아가기를 클릭합니다.
    • PDM 제품 유형
    • PDM 클라이언트 유형
    • 애드인
  11. 요약 페이지에서 SOLIDWORKS 사용권 계약의 조건에 동의하고 지금 설치를 클릭합니다.
또한 관리 이미지 옵션 편집기를 사용하여 PDM 클라이언트의 이미지를 작성하고 배포할 수도 있습니다. 자세한 내용은 관리 이미지 사용의 내용을 참조하십시오.
상위 주제 SOLIDWORKS PDM 및 SOLIDWORKS Manage


SOLIDWORKS Electrical

SOLIDWORKS 설치 관리자를 사용하여 SOLIDWORKS Electrical의 모든 구성 요소를 독립 실행형 또는 클라이언트/서버 모드로 설치할 수 있습니다.

SOLIDWORKS Electrical에는 여러 구성 요소가 사용됩니다. 설치 중에 원하는 설치 유형에 따라 이러한 구성 요소를 선택해야 합니다.
  • SOLIDWORKS Electrical Schematic - 전기 회로도를 작성하고 관리하는 2D 애플리케이션.
  • SOLIDWORKS Electrical 3D - 2D 회로도와 3D 모델을 통합하는 SOLIDWORKS 애드인. SOLIDWORKS Electrical 3D를 사용하면 전기 장치의 레이아웃을 관리하고 와이어, 케이블 및 하니스를 배선할 수 있습니다.
  • 데이터 - 데이터는 소프트웨어에 필요한 모든 데이터를 그룹화합니다. 이 데이터는 그래픽(예: 기호 및 제목 블록을 나타내는 파일) 또는 기술(예: 제조업체 카탈로그 및 기호와 관련된 데이터)입니다. 모든 사용자가 액세스할 수 있도록 데이터를 공유할 수 있습니다.
  • Collaborative Server - 전기 도면을 열고 업데이트하는 작업을 관리하는 유틸리티.
  • SQL Server - SOLIDWORKS Electrical에는 Microsoft SQL Server 데이터베이스가 필요합니다. 설치 중에 새 데이터베이스를 생성하거나 기존 데이터베이스를 사용하도록 선택할 수 있습니다.

설치 유형

모든 SOLIDWORKS Electrical의 부품을 같은 컴퓨터에 설치할 수 있습니다. 독립 실행형 설치입니다. 프로젝트 도면 및 보고서와 같은 모든 프로그램 데이터가 하나의 워크스테이션에 저장됩니다.

SOLIDWORKS Electrical 부품을 클라이언트/서버 응용 프로그램으로 설치할 수도 있습니다. 네트워크 서버에 데이터를 저장하려면 이 설치 유형을 사용합니다. 클라이언트/서버 설치에서는 여러 사용자가 동일한 프로젝트에서 작업할 수 있습니다. 클라이언트 시스템은 서버에 네트워크 액세스가 가능해야 하고 프로젝트, 라이브러리 및 기호 작성을 위한 읽기/쓰기 권한이 있어야 합니다.

정보

설치 유형(독립 실행형 또는 클라이언트/서버)에 관계없이, SOLIDWORKS Electrical을 설치하려면 Windows 세션을 전체 권한 모드로 시작해야 합니다.

한 컴퓨터에 SOLIDWORKS Electrical의 한 버전만 설치할 수 있습니다. SOLIDWORKS를 설치하고 설치할 제품 중 하나로 SOLIDWORKS Electrical을 선택하면 설치 프로그램이 이전 버전의 SOLIDWORKS Electrical을 제거합니다.

SOLIDWORKS 설치 관리자를 시작하면 워크스테이션 또는 서버에 설치된 SOLIDWORKS Electrical의 기존 버전이 자동으로 검색됩니다.

새 버전을 설치하기 전에 항상 기존 SOLIDWORKS Electrical 환경을 백업합니다. SOLIDWORKS Electrical Schematic에서 파일 > 환경 압축을 선택하거나 SOLIDWORKS Electrical 3D에서 SOLIDWORKS Electrical > 도구 > 환경 압축을 선택합니다.

목차

  • SOLIDWORKS Electrical의 설치 요구 사항

  • 독립 실행형 또는 클라이언트/서버 설치

    SOLIDWORKS Electrical은 두 가지 모드에서 설치할 수 있습니다. 독립 실행형 모드에서는 워크스테이션에 소프트웨어를 설치합니다. 클라이언트/서버 모드에서는 사용자가 데이터를 공유합니다.

  • Collaborative Server 설정

  • Microsoft SQL Server 설정

  • 데이터 위치 지정


SOLIDWORKS Electrical의 설치 요구 사항

현재 시스템 요구 사항에 액세스하려면 시스템 요구 사항을 참조하십시오.

상위 주제 SOLIDWORKS Electrical
독립 실행형 또는 클라이언트/서버 설치
Collaborative Server 설정
Microsoft SQL Server 설정
데이터 위치 지정


독립 실행형 또는 클라이언트/서버 설치

SOLIDWORKS Electrical은 두 가지 모드에서 설치할 수 있습니다. 독립 실행형 모드에서는 워크스테이션에 소프트웨어를 설치합니다. 클라이언트/서버 모드에서는 사용자가 데이터를 공유합니다.

SOLIDWORKS Electrical은 항상 SQL Server 인스턴스에 연결해야 합니다.

상위 주제 SOLIDWORKS Electrical
SOLIDWORKS Electrical의 설치 요구 사항
Collaborative Server 설정
Microsoft SQL Server 설정
데이터 위치 지정

Stand-Alone 설치

처음 설치하는 경우 워크스테이션에 모든 구성 요소를 설치해야 합니다.

  • SOLIDWORKS Electrical Schematic
  • SOLIDWORKS Electrical 3D
  • Collaborative Server
  • 애플리케이션 데이터
  1. 요약 탭에서 제품 선택 섹션의 변경을 클릭하고 모든 SOLIDWORKS Electrical 구성 요소를 선택합니다.
  2. 설치 옵션을 수정하려면 요약 탭에서 Electrical 옵션 섹션의 변경을 클릭합니다. SQL Server의 새 인스턴스를 생성하거나 기존 인스턴스를 사용할 수 있습니다. 자세한 내용은 이 설명서의 데이터 및 Microsoft SQL Server에 대한 관련 장을 참조하십시오. 그렇지 않은 경우 기본 옵션을 그대로 둡니다.
  3. 계속하려면 지금 설치를 클릭합니다.
SOLIDWORKS Electrical이 이미 워크스테이션에 설치되어 있으면 SOLIDWORKS 설치 관리자에서 자동으로 검색하여 이를 업데이트하라는 메시지를 표시합니다. Electrical 옵션을 변경하지 않고 모든 구성 요소를 설치합니다.

클라이언트/서버 설치

클라이언트/서버 설치를 통해 여러 사용자 간에 데이터를 공유할 수 있습니다.

서버에서는 다음과 같은 구성 요소를 설치해야 합니다.
  • Collaborative Server
  • 애플리케이션 데이터
  • SQL Server
클라이언트에서는 다음과 같은 구성 요소를 설치해야 합니다.
  • SOLIDWORKS Electrical Schematic
  • SOLIDWORKS Electrical 3D
  1. 서버에서 서버 구성 요소를 설치합니다.
  2. SOLIDWORKS 설치 관리자 시작 탭에서 서버 구성 요소 설치를 클릭합니다.
  3. SOLIDWORKS Electrical 옵션을 선택합니다.
  4. 요약 탭에서 설치 옵션을 수정할 수 있습니다. 자세한 내용은 이 설명서의 데이터 및 Microsoft SQL Server에 대한 관련 장을 참조하십시오. 그렇지 않은 경우 기본 옵션을 그대로 둡니다.
  5. 계속하려면 지금 설치를 클릭합니다.
  6. 클라이언트에서 애플리케이션을 설치합니다.
  7. SOLIDWORKS 설치 관리자 시작 탭에서 이 컴퓨터에 설치를 클릭합니다.
  8. 요약 탭에서 제품 선택 섹션의 변경을 클릭하고 Electrical Server 옵션을 선택 취소합니다.
  9. 요약 탭에서 Electrical 옵션 섹션의 변경을 클릭하고 서버에 연결하도록 설정을 수정합니다.
  10. 계속하려면 지금 설치를 클릭합니다.
SOLIDWORKS Electrical이 이미 워크스테이션이나 서버에 설치되어 있으면 SOLIDWORKS 설치 관리자에서 자동으로 검색하여 이를 업데이트하라는 메시지를 표시합니다. 소프트웨어를 업데이트하려면 첫 번째 설치와 동일한 프로세스를 사용합니다.


Collaborative Server 설정

Collaborative Server는 Windows 서비스로, 항상 실행 중이어야 하고, 방화벽과 바이러스 스캐너를 통해 클라이언트와 언제나 원활하게 양방향 통신을 수행할 수 있어야 합니다.

개별 모드나 서버 모드에서 Collaborative Server를 구성하려면 다음 파라미터를 지정합니다.
  • 컴퓨터 이름(예: LOCALHOST 또는 MyMachine) 또는 해당 IP 주소(예: 127.0.0.1 또는 192.168.999.999).
  • 포트 번호(기본값: 26666).

설치 중 또는 나중에 도구 > 애플리케이션 설정 명령에서 Collaborative Server를 구성할 수 있습니다.

원활한 양방향 통신을 제공하려면 Collaborative Server가 설치된 시스템에서 포트 번호 26666~26676(10명의 사용자가 동시에 연결된 경우)이 사용 가능한지 확인합니다. 그렇지 않다면 시스템 관리자에게 SOLIDWORKS Electrical의 다른 포트를 찾아줄 것을 문의합니다.

상위 주제 SOLIDWORKS Electrical
SOLIDWORKS Electrical의 설치 요구 사항
독립 실행형 또는 클라이언트/서버 설치
Microsoft SQL Server 설정
데이터 위치 지정


Microsoft SQL Server 설정

모든 유형의 SOLIDWORKS Electrical 설치에 대해 SQL Server 데이터베이스의 인스턴스를 사용할 수 있는지 확인합니다. SQL Server 데이터베이스가 이미 시스템에 설치되어 있는 경우 기존 데이터베이스를 사용하거나 SOLIDWORKS Electrical 설치 시 새 인스턴스를 설치할 수 있습니다.

SQL Server의 새 인스턴스를 설치할 때 SOLIDWORKS 설치에서는 무료 버전의 Microsoft SQL Express 2022를 제공합니다. 이 버전은 CPU 1개, 메모리 1GB 및 데이터 10GB로 제한됩니다. 이 메모리와 CPU 제한은 동시 사용자 10명을 지원하기에 충분합니다.

SQL Express 2022를 설치할 경우 서버 소프트웨어 및 하드웨어가 시스템 요구 사항에 나와 있는 요구 사항을 충족하는지 확인합니다.

동일한 서버에 10명 이상의 동시 사용자가 있는 경우 SQL Server 정식 버전을 구입하여 설치하는 것이 가장 좋습니다. SQL Server의 기존 인스턴스와 함께 SOLIDWORKS Electrical 설치에 대해 설명된 워크플로를 사용합니다.

SQL Express 2022에 대한 자세한 내용은 Microsoft SQL Server 문서를 참조하십시오.

상위 주제 SOLIDWORKS Electrical
SOLIDWORKS Electrical의 설치 요구 사항
독립 실행형 또는 클라이언트/서버 설치
Collaborative Server 설정
데이터 위치 지정

SOLIDWORKS Electrical에서 데이터 관리하기

대다수 프로그램에서는 모든 프로그램 데이터가 포함된 하나의 데이터베이스를 사용합니다. 그러나 SOLIDWORKS Electrical은 그렇지 않습니다. SOLIDWORKS Electrical의 각 프로젝트에는 고유한 ID 번호가 지정되고, 모든 프로젝트에는 이 고유한 ID 번호로 식별될 수 있는 관련 데이터베이스가 있습니다. 예를 들어, SOLIDWORKS Electrical Project Manager에서 ID 번호112로 프로젝트를 찾을 경우 연결된 데이터베이스의 이름은 “tew_project_data_112”입니다.

각 프로젝트마다 고유한 데이터베이스를 가지는 이유는 처리 시간이 상당히 줄어들기 때문입니다. 또한 심각한 데이터베이스 오류가 발생하더라도 프로젝트 하나만 영향을 받기 때문에 대다수 프로그램 정보의 무결성이 유지됩니다.

그러나 일부 기업에는 새 데이터베이스 작성을 제한하는 정책이 있습니다. SOLIDWORKS Electrical을 실행하려면 사용자가 새 데이터베이스를 작성하는 데 제한이 있어서는 안 됩니다. 사용자가 새 데이터베이스를 작성하지 못하도록 만드는 구성 설정이 없는지 시스템 또는 데이터베이스 관리자에게 확인하십시오.

SQL Server의 새 인스턴스

SQL Server의 새 인스턴스를 설치할 경우 서버와 모든 클라이언트 시스템에 대한 모든 관리 권한이 필요합니다. 프로젝트, 라이브러리, 기호 및 기타 프로젝트 데이터를 작성 및 수정할 수 있도록 클라이언트에게 데이터베이스에 대한 읽기/쓰기 권한이 있는지도 확인해야 합니다.

SQL Server의 새 인스턴스를 설치할 경우 기본값 이외의 이름을 선택합니다.

SQL Server의 기존 인스턴스

새 SOLIDWORKS Electrical 데이터베이스를 설치하거나 기존 SQL Server 인스턴스에 설치된 SOLIDWORKS Electrical에 연결하려면 SQL Server 데이터베이스에 대한 모든 관리 권한이 있는 사용자 계정이 필요합니다.

SOLIDWORKS Electrical이 제대로 작동하려면 SQL Server를 혼합 모드 인증으로 사용해야 합니다. 혼합 모드 인증을 사용하면 Windows 또는 SQL Server 자격 증명 중 어느 것이든 사용할 수 있습니다.

기존 SQL Server 데이터베이스에 연결하기 위해 Windows 또는 SQL Server 인증을 사용할 수 있습니다. Windows 또는 SQL Server 로그인 시 모든 SQL Server 관리 권한을 가진 사용자 이름과 비밀번호를 입력합니다.

‘tew’ 사용자를 사용하여 SQL Server에 연결해 설치하는 것은 불가능합니다. SQL Server에 대한 적절한 자격 증명이 있는 로그인 정보를 얻으려면 SQL Server 관리자 또는 시스템 관리자에게 문의하십시오.

SOLIDWORKS Electrical 데이터베이스

SOLIDWORKS Electrical을 설치한 후에는 설치 프로그램이 SQL Server 인스턴스에 다음 데이터베이스를 생성합니다.

  • TEW_APP_DATA
  • TEW_APP_MACRO
  • TEW_APP_PROJECT
  • TEW_CATALOG
  • TEW_CLASSIFICATION


데이터 위치 지정

데이터 위치에 파트, 템플릿, 2D 및 3D 기호와 같은 프로그램 데이터를 저장할 디렉터리를 선택합니다. 이 위치는 전용 디렉터리여야 합니다. 루트 디렉터리이거나 SOLIDWORKS 데이터를 저장하는 데 사용한 디렉터리는 안 됩니다.

기본 디렉터리는 C:\ProgramData\SOLIDWORKS Electrical입니다.

클라이언트/서버 설치의 경우 데이터 디렉터리를 공유해야 합니다.

설치 프로그램은 기본 디렉터리에 새 데이터를 모두 저장할 Update라는 새 폴더를 생성합니다.

SOLIDWORKS Electrical을 처음 시작하면 Update 폴더에 저장된 데이터가 기존 데이터와 자동으로 병합됩니다. 데이터 업데이트 마법사에서 애플리케이션 및 SQL Server 데이터베이스에 추가할 데이터를 선택할 수 있습니다.

상위 주제 SOLIDWORKS Electrical
SOLIDWORKS Electrical의 설치 요구 사항
독립 실행형 또는 클라이언트/서버 설치
Collaborative Server 설정
Microsoft SQL Server 설정


SOLIDWORKS Visualize 및 SOLIDWORKS Visualize Boost

SOLIDWORKS® Visualize는 고급 렌더링 기능과 시각적 설계 중심 기능 및 워크플로를 결합한 독립 실행형 도구 모음을 제공하므로 3D CAD 모델의 매우 사실적인 이미지를 작성할 수 있습니다.

SOLIDWORKS Visualize 제품은 다음 두 가지 패키지로 제공됩니다.
  • Standard
  • Professional

서브스크립션이 활성화된 SOLIDWORKS Professional과 Premium 사용권마다 SOLIDWORKS Visualize Standard의 무료 시트가 제공됩니다. 독립실행형 활성화 SOLIDWORKS 고객의 경우 추가 제품 번호가 필요합니다. SOLIDWORKS Visualize 제품 번호를 모르는 경우 SOLIDWORKS 관리자 또는 리셀러에게 문의하십시오.

SOLIDWORKS Visualize는 부동과 같은 SolidNetWork 사용권(SNL) 사용권 유형뿐만 아니라 오프라인 활성화도 지원합니다.

SLDIM(SOLIDWORKS 설치 관리자)을 사용하여 개별(이 컴퓨터에 설치) 설치로 SOLIDWORKS Visualize를 설치합니다. 이는 모델링 및 렌더링에 별도의 컴퓨터를 사용하려는 경우에 유용한 독립 실행형 애플리케이션으로 설치할 수 있습니다. SOLIDWORKS 사용권은 요구되지 않습니다.

SOLIDWORKS Visualize Boost는 SOLIDWORKS Visualize Professional을 실행 중인 컴퓨터에서 네트워크에 있는 하나 이상의 컴퓨터로 렌더링을 배포할 수 있는 서비스입니다. 렌더링된 이미지를 생성하는 동안 컴퓨터에서 다른 작업을 수행할 수 있기 때문에 최종 렌더링 이미지를 더 빨리 사용할 수 있습니다. SOLIDWORKS 설치 관리자의 개별(이 컴퓨터에 설치) 설치의 일부로 Visualize Boost를 설치할 수도 있습니다.

서브스크립션이 활성화된 SOLIDWORKS Visualize Professional의 시트마다 SOLIDWORKS Visualize Boost의 무료 시트가 제공됩니다.
Visualize Boost는 Visualize Professional 전용 제품 애드온입니다. Visualize Boost는 Visualize Standard에서 지원되지 않습니다.

목차

  • SOLIDWORKS Visualize의 시스템 요구 사항

  • SOLIDWORKS 설치 관리자로 SOLIDWORKS Visualize 설치

  • SOLIDWORKS 설치 관리자를 사용하여 Visualize Boost 설치


SOLIDWORKS Visualize의 시스템 요구 사항

SOLIDWORKS Visualize 및 SOLIDWORKS Visualize Boost의 성능 및 설정을 최적화하려면 설치하기 전에 다음 지침을 따르십시오.
  • SOLIDWORKS Visualize 및 SOLIDWORKS Visualize Boost를 설치하기 전에 각 제품에 대해 별도의 제품 번호가 있는지 확인하십시오.
  • SOLIDWORKS Visualize 또는 SOLIDWORKS Visualize Boost를 실행하는 모든 컴퓨터가 시스템 요구 사항에 나열된 요구 사항을 충족하는지 확인합니다.
  • SOLIDWORKS Visualize Boost 애플리케이션을 동일한 네트워크 내의 전용 렌더링 컴퓨터에 설치합니다. 이러한 컴퓨터는 렌더링 작업을 오프로드하기 위해 SOLIDWORKS Visualize Professional을 실행하는 컴퓨터와 달라야 합니다.
  • 해당 GPU를 찾을 수 없는 경우 SOLIDWORKS Visualize 및 SOLIDWORKS Visualize Boost는 기본적으로 중앙 처리 장치(CPU)로 설정됩니다. 특정 그래픽 카드 및 드라이버에 대한 자세한 내용은 SOLIDWORKS 하드웨어 인증서를 참조하십시오.

3DS Stellar Physically Correct를 사용하는 GPU 지원의 경우:

Stellar 정확 렌더링 모드:
  • 최소한 Maxwell 마이크로아키텍처를 기반으로 하는 NVIDIA 그래픽 카드
  • CUDA 12.2을 지원하는 538.78의 권장 드라이버 버전.
  • 최소 4GB의 비디오 메모리
Stellar 빠른 렌더링 모드:
  • 최소한 Turing 마이크로아키텍처를 기반으로 하는 NVIDIA 그래픽 카드(RT 코어 지원)
  • 정확 모드와 동일한 드라이버 버전 및 메모리 요구 사항을 사용합니다.

AMD ProRender를 사용하는 GPU 지원의 경우:

AMD ProRender 빠른 및 정확 렌더링 모드:
  • Vulkan 표준을 지원하는 GPU 및 드라이버
  • 1.2 이상의 OpenCL 지원
상위 주제 SOLIDWORKS Visualize 및 SOLIDWORKS Visualize Boost


SOLIDWORKS 설치 관리자로 SOLIDWORKS Visualize 설치

SOLIDWORKS Visualize를 설치하는 방법

  1. SOLIDWORKS 설치 관리자를 시작합니다.
  2. 시작 페이지에서 이 컴퓨터에 설치를 선택합니다.
  3. 다음과 같이 합니다.
    1. 제품 번호 페이지에서 시각화를 확장합니다.
    2. SOLIDWORKS Visualize를 선택하고 제품 번호를 입력합니다.
    3. 다음을 클릭합니다.
  4. 시스템 경고의 지침을 따르고 다음을 클릭합니다.
  5. 요약 페이지에서 SOLIDWORKS 사용권 계약의 조건에 동의하고 지금 설치를 클릭합니다.
제품 활성화 마법사의 지침에 따라 제품을 활성화합니다.

활성화 후 바탕 화면에서 SOLIDWORKS Visualize 바로가기 아이콘을 더블 클릭하여 애플리케이션을 시작하거나 Windows 시작 메뉴에서 SOLIDWORKS version > SOLIDWORKS Visualize version을 클릭합니다.

목차

  • 설치 후 작업

상위 주제 SOLIDWORKS Visualize 및 SOLIDWORKS Visualize Boost


설치 후 작업

설치 후 SOLIDWORKS Visualize를 설정하려면 몇 가지 작업을 수행해야 합니다.

자세한 내용은 SOLIDWORKS Visualize 도움말에서 SOLIDWORKS Visualize 시작하기를 참조하십시오.

목차

  • Content 폴더 생성하기

  • 도움말, 튜터리얼, 시스템 정보, 사용권에 액세스하기

상위 주제 SOLIDWORKS 설치 관리자로 SOLIDWORKS Visualize 설치


Content 폴더 생성하기

소프트웨어를 처음 실행하면 SOLIDWORKS Visualize에 Content 폴더를 생성할 위치를 묻는 메시지가 나타납니다.

Content 폴더에는 프로젝트의 자산을 저장할 수 있는 다음과 같은 하위 폴더가 포함되어 있습니다.
하위 폴더 | 저장
카메라 | 기본 카메라와 저장한 카메라
환경 | HDR(High Dynamic Range) 이미지
팔레트 | 백플레이트 이미지
이미지 | 렌더링 및 스냅샷
표현 | 표현 라이브러리에 있는 재질 라이브러리에 표현을 추가할 때 콘텐츠를 업데이트합니다.
모델 | 모델 파일 기본적으로 SOLIDWORKS Visualize에서는 파일 > 모델 불러오기를 사용할 때 이 폴더를 먼저 검색합니다.
평판 | 백플레이트에서 사용할 표준 2D 이미지
프로젝트 | .SVPJ 형식의 고유 프로젝트 파일
텍스처 | 표현에서 사용할 2D 텍스처
상위 주제 설치 후 작업


도움말, 튜터리얼, 시스템 정보, 사용권에 액세스하기

도움말 메뉴는 소프트웨어를 업데이트하고 시스템 문제를 해결하기 위한 설명서와 옵션을 제공합니다.

Visualize 도움말 | SOLIDWORKS Visualize 온라인 도움말을 엽니다.
Visualize 튜터리얼 | MySolidWorks를 열어 SOLIDWORKS Visualize 튜터리얼에 액세스할 수 있습니다.
릴리즈 노트 | 현재 버전의 온라인 릴리즈 노트를 표시합니다.
새 기능 설명서 | SOLIDWORKS 제품의 새로운 기능을 표시합니다.
시스템 정보 | PC 하드웨어와 함께 SOLIDWORKS Visualize 소프트웨어의 시스템 점검을 수행하고 필요한 경우 업그레이드를 제안합니다.
업데이트 확인 | 서버에서 최신 SOLIDWORKS Visualize 업데이트를 확인하십시오.
라이선스 활성화 | (노드 락 사용권) SOLIDWORKS 제품 활성 마법사로 제품을 활성화합니다.
라이선스 비활성화 | (노드 락 사용권) SOLIDWORKS 제품 활성 마법사로 제품을 비활성화합니다.
SolidNetWork License Manager | SOLIDWORKS 제품 활성 마법사로 제품을 비활성화합니다.
Visualize 정보 | SOLIDWORKS Visualize 복사본의 버전 번호와 사용권 정보를 표시합니다.
상위 주제 설치 후 작업


SOLIDWORKS 설치 관리자를 사용하여 Visualize Boost 설치

SOLIDWORKS 설치 관리자를 사용하여 Visualize Boost를 설치합니다. 여기에는 별도의 제품 번호가 필요합니다.

Visualize Boost는 SOLIDWORKS Visualize Professional을 실행하는 시스템이 아닌 다른 시스템에 설치해야 합니다. 여러 GPU(그래픽 처리 장치)가 있는 컴퓨터에 Visualize Boost를 설치하여 렌더링 성능을 극대화할 수 있습니다.

SOLIDWORKS Visualize Boost를 설치하는 방법

  1. SOLIDWORKS 설치 관리자를 시작합니다.
  2. 시작 페이지에서 이 컴퓨터에 설치를 선택합니다.
  3. 다음과 같이 합니다.
    1. 제품 번호 페이지에서 시각화를 확장합니다.
    2. SOLIDWORKS Visualize Boost를 선택하고 제품 번호를 입력합니다.
    3. 다음을 클릭합니다.
  4. 시스템 경고의 지침을 따르고 다음을 클릭합니다.
  5. 요약 페이지에서 SOLIDWORKS 사용권 계약의 조건에 동의하고 지금 설치를 클릭합니다.
제품 활성화 마법사의 지침에 따라 제품을 활성화합니다.

활성화한 후 SOLIDWORKS Visualize Boost 바탕 화면 바로 가기 [image] 를 더블 클릭하여 앱을 엽니다.

목차

  • Visualize Boost 설정

    기본 Visualize Boost 시스템을 코디네이터로 구성하고 렌더링 클러스터의 추가 시스템을 노드로 구성할 수 있습니다.

상위 주제 SOLIDWORKS Visualize 및 SOLIDWORKS Visualize Boost


Visualize Boost 설정

기본 Visualize Boost 시스템을 코디네이터로 구성하고 렌더링 클러스터의 추가 시스템을 노드로 구성할 수 있습니다.

Visualize Boost를 사용하면 단일 시스템 또는 여러 시스템 클러스터에서 이미지를 렌더링할 수 있습니다. 설정은 간단하고 직관적입니다. 기본 컴퓨터인 코디네이터는 클러스터를 관리하고 SOLIDWORKS Visualize의 렌더링 작업을 배포합니다. 노드라는 추가 시스템은 코디네이터에 연결하여 네트워크에서 이러한 작업을 지원합니다. 렌더링 팜에서 클러스터의 각 시스템은 Visualize Boost 인스턴스를 지속적으로 실행합니다.

Visualize Boost를 설정하는 방법:

  1. Visualize Boost를 열려면,
    • Visualize Boost 바탕 화면 바로 가기 [image] 를 더블 클릭합니다.
    • Windows 시작 메뉴에서 SOLIDWORKS <버전> > SOLIDWORKS Visualize Boost <버전>을(를) 클릭합니다.
    활성화하면 Visualize Boost 창에서 사용권이 있는 시스템의 이름과 IP 주소를 식별하고 표시합니다.
  2. Visualize Boost에서 파일 > 설정을 클릭합니다.
  3. 설정 대화 상자에서 다음을 수행합니다.
    1. 하나의 시스템을 코디네이터로 선택합니다. 다른 모든 노드를 구성할 때는 코디네이터를 선택하지 않은 상태로 둡니다.
    2. Boost 포트에는 기본값인 8001을 적용하고 DStellar 포트에는 8002를 적용합니다.
      네트워크 요구 사항에 맞게 이러한 포트를 업데이트할 수 있습니다. 노드 통신을 위한 방화벽 예외를 추가해야 합니다. 궁금한 사항은 네트워크 관리자에게 문의하십시오.
  4. 옵션: 다음과 같은 추가 파라미터가 있습니다.
    옵션 | 설명
    언어 | 시스템은 자동으로 운영 체제의 언어를 사용합니다.
    테마 | 테마의 경우 밝은 또는 어두운 배경을 선택합니다. 이 설정은 SOLIDWORKS Visualize가 Visualize Boost와 동일한 시스템에 설치된 경우 SOLIDWORKS Visualize에 영향을 미칩니다.
    알림 활성화됨 | Windows 알림 영역에 DStellar.Boost의 메시지가 표시됩니다.
    내보내기 | Visualize Boost 구성 설정을 .json 파일에 저장합니다.
    불러오기 | .json 파일의 Visualize Boost 인스턴스에 기존 설정을 로드합니다.
  5. 적용을 클릭합니다.
설정을 완료하려면 Visualize Boost 작업 지침을 참조하십시오.
상위 주제 SOLIDWORKS 설치 관리자를 사용하여 Visualize Boost 설치


사용권 관리

설치 후 개별 컴퓨터를 활성화하거나(컴퓨터 정품 인증) 서버에서 부동 네트워크 사용권을 설치하고 활성화하여(SolidNetWork 사용권 발급) SOLIDWORKS 사용권을 활성화할 수 있습니다.

대개, 개별 컴퓨터에 설치할 때 사용권 활성을 사용합니다; 그러나 소프트웨어를 개별적으로 설치한 다음, SolidNetWork License Manager로 사용권을 제어할 수 있습니다. 이와 반대로, 일반적으로 더 큰 사이트에서 부동 네크워크 사용권을 사용하더라도, 사용자가 관리자 이미지에서 배포한 다음 개별 컴퓨터에서 제품 번호를 활성화 할 수 있습니다.

목차

  • 개별 사용권 관리

    컴퓨터 정품 인증을 사용하도록 개별 사용권을 지정할 수 있습니다.

  • SolidNetWork License Manager를 사용하여 사용권 관리

    SolidNetWork License Manager는 사용권을 네트워크 상의 클라이언트에 배포하여 여러 개의 사용권 클라이언트를 지원합니다. 따라서 사용자는 사용권 부동화를 사용하여 사용권 수를 초과하여 사용할 수 있습니다.


개별 사용권 관리

컴퓨터 정품 인증을 사용하도록 개별 사용권을 지정할 수 있습니다.

일반적으로 개별 사용권의 관리는 SOLIDWORKS 소프트웨어에서 직접 사용권을 활성화하거나 비활성화하여 수행됩니다.

활성화란, SOLIDWORKS 스탠드얼론 사용권(SOLIDWORKS 사용권 외)의 제품 사용권 발급 및 등록 절차를 뜻합니다. 대개, 제품 사용권이 활성화되어 있지 않으면 SOLIDWORKS에서 제품을 시작할 때 활성화를 시도합니다.

SOLIDWORKS 2022부터는 SOLIDWORKS 영구 사용권을 구입한 경우, 1년에 한 번 사용권을 다시 활성화하기도 해야 합니다. 영구 사용권은 만료되지 않지만 다시 활성화하기는 해야 합니다. 필요한 재활성화 날짜 이전에 영구 사용권을 다시 활성화하라는 메시지가 표시됩니다.

SOLIDWORKS에서 [image] > 사용권 > 비활성화를 클릭하면 개별 사용권을 비활성화할 수 있습니다.

상위 주제 사용권 관리
SolidNetWork License Manager를 사용하여 사용권 관리

사용권 활성

개별 컴퓨터에서 SOLIDWORKS 제품을 실행할 수 있으려면 먼저, 해당 컴퓨터에 대한 사용권을 활성화해야 합니다.

활성화하려면 인터넷 또는 이메일 액세스 권한이 있어야 합니다. 활성화 후에는 온라인 상태가 아니어도 제품을 사용할 수 있습니다. 이 제품을 사용하는 컴퓨터에 이메일 액세스 권한이 없는 경우 활성화 파일을 저장하고 다른 컴퓨터에서 전송할 수 있습니다.

절차:
  • SOLIDWORKS 모든 제품 라인의 소프트웨어 사용권을 활성화합니다.
  • 특정 컴퓨터에서 다른 컴퓨터로 사용권을 이동할 수 있습니다.
  • 즉시 수행하거나(권장됨) 설치 후 30일 이내에 수행할 수 있습니다.
  • 동글이 필요없습니다. 그러나 활성화가 필요하지 않은 SOLIDWORKS의 이전 제품을 실행할 경우에는 동글이 필요합니다.

관리할 제품 번호가 여러 개 있는 시스템 관리자의 경우 관리 이미지 옵션 편집기를 사용할 수 있습니다. 자세한 내용은 관리 이미지 옵션 편집기의 내용을 참조하십시오.

사용권 활성하기:

  1. SOLIDWORKS를 시작합니다.
  2. 다음 중 한 가지 방법을 사용하여 SOLIDWORKS 제품 활성을 시작합니다.
    • 해당 컴퓨터에 대해 사용권을 활성화하지 않은 경우 SOLIDWORKS 소프트웨어를 시작할 때 SOLIDWORKS 제품 활성화 창이 자동으로 나타납니다.
    • SOLIDWORKS 제품 활성화 창이 자동으로 나타나지 않으면 [image] > 사용권 > 활성화를 클릭하여 활성화를 시작합니다.
  3. 제품 목록을 선택하여 사용권을 활성화할 제품을 지정합니다.
  4. 인터넷을 통해 자동 활성을 지정하거나 전자우편을 통한 직접 활성을 지정합니다.
  5. 전자우편 정보를 입력합니다.
  6. 다음을 클릭합니다.
    • 인터넷: 활성화가 자동으로 이루어집니다.
    • 이메일: 저장을 클릭하여 요청 파일을 작성한 후 이메일(activation@solidworks.com)로 파일을 보냅니다. 응답 파일이 포함된 이메일을 받으면 첨부 파일의 압축을 푼 다음 열기를 클릭하여 로드합니다.
      필요한 경우 활성화 절차를 종료하고 다시 실행하여 응답 파일을 열 수 있습니다.
  7. 마침을(를) 클릭합니다.
관리 이미지 옵션 편집기

사용권 다시 활성화

SOLIDWORKS 2022 이후 제품의 영구 상용 또는 교육용 사용권이 있는 경우 해당 사용권을 1년에 한 번 다시 활성화해야 합니다. SOLIDWORKS 제품 활성화에서 필요한 재활성화 날짜 이전에 이를 수행하라는 메시지가 표시됩니다.

사용권을 다시 활성화하려면:

  1. SOLIDWORKS를 시작합니다.
    SOLIDWORKS 제품 활성화에서 다시 활성화하라는 메시지가 표시됩니다. 각 SOLIDWORKS 제품 사용권에 대해 다음이 표시됩니다.
    • 현재 활성화가 만료되는 날짜
    • 영구 사용권을 다시 활성화하거나 기간제 또는 평가판 사용권을 갱신 및 다시 활성화하는 등 제품을 계속 사용하는 데 필요한 조치.
  2. 지금 다시 활성화를 클릭하여 제품 활성화 마법사를 시작합니다.

    사용권을 즉시 다시 활성화하지 않으려면 나중에 알림을 클릭합니다. 예를 들어, SOLIDWORKS에서 [image] > 사용권 > 활성화를 클릭하여 제품 활성화 마법사를 시작합니다. 사용권 활성을 참조하십시오.

사용권 이동

SolidNetWork License를 새 컴퓨터나 업그레이드된 컴퓨터로 이동하려면 우선 Dassault Systemes SOLIDWORKS Corporation의 사용권 키 서버에서 해당 사용권을 비활성화합니다. 그런 다음 다른 컴퓨터에서 다시 활성화합니다.

하드 디스크 드라이브 고장 등의 이유로 Dassault Systemes SOLIDWORKS Corporation에서 사용권을 비활성화할 수 없더라도 대부분의 경우 재활성화는 성공합니다. 그렇지 않은 경우에는 공인 리셀러에게 도움을 요청하십시오.

사용권을 이동하는 방법:

  1. SOLIDWORKS에서 [image] > 사용권 > 비활성화를 클릭하고 지침을 따릅니다.
  2. 재활성화를 하려면 새 컴퓨터나 업그레이드된 컴퓨터에서 첫 활성화 중 했던 것 같이 사용권을 활성화합니다. 자세한 내용은 사용권 활성을 참조하십시오.


SolidNetWork License Manager를 사용하여 사용권 관리

SolidNetWork License Manager는 사용권을 네트워크 상의 클라이언트에 배포하여 여러 개의 사용권 클라이언트를 지원합니다. 따라서 사용자는 사용권 부동화를 사용하여 사용권 수를 초과하여 사용할 수 있습니다.

다음 그림은 일반적인 SolidNetWork 사용권 설치 과정을 보여줍니다.

이 그림의 과정:
  • SolidNetWork License Manager 소프트웨어가 사용권 관리자 컴퓨터에만 설치되고 활성화되었습니다.
  • 사용권 클라이언트 컴퓨터에는 추가로 설치된 별도의 SolidNetWork 사용권 소프트웨어가 없습니다.

    설치 시 SolidNetWork License 제품 번호를 지정하면 SOLIDWORKS 설치 관리자가 해당 컴퓨터를 SolidNetWork License 클라이언트로 인식합니다. SOLIDWORKS 설치 관리자는 사용자에게 클라이언트를 사용권 관리자에 연결하기 위해 SolidNetWork License Manager 컴퓨터 이름과 포트 번호를 입력하라는 메시지를 표시합니다.

  • 사용권 관리자와 모든 사용권 클라이언트는 TCP/IP(Transmission Control Protocol/Internet Protocol) 연결이 설정되어 있어야 합니다.

목차

  • SolidNetWork 사용권 설치 개요

    컴퓨터에 SOLIDWORKS 클라이언트 소프트웨어를 설치하기 전에 SolidNetWork License Manager를 사용하여 하나 이상의 컴퓨터에 SolidNetWork License Manager Server를 설치합니다. 그런 다음 제품 활성화 마법사를 사용하여 영구 및 기간 사용권에 대한 제품 번호를 추가하고 활성화할 수 있습니다.

  • SolidNetWork License Manager 시작

    Windows 시작 메뉴에서 SolidNetWork License Manager를 시작할 수 있습니다.

  • SolidNetWork License Manager 업그레이드

    SOLIDWORKS 주요 릴리스의 경우 License Manager 업그레이드 과정은 이전 License Manager 제거, 새 License Manager 설치, SolidNetWork License 다시 활성화 과정으로 이루어집니다.

  • SolidNetWork 사용권 이동

    SolidNetWork 사용권을 새 컴퓨터나 업그레이드된 컴퓨터로 이동하려면 먼저 사용권을 Dassault Systemes SOLIDWORKS Corporation의 사용권 키 서버에서 비활성화한 후 다른 컴퓨터에서 다시 활성화합니다.

  • SolidNetWork 사용권 파일 삭제

    만료된 SolidNetWork License 파일을 새 사용권으로 업그레이드하기 전에 삭제할 수 있습니다.

  • SolidNetWork 사용권 차용 및 반환

    SolidNetWork 사용권을 빌려와 원격 위치에서 소프트웨어를 사용할 수 있습니다. 사용 가능한 사용권 풀에서 사용권이 제거되므로 차용된 사용권을 다시 사용할 수 있게 하려면 반환해야 합니다.

  • SOLIDWORKS 버전 액세스 관리

    사용자는 SolidNetWork 환경에서 특정 SOLIDWORKS 버전을 사용하지 못하도록 제한할 수 있습니다. 이 기능을 통해 다양한 개인, 프로젝트 및 비즈니스 부서에서 사용되는 SOLIDWORKS 버전을 관리할 수 있습니다.

  • 사용권 유휴 시간 추적

    SOLIDWORKS는 일정 시간 동안 사용되지 않은 사용권들을 남은 사용권 목록에 되돌려 보낼 수 있도록 SolidNetWork License Manager의 유휴 시간을 등록해주는 옵션이 있습니다.

  • 임시 사용권 사용

    SolidNetWork License를 사용할 수 없을 때 임시 "ANY" 사용권을 사용할 수 있습니다.

  • 애드인 제품을 포함해 SolidNetWork 사용권 사용

    SolidNetWork License Manager를 사용하여 SOLIDWORKS 주요 애드인 제품의 사용권을 배포할 수 있습니다.

  • SolidNetWork License로 SOLIDWORKS Simulation 사용권 선택

    SolidNetWork 사용권 사용자는 SOLIDWORKS Simulation에 추가할 때 사용권 풀에서 사용할 SOLIDWORKS® Simulation 사용권을 제어할 수 있습니다. 또한 고급 스터디의 상위 사용권 유형이 필요한 경우 추가 기능을 언로드하지 않고도 SOLIDWORKS Simulation 사용권을 업그레이드할 수 있습니다.

  • Flow Simulation 모듈 로드

    SolidNetWork License 고객은 두 가지 방법을 사용하여 Flow Simulation용 HVAC 및 Electronics Cooling 애드인 모듈을 로드하는 방법을 제어할 수 있습니다.

  • SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation, SOLIDWORKS Plastics의 비활성 제한 시간 초과

    SOLIDWORKS Simulation, Plastics 또는 Flow Simulation 스터디를 실행하면 네트워크 사용권은 활성 상태로 유지되며, 제한 시간은 초과되지 않습니다. SOLIDWORKS는 계산 프로세스 중에 사용권을 보유하며, 이것은 작업으로 간주됩니다.

  • 사용권 관리자와 관리 이미지 설치에 같은 컴퓨터 사용

    네트워크에서 컴퓨터 한 대를 구성하여 SolidNetWork 사용권을 배포하는 사용권 관리자와 사용자가 SOLIDWORKS 소프트웨어를 설치할 수 있는 관리 이미지 위치로의 역할을 동시에 할 수 있습니다.

  • SolidNetWork License Manager 설치 제거

    SolidNetWork License Manager를 업그레이드할 경우 새 관리자를 설치하기 전에 이전 사용권 관리자를 제거해야 합니다.

  • FlexNet Publisher 사용권 관리

    SolidNetWork 사용권은 FlexNet Publisher® 사용권 관리에 기반합니다.

상위 주제 사용권 관리
개별 사용권 관리


SolidNetWork 사용권 설치 개요

컴퓨터에 SOLIDWORKS 클라이언트 소프트웨어를 설치하기 전에 SolidNetWork License Manager를 사용하여 하나 이상의 컴퓨터에 SolidNetWork License Manager Server를 설치합니다. 그런 다음 제품 활성화 마법사를 사용하여 영구 및 기간 사용권에 대한 제품 번호를 추가하고 활성화할 수 있습니다.

컴퓨터에 SOLIDWORKS 클라이언트 소프트웨어를 설치할 때는 SolidNetWork License 제품 번호를 지정합니다. SolidNetWork License Manager는 해당 컴퓨터를 SolidNetWork License 클라이언트로 인식하고 SolidNetWork License Manager Server의 컴퓨터 이름과 포트 번호를 묻는 메시지가 표시됩니다. SolidNetWork License Manager Server가 설치되지 않았거나 이름 또는 포트 번호가 잘못된 경우 오류가 표시됩니다.

활성화 프로세스

개별 컴퓨터에서 SOLIDWORKS 제품을 실행할 수 있으려면 먼저, SolidNetWork License Manager Server 컴퓨터에서 SolidNetWork License을 활성화해야 합니다.

활성화하려면 활성화된 인터넷 연결 또는 이메일 액세스 권한이 있어야 합니다. 활성화 후에는 온라인 상태가 아니어도 제품을 사용할 수 있습니다. 이 제품을 사용하는 컴퓨터에 이메일 액세스 권한이 없는 경우 활성화 파일을 저장하고 다른 컴퓨터에서 전송할 수 있습니다.

절차:
  • 모든 SolidWorks 제품에 대한 SolidNetWork 사용권으로 SOLIDWORKS SolidNetWork License Manager를 활성화합니다.
  • SolidNetWork License Manager 컴퓨터에서 다른 컴퓨터로 SolidNetWork License을 이동할 수 있도록 합니다.
  • SolidNetWork License Manager 컴퓨터 한 대에서 SolidNetWork 사용권을 설치하고 활성화할 수 있습니다.
  • SolidNetWork 사용권을 사용하려면 먼저 수행해야 합니다.
  • 동글이 필요없습니다. SOLIDWORKS 현 버전에 대한 SolidNetWork 사용권을 활성화할 경우 이전 버전의 SOLIDWORKS에 대한 SolidNetWork 사용권이 활성화됩니다. 동글은 보유하지 않아도 됩니다.

목차

  • SolidNetWork License Manager Server 설치

    SolidNetWork License Manager Server는 여러 개의 사용권 클라이언트를 지원합니다. 네트워크상에 있는 다른 사용자에게 사용권을 분배합니다.

  • SolidNetWork 사용권 활성화

    개별 컴퓨터에서 SOLIDWORKS 제품을 실행할 수 있으려면 먼저, SolidNetWork License Manager 컴퓨터에서 SolidNetWork 사용권을 활성화해야 합니다.

  • SolidNetWork License Manager Server를 사용한 수동 활성화

    SolidNetWork License Manager Server를 설치 또는 업그레이드하는 경우 사용권을 활성화 또는 다시 활성화해야 합니다. 인터넷을 통해 사용권을 활성화 또는 다시 활성화하거나 수동으로 사용권을 다시 활성화할 수 있습니다.

  • SolidNetWork License 클라이언트 설치

  • 방화벽이 있는 상태에서 SolidNetWork 네트워크 사용권 사용

    컴퓨터에 방화벽이 사용되는 경우 포트를 구성하여 SolidNetWork 사용권을 지원해야 합니다.

  • SolidNetWork 사용권 다시 활성화

    다시 활성화는 조직에서 SolidNetwork License Manager 서버를 2022 버전 이상으로 업그레이드한 후 SolidNetWork License 제품에 적용됩니다. 설치된 제품이 이전 릴리즈이더라도 서버의 2022 버전부터 사용권은 1년에 한 번 다시 활성화해야 합니다.

  • 트라이어드 사용권 관리자 설치

    트라이어드 사용권 관리자는 추가적인 안정성을 위해 3대의 컴퓨터를 사용합니다. 사용권 파일을 관리하는 컴퓨터를 사용할 수 없는 경우, 다른 두 개의 컴퓨터 중 하나가 대신합니다.

상위 주제 SolidNetWork License Manager를 사용하여 사용권 관리
SolidNetWork License Manager 시작
SolidNetWork License Manager 업그레이드
SolidNetWork 사용권 이동
SolidNetWork 사용권 파일 삭제
SolidNetWork 사용권 차용 및 반환
SOLIDWORKS 버전 액세스 관리
사용권 유휴 시간 추적
임시 사용권 사용
애드인 제품을 포함해 SolidNetWork 사용권 사용
SolidNetWork License로 SOLIDWORKS Simulation 사용권 선택
Flow Simulation 모듈 로드
SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation, SOLIDWORKS Plastics의 비활성 제한 시간 초과
사용권 관리자와 관리 이미지 설치에 같은 컴퓨터 사용
SolidNetWork License Manager 설치 제거
FlexNet Publisher 사용권 관리


SolidNetWork License Manager Server 설치

SolidNetWork License Manager Server는 여러 개의 사용권 클라이언트를 지원합니다. 네트워크상에 있는 다른 사용자에게 사용권을 분배합니다.

사용권 활성화에 하드웨어 동글을 사용한 이전 버전의 SolidNetWork License Manager Server에서 업그레이드하는 경우, 새 버전의 SolidNetWork License Manager Server를 설치하기 전에 하드웨어 동글을 제거하십시오.

  1. 설치 미디어 다운로드에 설명된 대로 SOLIDWORKS 설치 관리자를 시작합니다.
  2. 설치 유형으로 서버 구성 요소 설치를 선택하고 이 컴퓨터에 SolidNetWork License Manager(분산 사용권) 설치를 클릭합니다.
  3. 요약 페이지에서 설치 위치 및 백그라운드 다운로더를 검토하고 사용권 조건에 동의한 다음 지금 설치를 클릭합니다.
  4. SolidNetWork License Manager Server의 SOLIDWORKS 제품 활성화 마법사에서 제품 번호를 추가하고 하나 이상의 사용권을 활성화합니다. 제품 번호 추가 및 SolidNetWork License 활성화를 참조하십시오.
상위 주제 SolidNetWork 사용권 설치 개요
SolidNetWork 사용권 활성화
SolidNetWork License Manager Server를 사용한 수동 활성화
SolidNetWork License 클라이언트 설치
방화벽이 있는 상태에서 SolidNetWork 네트워크 사용권 사용
SolidNetWork 사용권 다시 활성화
트라이어드 사용권 관리자 설치


SolidNetWork 사용권 활성화

개별 컴퓨터에서 SOLIDWORKS 제품을 실행할 수 있으려면 먼저, SolidNetWork License Manager 컴퓨터에서 SolidNetWork 사용권을 활성화해야 합니다.

SolidNetWork 사용권 활성하기:

  1. 시작 > SOLIDWORKS 도구 버전 > SolidNetWork License Manager Server버전을 클릭하여 SolidNetWork License Manager를 시작합니다.
  2. 옵션: SolidNetWork License를 아직 활성화하지 않은 경우 활성화할지 여부를 묻는 메시지가 나타납니다. 예를 클릭합니다.
    그러면 SOLIDWORKS 제품 활성화 마법사가 시작됩니다.
  3. 옵션: 방화벽을 사용하는 경우 서버에 방화벽 사용 중을 선택합니다.
  4. SolidNetWork License 서버 정보 페이지에서 포트 번호를 입력한 후 다음을 클릭합니다.
  5. 제품 번호:에서 특정 제품 번호를 선택하거나 모두 선택을 클릭하여 모든 SOLIDWORKS 제품 번호를 강조 표시하고 활성화합니다.
    1. 인터넷에서 자동으로 활성페이지 연결 (권장) 활성화 옵션을 선택합니다.
    2. 연락처 정보 아래에서 이메일 주소를 입력합니다.
    활성/재활성 되었습니다 대화 상자에 활성화된 제품이 표시됩니다.
  6. 마침을 클릭합니다.
상위 주제 SolidNetWork 사용권 설치 개요
SolidNetWork License Manager Server 설치
SolidNetWork License Manager Server를 사용한 수동 활성화
SolidNetWork License 클라이언트 설치
방화벽이 있는 상태에서 SolidNetWork 네트워크 사용권 사용
SolidNetWork 사용권 다시 활성화
트라이어드 사용권 관리자 설치


SolidNetWork License Manager Server를 사용한 수동 활성화

SolidNetWork License Manager Server를 설치 또는 업그레이드하는 경우 사용권을 활성화 또는 다시 활성화해야 합니다. 인터넷을 통해 사용권을 활성화 또는 다시 활성화하거나 수동으로 사용권을 다시 활성화할 수 있습니다.

수동으로 활성화하는 경우:
  • 새 SolidNetWork License Manager Server의 경우 서버를 올바르게 구성하려면 두 번 활성화해야 합니다. 처음 활성화하는 경우 서버에서 사용권 시스템을 초기화합니다. 이 절차를 두 번째로 반복하면 사용권을 활성화하는 것입니다.
  • 업그레이드된 SolidNetWork License Manager Server의 경우 기존 사용권을 다시 활성화해야 합니다. 서버에 활성화된 사용권이 없는 경우 대신 서버 관리 탭의 수정을 사용하여 활성화를 실행합니다.
상위 주제 SolidNetWork 사용권 설치 개요
SolidNetWork License Manager Server 설치
SolidNetWork 사용권 활성화
SolidNetWork License 클라이언트 설치
방화벽이 있는 상태에서 SolidNetWork 네트워크 사용권 사용
SolidNetWork 사용권 다시 활성화
트라이어드 사용권 관리자 설치


SolidNetWork License 클라이언트 설치

컴퓨터에 SOLIDWORKS CAD 소프트웨어를 설치할 때 SolidNetWork License 제품 번호를 지정합니다. SolidNetWork License Manager는 해당 컴퓨터를 SolidNetWork License 클라이언트로 인식하고 SolidNetWork License Manager 컴퓨터 이름과 번호를 묻는 메시지가 표시됩니다. SolidNetWork License Manager Server가 설치되지 않았거나 이름 또는 포트 번호가 잘못된 경우 오류가 표시됩니다.

SolidNetWork License로 SOLIDWORKS를 설치하는 방법:

  1. 설치 미디어 다운로드에 설명된 대로 SOLIDWORKS 설치 관리자를 시작합니다.
  2. 이 주요 릴리스로는 이 컴퓨터에 SOLIDWORKS 설치가 처음이라면 시작 페이지에서 이 컴퓨터에 설치를 클릭합니다.
    기존 릴리즈에서 업그레이드하는데 개별 사용권을 SolidNetWork 사용권으로 변경하는 경우에는 (현재 컴퓨터의) 개별 설치 수정을 클릭합니다. 자세한 내용은 개별 사용권에서 SolidNetWork 사용권으로 업그레이드 를 참조하십시오.
  3. 서버 추가 대화 상자에 SolidNetWork License Manager의 주소를 다음과 같은 형식으로 입력합니다.

    포트@컴퓨터이름

    포트 번호는 사용권 관리자 컴퓨터에서 사용한 번호와 동일해야 합니다. 기본값은 25734입니다.

    SOLIDWORKS 설치 관리자가 해당 SolidNetWork License Manager가 액세스 가능한지 확인합니다. License Manager를 아직 설치하지 않은 경우 이 확인에 실패하지만 사용권 클라이언트 설치를 계속할 수 있습니다.
  4. 다음 SOLIDWORKS 설치 관리자 지침에 따라 SOLIDWORKS 설치를 완료합니다.
상위 주제 SolidNetWork 사용권 설치 개요
SolidNetWork License Manager Server 설치
SolidNetWork 사용권 활성화
SolidNetWork License Manager Server를 사용한 수동 활성화
방화벽이 있는 상태에서 SolidNetWork 네트워크 사용권 사용
SolidNetWork 사용권 다시 활성화
트라이어드 사용권 관리자 설치


방화벽이 있는 상태에서 SolidNetWork 네트워크 사용권 사용

컴퓨터에 방화벽이 사용되는 경우 포트를 구성하여 SolidNetWork 사용권을 지원해야 합니다.

방화벽 소프트웨어에서 두 개의 SolidNetWork License 포트(예: SNL-in-port 및 SNL-out-port)를 방화벽 예외 목록에 추가해야 합니다. 이러한 포트 구성에 대한 자세한 내용은 시스템 관리자에게 문의하십시오.

지원되는 Windows 운영 체제에서 Windows 방화벽을 사용할 경우, SolidNetWork License Manager 컴퓨터에서 포트를 수정하고 SolidNetWork License 파일을 수정하여 사용권 클라이언트 컴퓨터에 사용권을 배포해야 합니다.

Windows 방화벽에 대한 License Manager 컴퓨터 포트 수정

  1. 시작을 클릭하고 Windows 보안을 엽니다.
  2. 방화벽 및 네트워크 보호 > 고급 설정을 선택하고 예를 클릭하여 변경 사항을 확인합니다.
  3. 고급 보안이 포함된 Windows Defender 방화벽 대화 상자에서 인바운드 규칙 > 새 규칙을 선택합니다.
  4. 새 인바운드 규칙 마법사에서 규칙 유형 포트를 선택하고 다음을 클릭합니다.
  5. 특정 로컬 포트에 포트 번호를 입력(예: 80, 25734, 443)한 후 다음을 클릭합니다.
  6. 이름을 선택합니다. 이름(예: SNL-in-port)을 입력합니다.
  7. 마침을 클릭합니다.

Windows 방화벽에 SolidNetWork License Manager 수정

  1. 시작 > SOLIDWORKS 도구 버전 > SolidNetWork License Manager Server 버전을 클릭하여 SolidNetWork License Manager를 시작합니다.
  2. 서버 관리 탭의 사용권 서버 아래에서 정지를 클릭합니다. 예를 클릭하여 확인하고 확인을 클릭하여 사용권 서버를 정지합니다.
  3. 사용권 정보 아래에서 수정을 클릭합니다.
  4. 서버 유형 아래에서 해당 네트워크의 서버 배열 상태(단일 또는 트라이어드)를 선택한 후 다음을 클릭합니다.
  5. 서버 정보 아래에서
    1. 서버에 방화벽 사용 중을 선택합니다.
    2. 포트 번호와 공급업체 데몬 포트 번호에는 Windows 방화벽에 대해 지정된 포트 번호가 포함되어야 합니다(자세한 내용은 위 절차 참조).
    3. 옵션 파일을 선택하고 파일을 찾기 위해서 찾아보기를 클릭합니다. 파라미터를 변경하려면 편집을 클릭합니다.
    사용권 관리자는 옵션 파일을 사용하여 FlexNet 사용권의 다양한 작동 파라미터를 제어할 수 있습니다.

    권장 사항: SolidNetWork License Manager 설치 디렉터리에 있는 옵션 파일(SolidNetWork_License_Manager_install_dir\Licenses \sw_d.opt)을 찾습니다. 이 파일은 sw_d.lic 파일과 동일한 디렉터리에 있어야 합니다.

    옵션 파일에 대한 자세한 내용은 SolidNetWork License Manager 설치 디렉터리( )의 FlexNet Publisher 사용권 관리 안내서를 참조하십시오.

    C:\Program Files\SOLIDWORKS SolidNetWork License Manager\Docs\flexuser\fnp_LicAdmin.pdf

상위 주제 SolidNetWork 사용권 설치 개요
SolidNetWork License Manager Server 설치
SolidNetWork 사용권 활성화
SolidNetWork License Manager Server를 사용한 수동 활성화
SolidNetWork License 클라이언트 설치
SolidNetWork 사용권 다시 활성화
트라이어드 사용권 관리자 설치


SolidNetWork 사용권 다시 활성화

다시 활성화는 조직에서 SolidNetwork License Manager 서버를 2022 버전 이상으로 업그레이드한 후 SolidNetWork License 제품에 적용됩니다. 설치된 제품이 이전 릴리즈이더라도 서버의 2022 버전부터 사용권은 1년에 한 번 다시 활성화해야 합니다.

재활성화 날짜로부터 30일 이내에 네트워크의 SOLIDWORKS 제품은 사용자에게 사용권이 만료될 것임을 알립니다. 관리자는 사용권을 기한 내에 다시 활성화하려면 만료일을 알고 있어야 합니다.

SolidNetWork 사용권을 다시 활성화하려면:

  1. 시작 > SOLIDWORKS 도구 버전 > SolidNetWork License Manager Server 버전을 클릭하여 SolidNetWork License Manager Server를 시작합니다.
  2. 서버 관리 탭의 사용권 정보 아래에서 다시 활성화를 클릭합니다.

  3. 제품 번호에서 모든 사용권을 보려면 모두를 선택하거나 사용권 번호를 입력하여 특정 사용권을 검색합니다.

    사용권 재활성화 대화 상자에서 30일 이내의 모든 사용권 만료 및 재활성화 날짜가 빨간색으로 강조 표시됩니다. 별표는 갱신이 필요한 사용권을 표시합니다.

  4. 다시 활성화를 클릭합니다.
상위 주제 SolidNetWork 사용권 설치 개요
SolidNetWork License Manager Server 설치
SolidNetWork 사용권 활성화
SolidNetWork License Manager Server를 사용한 수동 활성화
SolidNetWork License 클라이언트 설치
방화벽이 있는 상태에서 SolidNetWork 네트워크 사용권 사용
트라이어드 사용권 관리자 설치


트라이어드 사용권 관리자 설치

트라이어드 사용권 관리자는 추가적인 안정성을 위해 3대의 컴퓨터를 사용합니다. 사용권 파일을 관리하는 컴퓨터를 사용할 수 없는 경우, 다른 두 개의 컴퓨터 중 하나가 대신합니다.

트라이어드 사용권 관리자를 사용하기 위한 조건:
  • 자주 종료되도록 예약되지 않은 안정적인 컴퓨터에서만 트라이어드 관리자를 설치합니다.
  • 세 개의 사용권 관리자 컴퓨터를 같은 서브네트에 설치해야 하며, 속도가 느리거나 다이얼업 링크를 통해 트라이어드 사용권 관리자를 설정해서는 안됩니다.
  • 시스템 관리자는 사용권 관리자 컴퓨터가 다운될 때를 잘 포착하여 가능한 빨리 서버를 다시 시작해야 합니다.
    두 대의 사용권 관리자 컴퓨터만 실행할 경우 실패가 두 지점에서 일어나기 때문에 단일 사용권 관리자 컴퓨터를 운행하는 것보다 열악한 상황으로 됩니다.

목차

  • 첫 트라이어드 사용권 관리자 설치

    이 절차에서는 트라이어드의 첫 번째 컴퓨터에 SolidNetWork License Manager를 설치하는 방법을 제시합니다.

  • 다음 컴퓨터에서 트라이어드 사용권 관리자 설치

    트라이어드의 두 번째 및 세 번째 컴퓨터에 SolidNetWork License Manager 소프트웨어를 설치하려면 다음 지침을 따릅니다. 이 절차는 첫 번째 컴퓨터에 소프트웨어를 설치하는 절차에서 2(f)단계 및 2(i)단계를 제외하고 거의 동일합니다.

상위 주제 SolidNetWork 사용권 설치 개요
SolidNetWork License Manager Server 설치
SolidNetWork 사용권 활성화
SolidNetWork License Manager Server를 사용한 수동 활성화
SolidNetWork License 클라이언트 설치
방화벽이 있는 상태에서 SolidNetWork 네트워크 사용권 사용
SolidNetWork 사용권 다시 활성화


첫 트라이어드 사용권 관리자 설치

이 절차에서는 트라이어드의 첫 번째 컴퓨터에 SolidNetWork License Manager를 설치하는 방법을 제시합니다.

  1. 첫 번째 트라이어드 사용권 관리자 컴퓨터에서 SOLIDWORKS 설치 관리자를 사용하여 SolidNetWork License Manager를 설치합니다.
    1. 설치 미디어 다운로드에 설명된 대로 SOLIDWORKS 설치 관리자를 시작합니다.
    2. 설치 유형으로 서버 구성 요소 설치를 선택하고 이 컴퓨터에 SolidNetWork License Manager(분산 사용권) 설치를 클릭합니다.
    3. 요약 페이지에서 SolidNetWork License Manager 설치 위치, 다운로드 옵션을 검토하고 지금 설치를 클릭하여 SOLIDWORKS 설치 관리자 프로세스를 완료합니다.
  2. SolidNetWork License Manager를 사용하여 첫 트라이어드 사용권 관리자 컴퓨터를 구성합니다.
    1. SolidNetWork License Manager 시작 시작 > SOLIDWORKS 도구 버전 > SolidNetWork License Manager Server 버전을 클릭합니다.

      이 컴퓨터에서 SolidNetWork License Manager를 처음 실행하는 것이므로 지금 활성화할지 묻는 메시지가 나타납니다.

    2. 아니오를 클릭합니다.

      SOLIDWORKS SolidNetWork License Manager의 서버 관리 탭이 나타납니다.

    3. 서버 관리 탭의 고급 옵션에서 옵션을 클릭합니다.
    4. SolidNetWork Server 사용권 모드 아래에서 사용권 파일 사용을 클릭하고 확인을 클릭합니다.
    5. 사용권 정보에서 수정을 클릭합니다.
      SolidNetWork 사용권 파일 마법사가 나타납니다.
    6. 서버 유형에서 트라이어드을 선택하고 다음을 클릭합니다.
    7. 서버 정보 창에서 첫 트라이어드 사용권 관리자 컴퓨터의 컴퓨터 이름 및 포트 번호가 맞는지 확인하고 다음을(를) 클릭합니다.

      NIC(네트워크 인터페이스 카드) 주소가 SOLIDWORKS로부터 받은 사용권 파일의 정보와 일치하며 트라이어드 사용권 관리자 컴퓨터의 포트 번호가 올바른지 확인합니다. NIC 주소는 MAC(미디어 액세스 제어 주소) 주소라고도 합니다. 확인 후 다음을 클릭합니다.

      NIC 주소를 찾으려면 명령 프롬프트 창을 열고 다음을 입력합니다.

      ipconfig /all

      컴퓨터가 방화벽을 사용하는 경우 이 화면에서 추가 항목도 설정해야 합니다. 자세한 내용은 방화벽이 있는 상태에서 SolidNetWork 네트워크 사용권 사용을 참조하십시오.

    8. 트라이어드 파트너 서버 정보 화면에서 다른 두 트라이어드 사용권 관리자 컴퓨터의 컴퓨터 이름과 호스트 ID 값을 입력하고 다음을 클릭합니다.
      이렇게 하면 하나의 트라이어드 사용권 관리자를 사용할 수 없는 경우 클라이언트 컴퓨터가 다른 두 서버에서 사용권을 가져올 수 있습니다.
    9. 사용권 화면에서 읽기를 클릭하여 SolidNetWork 사용권 파일을 찾아 엽니다.
      사용권이 SolidNetWork License 파일 마법사에 표시됩니다. 이 컴퓨터에서는 공인 리셀러(VAR) 또는 Dassault Systemes의 SOLIDWORKS 고객 지원에서 받은 사용권 파일을 사용합니다.
    10. 마침를 클릭합니다.
    11. 확인을 클릭하여 종료하고 마침을 클릭하여 SolidNetWork License Manager를 닫습니다.
상위 주제 트라이어드 사용권 관리자 설치
다음 컴퓨터에서 트라이어드 사용권 관리자 설치
방화벽이 있는 상태에서 SolidNetWork 네트워크 사용권 사용


다음 컴퓨터에서 트라이어드 사용권 관리자 설치

트라이어드의 두 번째 및 세 번째 컴퓨터에 SolidNetWork License Manager 소프트웨어를 설치하려면 다음 지침을 따릅니다. 이 절차는 첫 번째 컴퓨터에 소프트웨어를 설치하는 절차에서 2(f)단계 및 2(i)단계를 제외하고 거의 동일합니다.

여기에서는 다른 컴퓨터에서 최소 하나의 트라이어드 사용권 관리자를 설치했다는 것을 전제로 합니다.

  1. 트라이어드 사용권 관리자 컴퓨터에서 SOLIDWORKS 설치 관리자를 사용하여 SolidNetWork License Manager를 설치합니다.
    1. 설치 미디어 다운로드에 설명된 대로 SOLIDWORKS 설치 관리자를 시작합니다.
    2. 설치 유형으로 서버 구성 요소 설치를 선택하고 이 컴퓨터에 SolidNetWork License Manager(분산 사용권) 설치를 클릭합니다.
    3. 요약 페이지에서 SolidNetWork License Manager 설치 위치, 다운로드 옵션을 확인하고 지금 설치를 클릭하여 SOLIDWORKS 설치 관리자 프로세스를 완료합니다.
  2. SolidNetWork License Manager를 사용하여 트라이어드 사용권 관리자 컴퓨터를 구성합니다.
    1. SolidNetWork License Manager 시작 시작 > SOLIDWORKS 도구 버전 > SolidNetWork License Manager Server 버전을 클릭합니다.
      해당 컴퓨터에서 SolidNetWork License Manager를 처음으로 실행하는 것이므로 지금 활성화할 지 여부를 묻는 메시지가 나타납니다.
    2. 아니오를 클릭합니다.
      SOLIDWORKS SolidNetwork License Manager의 서버 관리 탭이 나타납니다.
    3. 고급 옵션에서 옵션을 클릭합니다.
      고급 옵션 대화 상자가 나타납니다.
    4. SolidNetWork Server 사용권 모드 아래에서 사용권 파일 사용을 클릭하고 확인을 클릭합니다.
      고급 옵션 대화 상자가 닫힙니다.
    5. 사용권 정보에서 수정을 클릭합니다.
      SolidNetWork 사용권 파일 마법사가 나타납니다.
    6. 서버 유형에서 트라이어드 및 서버/사용권 정보 일치를 선택한 다음 다음을 클릭합니다.
    7. 트라이어드 서버 정보 화면에서 컴퓨터 이름과 호스트 ID 값을 입력합니다. 확인 후 다음을 클릭합니다.
      이렇게 하면 한 개의 사용권 관리자를 사용할 수 없을 경우 클라이언트 컴퓨터가 다른 두 서버에서 사용권을 가져올 수 있습니다.
    8. 사용권 화면에서 읽기를 클릭하여 SolidNetWork 사용권 파일을 찾아 엽니다.
      사용권이 SolidNetWork 사용권 파일 마법사에 표시됩니다.
    사용권 파일은 사용자가 구성한 첫 번째 트라이어드 사용권 관리자 컴퓨터에 의해 생성됩니다. 일반적으로 사용권 파일은 \licenses\sw_d.lic에 있습니다(예: C:\Program Files\SOLIDWORKS SolidNetWork License Manager\licenses\sw_d.lic).
    1. 마침을 클릭합니다.
      SolidNetWork 사용권 파일 마법사 경고가 나타납니다.
    2. 확인을 클릭하여 SolidNetWork 사용권 파일 마법사를 종료한 후 마침을 클릭하여 SolidNetWork License Manager를 종료합니다.

세 번째 트라이어드 사용권 관리자 컴퓨터에 대해서도 이 과정을 반복합니다.

상위 주제 트라이어드 사용권 관리자 설치
첫 트라이어드 사용권 관리자 설치


SolidNetWork License Manager 시작

Windows 시작 메뉴에서 SolidNetWork License Manager를 시작할 수 있습니다.

Windows에서 시작 > SOLIDWORKS 도구 버전 > SolidNetWork License Manager Server 버전을 클릭합니다.

Windows 시작 메뉴에서 같은 경로를 사용하여 SolidNetWork License Manager Client 버전을 열 수 있습니다.

상위 주제 SolidNetWork License Manager를 사용하여 사용권 관리
SolidNetWork 사용권 설치 개요
SolidNetWork License Manager 업그레이드
SolidNetWork 사용권 이동
SolidNetWork 사용권 파일 삭제
SolidNetWork 사용권 차용 및 반환
SOLIDWORKS 버전 액세스 관리
사용권 유휴 시간 추적
임시 사용권 사용
애드인 제품을 포함해 SolidNetWork 사용권 사용
SolidNetWork License로 SOLIDWORKS Simulation 사용권 선택
Flow Simulation 모듈 로드
SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation, SOLIDWORKS Plastics의 비활성 제한 시간 초과
사용권 관리자와 관리 이미지 설치에 같은 컴퓨터 사용
SolidNetWork License Manager 설치 제거
FlexNet Publisher 사용권 관리


SolidNetWork License Manager 업그레이드

SOLIDWORKS 주요 릴리스의 경우 License Manager 업그레이드 과정은 이전 License Manager 제거, 새 License Manager 설치, SolidNetWork License 다시 활성화 과정으로 이루어집니다.

최근 버전의 사용권 관리자는 이전 버전에 남아 있는 클라이언트 컴퓨터에 사용권에 분배할 수도 있습니다.

  1. 시작 > SOLIDWORKS 도구 버전 > SolidNetWork License Manager Server 버전을 클릭하여 SolidNetWork License Manager를 시작합니다.
  2. 사용권 사용 탭에서, 네트워크상에 있는 클라이언트 컴퓨터에서 SOLIDWORKS를 실행하고 있지 않은지 확인합니다.
  3. 이전 사용권 관리자 제거 자세한 내용은 SolidNetWork License Manager 설치 제거의 내용을 참조하십시오.
  4. 사용권 관리자 컴퓨터에서 새 사용권 관리자 설치 및 SolidNetWork License 다시 활성 자세한 내용은 SolidNetWork License Manager Server 설치의 내용을 참조하십시오.

SOLIDWORKS 애플리케이션도 실행하는 컴퓨터에서 SOLIDWORKS License Manager를 업그레이드하려면 해당 컴퓨터에 새 SOLIDWORKS 애플리케이션 서비스 팩을 설치하기 전에 SolidNetWork License Manager와 클라이언트를 업그레이드합니다.

관리 이미지를 호스팅하는 컴퓨터에서 사용권 관리자를 업그레이드할 경우 관리 이미지를 업그레이드하기 전에 사용권 관리자를 업그레이드합니다. 자세한 내용은 사용권 관리자와 관리 이미지 설치에 같은 컴퓨터 사용의 내용을 참조하십시오.

상위 주제 SolidNetWork License Manager를 사용하여 사용권 관리
SolidNetWork 사용권 설치 개요
SolidNetWork License Manager 시작
SolidNetWork 사용권 이동
SolidNetWork 사용권 파일 삭제
SolidNetWork 사용권 차용 및 반환
SOLIDWORKS 버전 액세스 관리
사용권 유휴 시간 추적
임시 사용권 사용
애드인 제품을 포함해 SolidNetWork 사용권 사용
SolidNetWork License로 SOLIDWORKS Simulation 사용권 선택
Flow Simulation 모듈 로드
SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation, SOLIDWORKS Plastics의 비활성 제한 시간 초과
사용권 관리자와 관리 이미지 설치에 같은 컴퓨터 사용
SolidNetWork License Manager 설치 제거
FlexNet Publisher 사용권 관리


SolidNetWork 사용권 이동

SolidNetWork 사용권을 새 컴퓨터나 업그레이드된 컴퓨터로 이동하려면 먼저 사용권을 Dassault Systemes SOLIDWORKS Corporation의 사용권 키 서버에서 비활성화한 후 다른 컴퓨터에서 다시 활성화합니다.

하드 디스크 드라이브 고장 등의 이유로 Dassault Systemes SOLIDWORKS Corporation에 대한 사용권을 비활성화할 수 없더라도 대부분의 경우 재활성화는 성공합니다. 그렇지 않은 경우에는 공인 리셀러에게 도움을 요청하십시오.

SolidNetWork License를 이전하는 방법:

  1. 시작 > SOLIDWORKS 도구 버전 > SolidNetWork License Manager Server 버전을 클릭하여 SolidNetWork License Manager Server를 시작합니다.
  2. 서버 관리 탭의 사용권 정보 아래에서 수정을 클릭합니다. SOLIDWORKS 제품 활성 마법사가 시작됩니다.
  3. 무엇을 하시겠습니까? 아래에서 제품 사용권을 새 컴퓨터/업그레이드된 컴퓨터로 이전을 선택한 후 다음을 클릭합니다.
  4. 제품 번호: 목록에서 제품 번호를 선택하거나 모두 선택을 클릭하여 모든 SOLIDWORKS 제품 번호를 활성화합니다.
    1. 인터넷에서 자동으로 활성페이지 연결 (권장) 옵션을 선택합니다.
    2. 연락처 정보(필수): 아래에서 이메일 주소를 지정합니다.
  5. 비활성화되었습니다라는 메시지 상자가 나타납니다.
    제품 사용권 비활성화가 완료됩니다.
  6. 마침을 클릭합니다.
상위 주제 SolidNetWork License Manager를 사용하여 사용권 관리
SolidNetWork 사용권 설치 개요
SolidNetWork License Manager 시작
SolidNetWork License Manager 업그레이드
SolidNetWork 사용권 파일 삭제
SolidNetWork 사용권 차용 및 반환
SOLIDWORKS 버전 액세스 관리
사용권 유휴 시간 추적
임시 사용권 사용
애드인 제품을 포함해 SolidNetWork 사용권 사용
SolidNetWork License로 SOLIDWORKS Simulation 사용권 선택
Flow Simulation 모듈 로드
SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation, SOLIDWORKS Plastics의 비활성 제한 시간 초과
사용권 관리자와 관리 이미지 설치에 같은 컴퓨터 사용
SolidNetWork License Manager 설치 제거
FlexNet Publisher 사용권 관리


SolidNetWork 사용권 파일 삭제

만료된 SolidNetWork License 파일을 새 사용권으로 업그레이드하기 전에 삭제할 수 있습니다.

  1. 시작 > SOLIDWORKS 도구 버전 > SolidNetWork License Manager Server를 클릭하여 SolidNetWork License Manager를 시작합니다.
  2. 서버 관리 탭의 사용권 정보 아래에서 수정을 클릭하고 다음을 클릭합니다.
  3. SOLIDWORKS 제품 활성화/비활성화 페이지에서 만료된 SolidNetWork License 파일을 선택하고 제거를 클릭합니다.
  4. 마침을 클릭하고 확인을 클릭하여 종료합니다.
상위 주제 SolidNetWork License Manager를 사용하여 사용권 관리
SolidNetWork 사용권 설치 개요
SolidNetWork License Manager 시작
SolidNetWork License Manager 업그레이드
SolidNetWork 사용권 이동
SolidNetWork 사용권 차용 및 반환
SOLIDWORKS 버전 액세스 관리
사용권 유휴 시간 추적
임시 사용권 사용
애드인 제품을 포함해 SolidNetWork 사용권 사용
SolidNetWork License로 SOLIDWORKS Simulation 사용권 선택
Flow Simulation 모듈 로드
SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation, SOLIDWORKS Plastics의 비활성 제한 시간 초과
사용권 관리자와 관리 이미지 설치에 같은 컴퓨터 사용
SolidNetWork License Manager 설치 제거
FlexNet Publisher 사용권 관리


SolidNetWork 사용권 차용 및 반환

SolidNetWork 사용권을 빌려와 원격 위치에서 소프트웨어를 사용할 수 있습니다. 사용 가능한 사용권 풀에서 사용권이 제거되므로 차용된 사용권을 다시 사용할 수 있게 하려면 반환해야 합니다.

차용한 사용권은 차용된 현재 사용자 및 컴퓨터에서만 유효하며 이동할 수 없습니다.

사용권은 지정 기간 동안(최고 30일까지 또는 시스템 관리자가 지정한 기간으로) 대여되고 해당 사용권은 사용권 풀에서 삭제됩니다.

SOLIDWORKS 사용권을 사용하는 경우 사용권의 대여 및 반환은 지원되지 않습니다.

시스템 관리자가 차용(빌려오기)를 사용자 정의해서 할 수 있는 작업:
  • 사용권 빌려주기를 허용할 사용자 또는 그룹 지정
  • 빌려줄 수 없는 사용권 수 설정

자세한 내용은 SolidNetWork_License_Manager_설치_디렉터리\Docs\flexuser\licensingenduserguide.pdf를 참고합니다.

목차

  • SolidNetWork 사용권 차용

  • 차용한 SolidNetWork 사용권 반환

    차용한 SolidNetWork 사용권은 사용 가능한 사용권 풀에서 제거되므로 해당 사용권을 반환하여 다시 사용할 수 있게 해야 합니다.

상위 주제 SolidNetWork License Manager를 사용하여 사용권 관리
SolidNetWork 사용권 설치 개요
SolidNetWork License Manager 시작
SolidNetWork License Manager 업그레이드
SolidNetWork 사용권 이동
SolidNetWork 사용권 파일 삭제
SOLIDWORKS 버전 액세스 관리
사용권 유휴 시간 추적
임시 사용권 사용
애드인 제품을 포함해 SolidNetWork 사용권 사용
SolidNetWork License로 SOLIDWORKS Simulation 사용권 선택
Flow Simulation 모듈 로드
SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation, SOLIDWORKS Plastics의 비활성 제한 시간 초과
사용권 관리자와 관리 이미지 설치에 같은 컴퓨터 사용
SolidNetWork License Manager 설치 제거
FlexNet Publisher 사용권 관리


SolidNetWork 사용권 차용

항상 시작 메뉴에서 SolidNetWork License Manager를 시작합니다. 사용권을 차용하려면 SolidNetWork License Manager에 연결해야 합니다.

이러한 단계는 시스템 설정에 따라 달라질 수 있습니다. 자세한 설명과 옵션은 Microsoft Windows 문서를 참고하십시오.
  1. 클라이언트 컴퓨터에서 시작 > SOLIDWORKS 도구 버전 > SolidNetWork License Manager Client 버전을 클릭하여 SolidNetWork License Manager를 시작합니다.
  2. 사용권 차용 탭에서:
    1. 차용 기간에서 날짜를 선택합니다.
    2. 사용 가능한 제품 사용권에서 차용할 제품을 선택하고 차용을 클릭합니다.
    3. 제품 선택 대화 상자가 나타나면 목록에서 제품을 선택한 다음 확인을 클릭하여 확인합니다.
    4. 대화 상자의 하단에서 새로 고침을 클릭합니다.
      차용 기한 열에 사용권을 반납할 날짜가 표시됩니다.
  3. 확인을(를) 클릭합니다.

사용권 사용 탭에서 총 사용권, 무료 사용권, 사용권 이용자 및 차용 기한 날짜도 볼 수 있습니다.

원격으로 작업하고 SOLIDWORKS 애플리케이션이 열리는 속도가 느린 경우 차용한 사용권만 사용(더 빠른 시작)을 선택합니다.

이 옵션은 사용권 서버에 대한 쿼리를 차단하므로, 일부 환경에서는 속도가 느려질 수 있습니다. 쿼리를 생략하면 애플리케이션을 더 빠르게 시작할 수 있지만 사용자가 차용한 사용권만 사용합니다.

이 옵션을 적용하려면 애플리케이션을 다시 시작하십시오.

상위 주제 SolidNetWork 사용권 차용 및 반환
차용한 SolidNetWork 사용권 반환


차용한 SolidNetWork 사용권 반환

차용한 SolidNetWork 사용권은 사용 가능한 사용권 풀에서 제거되므로 해당 사용권을 반환하여 다시 사용할 수 있게 해야 합니다.

  1. 클라이언트 컴퓨터에서 시작 > SOLIDWORKS 도구 버전 > SolidNetWork License Manager Client 버전을 클릭하여 SolidNetWork License Manager를 시작합니다.
  2. 사용권 차용 탭에서:
    1. 차용된 제품 사용권에서 반환할 제품을 선택하고 반환을 클릭합니다.
    2. 새로 고침을 클릭합니다. 차용 기한 열이 비워져 사용권이 반환되었음을 나타냅니다.
  3. 확인을 클릭합니다.

사용권 사용 탭에서 총 사용권 수를 볼 수도 있습니다.

만료일 이후에 사용권을 반환할 필요는 없습니다. 사용권은 만료일 자정에 SolidNetWork License Manager의 풀로 반환되고 원격 시스템의 애플리케이션은 더 이상 실행되지 않습니다.
상위 주제 SolidNetWork 사용권 차용 및 반환
SolidNetWork 사용권 차용


SOLIDWORKS 버전 액세스 관리

사용자는 SolidNetWork 환경에서 특정 SOLIDWORKS 버전을 사용하지 못하도록 제한할 수 있습니다. 이 기능을 통해 다양한 개인, 프로젝트 및 비즈니스 부서에서 사용되는 SOLIDWORKS 버전을 관리할 수 있습니다.

FlexNet 옵션 파일을 사용하여 SOLIDWORKS 버전에 대한 액세스를 관리하는 방법:

  1. SolidNetWork License Manager 설치 디렉터리에서 텍스트 파일을 작성합니다.
    SolidNetWork_License_Manager_설치_디렉터리\Licenses\sw_d.opt
  2. 사용권 파일에서 특정 SOLIDWORKS 버전에 대한 액세스를 관리하려면 SOLIDWORKS 옆에 다음 구문을 추가합니다.
    :SWVERSION=xx 여기서 xx는 관리하고자 하는 SOLIDWORKS 제품의 버전입니다.
  3. SOLIDWORKS의 여러 버전을 관리하려면 관리하고자 하는 각 버전에 대해 줄을 추가합니다.

    일부 FlexNet 옵션은 지원되지 않습니다. 버전 필터에 지원되는 옵션은 다음과 같습니다.

    INCLUDE | 사용자 또는 그룹이 특정 버전을 시작하는 기능만 사용할 수 있습니다. 다른 모든 사용자는 해당 버전을 시작할 수 없습니다.
    INCLUDE_BORROW | 사용자 또는 그룹이 특정 버전을 차용하는 기능만 사용할 수 있습니다. 다른 모든 사용자는 해당 버전을 차용할 수 없습니다.
    EXCLUDE | 사용자 또는 그룹이 SOLIDWORKS의 특정 버전을 시작하는 것을 금지합니다. EXCLUDE는 INCLUDE에 우선합니다.
    EXCLUDE_BORROW | 사용자 또는 그룹이 SOLIDWORKS의 특정 버전을 차용하는 것을 금지합니다. EXCLUDE는 INCLUDE에 우선합니다.
    예제:
    1 | SWVERSION=32.0 SOLIDWORKS 2025 참조
    SWVERSION=31.0 SOLIDWORKS 2024 참조
    2 | INCLUDE solidworks:SWVERSION=32.0 USER jane
    INCLUDE_BORROW solidworks:SWVERSION=32.0 USER jane
    옵션 파일의 이러한 라인은 jane에게만 SOLIDWORKS 2025 실행을 허용합니다. 다른 모든 사용자는 SOLIDWORKS 2025을 실행하거나 차용할 수 없지만 다른 버전의 SOLIDWORKS는 실행하고 차용할 수 있습니다. jane은 다른 버전의 SOLIDWORKS를 실행하고 차용할 수도 있습니다.
    3 | GROUP chicago USER john robert eva
    EXCLUDE solidworks:SWVERSION=32.0 GROUP chicago
    EXCLUDE solidworks:SWVERSION=31.0 GROUP chicago
    EXCLUDE solidworks USER don
    chicago라는 사용자 GROUP을 정의하고 이들의 SOLIDWORKS 2025와 SOLIDWORKS 2024에 대한 액세스를 거부하지만, 다른 버전의 SOLIDWORKS는 실행할 수 있습니다. 사용자 don은 모든 SOLIDWORKS 버전을 실행할 수 없습니다.
    4 | EXCLUDE swinspection_std:SWVERSION=32.0 HOST machine1
    이 라인은 machine1의 모든 사용자가 SOLIDWORKS Inspection 2025를 실행하는 것을 금지합니다.

    FlexNet에 대한 자세한 내용은 SolidNetWork License Manager 설치 디렉터리의 FlexNet Publisher 사용권 관리 안내서(\Docs\flexuser\fnp_LicAdmin.pdf)를 참조하십시오.

상위 주제 SolidNetWork License Manager를 사용하여 사용권 관리
SolidNetWork 사용권 설치 개요
SolidNetWork License Manager 시작
SolidNetWork License Manager 업그레이드
SolidNetWork 사용권 이동
SolidNetWork 사용권 파일 삭제
SolidNetWork 사용권 차용 및 반환
사용권 유휴 시간 추적
임시 사용권 사용
애드인 제품을 포함해 SolidNetWork 사용권 사용
SolidNetWork License로 SOLIDWORKS Simulation 사용권 선택
Flow Simulation 모듈 로드
SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation, SOLIDWORKS Plastics의 비활성 제한 시간 초과
사용권 관리자와 관리 이미지 설치에 같은 컴퓨터 사용
SolidNetWork License Manager 설치 제거
FlexNet Publisher 사용권 관리


사용권 유휴 시간 추적

SOLIDWORKS는 일정 시간 동안 사용되지 않은 사용권들을 남은 사용권 목록에 되돌려 보낼 수 있도록 SolidNetWork License Manager의 유휴 시간을 등록해주는 옵션이 있습니다.

  1. SolidNetwork License Manager 설치 디렉터리에서 텍스트 파일을 작성합니다.
    SolidNetWork_License_Manager_설치_디렉터리\Licenses\sw_d.opt
  2. 파일에 다음 줄을 추가합니다.
    TIMEOUTALL 초

    여기에서 초는 900(15분) 또는 이 보다 큰 수로, 최대 허용 시간입니다.

상위 주제 SolidNetWork License Manager를 사용하여 사용권 관리
SolidNetWork 사용권 설치 개요
SolidNetWork License Manager 시작
SolidNetWork License Manager 업그레이드
SolidNetWork 사용권 이동
SolidNetWork 사용권 파일 삭제
SolidNetWork 사용권 차용 및 반환
SOLIDWORKS 버전 액세스 관리
임시 사용권 사용
애드인 제품을 포함해 SolidNetWork 사용권 사용
SolidNetWork License로 SOLIDWORKS Simulation 사용권 선택
Flow Simulation 모듈 로드
SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation, SOLIDWORKS Plastics의 비활성 제한 시간 초과
사용권 관리자와 관리 이미지 설치에 같은 컴퓨터 사용
SolidNetWork License Manager 설치 제거
FlexNet Publisher 사용권 관리


임시 사용권 사용

SolidNetWork License를 사용할 수 없을 때 임시 "ANY" 사용권을 사용할 수 있습니다.

기본적으로 SolidNetWork License Manager는 한 번에 하나의 서버만 활성화할 수 있습니다. 테스트 환경에서 작업하려면 기술 지원을 통해 임시 사용권 파일을 얻고 "ANY" 사용권을 다른 서버의 SolidNetWork License Manager에 로드할 수 있습니다. 오프라인 서버로 작업하는 경우 동일한 지침에 따라 활성화 예외 사용권을 로드할 수 있습니다.

"ANY" 사용권 파일을 사용하면 Dassault Systemes SOLIDWORKS Corporation의 SolidNetWork License 수령 시 사용권 구현에 동의하는 것입니다. 사용권 범위 내에서 규격 준수가 여전히 필요합니다.

"ANY" 사용권을 설치하는 방법:

  1. 시작 > SOLIDWORKS 도구 버전 > SolidNetWork License Manager Server 버전을 클릭하여 SolidNetWork License Manager를 시작합니다.
  2. 소프트웨어에서 활성화를 요청하면 아니오를 클릭합니다.
  3. 서버 관리 탭에서 고급 옵션 > 옵션을 클릭합니다.
  4. SolidNetWork Server 라이선스 모드 아래에서 라이선스 파일 사용을 클릭하고 확인을 클릭합니다.
  5. 서버 관리 탭의 사용권 정보 아래에서 수정을 클릭합니다.
    SolidNetWork 사용권 파일 마법사가 나타납니다.
  6. 서버 유형 아래에서 단일을 선택하고 다음을 클릭합니다.
  7. 동글 ID를 선택하거나 서버 정보에 대해 Any 또는 NIC 주소를 입력합니다. 확인 후 다음을 클릭합니다.

    다음 메시지가 표시되면 취소를 클릭합니다. 동글 ID를 읽을 수 없습니다.

    컴퓨터가 방화벽을 사용하는 경우 이 화면에서 추가 항목을 지정해야 할 수 있습니다. 자세한 내용은 방화벽이 있는 상태에서 SolidNetWork 네트워크 사용권 사용을 참고합니다.
  8. 라이선스 아래 읽기를 클릭하여 라이선스 파일을 읽습니다.
  9. 읽기 대화 상자에서 기술 지원에서 제공하는 SNL_ANY.txt 또는 SNL_(NIC Card Number).txt 파일로 이동하여 열기를 클릭합니다. 선택을 마치면 확인을 클릭합니다.
    SolidNetWork 파일 라이선스 마법사는 텍스트 파일에서 라이선스를 나열합니다.
    제거를 클릭하여 목록에서 만료된 임시 라이선스 항목을 삭제합니다.
  10. 마침을 클릭하여 SolidNetWork License 파일 마법사를 닫습니다.
  11. "ANY" 사용권을 활성화하는 방법:
    1. 서버 관리 탭에서 고급 옵션 > 옵션을 클릭합니다.
    2. SolidNetWork Server 사용권 모드 아래에서 사용권 파일 사용을 선택하고 확인을 클릭합니다.
    3. 서버 관리 탭에서 수정 > 제품 사용권 활성화/비활성화를 클릭합니다.
    4. 제품 번호를 선택하고 연락처 정보를 입력한 다음 활성화 방법을 선택합니다. 수동 활성화를 선택하는 경우 지침을 따릅니다.
    5. 마침을 클릭하여 활성화를 확인합니다.
상위 주제 SolidNetWork License Manager를 사용하여 사용권 관리
SolidNetWork 사용권 설치 개요
SolidNetWork License Manager 시작
SolidNetWork License Manager 업그레이드
SolidNetWork 사용권 이동
SolidNetWork 사용권 파일 삭제
SolidNetWork 사용권 차용 및 반환
SOLIDWORKS 버전 액세스 관리
사용권 유휴 시간 추적
애드인 제품을 포함해 SolidNetWork 사용권 사용
SolidNetWork License로 SOLIDWORKS Simulation 사용권 선택
Flow Simulation 모듈 로드
SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation, SOLIDWORKS Plastics의 비활성 제한 시간 초과
사용권 관리자와 관리 이미지 설치에 같은 컴퓨터 사용
SolidNetWork License Manager 설치 제거
FlexNet Publisher 사용권 관리


애드인 제품을 포함해 SolidNetWork 사용권 사용

SolidNetWork License Manager를 사용하여 SOLIDWORKS 주요 애드인 제품의 사용권을 배포할 수 있습니다.

  • SOLIDWORKS 소프트웨어 사용권과 SOLIDWORKS 애드인 사용권의 수가 같지 않아도 됩니다.
  • 애드인 제품의 사용권을 체크아웃하려면, 먼저 SOLIDWORKS의 사용권을 체크아웃해야 합니다.
  • 애드인 제품 사용권을 차용하려면, 애드인을 포함하는 SOLIDWORKS 소프트웨어 사용권과 SOLIDWORKS 제품 사용권을 모두 차용해야 합니다. 기본적으로 SOLIDWORKS Standard 사용권을 빌리지만 애드인을 사용하려면 SOLIDWORKS Professional, SOLIDWORKS Premium 또는 SOLIDWORKS Ultimate 제품 사용권을 빌려야 합니다.
  • 애드인 제품 사용권 릴리즈하기:
    • SOLIDWORKS에서 도구 > 애드인을 클릭하고 해당 애드인을 선택 취소합니다.
    • SOLIDWORKS를 종료합니다.
상위 주제 SolidNetWork License Manager를 사용하여 사용권 관리
SolidNetWork 사용권 설치 개요
SolidNetWork License Manager 시작
SolidNetWork License Manager 업그레이드
SolidNetWork 사용권 이동
SolidNetWork 사용권 파일 삭제
SolidNetWork 사용권 차용 및 반환
SOLIDWORKS 버전 액세스 관리
사용권 유휴 시간 추적
임시 사용권 사용
SolidNetWork License로 SOLIDWORKS Simulation 사용권 선택
Flow Simulation 모듈 로드
SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation, SOLIDWORKS Plastics의 비활성 제한 시간 초과
사용권 관리자와 관리 이미지 설치에 같은 컴퓨터 사용
SolidNetWork License Manager 설치 제거
FlexNet Publisher 사용권 관리


SolidNetWork License로 SOLIDWORKS Simulation 사용권 선택

SolidNetWork 사용권 사용자는 SOLIDWORKS Simulation에 추가할 때 사용권 풀에서 사용할 SOLIDWORKS® Simulation 사용권을 제어할 수 있습니다. 또한 고급 스터디의 상위 사용권 유형이 필요한 경우 추가 기능을 언로드하지 않고도 SOLIDWORKS Simulation 사용권을 업그레이드할 수 있습니다.

  1. 특정 SOLIDWORKS Simulation 사용권을 사용하는 방법
    1. SOLIDWORKS에서 도구 > 애드인을 클릭하고 애드인 대화 상자에서 SOLIDWORKS Simulation을 선택합니다.
    2. SOLIDWORKS Simulation(CommandManager)에서 아래쪽 화살표 [image] 를 클릭하여 Simulation을 지원하는 서버에 사용권 목록을 표시합니다.

    3. 적절한 SOLIDWORKS Simulation 사용권을 선택합니다.
  2. 현재 SOLIDWORKS Simulation 사용권을 확인하거나 변경하려면 SOLIDWORKS Simulation(CommandManager)에서 아래쪽 화살표 [image] 를 클릭합니다.

    사용 중인 사용권에는 확인 표시가 나타납니다. 사용 가능한 고급 사용권 유형이 있는 경우 업그레이드할 수 있습니다.
    SOLIDWORKS Simulation 사용권은 다운그레이드할 수 없습니다. SOLIDWORKS Simulation 애드인을 비활성화하고 하위 수준에서 사용권을 다시 추가합니다.
  3. 옵션: 애드인을 비활성화하려면 SOLIDWORKS Simulation(CommandManager)을 클릭하거나 도구 > 애드인에서 지웁니다.
다음 경우에도 사용권 순서를 사용합니다.
  • SOLIDWORKS Simulation이 실행되기 시작하는 경우
  • SOLIDWORKS Simulation이 도구 > 애드인에 추가되는 경우
  • 풀다운 목록에서 사용권을 지정하지 않고 SOLIDWORKS Simulation을 클릭하는 경우
상위 주제 SolidNetWork License Manager를 사용하여 사용권 관리
SolidNetWork 사용권 설치 개요
SolidNetWork License Manager 시작
SolidNetWork License Manager 업그레이드
SolidNetWork 사용권 이동
SolidNetWork 사용권 파일 삭제
SolidNetWork 사용권 차용 및 반환
SOLIDWORKS 버전 액세스 관리
사용권 유휴 시간 추적
임시 사용권 사용
애드인 제품을 포함해 SolidNetWork 사용권 사용
Flow Simulation 모듈 로드
SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation, SOLIDWORKS Plastics의 비활성 제한 시간 초과
사용권 관리자와 관리 이미지 설치에 같은 컴퓨터 사용
SolidNetWork License Manager 설치 제거
FlexNet Publisher 사용권 관리


Flow Simulation 모듈 로드

SolidNetWork License 고객은 두 가지 방법을 사용하여 Flow Simulation용 HVAC 및 Electronics Cooling 애드인 모듈을 로드하는 방법을 제어할 수 있습니다.

첫 번째 방법을 사용하면 Flow Simulation을 로드할 때 애드인의 기본 동작을 지정할 수 있습니다. 사용 가능한 경우 Flow Simulation 애드인 모듈 자동 로드 옵션은 SolidNetWork License Manager Client > 사용권 순서 탭에 있습니다. Flow Simulation 애드인이 필요하지 않으면 이 옵션을 선택 취소합니다. Flow Simulation이 기존 방법으로 추가되면 HVAC 및 Electronics Cooling 애드인 모듈이 로드되지 않습니다.

두 번째 방법을 사용하면 기본 동작을 무시하고 Flow Simulation을 로드할 때 HVAC 및 Electronics Cooling 애드인 모듈을 포함할 수 있습니다. SOLIDWORKS Flow Simulation에서 아래 화살표 [image] (SOLIDWORKS® 애드인 도구 모음)를 클릭하거나 또는 추가할 애드인 모듈 중 하나 또는 둘 다와 함께 SOLIDWORKS Flow Simulation을 클릭합니다.

이러한 방법을 사용하지 않으면 애드인 모듈의 사용권이 필요 여부에 관계없이 소비되고 네트워크의 다른 사용자의 이용이 거부될 수 있습니다.

상위 주제 SolidNetWork License Manager를 사용하여 사용권 관리
SolidNetWork 사용권 설치 개요
SolidNetWork License Manager 시작
SolidNetWork License Manager 업그레이드
SolidNetWork 사용권 이동
SolidNetWork 사용권 파일 삭제
SolidNetWork 사용권 차용 및 반환
SOLIDWORKS 버전 액세스 관리
사용권 유휴 시간 추적
임시 사용권 사용
애드인 제품을 포함해 SolidNetWork 사용권 사용
SolidNetWork License로 SOLIDWORKS Simulation 사용권 선택
SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation, SOLIDWORKS Plastics의 비활성 제한 시간 초과
사용권 관리자와 관리 이미지 설치에 같은 컴퓨터 사용
SolidNetWork License Manager 설치 제거
FlexNet Publisher 사용권 관리


SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation, SOLIDWORKS Plastics의 비활성 제한 시간 초과

SOLIDWORKS Simulation, Plastics 또는 Flow Simulation 스터디를 실행하면 네트워크 사용권은 활성 상태로 유지되며, 제한 시간은 초과되지 않습니다. SOLIDWORKS는 계산 프로세스 중에 사용권을 보유하며, 이것은 작업으로 간주됩니다.

시간 초과 옵션으로 정의된 비활성 기간은 스터디 계산이 완료된 후에만 적용됩니다.

상위 주제 SolidNetWork License Manager를 사용하여 사용권 관리
SolidNetWork 사용권 설치 개요
SolidNetWork License Manager 시작
SolidNetWork License Manager 업그레이드
SolidNetWork 사용권 이동
SolidNetWork 사용권 파일 삭제
SolidNetWork 사용권 차용 및 반환
SOLIDWORKS 버전 액세스 관리
사용권 유휴 시간 추적
임시 사용권 사용
애드인 제품을 포함해 SolidNetWork 사용권 사용
SolidNetWork License로 SOLIDWORKS Simulation 사용권 선택
Flow Simulation 모듈 로드
사용권 관리자와 관리 이미지 설치에 같은 컴퓨터 사용
SolidNetWork License Manager 설치 제거
FlexNet Publisher 사용권 관리


사용권 관리자와 관리 이미지 설치에 같은 컴퓨터 사용

네트워크에서 컴퓨터 한 대를 구성하여 SolidNetWork 사용권을 배포하는 사용권 관리자와 사용자가 SOLIDWORKS 소프트웨어를 설치할 수 있는 관리 이미지 위치로의 역할을 동시에 할 수 있습니다.

클라이언트 컴퓨터는 같은 컴퓨터에서 사용권 관리자로부터 사용권을 발급받은 후 SOLIDWORKS를 설치할 수 있습니다.

이 구성은 사용권 관리자와 관리 이미지가 같은 컴퓨터에 설치되어야 가능합니다. 먼저 사용권 관리자를 설치한 후 관리 이미지를 작성하고 배포합니다.
자세한 내용은 다음을 참고하십시오.
  • SolidNetWork License Manager Server 설치
  • 여러 클라이언트에 배포
상위 주제 SolidNetWork License Manager를 사용하여 사용권 관리
SolidNetWork 사용권 설치 개요
SolidNetWork License Manager 시작
SolidNetWork License Manager 업그레이드
SolidNetWork 사용권 이동
SolidNetWork 사용권 파일 삭제
SolidNetWork 사용권 차용 및 반환
SOLIDWORKS 버전 액세스 관리
사용권 유휴 시간 추적
임시 사용권 사용
애드인 제품을 포함해 SolidNetWork 사용권 사용
SolidNetWork License로 SOLIDWORKS Simulation 사용권 선택
Flow Simulation 모듈 로드
SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation, SOLIDWORKS Plastics의 비활성 제한 시간 초과
SolidNetWork License Manager 설치 제거
FlexNet Publisher 사용권 관리


SolidNetWork License Manager 설치 제거

SolidNetWork License Manager를 업그레이드할 경우 새 관리자를 설치하기 전에 이전 사용권 관리자를 제거해야 합니다.

  1. 시작 > SOLIDWORKS 도구 버전 > SolidNetWork License Manager Server 버전을 클릭하여 SolidNetwork License Manager를 시작합니다.
  2. 네트워크에서 SOLIDWORKS를 실행하는 컴퓨터가 없도록 합니다.
    사용권 수 탭에 SOLIDWORKS를 실행 중인 클라이언트가 표시됩니다.
  3. SolidNetWork 사용권을 다른 컴퓨터로 이동하려면 SolidNetWork License Manager를 제거하기 전에 해당 컴퓨터의 사용권을 비활성화합니다.
    SolidNetWork 사용권 이동에 관한 자세한 내용은 SolidNetWork 사용권 이동을 참조하십시오.
  4. 서버 관리 탭의 사용권 서버에 있는 정지를 클릭합니다.
  5. 확인을 클릭하여 사용권 관리자를 종료합니다.
  6. Windows에서 제어판 > 프로그램 및 기능을 엽니다.
  7. SOLIDWORKS SolidNetWork License Manager를 선택하고 제거를 클릭한 후 제거를 확인합니다.
  8. 파일 탐색기에서 SOLIDWORKS SolidNetWork License Manager 폴더를 삭제합니다.
    (일반적으로, 이 폴더는 SOLIDWORKS 설치 디렉터리의 Program Files (x86)에 있습니다.)

이제 사용권 관리자 새 버전을 설치할 준비가 됩니다. 자세한 내용은 SolidNetWork License Manager Server 설치를 참조하십시오.

SolidNetWork License Manager 컴퓨터에 하드웨어 동글이 있는 경우, 새 버전의 SolidNetWork License Manager를 설치하기 전에 해당 하드웨어 동글을 제거합니다.
상위 주제 SolidNetWork License Manager를 사용하여 사용권 관리
SolidNetWork 사용권 설치 개요
SolidNetWork License Manager 시작
SolidNetWork License Manager 업그레이드
SolidNetWork 사용권 이동
SolidNetWork 사용권 파일 삭제
SolidNetWork 사용권 차용 및 반환
SOLIDWORKS 버전 액세스 관리
사용권 유휴 시간 추적
임시 사용권 사용
애드인 제품을 포함해 SolidNetWork 사용권 사용
SolidNetWork License로 SOLIDWORKS Simulation 사용권 선택
Flow Simulation 모듈 로드
SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation, SOLIDWORKS Plastics의 비활성 제한 시간 초과
사용권 관리자와 관리 이미지 설치에 같은 컴퓨터 사용
FlexNet Publisher 사용권 관리
SolidNetWork License Manager Server 설치


FlexNet Publisher 사용권 관리

SolidNetWork 사용권은 FlexNet Publisher® 사용권 관리에 기반합니다.

FlexNet Publisher 사용권 관리에 대한 자세한 내용은 SolidNetWork License Manager 설치 디렉터리의 FlexNet Publisher 사용권 관리 안내서(C:\Program Files\SOLIDWORKS SolidNetWork License Manager\Docs\flexuser\fnp_LicAdmin.pdf)를 참조하십시오.

FlexNet Publisher 사용권 관리에 대한 최신 정보는 Flexera® Software에 문의하십시오.

License Server에서 로그를 검토하여 FlexNet 버전을 확인할 수 있습니다. SolidNetwork License Manager 서버를 열고 서버 관리 > 로그 보기 를 클릭합니다. 이 로그는 맨 앞에 괄호로 FlexNet 사용권 버전을 나열합니다.

상위 주제 SolidNetWork License Manager를 사용하여 사용권 관리
SolidNetWork 사용권 설치 개요
SolidNetWork License Manager 시작
SolidNetWork License Manager 업그레이드
SolidNetWork 사용권 이동
SolidNetWork 사용권 파일 삭제
SolidNetWork 사용권 차용 및 반환
SOLIDWORKS 버전 액세스 관리
사용권 유휴 시간 추적
임시 사용권 사용
애드인 제품을 포함해 SolidNetWork 사용권 사용
SolidNetWork License로 SOLIDWORKS Simulation 사용권 선택
Flow Simulation 모듈 로드
SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation, SOLIDWORKS Plastics의 비활성 제한 시간 초과
사용권 관리자와 관리 이미지 설치에 같은 컴퓨터 사용
SolidNetWork License Manager 설치 제거


문제 해결

다음 항목을 참고하여 설치 관련 문제를 해결합니다.

목차

  • 네트워크 저작권 사용

  • SOLIDWORKS 설치 관리자 로그 파일

    SOLIDWORKS 설치 관리자 로그 파일은 설치 문제를 해결하는 데 참조할 수 있습니다.

  • SOLIDWORKS 설치 관리자 다운로드 폴더

    SOLIDWORKS 설치 관리자는 사용자가 지정하는 폴더에 필요한 설치 파일을 다운로드할 수 있습니다. 다운로드 폴더에 관한 FAQ (자주 물어오는 질문)의 답이 이 항목에 제공됩니다.

  • SolidNetWork 사용권 문제 해결

    SolidNetWork License Manager 설치에 실패하면 다음 가능한 설명을 확인해 봅니다.

  • 업그레이드 문제 해결

    SOLIDWORKS 새 버전으로 업그레이드하는 동안 문제가 발생하면 다음과 같은 가능한 설명을 확인합니다.

  • 설치 또는 업그레이드 시 그래픽 카드 확인

    컴퓨터에 SOLIDWORKS 설치 또는 업그레이드를 하고 나면 SOLIDWORKS Rx를 실행하여 컴퓨터에서 지원 그래픽 카드와 그래픽 카드 드라이버가 실행되고 있는지 확인합니다.


네트워크 저작권 사용

서버에 제품 사용권이 없는 경우 이 대화 상자가 열립니다.

모든 제품 선택 항목을 표시하려면 제품 상자의 화살표를 클릭합니다. 선택 항목에는 SOLIDWORKS와 구매 가능한 모든 애드인이 포함됩니다.

총 사용권은 구입한 사용권의 총 수입니다.

무료 사용권은 사용되고 있지 않은 사용권의 수입니다.

사용권 이용자 상자에는 사용권을 이용 중인 각 사용자에 대한 정보가 나타납니다.

상위 주제 문제 해결
SOLIDWORKS 설치 관리자 로그 파일
SOLIDWORKS 설치 관리자 다운로드 폴더
SolidNetWork 사용권 문제 해결
업그레이드 문제 해결
설치 또는 업그레이드 시 그래픽 카드 확인


SOLIDWORKS 설치 관리자 로그 파일

SOLIDWORKS 설치 관리자 로그 파일은 설치 문제를 해결하는 데 참조할 수 있습니다.

이 로그 파일은 다른 SOLIDWORKS 응용 프로그램 로그 파일과 함께 있습니다.

  • C:\Users\username\AppData\Roaming\SOLIDWORKS\Installation Logs\installed_version

시스템 계정에서 설치 관리자를 실행하는 경우 로그는 다음 폴더에 있습니다.
  • C:\Windows\SysWOW64\config\systemprofile\AppData\Roaming\SOLIDWORKS\Installation Logs\installed_version
로그 파일 디렉터리를 보려면 Windows 폴더 옵션을 숨김 파일 및 폴더 표시으로 설정해야 합니다.

애플리케이션 데이터가 C: 드라이브 이외의 드라이브에 있는 경우 디렉터리 경로를 적절히 조정하십시오.

이 디렉터리에는 SOLIDWORKS 설치 관리자 과정의 일반 로그인 SummaryIMLog_nnnnn_nnnnn_nnnn_nnnnn.txt 파일이 포함되어 있습니다.

Other Logs 하위 디렉터리에는 더 상세한 로그 정보가 포함되어 있습니다.

상위 주제 문제 해결
네트워크 저작권 사용
SOLIDWORKS 설치 관리자 다운로드 폴더
SolidNetWork 사용권 문제 해결
업그레이드 문제 해결
설치 또는 업그레이드 시 그래픽 카드 확인


SOLIDWORKS 설치 관리자 다운로드 폴더

SOLIDWORKS 설치 관리자는 사용자가 지정하는 폴더에 필요한 설치 파일을 다운로드할 수 있습니다. 다운로드 폴더에 관한 FAQ (자주 물어오는 질문)의 답이 이 항목에 제공됩니다.

질문 답
이 폴더에 파일을 설치하는 방법은 무엇입니까?

setup.exe을(를) 실행합니다. 이전에 다운로드하지 않은 항목을 설치하기 위해 선택할 경우에도 일부 파일을 다운로드해야 할 수 있습니다.

msiexec를 사용하여 설치하지 마십시오(아래 참조).
msiexec나 일부 다른 응용 프로그램을 사용해서 이 폴더에서 직접 MSI 파일을 설치할 수 있습니까?

아니오. 설치 관리자가 msiexec를 실행할 때 필요한 일부 파일을 다운로드 하지 않습니다.
설치하는 각 버전마다 같은 다운로드 폴더를 선택할 수 있습니까?

다운로드 폴더는 버전에 특정합니다. SOLIDWORKS 설치 관리자는 지정 폴더 안에 버전 특정 하위 폴더를 자동으로 작성합니다.

또한 Dassault Systemes SOLIDWORKS Corporation 웹 사이트에서 일부 제품을 직접 다운로드합니다. 설치 관리자로 그 제품을 설치할 수 있습니까?
SOLIDWORKS 설치 관리자는 수동으로 다운로드한 파일을 사용할 수 있습니다. 그러나 파일을 다운로드하는 옵션을 선택한 상태에서 SOLIDWORKS 설치 관리자를 실행하는 것이 좋습니다. SOLIDWORKS 설치 관리자에 설치하려는 제품에 따라 필요한 파일이 링크와 함께 표시됩니다. (프록시 서버로 적용된 다운로드 한계 때문에) 다운로드 페이지가 작동하지 않을 때 이 옵션을 사용할 수 있습니다.
다운로드 또는 설치 중에 파일을 저장할지 아니면 실행할지 묻는 대화 상자가 나타날 경우 항상 저장을 선택하십시오.
다운로드한 파일을 다른 사용자와 공유할 수 있습니까?

예. 그렇게 하려면 네트워크 공유에 다운로드합니다. 그러면 각 클라이언트가 공유에서 SOLIDWORKS 설치 관리자를 실행해 설치할 수 있습니다.

사용자가 첫 다운로드 중 선택하지 않은 일부 설치 항목을 선택하지 않는 한, 또는 설치할 이 다운로드를 사용하는 컴퓨터가 파일을 다운로드한 컴퓨터와 요구되는 조건이 다를 경우 다운로드가 더 이상 필요하지 않습니다.

다른 사용자 대신해서 다운로드하지만 설치하지 않을 경우 설치 시 다운로드만 옵션을 선택합니다. 이 옵션을 통해 사용자 시스템에 설치 가능한 제품과 관계 없이 제품을 선택할 수 있습니다. 그러나 이 옵션은 패치 다운로드 또는 관리 이미지 작성에 사용할 수 없습니다.
SOLIDWORKS 제품의 새 버전 출시는 어떻게 통보받습니까?
새 버전이 출시되어 통보받는 경우:
  • 업데이트 확인을 실행할 경우(시작 > SOLIDWORKS 설치 관리자 > 업데이트 확인)
  • SolidWorks 백그라운드 다운로더를 활성화한 경우
  • Windows 프로그램 추가/제거에서 설치된 SOLIDWORKS 버전을 선택하고 변경을 클릭하는 경우
  • 다운로드 폴더에서 설치 관리자의 구 버전(sldIM.exe)을 실행하는 경우
이 경우, 새 버전을 선택해서 다운로드할 수 있습니다. SOLIDWORKS 설치 관리자가 설치 파일이 아닌 새 버전 자체를 다운로드하고 실행하게 됩니다. SOLIDWORKS 설치 관리자의 새 버전이 실행된 후, 설치 작업 세트를 선택할 수 있습니다. SOLIDWORKS 설치 관리자는 필요한 설치 파일(전에 다운로드하지 않음)을 확인하고 해당 파일의 다운로드를 제공합니다.
SOLIDWORKS 설치 관리자로 설치할 제품의 다른 서비스 팩을 선택할 수 없는 이유는 무엇입니까?

각 SOLIDWORKS 설치 관리자 버전은 SOLIDWORKS 제품의 특정 버전만 설치하도록 지정되었습니다. 다른 서비스 팩을 설치하려면 해당 버전의 SOLIDWORKS 설치 관리자를 실행해야 합니다. 출시된 최신 버전을 검색하려면 이전 항목을 참고하십시오.
SOLIDWORKS 설치 관리자에서 파일을 다운로드할 수 없는 이유는 무엇입니까?

프록시 서버의 제한 때문에 파일 다운로드를 할 수 없을 경우, SOLIDWORKS 설치 관리자가 파일을 자동으로 다운로드할 수 없습니다.

직접 파일을 다운로드한 다음 SOLIDWORKS 설치 관리자로 설치할 수 있습니다. SOLIDWORKS 설치 관리자에서 옵션을 선택하여 개별 파일을 선택합니다(예: 다운로드 옵션 페이지의 수동 다운로드 방법). 사용자 제품선택 및 시스템 요구사항을 근거로 하는 웹 페이지가 모든 필수 파일을 직접 다운로드하는 링크가 포함된 독립 창에 표시됩니다.
일부 SOLIDWORKS 제품만 최신 서비스 팩으로 업데이트됩니다. 업데이트 확인에서 최신 버전이라고 표시되는 이유는 무엇입니까?

업데이트 확인으로만 SolidWorks 설치 관리자의 최신 버전이 설치되었는지 (또는 실행 중인지) 여부를 알 수 있습니다.

제어판 > 프로그램 > 프로그램 및 기능에 설치된 최신 버전으로 모든 제품을 업데이트하려면 설치된 SOLIDWORKS 최신 버전을 선택하고 변경을 클릭합니다.
DVD를 다운로드 폴더에 복사할 수 있습니까?

예, 해당 플랫폼용으로 릴리즈된 모든 DVD의 모든 콘텐트를 복사하지 않으면 설치에 실패할 수 있습니다. SOLIDWORKS 설치 관리자가 버전을 인식을 위해 파일 swdata*.id를 찾습니다. 이 파일이 없으면 사용자가 복사한 설치 파일을 인식하지 못하며, 다운로드가 필요합니다.
상위 주제 문제 해결
네트워크 저작권 사용
SOLIDWORKS 설치 관리자 로그 파일
SolidNetWork 사용권 문제 해결
업그레이드 문제 해결
설치 또는 업그레이드 시 그래픽 카드 확인


SolidNetWork 사용권 문제 해결

SolidNetWork License Manager 설치에 실패하면 다음 가능한 설명을 확인해 봅니다.

상위 주제 문제 해결
네트워크 저작권 사용
SOLIDWORKS 설치 관리자 로그 파일
SOLIDWORKS 설치 관리자 다운로드 폴더
업그레이드 문제 해결
설치 또는 업그레이드 시 그래픽 카드 확인

SolidNetWork 사용권 로그 파일 액세스

사용권 오류가 있을 때 답이 SNL_Manager_설치_디렉토리\lmgrd.log 파일에 나와 있습니다.

SOLIDWORKS의 사용권을 얻을 수 없습니다. 사용권 서버에 연결할 수 없습니다.

대개, 이 문제는 포트 설정이 원인입니다.

  • SolidNetWork 사용권 관리자와 사용권 클라이언트 사이의 포트 설정이 일치하지 않을 수 있습니다.
  • SolidNetWork 사용권 관리자의 여러 버전의 추가 포트 설정이 지정되어 있지 않을 수 있습니다.
  • 클라이언트 컴퓨터에서 서버 이름을 정확하게 확인하고 해당 서버로 경로를 지정했는지 확인합니다.
SolidNetWork License 관리자와 클라이언트의 포트 설정에 대한 자세한 내용은 방화벽이 있는 상태에서 SolidNetWork 네트워크 사용권 사용을 참고합니다.
방화벽이 있는 상태에서 SolidNetWork 네트워크 사용권 사용


업그레이드 문제 해결

SOLIDWORKS 새 버전으로 업그레이드하는 동안 문제가 발생하면 다음과 같은 가능한 설명을 확인합니다.

상위 주제 문제 해결
네트워크 저작권 사용
SOLIDWORKS 설치 관리자 로그 파일
SOLIDWORKS 설치 관리자 다운로드 폴더
SolidNetWork 사용권 문제 해결
설치 또는 업그레이드 시 그래픽 카드 확인

이동한 원본 수정 또는 복구

SOLIDWORKS가 설치되면 SOLIDWORKS 설치 관리자는 설치 원본(디스크 미디어, 네트워크의 디스크 이미지 등)의 위치를 기억합니다. 수정 또는 복구 시 동일한 위치에서 이 원본을 사용할 수 있어야 합니다.

원본이 이동 또는 삭제되거나 원본 미디어가 변경된 경우, SOLIDWORKS 설치 관리자가 오류 메시지를 생성합니다. 그러나 다른 위치에 같은 파일과 폴더 구조가 들어 있는 경우 그 위치를 찾아서 설치 원본을 수정하거나 복구할 수 있습니다.


설치 또는 업그레이드 시 그래픽 카드 확인

컴퓨터에 SOLIDWORKS 설치 또는 업그레이드를 하고 나면 SOLIDWORKS Rx를 실행하여 컴퓨터에서 지원 그래픽 카드와 그래픽 카드 드라이버가 실행되고 있는지 확인합니다.

설치 또는 업그레이드 시 그래픽 카드를 확인하려면:

  1. 설치 관리자에서 설치를 완료하고 마침 페이지를 표시하면 시스템 검사에서 시스템 진단 실행을 클릭합니다.

    SOLIDWORKS Rx는 진단 프로그램을 시작하고 실행합니다.

  2. SOLIDWORKS Rx를 통해 지원되는 그래픽 카드 및 그래픽 드라이버인지 확인합니다.
    그래픽 카드는 지원되지만 드라이버가 없는 경우 상태 메시지가 드라이버 업데이트에 대한 표시를 제공할 수 있습니다.

SOLIDWORKS를 시작한 지 10회마다 시스템 점검 메시지가 나타나며 시스템 진단을 다시 실행하는 것이 좋습니다. 이러한 알림이 표시되지 않게 하려면 Windows 알림 영역에서 SOLIDWORKS Resource Monitor [image] 를 오른쪽 클릭하고 그래픽 알림 끄기를 클릭합니다.

Windows 알림 영역에서 SOLIDWORKS Resource Monitor를 마우스 오른쪽 버튼으로 클릭하여 언제든지 그래픽 카드와 드라이버를 확인할 수 있습니다. 메뉴를 사용하여 다음을 수행할 수도 있습니다.
  • SOLIDWORKS Resource Monitor의 도움말 액세스
  • 시스템 진단 실행
  • 그래픽 알림 닫기
  • 서브스크립션 알림 닫기
  • 인증된 그래픽 드라이버 보기
상위 주제 문제 해결
네트워크 저작권 사용
SOLIDWORKS 설치 관리자 로그 파일
SOLIDWORKS 설치 관리자 다운로드 폴더
SolidNetWork 사용권 문제 해결
업그레이드 문제 해결


SOLIDWORKS 설치 관리자 응용 프로그램 도움말

SOLIDWORKS 설치 관리자는 SOLIDWORKS 제품을 설치하고 업데이트하는 독립 실행형 애플리케이션입니다.

SOLIDWORKS 설치 관리자는 SOLIDWORKS 소프트웨어를 다운로드, 설치, 수정, 업데이트, 복구 및 제거하기 위한 기본 도구입니다.

다음 방법으로 SOLIDWORKS 설치 관리자를 실행할 수 있습니다.
  • SOLIDWORKS DVD 또는 공유 원본 폴더나 다운로드 폴더 사용(새 버전을 설치하는 경우)
  • 제어판 프로그램 추가/제거 페이지 사용(기존 버전을 수정하거나 제거할 경우)
  • 예약된 업데이트 확인이나 직접 업데이트 확인 이용(새 버전을 찾고 다운로드하고 설치할 경우)

SOLIDWORKS의 각 버전은 해당 SOLIDWORKS 버전에 특정한 SOLIDWORKS 설치 관리자가 있습니다.

목차

  • SOLIDWORKS 백그라운드 다운로더

    SOLIDWORKS 백그라운드 다운로더는 백그라운드 작업을 통해 자동화된 파일 다운로드를 수행하여(예를 들어, 새 서비스 팩 릴리즈를 찾은 경우) 다운로드 작업 동안 다른 작업을 계속할 수 있도록 도와줍니다. 다운로드가 완료되면 지금 설치할지 다운로드를 연기할지 또는 다운로드를 제거할지 결정할 수 있습니다.

  • 설치 관리자에 대한 옵션 지정

    이러한 옵션으로는 로깅, 인터넷 액세스, 설치 관리자에서 사용되는 언어에 대한 설정이 포함됩니다.

  • 업데이트 확인 결과

    업데이트 확인은 SOLIDWORKS의 차기 버전을 확인합니다.

  • 관리 이미지 위치

    관리 이미지의 설치 위치를 지정합니다.

  • 다운로드 옵션

    다운로드 파일 위치, 파일 다운로드 방식, 다운로드 파일 설치 여부와 같은 다운로드 작업 완료에 대한 세부 옵션을 지정합니다.

  • SOLIDWORKS 설치 관리자 파일 다운로드 옵션

    SOLIDWORKS 설치 관리자의 차후 버전을 다운로드하도록 선택했습니다. 이 화면을 사용해서 다운로드되는 위치과 방법을 지정합니다.

  • 제품 설치 파일 다운로드

    특정 제품에 빠진 파일을 다운로드하는 위치과 방법을 지정합니다.

  • 다운로드 진행

    SOLIDWORKS 설치 관리자가 이 절차 중 모든 파일을 동시에 다운로드하고 확인하고 압축을 풉니다.

  • 다운로드 결과

    다운로드 결과가 성공적이었는지, 실패했는지, 취소되었는지 여부를 알려줍니다.

  • 설치 오류/취소된 설치

    설치 시 오류가 발생했거나 취소되었습니다.

  • 설치 완료

    SOLIDWORKS 설치 관리자가 그 과정을 완료했습니다.

  • 설치 위치

  • 업그레이드 옵션

    한 개 이상의 SOLIDWORKS 이전 주요 버전이 해당 컴퓨터에 설치되어 있습니다. 이전 버전과 공존하도록 새 설치를 생성하거나 설치를 업그레이드하여 이전 버전을 제거할 수 있습니다.

  • 설치 진행

    이 화면에 설치 절차가 표시됩니다.

  • 설치 유형

    실행할 설치 작업을 지정할 수 있습니다. 새 설치 생성, 기존 설치 수정 또는 복구, 관리 이미지 작성, 관리 서버 제품 설치 또는 다른 컴퓨터에서 공유 및 설치할 수 있도록 파일 다운로드 등을 예로 들 수 있습니다.

  • 여러 컴퓨터에 설치하고 관리하기

    여러 대의 SOLIDWORKS 컴퓨터에 설치하고 관리하기 위해 SOLIDWORKS 설치 관리자에 다음 도구가 제공됩니다.

  • 수동 다운로드

    파일을 직접 다운로드할 것을 선택했습니다. (또는 마지막으로 SOLIDWORKS 설치 관리자를 실행할 때 수동 다운로드를 선택했습니다.)

  • 최신 버전이 있음

    설치 관리자가 새 SOLIDWORKS 제품을 감지했습니다. 선택으로 원본 설치 DVD나 다운로드에 포함된 버전을 설치하거나, 최신 버전을 다운로드하고 설치할 수 있습니다.

  • 새로운 버전이 없음

    다운로드할 새 버전이 없습니다. 지정된 버전을 계속 설치합니다.

  • 프로세스 감지

    SOLIDWORKS 설치 관리자가 해당 컴퓨터에서 설치를 하지 못하게 하는 프로세스를 감지했습니다.

  • 제품 선택

    설치, 수정, 다운로드 또는 제거할 제품 구성 요소를 지정할 수 있습니다.

  • 다운로드할 제품

    SOLIDWORKS 제품을 선택해서 특정 위치에 다운로드합니다.

  • 복구할 제품

    이 설치 복구하기를 지정할 경우 이 화면에 현 버전의 SOLIDWORKS 설치 관리자로 복구할 수 있는 SOLIDWORKS 제품이 버전 번호와 함께 표시됩니다.

  • 제품 번호

    제품 번호는 사용자의 컴퓨터와 구입한 SOLIDWORKS 제품을 연결합니다.

  • 서버 설치

    설치하려는 서버 제품이 설치 결과와 함께 나열됩니다.

  • 요약

    SOLIDWORKS 설치 관리자에 파일 작업에 필요한 모든 정보가 있습니다.

  • 시스템 검사 경고

    시스템 검사는 설치 과정에 영향을 줄 수 있는 보고된 문제를 검사합니다. 대부분의 경우 SOLIDWORKS 설치 관리자로 진행할 수 있습니다.

  • 구멍 가공 마법사/Toolbox 옵션

    SOLIDWORKS Toolbox를 설치하는 경우 SOLIDWORKS에 구멍 유형과 하드웨어의 규격 라이브러리가 포함됩니다.

  • 제품 설치 제거

    제어판에서 프로그램을 제거 또는 설치 제거하려면 화면에 현재 버전의 SOLIDWORKS 설치 관리자로 제거 가능한 SOLIDWORKS 제품이 버전 번호와 함께 표시됩니다. 표준, 사용자 정의 또는 전체 제거를 수행할 수 있습니다.


SOLIDWORKS 백그라운드 다운로더

SOLIDWORKS 백그라운드 다운로더는 백그라운드 작업을 통해 자동화된 파일 다운로드를 수행하여(예를 들어, 새 서비스 팩 릴리즈를 찾은 경우) 다운로드 작업 동안 다른 작업을 계속할 수 있도록 도와줍니다. 다운로드가 완료되면 지금 설치할지 다운로드를 연기할지 또는 다운로드를 제거할지 결정할 수 있습니다.

SOLIDWORKS 백그라운드 다운로더는 SOLIDWORKS를 설치하면 기본적으로 활성화됩니다.

SOLIDWORKS 설치 관리자가 실행 중일 동안(설치 작업 또는 다운로드 작업) SOLIDWORKS 백그라운드 다운로더가 일시 정지됩니다. 예를 들어, 다운로드가 실행 중이면 새 다운로드를 시작할 수 없게 일시 정지되고 다운로드 폴더 지정을 변경할 수 없습니다.

설치 중에 백그라운드 다운로더를 비활성화할 수 있습니다. 요약 페이지의 다운로드 옵션 아래에서 백그라운드 다운로더를 다음 서비스 팩에 사용합니다 옵션을 선택 취소합니다.

활성화되면 이 아이콘은 도구 모음의 Windows 알림 영역에 나타납니다.

이 아이콘을 클릭하면 다음 작업이 활성화됩니다.
  • 백그라운드 다운로더 도움말
  • 다운로드 일시 정지
  • 다운로드 재개
  • 다운로드 취소
  • 설치 옵션
  • 다운로드 설정 변경
  • 업데이트 확인
  • 업데이트 자동 확인
  • 업데이트 자동 다운로드
  • 백그라운드 다운로더 사용 해제

배경 다운로더 도움말

SOLIDWORKS 설치 안내서에서 백그라운드 다운로더에 대한 이 도움말 항목을 엽니다.

다운로드 일시 정지/계속

다운로드가 백그라운드에서 실행 중인 경우 다운로드 일시 정지를 클릭하여 해당 다운로드를 일시 정지하고 다운로드 재개를 클릭하여 나중에 다시 시작할 수 있습니다.

다운로드 취소

다운로드가 실행 중인 경우 해당 다운로드를 중단하고 백그라운드 다운로드가 이미 다운로드한 파일을 삭제합니다.
취소한 다운로드는 다시 시작할 수 없습니다.

설치 옵션

다운로드가 완료되면 다음 옵션 중에서 선택할 수 있습니다.
  • 지금 설치: 다운로드한 파일을 설치합니다.
  • 나중에 알림: 다운로드한 파일을 설치하지는 않고 나중에 알림 메시지를 설정합니다.
  • 이 다운로드 삭제: 다운로드한 파일을 설치하지 않고 삭제합니다. (다운로드한 파일을 더 이상 설치하지 않기로 한 경우에 유용합니다.)

다운로드 설정 변경

백그라운드 다운로더가 파일을 다운로드할 폴더 위치를 변경합니다.

이 옵션은 다운로드가 실행 중이거나 일시 정지된 상태에서는 사용할 수 없습니다.
업데이트 확인 기간을 지정할 수도 있습니다.

업데이트 확인

SOLIDWORKS 설치 관리자의 업데이트 확인 기능을 실행합니다.

업데이트 자동 확인

업데이트를 다운로드할 수 있는 시점을 알려 주는 업데이트 확인을 정기적으로 실행합니다.

업데이트 자동 다운로드

업데이트를 사용할 수 있게 되면 다운로드하는 업데이트 확인을 정기적으로 실행합니다.

SOLIDWORKS 백그라운드 다운로더 비활성/재활성

Windows 시스템 트레이에서 아이콘을 클릭하고 백그라운드 다운로더 사용 해제를 선택하여 백그라운드 다운로더를 비활성화할 수 있습니다.

백그라운드 다운로더를 다시 활성화하려면 시작 > SOLIDWORKS 설치 관리자 > SOLIDWORKS 백그라운드 다운로더를 클릭합니다.

상위 주제 SOLIDWORKS 설치 관리자 응용 프로그램 도움말


설치 관리자에 대한 옵션 지정

이러한 옵션으로는 로깅, 인터넷 액세스, 설치 관리자에서 사용되는 언어에 대한 설정이 포함됩니다.

소프트웨어를 설치하기 전에 설치 관리자 옵션을 지정하는 방법:

  1. 설치 관리자에서 제목 표시줄에 있는 SOLIDWORKS 아이콘을 오른쪽 클릭하고 다음을 선택합니다.
    옵션 | 설명
    설치 로깅 수준 로깅 수준을 높음, 중간 또는 낮음으로 지정합니다. 수준이 높을수록 문제 해결을 위해 더 많은 데이터를 수집하지만 설치 속도가 느려질 수 있습니다. 낮음(가장 빠름)이 기본값이며, 최상의 성능과 안정성을 제공합니다.

    Windows Installer 로그 작성(느림)은 로그를 다른 설치 로그와 동일한 폴더에 저장합니다.
    관리 이미지 옵션 | 짧은 파일 이름 사용(8.3 형식) 또는 전체 폴더 및 파일 이름 사용을 선택합니다.
    설치 로그 수집 | 설치 로그가 저장되는 위치를 지정합니다. 설치 관리자는 해당 파일을 IM_Logs.zip에 저장합니다.
    인터넷 액세스 사용 안 함
    언어 | 설치 관리자에서 사용되는 언어를 지정합니다. 기본값은 영어입니다.
  2. 닫기를 클릭합니다.
상위 주제 SOLIDWORKS 설치 관리자 응용 프로그램 도움말


업데이트 확인 결과

업데이트 확인은 SOLIDWORKS의 차기 버전을 확인합니다.

컴퓨터에 대한 관리자 권한이 있는 경우 업데이트 확인을 수동으로 실행할 수 있습니다.
  • Windows에서 시작 > SOLIDWORKS 설치 관리자 > 업데이트 확인을 클릭합니다.
  • SOLIDWORKS에서 [image] > 업데이트 확인을 클릭합니다.
관리 이미지로 설치한 클라이언트에서는 업데이트 확인을 사용할 수 없습니다.

새로운 버전이 있음

SOLIDWORKS 설치 관리자가 SOLIDWORKS 제품의 새 버전을 감지했습니다. 해당 버전의 SOLIDWORKS 설치 관리자를 선택하여 새 버전으로 업데이트할 수 있습니다.

이 새 버전은 설치에서 지정한 제품을 기반으로 설치 파일을 다운로드할 수 있습니다. SOLIDWORKS 설치 관리자로 설치하는 다른 사용자와 다운로드한 파일을 공유할 수 있습니다.

이 다운로드는 SOLIDWORKS 설치 관리자로만 할 수 있습니다.
다음 옵션을 사용할 수 있습니다.
  • 사용 가능한 버전이 여러 개인 경우 목록에서 버전을 선택할 수 있습니다.
  • 이 버전에 대한 자세한 내용을 보려면 업그레이드의 내용을 봅니다를 클릭하십시오.
다음을 클릭하면 선택한 버전의 SOLIDWORKS 설치 관리자를 받아 실행합니다.

새로운 다운로드가 없음/새 버전 확인 불가능

최신 버전을 설치하고 있거나 확인할 SOLIDWORKS 사이트에 연결할 수 없기 때문에 SOLIDWORKS 설치 관리자가 SOLIDWORKS 제품의 새 버전을 찾을 수 없습니다.

상위 주제 SOLIDWORKS 설치 관리자 응용 프로그램 도움말


관리 이미지 위치

관리 이미지의 설치 위치를 지정합니다.

관리 이미지를 작성할 경우에는 다음 옵션이 적용됩니다.
새로운 이미지 위치 | SOLIDWORKS 설치 관리자가 새로운 이미지를 작성할 디렉터리 위치입니다. | 이 위치에는 기존 이미지를 포함할 수 없습니다. 관리 이미지는 클라이언트 배포를 위해 공유할 수 있는 폴더에 있어야 합니다.
이미지 작성을 위해 필요한 예상 공간 | 관리 이미지 작성에 필요한 추가 공간입니다. | 설치할 디스크에 이미지 작성 조건에 맞는 충분한 여유 공간이 있는지 확인합니다.
다음으로부터 이미지 작성 | SOLIDWORKS 제품 설치를 실행하는 디렉터리 위치입니다. 이 옵션은 설치만 합니다 옵션을 지정한 경우에만 나타납니다. 자세한 내용은 다운로드 옵션를 참고하십시오.
상위 주제 SOLIDWORKS 설치 관리자 응용 프로그램 도움말


다운로드 옵션

다운로드 파일 위치, 파일 다운로드 방식, 다운로드 파일 설치 여부와 같은 다운로드 작업 완료에 대한 세부 옵션을 지정합니다.

SOLIDWORKS 설치 관리자가 전자 소프트웨어 유통(ESD)을 지원합니다. SOLIDWORKS DVD에서 설치하지 않을 경우, 설치 중인 SOLIDWORKS 제품의 원본을 지정할 것을 묻는 메시지가 받습니다.

다운로드 폴더와 관련된 질문에 대한 답변은 SOLIDWORKS 설치 관리자 다운로드 폴더를 참고하십시오.

어떤 작업을 수행하시겠습니까?

다음 중 하나를 선택합니다.

다운로드 및 설치/다운로드 및 이미지 작성

다운로드가 완료되면 SOLIDWORKS 설치 관리자는 다운로드한 파일을 사용하여 설치를 실행합니다.

다운로드만. 한 번 다운로드를 하면 여러 대의 컴퓨터에서 다운로드한 파일을 공유할 수 있습니다.

SOLIDWORKS 설치 관리자는 다운로드가 완료된 후 설치를 실행하지 않습니다.

대개, 설치 파일 세트를 구성하여 여러 대의 컴퓨터에 공유하기 위해 파일을 다운로드할 경우 이 옵션을 지정합니다.

이 옵션을 지정하면 다운로드할 다음 두 파일 세트 중에서 선택하라는 메시지가 나타납니다.
  • 이 컴퓨터를 위한 파일: 해당 컴퓨터에 현재 있는 설치 파일 세트 중 누락된 파일만 다운로드에 포함됩니다.
    이 세트에는 다음 요소만 포함되므로 상대적으로 크기가 작습니다.
    • 제품 선택 페이지에서 선택한 제품 파일만
    • 컴퓨터에 필요하지만 아직 설치되지 않은 구성 요소만

    그러나, 이 다운로드 파일 세트를 다른 컴퓨터에서 설치하기 위해 사용하면 일부 파일이 누락됩니다(다른 컴퓨터에 유효한 설치 파일 세트와 다를 수 있으므로). 이 다운로드 파일을 다른 컴퓨터에 설치하는 데 사용할 수 있지만 설치를 실행할 때 해당 컴퓨터에 유효한 설치 파일 세트를 완료하기 위해 파일을 추가로 다운로드해야 할 수 있습니다.

  • 모든 컴퓨터와 공유할 파일: 모든 컴퓨터에서 해당 버전을 설치하기 위해 사용할 수 있는 전체 설치 파일 세트가 다운로드에 포함됩니다.

    이 파일은 모든 컴퓨터에서 해당 버전의 모든 제품을 설치할 수 있는 전체 파일 세트가 포함되어 있으므로 다운로드 크기가 큽니다.

    다운로드할 제품 세트를 한정해 지정할 경우 이 옵션은 해당 지정을 무시하고 제품 버전에 포함된 모든 제품을 다운로드합니다.

    다운로드에는 개별 설치를 수행하는 데 필요한 파일만이 아닌, 관리 이미지를 작성하는 데 필요한 모든 파일이 포함됩니다.

설치만 합니다/관리 이미지만 작성합니다. 필요한 설치 파일이 이미 있습니다.

SOLIDWORKS 설치 관리자가 파일을 다운로드하지 않지만 선택한 디렉터리에 있는 파일을 사용합니다.

찾아보기를 클릭하여 다른 위치를 찾습니다. 예를 들어, 필요한 모든 파일이 포함된 위치인 설치 DVD나 다운로드 폴더를 찾아볼 수 있습니다.

폴더가 불완전하다는 오류 메시지가 표시되고 해당 위치에 모든 설치 파일이 있을 것으로 예상되는 경우 가능한 설명은 다음과 같습니다.
  • 이전에 다운로드하지 않은 설치 일부를 선택했거나 기본적으로 선택된 경우
  • 파일이 시스템 필수사항의 다른 세트와 함께 다른 컴퓨터에 다운로드된 경우
  • 클라이언트 설치를 이전에 실행했고, 대형 파일 세트가 필요한 관리 이미지를 현재 작성중인 경우.

모든 파일이 포함된 폴더를 찾아보거나(예: DVD) 다운로드 옵션 중 하나를 선택할 수 있습니다.

필요한 파일을 어디에 다운로드하시겠습니까?

이는 다운로드할 폴더 위치입니다.

경우에 따라 이 옵션이 보이지만 비활성 상태일 수 있습니다. 예를 들어, 설치만 하기를 지정한 경우 SOLIDWORKS 설치 관리자는 별도의 다운로드 폴더를 사용하지 않고 해당 옵션으로 지정된 디렉터리에서 다운로드된 파일을 설치합니다.

이 파일을 다운로드하는 경우나 사용자 위치에서 액세스할 경우 모두, 모든 파일이 반드시 같은 다운로드 폴더에 다운로드되어야 합니다.

예상 다운로드 크기

새 다운로드의 경우나 중단된 이전 세션에서 다운로드를 계속하는지 경우와 상관없이, 예상 다운로드 디스크 공간은 선택한 완전한 구성요소 부품을 기준으로 합니다.

예를 들어, 중단된 이전 다운로드를 계속하면 SOLIDWORKS 설치 관리자가 아직 다운로드되지 않은 파일만을 처리합니다. 다운로드 시간이 예상 시간보다 짧습니다.

파일이 이전 다운로드에서 다운로드가 완료된 경우 그 크기가 이 예상 크기에 포함되지 않습니다. 따라서, 예상 크기가 실제 다운로드 크기보다 클 수 있습니다.

어떤 방법으로 다운로드하시겠습니까?

수동 다운로드 수행

경우에 따라, 프록시 서버로 인해 SOLIDWORKS 설치 관리자가 자동 다운로드를 수행할 수 없습니다.

이 옵션을 선택함으로써, 웹 페이지를 통해 직접 파일을 다운로드한 후 SOLIDWORKS 설치 관리자에서 설치 과정을 완료할 수 있습니다. 이 웹 페이지는 설치 완료에 필요한 파일만 다운로드하도록 SOLIDWORKS 설치 관리자에 의해 사용자 정의됩니다.

SOLIDWORKS 백그라운드 다운로더 사용하기

SOLIDWORKS 백그라운드 다운로더를 사용하여 이 다운로드 작업을 완료하거나, SOLIDWORKS 서비스 팩이 릴리즈될 때마다 이를 다운로드할 수 있습니다.

SOLIDWORKS 백그라운드 다운로더는 새 서비스 팩의 업데이트를 탐지하고 이를 백그라운드에서 자동으로 다운로드합니다. 이때 다운로드 작업 완료 시간과 설치 준비가 된 파일을 알려 주는 메시지가 표시됩니다. 자세한 내용은 SOLIDWORKS 백그라운드 다운로더의 내용을 참조하십시오.

상위 주제 SOLIDWORKS 설치 관리자 응용 프로그램 도움말


SOLIDWORKS 설치 관리자 파일 다운로드 옵션

SOLIDWORKS 설치 관리자의 차후 버전을 다운로드하도록 선택했습니다. 이 화면을 사용해서 다운로드되는 위치과 방법을 지정합니다.

다운로드 폴더와 관련된 질문에 대한 답변은 SOLIDWORKS 설치 관리자 다운로드 폴더를 참고하십시오.

이 화면은 기본 다운로드 폴더에 문제가 있을 경우에만 나타납니다(예를 들어, 쓰기 권한이나 네트워크 권한이 없을 경우). 대개, 다운로드를 계속할 다른 다운로드 디렉터리를 지정할 수 있습니다.

다운로드 디렉터리

SOLIDWORKS 설치 관리자 파일의 대상을 찾아봅니다.

다운로드 크기와 필요한 공간이 표시됩니다. 필요한 공간은 특정 다운로드의 압축 풀기에 필요한 추가 공간을 포함하고 실제 다운로드 크기보다 큽니다.

상위 주제 SOLIDWORKS 설치 관리자 응용 프로그램 도움말


제품 설치 파일 다운로드

특정 제품에 빠진 파일을 다운로드하는 위치과 방법을 지정합니다.

SOLIDWORKS 설치 관리자가 다운로드 중 모든 파일을 동시에 다운로드하고 확인하고 압축을 풉니다.

이 화면을 취소하고 닫으면 남은 설치 작업이 취소됩니다.

취소 결과와 중단된 설치를 완료하는 방법에 대한 지침은 설치 오류/취소된 설치의 내용을 참조하십시오.

다운로드 디렉터리

다운로드된 파일의 대상을 찾아봅니다.

다운로드 크기와 필요한 공간이 표시됩니다. 필요한 공간은 특정 다운로드의 압축을 푸는 데 필요한 추가 공간이며, 실제 다운로드 크기보다 큽니다.

다운로드 폴더와 관련된 질문에 대한 답변은 SOLIDWORKS 설치 관리자 다운로드 폴더의 내용을 참고하십시오.

상위 주제 SOLIDWORKS 설치 관리자 응용 프로그램 도움말
설치 오류/취소된 설치
SOLIDWORKS 설치 관리자 다운로드 폴더


다운로드 진행

SOLIDWORKS 설치 관리자가 이 절차 중 모든 파일을 동시에 다운로드하고 확인하고 압축을 풉니다.

시작한 후 다운로드를 취소하려면 취소를 클릭합니다.

다운로드를 취소하거나 다운로드에 실패할 경우 다운로드 취소됨 또는 다운로드 문제 화면에 완료되지 않은 다운로드가 표시되어 다운로드를 계속하거나 응용 프로그램을 닫을 수 있습니다.

다운로드 폴더와 관련된 질문에 대한 답변은 SOLIDWORKS 설치 관리자 다운로드 폴더를 참고하십시오.
상위 주제 SOLIDWORKS 설치 관리자 응용 프로그램 도움말


다운로드 결과

다운로드 결과가 성공적이었는지, 실패했는지, 취소되었는지 여부를 알려줍니다.

다운로드 문제/다운로드 취소됨

다운로드 문제이(가) 나타나면 SOLIDWORKS 설치 관리자에 다운로드를 완료할 수 없는 문제가 발생한 것입니다.

다운로드 취소됨이 나타나면 다운로드가 완료되기 전에 사용자가 취소한 것입니다.

다운로드 계속하기:

자동 다운로드 다시 시도/계속 진행 | 취소한 부분부터 자동 다운로드를 계속 진행하려면 이 옵션을 선택하고 다운로드 다시 시도 또는 다운로드 계속 진행을 클릭합니다.
웹 브라우저에 파일을 개별 다운로드 | 경우에 따라, 프록시 서버로 인해 SOLIDWORKS 설치 관리자가 자동 다운로드를 수행할 수 없습니다. | 이 옵션을 선택함으로써, 웹 페이지를 통해 직접 파일을 다운로드한 후 SOLIDWORKS 설치 관리자에서 설치 과정을 완료할 수 있습니다. 이 웹 페이지는 설치 완료에 필요한 파일만 다운로드하도록 SOLIDWORKS 설치 관리자에 의해 사용자 정의됩니다.

다운로드 완료

다운로드만 옵션을 지정한 경우 다운로드가 완료되면 다운로드 완료 화면이 나타납니다.

마침을 클릭하여 SOLIDWORKS 설치 관리자를 종료합니다.

다운로드한 제품들을 직접 설치하려 하지 마십시오. 항상 SOLIDWORKS 설치 관리자를 사용하여 다운로드한 파일을 설치합니다.
상위 주제 SOLIDWORKS 설치 관리자 응용 프로그램 도움말


설치 오류/취소된 설치

설치 시 오류가 발생했거나 취소되었습니다.

오류나 취소가 발생되는 경우:
  • 오류나 취소 이전에 설치된 제품이 컴퓨터에 잔류합니다.
  • 가능하다면 취소 시 설치되던 제품을 되돌리며 부분적인 설치가 없게 됩니다.
  • 나머지 제품이 설치되지 않거나 설치 제거됩니다. 아직 시도하지 않았습니다 아래 해당 목록이 표시됩니다.

    해당 제품의 설치를 계속하거나 설치를 제거하려면 표시된 링크를 클릭합니다.

SOLIDWORKS 설치 관리자는 .NET Framework와 같이, 컴퓨터에 설치되지 않은 필수 구성 요소를 먼저 설치합니다.

목차

  • 실패하거나 취소된 설치에서 복구

    설치 중 오류가 발생하거나 설치가 취소된 경우 설치를 다시 실행하여 해당 시점에서 복구할 수 있습니다.

  • 설치 복구

    설치된 SOLIDWORKS 제품에 문제가 있을 경우, SOLIDWORKS 설치 관리자를 사용해서 설치를 복구할 수 있습니다.

  • SOLIDWORKS 리셀러에 문의

    설치의 수정이나 복구에 실패할 경우, 이 화면에서 수집된 정보와 함께 지역 SOLIDWORKS 리셀러에게 문의합니다. SOLIDWORKS 설치 관리자 로그 파일을 zip 파일로 제공해야 할 수도 있습니다.

상위 주제 SOLIDWORKS 설치 관리자 응용 프로그램 도움말


실패하거나 취소된 설치에서 복구

설치 중 오류가 발생하거나 설치가 취소된 경우 설치를 다시 실행하여 해당 시점에서 복구할 수 있습니다.

  1. 설치 오류 또는 설치 취소 화면에 표시된 대로 실패한 설치의 오류 메시지와 제품 코드를 기록합니다.
    원본 파일을 찾는 메시지가 나타나고 기존 SOLIDWORKS 설치를 수정하지 않을 경우 설치나 컴퓨터가 손상될 수 있습니다. SOLIDWORKS 리셀러에게 문의합니다.
  2. 컴퓨터를 다시 시작합니다.
  3. Windows에서 실행되는 SOLIDWORKS 제품이 없는지 확인하려면 Ctr+Alt+Del을 눌러서 작업 관리자를 엽니다.
  4. 프로세스 탭에서 이미지 이름 아래 다음과 같은 프로세스가 나타나면 프로세스 끝내기을(를) 클릭합니다.
    • SLDWORKS.exe
    • EModelViewer.exe
    • PDMworks.exe
    • pdmwVault.exe
    • SWViewer.exe
    • swlmwiz.exe
    • SWBoengine.exe
    • SWVBAServer.exe
    • Sldshellextserver.exe
  5. 응용 프로그램이 이미 설치된 상태에서 수정이나 제거를 하려면 설치 복구를 시도합니다. 자세한 사항은 설치 복구하기를 봅니다.
  6. Windows에서 시작 > 제어판 > 프로그램 및 기능을 클릭합니다.
  7. 실패한 SOLIDWORKS 버전을 선택합니다.
    설치하려는 SOLIDWORKS 버전을 입력하지 않으면 설치 절차를 반복합니다.
  8. 다음 중 하나를 실행합니다.
    • 재시도하려면 변경을 클릭하고 설치 중 설치에 실패하거나 건너뛴 모든 제품을 선택합니다.

    • 실패한 설치를 건너뛰려면, 변경을 클릭하고 설치중 건너뛴 모든 제품을 선택합니다. 설치에 실패한 제품을 선택 취소합니다.

    • 설치를 중단하려면 제거를 클릭하고 설치된 제품을 선택합니다.
    업그레이드 중인 제품의 이전 버전은 복원되지 않습니다.
상위 주제 설치 오류/취소된 설치
설치 복구
SOLIDWORKS 리셀러에 문의


SOLIDWORKS 리셀러에 문의

설치의 수정이나 복구에 실패할 경우, 이 화면에서 수집된 정보와 함께 지역 SOLIDWORKS 리셀러에게 문의합니다. SOLIDWORKS 설치 관리자 로그 파일을 zip 파일로 제공해야 할 수도 있습니다.

  1. 로그 파일을 찾습니다. Windows의 경우:
    C:\Users\사용자 이름\AppData\Roaming\SOLIDWORKS\Installation Logs\설치된_버전\.
    폴더를 찾을 수 없으면 숨겨져 있을 수 있습니다. 파일 탐색기에서 도구 > 폴더 옵션을 클릭합니다. 보기 탭의 고급 설정에서 숨김 파일 및 폴더 에 대해 숨김 파일, 폴더, 드라이브 표시를 선택합니다.
  2. 하위 폴더를 포함하여 이 폴더의 전체 내용을 압축합니다.
상위 주제 설치 오류/취소된 설치
실패하거나 취소된 설치에서 복구
설치 복구


설치 완료

SOLIDWORKS 설치 관리자가 그 과정을 완료했습니다.

다음 옵션 중 하나가 표시됩니다.

새 기능 설명서

개별 설치의 경우, 설치 절차를 완료하면 SOLIDWORKS와 애드인 제품의 새 기능을 설명하는 문서가 나타납니다.

관리 이미지 설치의 경우, 클라이언트 컴퓨터가 설치를 완료하면 같은 문서가 나타납니다.

SOLIDWORKS 고객 피드백 프로그램에 참여

작업 수행 정보를 SOLIDWORKS에 보내면 제품 향상에 도움이 됩니다. 이 절차는 명확하며 기밀로 처리됩니다. 다음 중 하나를 선택합니다.
  • 참여함
  • 참여 안 함
  • 나중에 알림:
자세한 내용은 사용자 환경 개선 프로그램 웹 사이트를 참조하십시오.

관리 이미지 작성이 완료되었습니다

관리 이미지 작성이 완료되면 이미지 사용자 정의를 클릭하여 관리 이미지 옵션 편집기를 실행하여 이미지를 사용자 정의할 수 있습니다.

현재 이미지를 클라이언트에 설치하는 방법을 보여줍니다.를 클릭하여 옵션 편집기 사용에 대한 사용법을 표시합니다.

옵션 편집기를 사용하여 관리 이미지를 설정하는 방법은 관리 이미지 옵션 편집기의 내용을 참조하십시오.

이미지 사용자 정의를 클릭하여 관리 이미지 옵션 편집기를 시작하여 해당 관리자에 대한 옵션 설정을 사용자 정의합니다.
SOLIDWORKS Admin 폴더에서 sldAdminOptionEditor.exe를 두 번 클릭하여 옵션 편집기를 나중에 시작할 수 있습니다.

목차

  • SOLIDWORKS 업데이트 확인

    컴퓨터에 대한 관리자 권한이 있는 경우 SOLIDWORKS 설치 관리자를 사용하여 업데이트를 직접 확인하거나 자동으로 주기적 업데이트를 확인하도록 구성할 수 있습니다.

  • SOLIDWORKS 고객 피드백 프로그램

    SOLIDWORKS를 설치할 때, 제품 향상에 도움이 되도록 작업 수행 정보를 SOLIDWORKS Corporation으로 보내도록 지정할 수 있습니다.

상위 주제 SOLIDWORKS 설치 관리자 응용 프로그램 도움말
관리 이미지 옵션 편집기


SOLIDWORKS 업데이트 확인

컴퓨터에 대한 관리자 권한이 있는 경우 SOLIDWORKS 설치 관리자를 사용하여 업데이트를 직접 확인하거나 자동으로 주기적 업데이트를 확인하도록 구성할 수 있습니다.

  1. 다음 중 한 방법으로 SOLIDWORKS 설치 관리자를 시작합니다.

    • SOLIDWORKS 응용 프로그램에서 도움말 > 업데이트 확인을 클릭합니다.

    • Windows에서 시작 > 프로그램 > SOLIDWORKS 설치 관리자 > 업데이트 확인을 클릭합니다.

    시작 > SOLIDWORKS 설치 관리자 > SOLIDWORKS 백그라운드 다운로더를 클릭할 수도 있습니다. Windows 알림 영역에서 SOLIDWORKS 백그라운드 다운로더를 마우스 오른쪽 버튼으로 클릭하고 업데이트 확인을 클릭합니다.
    SOLIDWORKS 설치 관리자가 사용할 수 있는 업데이트가 있는지 여부를 알려줍니다.
  2. 업데이트가 있을 경우 다운로드해서 설치할 지 여부를 선택합니다.
  3. 자동 주기적 업데이트 확인을 사용하도록 구성한 경우 SOLIDWORKS 설치 관리자가 그 과정을 완료할 때 __일마다 업데이트 확인을 선택하고 확인 빈도를 지정합니다.
상위 주제 설치 완료
SOLIDWORKS 고객 피드백 프로그램


SOLIDWORKS 고객 피드백 프로그램

SOLIDWORKS를 설치할 때, 제품 향상에 도움이 되도록 작업 수행 정보를 SOLIDWORKS Corporation으로 보내도록 지정할 수 있습니다.

이 정보는 SOLIDWORKS가 제품 사용과 품질에 관련된 트렌드를 결정하는 데 사용됩니다. 최고 품질의 제품을 만들고자 하는 목표에 이 성능 로그가 유용한 도구로 사용됩니다.

이 절차에는 숨김이 없습니다. 로그 파일 안에 포함된 모든 정보가 기밀로 취급됩니다. 이 정보는 기타 목적으로 사용되지 않으므로 사용자가 연락을 받는 경우는 없습니다.

자세한 내용은 사용자 환경 개선 프로그램 웹 사이트를 참조하십시오.

상위 주제 설치 완료
SOLIDWORKS 업데이트 확인


설치 위치

관리 이미지 작성을 제외한 설치에서 다음 옵션이 적용됩니다.
선택한 제품 설치 위치 | SOLIDWORKS를 설치하는 디렉터리 위치입니다. 설치를 업그레이드하거나 수정할 경우 해당 설치의 기존 위치에 모든 파일이 설치되어 있어야 합니다. 이 경우 SOLIDWORKS의 기존 설치 위치를 변경할 수 없습니다.
설치에 필요한 예상 디스크 공간 | 설치나 수정하기 위해 선택한 제품에 필요한 추가 공간입니다. | 설치할 디스크에 설치 조건에 맞는 충분한 여유 공간이 있는지 확인합니다.
다음으로 부터 설치 | SOLIDWORKS 설치를 실행하는 디렉터리 위치입니다. 이 옵션은 설치만 합니다 옵션을 지정한 경우에만 나타납니다. 자세한 내용은 다운로드 옵션을 참조하십시오.
SOLIDWORKS 설치 위치를 변경하기 전에 시스템 관리자에 문의하십시오.

관리 이미지 위치

관리 이미지를 작성할 경우에는 다음 옵션이 적용됩니다.
새로운 이미지 위치 | SOLIDWORKS 설치 관리자가 새로운 이미지를 작성할 디렉터리 위치입니다. | 이 위치에는 기존 이미지를 포함할 수 없습니다.
이미지 작성을 위해 필요한 예상 공간 | 관리 이미지 작성에 필요한 추가 공간입니다. | 설치할 디스크에 이미지 작성 조건에 맞는 충분한 여유 공간이 있는지 확인합니다.
다음으로부터 이미지 작성 | SOLIDWORKS 제품 설치를 실행하는 디렉터리 위치입니다. 이 옵션은 설치만 합니다 옵션을 지정한 경우에만 나타납니다. 자세한 내용은 다운로드 옵션을 참조하십시오.
기존 이미지 위치 | 기존 관리 이미지를 업그레이드할 경우 SOLIDWORKS 설치 관리자는 기존 이미지의 설정을 기반으로 새로운 이미지를 작성합니다. 이 기존 이미지는 수정되지 않습니다. 시작 화면에서 지정한 원본 이미지의 위치가 표시됩니다.

특정 버전 디렉터리 경로 사용하지 않기

설치 디렉터리 위치(예: C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS 2023\)에 버전 번호를 지정한 다음 해당 설치를 SOLIDWORKS 2024로 업그레이드하면 SOLIDWORKS 2023으로 표시된 SOLIDWORKS 2024 설치 디렉터리가 생성됩니다.

상위 주제 SOLIDWORKS 설치 관리자 응용 프로그램 도움말
다운로드 옵션


업그레이드 옵션

한 개 이상의 SOLIDWORKS 이전 주요 버전이 해당 컴퓨터에 설치되어 있습니다. 이전 버전과 공존하도록 새 설치를 생성하거나 설치를 업그레이드하여 이전 버전을 제거할 수 있습니다.

SOLIDWORKS 버전의 새 설치를 생성합니다.

새 설치를 생성하려는 경우 설치할 SOLIDWORKS 제품을 선택할 수 있습니다.

선택한 각 제품에 대해 이 주요 버전의 새 설치가 생성됩니다. SOLIDWORKS Electrical 및 SOLIDWORKS PDM Client를 제외한 이전 주요 버전은 컴퓨터에 남아 있습니다.

제품을 선택 취소하면 새 버전이 설치되지 않습니다.

새 설치 생성은 최신 버전을 설치한 후 SOLIDWORKS의 이전 버전에 액세스하려는 경우에 유용합니다. 예를 들어, 이전 버전을 실행하는 다른 사용자와 파일을 공유하는 경우 최신 버전을 사용하여 저장한 파일과 버전이 호환되지 않는 문제를 피할 수 있습니다.

SOLIDWORKS previous_major_version을 SOLIDWORKS current_major_version으로 업그레이드.

업그레이드하려는 경우 업그레이드할 SOLIDWORKS 제품을 선택할 수 있습니다. 선택한 각 제품에 대해 새 설치가 생성되고 이전 버전은 제거됩니다.

제품을 선택 취소하면 새 버전은 설치되지 않으며 이전 버전은 컴퓨터에 남아 있습니다.

SOLIDWORKS Electrical 및 SOLIDWORKS PDM 클라이언트에 대한 고려 사항

한 컴퓨터에 SOLIDWORKS Electrical의 한 버전만 설치할 수 있습니다. SOLIDWORKS의 새 설치를 생성하는 경우 설치할 제품 중 하나로 SOLIDWORKS Electrical을 선택하면 SOLIDWORKS Electrical의 이전 버전이 제거됩니다.

새 버전을 설치하기 전에 기존 SOLIDWORKS Electrical 환경을 백업하십시오. SOLIDWORKS Electrical Schematic에서 파일 환경 압축을 선택하거나 SOLIDWORKS Electrical 3D에서 SOLIDWORKS Electrical > 도구 > 환경 압축을 선택합니다.

SOLIDWORKS PDM 클라이언트의 주요 버전은 SOLIDWORKS PDM 서버의 주요 버전과 동일해야 합니다. SOLIDWORKS PDM 서버를 업그레이드하지 않으려는 경우 업그레이드할 때 SOLIDWORKS PDM 클라이언트를 선택하지 않습니다.

Windows에서 제품을 제거하려면 프로그램 추가/제거를 사용합니다. 자세한 내용은 설치 제거의 내용을 참조하십시오.
상위 주제 SOLIDWORKS 설치 관리자 응용 프로그램 도움말
설치 제거


설치 진행

이 화면에 설치 절차가 표시됩니다.

시작한 후 설치를 취소하려면 취소를 클릭합니다.

취소 결과와 중단된 설치를 완료하는 방법에 관한 자세한 내용은 설치 오류을(를) 참조하십시오.

상위 주제 SOLIDWORKS 설치 관리자 응용 프로그램 도움말


설치 유형

실행할 설치 작업을 지정할 수 있습니다. 새 설치 생성, 기존 설치 수정 또는 복구, 관리 이미지 작성, 관리 서버 제품 설치 또는 다른 컴퓨터에서 공유 및 설치할 수 있도록 파일 다운로드 등을 예로 들 수 있습니다.

최신 버전의 SOLIDWORKS 소프트웨어가 이미 컴퓨터에 설치되어 있으면 이를 수정하거나 복구하기 위한 옵션이 제공됩니다.

개별 설치

이 컴퓨터에 SOLIDWORKS 제품을 설치합니다.

이 옵션은 이 버전이 이 컴퓨터에 설치되어 있지 않은 경우에만 나타납니다.

개별 설치 수정

해당 컴퓨터에서 기존 SOLIDWORKS 설치를 수정합니다.

이 옵션은 이 버전이 이 컴퓨터에 설치되어 있는 경우에만 나타납니다.
수정 작업:
  • SOLIDWORKS 제품 구성 요소 추가 또는 제거
  • 다른 SOLIDWORKS 패키지(예: SOLIDWORKS Professional, SOLIDWORKS Premium, SOLIDWORKS Ultimate 등)로 변경
  • SOLIDWORKS 제품 번호 설정 변경
    이전 설치 중에 SOLIDWORKS 제품 번호를 이미 지정한 경우 SOLIDWORKS 설치 관리자가 다시 표시되지 않습니다. 제품 번호를 변경하려면 이 옵션을 선택해야 합니다.

개별 설치 복구

해당 컴퓨터에서 기존 SOLIDWORKS 설치를 복구합니다.

이 옵션은 이 버전이 이 컴퓨터에 설치되어 있는 경우에만 나타납니다.
복구는 모든 파일이 있으며 제대로 등록되었는지 확인하고 발견된 모든 문제를 해결합니다. 작성한 데이터는 영향을 받지 않습니다.
  • 제품을 복구하려면 선택이 되었는지 확인합니다.
  • 복구로 불필요한 제품의 확인란을 선택 취소합니다.
개별 설치를 복구할 수 있습니다. 관리 이미지 설치는 복구할 수 없습니다. 관리 이미지를 사용하여 다시 설치해야 합니다.

관리 이미지

여러 컴퓨터에 배포할 관리 이미지를 작성하거나 업데이트합니다.

관리 이미지를 사용하여 여러 클라이언트에 SOLIDWORKS를 설치하는 데 대한 내용은 관리 이미지 사용을 참조하십시오.

관리 이미지를 작성하거나 업데이트할 경우:
  • 기존 이미지의 설치 설정을 사용하여 새 이미지나 업데이트된 이미지를 구성하거나 SOLIDWORKS 기본 설치 설정을 사용할 수 있습니다.
  • 기존 이미지를 업데이트할 경우:
    • 업데이트하는 경우라도 SOLIDWORKS 설치 관리자가 새 이미지 복사본을 작성합니다. 원본 이미지는 수정되지 않습니다.
    • 업데이트하는 기존 이미지의 파일을 사용하여 업데이트된 이미지를 작성할 수 있습니다. 이렇게 하면 다운로드 크기가 작아집니다.
    이전 이미지를 업데이트하는 데 사용할 서비스 팩 버전의 이미지를 지정하지 않을 경우 크기를 줄이는 이점을 취할 수 없습니다.

서버 제품

SOLIDWORKS 서버 제품으로는 SOLIDWORKS Electrical, SOLIDWORKS PDM 및 SolidNetWork License Manager 등이 있습니다.

SOLIDWORKS Electrical 및 SOLIDWORKS PDM의 경우, 같은 컴퓨터나 다른 컴퓨터에 클라이언트 및 서버 도구를 설치할 수 있습니다.

이러한 서버 설치에 대한 자세한 내용은 도움말의 해당 항목을 참조하십시오.

모든 파일 다운로드 및 공유

제품을 설치하지 않고 선택한 SOLIDWORKS 제품의 설치 파일을 다운로드합니다.

이 옵션은 DVD에서 설치하는 경우 사용할 수 없습니다.
다운로드한 파일의 내용이 SOLIDWORKS 설치 DVD에 있는 파일과 동일합니다. 이 옵션을 선택하면 사용자 컴퓨터에 이미 설치된 파일과 상관없이 설치 파일의 정품 세트를 다운로드합니다. 그러면 파일을 휴대용 장치나 네트워크 디렉터리에 복사하고 이를 사용하여 다른 컴퓨터에 SOLIDWORKS 소프트웨어를 설치할 수 있습니다. 이 방법으로 사용자가 설치를 수행할 수 있는 서버를 설정할 수도 있습니다.
이 방법은 관리 이미지 작성과는 다릅니다.
상위 주제 SOLIDWORKS 설치 관리자 응용 프로그램 도움말
관리 이미지 사용
SolidNetWork License Manager를 사용하여 사용권 관리
SOLIDWORKS Electrical


여러 컴퓨터에 설치하고 관리하기

여러 대의 SOLIDWORKS 컴퓨터에 설치하고 관리하기 위해 SOLIDWORKS 설치 관리자에 다음 도구가 제공됩니다.

SOLIDWORKS 관리 이미지

여러 대 컴퓨터에 SOLIDWORKS를 설치할 경우, 관리 이미지를 사용한 다음 다른 컴퓨터로 응용 프로그램을 배포할 수 있습니다.

SOLIDWORKS PDM

SOLIDWORKS PDM은 SOLIDWORKS Enterprise PDM과 동일한 클라이언트/서버 아키텍처를 기반으로 하는 문서 관리 제품입니다. 다음 2가지 버전으로 제공됩니다. Standard 및 Professional. SOLIDWORKS PDM은 Microsoft SQL Server 데이터베이스를 사용하여 파일 볼트를 관리합니다.

SolidNetWork License Manager

SolidNetWork License Manager로 사용권을 부동화하면 사용자 수가 사용권 수를 초과되는 것이 허용됩니다. 클라이언트 사용권을 사용하고 있지 않으면 다른 SOLIDWORKS 사용자가 사용할 수 있습니다.

SolidNetWork License Manager를 사용해서 FeatureWorks 등과 같은 SOLIDWORKS 주요 애드인 제품의 사용권을 배포할 수도 있습니다.

상위 주제 SOLIDWORKS 설치 관리자 응용 프로그램 도움말


수동 다운로드

파일을 직접 다운로드할 것을 선택했습니다. (또는 마지막으로 SOLIDWORKS 설치 관리자를 실행할 때 수동 다운로드를 선택했습니다.)

해당 링크를 클릭하여 다운로드를 완료하는 데 필요한 전체 파일 목록이 포함된 자동으로 생성된 웹 페이지를 엽니다.

요약 페이지에서 지정한 폴더에 다운로드해야 합니다. 모든 파일이 해당 폴더에 다운로드되기 전까지는 설치를 시작할 수 없습니다.

수동 다운로드를 완료하고 나면 다음을 클릭하여 계속합니다.

자동으로 다운로드하려는 경우 요약 페이지로 돌아가 다운로드 옵션을 변경하여 옵션을 변경할 수 있습니다.

상위 주제 SOLIDWORKS 설치 관리자 응용 프로그램 도움말


최신 버전이 있음

설치 관리자가 새 SOLIDWORKS 제품을 감지했습니다. 선택으로 원본 설치 DVD나 다운로드에 포함된 버전을 설치하거나, 최신 버전을 다운로드하고 설치할 수 있습니다.

다운로드에서 설치할 경우

다음 중 하나를 선택합니다.
  • 버전 설치 계속.

    초기 다운로드에 포함된 버전을 계속 설치하려면 이 옵션을 선택합니다.

  • 새 버전 다운로드 및 설치: 버전.

    새 버전을 다운로드하여 설치하려면 이 옵션을 선택합니다. 새 버전이 여러 개일 경우 다운로드하고 설치할 버전을 선택할 수 있습니다.

DVD에서 설치할 경우

최신 버전을 사용하시겠습니까? 아래에서 다음 중 하나를 선택합니다.
  • 아니요, 이 DVD에서 버전을(를) 계속 설치합니다. 나중에 업데이트할 수 있습니다.

    이 옵션을 선택해서 현재 설치 관리자로 설치를 계속합니다.

    설치완료 후, 설치 관리자를 사용해서 업데이트를 확인하고 설치할 수 있습니다. 업데이트를 확인하려면 시작 > SOLIDWORKS 설치 관리자 > 업데이트 확인을 실행합니다.
    업데이트 확인은 컴퓨터에 대한 관리자 권한이 있는 경우에만 사용 가능합니다.

    이 방식의 장점은 다운로드 크기가 작다는 것입니다. 단점은 2단계 프로세스이고 다운로드 파일이 특정 버전에 속한다는 점입니다(다른 버전을 사용하는 다른 사용자와 공유가 불가능합니다).

  • 예, 이 DVD를 사용하여 설치한 후 다운로드하여 버전으로 업데이트합니다.

    이 옵션을 선택하면 설치 관리자의 차후 버전을 다운로드하고 실행하고 해당 버전의 SOLIDWORKS 제품이 설치됩니다.

    DVD 버전을 업데이트하는 작은 서비스 팩 버전이 있을 경우 설치 관리자는 DVD에서 원본 버전을 설치한 후 서비스 팩 업데이트를 적용합니다. 이렇게 하면 다운로드 크기가 작아집니다.

    DVD에서 설치를 계속한 후 나중에 업데이트를 적용하는 옵션을 선택하여 같은 결과를 얻을 수 있습니다.

    이 옵션의 이점은 한 단계로 이루어진다는 점입니다.

상위 주제 SOLIDWORKS 설치 관리자 응용 프로그램 도움말


새로운 버전이 없음

다운로드할 새 버전이 없습니다. 지정된 버전을 계속 설치합니다.

설치를 계속하려면 다음을 클릭합니다.

상위 주제 SOLIDWORKS 설치 관리자 응용 프로그램 도움말


프로세스 감지

SOLIDWORKS 설치 관리자가 해당 컴퓨터에서 설치를 하지 못하게 하는 프로세스를 감지했습니다.

  • SolidWorks 설치를 계속하려면 다음 중 하나를 실행합니다.
    • 관련 프로세스(예: Microsoft Windows 작업 관리자 사용)를 닫은 후 재시도를 누릅니다.
    • 프로세스를 닫지 않고 계속하려면 무시를 클릭합니다.
  • 설치를 중단하려면 취소를 누릅니다.
상위 주제 SOLIDWORKS 설치 관리자 응용 프로그램 도움말


제품 선택

설치, 수정, 다운로드 또는 제거할 제품 구성 요소를 지정할 수 있습니다.

제품 목록에서:
  • 제품 목록은 위에서 지정한 제품 목록에 나타나는 전체 제품 목록입니다.
  • 특정 구성 요소에 대해 적용되는 작업을 보려면 확인란이 아닌, 구성 요소 이름을 클릭합니다. 계획된 설치 작업이 제품 목록 아래 정보 필드에 나타납니다.
  • 제품 구성 요소 옆에 있는 확인란을 클릭하여 해당 구성 요소에 대한 설치 작업을 변경할 수 있습니다. (예를 들어, 구성 요소를 설치하거나 제거할 경우 해당 확인란을 선택하면 구성 요소가 설치되거나 제거되도록 지정되고 확인란을 선택 취소하면 구성 요소가 설치되거나 제거되지 않도록 지정됩니다.)
  • 설치 수정을 수행하는 경우 제품 선택을 변경하면 구성 요소 왼쪽에 별표(*)가 나타납니다.
  • 구성 요소에 설치 하위 구성 요소 선택 항목이 포함되어 있으면 해당 구성 요소 옆에 + 아이콘이 표시됩니다. 구성 요소에 포함된 하위 구성 요소를 보려면 + 아이콘을 클릭합니다.
  • 하위 구성 요소 선택 항목이 보이게 구성 요소가 확장되어 있으면 해당 구성 요소 옆에 - 아이콘이 표시됩니다. 하위 구성 요소 목록을 축소하려면 - 아이콘을 클릭합니다.

서비스 팩을 적용하는 경우 SOLIDWORKS 아래에 나타나는 SOLIDWORKS 기능(예: FeatureWorks)을 선택할 수 없습니다. 이 업그레이드 유형을 실행할 때 구성요소를 추가하거나 제거할 수 없기 때문입니다.

SOLIDWORKS 설치 관리자로 실행한 작업은 제품 공존 규칙 세트로 제어됩니다. 자세한 내용은 제품 공존 규칙의 내용을 참조하십시오.

SOLIDWORKS 설치 관리자는 기본적으로 다음 제품 구성 요소를 선택합니다.
  • 업그레이드 또는 Service Pack 업데이트를 수행하는 경우 SOLIDWORKS 설치 관리자가 현재 설치된 제품을 선택합니다.
  • 그렇지 않으면, SOLIDWORKS 설치 관리자 사용할 수 있는 모든 제품을 선택합니다.
설치 또는 다운로드 시간과 필요한 디스크 공간을 줄이려면 제품 구성 요소를 확장하고 필요치 않은 구성 요소에 해당하는 확인란을 선택 취소합니다.

SOLIDWORKS 설치 관리자로 사용자가 받을 수 있는 제품을 확인할 수 없을 경우 다른 패키지나 제품을 선택합니다를 클릭하여 설치하거나 수정할 SOLIDWORKS 패키지(SOLIDWORKS Professional, SOLIDWORKS Premium 또는 SOLIDWORKS Ultimate)를 변경할 수 있습니다. 사용자가 선택한 패키지와 호환 가능한 설치 미디어의 SOLIDWORKS 제품 모두가 SOLIDWORKS 설치 관리자에 나열됩니다. 구입하거나 평가하기 위해 받은 제품을 선택할 수 있습니다.

SOLIDWORKS 검색

SOLIDWORKS 검색은 SOLIDWORKS 문서의 강력한 전체 텍스트 검색 기능을 제공합니다. 검색이 미리보기와 파일 위치와 이름을 표시합니다.

설치 후 SOLIDWORKS 검색이 신속한 검색을 위해 SolidWorks 문서를 색인합니다. SOLIDWORKS 파일만이 기본적으로 색인됩니다.

언어 지원

SOLIDWORKS 제품과 언어 구성 요소를 확장하면 사용자가 설치할 수 있는 언어가 표시됩니다.

언어 스펙에 따라 SOLIDWORKS 제품에만 설치되는 언어가 제한됩니다. 이 때 SolidWorks가 아닌 타 제품의 경우 해당 언어 지정 설치에 영향을 받지 않습니다. 예를 들어 eDrawings® 및 SOLIDWORKS PDM 설치 시 모든 언어가 설치됩니다.

필요한 공간

SOLIDWORKS 설치 관리자가 페이지 하단에 총 설치 크기나 총 다운로드 크기를 보고합니다.

  • 다운로드만 옵션을 선택할 경우 다운로드 크기가 나타납니다. 다운로드 크기가 모든 다운로드 파일에 필요한 총 디스크 공간을 의미합니다(다운로드 완료 후 파일 압축을 풀 때 추가 필수 공간 제외). 이 값은 추정값입니다.
    설치에 필요한 모든 파일이 총 다운로드 크기에 포함됩니다. 일부 파일이 현재 다운로드 폴더로 이미 다운로드된 경우 이러한 파일은 다시 다운로드되지 않습니다. 결과적으로, 실제 다운로드 크기가 표시된 총 다운로드 크기보다 작거나 파일을 다운로드하지 않아도 됩니다.
  • 그렇지 않으면 설치 크기가 나타납니다. 설치크기란 이 설치를 완료할 때 일어나는 디스크 공간 사용의 변경사항을 의미합니다. 파일 압축으로 인해 이 값은 추정값입니다.

    기존 설치를 업그레이드하거나 제거하려면 이 설치 크기는 0입니다.

    설치에 필요할 경우 표시된 수에 다운로드에 필요한 공간이 포함되지 않습니다.

    다운로드가 필요하고 같은 드라이브로 다운로드 하는 경우, 실제 필요한 디스크 공간이 표시되는 설치 크기보다 눈에 띄게 클 수 있습니다.

    차후 수정에서 다운로드와 설치 시간을 줄이려면, 설치후 다운로드 파일을 삭제합니다. 일반적으로 결과 업데이트와 패치를 하려면 마지막 정품 설치 파일 세트에 권한이 있어야 합니다.

상위 주제 SOLIDWORKS 설치 관리자 응용 프로그램 도움말
제품 공존 규칙


다운로드할 제품

SOLIDWORKS 제품을 선택해서 특정 위치에 다운로드합니다.

다운로드 가능한 제품은 사용자가 제공하는 제품 번호로 결정됩니다:

  • 개별 부품에 실행할 작업이 각 항목의 오른쪽 나타납니다.
  • 구성 요소에 설치 하위 구성 요소 선택 항목이 포함되어 있으면 해당 구성 요소 옆에 + 아이콘이 표시됩니다. 구성 요소에 포함된 하위 구성 요소를 보려면 + 아이콘을 클릭합니다.
  • 하위 구성 요소 선택 항목이 보이게 구성 요소가 확장되어 있으면 해당 구성 요소 옆에 - 아이콘이 표시됩니다. 하위 구성 요소 목록을 축소하려면 - 아이콘을 클릭합니다.
  • 각 구성 요소의 왼쪽에 있는 확인란을 클릭해서 SOLIDWORKS 설치 관리자의 취급 방식을 선택합니다.
지정하지 않는 한 SOLIDWORKS 설치 관리자는 받을 수 있는 모든 제품 구성 요소를 다운로드합니다. 다운로드 시간과 필요한 디스크 공간을 줄이려면 제품 구성 요소를 확장하고 필요하지 않은 구성 요소만 선택합니다.

SOLIDWORKS 설치 관리자로 사용자가 받을 수 있는 제품을 확인할 수 없을 경우, 다운로드할 SOLIDWORKS 패키지를 선택할 수 있습니다. 사용자가 선택한 패키지와 호환 가능한 SOLIDWORKS 제품 모두가 SOLIDWORKS 설치 관리자에 나열됩니다.

SOLIDWORKS 설치 관리자로 사용자가 받을 수 있는 제품을 확인할 수 없을 경우 다른 패키지나 제품을 선택합니다를 클릭하여 설치하거나 수정할 SOLIDWORKS 패키지(SOLIDWORKS Professional, SOLIDWORKS Premium 또는 SOLIDWORKS Ultimate)를 변경할 수 있습니다. 사용자가 선택한 패키지와 호환 가능한 설치 미디어의 SOLIDWORKS 제품 모두가 SOLIDWORKS 설치 관리자에 나열됩니다. 구입하거나 평가하기 위해 받은 제품을 선택할 수 있습니다.

언어 지원

언어는 SOLIDWORKS 제품 설치 시 지정된 언어만 지원됩니다. 이 때 SolidWorks가 아닌 타 제품의 경우 해당 언어 지정 설치에 영향을 받지 않습니다. 예를 들어 eDrawings®는 모든 언어를 설치합니다.

필요한 공간

선택한 제품에 따라 다운로드 작업에 필요한 속도가 표시됩니다. 다운로드 크기가 모든 다운로드 파일에 필요한 총 디스크 공간을 의미합니다 (다운로드 완료 후 파일 압축을 풀 때 추가 필수 공간 제외). 이 값은 추정값입니다.

차후 업데이트와 패치에서 다운로드와 설치 시간을 줄이려면, 설치 후 다운로드 파일을 삭제합니다. 일반적으로 결과 업데이트와 패치를 하려면 마지막 정품 설치 파일 세트에 권한이 있어야 합니다.
상위 주제 SOLIDWORKS 설치 관리자 응용 프로그램 도움말


복구할 제품

이 설치 복구하기를 지정할 경우 이 화면에 현 버전의 SOLIDWORKS 설치 관리자로 복구할 수 있는 SOLIDWORKS 제품이 버전 번호와 함께 표시됩니다.

복구로 모든 파일이 존재하며 제대로 등록되고 검색된 문제를 수정하는지 확인합니다. 작성된 데이터는 영향을 받지 않습니다.
  • 제품을 복구하려면 선택이 되었는지 확인합니다.
  • 복구로 불필요한 제품의 확인란을 선택 취소합니다.

복구를 클릭하여 선택한 제품의 복구를 시작합니다.

개별 설치를 복구할 수 있습니다. 관리 이미지 설치는 복구할 수 없습니다. 관리 이미지를 다시 설치해야 합니다.
상위 주제 SOLIDWORKS 설치 관리자 응용 프로그램 도움말


제품 번호

제품 번호는 사용자의 컴퓨터와 구입한 SOLIDWORKS 제품을 연결합니다.

SOLIDWORKS 제품이 이미 사용자의 컴퓨터에 설치되어 있으므로 제품 번호가 기본적으로 표시됩니다.
  • SOLIDWORKS 제품 번호가 표시되어 있지 않으면 입력합니다.
  • SOLIDWORKS 사용권에 포함되지 않은 제품의 제품 번호가 있으면 해당 필드에 입력합니다.

인터넷에 연결되어 있으면 입력한 제품 번호가 설치할 제품 선택 시 사용 가능한 제품을 자동적으로 표시하는데 사용됩니다.

SOLIDWORKS 제품을 구입하는 여러 방법이 있으므로 일부 제품 번호로 두 개나 그 이상의 제품을 포괄할 수 있습니다. 예를 들어, SOLIDWORKS 제품 번호로 개별 SOLIDWORKS Simulation 제품 번호를 입력하지 않고 SOLIDWORKS Simulation을 설치할 수 있습니다. 또한, 일부 제품은 제품 번호를 필요로 하지 않습니다. 제품 번호에 관한 질문은 리셀러(VAR)에게 문의하십시오.

상위 주제 SOLIDWORKS 설치 관리자 응용 프로그램 도움말


서버 설치

설치하려는 서버 제품이 설치 결과와 함께 나열됩니다.

서버 설치 상태

서버 제품 설치는 외부 설치 애플리케이션에 의해 수행됩니다. 해당 애플리케이션에 있지 않은 경우 설치를 완료하려면 해당 애플리케이션으로 전환해야 합니다.

서버 제품 설치를 중단하려면 취소를 클릭합니다.

서버 설치 완료

외부 설치 응용 프로그램이 성공적으로 완료되었습니다.

마침 또는 다음를 클릭합니다.
  • 다른 관리 제품(예: SOLIDWORKS 관리 이미지)를 설치할 경우 해당 설치가 계속됩니다.
  • 서버 제품 설치만 설치 과정에 포함된 경우 SOLIDWORKS 설치 관리자가 닫힙니다.

서버 설치 취소 또는 실패

서버 제품 설치가 시작된 후 취소되었거나 설치에 실패한 경우 설치되지 않은 서버가 나열됩니다.

닫기 또는 다음를 클릭합니다.
  • 다른 관리 제품 설치를 지정한 경우 SOLIDWORKS 설치 관리자가 계속 실행됩니다.
  • 서버 제품 설치만 설치 과정에 포함된 경우 SOLIDWORKS 설치 관리자가 닫힙니다.

자세한 내용

SolidNetWork License Manager 설치, 설정 및 사용에 대한 자세한 내용은 SolidNetWork License Manager를 사용하여 사용권 관리의 내용을 참조하십시오.

상위 주제 SOLIDWORKS 설치 관리자 응용 프로그램 도움말


요약

SOLIDWORKS 설치 관리자에 파일 작업에 필요한 모든 정보가 있습니다.

계속하기: | 지금 작업을 클릭하여 설치 과정을 시작합니다(예: 지금 설치, 지금 작성, 지금 다운로드, 지금 수정).
설치 설정 변경하기: | 변경하려는 부분에서 변경 [image] 을 클릭합니다(예: 제품, 설치 위치, Toolbox 옵션).
취소하기: | 취소을(를) 클릭하여 설치 구성 요소를 변경하지 않고 SOLIDWORKS 설치 관리자를 종료합니다.
이전 페이지로 돌아가기: | 뒤로을(를) 클릭하여 SOLIDWORKS 설치 관리자의 이전 페이지로 돌아갑니다.
설치 옵션의 특정 세트에 대한 자세한 정보(예: 제품, 설치 위치, Toolbox 옵션 등):
  1. 정보를 보려는 부분 옆의 변경 [image] 을 클릭합니다.
  2. 세부 정보 페이지가 나타나면 도움말을(를) 클릭하여 설치 옵션 설정에 대한 정보를 얻습니다.
상위 주제 SOLIDWORKS 설치 관리자 응용 프로그램 도움말


시스템 검사 경고

시스템 검사는 설치 과정에 영향을 줄 수 있는 보고된 문제를 검사합니다. 대부분의 경우 SOLIDWORKS 설치 관리자로 진행할 수 있습니다.

이 단계에서 나타날 수 있는 경고가 해결 방법에 대한 권고와 함께 아래 나와 있습니다.

제품 번호 확인 문제

설치관리자가 사용자의 제품번호를 확인할 수 없으므로 새 버전 확인이 불가능합니다. 연결 후 타당한 제품번호를 입력했다면, 일시적인 서버 문제일 수 있습니다. 나중에 재시도 합니다.

제품 번호 확인: 설치 관리자가 제품 번호를 확인할 수 없어 귀하가 설치 가능한 제품을 판별할 수 없습니다. 설치하고자 하는 제품을 선택할 수 있으나 설치 파일을 다운로드 할 수 없습니다. 설치 파일을 다운로드 할 수 있는 원본 파일이나 DVD가 있어야 합니다.

해상도(R):
  • 인터넷 연결을 확인합니다. 제품 번호를 확인하려면 인터넷에 연결되어 있어야 합니다.
  • 입력한 제품 번호가 설치하려는 제품에 유효한 지 확인합니다.
  • 일부 설치에서는 버전이 릴리즈된 당시의 유효한 서브스크립션이 필요할 수 있습니다. 자세한 내용은 SOLIDWORKS 리셀러에게 문의하십시오.
  • 대부분의 경우 DVD 또는 이전에 다운로드한 파일 세트로 설치할 경우 설치를 계속할 수 있습니다.

최신 버전이 있음

최신 버전이 있음

새로운 버전이 있음

이 제품의 최신 버전을 다운로드 할 수 있습니다.

해상도(R): 업데이트 확인 작업을 수행할 때 SOLIDWORKS에서 다운로드하여 새로운 버전을 설치하라는 메시지가 나타납니다. 처음에 지정한 버전을 사용하여 이 작업을 계속하거나 새로운 버전을 다운로드하고 해당 버전을 대신 사용하여 계속할 수 있습니다.

최근 버전 사용 가능

이 버전은 최근 버전입니다. 다음을 클릭하여 계속합니다.

새로운 다운로드가 없음

해결 방법: 이 메시지는 설치 또는 설치 수정 중에 업데이트 확인을 할 때 나타날 수 있습니다. 현재 사용자가 최신 버전을 설치하고 있거나 설치했음을 나타냅니다.

인터넷 연결 문제

인터넷 연결: 설치 관리자가 사용자의 설치 가능한 제품 확인을 위한 SOLIDWORKS 서버에 연결할 수 없습니다. 설치하고자 하는 제품을 선택할 수 있으나 설치 파일을 다운로드 할 수 없습니다. DVD의 원본 파일이나 이전에 다운로드 받은 파일을 제공해야 합니다.

새 버전 확인 불가능

설치관리자를 서버에 연결할 수 없어서 새로운 버전 확인이 불가능합니다.

해결 방법:
  • 인터넷 연결을 확인합니다.
  • DVD 또는 이전에 다운로드한 파일 세트로 설치할 경우 설치를 계속할 수 있습니다.

상위 주제 SOLIDWORKS 설치 관리자 응용 프로그램 도움말


구멍 가공 마법사/Toolbox 옵션

SOLIDWORKS Toolbox를 설치하는 경우 SOLIDWORKS에 구멍 유형과 하드웨어의 규격 라이브러리가 포함됩니다.

SOLIDWORKS Toolbox 설정, 확장, 사용에 대한 자세한 내용을 보려면 SOLIDWORKS에서 도움말을 클릭하고 Toolbox 섹션을 참조하십시오.

SOLIDWORKS Toolbox를 사용하기 전에, 사용자의 회사와 그룹 정책에 따라 적절히 구성되었는지 확인하십시오. 여러 경우, 그룹이 구성되고 중앙 Toolbox가 유지됩니다. SOLIDWORKS 관리자에게 SOLIDWORKS 설치 중 Toolbox를 지정하는 방법에 대해 문의하십시오.

설치 후 선택된 SOLIDWORKS Toolbox를 변경할 수 있습니다. SOLIDWORKS에서 도구 > 옵션을 클릭합니다. 시스템 옵션 탭에서 구멍 가공 마법사/Toolbox를 클릭합니다.

다음 섹션에는 이 화면에서 볼 수 있는 모든 설정의 모든 옵션에 대한 설명이 나와 있습니다. 실제로 표시되는 Toolbox 옵션은 해당 컴퓨터의 기존 SOLIDWORKS와 Toolbox 설정과 사용자가 지정한 SOLIDWORKS 설치 관리자 선택 항목에 따라 다릅니다.

새 새 버전 Toolbox 생성

해당 컴퓨터에 새 버전의 SOLIDWORKS Toolbox를 작성합니다.

새 버전을 작성하려면 제품 선택 화면에서 SOLIDWORKS > SOLIDWORKS Toolbox를 확장하고 Toolbox에서 지원할 규격을 선택합니다. 모든 규격이 기본적으로 선택됩니다.

해당 컴퓨터의 기존 Toolbox는 수정되지 않습니다.

기존 Toolbox 참조 또는 업그레이드

기존 Toolbox를 사용합니다. 찾아보기를 클릭하여 현 설치에 사용하려는 Toolbox의 위치를 지정합니다.

  • Toolbox가 이전 SOLIDWORKS 주요 버전으로 설정된 경우 최신 버전으로 업그레이드됩니다. 해당 Toolbox에 대한 모든 사용자 정의가 업그레이드된 Toolbox에서 유지됩니다.
    Toolbox를 SOLIDWORKS 새 주요 릴리즈 버전으로 업그레이드하면 해당 Toolbox가 SOLIDWORKS의 이전 주요 릴리즈 버전을 실행하는 컴퓨터와 호환되지 않습니다.
  • Toolbox가 현 SOLIDWORKS 버전으로 설정된 경우(예를 들어, 이미 업그레이드된 공유 네트워크 Toolbox를 지정한 경우) 해당 Toolbox에 대한 업그레이드가 수행되지 않습니다.
  • SOLIDWORKS PDM 환경의 Toolbox를 업그레이드하는 경우 추가적인 절차가 필요합니다. 자세한 내용은 SOLIDWORKS Toolbox 설정의 내용을 참조하십시오.

이 옵션은 관리 이미지 작성을 제외한 모든 설치 시나리오에서 나타납니다.

이전 버전 Toolbox 업그레이드

이전 주요 버전으로 설정된 Toolbox를 새 위치로 복사하고 해당 복사본을 최신 버전으로 업그레이드합니다.

이 옵션은 SOLIDWORKS의 이전 주요 릴리즈 버전이 해당 컴퓨터에 설치되어 있지만 해당 설치를 최신 릴리즈로 업그레이드할 것을 선택하지 않은 경우 나타납니다.
이 옵션의 목적은 이전 버전의 Toolbox를 사용하는 사용자에게 영향을 주지 않고 컴퓨터에 설치된 SOLIDWORKS의 이전 주요 버전의 Toolbox를 업그레이드하기 위함입니다.

SOLIDWORKS PDM 환경의 Toolbox를 업그레이드하는 경우 추가적인 절차가 필요합니다. 자세한 내용은 SOLIDWORKS Toolbox 설정의 내용을 참조하십시오.

현재 설치된 이전 버전 Toolbox 업그레이드

현 Toolbox를 최신 버전으로 업그레이드합니다.
Toolbox를 SOLIDWORKS 새 주요 릴리즈 버전으로 업그레이드하면 해당 Toolbox가 SOLIDWORKS의 이전 주요 릴리즈 버전을 실행하는 컴퓨터와 호환되지 않습니다.

이 옵션은 SOLIDWORKS의 이전 주요 릴리즈 버전을 현 버전으로 업그레이드하고 해당 버전으로 설정된 Toolbox가 해당 컴퓨터에 있을 경우 나타납니다.

SOLIDWORKS PDM 환경의 Toolbox를 업그레이드하는 경우 추가적인 절차가 필요합니다. 자세한 내용은 SOLIDWORKS Toolbox 설정의 내용을 참조하십시오.

설치된 현재 버전 Toolbox 사용

SOLIDWORKS 설치 관리자가 해당 컴퓨터에서 SOLIDWORKS의 현 주요 릴리즈 버전으로 설정된 Toolbox를 감지했습니다.

이 옵션을 선택하면 SOLIDWORKS가 이 Toolbox를 사용합니다. 업그레이드가 수행되지 않습니다.

이 옵션은 SOLIDWORKS의 이전 주요 릴리즈 버전이 해당 컴퓨터에 설치되어 있지만 Toolbox가 현 버전으로 설정되어 있는 경우 나타납니다. 이는 공유 Toolbox가 아직 이전 버전의 SOLIDWORKS를 실행하는 컴퓨터에서 작성된 경우 발생합니다.

클라이언트 컴퓨터의 Toolbox 위치 지정

클라이언트를 관리 이미지로 설치할 때 네트워크나 디렉터리 위치를 기본 Toolbox 위치로 지정합니다.
위치에 클라이언트 설치 시 SOLIDWORKS의 이전 주요 릴리즈 버전으로 설정된 Toolbox가 포함되어 있으면 SOLIDWORKS 설치 관리자가 해당 Toolbox를 업그레이드합니다.

이 옵션은 새 관리 이미지를 작성할 때 나타납니다.

클라이언트 컴퓨터의 기존 이미지에서 참조되는 Toolbox 업그레이드 또는 사용

업데이트하는 기존 관리 이미지에 지정된 Toolbox 위치를 사용합니다.
위치에 클라이언트 설치 시 SOLIDWORKS의 이전 주요 릴리즈 버전으로 설정된 Toolbox가 포함되어 있으면 SOLIDWORKS 설치 관리자가 해당 Toolbox를 업그레이드합니다.

클라이언트 컴퓨터의 다른 Toolbox 위치 선택

업데이트하는 기존 관리 이미지에 지정된 위치와 다른 Toolbox 위치를 지정합니다.
위치에 클라이언트 설치 시 SOLIDWORKS의 이전 주요 릴리즈 버전으로 설정된 Toolbox가 포함되어 있으면 SOLIDWORKS 설치 관리자가 해당 Toolbox를 업그레이드합니다.

목차

  • SOLIDWORKS Toolbox 설정

    SOLIDWORKS Toolbox는 강력하고 복합적인 도구입니다. 여기에서는 SOLIDWORKS 설치 관리자를 사용하여 Toolbox를 설정하기 전에 고려할 몇 가지 사항을 요약합니다.

  • UNC 서식

    UNC(Uniform(또는 Universal) Naming Convention) 서식은 공유 파일 위치를 나타내기 위해 파일 이름 구문 형식을 지정합니다.

상위 주제 SOLIDWORKS 설치 관리자 응용 프로그램 도움말
SOLIDWORKS Toolbox 설정


SOLIDWORKS Toolbox 설정

SOLIDWORKS Toolbox는 강력하고 복합적인 도구입니다. 여기에서는 SOLIDWORKS 설치 관리자를 사용하여 Toolbox를 설정하기 전에 고려할 몇 가지 사항을 요약합니다.

SOLIDWORKS Toolbox에 대한 자세한 도움말 보기

SOLIDWORKS Toolbox 설정, 확장, 사용에 대한 자세한 내용을 보려면 SOLIDWORKS에서 [image] 도움말을 클릭하고 Toolbox 섹션을 참조하십시오.

공유 Toolbox 사용

Toolbox를 설치할 때, Toolbox 데이터를 로컬 컴퓨터나 공유 위치에 저장할 수 있습니다. 네트워크 위치에 Toolbox 데이터를 저장할 것을 권장합니다. 공유 위치를 사용함으로써, 모든 SOLIDWORKS 사용자가 같은 체결부품 정보를 공유할 수 있습니다.

첫 설치일 경우 Toolbox를 설치하고자 하는 새 공유 위치를 찾아봅니다.

기존 Toolbox 업그레이드

Toolbox를 SOLIDWORKS 새 주요 릴리즈 버전으로 업그레이드하면 해당 Toolbox가 SOLIDWORKS의 이전 주요 릴리즈 버전을 실행하는 컴퓨터와 호환되지 않습니다.

다른 컴퓨터에 이전 버전이 설치되어 있고 해당 버전에 대해 설정된 Toolbox 설정이 계속 필요한 경우 해당 Toolbox를 복사하고 그 사본을 업그레이드합니다. SOLIDWORKS를 새로 설치하면 Toolbox 사본이 업그레이드되며, 이전 SOLIDWORKS 설치에서는 이전 Toolbox를 계속 사용합니다.

Toolbox 액세스 구성

설치 후 Toolbox 부품을 액세스할 때 SOLIDWORKS는 Toolbox 설정을 확인하고 액세스와 성능 향상을 위한 제안을 합니다.

공유 네트워크 Toolbox(권장)을 액세스하기 위해서는 공유 Toolbox가 설치된 서버에 대한 UNC 경로를 사용합니다. 자세한 내용은 UNC 서식의 내용을 참조하십시오.

관리자는 Toolbox 비밀번호를 만들고 작업 그룹에 대한 권한과 기본 설정을 설정할 수 있습니다. 설정에 대한 액세스를 제한하고 공통 기본 설정을 설정하면 Toolbox 데이터의 일관성이 보장됩니다.

SOLIDWORKS PDM 환경에서 Toolbox 업그레이드하기

SOLIDWORKS 소프트웨어를 업그레이드할 때 파트가 추가되었으면 Toolbox도 업그레이드됩니다. Toolbox 루트 폴더가 SOLIDWORKS PDM 볼트에 있으면 SOLIDWORKS 업그레이드를 시작하기 전에 Toolbox 폴더를 준비해야 합니다.

업그레이드를 수행하는 첫 번째 시스템에서 최근 버전 내려 받기를 사용하여 Toolbox 파일을 로컬 캐시로 다운로드하고 Toolbox 데이터베이스 파일을 체크아웃해야 합니다. 업그레이드하는 다른 시스템에서는 Toolbox 파일만 다운로드하면 됩니다.

업그레이드하기 전에:
  • 볼트 데이터베이스 및 보관의 완전한 최근 백업이 있는지 확인합니다.
  • Toolbox 파트가 체크아웃되었거나 체크아웃된 어셈블리에 의해 사용되고 있지는 않은지 확인합니다.

Toolbox를 업그레이드하는 방법

  1. 파일 탐색기에서 모든 권한(체크아웃, 체크인, 추가, 삭제)을 가진 사용자로 볼트에 로그인합니다.
  2. Toolbox 폴더를 오른쪽 클릭하고 최근 버전 내려받기를 클릭하여 모든 Toolbox 파일과 Toolbox 데이터베이스를 로컬 캐시에 복사합니다.
    보관 서버가 원격에 있는 경우에는 이 작업에 몇 분이 소요됩니다.
  3. \Toolbox_folder_name\lang\your_lang에서 Toolbox 데이터베이스 파일(SWBrowser.mdb 또는 swbrowser.sldedb)을 체크아웃합니다.
  4. SOLIDWORKS 설치 관리자를 실행하여 업그레이드를 수행합니다.
  5. 요약 화면 Toolbox 옵션 설치 위치가 볼트 내의 위치인지 확인합니다.

    볼트 내 위치가 아닐 경우 변경을 클릭하고 Reference or upgrade an existing Toolbox(기존 Toolbox 참조 또는 업그레이드)를 선택하여 볼트 내 Toolbox 위치를 찾습니다.

  6. 업그레이드가 완료되면 파일 탐색기에서 Toolbox 폴더를 체크인하여 새 파일이나 업데이트된 파일을 볼트에 추가해 다른 사용자가 Toolbox로 작업할 수 있도록 합니다.
  7. 업그레이드하려면 볼트의 Toolbox 폴더로 이동하여 다음 항목이 있는지 확인합니다.
    • \Toolbox_folder_name\Updates
    • \Toolbox_folder_name\ToolboxStandards.xml
    • \Toolbox_folder_name\Browser\ToolboxFiles.index

      이 파일이 없으면 공인 리셀러에게 문의하십시오.

  8. Toolbox를 사용하여 SOLIDWORKS PDM 통합을 사용하는 나머지 컴퓨터를 업그레이드합니다.
    1. 파일 탐색기에서 Toolbox 폴더에 대한 읽기 권한 이상의 권한을 가진 사용자로 볼트에 로그인합니다.
    2. Toolbox 폴더를 오른쪽 클릭하고 최근 버전 내려받기를 클릭하여 모든 Toolbox 파일을 로컬 캐시에 복사합니다.
    3. SOLIDWORKS 설치 관리자를 실행하여 업그레이드를 수행합니다.

      Installer가 Toolbox가 이미 업그레이드되었음을 감지합니다.

SOLIDWORKS PDM의 Toolbox 설정에 대한 자세한 내용은 SOLIDWORKS PDM 관리 도구 도움말에서 Toolbox 설정을 참조하십시오.

상위 주제 구멍 가공 마법사/Toolbox 옵션
UNC 서식


UNC 서식

UNC(Uniform(또는 Universal) Naming Convention) 서식은 공유 파일 위치를 나타내기 위해 파일 이름 구문 형식을 지정합니다.

\\서버\볼륨\경로

예:

\\Disk_Server\SOLIDWORKS\AdminImage

상위 주제 구멍 가공 마법사/Toolbox 옵션
SOLIDWORKS Toolbox 설정


제품 설치 제거

제어판에서 프로그램을 제거 또는 설치 제거하려면 화면에 현재 버전의 SOLIDWORKS 설치 관리자로 제거 가능한 SOLIDWORKS 제품이 버전 번호와 함께 표시됩니다. 표준, 사용자 정의 또는 전체 제거를 수행할 수 있습니다.

표준 제거를 수행하면 SOLIDWORKS 제품의 프로그램 파일 및 폴더가 제거됩니다. 표준 제거 대상으로 지정한 릴리즈의 모든 SOLIDWORKS 제품이 기본적으로 표시됩니다.

사용자 정의 제거를 수행하면 프로그램 파일 및 폴더, 레지스트리 키 및 데이터 폴더(예: SOLIDWORKS Toolbox), 원본 다운로드 위치의 파일 및 폴더 중에서 하나 이상이 제거됩니다.

설치 제거를 완전히 수행하면 설치 디렉터리, 레지스트리 키 및 데이터 폴더가 제거됩니다.

제품을 제거하는 방법
  1. 제거 화면에서 제품이 선택되어 있는지 확인합니다.

    모든 제품을 제거하면 Solidworks 설치 관리자도 제거됩니다.

  2. 제거하지 않으려는 제품은 선택 취소합니다.

    어떤 제품이라도 그대로 두면 SOLIDWORKS 설치 관리자는 제거되지 않습니다.

  3. 사용자 정의 제거를 수행할지 또는 전체 제거를 수행할지 선택합니다.
    1. 고급 옵션에서 변경을 클릭합니다.

      고급 옵션 화면이 나타납니다. 프로그램 파일 및 폴더 옵션이 선택되어 있습니다.

    2. 사용자 정의 제거를 수행하려면 하나 이상의 옵션을 선택하고, 전체 제거를 수행하려면 모든 옵션을 선택합니다.
    3. 요약으로 돌아가기를 클릭합니다.
    4. 요약 화면에서 고급 옵션을 확장하여 제거 방법 및 항목을 표시합니다.
  4. 항목 제거를 클릭합니다.
항목 제거를 클릭하면 SOLIDWORKS 설치 관리자가 즉시 제품을 제거하기 시작합니다.
상위 주제 SOLIDWORKS 설치 관리자 응용 프로그램 도움말


SOLIDWORKS Visualize Boost

SOLIDWORKS Visualize Boost는 SOLIDWORKS Visualize Professional을 실행 중인 컴퓨터에서 네트워크에 있는 하나 이상의 컴퓨터로 렌더링을 배포할 수 있는 앱입니다.

백그라운드에서 렌더링이 진행되는 동안 시스템에서 다른 작업을 수행할 수 있으며 최종 렌더링 이미지를 더 빨리 준비할 수 있습니다. 단일 시스템에서 이미지를 렌더링하거나 Visualize Boost를 실행 중인 여러 시스템의 클러스터에서 할 수도 있습니다.

SOLIDWORKS Visualize Professional의 각 활성 서브스크립션에는 SOLIDWORKS Visualize Boost의 무료 사용권이 하나씩 포함되어 있습니다.

렌더링 시간 단축과 같은 성능 향상은 Visualize Boost 컴퓨터의 성능에 따라 달라집니다. 고성능 GPU가 장착된 시스템에서는 성능이 더 개선됩니다.


개별 사용권에서 SolidNetWork 사용권으로 업그레이드

SOLIDWORKS 설치 관리자에서 SolidNetWork License 제품 번호를 지정하여 개별 SOLIDWORKS 사용권에서 SolidNetWork 사용권으로 컴퓨터를 업그레이드할 수 있습니다.

컴퓨터에 SOLIDWORKS가 설치되어 있지 않을 경우 SOLIDWORKS 설치 관리자로 설치할 때 SolidNetWork 제품 번호를 입력하여 SolidNetWork 사용권을 지정할 수 있습니다.

컴퓨터에 SOLIDWORKS가 이미 설치되어 있고 개별 사용권에서 SolidNetWork 사용권으로 전환하려면 클라이언트 컴퓨터에 대한 설치를 수정하고 SOLIDWORKS 설치 관리자를 실행할 때 개별 사용권 제품 번호 대신 SolidNetWork 사용권 제품 번호를 지정할 수 있습니다. 자세한 내용은 설치 수정하기를 참조하십시오.
관리 이미지에서 SOLIDWORKS를 설치한 경우에는 수정 옵션을 사용할 수 없습니다. 관리 옵션 편집기를 사용하여 관리 이미지를 변경하고 클라이언트를 제거한 후 설치를 재실행합니다.


Visualize Boost 작업

배포 렌더링을 활성화하려면 SOLIDWORKS Visualize를 설정한 후 Visualize Boost에 연결해야 합니다.

Boost 연결에는 코디네이터 IP 주소와 SOLIDWORKS Visualize의 Boost 포트 값이 필요합니다.

다음 단계를 수행하려면 Visualize Boost 및 SOLIDWORKS Visualize를 열어 두십시오.

SOLIDWORKS Visualize를 Visualize Boost에 연결하는 방법:

  1. 바탕 화면 바로 가기 [image] 를 더블 클릭하여 Visualize Boost를 엽니다.
  2. Visualize Boost에서 코디네이터 IP 주소를 더블 클릭하여 클립보드에 복사합니다.
  3. SOLIDWORKS Visualize에서 도구 > 옵션 > Boost를 클릭하고 CTRL+V를 눌러 코디네이터 IP 주소를 붙여넣습니다.
  4. 2단계와 3단계를 반복하여 Visualize Boost에서 SOLIDWORKS Visualize로 Boost 포트를 복사합니다.
    Visualize Boost와 SOLIDWORKS Visualize Boost에 지정된 Boost 포트는 동일해야 합니다.
    SOLIDWORKS Visualize에 Boost 상태 컨트롤이 나타납니다.
  5. 확인을 클릭하여 옵션 대화 상자를 닫습니다.
  6. Boost에 연결하려면 Boost 상태 컨트롤 [image] 을 클릭하거나 다음 인터페이스에서 [image] 의 연결을 끊습니다.
    • HUD(Heads-Up Display)
    • 렌더링 마법사 품질 페이지
    • 도구 옵션 Boost 탭

Boost 설정에 대한 자세한 내용은 SOLIDWORKS Visualize Boost를 참조하십시오.


새 SolidNetWork 사용권 서버 초기화

새 SolidNetWork 사용권 서버를 초기화하려면 다음을 수행합니다.

  1. SolidNetWork License Manager Server를 설치하고 연 후 활성화 여부 메시지가 나타나면 예를 클릭합니다.
  2. SolidNetWork 사용권 서버 정보 대화 상자에서 방화벽 및 포트를 확인하고 다음을 클릭합니다.
  3. 제품 활성화 마법사에서 활성화할 일련 번호를 선택하고, 활성화 방법으로 이메일을 통해 직접을 선택한 다음 이메일 연락처 정보를 입력합니다.

    수동 방법을 사용하려면 요청 파일을 작성하여 activation@solidworks.com으로 이메일을 보내야 합니다. 사용권 응답 파일이 포함된 이메일을 받으면 파일의 압축을 풀고 열기를 클릭하여 서버에 로드합니다.

    제품 활성화 마법사를 닫았다가 다시 실행하여 응답 파일을 열고 로드할 수 있습니다.

  4. 초기화에 성공했다는 메시지 상자가 나타나면 확인을 클릭하고 제품 활성화 마법사에서 마침을 클릭합니다.


새 SolidNetWork License Manager Server를 수동으로 활성화

SolidNetWork License Manager Server를 초기화하고, SolidNetWork License Manager Server를 열고, 두 번째 요청을 작성하여 활성화를 완료합니다.

새 SolidNetWork License Manager Server를 수동으로 활성화하는 방법:

  1. 다음 중 하나를 수행합니다.
    • 활성화하라는 메시지가 나타나면 예를 클릭합니다.
    • 메시지가 나타나지 않으면 서버 관리 탭에서 수정을 클릭합니다.
    기본적으로, 고급 옵션은 활성화 사용 모드가 설정되어 있습니다.
  2. SolidNetWork 사용권 서버 정보 대화 상자에서 방화벽 및 포트를 확인하고 다음을 클릭합니다.
  3. 제품 활성화 마법사에서 활성화할 제품 번호를 선택하고 이메일 연락처 정보를 입력한 다음 활성화 방법으로 이메일을 통해 직접을 선택합니다.
  4. 다음 단계에 따라 요청 파일을 작성하여 activation@solidworks.com으로 보냅니다. 사용권 응답 파일을 받으면 열기를 클릭하여 파일을 로드합니다.
  5. 활성화가 완료되면 마침을 클릭합니다.


업그레이드된 SolidNetWork License Manager Server를 수동으로 활성화

SOLIDWORKS Installation Manager를 사용하여 SolidNetWork License Manager Server를 업그레이드한 후 SolidNetWork License Manager Server를 엽니다.

업그레이드된 SolidNetWork License Manager Server를 수동으로 활성화하는 방법:

  1. 서버 관리 탭의 사용권 정보 아래에서 다시 활성화를 클릭합니다.
    SolidNetWork License Manager Server를 제거 및 업그레이드하기 전에 사용권을 비활성화한 경우, 대신 서버 관리 탭에서 수정을 클릭합니다. 다시 활성화는 서버에 활성화된 사용권이 있는 경우에만 사용할 수 있습니다.

    계속해서 3단계를 진행합니다.

  2. 다시 활성화 대화 상자에서 설치된 제품 번호를 선택하여 관련 사용권을 보고 다시 활성화를 클릭합니다.
  3. SolidNetWork 사용권 서버 정보 대화 상자에서 방화벽 및 포트를 확인하고 다음을 클릭합니다.
  4. 제품 활성화 마법사에서 활성화할 제품 번호를 선택하고 이메일 연락처 정보를 입력한 다음 활성화 방법으로 이메일을 통해 직접을 선택합니다.
    수동으로 활성화는 간단한 프로세스입니다. 제품 활성화 마법사의 지침으로 절차가 안내됩니다.
  5. 활성화가 완료되면 마침을 클릭합니다.