SOLIDWORKS インストレーションおよびアドミニストレーション（SOLIDWORKS Installation and Administration）

このガイドは SOLIDWORKS 製品の個人インストレーションと複数インストレーションの両方におけるインストレーション、ライセンス管理、アップグレード、管理について説明します。

個人インストレーション | 複数インストレーションの展開
インストール 1台または数台のコンピュータへのインストレーション。 | インストール 複数のクライアント コンピュータに展開するアドミニストレーティブ イメージの作成。
ライセンス契約（Licensing） マシン アクティベーションまたはネットワーク ライセンス。 | ライセンス契約（Licensing） マシン アクティベーションまたはネットワーク ライセンス。
アップグレード 各コンピュータを新しいリリース版に移行。 | アップグレード コンピュータへのインストールに使用したアドミニストレーティブ イメージのアップデートにより複数のコンピュータを新しいリリース版に移行。
管理 インストレーションの変更、修復、削除、および新しいリリースへのアップグレード。 | 管理 アドミニストレーティブ イメージとクライアント、およびネットワーク ライセンス管理のアップグレード

SOLIDWORKS Installation Manager では、さまざまな SOLIDWORKS 製品コンポーネントの設定を構成できます。これらの製品コンポーネントには、SOLIDWORKS、SOLIDWORKS Toolbox、SOLIDWORKS Electrical、SOLIDWORKS Manage、SOLIDWORKS PDM、SOLIDWORKS Visualize、SOLIDWORKS SolidNetWork License Manager が含まれます。

SolidNetWork License Managerは、ネットワーク上のクライアントにライセンスを配布することで複数のライセンス クライアントをサポートします。 フローティング ライセンスを使用することにより、ユーザー数はライセンス数を上回ることが可能になります。

目次

  • 個人インストレーションまたはアドミニストレーティブ イメージ（Individual Installation or Administrative Image）

    SOLIDWORKS 製品を各コンピュータに個別にインストールしますか? あるいはアドミニストレーティブ イメージを作成して展開し、すべてのクライアントに 1 コマンドでインストールしますか?

  • システムおよびソフトウェア要件の確認

    インストール前に、システムがハードウェア、オペレーティング システム、および Microsoft 製品の要件を満たしていることを確認します。 SOLIDWORKS Electrical、SOLIDWORKS Visualize、および eDrawings などのアドインには、別の要件があるので注意してください。

  • インストレーション メディアをダウンロード

    すべてのインストレーション メディアは SOLIDWORKS ダウンロード ページから入手できます。

  • 3DEXPERIENCE アプリケーションのインストール

    3DEXPERIENCE Platform を使用してデータを管理する場合は、Collaborative Designer for SOLIDWORKS ロールを購入して、デスクトップ環境をプラットフォームに接続できます。


個人インストレーションまたはアドミニストレーティブ イメージ（Individual Installation or Administrative Image）

SOLIDWORKS 製品を各コンピュータに個別にインストールしますか? あるいはアドミニストレーティブ イメージを作成して展開し、すべてのクライアントに 1 コマンドでインストールしますか?

一台のコンピュータのみにインストールする場合や数百台のコンピュータにインストールする場合、この選択は明らかです。それ以外の場合は、次の比較を参考にしてください。

個人インストレーション | アドミニストレーティブ イメージ
各ユーザーが個人的に SOLIDWORKS を管理できます。 | システム管理者はオプション エディタを使って、複数のインストレーションをカスタマイズすることができます。新規インストレーションを作成したり、あるいは既存のものを更新するインストレーション オプションを指定したり、アドミニストレーティブ ユーザーとして起動したり、インストレーションの前後に外部コマンドを実行したり、異なる製品のグループ分けを行います。
インストレーションを実行する個人が、コンピュータに物理的にアクセスできなければなりません。 | クライアント コンピュータが同じネットワーク上でアクセス可能な限り、物理的な距離は問題ありません。
異なるバージョン、ServicePack、製品を、別々のコンピュータ上に独自の設定でインストールできます。 | オプション エディタを使って、アドミニストレーティブ イメージはバージョン、Service Pack、製品、設定の一貫性を維持することができます。
コンピューターには、ネットワークまたは電子メールへのアクセスが必要です。 SOLIDWORKS をアクティブ化してファイルをダウンロードするには、ネットワークまたは電子メールの接続が必要です。 また、ネットワーク ライセンス サーバーからライセンスを収集するには、ネットワークへのアクセスが必要です。 | アプリケーションを展開するには、ローカル ネットワークが接続されている必要があります。クライアント コンピュータ上にメディア ドライブは必要ありません。 クライアントは自動的にアップデートされます。 同じアドミニストレーティブ イメージから展開されたすべてのクライアントが同じServicePackになります。 複数のバージョンを維持するには、複数のアドミニストレーティブ イメージを作成します。 ライセンスのアクティベーションを自動的に行うことができます。 アドミニストレーティブ イメージは、サーバー上の追加のディスク容量を必要とします。クライアントは、個別インストレーションと同じ容量を必要とします。
親トピック SOLIDWORKS インストレーションおよびアドミニストレーション（SOLIDWORKS Installation and Administration）
システムおよびソフトウェア要件の確認
インストレーション メディアをダウンロード
3DEXPERIENCE アプリケーションのインストール


システムおよびソフトウェア要件の確認

インストール前に、システムがハードウェア、オペレーティング システム、および Microsoft 製品の要件を満たしていることを確認します。 SOLIDWORKS Electrical、SOLIDWORKS Visualize、および eDrawings などのアドインには、別の要件があるので注意してください。

SolidWorks ソフトウェアを確実にインストールし、最適なパフォーマンスでお使いいただくために、次を参照してください: System Requirements（必要なシステム要件）

親トピック SOLIDWORKS インストレーションおよびアドミニストレーション（SOLIDWORKS Installation and Administration）
個人インストレーションまたはアドミニストレーティブ イメージ（Individual Installation or Administrative Image）
インストレーション メディアをダウンロード
3DEXPERIENCE アプリケーションのインストール


インストレーション メディアをダウンロード

すべてのインストレーション メディアは SOLIDWORKS ダウンロード ページから入手できます。

SOLIDWORKS ダウンロード ページにアクセスできない場合は、代理店に連絡して DVD を入手してください。

インストール メディアをダウンロードするには:

  1. SOLIDWORKS ダウンロード ページに Subscription サービス（有償サポート）契約ユーザーとしてログインし、電子メール アドレスとパスワードを入力するか、SOLIDWORKS シリアル番号を入力します。
  2. ダウンロード ページのバージョンの選択（Select Version）で、年（year）を選択します。
  3. SOLIDWORKS 製品のSOLIDWORKSタブを選択します。
  4. 製品領域で、サービス パックを選択します。
    最新のメジャー リリース版では、SOLIDWORKS 製品バージョン 0.0 を選択します。
  5. 使用許諾契約に同意する＆続行（Accept Agreement & Continue）をクリックして、使用許諾契約の条項に同意します。
  6. ダウンロード（Download）をクリックします。
    ご使用の Web ブラウザでは、SolidworksSetup.exe が、デフォルトの場所 C:\Users\Username\Downloads にダウンロードされます。
  7. SolidworksSetup.exe を Downloads フォルダに解凍します。
    SolidworksSetup.exe を希望の場所に解凍することもできます。
  8. setup.exe を管理権限で実行します。
  9. Installation Manager で、全ファイルのダウンロードと共有（Download and share all files）をクリックします。
    一度のダウンロードで複数のマシン上に個人インストレーションまたはアドミニストレーティブ イメージを作成してから、プロンプトに従ってプロセスを完了します。

    Installation Manager はインストレーション メディアをダウンロードします。

    このオプションは以下の場合に有用です。
    • 当ソフトウェアを少数のマシンにインストールする
    • ポータブル ドライブまたはネットワーク ドライブを使用してダウンロードする
    • サービス パックをインストールする
    インストール ファイルを選択してダウンロードするには、プロンプトに従って手動ダウンロード方法を選択します。
親トピック SOLIDWORKS インストレーションおよびアドミニストレーション（SOLIDWORKS Installation and Administration）
個人インストレーションまたはアドミニストレーティブ イメージ（Individual Installation or Administrative Image）
システムおよびソフトウェア要件の確認
3DEXPERIENCE アプリケーションのインストール


3DEXPERIENCE アプリケーションのインストール

3DEXPERIENCE Platform を使用してデータを管理する場合は、Collaborative Designer for SOLIDWORKS ロールを購入して、デスクトップ環境をプラットフォームに接続できます。

Collaborative Designer for SOLIDWORKS ロールは、3DEXPERIENCE アプリケーションへのアクセスを許可します。これにより、SOLIDWORKS Desktop 製品で、プラットフォームに保存されているデータを保存、検索、および管理することができます。

これらのアプリケーションは、SOLIDWORKS Installation Manager ではなく、3DEXPERIENCE Platform からインストールしてライセンスを取得します。インストール手順については、SOLIDWORKS ヘルプの 3DEXPERIENCE Platform および 3DEXPERIENCE アプリケーションの使用（Working with the 3DEXPERIENCE Platform and 3DEXPERIENCE Apps） > 3DEXPERIENCE アプリケーションのインストール（Installing the 3DEXPERIENCE Apps）を参照してください。

親トピック SOLIDWORKS インストレーションおよびアドミニストレーション（SOLIDWORKS Installation and Administration）
個人インストレーションまたはアドミニストレーティブ イメージ（Individual Installation or Administrative Image）
システムおよびソフトウェア要件の確認
インストレーション メディアをダウンロード
https://help.solidworks.com


個人インストレーション（Individual Installations）

目次

  • 個人コンピュータでのインストール（Installation on Individual Computers）

    SOLIDWORKS は、いくつかのインストレーション方法を使用して個々のコンピュータにインストールできます。

  • 個人インストレーションの管理（Administration of Individual Installations）

    通常、個人インストレーションの管理はインストレーションの変更、修復、削除、アップグレードで構成されます。


個人コンピュータでのインストール（Installation on Individual Computers）

SOLIDWORKS は、いくつかのインストレーション方法を使用して個々のコンピュータにインストールできます。

SOLIDWORKS Installation Manager はインストレーションを購入した製品に合うように調整し、インストレーションを実行します。 インストレーションを開始する前に、以下を行います。

  • SOLIDWORKS のスタンドアロン シートをインストールする場合は、SOLIDWORKS シリアル番号をご用意ください。
  • インターネット接続された環境であることを確認してください。 権利をチェックするには、接続が必要です。
  • 3DEXPERIENCE ID を作成します。3DEXPERIENCE ID の作成の詳細については、https://www.3ds.com/support を参照してください。
  • あなたがアカウントの管理者として指定されていること、または管理者があなたを連絡先としてリストしていることを確認します。

SOLIDWORKS Installation Manager は、Microsoft Visual Studio Tools for Applications、Visual Basic、.NET Framework など、さまざまな Microsoft コンポーネントをインストールします。すべての Windows 前提条件コンポーネントの正しいバージョンがコンピュータにインストールされていない場合、SOLIDWORKS Installation Manager は SOLIDWORKS 製品をインストールする前に、これらのコンポーネントを自動的にインストールします。

SOLIDWORKS Chromium Embedded Framework（CEF）は、SOLIDWORKS Installation Manager によってインストールされるもう 1 つのコンポーネントです。その目的は、SOLIDWORKS アプリケーションと 3DEXPERIENCE Platform のコンテンツを表示することです。

SOLIDWORKS Login Manager も SOLIDWORKS Installation Manager によってインストールされます。3DEXPERIENCE Marketplace および 3DEXPERIENCE アプリケーションにログインできます。

インストレーション方法 プロセスの概要
SOLIDWORKS ダウンロード ページからダウンロード

すべてのインストレーション メディアは SOLIDWORKS ダウンロード ページから入手できます。

  1. SOLIDWORKS ダウンロード ページを参照します。
  2. 3DEXPERIENCE ID でログインします。
  3. ダウンロード ページのバージョンの選択（Select Version）で、年（year）を選択します。
  4. SOLIDWORKS 製品（SOLIDWORKS products）の SOLIDWORKS タブをクリックし、製品（Product）の下でサービス パックを選択します。
  5. 使用許諾契約に同意する＆続行（Accept Agreement & Continue）をクリックして、使用許諾契約の条項に同意します。
  6. ダウンロード（Download）をクリックします。
ダウンロード ページへのログイン アクセス権を持ち、動作しているインターネット接続が必要です。

ダウンロード ページにアクセスできない場合は、代理店に連絡してインストール メディアを入手してください。
サーバー上のダウンロード ディレクトリを使用 ダウンロード先のディレクトリで、setup.exe をダブルクリックします。

ダウンロード ディレクトリは、SOLIDWORKS 製品をインストールするコンピュータからアクセスでき、インストレーションの開始前にすべての SOLIDWORKS インストレーション ファイルを含んでいることが必要です。SOLIDWORKS Installation Manager は、ダウンロード ディレクトリに対するインターネット アクセスと書き込みアクセスがある場合、見つからないファイルを探すのに役立ちます。
アップデート チェック を使用して既存の SOLIDWORKS インストレーションを更新 次のいずれかの操作を行います:
  • SOLIDWORKS で、 [image] > アップデート チェック（Check for Updates）をクリックします。
  • Windows で、スタート（Start） > SOLIDWORKS Installation Manager > アップデート チェック（Check for Updates）をクリックします
スタート（Start） > SOLIDWORKS Installation Manager > SOLIDWORKS バックグラウンド ダウンローダー（SOLIDWORKS Background Downloader）をクリックすることもできます。Windows の通知領域で、SOLIDWORKS バックグラウンド ダウンローダー（SOLIDWORKS Background Downloader）を右クリックして、アップデート チェック（Check for Updates）をクリックします。
動作しているインターネット接続とマシンの管理者権限が必要です。

SOLIDWORKS Installation Manager では、必須ソフトウェアを含めて、全ファイルのダウンロードと共有（Download and share all files）というオプションを選択することもできます。 このオプションは、ソフトウェアをいくつかのマシンにインストールし、ポータブル ドライブまたはネットワーク ドライブを使用してダウンロードをコピーする場合に便利です。 フル バージョンとサービス パックは 1 つのインストールに含まれているため、サービスパックのインストールにも役立ちます。

インストレーションが完了したら、SOLIDWORKS アプリケーションおよびライセンス アクティベーションを開始します。

マシン上でライセンス供与されている製品のリストを表示するには、SOLIDWORKS メイン メニューから、
  • > マイ製品（My Products）をクリックします。
  • タスク パネルのホーム（Home）をクリックして、SOLIDWORKS リソース（SOLIDWORKS Resources） > マイ製品（My Products）をクリックします。
  • スタート（Start） > SOLIDWorks ツール（SOLIDWorks Tools ）バージョン（Version） > マイ製品（My Products）をクリックします。

ダイアログ ボックスのチェック マークは、アクティベーションおよびネットワーク ライセンスに基づいて、ユーザーまたはユーザーの組織が保持している製品を示します。また、各製品カテゴリの先頭にあるリンクをクリックすることで、SOLIDWORKS 製品の詳細を確認できます。

SOLIDWORKS ライセンスを持っている場合に、使用中のライセンスを特定するには、Windows で、スタート（Start） > SOLIDWORKS ツール <バージョン>（SOLIDWORKS Tools <version>） > SolidNetWork License Manager Client > ライセンスの使用状況（License Usage）タブをクリックします。

親トピック 個人インストレーション（Individual Installations）
個人インストレーションの管理（Administration of Individual Installations）


個人インストレーションの管理（Administration of Individual Installations）

通常、個人インストレーションの管理はインストレーションの変更、修復、削除、アップグレードで構成されます。

目次

  • インストレーションの変更（Modifying an Installation）

    インストレーションを変更して、インストールされていない製品をインストールしたり、製品を削除したりできます。ただし、前回のインストールがインストレーション ファイルの完全なセットを使用して完了していることを条件とします。 このオプションは、前回のインストールをサービス パックでアップグレードしている場合は使用できません。

  • インストールの修復（Repairing an Installation）

    もしインストールされた SOLIDWORKS 製品の問題があるならば、SOLIDWORKS インストール マネージャーをインストールを修復するために使うことができます。

  • 個別インストレーションを前回までのService Packにロールバックする方法（Rolling Back an Individual Installation to a Previous Service Pack）

  • インストレーションの削除（Removing an Installation）

    個人コンピュータ上、およびクライアント/サーバー環境で、インストレーションを削除することができます。

  • 新しいリリースへのアップグレード（Upgrading to a New Release）

    個人インストレーションを新しい SOLIDWORKS リリースにアップグレードする方法は、いくつかあります。

  • 製品の共存ルール（Product Coexistence Rules）

    製品の共存ルールは、新規製品のインストールと既存製品のアップグレード方法を決定します。

親トピック 個人インストレーション（Individual Installations）
個人コンピュータでのインストール（Installation on Individual Computers）


インストレーションの変更（Modifying an Installation）

インストレーションを変更して、インストールされていない製品をインストールしたり、製品を削除したりできます。ただし、前回のインストールがインストレーション ファイルの完全なセットを使用して完了していることを条件とします。 このオプションは、前回のインストールをサービス パックでアップグレードしている場合は使用できません。

SOLIDWORKS をインストールした後でアドインを購入した場合は、新規のアドインが含まれるようにインストレーションを変更できます。 アドインは個別のコンピュータにインストールする必要があります。

  1. アクティブな SOLIDWORKS のセッションがないことを確認します。
  2. Windows のアプリ（Apps）を開き、インストールされているアプリ（Installed apps）をクリックします。
  3. 変更したい SOLIDWORKS インストレーションを選択してから、変更 をクリックします。
  4. SOLIDWORKS Installation Manager へようこそ（Welcome to the SOLIDWORKS Installation Manager）画面で、インストレーションを変更（Modify your installation）をクリックします。
  5. シリアル番号 画面で適切なシリアル番号が指定されていることを確認します。
  6. 製品選択 画面でインストールまたは削除する製品を選択します。
    インストレーションの変更は以下のようになります。
    • 新しいシリアル番号を指定した場合も、デフォルトでインストールまたは削除される製品はありません。それぞれの製品や機能コンポーネントのインストール動作を変更する必要があります。
    • 特定のコンポーネントに対して計画された動作を確認するには、コンポーネント名（チェックボックスではなく）をクリックします。製品リストの下部にある情報フィールドに意図されたインストール動作が表示されます。
    • 製品コンポーネントに対するインストール動作を変更するには、コンポーネントの隣にあるチェックボックスをクリックします。（たとえば、コンポーネントのインストールや削除を行っている場合は、チェックボックスを選択すると対応するコンポーネントがインストールまたは削除の対象となり、チェックボックスの選択を解除すると対応するコンポーネントがインストールまたは削除の対象から外れます。）
    • 初期の指定からコンポーネントのインストール動作を変更すると、アスタリスク（*）がリスト内のそのコンポーネントの横に表示されます。
    • コンポーネント内にサブコンポーネントがある場合には、コンポーネントの隣に [image] アイコンが表示されます。利用可能なサブコンポーネントを確認するには、 [image] アイコンをクリックします。
    • コンポーネントが展開されサブコンポーネントが表示されている場合は、コンポーネントの隣に [image] アイコンが表示されます。サブコンポーネントへの展開を解除するには、 [image] アイコンをクリックします。
  7. サマリー 画面で、今すぐ変更 をクリックします。
  8. インストレーション完了 画面で、完了 をクリックします。
親トピック 個人インストレーションの管理（Administration of Individual Installations）
インストールの修復（Repairing an Installation）
個別インストレーションを前回までのService Packにロールバックする方法（Rolling Back an Individual Installation to a Previous Service Pack）
インストレーションの削除（Removing an Installation）
新しいリリースへのアップグレード（Upgrading to a New Release）
製品の共存ルール（Product Coexistence Rules）


インストールの修復（Repairing an Installation）

もしインストールされた SOLIDWORKS 製品の問題があるならば、SOLIDWORKS インストール マネージャーをインストールを修復するために使うことができます。

インストールを修復するには、以前のインストールのすべてのソース ファイルと、適用されたすべてのサービス パックが、ご使用のコンピュータになければなりません。これらは、最初にそれらをインストールした場所にある必要があります。

個人インストレーションは修復できます。 アドミニストレーティブ イメージは修復できません； アドミニストレーティブ イメージをアンインストールして、次に再インストールしなければなりません。
  1. Windows のコントロール パネル（Control Panel）を開き、プログラム（Programs） > プログラムと機能（Programs and Features）をクリックします。
  2. 修復する SOLIDWORKS バージョンを右クリックし、変更（Change）をクリックします。
  3. SOLIDWORKS Installation Manager へようこそ（Welcome to SOLIDWORKS Installation Manager）画面で、インストレーションを修復（Repair your installation）をクリックし、次へ（Next）をクリックします。
  4. 修復する製品 画面で、修復する製品を選択します。
  5. スクリーン上で残りの製品を選択解除します。
  6. 修復 をクリックします。
親トピック 個人インストレーションの管理（Administration of Individual Installations）
親トピック インストレーション エラー/インストールのキャンセル（Installation Errors / Installation Cancelled）
インストレーションの変更（Modifying an Installation）
個別インストレーションを前回までのService Packにロールバックする方法（Rolling Back an Individual Installation to a Previous Service Pack）
インストレーションの削除（Removing an Installation）
新しいリリースへのアップグレード（Upgrading to a New Release）
製品の共存ルール（Product Coexistence Rules）
失敗またはキャンセルされたインストレーションからの回復
代理店までご連絡する場合（Contacting the SOLIDWORKS Reseller）


個別インストレーションを前回までのService Packにロールバックする方法（Rolling Back an Individual Installation to a Previous Service Pack）

個人インストレーションを現在のメジャー リリース ファミリー内の以前のServicePackリリースにロールバックするには、コンピュータに現在インストールされているServicePackバージョンをアンインストールしてから、以前のバージョンを再インストールします。
親トピック 個人インストレーションの管理（Administration of Individual Installations）
インストレーションの変更（Modifying an Installation）
インストールの修復（Repairing an Installation）
インストレーションの削除（Removing an Installation）
新しいリリースへのアップグレード（Upgrading to a New Release）
製品の共存ルール（Product Coexistence Rules）


インストレーションの削除（Removing an Installation）

個人コンピュータ上、およびクライアント/サーバー環境で、インストレーションを削除することができます。

  1. アクティブな SOLIDWORKS のセッションがないことを確認します。
  2. SOLIDWORKS ライセンスを別のコンピュータに移動する場合は、そのコンピュータから SOLIDWORKS インストレーションを削除する前に、ライセンスを非アクティブにしてください。
    詳細は、ライセンスの移動 を参照してください。
  3. Windows のコントロール パネル（Control Panel）を開き、プログラムと機能（Programs and Features）をクリックします。
  4. 除去する製品コンポーネントを選択して、アンインストール（Uninstall）をクリックします。
    場合によっては、特定のメジャー リリース バージョンに対して複数の SOLIDWORKS ServicePack コンポーネントが存在するかもしれません。 SOLIDWORKS メジャー リリースを削除するには、そのメジャー リリースに対するすべての SevicePack 要素を削除します。
  5. アンインストール 画面で:
    1. 削除する製品を選択します。
      すべての製品コンポーネントがデフォルトで選択されています。
    2. 削除したくない製品を選択解除します。
    3. 詳細設定オプション で 変更 をクリックします。
      詳細設定オプション（Advanced Options）画面が表示され、プログラム ファイルとフォルダのオプションが選択されています。
    4. 希望のオプションを選択してカスタム アンインストールを行うか、すべてのオプションを選択して完全アンインストールを行います。
      デフォルトでは、SOLIDWORKS Installation Manager では完全アンインストールが実行され、インストール時に追加されたファイルとフォルダがすべて削除されます。
    5. サマリーに戻る（Back to Summary）をクリックします。
    6. サマリー（Summary）画面で、詳細設定オプション（Advanced Options）を展開し、アンインストールの方法とエントリを表示します。
    7. アイテムを削除 をクリックします。
親トピック 個人インストレーションの管理（Administration of Individual Installations）
親トピック 複数インストレーションの管理（Administration of Multiple Installations）
インストレーションの変更（Modifying an Installation）
インストールの修復（Repairing an Installation）
個別インストレーションを前回までのService Packにロールバックする方法（Rolling Back an Individual Installation to a Previous Service Pack）
新しいリリースへのアップグレード（Upgrading to a New Release）
製品の共存ルール（Product Coexistence Rules）
新しいリリースへのアドミニストレーティブ イメージのアップグレード（Upgrading Administrative Images to a New Release）
ServicePack製品アップデートの管理（Service Pack Product Update Administration）
ライセンスの移動


新しいリリースへのアップグレード（Upgrading to a New Release）

個人インストレーションを新しい SOLIDWORKS リリースにアップグレードする方法は、いくつかあります。

次の場合に新しいリリースにアップグレードすることができます。
  • 新しいインストレーション メディアを受け取った
  • SOLIDWORKS の開始時にアップグレードが通知された
  • マニュアルでのアップデート チェックを行った
  • 新しいインスタンスの SOLIDWORKS Installation Manager を開始した

新しいメジャー リリースのインストール時には、前にインストールしたメジャー リリースをアップグレードするか、または新しいリリースを並行してインストールできます。インストール済みのメジャー リリースに対するServicePackリリースをインストールする場合、このリリースは自動的にアップデートされます。

親トピック 個人インストレーションの管理（Administration of Individual Installations）
インストレーションの変更（Modifying an Installation）
インストールの修復（Repairing an Installation）
個別インストレーションを前回までのService Packにロールバックする方法（Rolling Back an Individual Installation to a Previous Service Pack）
インストレーションの削除（Removing an Installation）
製品の共存ルール（Product Coexistence Rules）

マニュアルでのアップデート チェック（Checking for Updates Manually）

マシンの管理者権限があれば、インストールされている SOLIDWORKS リリースのアップデート チェックを、以下のいずれかの方法を使用して実行できます。

  • SOLIDWORKS で、 [image] > アップデート チェック（Check for Updates）をクリックします。
  • Windows で スタート（Start） > SOLIDWORKS Installation Manager > アップデート チェック（Check for Updates）をクリックします。
スタート（Start） > SOLIDWORKS Installation Manager > SOLIDWORKS バックグラウンド ダウンローダー（SOLIDWORKS Background Downloader）をクリックすることもできます。Windows の通知領域で、SOLIDWORKS バックグラウンド ダウンローダー（SOLIDWORKS Background Downloader）を右クリックして、アップデート チェック（Check for Updates）をクリックします。

アップグレードの注意点（Upgrade Caveats）

メジャー バージョンが異なる複数のインストレーションが許可される製品の場合は、メジャー アップグレードがサポートされない、あるいは次のメジャー バージョンへのアップグレードが一度の作業で可能でない場合があります。

このような場合、SOLIDWORKS Installation Manager は先ず新規バージョンをインストールし、続いて古いバージョンを削除することにより、アップグレードを実行しようします。 現時点では、SOLIDWORKS のコア製品はメジャー バージョンのアップグレードをサポートしますが、その他の製品はサポートしません。

この結果、以下のようになります。
  • SOLIDWORKS のコア製品のメジャー バージョン アップグレードを行う場合:
    • 既存のインストレーション場所は変更しません。
    • アップグレード中にエラーが発生したり、キャンセルをした場合、アップグレードをロールバックできます。
  • その他の製品のメジャー バージョン アップグレードを行う場合:
    • 各製品は、先ず新規製品として新しい場所にインストールされ、続いて元のインストレーションが削除されます。
    • 一度アップグレードを開始すると、エラーが発生したり、キャンセルをした場合でも、アップグレードをロールバックすることはできません。


製品の共存ルール（Product Coexistence Rules）

製品の共存ルールは、新規製品のインストールと既存製品のアップグレード方法を決定します。

ルール | 例
以下に示す製品を除いて、複数のメジャー リリース バージョンのコア SOLIDWORKS 製品が許可されます。 | SOLIDWORKS 2024 SP3.0 と SOLIDWORKS 2025 SP0.0 は 1 台のコンピュータに共存できます。
同じメジャー リリース バージョンの複数のサービス パックは許可されません。 | SOLIDWORKS 2025 SP0.0 と 2025 SP1.0 は 1 台のコンピュータに共存できません。SOLIDWORKS 2025 SP0.0 が既にインストールされているコンピュータに SOLIDWORKS 2025 SP1.0 をインストールすると、SOLIDWORKS Installation Manager によって SP0.0 が SP1.0 に置き換えられます。
次の製品は、1台のコンピュータで 1 つのバージョンのみが許可されます。
  • SolidNetWork License Manager
 SolidNetWork License Manager 2024 SP3.0 がインストールされている場合、SolidNetWork License Manager は、以前の SOLIDWORKS メジャー リリースがコンピュータ上に残っている場合でも、2025 SP0.0 にアップグレードします。
次の製品は、1 台のコンピュータで 1 つのバージョンのみが許可されます。
  • SOLIDWORKS Electrical
 SOLIDWORKS Electrical 2025 SP1.0 の新規インストレーションを作成する場合は、SOLIDWORKS Installation Manager によって、それより前のバージョンの SOLIDWORKS Electrical がマシンから自動的に除去されます。アップグレードする前に SOLIDWORKS Electrical 環境をバックアップしてください。
次の製品は、1台のコンピュータで 1 つのバージョンのみが許可されます。
  • SOLIDWORKS PDM Client
  • SOLIDWORKS PDM Server

SOLIDWORKS 2025 SP0.0 または SP1.0 をインストールした場合、SOLIDWORKS 2025 PDM Server や PDM Client もアップグレードする必要があります。

SOLIDWORKS 2025 PDM Server をインストールした場合、PDM Server のインストール プロセスを使用して SOLIDWORKS PDM Client をインストールする必要があります。SOLIDWORKS PDM Client をクライアントのインストール プロセスと別にインストールしないでください。

同じマシン上の SOLIDWORKS PDM Server と SOLIDWORKS PDM Client は同じリリース バージョンとサービス パックである必要があります。

詳細は、SOLIDWORKS PDM および SOLIDWORKS Manageを参照してください。

SOLIDWORKS に含まれる製品は、各メジャー リリース バージョンについて 1 つのバージョンのみインストールできます。 ただし、異なるメジャー リリース バージョンの SOLIDWORKS に含まれる製品は共存できます。 | SOLIDWORKS 2025 SP0.0 が 2025 SP1.0 にアップグレードされると、SOLIDWORKS Composer 2025 SP0.0 は自動的に 2025 SP1.0 にアップグレードします。ただし、SOLIDWORKS Composer 2024 SP4.0 は SOLIDWORKS Composer 2025 SP0.0 や SOLIDWORKS Composer 2025 SP1.0 と共存できます。
親トピック 個人インストレーションの管理（Administration of Individual Installations）
インストレーションの変更（Modifying an Installation）
インストールの修復（Repairing an Installation）
個別インストレーションを前回までのService Packにロールバックする方法（Rolling Back an Individual Installation to a Previous Service Pack）
インストレーションの削除（Removing an Installation）
新しいリリースへのアップグレード（Upgrading to a New Release）


複数インストレーション（Multiple Installations）

目次

  • 複数クライアントへの展開（Deploying to Multiple Clients）

    アドミニストレーティブ イメージを作成してからクライアントにインストレーションを展開することにより、複数のクライアントに SOLIDWORKS 製品をインストールできます。

  • アドミニストレーティブ イメージの使用（Using Administrative Images）

    アドミニストレーティブ イメージは、単一のネットワーク位置からの SOLIDWORKS 製品の設定可能なインストレーションを可能にします。

  • コマンドラインによる展開（Command-Line Deployment）

    コマンド プロンプト/バッチ ファイルによってアドミニストレーティブ イメージを自動的に展開（サイレント インストレーション）できます。

  • 複数インストレーションの管理（Administration of Multiple Installations）

    複数インストレーションの場合、管理タスクには新しいリリースへのアドミニストレーティブのアップグレード、ServicePack製品アップデートの適用、インストレーションの削除が含まれます。


複数クライアントへの展開（Deploying to Multiple Clients）

アドミニストレーティブ イメージを作成してからクライアントにインストレーションを展開することにより、複数のクライアントに SOLIDWORKS 製品をインストールできます。

複数クライアントに展開する手順は、以下のようになります。
  1. アドミニストレーティブ イメージを作成します。
    • SOLIDWORKS Installation Manager を使ったアドミニストレーティブ イメージの作成（Creating an Administrative Image from SOLIDWORKS Installation Manager）
  2. アドミニストレーティブ イメージをクライアントに展開します。
    • （電子メール）手動/プル方式によるクライアントへのアドミニストレーティブ イメージの展開
    • 自動/プッシュ方式によるクライアントへのアドミニストレーティブ イメージの展開
    • コマンドラインを使用したアドミニストレーティブ イメージからのインストール（Installing from the Administrative Image Using the Command Line）
  3. ライセンス管理（licensing）を行います。
    • 個人ライセンスの管理（Administering Individual Licenses）
    • SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）
親トピック 複数インストレーション（Multiple Installations）
アドミニストレーティブ イメージの使用（Using Administrative Images）
コマンドラインによる展開（Command-Line Deployment）
複数インストレーションの管理（Administration of Multiple Installations）


アドミニストレーティブ イメージの使用（Using Administrative Images）

アドミニストレーティブ イメージは、単一のネットワーク位置からの SOLIDWORKS 製品の設定可能なインストレーションを可能にします。

ネットワーク上のクライアント コンピュータを含む任意のコンピュータから、アドミニストレーティブ イメージをインストールできます。
  • アドミニストレーティブ イメージは必ず共有フォルダに保存してください。
  • すべての製品を含むと、アドミニストレーティブ イメージには 17GB 以上のディスク容量が必要です。
  • アドミニストレーティブをアップグレードするときに、共有名を更新した場合、クライアントは、次の機会にアプリケーションを開始すると、アップグレードされます。詳細は、アドミニストレーティブ イメージのアップグレード（Upgrading an Administrative Image）を参照してください。
  • アドミニストレーティブ イメージを展開するときは、イメージのパスを 58 文字未満にする必要があります。
  • クライアントには、各自のコンピュータにおける管理権限が必要です。クライアントは、十分な権限がない場合、別のユーザーとしてインストールを実行できます。本オプションが役立つのは、個別のユーザーが使用中のマシンで SOLIDWORKS 製品のインストールに必要なローカル管理権限を持っていないときです。

    オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）を参照してください。クライアントに十分な権限がないときにイメージをインストールする、別の方法についても説明されています。

  • Windows ログが有効な場合、またはアドミニストレーティブ イメージ オプション エディタでステータス機能を使用している場合、次のフォルダに対して読み取り/書き込み権限を持っている必要があります: {Administrative image directory}\x64\Logsをクリックします。

アドミニストレーティブ イメージを作成すれば、アドミニストレーティブ イメージ オプション エディタを用い、そのイメージからインストールするユーザーとグループに対するインストレーション オプション設定を管理することが可能です。 詳細は、アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）を参照してください。

目次

  • アドミニストレーティブ イメージのタイプ

    アドミニストレーティブ イメージ オプション エディタを使用して、リモート ユーザーおよびネットワーク上のユーザー用に複数のタイプのイメージを作成できます。

  • SOLIDWORKS Installation Manager を使ったアドミニストレーティブ イメージの作成（Creating an Administrative Image from SOLIDWORKS Installation Manager）

    SOLIDWORKS を複数コンピュータにインストールする場合は、アドミニストレーティブ イメージを作成し、アプリケーションを他のコンピュータで展開できます。

  • アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）

    アドミニストレーティブ イメージ オプション エディタでは、個々のマシンと、マシンのグループのためのアドミニストレーティブ イメージのインストレーション パラメータ設定をカスタマイズできます。

  • 設定アドミニストレータ ツール

親トピック 複数インストレーション（Multiple Installations）
複数クライアントへの展開（Deploying to Multiple Clients）
コマンドラインによる展開（Command-Line Deployment）
複数インストレーションの管理（Administration of Multiple Installations）
アドミニストレーティブ イメージからのクライアント アップグレード（Upgrading Clients from Administrative Images）


アドミニストレーティブ イメージのタイプ

アドミニストレーティブ イメージ オプション エディタを使用して、リモート ユーザーおよびネットワーク上のユーザー用に複数のタイプのイメージを作成できます。

アドミニストレーティブ イメージタイプ 説明
標準

このイメージは、すべての新しいアドミニストレーティブ イメージのデフォルトです。

標準的な Windows Installer 管理用イメージで、社内ネットワークに確実にアクセスできるユーザーに最適です。 選択した SOLIDWORKS 製品をインストールするために必要なすべてのファイルが共有インストール フォルダに保存されます。

ユーザーが新しいサービス パックにアップグレードする場合、パッチ ファイルをダウンロードして適用でき、イメージ全体をダウンロードする必要はありません。
リモート クライアント

このイメージは、社内ネットワークに確実にアクセスできないリモート ユーザー向けに設計されています。

このタイプのイメージをインストールすると、リモート ユーザーは、シリアル番号やインストールする製品など、指定したすべてのインストール オプションを継承します。

ユーザーは、必要なファイルを SOLIDWORKS ダウンロード ページからインターネット経由でダウンロードします。インターネットからこれらのファイルにアクセスしてインストールすると、会社のネットワークからダウンロードするよりも信頼性が高く、ネットワークの負荷が軽減される場合があります。

リモート ユーザーは、標準のアドミニストレーティブ イメージでサポートされている手法と同じ手法を使用して、このイメージをインストールします。 sldim.exe および startwinstall.exe ファイルを使用してインストールをスクリプト化することもできます。

インストール ファイルは、インストール前にアドミニストレーティブ イメージ オプション エディタで指定されたパスにダウンロードされます。 ユーザーは、アドミニストレーティブ インストール フォルダにアクセスしてインストールを開始し、そこにホストされているバッチ ファイルや設定ファイルを実行する必要があります。

リモート ユーザーは、イメージ内のすべてのファイルを保存できるディスク容量を持っている必要がありますが、そのイメージはインストールの完了後、削除できます。
圧縮

圧縮アドミニストレーティブ イメージは、複数のサイトまたはクライアント マシンにアドミニストレーティブ イメージをコピーする必要があり、ネットワークへの影響を最小限に抑える必要がある組織を対象としています。

このイメージは、標準アドミニストレーティブ イメージより 60% 小さくなっていますが、同じ時間でインストールされます。 変更や修復など、すべてのインストール操作をサポートします。

圧縮アドミニストレーティブ イメージにも短いファイルパスがあります。 これにより、イメージが階層の深いフォルダ構造に保存される際の問題を回避できます。

新しいサービス パックにアップグレードする場合は、パッチだけでなく、イメージ全体をダウンロードする必要があります。
親トピック アドミニストレーティブ イメージの使用（Using Administrative Images）


SOLIDWORKS Installation Manager を使ったアドミニストレーティブ イメージの作成（Creating an Administrative Image from SOLIDWORKS Installation Manager）

SOLIDWORKS を複数コンピュータにインストールする場合は、アドミニストレーティブ イメージを作成し、アプリケーションを他のコンピュータで展開できます。

  1. SOLIDWORKS Installation Manager を起動します。

    インストレーション メディアをダウンロード を参照してください。

  2. ようこそ（Welcome）画面で、アドミニストレーティブ イメージを作成して複数のコンピュータに展開（Create an administrative image to deploy to multiple computers）を選択し、次のいずれかのオプションを選択します。
    オプション | 説明
    新規イメージをデフォルト設定を使用して作成します。（Create a new image using default settings） | デフォルト設定を使用してイメージを作成します（サイトの既存のアドミニストレーティブ イメージに対して設定されている設定ではなく）。
    新規イメージを既存のイメージの設定とファイルを使用して作成します。（Create a new image using settings and files from an existing image.） | 現在のサイトの既存のアドミニストレーティブ イメージに指定されている設定を使用してイメージを作成します。 参照 をクリックして既存のアドミニストレーティブ イメージのインストール ディレクトリを指定します。
  3. SOLIDWORKS のシリアル番号（Serial Numbers）を入力します。
  4. 変更（Change）をクリックして、製品または次を含むデフォルト オプションを変更します。
    • アドミニストレーティブ イメージ位置
    • アドミニストレーティブ イメージタイプ
  5. 使用許諾契約を読み、今すぐ作成（Create Now）をクリックします。
  6. イメージのカスタマイズ（Customize Image）をクリックし、アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）で設定を開いて表示します。
  7. オプション: デスクトップ ショートカットを作成（Create desktop shortcut）をクリックして、デスクトップ上のイメージにアクセスします。
親トピック アドミニストレーティブ イメージの使用（Using Administrative Images）


アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）

アドミニストレーティブ イメージ オプション エディタでは、個々のマシンと、マシンのグループのためのアドミニストレーティブ イメージのインストレーション パラメータ設定をカスタマイズできます。

アドミニストレーティブ イメージを作成した後で、SOLIDWORKS Installation Manager はオプション エディタを開始するように要求します。 オプション エディタは、アドミニストレーティブ イメージ フォルダにある sldAdminOptionEditor.exe をダブルクリックにより、後から起動することも可能です。

マシンのグループまたは個々のマシンに対して異なるインストール構成を指定するには、オプション エディタで、マシンを選択します。次に、これらのマシンに対してインストール オプションを指定します。

ファイルまたはフォルダのパスを要求するすべてのダイアログ ボックスには、選択したフォルダを環境変数にマッピングするオプションがあります。たとえば、C:\Program Files\SOLIDWORKS Corp を選択した場合、ファイル パスは %ProgramFiles%\SOLIDWORKS Corp にマッピングされます。最も一般的な変数は、%ProgramFiles% と %SystemDrive% です。

すべてのパスを環境変数にマッピングできるわけではありません。たとえば、Z:\SOLIDWORKS Data を環境変数にマッピングすることはできません。

目次

  • グループとマシンの追加と削除（Adding and Deleting Groups and Machines）

    アドミニストレーティブ イメージのオプション エディタは、マシンのグループと個々のマシンに異なるインストレーション設定を指定できるようにします。

  • オプション設定の表示と編集（Viewing and Editing Option Settings）

    SOLIDWORKS アドミニストレーティブ イメージ オプション エディタでは、イメージに対して設定されたグループおよびマシンに対するオプション設定の確認と編集が可能です。

  • オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）

    手動またはプッシュによる方法を用いると、オプション エディタから直接インストレーションを展開できます。

  • オプション エディタの終了（Exiting the Option Editor）

    OK または閉じる（Close）をクリックして変更内容を適用して、オプション エディタを終了できます。

  • オプション エディタへのデスクトップ ショートカットの作成

    特定のアドミニストレーティブ イメージのためのオプション エディタへのWindowsのデスクトップ ショートカットをアプリケーション内から作成することが可能です。

  • 電子メールによるクライアントへのアドミニストレーティブ イメージの展開（Deploying an Administrative Image to Clients Through Email）

    共有のアドミニストレーティブ イメージ ディレクトリを作成したら、電子メールでクライアントに通知できます。

親トピック アドミニストレーティブ イメージの使用（Using Administrative Images）


グループとマシンの追加と削除（Adding and Deleting Groups and Machines）

アドミニストレーティブ イメージのオプション エディタは、マシンのグループと個々のマシンに異なるインストレーション設定を指定できるようにします。

たとえば、いくつかのマシンで、イメージに含まれる製品コンポーネントのサブセットを使用するように設定し、別のグループでは異なるコンポーネントのサブセットを使用するように設定することができます。 オプション エディタのグループ設定は 1 つのアドミニストレーティブ イメージを使用しているにもかかわらず、異なるマシンのグループに異なる製品のサブセットをインストールできるようにします。 グループ間で設定を移動したり、マシンのグループを編集したりできます。

また、マシンのグループをサブグループに分割することもできます。 サブグループは親グループから設定を継承しますが、サブグループごとに個別に設定を変更できます。

グループを追加するには:
  1. グローバル設定を右クリックし、グループ追加をクリックします。
  2. グループ名を入力します。

マシンを追加するには:
  1. 既存のグループまたはグローバル設定を右クリックし、マシン追加をクリックします。
    既存のグループを右クリックした場合、マシンはそのグループに追加されます。 他の場合、マシンはトップレベルに追加されます。
  2. 次のいずれかの操作を行います:
    • マシン名（By Machine Name）を選択し、マシン名を入力します。
      マシン名にドメイン修飾子を含めることはできません。例えば、pluto.solidworks.com は無効です。
    • IP アドレス（By IP Address）を選択し、マシンの IP アドレスを入力します。
    • IP アドレスの範囲（By IP Address Range）を選択し、指定する範囲の開始 IP アドレスと終了 IP アドレスを入力します。
    • 複数のマシン追加（Add Multiple Machines）をクリックして、マシン名を入力します。マシン名は、改行、スペース、タブ、カンマ、ピリオド、コロン、またはセミコロンで区切ることができます。また、*.xls ファイルや *.cvs ファイルなどの区切りファイルからマシン名のリストをコピーして、ダイアログ ボックスに貼り付けることもできます。

    マシンを、名前、IP アドレス、および IP アドレスの範囲で追加すると、インストール マシンは次の順序で一致するものを検索します: マシン名（Machine Name）、IP アドレス（IP Address）、IP アドレスの範囲（IP Address Range）。インストール オプションは、検出された最初の一致に基づくインストール マシンに適用されます。

既存のマシンをグループまたはサブグループに移動するには:

マシンをグループまたはサブグループにドラッグします。

マシンをグループ外またはサブグループ外に移動するには:

グローバル設定（Global Settings）にマシンをドラッグするか、他のグループかサブグループにドラッグします。

グループ、サブグループ、マシンを削除するには:

グループ、サブグループ、マシンを右クリックし、グループ削除（Delete Group）またはマシン削除（Delete Machine）をクリックします。

グループを削除した場合、グループ内のすべてのマシンは削除されます。

すべてのグループとマシンを削除するには:

グローバル設定を右クリックし、すべて削除をクリックします。

親トピック アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）
オプション設定の表示と編集（Viewing and Editing Option Settings）
オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）
オプション エディタの終了（Exiting the Option Editor）
オプション エディタへのデスクトップ ショートカットの作成
電子メールによるクライアントへのアドミニストレーティブ イメージの展開（Deploying an Administrative Image to Clients Through Email）


オプション設定の表示と編集（Viewing and Editing Option Settings）

SOLIDWORKS アドミニストレーティブ イメージ オプション エディタでは、イメージに対して設定されたグループおよびマシンに対するオプション設定の確認と編集が可能です。

  • オプション エディタを最初に起動すると、オプション設定が読み取り専用モードで表示されます。 変更アイコン [image] は押された状態になっていません。

    グローバル設定、グループ、またはマシンをクリックすると、該当アイテムに対するオプション設定のサマリが表示されます：

    スコープ（Scope） | 表示されるオプション設定
    グローバル設定 | アドミニストレーティブ イメージに対して指定されたすべてのオプション設定
    グループ | グローバル設定と比較してグループ設定で変更された内容
    工作機械 | グループ設定と比較してマシン設定で変更された内容
  • オプション設定を変更するには、変更（Change） [image] をクリックします。 アイコン表示が押された状態になり、より詳細なオプション設定の一覧が表示されます。

    グローバル設定、グループ、またはマシンをクリックすると、該当アイテムに対するオプション設定が変更可能です。 変更により、グローバル設定やグループ設定から継承された設定から変わったオプション設定は、ハイライト表示されます。

    変更（Change） [image] を再度クリックすると、表示は読み取り専用モードに戻ります。

    変更を行った場合は、オプション エディタの終了時に、それらの保存または破棄が要求されます。

目次

  • グループとマシンのオプション設定を指定（Specifying Option Settings for Groups and Machines）

    すべてのマシン（グローバル設定）、グループのマシン、個々のマシンのオプション設定を指定することができます。

  • アドミニストレーティブ イメージのオプション設定（Administrative Image Option Settings）

    オプション エディタで各クライアントやグループのオプション設定（シリアル番号、クライアント インストレーション オプション、インストールするソフトウェア コンポーネント、ツールボックスの場所などを含む）を指定できます。

  • グローバルおよびグループ オプション設定の継承（Inheritance of Global and Group Option Settings）

    グローバル設定（Global Settings）やグループに対するオプション設定は、それらの下にあるアイテムで継承されます。

  • 各マシンの設定のカスタマイズ

    マシン名を右クリックして、そのマシンに適用した設定を変更することもできます。

親トピック アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）
グループとマシンの追加と削除（Adding and Deleting Groups and Machines）
オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）
オプション エディタの終了（Exiting the Option Editor）
オプション エディタへのデスクトップ ショートカットの作成
電子メールによるクライアントへのアドミニストレーティブ イメージの展開（Deploying an Administrative Image to Clients Through Email）


グループとマシンのオプション設定を指定（Specifying Option Settings for Groups and Machines）

すべてのマシン（グローバル設定）、グループのマシン、個々のマシンのオプション設定を指定することができます。

  1. オプション エディタで、修正するオブジェクト（グローバル設定、グループ、またはマシン）をクリックします。
  2. 右側で、変更（Change） [image] をクリックします。
    アイコン表示が押された状態になり、より詳細なオプション設定の一覧が表示されます。
  3. 左側で選択されたアイテムに対する右側のオプション設定をクリックすることにより、それらを変更します。
    グローバル設定やグループ設定をオーバーライドするオプション設定の変更は、ハイライト表示されます。
  4. OKまたは閉じるをクリックして、変更内容を保存します。
    オプション | 説明
    OK | 変更内容が保存され、オプション エディタが終了します。
    閉じる（Close） | 変更内容を保存するか否かについてユーザーに質問を行い、その対応を受けた後、オプション エディタを終了します。
親トピック オプション設定の表示と編集（Viewing and Editing Option Settings）
アドミニストレーティブ イメージのオプション設定（Administrative Image Option Settings）
グローバルおよびグループ オプション設定の継承（Inheritance of Global and Group Option Settings）
各マシンの設定のカスタマイズ


アドミニストレーティブ イメージのオプション設定（Administrative Image Option Settings）

オプション エディタで各クライアントやグループのオプション設定（シリアル番号、クライアント インストレーション オプション、インストールするソフトウェア コンポーネント、ツールボックスの場所などを含む）を指定できます。

シリアル番号（Serial Numbers）

クライアント マシンに製品をインストールするためにシリアル番号を入力します。
SOLIDWORKS 製品を購入するには複数の方法があるため、一部のシリアル番号は複数の製品に対応している場合があります。たとえば、 SOLIDWORKS シリアル番号は、個々の SOLIDWORKS Simulation シリアル番号を入力しないで SOLIDWORKS Simulation のインストールを可能にします。また、一部の製品はシリアル番号を必要としません。シリアル番号に関する質問は、お客様の代理店までご連絡ください。
ライセンス管理を SolidNetWork ライセンスを用いて行っている場合:
  • 最初のシリアル番号フィールドに SolidNetWork のシリアル番号を入力します。
  • SNLサーバー ポート@サーバー（SNL Server port@server）フィールドにSolidNetWork License Managerのサーバー名とポートをnnnnn@サーバー名の形式で入力します。 複数のエントリはセミコロンにより区切ってください。

SolidNetWork ライセンスに関する詳細は、「SolidNetWork ライセンスのインストールの概要」を参照してください。

クライアント インストレーション オプション（Client Installation Options）

メジャー バージョンのクライアント インストールどの方法で行いますか? クライアントのインストールでは、インストール済みの古いメジャー バージョンの取り扱い方法を指定できます。
  • 既存のメジャー バージョン（存在する場合）をアップグレードします。

    インストール済みの古いメジャー バージョンを新しいバージョンのインストールで置き換えるには、このオプションを指定します。

  • 新規メジャー バージョンをインストールします。

    インストール済みの古いメジャー バージョンを保持したまま、新しいメジャー バージョンをインストールするには、このオプションを指定します。 新しいバージョンのインストール先を指定するには、参照（Browse）をクリックします。
新しいメジャー バージョンをインストールする前に、最も最新の前のバージョンをアンイストールしますか? インストール済みの古いメジャー バージョンをアンインストールするかどうかを指定できます:
  • アンインストールしません。

    古いメジャー バージョンを保持する場合に選択します。

  • 最新のバージョンをアンインストールします。
  • すべてのバージョンをアンインストールします。
SOLIDWORKS 設定をどのように適用しますか? ソフトウェアの起動時に設定ファイルを指定できます。クライアント インストレーションは設定ファイルを参照します。設定（*.sldsettings）ファイルは、すべてのインストールで表示可能な共有 UNC パスに保存する必要があります。SOLIDWORKS をインストールする前に *.sldsettings パスを指定してください。クライアント インストールは、インストール中に *.sldsettings ファイル パスを検出します。
指定したユーザーのみ書き込みアクセス権を許可するように Windows のファイル権限を指定することによって、*.sldsettings ファイルを保護します。

*.sldsettings を作成または編集するには、設定アドミニストレータ実行（Launch Settings Administrator）をクリックします。SOLIDWORKS 設定アドミニストレータ（Settings Administrator）ツールで、どの SOLIDWORKS システム オプションをエンド ユーザーに適用し、オプションでロックするかを定義できます。個々のインストールに対して、設定をいつどのように適用するか定義することもできます。また *.sldsettings ファイルは、設定アドミニストレータ（Settings Administrator）ツールを実行して、既存ファイルを上書きすることによって、いつでも変更できます。

さまざまなマシンまたはグループに対して、異なる *.sldsettings ファイルを使用できます。

*.sldsettings へのパスはインストール時に設定されます。展開後、*.sldsettings ファイルは、名前を変更したり、移動したりしないでください。

設定アドミニストレータ（Settings Administrator）ツールを実行するには、既存の SOLIDWORKS [現行メジャー バージョン] のインストールが必要です。
クライアント インストレーションはどの方法でアクティブ化しますか? ライセンスのアクティブ化は、インストール後に自動で完了するか、あるいはユーザーが手動で行うかを選択することが可能です。
  • 各クライアント インストレーションが完了した時点で自動的にアクティベーションを行います。（Activate automatically when each client installation completes.）

    このオプション設定を選択すると、製品アクティベーションが自動的に実行されます。クライアント コンピュータでアクティベーションを実行するときに指定する電子メール アドレスを入力します。

  • 自動的にアクティブ化しません。（Do not activate automatically.）

    オプションを選択すると、製品は自動的にアクティブ化されません。クライアントは、インストレーション後に製品をアクティブ化します。

アドミニストレーティブ オプション（Administrative Options）

各インストレーションに対して診断ログ ファイルを作成します。 | クライアントのインストールでは、インストール時に発生した問題をトラブルシューティングするための診断ログを作成できます。 このログを作成すると、クライアントのインストール速度が遅くなります。 ログ ファイルは、{アドミニストレーティブ イメージ ディレクトリ}\x64\Logs\<マシン名> に格納されます。
別ユーザーとしてインストレーションを実行。

ログイン ユーザーの代わりに、管理権限を持つ別のユーザーを指定して、インストールを実行できます。このオプションは、個別のユーザーが、使用中のマシンで SOLIDWORKS 製品のインストールに必要なローカル管理権限を持っていない場合に便利です。

クライアントが管理権限を持っていない場合、展開とインストールは別の方法で実行できます。 オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor） を参照してください。
インストレーションの前後に実行するプログラム。 | クライアントのインストール前後におけるユーザー定義プログラムの実行を指定できます。
クライアントは SOLIDWORKS ユーザー パフォーマンス フィードバック プログラムに参加しますか? | クライアント マシンの SOLIDWORKS ユーザー パフォーマンス フィードバック プログラムへの参加を指定できます。 パフォーマンス インフォメーションが、製品改善の手助けの為に SOLIDWORKS Corporation に送られます。 このプロセスでは透明性と機密情報が確保されます。 詳細は Customer Experience Improvement Program Web サイトを参照してください。

インスレーションの前にプログラムを作動 (Run a Program Before Installation) オプションおよび インスレーションの後にプログラムを作動 (Run a Program After Installation) オプション

これらのオプションを使用すると、SOLIDWORKS を展開する前後に他のインストール プログラムまたはスクリプト（例: Microsoft Office をインストールするスクリプト）をクライアント マシンで実行できます。

これらのオプションを使用する際には制限があります。いずれかのオプションを使用して、ユーザー インタフェースを表示するインストール プログラムまたはスクリプト（例: ダイアログ ボックスを表示するスクリプト）を展開した場合、失敗が生じます。SOLIDWORKS の自動展開が実行されても、SOLIDWORKS がターゲット マシンにインストールされません。

インストレーションの前にプログラムを作動（Run a program before installation）オプションと インストレーションの後にプログラムを作動（Run a program after installation）オプションを使用するには、サイレント モードでインストール可能なプログラムのみを選択する必要があります。

インストールするソフトウェア

インストールする SOLIDWORKS 製品は指定することが可能です。
  • クライアントのインストール中にインストールされる製品コンポーネントを指定するには、コンポーネントの隣にあるチェックボックスを選択します。
  • チェックボックスの選択を解除すると、そのコンポーネントはインストールされません。
  • コンポーネント内にサブコンポーネントがある場合には、コンポーネントの隣に + アイコンが表示されます。 利用可能なサブコンポーネントを確認するには、+ アイコンをクリックしてください。
  • コンポーネントが展開されサブコンポーネントが表示されている場合は、コンポーネントの隣に - アイコンが表示されます。 サブコンポーネントへの展開を解除するには、- アイコンをクリックしてください。
言語（Languages）仕様はインストールされる言語を SOLIDWORKS 製品でのみ限定します。 その他の製品のインストレーションはこの仕様では影響されません。 たとえば、eDrawings® ではすべての言語版がインストールされます。

Toolbox オプション

クライアントのインストールに対しては、サポートする規格とデフォルトの Toolbox の場所を指定することが可能です。

Toolboxへのアクセスはネットワーク上のフォルダを、UNCパス、共有フォルダ、共通のネットワーク ドライブ指定等を用い、複数のユーザーで共有することが一般的です。

該当する場所に古いメジャー バージョンの Toolbox が存在する場合は、クライアントのインストール時に新しいメジャー バージョンの Toolbox にアップグレードされます。 このファイルは、古いメジャー バージョンの SOLIDWORKS との互換性をもはや持ちません。
一部のクライアントが古いバージョンの SOLIDWORKS を継続して使用する場合、新しいバージョンにアップグレードするクライアントには異なる Toolbox ネットワーク ロケーションを指定する必要があります。

SOLIDWORKS Toolbox の管理に関する詳細は、SOLIDWORKS ヘルプの Toolbox 情報を参照してください。

Toolbox データをインストールせずに Toolbox ソフトウェアをインストールする

ご使用の環境に PDM または共有の Toolbox/穴ウィザードの場所がある場合は、その場所で Toolbox データのインストールまたはアップグレードを実行しないようにクライアントのインストールを指定できます。

次のような場合にこの設定を行います。
  • SOLIDWORKS をインストールする前に SOLIDWORKS PDM ローカル ビューをまだ指定していない場合。
  • その場所にあるファイルを使用中であり、SOLIDWORKS インストールの完了がブロックされる可能性がある場合。
  • その場所を使用できず、SOLIDWORKS インストールの完了がブロックされる可能性がある場合。

クライアントのインストールを Toolbox データをインストールしないように指定すると、SOLIDWORKS ソフトウェアと設定では Toolbox/穴ウィザードの位置が指定されますが、後で中央の場所にデータをインストールする必要があります。

Toolbox/穴ウィザード データを含まない SOLIDWORKS ソフトウェアをインストールするには:
  • このクライアントで Toolbox ファイルのインストール/アップグレードを行うかどうか尋ねられたら、いいえ、データ ファイルなしで Toolbox ソフトウェアをインストールします（No, install the Toolbox software without including the data files）を選択します。

少なくとも 1 人のユーザー（通常は CAD 管理者）が、Toolbox/穴ウィザードのデータを中央の場所にインストールまたはアップグレードする必要があります。そうしないと、ソフトウェアは正しく機能しません。組織内の誰でも、SOLIDWORKS ソフトウェアを 1 回手動インストールするだけで、このタスクを処理できるようになります。SOLIDWORKS PDM 内で Toolbox を管理する場合は、『SOLIDWORKS PDM アドミニストレーション ガイド』の Toolbox セクションに記載されている手順に従って、Toolbox データをインストールまたはアップグレードします。

SOLIDWORKS PDM Client オプション

SOLIDWORKS PDM のクライアントとアドインを配布する際に、次のオプションを選択できます:

  • PDM 製品のタイプ
  • PDM クライアントの種類
  • フィーチャー
  • ボルト ビュー（Vault View）

    ビュー セットアップ ウィザード（View Setup Wizard）を開くには、SOLIDWORKS PDM クライアントがインストールされているマシンでアドミニストレーティブ イメージ オプション エディタを実行する必要があります。

    クライアント マシン上にボルト ビューを作成するには、クライアント マシン上でボルト ビューを設定するためのパラメータを定義する Conisio View Setup（.cvs）ファイルが必要です。既存の .cvs ファイルを参照するか、アドミニストレーティブ イメージ オプション エディタからこのファイルを作成できます。

これらのクライアントやアドインの詳細については、SOLIDWORKS ヘルプの SOLIDWORKS PDM のセクションを参照してください。

Electrical オプション

SOLIDWORKS Electrical の管理コンポーネントに次のパラメータを指定できます。
  • データ パス
  • Collaborative Server マシン名とポート番号
  • SQL Server マシン名とパスワード

これらのコンポーネントの詳細については、SOLIDWORKS Electrical を参照してください。

親トピック オプション設定の表示と編集（Viewing and Editing Option Settings）
グループとマシンのオプション設定を指定（Specifying Option Settings for Groups and Machines）
グローバルおよびグループ オプション設定の継承（Inheritance of Global and Group Option Settings）
各マシンの設定のカスタマイズ
SolidNetWork ライセンスのインストールの概要
オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）
SOLIDWORKS Electrical


グローバルおよびグループ オプション設定の継承（Inheritance of Global and Group Option Settings）

グローバル設定（Global Settings）やグループに対するオプション設定は、それらの下にあるアイテムで継承されます。

例:
  • グローバル設定（Global Settings）に定義された設定は、すべてのグループとマシンに継承されます。
  • グループのために定義された設定は、そのグループの中ですべてのサブグループおよびマシンに継承されます。

グループ、サブグループ、またはマシンのオプション設定で、デフォルトに上書きするか、設定を継承するかを変更することができます。 オプション設定をデフォルト、またはその継承された値から変えるとき、そのオプションはハイライトされます。

オプション設定を元の継承された値に戻すには、グループ、サブグループ、またはマシンを右クリックし、次のいずれかをクリックします。
  • グローバル設定に戻す（Revert to Global Settings）（グループ メンバーではないグループ、サブグループ、またはマシンが対象）
  • グループ設定に戻す（Revert to Group Settings）（グループ メンバーであるマシンが対象）
  • メンバーをグループ設定に戻す（Revert All Members to Group Settings）（そのグループのすべてのメンバーを対象にして一度に）
親トピック オプション設定の表示と編集（Viewing and Editing Option Settings）
グループとマシンのオプション設定を指定（Specifying Option Settings for Groups and Machines）
アドミニストレーティブ イメージのオプション設定（Administrative Image Option Settings）
各マシンの設定のカスタマイズ


各マシンの設定のカスタマイズ

マシン名を右クリックして、そのマシンに適用した設定を変更することもできます。

ショートカット メニューから、各マシンに対して以下の操作を実行できます。
  • 名前変更（Rename）
  • マシン削除（Delete machine）
  • グローバル設定に戻す（Revert To Global Settings）
  • 注記編集（Edit Notes）
  • 編集オプション（Edit Options）

[編集オプション]（Edit options）では、クライアント インストール オプションやアドミニストレーティブ オプションなど、そのマシンのすべてのオプションを変更できます。

親トピック オプション設定の表示と編集（Viewing and Editing Option Settings）
グループとマシンのオプション設定を指定（Specifying Option Settings for Groups and Machines）
アドミニストレーティブ イメージのオプション設定（Administrative Image Option Settings）
グローバルおよびグループ オプション設定の継承（Inheritance of Global and Group Option Settings）


オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）

手動またはプッシュによる方法を用いると、オプション エディタから直接インストレーションを展開できます。

  • インストールの開始方法に関する電子メールの指示をユーザーに送信するには、オプション エディタの [手動配布（Deploy Manually）] ページを使用します。 この方法は、ユーザーがクライアント マシンの管理権限を持っている場合に使用します。
    アドミニストレーティブ オプション（Administrative Options）で、別ユーザーとしてインストレーションを実行（Run the installation as a different user）を選択することにより、管理者権限をユーザーに割り当てることができます。
  • ターゲット マシンにインストレーションを自動的にプッシュするには、オプション エディタの [自動配布（Deploy Automatically）] ページを使用します。 この方法は、ユーザーがシステムにソフトウェアをインストールする管理権限を持っていない場合に使用します。 この方法でカスタム インストールを実行することもできます。

手動または自動で展開するには、アドミニストレーティブ イメージのインストール ディレクトリを Windows 共有ディレクトリに保存し、ネットワークを介して使用可能にする必要があります。たとえば \\machine\shared_directory などです。または、 C:\SOLIDWORKS Admin\SOLIDWORKS 2025 SP0 など、各マシンのローカル ディレクトリにイメージをコピーして展開させることも可能です。

目次

  • UNC パスを使用したアドミニストレーティブ イメージの展開

    ネットワーク ドライブの場所をマッピングする代わりに、UNC パス (\\machine_name\share_name) を使用して、アドミニストレーティブ イメージのインストール ディレクトリのネットワーク ロケーションを指定します。

  • StartSWInstall.exe によるアドミニストレーティブ イメージの展開

  • 手動で展開する

    システムへのインストールに必要な権限がある場合は、この方法を使用できます。

  • 自動展開の前提条件

    自動展開は、ソフトウェアのインストールをシームレスに進めることができるため、管理者権限のないユーザーに効果的です。

  • 自動的に展開する

  • プッシュ展開の設定のテスト

    アドミニストレーティブ イメージ オプション エディタの自動配布（Deploy Automatically）タブには、テスト フィーチャーが含まれています。

親トピック アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）
グループとマシンの追加と削除（Adding and Deleting Groups and Machines）
オプション設定の表示と編集（Viewing and Editing Option Settings）
オプション エディタの終了（Exiting the Option Editor）
オプション エディタへのデスクトップ ショートカットの作成
電子メールによるクライアントへのアドミニストレーティブ イメージの展開（Deploying an Administrative Image to Clients Through Email）


UNC パスを使用したアドミニストレーティブ イメージの展開

ネットワーク ドライブの場所をマッピングする代わりに、UNC パス (\\machine_name\share_name) を使用して、アドミニストレーティブ イメージのインストール ディレクトリのネットワーク ロケーションを指定します。

マッピングされたネットワーク ドライブは、プッシュ方式の自動インストール方法とも、プル方式の手動方法による”異なるユーザーとして実行（Run As Different User）”にも適合しません。

親トピック オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）


StartSWInstall.exe によるアドミニストレーティブ イメージの展開

クライアント上でアドミニストレーティブ イメージをインストールまたはアンインストールするには、admin_image_install_dir\ StartSWInstall.exe コマンドを実行します。 この方法により、アドミニストレーティブ イメージ オプション エディタで定義されたオプション、マシン、およびグループを使用して SOLIDWORKS がインストールされます。

StartSWInstall.exe コマンドには以下のオプションを追加できます。
スイッチ | 説明
/install | クライアント マシンにアドミニストレーティブ イメージをインストールします。
/uninstall クライアント マシンからソフトウェアをアンインストールします。次の 2 つのオプションを使用できます。

/removedata

アンインストールの場合のみ有効です。 アンインストール時に SOLIDWORKS のデータ ファイルおよびフォルダを削除します。

/removeregistry

アンインストールの場合のみ有効です。 アンインストール時に SOLIDWORKS のレジストリ エントリを削除します。
/showui | SOLIDWORKS Installation Manager のプログレス ウィンドウを表示します。 指定しなかった場合、SOLIDWORKS Installation Manager はユーザーに対して非表示になります。
/now | インストールまたはアンインストールを直ちに開始します。 5 分間の警告ダイアログ ボックスは表示されません。

ユーザー操作なしでインストールを実行したいが、アドミニストレーティブ イメージ オプション エディターの自動展開を使用したくない場合は、StartSWInstall.hta ではなく StartSWInstall.exe を使用することを推奨します。

親トピック オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）


手動で展開する

システムへのインストールに必要な権限がある場合は、この方法を使用できます。

電子メールを使用して手動でインストレーションを展開するには:

  1. オプション エディタで展開をクリックします。
    それぞれのマシンに対するステータスと利用可能なインストールが表示されます。
  2. メール送信 をクリックします。
  3. アドミニストレーティブ イメージのインストール ディレクトリに対するネットワーク パスを指定します。
    一般的にアドミニストレーティブ イメージのインストール ディレクトリに対するディレクトリ パスは、初期状態において、（C:\SOLIDWORKS Admin\SOLIDWORKS 2025 SP0 のように）Windows のファイル パスで表示されます。ダイアログ ボックスにはこのパスはネットワーク パスではありませんと表示されます。
    1. 参照 をクリックして、このアドミニストレーティブ イメージのインストール ディレクトリに対するネットワーク ロケーションを指定します。
    2. アドミニストレーティブ イメージがインストールされたコンピュータを探し、アドミニストレーティブ イメージに対するWindowsの共有ディレクトリを選択します。
      アドミニストレーティブ イメージの共有ディレクトリの内部（64bit のサブディレクトリなど）は選択しないでください。
    3. OK をクリックします。
      ダイアログ ボックスにはこのパスはネットワーク パスですと表示されます。
    電子メールが作成されます。このメールは、アドミニストレーティブ イメージ内の StartSWInstall.hta ファイルに対するネットワーク ロケーションを使用してアドミニストレーティブ イメージからインストールする方法をマシンの所有者に伝えるものです。
  4. SOLIDWORKS のインストール権限を持つユーザーに電子メールを送信してください。

ユーザーは電子メールに記述された StartSWInstall.hta に対するネットワーク ロケーションのリンクをダブルクリックすることで、アドミニストレーティブ イメージから SOLIDWORKS をインストールできます。

オプション エディターでは、インストレーション ステータス で次のように表示されます：
保留中 | ユーザーによる該当マシンへのインストールは未だ実施されていません。
成功 | ユーザーによる該当マシンへのインストールは無事完了しています。
失敗 | ユーザーによる該当マシンへのインストールが実施されましたが、失敗しました。
表示される可能性がある他のステータスメッセージは、次のとおりです: 「正常にインストールされました」、「正常にアンインストールされました」、「インストール中」、「アンインストール中」、「再起動が必要です」、「インストールできませんでした」、「アンインストールできませんでした」。
ステータス（Status）列の一番上にある緑色の矢印をクリックしてリフレッシュして、更新された情報を表示します。
親トピック オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）


自動展開の前提条件

自動展開は、ソフトウェアのインストールをシームレスに進めることができるため、管理者権限のないユーザーに効果的です。

自動展開を使用するには、クライアントとサーバーの両方が、同じ Active Directory ドメインに属している必要があります。このコンフィギュレーションにより、インストール タスクをターゲット マシンにプッシュでき、ユーザーが操作しなくても、Microsoft タスク スケジューラによってタスクが実行されます。

プッシュ インストールでは、タスク スケジューラは、オプション エディタで管理者により指定された資格情報を使用して、クライアント マシン上で SOLIDWORKS Installation Manager を起動するタスクを実行します。 タスク スケジューラはコンピュータの LocalSystem アカウントに従って動作します。 このアカウントはネットワーク上で、コンピュータ セキュリティ原則として表示されます。 コンピュータ セキュリティ原則には、次のアクセス権が必要です:
  • アドミニストレーティブ イメージ フォルダへの読み取りアクセス権。
  • <アドミニストレーティブ イメージ フォルダ>\x64\logs フォルダへの読み取り/書き込みアクセス権。

Active Directory では、共有フォルダのグループにコンピュータを追加する場合、オブジェクト タイプ（Object Types）とコンピュータ（Computers）を選択します。

また、アドミニストレーティブ イメージをホストするコンピュータとターゲット クライアント マシンが、同じ Active Directory ドメインのメンバーである必要があります。

親トピック オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）


自動的に展開する

ユーザー システムにインストールをプッシュして自動的に展開するには:

  1. オプション エディタで自動配布タブをクリックします。
    それぞれのマシンに対するステータスと利用可能なインストールが表示されます。
  2. 展開（Deploy）列では、展開（Deploy）列のターゲットのクライアント マシンとグループを選択します。
    展開プロセスを開始する前に、展開（Deploy）列で 1 つ以上のマシンまたはグループを選択します。
  3. インストール時間 で、今すぐ を選択してすぐに展開するか、後で実行 を選択して展開する特定の日時をスケジュールします。
  4. クライアント オプション（Client Options）で、以下を選択します:
    • SOLIDWORKS 2025 インストールまたはアップグレード
    • SOLIDWORKS 2025 アンインストール
      アンインストールを選択する場合、プログラム ファイルおよびプログラム フォルダーと共にレジストリ エントリ、データ ファイル、データ フォルダーをアンインストールするかどうかを指定できます。
  5. 展開中または展開後に必要に応じて 1 台以上のターゲット マシンを再起動する場合は、コンピュータの自動再起動（Reboot computer automatically）を選択します。
  6. 1 台以上のターゲット マシンのクライアント資格情報（Client Credentials）を入力します。
  7. 展開（Deploy）をクリックして展開プロセスを開始します。
オプション エディタには次のようなインストレーション ステータスが表示されます:
保留中 | このマシンではまだインストールが実行されていません。
成功 | このマシンでのインストールは正常に完了しました。
失敗 | このマシンでのインストールは失敗しました。

表示される可能性がある他のステータスメッセージは、次のとおりです: 「正常にインストールされました」、「正常にアンインストールされました」、「スケジューリング」、「接続中」、「インストール中」、「アンインストール中」、「再起動が必要です」、「インストール スケジュール済」、「アンインストール スケジュール済」、「インストールできませんでした」、「アンインストールできませんでした」、「接続できませんでした」、「スケジュールできませんでした」。

親トピック オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）


プッシュ展開の設定のテスト

アドミニストレーティブ イメージ オプション エディタの自動配布（Deploy Automatically）タブには、テスト フィーチャーが含まれています。

次のように配置に使用されるシステムの練習となるモックアップ インストールを実行できます。
  • ターゲット コンピュータへの接続。
  • そのコンピュータへのインストール タスクの作成。
  • そのコンピュータでのインストール タスクの完了。
  • アドミニストレーティブ イメージのステータスおよびログの更新。
  • インストール前またはインストール後に実行するプログラムの検出。

テストはファイル パスを確認し、権限を検証して、インストールが正常に終了したことをレポートします。ターゲット システムにソフトウェアをインストールしたり、レジストリを変更したりすることはありません。いずれかのターゲット コンピュータでシステムに障害が発生した場合、テストは障害が発生したシステムを示します。

ツールチップには、障害に関する詳細情報が表示されます。結果を .xml スプレッドシートまたは .csv にエクスポートできます。これは、複数のエラーを確認したり、他のサポート担当者と結果を共有したりするのに役立ちます。

プッシュ展開の設定をテストするには:

  1. Installation Manager を使用してアドミニストレーティブ イメージを作成します。
  2. アドミニストレーティブ イメージ オプション エディタを起動します。

    このオプションは、 Installation Manager がアドミニストレーティブ イメージの作成を完了した後に起動することも、アドミニストレーティブ イメージ フォルダの sldAdminOptionEditor.exe をダブルクリックして起動することもできます。

  3. セットアップ（Setup）タブで、1 つまたは複数のコンピュータを追加します。
  4. 自動配布（Deploy Automatically）をクリックします。
    1. ドメイン管理者のユーザー名とパスワードを入力します。
    2. テストするコンピュータを1つ以上選択します。
    3. テスト（Test） をクリックします。
  5. 設定テストが表示されたら、テストを実行（Run Test）をクリックします。
  6. テストが完了するまで数分間待つか、いつでもテストのキャンセル（Cancel Test）をクリックします。
  7. 設定の問題を確認して修正します。
親トピック オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）


オプション エディタの終了（Exiting the Option Editor）

OK または閉じる（Close）をクリックして変更内容を適用して、オプション エディタを終了できます。

  • OK をクリックすると、オプション設定の変更内容が適用され、オプション エディタが終了します。
  • Windows アプリケーションの閉じる（Close）ボタンをクリックして、オプション エディタを終了します。未保存の変更内容が存在することが検出された場合は、保存を求めるメッセージが表示されます。
親トピック アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）
グループとマシンの追加と削除（Adding and Deleting Groups and Machines）
オプション設定の表示と編集（Viewing and Editing Option Settings）
オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）
オプション エディタへのデスクトップ ショートカットの作成
電子メールによるクライアントへのアドミニストレーティブ イメージの展開（Deploying an Administrative Image to Clients Through Email）


オプション エディタへのデスクトップ ショートカットの作成

特定のアドミニストレーティブ イメージのためのオプション エディタへのWindowsのデスクトップ ショートカットをアプリケーション内から作成することが可能です。

  1. オプション エディタを起動します。
    たとえばファイル エクスプローラにおいて、アドミニストレーティブ イメージのインストール ディレクトリに移動し、sldAdminOptionEditor.exe をダブルクリックします。
  2. デスクトップにこのオプション エディタへのショートカットを作成（Create Desktop Shortcut to this Option Editor）をクリックします。
    該当するアドミニストレーティブ イメージのためのオプション エディタへのショートカットが、Windowsデスクトップに作成されます。
親トピック アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）
グループとマシンの追加と削除（Adding and Deleting Groups and Machines）
オプション設定の表示と編集（Viewing and Editing Option Settings）
オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）
オプション エディタの終了（Exiting the Option Editor）
電子メールによるクライアントへのアドミニストレーティブ イメージの展開（Deploying an Administrative Image to Clients Through Email）


電子メールによるクライアントへのアドミニストレーティブ イメージの展開（Deploying an Administrative Image to Clients Through Email）

共有のアドミニストレーティブ イメージ ディレクトリを作成したら、電子メールでクライアントに通知できます。

アドミニストレーティブ イメージ ディレクトリは、他のコンピュータからアクセス可能なマシン（例えば、UNCパス経由）で共有されるように設定します。

すべてのクライアントに admin_image_install_dir\StartSWInstall.hta へのリンクを含む電子メールを送信できます。 その後、クライアントはこのリンクをクリックし、続いて SOLIDWORKS 製品のインストール開始（Install SOLIDWORKS products now） をクリックし、アドミニストレーティブ イメージからのインストレーションを開始します。

新しい SOLIDWORKS バージョンのアドミニストレーティブ イメージをアップグレードしている場合は、そのイメージを使用して前にインストールしたクライアントが自動的にアップグレードされるように、アドミニストレーティブ イメージの場所と共有プロパティを設定できます。詳細については、アドミニストレーティブ イメージからのクライアント アップグレード (Upgrading Clients from Administrative Images)を参照してください。
親トピック アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）
グループとマシンの追加と削除（Adding and Deleting Groups and Machines）
オプション設定の表示と編集（Viewing and Editing Option Settings）
オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）
オプション エディタの終了（Exiting the Option Editor）
オプション エディタへのデスクトップ ショートカットの作成


設定アドミニストレータ ツール

設定アドミニストレータ ツールを使用して、SOLIDWORKS ソフトウェアを展開またはアップグレードするときに適用されるシステム オプションを指定すること、またユーザーがそれらのオプションを変更できないようにすることができます。このツールは、設定を展開するための SOLIDWORKS 設定ウィザードに置き換わりますが、そのウィザードは引き続き設定のコピーに利用できます。

アドミニストレーティブ イメージ オプション エディタで設定アドミニストレータ ツールを使用するためのステップが 3 つあります。
  1. ツールにアクセスするためのアドミニストレーティブ イメージを作成します。
  2. 設定アドミニストレータ ツールを使用して、選択した SOLIDWORKS オプションを含む *.sldsettings ファイルを生成します。
  3. *.sldsettings ファイルを SOLIDWORKS インストレーションに含めます。
3DEXPERIENCE アドインを使用している場合は、アドミニストレーティブ イメージの外部に *.sldsettings ファイルを展開することもできます。この方法を使用する利点は、設定がログイン時に自動的に展開されることです。
  1. 設定アドミニストレータ ツールにアクセスするには、設定アドミニストレータ ツールにアクセスするに記載されている手順に従います。
  2. 指示に従って設定を適用およびロックします。
  3. 3DEXPERIENCE Compass で、マイ ロール（My Roles）を展開し、プラットフォーム マネージャー（Platform Manager）アプリケーションをクリックします。内容（Content） > コラボレーション スペース構成センター（Collaborative Spaces Configuration Center） > CAD コラボレーション（CAD Collaboration） > SOLIDWORKS > 設定（Settings） > リソース（Resources） > CAD 設定（CAD Settings）へ移動します。
  4. CAD 設定（CAD Settings）で、*.sldsettings ファイルを参照、アップロード、およびダウンロードします。

目次

  • 設定アドミニストレータ ツールにアクセスする

    設定アドミニストレータ ツール（Settings Administrator Tool）にアクセスするには、まずアドミニストレーティブ イメージを作成する必要があります。

  • 設定アドミニストレータ ツールの使用

  • オプションの適用およびロック

  • オプション設定を終了

  • SOLIDWORKS インストレーションに sldsettings ファイルを含める

親トピック アドミニストレーティブ イメージの使用（Using Administrative Images）


設定アドミニストレータ ツールにアクセスする

設定アドミニストレータ ツール（Settings Administrator Tool）にアクセスするには、まずアドミニストレーティブ イメージを作成する必要があります。

設定アドミニストレータ ツール（Settings Administrator Tool）は、アドミニストレーティブ イメージから起動できます。

設定アドミニストレータ ツールにアクセスするには:

  1. アドミニストレーティブ イメージ フォルダの sldAdminOptionEditor.exe を実行します。
  2. アドミニストレーティブ イメージ オプション エディタで、変更（Change） [image] をクリックします。
  3. クライアント インストール オプション（Client Installation Options）セクションで、以下を実行します。
    1. SOLIDWORKS 設定アドミニストレータで出力した設定ファイルを使用します（Use a settings file exported from the SOLIDWORKS Settings Administrator）をクリックします。
    2. 設定アドミニストレータ起動（Launch Settings Administrator）をクリックします。
      設定アドミニストレータ実行（Launch Settings Administrator）にアクセスするには、sldAdminOptionEditor.exe を実行しているコンピュータに SOLIDWORKS <バージョン> がインストールされている必要があります。
親トピック 設定アドミニストレータ ツール


設定アドミニストレータ ツールの使用

設定アドミニストレータ ツール（Settings Administrator Tool）を使用するには:

  1. ようこそ（Welcome）タブで、次のオプションを選択します。
    • デフォルトのオプション設定（Default set of options）。このリリースの SOLIDWORKS で開始します。
    • SOLIDWORKS 2025 オプション設定をコンピュータからインポート（Import SOLIDWORKS 2025 options from this computer）。
    • 既存の sldreg ファイルを参照。
    • 既存の .sldsettings ファイルを参照（Browse to an existing .sldsettings file）。
    *.sldreg ファイルは SOLIDWORKS 設定ウィザードによって生成され、*.sldsettings ファイルは設定管理者ツールによって生成されます。
  2. 次へ（Next）をクリックします。
親トピック 設定アドミニストレータ ツール


オプションの適用およびロック

システム オプション（System Options）タブで、チェック ボックスの 2 つの列を使って、これらのオプションのどちらを適用するか、また適用したオプションのどちらをロックしてユーザーが変更できないようにするかを選択できます。

ユーザーが SOLIDWORKS ソフトウェアの システム オプション（System Options）ダイアログ ボックスにアクセスすると、ロックされたオプションはロックアイコン [image] 付きで使用不可と表示されます。 ただし、オプションをユーザーがロック解除できるようにするパスワードを作成できます。 ユーザーがロックされたオプションの上にポインタを移動すると、ツールチップに管理者の名前とメールアドレスが表示されるため、ユーザーは管理者に連絡し、パスワードをリクエストできます。

オプションを適用およびロックするには:

  1. システム オプション（System Options）タブで、次を行います。
    1. システム オプションを適用するには、オプションを選択し、適用（Apply）列の対応するボックスをチェックします。
    2. システム オプションをロックするには、オプションを選択し、適用（Apply）列とロック（Lock）列の両方の対応するボックスをチェックします。
      システム オプション（System Options）タブにアクセスすると、これらのオプションはロック付き [image] で表示されます。
  2. オプションによっては、追加のパラメータをオプションに指定する必要があります。
  3. メッセージ/エラー/警告のコントロールを適用することにより、メッセージをユーザーが閉じられないようにすることもできます。
    1. メッセージ/エラー/警告（Messages/Errors/Warnings）をクリックします。
    2. 適用（Apply）を選択して、管理するメッセージのロック（Lock）を任意で選択します。
    3. メッセージを表示（Show）または表示しない（Don't Show）に設定します。

      表示（Show）を選択した場合、メッセージはユーザーの閉じられたメッセージ リストから削除され、ユーザーに適時表示されます。 表示しない（Don't Show）を選択した場合、メッセージは自動的にユーザーの閉じられたメッセージ リストに追加されて、ユーザーがモデルで作業を行っているときに表示されません。

      次の表に、ソフトウェアでの動作を示します:
      適用 | ロック | 表示 | 表示しない | 動作状態
      X | X | メッセージを強制的に表示します。
      X | X | メッセージを閉じて、メッセージを閉じられたメッセージ リストに追加します。
      X | X | X | メッセージを強制的に表示して、メッセージ ボックスの以後、このメッセージを表示しない（Don't show again）オプションを無効にします。
      X | X | X | メッセージを閉じて、ユーザーがツール（Tools） > オプション（Options） > メッセージ/エラー/警告（Messages/Errors/Warnings）でそれを有効にできないようにします。
  4. システム オプション（System Options）タブの次へ（Next）をクリックします。
親トピック 設定アドミニストレータ ツール


オプション設定を終了

オプション設定を終了するには:

  1. 完了（Finish）タブで、システム オプションがいつ適用されるかを選択します:
    • ユーザーが最初にソフトウェアを開始したとき（the first time a user starts the software）。
    • ソフトウェアが開始されるたび毎回（every time the software starts）。
    • ユーザー定義（customizations）が同時に適用されるかどうかも選択します。
  2. ユーザーがネットワークからはずれたとき、ロックされたオプションを適用（apply locked options when users are off the network）、およびAPI によるロックされたオプションの上書きを許可（allow the API to override locked options）を選択できます。
  3. ロックされたシステム オプションには、ユーザーの名前（Name）およびメール（Email）アドレスを指定する必要があります。 SOLIDWORKS ソフトウェアは、ユーザーがロックされたオプションの上にポインタを移動したとき、ヒントにこの情報を表示します。
  4. ユーザーがロックされたオプションを上書きすることを許可（allow users to override locked options）することもできます。 その後、ユーザーに提供できるパスワード（Password）を指定する必要があります。
  5. 保存（Save）をクリックして、配布用の *.sldsettings ファイルを生成します。
親トピック 設定アドミニストレータ ツール


SOLIDWORKS インストレーションに sldsettings ファイルを含める

*.sldsettings ファイルをインストレーションに含めるには:

  1. アドミニストレーティブ イメージ フォルダの sldAdminOptionEditor.exe をダブル クリックします。
  2. アドミニストレーティブ イメージ オプション エディタで、変更（Change）をクリックします。
  3. クライアント インストール オプション（Client Installation Options）セクションで、以下を実行します。
    1. SOLIDWORKS 設定アドミニストレータで出力した設定ファイルを使用します（Use a settings file exported from the SOLIDWORKS Settings Administrator）をクリックします。
    2. パスの編集（Edit Path）をクリックし、*.sldsettings ファイルを参照します。
    さまざまなグループやマシンに、さまざまな *.sldsettings ファイルを作成し適用できます。
  4. SOLIDWORKS ソフトウェアを配布してインストールします。

展開後、ステップ 2 を繰り返せば、既存の *.sldsettings を何度でも変更できます。 SOLIDWORKS ソフトウェアは、次回開始されたときに、変更された *.sldsettings を読み込みます。

親トピック 設定アドミニストレータ ツール


コマンドラインによる展開（Command-Line Deployment）

コマンド プロンプト/バッチ ファイルによってアドミニストレーティブ イメージを自動的に展開（サイレント インストレーション）できます。

コマンドラインを使用して SOLIDWORKS PDM クライアントにアドミニストレーティブ イメージを配布するには、SOLIDWORKS PDM インストール ガイドを参照してください。

目次

  • アドミニストレーティブ イメージからのコマンドライン インストレーションに向けたクライアントの準備（Preparing Clients for Command-Line Installation from an Administrative Image）

    アドミニストレーティブ イメージを作成した後でクライアントに通知する前に、コマンドラインまたはMicrosoft Active Directoryを使用して作成したアドミニストレーティブ イメージではインストールできないMicrosoft Windowsコンポーネントをインストールする必要があります。

  • コマンドラインを使用したアドミニストレーティブ イメージからのインストール（Installing from the Administrative Image Using the Command Line）

    コマンドラインを使用したアドミニストレーティブ イメージからインストレーションを展開できます。

  • コマンドライン プロパティ（Command-Line Properties）

    ここで説明するコマンドライン プロパティには、機能プロパティ、グローバル プロパティ、製品特有のプロパティ、およびWindowsの位置表記が含まれます。

  • Microsoft Active Directoryを使用したアドミニストレーティブ イメージの展開（Deploying an Administrative Image Using Microsoft Active Directory）

    Microsoft Active Directory による展開では、SOLIDWORKS コア製品のクライアントへの展開もサポートされます。

親トピック 複数インストレーション（Multiple Installations）
複数クライアントへの展開（Deploying to Multiple Clients）
アドミニストレーティブ イメージの使用（Using Administrative Images）
複数インストレーションの管理（Administration of Multiple Installations）


アドミニストレーティブ イメージからのコマンドライン インストレーションに向けたクライアントの準備（Preparing Clients for Command-Line Installation from an Administrative Image）

アドミニストレーティブ イメージを作成した後でクライアントに通知する前に、コマンドラインまたはMicrosoft Active Directoryを使用して作成したアドミニストレーティブ イメージではインストールできないMicrosoft Windowsコンポーネントをインストールする必要があります。

これらの Windows コンポーネントのマニュアル インストールは、コマンドラインの使用または Microsoft Active Directory によってアドミニストレーティブ イメージからインストールする場合のみに必要となります。 SOLIDWORKS Installation Manager でアドミニストレーティブ イメージを作成してインストールする場合、これらの Windows コンポーネントは自動的にインストールされます。
以下に、SOLIDWORKS で必要になる Windows コンポーネントのファイルをまとめます。
Windows Performance Toolkit | SOLIDWORKS Rx で拡張ログを有効にします。
Visual C++ 2022 再頒布可能パッケージ | Microsoft Visual C++の実行に必要なランタイム コンポーネントを含みます。 2022 バージョンがインストールされている必要があります。
Visual Basic for Applications 7.1 | Visual Basic のマクロをサポートします。
Visual Studio Tools for Application 2022 | この操作はオプションです。Visual Studio 2022 アプリケーションをサポートするツールセットを含みます（VSTA17）。
.NET Framework 4.8 | .NET Framework 4.8 アプリケーションの実行に必要な共通語のランタイムと .NET Framework 構成部品が含まれています。
SWCEF | Chromium Embedded Framework（CEF）は、3DEXPERIENCE platform のコンテンツを表示するために使用されます。
Microsoft Edge Web View2 | Web コンテンツを表示するために必要です。
SOLIDWORKS Login Manager | 3DEXPERIENCE Marketplace およびその他の 3DEXPERIENCE アプリケーションにログインできます。
Visual C++ 再頒布可能パッケージと .NET Framework .4.8 は、コア SOLIDWORKS 製品だけでなく、すべての SOLIDWORKS 製品に必要です。

これらのコンポーネントはアドミニストレーティブ イメージのサブディレクトリに含める必要があります。

サポートされるオペレーティング システムで必要なファイルは次の通りです:
オペレーティング システム: Windows Server 2019 64-bit および Windows Server 2022 64-bit
Windows Server 2019 および 2022 でのインストールは、SOLIDWORKS PDM Server および SOLIDWORKS SolidNetWork License Manager でサポートされています。
Windows Performance Toolkit: | WPTx64-x86_en-us.msi
Visual C++ 2022 再頒布可能パッケージ: | vc_redist.x86.exe vc_redist.x64.exe 両方がインストールされている必要があります。
Visual Basic 7.1: | vba71_1033.msi オプションの言語パックを含む。
.NET Framework 4.8: | ndp48-x86-x64-allos-enu.exe
SWCEF | CEF for SOLIDWORKS Applications.msi
Microsoft Edge Web View2 | MicrosoftEdgeWebView2RuntimeInstallerX64.exe
オペレーティング システム: Windows 10 および Windows 11 64 ビット
Windows Performance Toolkit: | WPTx64-x86_en-us.msi
Visual C++ 2022 再頒布可能パッケージ: | vc_redist.x86.exe vc_redist.x64.exe 両方がインストールされている必要があります。
Visual Basic 7.1: | vba71_1033.msi オプションの言語パックを含む。
.NET Framework 4.8: | .NET 4.8 は、この要件を満たすオペレーティング システムの一部です。
SWCEF | CEF for SOLIDWORKS Applications.msi
Microsoft Edge Web View2 | MicrosoftEdgeWebView2RuntimeInstallerX64.exe

目次

  • 64-bitオペレーティング システム上のコマンドラインからのWindows前提条件のインストール（Installing Windows Prerequisites from the Command Line on 64-bit Operating Systems）

    次の手順に従い、64-bit バージョンの Windows でコマンドラインを使用したアドミニストレーティブ イメージ インストレーションのために Windows 前提条件をインストールできます。

親トピック コマンドラインによる展開（Command-Line Deployment）
コマンドラインを使用したアドミニストレーティブ イメージからのインストール（Installing from the Administrative Image Using the Command Line）
コマンドライン プロパティ（Command-Line Properties）
Microsoft Active Directoryを使用したアドミニストレーティブ イメージの展開（Deploying an Administrative Image Using Microsoft Active Directory）


64-bitオペレーティング システム上のコマンドラインからのWindows前提条件のインストール（Installing Windows Prerequisites from the Command Line on 64-bit Operating Systems）

次の手順に従い、64-bit バージョンの Windows でコマンドラインを使用したアドミニストレーティブ イメージ インストレーションのために Windows 前提条件をインストールできます。

1回のインストール作業で複数のコンポーネントをインストールするには、次の手順にあるコマンドでバッチ ファイルを作成し、コンポーネントをクライアント コンピュータにインストールします。

  1. ターゲットのコンピュータに最低620 MBの空き容量と、有効なTEMPディレクトリがあることを確認します。
  2. Visual C++ RELEASE 再頒布可能パッケージをインストールします。各パッケージの 32-bit バージョンと 64-bit バージョンをインストールする必要があります。
    RELEASE = 2022 用のパッケージをインストールします。

    administrative_image_directory\Microsoft_C++_RELEASE_Redistributable_(x64)\vc_redist.x64.exe /Q

    administrative_image_directory\Microsoft_C++_RELEASE_Redistributable\vc_redist.x86.exe /Q

  3. Microsoft .NET Framework 4.8 をインストールします。
    administrative_image_directory\.Net_Framework_4.8\ndp48-x86-x64-allos-enu.exe
  4. Visual Studio Tools for Applications 2022:
    administrative_image_directory\Microsoft_VSTA17\vsta_setup.exe
  5. Visual Basic 7.1 をインストールします。
    administrative_image_directory\Microsoft_VBA\vba71.msi および administrative_image_directory\Microsoft_VBA\vba71_1033.msi は、すべての言語で必須です。
    このパッケージでは 64-bit バージョンのみ、インストールが必須です。

    さらに、目的の言語用に次のパッケージをインストールします。

    vba71_1028.msi | 中国語(Chinese)
    vba71_1031.msi | ドイツ語
    vba71_1036.msi | フランス語
    vba71_1040.msi | イタリア語
    vba71_1041.msi | 日本語
    vba71_1042.msi | 韓国語
    vba71_1046.msi | ポルトガル語（ブラジル）
    vba71_2052.msi | 簡体字中国語
    vba71_3082.msi | スペイン語
    英語、チェコ語、ポーランド語、ロシア語、およびトルコ語では、言語パッケージを追加する必要がありません。
    次の追加の前提条件をインストールします: Msiexec.exe /p vba71-kb27832-x64.msp
  6. SOLIDWORKS Chromium Embedded Framework（SWCEF）のインストール:
    administrative_image_directory\swcef\CEF for SOLIDWORKS Applications.msi.
  7. SOLIDWORKS Login Manager のインストール:
    administrative_image_directory\swloginmgr\SOLIDWORKS Login Manager.msi.
親トピック アドミニストレーティブ イメージからのコマンドライン インストレーションに向けたクライアントの準備（Preparing Clients for Command-Line Installation from an Administrative Image）


コマンドラインを使用したアドミニストレーティブ イメージからのインストール（Installing from the Administrative Image Using the Command Line）

コマンドラインを使用したアドミニストレーティブ イメージからインストレーションを展開できます。

サイレント インストールを行うには:

  1. コマンド プロンプト ウィンドウを開きます（Windows でスタート（Start） > ファイル名を指定して実行（Run）をクリックします）。
  2. msiexec.exe コマンドを /i と /qb というスイッチ付きで入力し、下記のようにデフォルト値とは異なる値を指定する任意のオプションのプロパティを指定します。

    msiexec /i "administrative_image_directory\64bit\SWFileUtilities\SOLIDWORKS File Utilities.msi" INSTALLDIR="C:\Program Files\your_folder /qb

個々のインストール コンポーネントのコマンドライン プロパティには次が含まれます:
  • コマンドラインの機能プロパティ（Command-Line Feature Properties）
  • コマンドラインのグローバル プロパティ（Command-Line Global Properties）
  • eDrawings コマンドライン プロパティ
  • SOLIDWORKS Flow Simulation コマンド ライン プロパティ（SOLIDWORKS Flow Simulation Command Line Properties）

次の例をサイレント インストレーションのテンプレートとして使用してください。

SOLIDWORKS Client

  • SOLIDWORKS コア (英語)
  • Toolboxアドイン
  • フィードバック プログラムに参加
  • フランス語

SOLIDWORKS:

msiexec /i "administrative_image_directory\64bit\SOLIDWORKS\SOLIDWORKS.Msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=4 ADDLOCAL=SolidWorks, SolidWorksToolbox TOOLBOXFOLDER="toolbox path for example C:\SolidWorks Data\" /qb

SOLIDWORKS フランス語インストール コンポーネントは個別にインストールする必要があります:

msiexec /i "administrative_image_directory\64bit\SOLIDWORKS French\french.msi" /qb

SOLIDWORKS 言語コンポーネントのインストール コマンドを指定する際には、コマンド ライン引数を指定しないでください。

eDrawings クライアント

  • すべての機能

msiexec /i
            "administrative_image_directory\64bit\eDrawings\eDrawings.msi"
          INSTALLDIR="C:\Program Files\your_folder"
            SNLSERVER=eDrawings_SNL_server TRANSFORMS=1040.mst
          ADDLOCAL=All /qb

SOLIDWORKS Electrical

Microsoft SQL Server とともに SOLIDWORKS Electrical をインストールする場合の技術的な複雑さが原因で、SOLIDWORKS Electrical のコマンド ラインの例はドキュメントから除外されています。

SOLIDWORKS Visualize および Visualize Boost

SOLIDWORKS Visualize の場合:

msiexec. /i “administrative_image_directory\64bit\SOLIDWORKS Visualize.msi” ACTIVSERIALNUMBER=”1234123412341234ABCDEFGH” INSTALLDIR=”C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS Visualize” /qb

SOLIDWORKS Visualize Boost の場合:

msiexec /i “administrative_image_directory\64bit\SOLIDWORKS Visualize Boost.msi” ACTVISERIALNUMBER=”1234123412341234ABCDEFGH” INSTALLDIR=”C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS Visualize Boost” /qb

親トピック コマンドラインによる展開（Command-Line Deployment）
アドミニストレーティブ イメージからのコマンドライン インストレーションに向けたクライアントの準備（Preparing Clients for Command-Line Installation from an Administrative Image）
コマンドライン プロパティ（Command-Line Properties）
Microsoft Active Directoryを使用したアドミニストレーティブ イメージの展開（Deploying an Administrative Image Using Microsoft Active Directory）


コマンドライン プロパティ（Command-Line Properties）

ここで説明するコマンドライン プロパティには、機能プロパティ、グローバル プロパティ、製品特有のプロパティ、およびWindowsの位置表記が含まれます。

目次

  • コマンドラインの機能プロパティ（Command-Line Feature Properties）

    SOLIDWORKS のインストレーションでは、コマンドラインによる展開の ADDLOCAL プロパティをサポートしています。

  • コマンドラインのグローバル プロパティ（Command-Line Global Properties）

    各プロパティは、注記がある場合を除き、アドミニストレーティブ（管理者用）、または個人インストレーション用に定義されています。グローバル プロパティを使用してアドミニストレーティブ（管理者用）インストレーションと個人インストレーションの両方にシリアル番号を指定できます。

  • eDrawings コマンドライン プロパティ

    これらのコマンドライン プロパティは eDrawings ® 特有のものです。

  • SOLIDWORKS Composer/Composer Player コマンドライン プロパティ

    これらのコマンドライン プロパティは、SOLIDWORKS Composer と SOLIDWORKS Composer Player に特有のものです。

  • SOLIDWORKS Flow Simulation コマンド ライン プロパティ（SOLIDWORKS Flow Simulation Command Line Properties）

    これらのコマンド ライン プロパティは SOLIDWORKS Flow Simulation 特有のものです。

  • SOLIDWORKS Inspection コマンド ライン プロパティ（SOLIDWORKS Inspection Command Line Properties）

    これらのコマンドライン プロパティは SOLIDWORKS 特有のものです。

  • SOLIDWORKS Visualize コマンド ライン プロパティ

    これらのコマンド ライン プロパティは、SOLIDWORKS Visualize 特有のものです。

  • アドミニストレーティブ イメージのためのMSIファイルの場所（MSI File Locations for Administrative Images）

    コマンド ラインからアドミニストレーティブ イメージを作成する際、製品コンポーネントの .msi ファイルは SOLIDWORKS メディアの次の場所に保存されています。

親トピック コマンドラインによる展開（Command-Line Deployment）
アドミニストレーティブ イメージからのコマンドライン インストレーションに向けたクライアントの準備（Preparing Clients for Command-Line Installation from an Administrative Image）
コマンドラインを使用したアドミニストレーティブ イメージからのインストール（Installing from the Administrative Image Using the Command Line）
Microsoft Active Directoryを使用したアドミニストレーティブ イメージの展開（Deploying an Administrative Image Using Microsoft Active Directory）


コマンドラインの機能プロパティ（Command-Line Feature Properties）

SOLIDWORKS のインストレーションでは、コマンドラインによる展開の ADDLOCAL プロパティをサポートしています。

  • CircuitWorks
  • CoreSolidWorksTaskScheduler
  • ExampleFiles
  • FeatureWorks
  • HelpFiles
  • Manuals
  • Motion
  • ScanTo3D
  • Simulation
  • SolidWorksCosting
  • SolidWorksDesignChecker
  • SolidWorksRoutedsystems
  • SolidWorksToolbox
  • SolidWorksUtilities
  • TolAnalyst
コマンドライン インストールのプロパティを指定する際の注意:
  • SOLIDWORKS では、ADDSOURCE オプションを使用した製品インストレーションはサポートされていません。
  • プロパティでは、大文字と小文字が識別されます。 またコマンドラインには、スペースやダッシュを含むことはできず、コンマで区切る必要があります。
親トピック コマンドライン プロパティ（Command-Line Properties）
コマンドラインのグローバル プロパティ（Command-Line Global Properties）
eDrawings コマンドライン プロパティ
SOLIDWORKS Composer/Composer Player コマンドライン プロパティ
SOLIDWORKS Flow Simulation コマンド ライン プロパティ（SOLIDWORKS Flow Simulation Command Line Properties）
SOLIDWORKS Inspection コマンド ライン プロパティ（SOLIDWORKS Inspection Command Line Properties）
SOLIDWORKS Visualize コマンド ライン プロパティ
アドミニストレーティブ イメージのためのMSIファイルの場所（MSI File Locations for Administrative Images）


コマンドラインのグローバル プロパティ（Command-Line Global Properties）

各プロパティは、注記がある場合を除き、アドミニストレーティブ（管理者用）、または個人インストレーション用に定義されています。グローバル プロパティを使用してアドミニストレーティブ（管理者用）インストレーションと個人インストレーションの両方にシリアル番号を指定できます。

プロパティ | 説明
ENABLEPERFORMANCE SOLIDWORKS 社に自動的にパフォーマンス データを送信するかどうかを指定します。

1

パフォーマンス データを送信します。

0

パフォーマンス データを送信しません。
INSTALLDIR | SOLIDWORKS インストレーション フォルダです。
MBDSERIALNUMBER | SOLIDWORKS モデル ベース定義のプロダクトのシリアル番号です。
MOTIONSERIALNUMBER | SOLIDWORKS Motion プロダクトのシリアル番号です。
OFFICEOPTION インストールする製品パッケージを指定します。
0 | SOLIDWORKS Standard
1 | SOLIDWORKS Office
2 | SOLIDWORKS Professional
3 | SOLIDWORKS Premium
4 | SOLIDWORKS Ultimate
REINSTALL 現在インストールされている機能すべてを更新するには、ALL を指定します。
このプロパティは、既存のメジャー リリース内の Service Pack リリースへの更新（たとえば、既存の SOLIDWORKS 2025 SP01 インストールから SOLIDWORKS 2025 SP02 への更新）にのみ指定してください。
REINSTALLMODE Microsoft Installer の再インストール オプションです。

たとえば、ある Service Pack リリースから別の Service Pack へ、同じメジャー リリース内でアップグレードする場合は、REINSTALLMODE=vomus を指定してください。

REINSTALLMODE の設定の詳細については、www.microsoft.com にある Windows Installer の関連ドキュメントを参照してください。

このプロパティは、既存のメジャー リリース内の Service Pack リリースへの更新（たとえば、既存の SOLIDWORKS 2025 SP01 インストールから SOLIDWORKS 2025 SP02 への更新）にのみ指定してください。このプロパティは、SOLIDWORKS の新しいメジャー リリースを最初にインストールする際には指定しないでください。
SERVERLIST SolidNetWork サーバー リストです。
SolidNetWork サーバー リストは、文字列の区切りリストで、それぞれの文字列は次のフォーマットでサーバー上のポート番号を表します:
  • トライアド（カンマ区切り）=xxxxx@サーバー名1,yyyyy@サーバー名2,zzzzz@サーバー名3
  • 非トライアド（セミコロン区切り）=xxxxx@サーバー名1;yyyyy@サーバー名2;zzzzz@サーバー名3
x および y は 1 桁の数字です。 リスト内の最後のサーバーの後には区切り文字を追加しないでください。
SIMULATIONSERIALNUMBER | SOLIDWORKS Simulation プロダクトのシリアル番号です。
SOLIDWORKSSERIALNUMBER | SOLIDWORKS プロダクトのシリアル番号です（すべてのアドインが含まれます）。
SWMIGRATE アップグレードする SOLIDWORKS のバージョンを指定します。このリストは SOLIDWORKS インストレーションの選択（SOLIDWORKS Install Choice）ダイアログ ボックスに表示されます。例を示します。

SWMIGRATE="SOLIDWORKS 2025 x64 Edition SP01"

このプロパティは、前にインストールしたメジャー リリースが存在するときに、新しいメジャー リリースをインストールする場合にのみ指定してください。このプロパティは、同じメジャー リリース内で 1 つの Service Pack から別の Service Pack にアップグレードする場合には指定しないでください。
TOOLBOXFOLDER SOLIDWORKS Toolbox ファイルのインストレーション フォルダです。

例を示します。 TOOLBOXFOLDER = "C:\SOLIDWORKS Data"

ご使用の環境に PDM または共有の Toolbox/穴ウィザードの場所がある場合は、その場所で Toolbox データのインストールまたはアップグレードを実行しないように、NOTTOOLBOXSETUP プロパティを使用して、クライアントのインストールを指定できます。次を指定します:

0 | Toolbox ファイルをインストールします。
1 | Toolbox ファイルはインストールしません。
TRANSFORMS 次の形式で言語固有のアイテムを含めます。
TRANSFORMS number.mst
  • 中国語（台湾）（1028）
  • 中国語（中国）（2052）
  • チェコ語（1029）
  • 英語（1033）
  • フランス語（1036）
  • ドイツ語（1031）
  • イタリア語（1040）
  • 日本語（1041）
  • 韓国語（1042）
  • ポーランド語（1045）
  • ポルトガル語（ブラジル）（1046）
  • ロシア語（1049）
  • スペイン語（1034）
  • トルコ語（1055）
UPGRADESWINSTALL
既存の SOLIDWORKS のバージョンを現在のバージョンにアップグレードするかどうかを指定します。
0 | 新規インストレーション、アップデートなし。
1 | アップデート
このプロパティは、前にインストールしたメジャー リリースが存在する場合に新しいメジャー リリースをインストールする場合にのみ指定してください。 このプロパティは、同じメジャー リリース内で 1 つのサービス パックから別のサービス パックにアップグレードする場合には指定しないでください。
親トピック コマンドライン プロパティ（Command-Line Properties）
コマンドラインの機能プロパティ（Command-Line Feature Properties）
eDrawings コマンドライン プロパティ
SOLIDWORKS Composer/Composer Player コマンドライン プロパティ
SOLIDWORKS Flow Simulation コマンド ライン プロパティ（SOLIDWORKS Flow Simulation Command Line Properties）
SOLIDWORKS Inspection コマンド ライン プロパティ（SOLIDWORKS Inspection Command Line Properties）
SOLIDWORKS Visualize コマンド ライン プロパティ
アドミニストレーティブ イメージのためのMSIファイルの場所（MSI File Locations for Administrative Images）


eDrawings コマンドライン プロパティ

これらのコマンドライン プロパティは eDrawings ® 特有のものです。

プロパティ（Properties） | 説明
ADDLOCAL インストールする eDrawings アプリケーション機能を指定します。
All が推奨オプションです。
コマンドライン構文 | フィーチャー
All | 全機能をインストールします。eDrawings はインストール済みの SOLIDWORKS と AutoCAD の Publisher を検索し、インストールを有効にします。
CALS | eDrawings Viewer で CAL ファイルを表示
Inventor | Autodesk Inventor アプリケーションから eDrawings ファイルを作成します。
eDrawingsViewer | eDrawings やその他のファイルを表示します。
ProE | eDrawings Viewer を使用して ProE ファイルを表示
DXFDWGTranslator | eDrawings Viewer で DXF/DWG ファイルを表示します。
Shortcuts | デスクトップ ショートカットをインストールします。
XML3D | eDrawings Viewer で 3DXML ファイルを表示します。
INSTALLDIR | のためのインストール フォルダを指定します。 eDrawings
SNLSERVER SolidNetWork License Server の ポート@サーバー名 を入力します。複数の ポート@サーバー名 の組み合わせはセミコロンで区切ります。

SERVERLIST および SNLSERVER のポート サーバー名は、SOLIDWORKS SNL サーバーを設定する場合にのみ必要です。

SolidNetWork サーバー リストは、文字列の区切りリストで、それぞれの文字列は次のフォーマットでサーバー上のポート番号を表します:
  • トライアド（コンマ区切り）

    = xxxx@server_name1,yyyy@server_name2,zzzz@server_name3

  • 非トライアド（セミコロン区切り）

    = xxxx@server_name1,yyyy@server_name2,zzzz@server_name3

x および y は 1 桁の数字です。リスト内の最後のサーバーの後にはセミコロンを追加しないでください。
親トピック コマンドライン プロパティ（Command-Line Properties）
コマンドラインの機能プロパティ（Command-Line Feature Properties）
コマンドラインのグローバル プロパティ（Command-Line Global Properties）
SOLIDWORKS Composer/Composer Player コマンドライン プロパティ
SOLIDWORKS Flow Simulation コマンド ライン プロパティ（SOLIDWORKS Flow Simulation Command Line Properties）
SOLIDWORKS Inspection コマンド ライン プロパティ（SOLIDWORKS Inspection Command Line Properties）
SOLIDWORKS Visualize コマンド ライン プロパティ
アドミニストレーティブ イメージのためのMSIファイルの場所（MSI File Locations for Administrative Images）


SOLIDWORKS Composer/Composer Player コマンドライン プロパティ

これらのコマンドライン プロパティは、SOLIDWORKS Composer と SOLIDWORKS Composer Player に特有のものです。

SOLIDWORKS Composer の場合:

プロパティ(Properties) | 説明
ACTIVSERIALNUMBER ‏‎（日本語版未対応） | SOLIDWORKS Composer のシリアル番号。
ACTIVSERIALNUMBERPLAYERPRO | この操作はオプションです。 SOLIDWORKS Composer Player Pro のシリアル番号。
ADDLOCAL この操作はオプションです。完全なアプリケーションをインストールする場合は、ADDLOCAL プロパティを指定する必要はありません。
ユーザー定義インストールの場合は、ADDLOCAL を以下の必須項目と使用してください。
  • ライセンス
  • CLOSA
  • InterOps
  • LicenseSupportFiles
  • PlugIns
  • SWComposerCommon
  • SWPlayer
Sync3Dvia で ADDLOCAL を使用することもできますが、必須ではありません。
INSTALLDIR | SOLIDWORKS Composer ソフトウェアをインストールするフォルダを指定します。

SOLIDWORKS Composer Player の場合:

プロパティ(Properties) | 説明
ACTIVSERIALNUMBERPLAYERPRO | この操作はオプションです。 SOLIDWORKS Composer Player Pro のシリアル番号。
INSTALLDIR | SOLIDWORKS Composer Player ソフトウェアをインストールするフォルダを指定します。
SOLIDWORKS がインストールされていないマシンでは、SOLIDWORKS Translator を使用して SOLIDWORKS ファイルを SOLIDWORKS Composer にインポートする必要があります。 SOLIDWORKS Translator を展開するには、SOLIDWORKS Installation Manager を使用する必要があります。コマンド ラインは使用できません。
親トピック コマンドライン プロパティ（Command-Line Properties）
コマンドラインの機能プロパティ（Command-Line Feature Properties）
コマンドラインのグローバル プロパティ（Command-Line Global Properties）
eDrawings コマンドライン プロパティ
SOLIDWORKS Flow Simulation コマンド ライン プロパティ（SOLIDWORKS Flow Simulation Command Line Properties）
SOLIDWORKS Inspection コマンド ライン プロパティ（SOLIDWORKS Inspection Command Line Properties）
SOLIDWORKS Visualize コマンド ライン プロパティ
アドミニストレーティブ イメージのためのMSIファイルの場所（MSI File Locations for Administrative Images）


SOLIDWORKS Flow Simulation コマンド ライン プロパティ（SOLIDWORKS Flow Simulation Command Line Properties）

これらのコマンド ライン プロパティは SOLIDWORKS Flow Simulation 特有のものです。

プロパティ | 説明
ACTIVSERIALNUMBER ‏‎（日本語版未対応） SOLIDWORKS Flow Simulation スタンドアロン シリアル番号です。

（アドミニストレーティブ イメージからの個人インストレーションとクライアント インストレーション）。

CWUPGRADEINSTALL 特定の SOLIDWORKS Flow Simulation アプリケーション ソフトウェアの既存バージョンをアップグレードします。
1 | アップデート
2 | 新規インストレーション、新規ディレクトリにインストール

（アドミニストレーティブ イメージからの個人インストレーションとクライアント インストレーション）。

INSTALLDIR 特定の SOLIDWORKS Flow Simulation アプリケーション ソフトウェアのインストレーションを指定します。

（個人インストレーションのみ）。
SERVERLIST | セミコロンで区切られているストリングのリストであり、それぞれのストリングは次のフォーマットをもつサーバー上のポート番号を表します。 xxxxx@サーバー_名1; yyyyy@サーバー_名2;& ここで x と y は 1 桁の数字です。 リスト内の最後のサーバーの後にはセミコロンを追加しないでください。
SOLIDWORKSPATH SOLIDWORKS ソフトウェアのインストール フォルダを指定します。

（アドミニストレーティブ イメージからの個人インストレーションとクライアント インストレーション）。

親トピック コマンドライン プロパティ（Command-Line Properties）
コマンドラインの機能プロパティ（Command-Line Feature Properties）
コマンドラインのグローバル プロパティ（Command-Line Global Properties）
eDrawings コマンドライン プロパティ
SOLIDWORKS Composer/Composer Player コマンドライン プロパティ
SOLIDWORKS Inspection コマンド ライン プロパティ（SOLIDWORKS Inspection Command Line Properties）
SOLIDWORKS Visualize コマンド ライン プロパティ
アドミニストレーティブ イメージのためのMSIファイルの場所（MSI File Locations for Administrative Images）


SOLIDWORKS Inspection コマンド ライン プロパティ（SOLIDWORKS Inspection Command Line Properties）

これらのコマンドライン プロパティは SOLIDWORKS 特有のものです。

プロパティ | 説明
ACTIVSERIALNUMBER ‏‎（日本語版未対応） | SOLIDWORKS Inspection のシリアル番号。 （アドミニストレーティブ イメージからの個人インストレーションとクライアント インストレーション）。
INSTALLDIR | SOLIDWORKS Inspection アプリケーション ソフトウェアのインストールを指定します。 （個人インストレーションのみ）。
SERVERLIST | セミコロンで区切られているストリングのリストであり、それぞれのストリングは次のフォーマットをもつサーバー上のポート番号を表します。 xxxxx@サーバー_名1; yyyyy@サーバー_名2;& ここで x と y は 1 桁の数字です。 リスト内の最後のサーバーの後にはセミコロンを追加しないでください。
親トピック コマンドライン プロパティ（Command-Line Properties）
コマンドラインの機能プロパティ（Command-Line Feature Properties）
コマンドラインのグローバル プロパティ（Command-Line Global Properties）
eDrawings コマンドライン プロパティ
SOLIDWORKS Composer/Composer Player コマンドライン プロパティ
SOLIDWORKS Flow Simulation コマンド ライン プロパティ（SOLIDWORKS Flow Simulation Command Line Properties）
SOLIDWORKS Visualize コマンド ライン プロパティ
アドミニストレーティブ イメージのためのMSIファイルの場所（MSI File Locations for Administrative Images）


SOLIDWORKS Visualize コマンド ライン プロパティ

これらのコマンド ライン プロパティは、SOLIDWORKS Visualize 特有のものです。

プロパティ | 説明
ACTIVSERIALNUMBER ‏‎（日本語版未対応） | SOLIDWORKS Visualize のシリアル番号。 （アドミニストレーティブ イメージからの個人インストレーションとクライアント インストレーション）。
INSTALLDIR | SOLIDWORKS Visualize アプリケーション ソフトウェアのインストールを指定します。 （個人インストレーションのみ）。
SERVERLIST | セミコロンで区切られているストリングのリストであり、それぞれのストリングは次のフォーマットをもつサーバー上のポート番号を表します。 xxxxx@サーバー_名1; yyyyy@サーバー_名2;& ここで x と y は 1 桁の数字です。 リスト内の最後のサーバーの後にはセミコロンを追加しないでください。
親トピック コマンドライン プロパティ（Command-Line Properties）
コマンドラインの機能プロパティ（Command-Line Feature Properties）
コマンドラインのグローバル プロパティ（Command-Line Global Properties）
eDrawings コマンドライン プロパティ
SOLIDWORKS Composer/Composer Player コマンドライン プロパティ
SOLIDWORKS Flow Simulation コマンド ライン プロパティ（SOLIDWORKS Flow Simulation Command Line Properties）
SOLIDWORKS Inspection コマンド ライン プロパティ（SOLIDWORKS Inspection Command Line Properties）
アドミニストレーティブ イメージのためのMSIファイルの場所（MSI File Locations for Administrative Images）


アドミニストレーティブ イメージのためのMSIファイルの場所（MSI File Locations for Administrative Images）

コマンド ラインからアドミニストレーティブ イメージを作成する際、製品コンポーネントの .msi ファイルは SOLIDWORKS メディアの次の場所に保存されています。

SOLIDWORKS （コア製品、英語版）

swwi\data\SOLIDWORKS.msi

SOLIDWORKS （英語以外の言語コンポーネント）

中国語（台湾） | swwi\lang\chinese\chinese.msi
中国語（中国） | swwi\lang\chinese-simplified\chinese-simplified.msi
チェコ語 | swwi\lang\czech\czech.msi
フランス語 | swwi\lang\french\french.msi
ドイツ語 | swwi\lang\german\german.msi
イタリア語 | swwi\lang\italian\italian.msi
日本語 | swwi\lang\japanese\japanese.msi
Korean | swwi\lang\korean\korean.msi
ポーランド語 | swwi\lang\polish\polish.msi
ポルトガル語（ブラジル） | swwi\lang\portuguese-brazilian\portuguese-brazilian.msi
Russian | swwi\lang\russian\russian.msi
スペイン語 | swwi\lang\spanish\spanish.msi
Turkish | swwi\lang\turkish\turkish.msi

DocManager APIs

swdocmgr\SOLIDWORKS Document Manager API.msi

eDrawings

eDrawings\eDrawings.msi

eDrawingsAPI SDK

eDrwAPISDK\eDrawings API SDK.msi

Flow Simulation

Flow Simulation\SOLIDWORKS Flow Simulation.msi

SOLIDWORKS 用 3DEXPERIENCE Marketplace

marketplace\3dexperience marketplace.msi

SolidNetWork License Manager

swlicmgr\SOLIDWORKS SolidNetWork License Manager.msi

SOLIDWORKS API SDK

apisdk\SOLIDWORKS API SDK.msi

SOLIDWORKS CAM

cam\SOLIDWORKS CAM.msi

SOLIDWORKS Composer

swComposer\SOLIDWORKS Composer.msi

SOLIDWORKS Composer Player

swComposerPlayerSOLIDWORKS Composer Player.msi

SOLIDWORKS Electrical

swelectric\SOLIDWORKS Electrical.msi

SOLIDWORKS File Utilities

SWFileUtilities\SOLIDWORKS File Utilities.msi

SOLIDWORKS Inspection

Inspection\SOLIDWORKS Inspection.msi

SOLIDWORKS Manage Client

SWManageClient\SOLIDWORKS Manage Client.msi

SOLIDWORKS PDM

SOLIDWORKS PDM Professional には API が用意されていますが、Client でのみ使用可能で、.msi では使用できません。 詳細については、SOLIDWORKS PDM Client の install\API ディレクトリにある API ガイドを参照してください。

SOLIDWORKS Plastics

plastics\SOLIDWORKS Plastics.msi

SOLIDWORKS Visualize

visualize\SOLIDWORKS Visualize.msi

SOLIDWORKS Visualize Boost

visualizeboost\SOLIDWORKS Visualize Boost.msi
親トピック コマンドライン プロパティ（Command-Line Properties）
コマンドラインの機能プロパティ（Command-Line Feature Properties）
コマンドラインのグローバル プロパティ（Command-Line Global Properties）
eDrawings コマンドライン プロパティ
SOLIDWORKS Composer/Composer Player コマンドライン プロパティ
SOLIDWORKS Flow Simulation コマンド ライン プロパティ（SOLIDWORKS Flow Simulation Command Line Properties）
SOLIDWORKS Inspection コマンド ライン プロパティ（SOLIDWORKS Inspection Command Line Properties）
SOLIDWORKS Visualize コマンド ライン プロパティ


Microsoft Active Directoryを使用したアドミニストレーティブ イメージの展開（Deploying an Administrative Image Using Microsoft Active Directory）

Microsoft Active Directory による展開では、SOLIDWORKS コア製品のクライアントへの展開もサポートされます。

Microsoft Active Directoryはネットワーク環境にあるクライアントとサーバーを管理するためのディレクトリ サービスです。 これにより、管理、移行、展開がシンプルになります。

Microsoft Active Directory での SOLIDWORKS のインストールについては、代理店にお問い合わせください。

親トピック コマンドラインによる展開（Command-Line Deployment）
アドミニストレーティブ イメージからのコマンドライン インストレーションに向けたクライアントの準備（Preparing Clients for Command-Line Installation from an Administrative Image）
コマンドラインを使用したアドミニストレーティブ イメージからのインストール（Installing from the Administrative Image Using the Command Line）
コマンドライン プロパティ（Command-Line Properties）


複数インストレーションの管理（Administration of Multiple Installations）

複数インストレーションの場合、管理タスクには新しいリリースへのアドミニストレーティブのアップグレード、ServicePack製品アップデートの適用、インストレーションの削除が含まれます。

目次

  • 新しいリリースへのアドミニストレーティブ イメージのアップグレード（Upgrading Administrative Images to a New Release）

    アドミニストレーティブ イメージからインストールしたクライアントをアップデートするには、まずアドミニストレーティブ イメージをアップデートしてから新しいイメージのコピーを参照するようにクライアントを設定します。

  • ServicePack製品アップデートの管理（Service Pack Product Update Administration）

    ServicePack製品アップデートには、システムの信頼性、互換性、セキュリティなどのためのアップデートが含まれています。

  • インストレーションの削除（Removing an Installation）

    個人コンピュータ上、およびクライアント/サーバー環境で、インストレーションを削除することができます。

親トピック 複数インストレーション（Multiple Installations）
複数クライアントへの展開（Deploying to Multiple Clients）
アドミニストレーティブ イメージの使用（Using Administrative Images）
コマンドラインによる展開（Command-Line Deployment）


新しいリリースへのアドミニストレーティブ イメージのアップグレード（Upgrading Administrative Images to a New Release）

アドミニストレーティブ イメージからインストールしたクライアントをアップデートするには、まずアドミニストレーティブ イメージをアップデートしてから新しいイメージのコピーを参照するようにクライアントを設定します。

SOLIDWORKS Installation Manager を SOLIDWORKS ダウンロード ページから実行し、正しいファイルが参照されるようにします。

アドミニストレーティブ イメージをアップデートすると、このイメージの新しいコピーが作成され、クライアントにアドミニストレーティブ イメージの新しいコピーを参照させることによって、クライアントを更新できます。

クライアントが、共有ディレクトリを使用している旧バージョンのアドミニストレーティブ イメージを参照していた場合、更新されたアドミニストレーティブ イメージの位置を使用して、その共有ディレクトリを再定義できます。

目次

  • アドミニストレーティブ イメージのアップデートされたインストレーション ファイルのダウンロード（Downloading Updated Installation Files for Administrative Images）

    SOLIDWORKS Installation Manager はアドミニストレーティブ イメージのアップグレード時に、いつアップデートされたインストレーション ファイルが必要となるかを検知します。

  • アドミニストレーティブ イメージのアップグレード（Upgrading an Administrative Image）

    アドミニストレーティブ イメージをアップグレードするため、SOLIDWORKS Installation Manager は新しいイメージ ディレクトリを作成します。 その後、その製品バージョンにアップグレードするため新しいアドミニストレーティブ イメージ ディレクトリを使用するよう、クライアントに指示します。

  • アドミニストレーティブ イメージからのクライアント アップグレード（Upgrading Clients from Administrative Images）

    SOLIDWORKS Installation Manager はアドミニストレーティブ イメージからインストールしたクライアント コンピュータを自動的に更新できます。

親トピック 複数インストレーションの管理（Administration of Multiple Installations）
ServicePack製品アップデートの管理（Service Pack Product Update Administration）
インストレーションの削除（Removing an Installation）


アドミニストレーティブ イメージのアップデートされたインストレーション ファイルのダウンロード（Downloading Updated Installation Files for Administrative Images）

SOLIDWORKS Installation Manager はアドミニストレーティブ イメージのアップグレード時に、いつアップデートされたインストレーション ファイルが必要となるかを検知します。

  1. SOLIDWORKS Installation Manager を起動します。
  2. ようこそ（Welcome）スクリーンで、アドミニストレーティブ イメージ（Administrative image）をクリックします。
  3. シリアル番号 画面で、SOLIDWORKS のシリアル番号を入力します。
    SOLIDWORKS Installation Manager は、ライセンスのある製品と使用可能なサービス パックが SOLIDWORKS Web サイトにあるかどうかをチェックします。
  4. 利用可能なより新しいバージョン（Newer Version Available）画面が表示されたら、はい、新しいバージョンをダウンロードﾞしてインストールします（Yes, download and install a newer version）を選択します。version。
    SOLIDWORKS Installation Manager が新しいバージョンをインストールするためのセッションを新たに開始します。
  5. ダウンロード フォルダーに問題がある場合は、ダウンロード オプション（Download Options）が表示されるかもしれません。この場合は、新しいインストレーション ファイルのデフォルトのディレクトリを確定するか、または新しいディレクトリ名を入力します。
    ディレクトリが存在しない旨を伝えるメッセージが表示された場合は、はい（Yes）をクリックしてディレクトリを作成します。
  6. ダウンロード完了（Download Complete）画面で閉じる（Close）をクリックして、現在のインストーラを閉じ、新規バージョンのインストーラを開始します。
親トピック 新しいリリースへのアドミニストレーティブ イメージのアップグレード（Upgrading Administrative Images to a New Release）
アドミニストレーティブ イメージのアップグレード（Upgrading an Administrative Image）
アドミニストレーティブ イメージからのクライアント アップグレード（Upgrading Clients from Administrative Images）


アドミニストレーティブ イメージのアップグレード（Upgrading an Administrative Image）

アドミニストレーティブ イメージをアップグレードするため、SOLIDWORKS Installation Manager は新しいイメージ ディレクトリを作成します。 その後、その製品バージョンにアップグレードするため新しいアドミニストレーティブ イメージ ディレクトリを使用するよう、クライアントに指示します。

このプロセスは、アドミニストレーティブ イメージのすべてのアップデートされたインストレーション ファイルのダウンロードが行われていることを前提とします。詳細は、アドミニストレーティブ イメージのアップデートされたインストレーション ファイルのダウンロードを参照してください。

  1. SOLIDWORKS Installation Manager を起動します。
  2. ようこそ 画面で アドミニストレーティブ イメージ を選択します。
    アドミニストレーティブ イメージの作成オプションが表示されます。
    オプション | 説明
    新規イメージをデフォルト設定を使用して作成します。（Create a new image using default settings） | デフォルト設定を使用してイメージを作成します（サイトの既存のアドミニストレーティブ イメージに対して設定されている設定ではなく）。
    新規イメージを既存のイメージの設定とファイルを使用して作成します。（Create a new image using settings and files from an existing image.） | 現在のサイトの既存のアドミニストレーティブ イメージに指定されている設定を使用してイメージを作成します。 参照 をクリックして既存のアドミニストレーティブ イメージのインストール ディレクトリを指定します。
  3. シリアル番号 画面でシリアル番号を確認します。
  4. サマリー（イメージ作成の準備完了）画面で、アドミニストレーティブ イメージのオプションが正しいかどうか確認します。
    個々のアドミニストレーティブ イメージとインストレーション オプションの詳細については、変更（CHANGE）をクリックしてオプション ページに移動してから、ヘルプ（Help）をクリックします。
  5. アドミニストレーティブ イメージの新しいバージョンを作成するには、今すぐ作成（Create Now）をクリックします。

これで、この新しいバージョンのアドミニストレーティブ イメージへのクライアントのアップグレードを行えるようになります。詳細については、アドミニストレーティブ イメージからのクライアント アップグレード (Upgrading Clients from Administrative Images)を参照してください。

親トピック 新しいリリースへのアドミニストレーティブ イメージのアップグレード（Upgrading Administrative Images to a New Release）
アドミニストレーティブ イメージのアップデートされたインストレーション ファイルのダウンロード（Downloading Updated Installation Files for Administrative Images）
アドミニストレーティブ イメージからのクライアント アップグレード（Upgrading Clients from Administrative Images）


アドミニストレーティブ イメージからのクライアント アップグレード（Upgrading Clients from Administrative Images）

SOLIDWORKS Installation Manager はアドミニストレーティブ イメージからインストールしたクライアント コンピュータを自動的に更新できます。

通常、アドミニストレーティブ イメージはサーバー上のフォルダーにまとめられています。クライアントの自動アップグレードをサポートするためには、アドミニストレーティブ イメージが共有フォルダーにある必要があります。

アドミニストレーティブ イメージのアップグレードを行うと、元のインストレーションが1つのフォルダーに保存され、更新されたインストレーションが別のフォルダーに保存されます。アップグレードされたインストレーションを使用するには、元のアドミニストレーティブ イメージ フォルダーの共有オプションを解除します。続いてアップグレードされたアドミニストレーティブ イメージ フォルダーに共有オプションを追加します。

元のアドミニストレーティブ イメージからインストールした SOLIDWORKS をクライアント マシンで起動すると、新しいバージョンが識別されてクライアントがアップグレードされます。
SOLIDWORKS によって更新が引き起こされると、アドミニストレーティブ イメージからインストールした他の製品も自動的に更新されます。
親トピック 新しいリリースへのアドミニストレーティブ イメージのアップグレード（Upgrading Administrative Images to a New Release）
アドミニストレーティブ イメージのアップデートされたインストレーション ファイルのダウンロード（Downloading Updated Installation Files for Administrative Images）
アドミニストレーティブ イメージのアップグレード（Upgrading an Administrative Image）

元のアドミニストレーティブ イメージ フォルダからの共有オプションの解除（Removing the Sharing Option from the Original Administrative Image Folder）

共有フォルダからアクセスされるアドミニストレーティブ イメージをアップグレードする際は、元のフォルダから共有オプションを解除する必要があります。

  1. 元のアドミニストレーティブ イメージ ファイルがあるフォルダまで検索します。
  2. フォルダーを右クリックし、プロパティ（Properties）を選択します。
  3. 共有（Sharing）タブでこのフォルダを共有しない（Do not share this folder）を選択し、OKをクリックします。

次に、アップグレードされたアドミニストレーティブ イメージ フォルダに対する共有オプションの追加（Adding the Sharing Option to an Upgraded Administrative Image Folder）の手順に従い、アップグレードされたアドミニストレーティブ フォルダに共有オプションを追加します。

アップグレードされたアドミニストレーティブ イメージ フォルダに対する共有オプションの追加（Adding the Sharing Option to an Upgraded Administrative Image Folder）

アドミニストレーティブ イメージ フォルダーを作成してアップデートし、元のアドミニストレーティブ イメージ フォルダーの共有を無効にしたら、新しいフォルダーに共有オプションを追加してアドミニストレーティブ イメージを再び有効にする必要があります。

  1. アップグレードされたアドミニストレーティブ イメージ ファイルがあるフォルダまで検索します。
  2. フォルダーを右クリックし、プロパティ（Properties）を選択します。
  3. 共有（Sharing）タブで、適切な共有プロパティを業務グループ用に指定し、共有名を元のアドミニストレーティブ イメージ フォルダ名に変更します。
元のアドミニストレーティブ イメージの共有場所からインストールしたコンピュータは、SOLIDWORKS の起動時に新しいバージョンに自動的にアップグレードされます。


ServicePack製品アップデートの管理（Service Pack Product Update Administration）

ServicePack製品アップデートには、システムの信頼性、互換性、セキュリティなどのためのアップデートが含まれています。

次の 2 つの方法で製品アップデートを入手できます。
  • SOLIDWORKS Installation Manager を使用して、アップデートをダウンロードしインストールします。

    SOLIDWORKS Installation Manager を手動で開始するか、アップデート チェックが定期的に行われるようにスケジュールします。

  • サービス パックを SOLIDWORKS サポート Web サイトから手動でダウンロードします。

    サービス パックはソフトウェアの既存バージョンにパッチとして適用されます。たとえば、SOLIDWORKS 2025 SP1.0 は SOLIDWORKS 2025 SP0.0 のサービス パックです。これらのサービス パックは SOLIDWORKS 2025 Installation Manager を使用してインストールします。SOLIDWORKS 2024 の SOLIDWORKS Installation Manager を使用してインストールすることはできません。

    サービス パックのダウンロードとインストールに関するヘルプ情報については、アップデートする SOLIDWORKS バージョンのインストレーション ドキュメントを参照してください。

目次

  • アドミニストレーティブ イメージにおけるServicePackのロールバック（Rolling Back Service Packs in an Administrative Image）

    アドミニストレーティブ イメージを以前のアドミニストレーティブ イメージにロールバックして戻すことができます。 ディスクから SOLIDWORKS をインストールした場合、特定のサービス パックまでロールバックするには、元のディスクが必要です。 以前のアドミニストレーティブ イメージの保存コピーが必要です。

親トピック 複数インストレーションの管理（Administration of Multiple Installations）
新しいリリースへのアドミニストレーティブ イメージのアップグレード（Upgrading Administrative Images to a New Release）
インストレーションの削除（Removing an Installation）


アドミニストレーティブ イメージにおけるServicePackのロールバック（Rolling Back Service Packs in an Administrative Image）

アドミニストレーティブ イメージを以前のアドミニストレーティブ イメージにロールバックして戻すことができます。 ディスクから SOLIDWORKS をインストールした場合、特定のサービス パックまでロールバックするには、元のディスクが必要です。 以前のアドミニストレーティブ イメージの保存コピーが必要です。

一度アップグレードしたアドミニストレーティブ イメージを前回バージョンのService Packへとロールバックすることはできません。 SOLIDWORKS Installation Manager 以外の方法で作成したアドミニストレーティブ イメージを以前のバージョンにロールバックすることはできません。 これらのアドミニストレーティブ イメージからインストールしたクライアントは、アンインストールしてから前のバージョンで作成したアドミニストレーティブ イメージを使用して再インストールする必要があります。
  1. 現在のアドミニストレーティブ イメージを含むフォルダーを削除します。これを行うには、コマンド プロンプト ウィンドウを開いて次のように入力します。
    rmdir /s/q 現在の_アドミニストレーティブ_イメージ_への_パス
  2. アドミニストレーティブ イメージのバックアップ コピーを現在のアドミニストレーティブ イメージを削除した場所へ移動します。これを行うには、コマンド プロンプト ウィンドウを開いて次のように入力します。
    move バックアップした_アドミニストレーティブ_イメージ_への_パス 現在の_アドミニストレーティブ_イメージ_への_パス
    アドミニストレーティブ イメージをロールバックすると、次回 SOLIDWORKS を実行した時にクライアント コンピュータは自動的にロールバックされます。
親トピック ServicePack製品アップデートの管理（Service Pack Product Update Administration）


SOLIDWORKS PDM および SOLIDWORKS Manage

SOLIDWORKS PDM は、以前 SOLIDWORKS Enterprise PDM と呼ばれていたクライアント/サーバー アーキテクチャに基づくドキュメント管理製品です。 SOLIDWORKS PDM には次の 2 種類があります。
  • SOLIDWORKS PDM Standard
  • SOLIDWORKS PDM Professional

SOLIDWORKS PDM は Microsoft SQL Server データベースを使用してファイル ボルトを管理します。

この表には、各製品タイプで使用できるデータベース システム、サーバー コンポーネント、およびクライアント オプションがリストされています。
 | PDM Standard | PDM Professional
設計対象 | 小規模～中規模のオフィス ネットワーク（一般的に 20 以下の同時ユーザー）。 | 大規模オフィス ネットワーク（多数の同時ユーザー）
制限 | 1 ソケットまたは 4 コア（どちらか少ない方）、1 GB RAM、10 GB データベース サイズ | SQL Standard の制限: 4 ソケットまたは 16 コア（どちらか少ない方）、128 GB RAM、524 PB データベース サイズ
データベース管理システム | Microsoft SQL Server Express 2019 以降のバージョン（2022 まで）。 | Microsoft SQL Server 2019 以降のバージョン（2022 まで）。
SolidNetWork License Manager が必要ですか? | はい | はい
アーカイブ サーバーとデータベース サーバーが含まれていますか? | はい | はい
SOLIDWORKS PDM Web2 サーバーと WebAPI サーバーが含まれていますか? | いいえ | はい
クライアント タイプ | ネイティブ | ネイティブ、ブラウザ ベース
CAD Editors クライアント アドイン | SOLIDWORKS、DraftSight | SOLIDWORKS、DraftSight、Microsoft Office Integration
Contributor クライアント アドイン | DraftSight | DraftSight、Microsoft Office Integration
Viewer クライアント アドイン |  | Microsoft Office 統合

SOLIDWORKS Manage Professional では、高度なデータ管理ツールが SOLIDWORKS PDM Professional に提供されます。 高度なバージョン制御機能、およびプロジェクト、プロセス、アイテムの管理機能が提供されます。 インタラクティブなダッシュボードとレポートでは、アイテム、アクティビティ、プロジェクト完了までの進行状況を追跡できます。

SOLIDWORKS Manage Professional のアーキテクチャは、SOLIDWORKS PDM Professional に似ています。アイテムおよびプロジェクト データを管理するために Microsoft SQL Server データベースを用いる、クライアント/サーバー アーキテクチャを使用します。データベース、ファイル サーバー、Web サーバー機能の 3 つのサービスがあり、シック クライアントと Web ブラウザ クライアントの両方がサポートされます。これら 3 つのサービスは、同一のサーバー上でホストすることも、別々のサーバー上でホストすることもできます。SOLIDWORKS Manage Professional Editor のライセンスを所有するユーザーは、SOLIDWORKS Manage アドインを使用すると、SOLIDWORKS の内部から Manage のデータに直接アクセスできます。

SOLIDWORKS Installation Manager を使用すると、SOLIDWORKS Manage Professional のサーバーとクライアントをインストールすることができます。

SOLIDWORKS Manage Professional のインストール手順については、SOLIDWORKS PDM/SOLIDWORKS Manage インストレーション ガイドを参照してください。

目次

  • PDM Server コンポーネントのリスト

  • PDM クライアントの違いについて

    クライアント ソフトウェアをインストールする前に、PDM 環境によって異なるクライアントのうちどのクライアントが必要なのかを判断する必要があります。

  • PDM Server をインストールする前に

    PDM Server コンポーネントをインストールする前に、次の要件を満たしておく必要があります。

  • SOLIDWORKS Installation Manager を使用した PDM Server のインストール

    PDM Standard 用に PDM Server をインストールする場合、同じマシン上にアーカイブ サーバー、データベース サーバー、および PDM CAD Editor クライアントをインストールできます。 クライアントのインストレーションを別途実行する必要はありません。

  • SOLIDWORKS Installation Manager を使用した PDM Client のインストール


PDM Server コンポーネントのリスト

このテーブルにはSOLIDWORKS PDM Server のサーバー コンポーネントがまとめられています。

Server | 関数 | インストレーション（Installation）
PDM Standard 向け Microsoft SQL Server Express | SOLIDWORKS PDM データ ボルトのデータを管理します。 | PDM Standard と一緒にインストール可能です。または、前にライセンスが付与されインストールされているバージョンを使用できます。
PDM Professional 向け Microsoft SQL Server | SOLIDWORKS PDM データ ボルトのデータを管理します。 | 必ず実行: 以前に使用許諾され、インストールされたバージョンも使用できます。
SolidNetWork License Manager クライアント | SOLIDWORKS PDM ライセンスを管理します。 | 新しいボルトを作成する前にインストールされている必要があります。 SOLIDWORKS Installation Manager を使用している場合、SOLIDWORKS PDM サーバー構成部品とともにインストールできます。
アーカイブ サーバー | クライアントとファイル ボルト アーカイブ間のファイル転送を管理し、ユーザーとその資格情報を管理します。 | 必ず実行: PDM Standard または Professional と一緒にインストールします。
データベース サーバー | 更新に関して PDM データベースをポーリングし、データのインポートおよびエクスポート ルールを管理し、メッセージ システムを管理し、また複製およびコールド ストレージをスケジュールします。 | 必ず実行: PDM Standard または Professional と一緒にインストールします。
Web2 Server | ブラウザ ベースのクライアントからインターネット経由でファイル ボルトへのアクセスを提供します。 | この操作はオプションです。 PDM Professional のみと一緒にインストールします。
Web API サーバー | EXALEAD OnePart ユーザーは、Web API サーバーを使用して、SOLIDWORKS PDM データをインデックス化し、取得することができます。 | この操作はオプションです。 PDM Professional のみと一緒にインストールします。

アーカイブ サーバーはインストール先のコンピュータのシステム アカウントでのサービスとして実行されます。 1 つのアーカイブ サーバーは同じコンピュータにある複数のファイル ボルトをホスティングできます。

スタンドアロン インストレーションでは、アーカイブ サーバー、データベース サーバー、ライセンス サーバー、Web API サーバーだけでなく、SQL Express または SQL Server データベースもすべて同じマシンにインストールできます。

分散環境では、サーバー コンポーネントは別のマシンに配置できます。 SOLIDWORKS PDM Professional では、リモート位置でのパフォーマンスを向上させるため、ファイル ボルト アーカイブおよび SQL サーバー データベースの複製もサポートしています。 詳細については、SOLIDWORKS PDM Professional 複製ガイドを参照してください。

親トピック SOLIDWORKS PDM および SOLIDWORKS Manage


PDM クライアントの違いについて

クライアント ソフトウェアをインストールする前に、PDM 環境によって異なるクライアントのうちどのクライアントが必要なのかを判断する必要があります。

このテーブルには SOLIDWORKS PDM Standard 向けクライアントの要約が記載されています。
Standard クライアントの種類 | 説明
CAD Editor | SOLIDWORKS、DWG/DXF 形式、Microsoft Word、Microsoft Excel ファイルをサポートします。Office プラグインで処理されるすべてのファイル フォーマットは、プレビューを除き SOLIDWORKS PDM Standard で同じように動作します。
Contributor | SOLIDWORKS、DWG/DXF 形式、Microsoft Word、Microsoft Excel ファイルをサポートします。
Viewer | ファイル ボルトに読み取り専用のアクセスを許可します。ユーザーは、ワークフローを通してファイルを遷移させることができますが、ファイルを追加または修正（チェックアウト、チェックイン、値の更新）することはできません。
このテーブルには SOLIDWORKS PDM Professional 向けクライアントの要約が記載されています。
Professional クライアントの種類 | 説明
CAD Editor & Web | 全てのファイル タイプをサポートし、SOLIDWORKS を含む CAD フォーマットの管理とプレビュー機能が強化されています。CAD アドインの使用により、CAD アプリケーションから SOLIDWORKS PDM Professional にアクセスすることも可能です。リモート ユーザーは、ボルトを検索し、インターネットを介して Web2 クライアントを使用して基本的な機能を実行できます。
Contributor & Web | CAD ファイルを含む全てのファイル タイプをサポートしています。しかし、このクライアント タイプは CAD アドインがサポートされていません。リモート ユーザーは、Web2 クライアントを使用して、インターネット経由でボルトの検索や基本的な機能を実行できます。
Viewer | ファイル ボルトに読み取り専用のアクセスを許可します。 ユーザーは、ワークフローを通してファイルを遷移させることができますが、ファイルを追加または修正（チェックアウト、チェックイン、値の更新）すること、または CAD アドインを使用することはできません。
親トピック SOLIDWORKS PDM および SOLIDWORKS Manage


PDM Server をインストールする前に

PDM Server コンポーネントをインストールする前に、次の要件を満たしておく必要があります。

  • サーバーとクライアントをインストールする予定のマシンに完全な管理権限を取得してください。
  • データベース サーバーがTCP</Z1>ポート3030</Z2>を使ってアーカイブ サーバーへ、そしてTCP</Z3>ポート1433</Z4>を使ってSQL</Z5>サーバーにアクセス可能であることを確認してください。
  • 既存の SQL Server Express または SQL Server データベースを使用する予定の場合、SQL Server データベースの名前と、データベースへの読み取り/書き込みアクセス権を持つ SQL Server 管理者またはデータベース所有者のアカウント ID とパスワードを取得してください。 tew ユーザーは使用できません。
  • PDM クライアントが既にシステムにインストールされている場合、それをアンインストールします。 PDM Server と PDM クライアントを同じシステムに置きたい場合、SOLIDWORKS Installation Manager のServer 製品ページから両方をインストールできます。
親トピック SOLIDWORKS PDM および SOLIDWORKS Manage


SOLIDWORKS Installation Manager を使用した PDM Server のインストール

PDM Standard 用に PDM Server をインストールする場合、同じマシン上にアーカイブ サーバー、データベース サーバー、および PDM CAD Editor クライアントをインストールできます。 クライアントのインストレーションを別途実行する必要はありません。

PDM Professional 用に PDM Server をインストールするとき、これらのコンポーネントの他、Web2 サーバーおよび Web API サーバーも含めることができます。

PDM Server とそのコンポーネントをインストールするには:

  1. SOLIDWORKS Installation Manager を起動します。
  2. ようこそ（Welcome）ページでサーバー コンポーネントをインストール（Install server components）を選択して以下をクリックします:
    • SOLIDWORKS PDM Server コンポーネントをこのコンピュータにインストールする（Install SOLIDWORKS PDM Server components on this computer）。
    • SolidNetWork License Manager をこのコンピュータにインストールする（Install SolidNetWork License Manager on this computer）。

      このコンピュータまたは別のコンピュータに SolidNetWork License Manager がインストールされている場合、このオプションは表示されません。

  3. SolidNetwork License Manager オプション（SolidNetwork License Manager Options）ページが表示される場合、シリアル番号を入力し、ディレクトリの場所を指定して次へ（Next）をクリックします。
  4. システムの警告の指示に従い次へ（Next）をクリックします。
  5. SOLIDWORKS PDM Server のサマリー（Summary）ページで変更（Change）をクリックします。
  6. SOLIDWORKS PDM Server オプション（SOLIDWORKS PDM Server Options）ページで:
    1. Server 製品の選択（Select Server Product）で、SOLIDWORKS PDM Standard または Professional をクリックします。
    2. インストレーション先（Installation Location）で、参照（Browse）をクリックしてファイル パスを指定します。
    3. 機能の選択（Select Features）で:
      1. アーカイブ サーバー（Archive Server）、データベース サーバー（Database Server）、およびクライアント（client）をクリックして、これらのコンポーネントを同じマシン上にインストールします。分散環境の場合、別のマシン上で Installation Manager を実行して、アーカイブ サーバーとデータベース サーバーをインストールできます。
        • マシン上に PDM クライアントが既にインストールされている場合、インストレーションをキャンセルして、クライアントをアンインストールする必要があります。次に、SOLIDWORKS Installation Manager を実行して、クライアントと共に PDM サーバーをインストールします。
        • SOLIDWORKS PDM サーバー インストールに含まれる SOLIDWORKS PDM クライアント コンポーネントにはアイテム エクスプローラが含まれており、これを除外することはできません。
      2. PDM Professional をインストールしている場合は、Web2 サーバー（Web2 server）および Web API サーバー（Web API Server）もクリックできます。
        Web API サーバーをインストールしている場合は、HTTP ポート番号（HTTP port number）に 0 ～ 65535 の値を指定します。デフォルト値は 65453 です。
    4. SQL Server で、PDM Server と共に提供されるデータベース ツールの新規インスタンスをインストールできます（SQL Server Express for PDM Standard）。または、既存インスタンスのデータベース名、ユーザー名、およびパスワードを指定できます。
      SOLIDWORKS PDM Professional では、SQL Server の完全バージョンがインストールされている必要があります。
    5. サマリーに戻る（Back to Summary）をクリックします。
  7. サマリー（Summary）ページで SOLIDWORKS 使用許諾書の条件を受け入れて今すぐインストール（Install Now）をクリックします。

    SOLIDWORKS Installation Manager がインストールを完了すると、アーカイブ サーバー コンフィギュレーション ツール（Archive Server Configuration Tool）が開始します。 ウィザード内のプロンプトに従って、アーカイブ サーバーを構成します。

アーカイブ サーバー、データベース サーバー、Web2 サーバー、および SQL Server データベースのセットアップ、構成、およびトラブルシューティングを行うには、SOLIDWORKS PDM インストール ガイドで関連するトピックを参照してください。

目次

  • SOLIDWORKS PDM Server のインストールを変更する

親トピック SOLIDWORKS PDM および SOLIDWORKS Manage


SOLIDWORKS PDM Server のインストールを変更する

SOLIDWORKS PDM Server とそのコンポーネントのインストールを変更するには、Windows コントロール パネル（Windows Control Panel）からプログラムと機能（Programs and Features）を使用します。 SOLIDWORKS PDM Server のインストールに使用した場合でも、SOLIDWORKS Installation Manager（SLDIM）でインストールを変更することはできません。

親トピック SOLIDWORKS Installation Manager を使用した PDM Server のインストール


SOLIDWORKS Installation Manager を使用した PDM Client のインストール

SOLIDWORKS PDM Client のメジャー バージョンは SOLIDWORKS PDM Server のメジャー バージョンと一致させる必要があります。 SOLIDWORKS PDM Client をインストールまたはアップグレードする場合は、バージョンが一致していることを確認してください。

PDM Client をインストールするには:

  1. SOLIDWORKS Installation Manager を起動します。
  2. ようこそ（Welcome）ページで、このコンピュータにインストール（Install on this computer）を選択します。
  3. シリアル番号（Serial Number）ページで次へ（Next）をクリックします。
    SOLIDWORKS PDM クライアントは、別個のシリアル番号を必要としません。
  4. システムの警告の指示に従い次へ（Next）をクリックします。
  5. サマリー（Summary）ページの製品（Products）の下で変更（Change）をクリックします。
  6. 製品選択（Product Selection）ページで別のパッケージ/製品の選択（Select different packages or products）をクリックします。
  7. 表示するパッケージを選択してください（Select the package you want to show）ダイアログ ボックスで SOLIDWORKS のエディションを選択します。OKをクリックします。
  8. 製品選択（Product Selection）ページで SOLIDWORKS PDM Client を選択します。 次に、eDrawings を選択して、PDM プレビュー機能を有効にします。 SOLIDWORKS PDM Professional を使用している場合は Item Explorer も選択できます。
  9. サマリー（Summary）ページで SOLIDWORKS PDM オプション（SOLIDWORKS PDM Options）を展開して変更（Change）をクリックします。
  10. SOLIDWORKS PDM Client オプション（SOLIDWORKS PDM Client Options）ページで次を選択してサマリーに戻る（Back to Summary）をクリックします。
    • PDM 製品のタイプ
    • PDM クライアントの種類
    • アドイン
  11. サマリー（Summary）ページで SOLIDWORKS 使用許諾書の条件を受け入れて今すぐインストール（Install Now）をクリックします。
管理者は、PDM クライアントのイメージの作成と展開に、アドミニストレーティブ イメージ オプション エディタも使用できます。詳細は、アドミニストレーティブ イメージの使用（Using Administrative Images）を参照してください。
親トピック SOLIDWORKS PDM および SOLIDWORKS Manage


SOLIDWORKS Electrical

SOLIDWORKS Installation Manager では、SOLIDWORKS Electrical のすべてのコンポーネントを、スタンドアロン モードまたはクライアント/サーバー モードでインストールできます。

SOLIDWORKS Electrical では複数のコンポーネントを使用します。インストール中に、必要なインストールのタイプに応じて、これらのコンポーネントを選択する必要があります。
  • SOLIDWORKS Electrical Schematic - 電気配線図を作成および管理するための 2D アプリケーション。
  • SOLIDWORKS Electrical 3D - 2D スキマティックと 3D モデルを統合するための SOLIDWORKS アドイン。SOLIDWORKS Electrical 3D を使用すると、エレクトリカル デバイスのレイアウトを管理し、ワイヤ、ケーブル、およびハーネスを配線できます。
  • Data - Data では、ソフトウェアで必要なすべてのデータがグループ化されます。このデータは、グラフィック データ（シンボルや表題欄を表すファイルなど）またはテクニカル データ（メーカー カタログや記号に関連付けられたデータなど）です。すべてのユーザーがアクセスできるようにデータを共有することができます。
  • Collaborative Server - 電気図面のオープンと更新を管理するユーティリティです。
  • SQL Server - SOLIDWORKS Electrical には、Microsoft SQL Server データベースが必要です。インストール時に、新しいデータベースを作成するか、既存のデータベースを使用するかを選択できます。

インストールのタイプ

SOLIDWORKS Electrical のすべてのコンポーネントを同じマシンにインストールできます。これはスタンドアロン インストールです。ワークステーションにすべてのプログラム データ（プロジェクトの図面やレポートなど）が保存されます。

SOLIDWORKS Electrical のコンポーネントをクライアント/サーバー アプリケーションとしてインストールすることもできます。 データをネットワーク サーバーに保存する場合は、このタイプのインストールを使用します。 クライアント/サーバー インストールでは、複数のユーザーが同じプロジェクトで作業できます。 クライアント システムには、サーバーへのネットワーク アクセス権と、プロジェクト、ライブラリ、および記号を作成するための読み取り/書き込み権限が必要です。

情報

どのインストールの種類（スタンドアロンまたはクライアント/サーバー）でも、SOLIDWORKS Electrical をインストールするには、完全な権限があるモードで Windows セッションを起動する必要があります。

1 台のマシンにインストールできる SOLIDWORKS Electrical のバージョンは 1 つだけです。 SOLIDWORKS のインストールで、インストールする製品の 1 つとして SOLIDWORKS Electrical を選択した場合、インストール プログラムは古いバージョンの SOLIDWORKS Electrical を削除します。

SOLIDWORKS Installation Manager を起動すると、ワークステーションまたはサーバーにインストールされている既存のバージョンの SOLIDWORKS Electrical が自動的に検出されます。

新しいバージョンをインストールする前に、常に既存の SOLIDWORKS Electrical 環境をバックアップしてください。 SOLIDWORKS Electrical Schematic 内からファイル（File） > アーカイブ環境（Archive Environment）を選択するか、SOLIDWORKS Electrical 3D 内から SOLIDWORKS Electrical > ツール（Tools） > アーカイブ環境（Archive Environment）を選択します。

目次

  • SOLIDWORKS Electrical をインストールするための要件

  • スタンドアロンまたはクライアント/サーバー インストール

    SOLIDWORKS Electrical は 2 つのモードでインストールできます。スタンドアロン モードでは、ソフトウェアをワークステーションにインストールします。クライアント/サーバー モードでは、ユーザーがデータを共有します。

  • Collaborative Server の設定

  • Microsoft SQL Server の設定

  • データの場所の指定


SOLIDWORKS Electrical をインストールするための要件

現在のシステム要件にアクセスするには、システム要件を参照してください。

親トピック SOLIDWORKS Electrical
スタンドアロンまたはクライアント/サーバー インストール
Collaborative Server の設定
Microsoft SQL Server の設定
データの場所の指定


スタンドアロンまたはクライアント/サーバー インストール

SOLIDWORKS Electrical は 2 つのモードでインストールできます。スタンドアロン モードでは、ソフトウェアをワークステーションにインストールします。クライアント/サーバー モードでは、ユーザーがデータを共有します。

SOLIDWORKS Electrical は、常に SQL Server のインスタンスに接続している必要があります。

親トピック SOLIDWORKS Electrical
SOLIDWORKS Electrical をインストールするための要件
Collaborative Server の設定
Microsoft SQL Server の設定
データの場所の指定

Stand-Alone インストレーション

最初のインストールでは、すべてのコンポーネントをワークステーションにインストールする必要があります。

  • SOLIDWORKS Electrical Schematic
  • SOLIDWORKS Electrical 3D
  • Collaborative Server
  • アプリケーション データ
  1. サマリー（Summary）タブで、製品選択（Product Selection）セクションの変更（Change）をクリックし、すべての SOLIDWORKS Electrical コンポーネントを選択します。
  2. インストール オプションを変更する場合は、サマリー（Summary）タブの Electrical オプション（Electrical Options）セクションの変更（Change）をクリックします。 SQL Server の新しいインスタンスを作成することも、既存のインスタンスを使用することもできます。 詳細については、このドキュメントの『データおよび Microsoft SQL Server』に関する特定の章を参照してください。 不明な場合は、デフォルトを保持します。
  3. 作業を続行するには、今すぐインストール（Install now）をクリックします。
SOLIDWORKS Electrical が既にワークステーションにインストールされている場合は、SOLIDWORKS Installation Manager によって自動的に検出され、更新するように求められます。 Electrical オプション（Electrical Options）を変更せずにすべてのコンポーネントをインストールします。

クライアント/サーバー インストール

クライアント/サーバーのインストールでは、複数のユーザー間でデータを共有できます。

サーバーには、以下のコンポーネントをインストールする必要があります。
  • Collaborative Server
  • アプリケーション データ
  • SQL Server
クライアントでは、以下のコンポーネントをインストールする必要があります。
  • SOLIDWORKS Electrical Schematic
  • SOLIDWORKS Electrical 3D
  1. サーバーに、サーバー コンポーネントをインストールします。
  2. SOLIDWORKS Installation Manager へようこそ（Welcome SOLIDWORKS Installation Manager）タブで、サーバー コンポーネントをインストール（Install server component）をクリックします。
  3. SOLIDWORKS Electrical オプションを選択します。
  4. Summary（サマリ）タブで、インストール オプションを変更できます。 詳細については、このドキュメントの『データおよび Microsoft SQL Server』に関する特定の章を参照してください。 不明な場合は、デフォルトを保持します。
  5. 作業を続行するには、今すぐインストール（Install now）をクリックします。
  6. クライアントで、アプリケーションをインストールします。
  7. SOLIDWORKS Installation Manager へようこそ（Welcome SOLIDWORKS Installation Manager）タブで、このコンピュータにインストール（Install on this computer）をクリックします。
  8. サマリ（Summary）タブで、製品選択（Product Selection）セクションの変更（Change）をクリックし、Electrical Serverオプションを選択解除します。
  9. サマリ（Summary）タブで、Electrical オプション（Electrical Options）セクションの変更（Change）をクリックし、サーバーに接続するための設定を変更します。
  10. 作業を続行するには、今すぐインストール（Install now）をクリックします。
SOLIDWORKS Electrical が既にワークステーションまたはサーバーにインストールされている場合、SOLIDWORKS Installation Manager は自動的にそれを検出し、更新を求めるプロンプトを表示します。 ソフトウェアを更新するには、初回インストールと同じプロセスを使用します。


Collaborative Server の設定

Collaborative Server は、常に実行されている必要がある Windows Service で、ファイアウォールとウイルス スキャナーを介してクライアントと常に中断なしで双方向通信を行います。

Collaborative Server を個別モードまたはサーバー モードで構成するには、以下のパラメータを指定します。
  • マシン名（たとえば LOCALHOST または MyMachine）あるいはその IP アドレス（たとえば、 127.0.0.1、または 192.168.999.999）。
  • ポート番号（デフォルトは 26666）。

Collaborative Server は、インストール中に構成することも、後でツール（Tools） > アプリケーション設定（Application Settings）コマンドで構成することもできます。

双方向通信を中断しないようにするため、Collaborative Server がインストールされているシステムでポート番号 26666 ～ 26676（10 人のユーザーが同時に接続する場合）が使用可能であることを確認します。 使用可能でない場合は、システム管理者に SOLIDWORKS Electrical の別のポートを検索するよう依頼してください。

親トピック SOLIDWORKS Electrical
SOLIDWORKS Electrical をインストールするための要件
スタンドアロンまたはクライアント/サーバー インストール
Microsoft SQL Server の設定
データの場所の指定


Microsoft SQL Server の設定

SOLIDWORKS Electrical のどのタイプのインストールでも、必ず SQL Server データベースのインスタンスを使用可能にしてください。既存の SQL Server データベースがシステムにインストールされている場合は、それを使用できます。SOLIDWORKS Electrical のインストール時に新しいインスタンスをインストールすることもできます。

SQL Server の新しいインスタンスをインストールすると、SOLIDWORKS のインストール環境では Microsoft SQL Express 2022 の無償ライセンス版がインストールされます。このバージョンは、1 CPU、1 GB のメモリ、10 GB のデータに制限されています。このメモリと CPU の制限内で、10 人の同時ユーザーを十分にサポートできます。

SQL Express 2022 をインストールする場合は、サーバーのソフトウェアとハードウェアがシステム要件に記載されている要件を満たすことを確認してください。

ベスト プラクティスとして、同じサーバー上に 10 人より多いユーザーが同時にいる場合は、フル バージョンの SQL Server を購入してインストールすることをお勧めします。既存の SQL Server インスタンスを使用した SOLIDWORKS Electrical のインストール向けに記述されているワークフローを使用してください。

SQL Express 2022 については、Microsoft SQL Server のドキュメントを参照してください。

親トピック SOLIDWORKS Electrical
SOLIDWORKS Electrical をインストールするための要件
スタンドアロンまたはクライアント/サーバー インストール
Collaborative Server の設定
データの場所の指定

SOLIDWORKS Electrical でのデータの管理

多くのプログラムは、1 つのデータベースを使用してすべてのプログラム データを格納します。 SOLIDWORKS Electrical はこれに該当しません。SOLIDWORKS Electrical の各プロジェクトには一意の ID 番号が割り当てられ、その一意の ID 番号に基づいて識別できるデータベースが各プロジェクトに関連付けられています。 たとえば、SOLIDWORKS Electrical Project Manager で、ID 番号 112 のプロジェクトが存在する場合、関連付けられたデータベースの名前は「tew_project_data_112」になります。

各プロジェクトに一意のデータベースが存在する理由は、それによって処理時間が大幅に短縮されるためです。 また、重大なデータベース障害が発生した場合も、影響を受けるプロジェクトは 1 つだけであり、プログラム情報の大部分の整合性が保持されます。

ただし、新しいデータベースの作成を制限するポリシーを持つ企業もあります。 SOLIDWORKS Electrical を実行するには、ユーザーによる新しいデータベースの作成を制限しないようにする必要があります。 システムまたはデータベースの管理者に問い合わせて、ユーザーによる新しいデータベースの作成を禁止するコンフィギュレーション設定が存在しないことを確認してください。

SQL Server の新しいインスタンス

SQL Server の新しいインスタンスをインストールする場合は、サーバーおよびクライアント システムに対する完全な管理者権限が必要です。 また、クライアントにデータベースの読み取り/書き込み権限があり、クライアントでプロジェクト、ライブラリ、記号、およびその他のプロジェクト データを作成できることを確認する必要があります。

SQL Server の新しいインスタンスをインストールする場合は、デフォルト以外の名前を選択してください。

SQL Server の既存のインスタンス

新しい SOLIDWORKS Electrical データベースをインストールする場合、または SQL Server の既存のインスタンスにインストールされた SOLIDWORKS Electrical に接続する場合は、SQL Server データベースに対する完全な管理者権限を持つユーザー アカウントが必要です。

SOLIDWORKS Electrical が正しく機能するには、SQL Server の混合モード認証を有効にする必要があります。 混合モード認証では、Windows と SQL Server のどちらかの認証情報を使用できます。

既存の SQL Server データベースに接続するには、Windows 認証または SQL Server 認証を使用します。 SQL Server に対する完全な管理者権限を持つユーザーが Windows または SQL Server にログインするためのユーザー名とパスワードを入力します。

インストール時に「tew」ユーザーを使用して SQL Server に接続することはできません。 SQL Server に対する適切な認証情報を含むログインの取得方法については、SQL Server 管理者またはシステム管理者に問い合わせてください。

SOLIDWORKS Electrical データベース

SOLIDWORKS Electrical をインストールすると、インストール プログラムにより、SQL Server インスタンスに次のデータベースが作成されます。

  • TEW_APP_DATA
  • TEW_APP_MACRO
  • TEW_APP_PROJECT
  • TEW_CATALOG
  • TEW_CLASSIFICATION


データの場所の指定

データの場所として、部品、テンプレート、2D と 3D の記号などのプログラム データを保存するディレクトリを選択します。 この場所については、専用のディレクトリを指定してください。 ルート ディレクトリや SOLIDWORKS データの保存に使用するディレクトリは指定できません。

デフォルト ディレクトリは、C:\ProgramData\SOLIDWORKS Electrical です。

クライアント/サーバー インストールの場合は、データ ディレクトリを共有する必要があります。

インストール プログラムは、すべての新しいデータを格納するために、デフォルト ディレクトリに Update という名前の新しいフォルダを作成します。

SOLIDWORKS Electrical を初めて起動すると、 Update フォルダに保存されているデータが既存のデータと自動的にマージされます。 データを更新（Update Data）ウィザードで、アプリケーションや SQL Server データベースに追加するデータを選択できます。

親トピック SOLIDWORKS Electrical
SOLIDWORKS Electrical をインストールするための要件
スタンドアロンまたはクライアント/サーバー インストール
Collaborative Server の設定
Microsoft SQL Server の設定


SOLIDWORKS Visualize および SOLIDWORKS Visualize Boost

SOLIDWORKS® Visualize は、高度なレンダリング機能と設計指向の機能およびワークフローを組み合わせたスタンドアロン ツール一式を備えます。これにより、3D CAD モデルの非常にリアルなイメージを作成できます。

SOLIDWORKS Visualize 製品は、次の 2 つのパッケージで利用できます:
  • 標準
  • Professional

SOLIDWORKS Visualize Standard の無償シートは、アクティブなサブスクリプションの SOLIDWORKS Professional および Premium ライセンスそれぞれに含まれています。スタンドアロンで SOLIDWORKS を使用する場合は、追加のシリアル番号が必要です。SOLIDWORKS Visualize のシリアル番号が不明な場合は、SOLIDWORKS 管理者または代理店に問い合わせてください。

SOLIDWORKS Visualize は、オフライン アクティベーションの他、フローティングなどの SolidNetWork Licensing（SNL）ライセンス タイプもサポートします。

SOLIDWORKS Installation Manager（SLDIM）を使用して、SOLIDWORKS Visualize を個別（このコンピュータ上にインストール（Install on this computer））インストールの一部としてインストールします。スタンドアロン アプリケーションとしてインストールできるため、モデリングとレンダリングに別々のコンピュータを使用する場合に有効です。SOLIDWORKS ライセンスは使用しません。

SOLIDWORKS Visualize Boost は、SOLIDWORKS Visualize Professional を実行しているコンピュータから、ネットワーク上の 1 つ以上のコンピュータにレンダリングを配布できるサービスです。レンダリングされたイメージが生成されている間に、コンピュータ上で他のタスクを実行でき、最終レンダリング イメージがより早く利用可能になります。Visualize Boost は、SOLIDWORKS Installation Manager の個別（このコンピュータ上にインストール（Install on this computer））インストールの一部としてインストールすることもできます。

SOLIDWORKS Visualize Boost の無償シートは、アクティブなサブスクリプションの SOLIDWORKS Visualize Professional の各シートに含まれています。
Visualize Boost は、Visualize Professional のみに対するプロダクト アドオンです。Visualize Boost は、Visualize Standard では機能しません。

目次

  • SOLIDWORKS Visualize のシステム要件

  • SOLIDWORKS Installation Manager による SOLIDWORKS Visualize のインストール

  • SOLIDWORKS Installation Manager での Visualize Boost のインストール


SOLIDWORKS Visualize のシステム要件

SOLIDWORKS Visualize および SOLIDWORKS Visualize Boost の最適なパフォーマンスとセットアップのために、インストール前に次のガイドラインに従ってください。
  • 各製品に個別のシリアル番号があることを確認してから、SOLIDWORKS Visualize および SOLIDWORKS Visualize Boost をインストールしてください。
  • SOLIDWORKS Visualize または SOLIDWORKS Visualize Boost を実行しているすべてのコンピュータが、システム要件に記載されている要件を満たしていることを確認します。
  • SOLIDWORKS Visualize Boost アプリケーションは、同じネットワーク内の専用レンダリング コンピュータにインストールします。これらのコンピュータは SOLIDWORKS Visualize Professional を実行するコンピュータと別にして、レンダリング タスクをオフロードする必要があります。
  • SOLIDWORKS Visualize および SOLIDWORKS Visualize Boost は、適切な GPU が見つからない場合、代わりに中央処理装置（CPU）をデフォルトで選択します。特定のグラフィック カードとドライバの詳細については、SOLIDWORKS ハードウェア認定（SOLIDWORKS Hardware Certification）を参照してください。

3DS Stellar Physically Correct を使用した GPU サポートの場合

Stellar の高精度（Accurate）レンダリング モード:
  • 少なくとも Maxwell マイクロアーキテクチャに基づく NVIDIA グラフィックス カード
  • 推奨ドライバ バージョンは CUDA 12.2 をサポートする 538.78。
  • 最小 4 GB のビデオ メモリ
Stellar の高速（Fast）レンダリング モード:
  • 少なくとも Turing マイクロアーキテクチャに基づく NVIDIA グラフィックス カード（RT コア搭載）
  • 使用するドライバ バージョンとメモリ要件は高精度（Accurate）モードと同じ

AMD ProRender を使用した GPU サポートの場合

AMD ProRender の高速（Fast）および高精度（Accurate）レンダリング モード:
  • Vulkan 標準をサポートする GPU およびドライバ
  • 1.2 以上の OpenCL をサポート
親トピック SOLIDWORKS Visualize および SOLIDWORKS Visualize Boost


SOLIDWORKS Installation Manager による SOLIDWORKS Visualize のインストール

SOLIDWORKS Visualize をインストールするには:

  1. SOLIDWORKS Installation Manager を起動します。
  2. ようこそ（Welcome）ページで、このコンピュータにインストール（Install on this computer）を選択します。
  3. 以下を行います：
    1. シリアル番号（Serial Number）ページで Visualization を展開します。
    2. SOLIDWORKS Visualize を選択し、シリアル番号を入力します。
    3. 次へ（Next）をクリックします。
  4. システムの警告の指示に従い次へ（Next）をクリックします。
  5. サマリー（Summary）ページで SOLIDWORKS 使用許諾書の条件を受け入れて今すぐインストール（Install Now）をクリックします。
プロダクト アクティベーション ウィザードの指示に従って、製品をアクティブ化します。

アクティベーション後、デスクトップで SOLIDWORKS Visualize ショートカット アイコンをダブルクリックしてアプリケーションを開始するか、Windows のスタート（Start）メニューから、SOLIDWORKS バージョン > SOLIDWORKS Visualize バージョンをクリックします。

目次

  • インストール後のタスク

親トピック SOLIDWORKS Visualize および SOLIDWORKS Visualize Boost


インストール後のタスク

インストール後、SOLIDWORKS Visualize を構成するために実行するタスクがいくつかあります。

詳細については、SOLIDWORKS Visualize ヘルプの SOLIDWORKS Visualize の基本操作（Getting Started with SOLIDWORKS Visualize）を参照してください。

目次

  • 内容フォルダの作成

  • ヘルプ、チュートリアル、システム情報、およびライセンスへのアクセス

親トピック SOLIDWORKS Installation Manager による SOLIDWORKS Visualize のインストール


内容フォルダの作成

ソフトウェアを初めて起動すると、SOLIDWORKS Visualize から内容（Content）フォルダを作成する場所が求められます。

内容（Content）フォルダには次のサブフォルダが含まれ、プロジェクトのアセットを格納できます:
サブフォルダ | ストア（Stores）
カメラ（Cameras） | デフォルトのカメラおよび保存したカメラ
環境（Environments） | ハイ ダイナミック レンジ（HDR）イメージ
パレット（Palettes） | バックプレート イメージ
イメージ（Images） | レンダリングおよびスナップショット
外観（Appearances） | 外観ライブラリの材料 外観をライブラリに追加すると、内容が更新されます。
モデル（Models） | モデル ファイル（Model files） デフォルトでは、モデルでファイル（File） > インポート（Import）を使用すると、SOLIDWORKS Visualize は最初にこのフォルダを検索します。
プレート（Plates） | バックプレートで使用するための標準 2D イメージ
プロジェクト（Projects） | .SVPJ 形式のネイティブ プロジェクト ファイル
テクスチャ（Textures） | 外観で使用するための 2D テクスチャ
親トピック インストール後のタスク


ヘルプ、チュートリアル、システム情報、およびライセンスへのアクセス

ヘルプ メニューには、ソフトウェアを更新したり、システムをトラブルシューティングするためのドキュメントおよびオプションが含まれています。

Visualize ヘルプ（Visualize Help） | SOLIDWORKS Visualize オンライン ヘルプを開きます。
Visualize チュートリアル（Visualize Tutorials） | MySolidWorks を開き、SOLIDWORKS Visualize のチュートリアルにアクセスできるようにします。
リリース ノート（Release Notes） | 現在のバージョンのオンライン リリース ノートを表示します。
新規機能（What's New） | SOLIDWORKS 製品の新機能を表示します。
システム情報（System Info） | 使用中の PC ハードウェアで SOLIDWORKS Visualize ソフトウェアのシステム チェックを実行し、必要な場合はアップグレードを提案します。
更新をチェック（Check for updates） | サーバーに最新の SOLIDWORKS Visualize 更新があるかチェックします。
ライセンスのアクティブ化（Activate License） | （ノードロック ライセンス）SOLIDWORKS 製品アクティベーション ウィザードを使用して製品をアクティブ化します。
ライセンスを無効化（Deactivate License） | （ノードロック ライセンス）SOLIDWORKS 製品アクティベーション ウィザードを使用して製品を無効化します。
SolidNetWork License Manager | SOLIDWORKS 製品アクティベーション ウィザードを使用して製品を無効化します。
Visualize について（About Visualize） | SOLIDWORKS Visualizeのバージョン番号およびライセンス情報が表示されます。
親トピック インストール後のタスク


SOLIDWORKS Installation Manager での Visualize Boost のインストール

Visualize Boost は、SOLIDWORKS Installation Manager を使用してインストールします。 別のシリアル番号が必要です。

Visualize Boost は、SOLIDWORKS Visualize Professional を実行しているコンピュータとは異なるコンピュータにインストールする必要があります。グラフィックス プロセッシング ユニット（GPU）を複数備えたコンピュータに Visualize Boost をインストールすると、レンダリングのパフォーマンスを最大化できます。

SOLIDWORKS Visualize Boost をインストールするには:

  1. SOLIDWORKS Installation Manager を起動します。
  2. ようこそ（Welcome）ページで、このコンピュータにインストール（Install on this computer）を選択します。
  3. 以下を行います：
    1. シリアル番号（Serial Number）ページで Visualization を展開します。
    2. SOLIDWORKS Visualize Boost を選択し、シリアル番号を入力します。
    3. 次へ（Next）をクリックします。
  4. システムの警告の指示に従い次へ（Next）をクリックします。
  5. サマリー（Summary）ページで SOLIDWORKS 使用許諾書の条件を受け入れて今すぐインストール（Install Now）をクリックします。
プロダクト アクティベーション ウィザードの指示に従って、製品をアクティブ化します。

アクティブ化の後、SOLIDWORKS Visualize Boost のデスクトップ ショートカット [image] をダブルクリックして開きます。

目次

  • Visualize Boost の設定

    第 1 Visualize Boost マシンをコーディネータとして設定し、レンダリング クラスタ内の追加マシンをノードとして設定できます。

親トピック SOLIDWORKS Visualize および SOLIDWORKS Visualize Boost


Visualize Boost の設定

第 1 Visualize Boost マシンをコーディネータとして設定し、レンダリング クラスタ内の追加マシンをノードとして設定できます。

Visualize Boost では、単一のマシンまたはマシンのクラスタ全体でイメージをレンダリングできます。セットアップは簡単かつ直感的です。第 1 コンピュータのコーディネータ（Coordinator）は、クラスタを管理し、SOLIDWORKS Visualize からレンダリング ジョブを配布します。ノード（Nodes）と呼ばれる追加のマシンは、コーディネータに接続して、ネットワーク上のこれらのタスクを支援します。レンダリング ファームでは、クラスタ内の各マシンが Visualize Boost のインスタンスを連続的に実行します。

Visualize Boost を設定するには:

  1. Visualize Boost を開きます。
    • Visualize Boost のデスクトップ ショートカット [image] をダブルクリックします。
    • Windows のスタート（Start）メニューで、SOLIDWORKS <バージョン> > SOLIDWORKS Visualize Boost <バージョン> をクリックします。
    起動後、Visualize Boost ウィンドウは、ライセンスされたマシンの名前と IP アドレスを識別して表示します。
  2. Visualize Boost で、ファイル（File） > 設定（Settings）をクリックします。
  3. 設定（Settings）ダイアログ ボックスで:
    1. コーディネータ（Coordinator）としてマシンを 1 台選択します。他のすべてのノード（Nodes）を設定する場合は、コーディネータ（Coordinator）を選択解除したままにします。
    2. ブースト ポート（Boost Port）はデフォルト値 8001、DStellar ポート（DStellar Port）はデフォルト値 8002 のままにします。
      これらのポートは、ネットワーク要件を満たすように更新できます。ノード通信にファイアウォール例外を必ず追加してください。不明な点があれば、ネットワーク管理者に確認してください。
  4. オプション: その他のパラメータは次のとおりです。
    オプション | 説明
    言語 | マシンは自動的にオペレーティング システムの言語を使用します。
    テーマ | テーマ（Theme）の背景として薄い（Light）または濃い（Dark）を選択します。Visualize Boost と同じマシンにインストールされている場合、この設定は、SOLIDWORKS Visualize に影響します。
    通知が有効化されました（Notifications Enabled） | DStellar.Boost からのメッセージを Windows 通知領域に表示します。
    エクスポート（Export） | Visualize Boost の設定を .json ファイルに保存します。
    インポート（Import） | 既存の設定を .json ファイルの Visualize Boost のインスタンスに読み込みます。
  5. 適用（Apply）をクリックします。
セットアップを完了するには、Visualize Boost での作業（Working with Visualize Boost）の手順を参照してください。
親トピック SOLIDWORKS Installation Manager での Visualize Boost のインストール


ライセンス管理（License Administration）

インストール後に SOLIDWORKS ライセンスをアクティブ化するには、個人コンピュータでのアクティブ化（マシン アクティベーション）、またはサーバーでのフローティングネットワーク ライセンスのインストールとアクティブ化（SolidNetWork ライセンス）のいずれかを行います。

一般的に、個人コンピュータで行うインストレーションではライセンス アクティベーションを使用します。しかし、ソフトウェアを個別にインストールしてからライセンスをSolidNetWork License Managerでコントロールすることもできます。逆に、大規模な環境では一般的にフローティング ネットワーク ライセンスが使用されますが、アドミニストレーティブ イメージからインストレーションを展開し、シリアル番号を各コンピュータからアクティブ化することもできます。

目次

  • 個人ライセンスの管理（Administering Individual Licenses）

    個別のライセンスを指定して、マシン アクティベーションを使用できます。

  • SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）

    SolidNetWork License Managerは、ネットワーク上のクライアントにライセンスを配布することで複数のライセンス クライアントをサポートします。 フローティング ライセンスを使用することにより、ユーザー数はライセンス数を上回ることが可能になります。


個人ライセンスの管理（Administering Individual Licenses）

個別のライセンスを指定して、マシン アクティベーションを使用できます。

通常、個人ライセンスの管理は、SOLIDWORKS ソフトウェアから直接、ライセンスをアクティブ化/非アクティブ化して行います。

SOLIDWORKS スタンドアロン ライセンス (SolidNetWork ライセンスではありません) において、製品のライセンスを取得して登録するプロセスを「アクティベーション」と呼びます。 一般に製品のライセンスがアクティブ化されていない場合、SOLIDWORKS は製品の開始時にライセンスをアクティブ化しようとします。

SOLIDWORKS 2022 以降、SOLIDWORKS の永久ライセンスを購入した場合、年に 1 回ライセンスを再アクティブ化する必要があります。永久ライセンスの有効期限は切れませんが、再アクティブ化する必要があります。SOLIDWORKS でプロンプトが表示され、必要な再アクティブ化日までに永久ライセンスを再アクティブ化するように求められます。

個人ライセンスを非アクティブにするには、SOLIDWORKS で [image] > ライセンス（Licenses） > 非アクティブ化（Deactivate）をクリックします。

親トピック ライセンス管理（License Administration）
SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）

ライセンス アクティベーション（Activating a License）

SOLIDWORKS 製品を個人コンピュータで実行する前に、そのコンピュータに対するライセンスをアクティブ化する必要があります。

アクティベーションにはインターネットと電子メールへのアクセスが必要です。 アクティベーションが終了した後、製品を使用するには、オンライン上でつながっている必要はありません。 製品を使用するコンピュータに電子メールの設定がない場合は、アクティベーション ファイルを保存し、それを別のコンピュータから送信できます。

このプロセスでは次を行います:
  • SOLIDWORKS 製品全体のソフトウェア ライセンスをアクティブ化します。
  • ライセンス権を別のコンピュータへ移動します。
  • その場で実行する（推奨）ことも、インストレーション後 30日以内に実行することもできます。
  • ドングル（ハードウェア ロック）が不必要になります。 しかし、アクティベーションを利用しない、以前のバージョンの SOLIDWORKS 製品をご使用の場合は、ドングルが必要です。

複数のシリアル番号を管理するシステム管理者の場合、アドミニストレーティブ イメージ オプション エディタを使用すると良いでしょう。詳細は、アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）を参照してください。

ライセンスをアクティブ化するには:

  1. SOLIDWORKS を起動します。
  2. 以下のいずれかの方法を使用し、SOLIDWORKS 製品のアクティベーション (SOLIDWORKS Product Activation) を開始します。
    • このコンピュータのライセンスがアクティブ化されていない場合、SOLIDWORKS 製品のアクティベーション (SOLIDWORKS Product Activation) ウィンドウは SOLIDWORKS ソフトウェアの開始時に自動的に表示されます。
    • SOLIDWORKS 製品のアクティベーション（SOLIDWORKS Product Activation）ウィンドウが自動的に表示されない場合は、 [image] > ライセンス（Licenses） > アクティブ化（Activate）をクリックして、アクティブ化を開始します。
  3. 製品（Product）リストを選択し、ライセンスをアクティブ化する製品を指定します。
  4. インターネット経由の自動アクティベーションまたは電子メール使用のマニュアル アクティベーションを指定します。
  5. 電子メールの連絡先を入力します。
  6. 次へ（Next） をクリックします。
    • インターネットの場合:アクティベーションは自動的に行われます。
    • 電子メール: 保存（Save）をクリックしてリクエスト ファイルを作成し、ファイルを activation@solidworks.com まで電子メールで送信します。レスポンス ファイルを含む電子メールを受信したら、電子メールからファイルを抽出し、開く（Open）をクリックしてファイルを読み込みます。
      必要に応じて、アクティベーション手順を終了した場合でも、再実行時にレスポンス ファイルを開くことができます。
  7. 完了 をクリックします。
アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）

ライセンスの再アクティブ化

SOLIDWORKS 2022 以降の製品の商用または教育用の永久ライセンスをお持ちの場合は、年に 1 回これらのライセンスを再アクティブ化する必要があります。SOLIDWORKS 製品のアクティベーション（SOLIDWORKS Product Activation）でプロンプトが表示され、再アクティブ化の期限までに再アクティブ化するように求められます。

ライセンスを再アクティブ化するには:

  1. SOLIDWORKS を起動します。
    SOLIDWORKS 製品のアクティベーション（SOLIDWORKS Product Activation）で、再アクティブ化を求めるプロンプトが表示されます。各 SOLIDWORKS 製品ライセンスに対して、次の情報が表示されます。
    • 現在のライセンス有効期限（Activation Expires）の日付
    • 製品の使用を継続するために必要な操作（Action Required）。永久ライセンスの再アクティブ化、期間ライセンスまたは評価ライセンスの更新と再アクティブ化など。
  2. 今すぐ再アクティブ化（Reactivate Now）をクリックして、製品のアクティベーション（Product Activation）ウィザードを開始します。

    ライセンスをすぐに再アクティブ化しない場合は、後で通知（Remind Me Later）をクリックします。 たとえば、SOLIDWORKS で、 [image] > ライセンス（Licenses） > アクティブ化（Activate）をクリックして、製品のアクティベーション（Product Activation）ウィザードを開始します。 ライセンス アクティベーション（Activating a License） を参照してください。

ライセンスの移動

SolidNetwork ライセンスを新しいまたはアップグレードしたコンピュータに移動するには、まず Dassault Systèmes SolidWorks Corporation のライセンス キー サーバーからライセンスを非アクティブ化します。続いて別のコンピュータ上で再度アクティブ化します。

Dassault Systèmes SOLIDWORKS Corporation のライセンスを非アクティブにできない場合（ハード ディスク ドライブの故障など）でも、再アクティベーションはほとんどの場合に成功します。再アクティブ化できない場合は、代理店までご連絡ください。

ライセンスを移動するには:

  1. SOLIDWORKS で [image] > ライセンス（Licenses） > 非アクティブ化（Deactivate）をクリックし、指示に従います。
  2. 再アクティブ化するには、新しいまたはアップグレードしたコンピュータで初期のアクティベーションと同じようにライセンス アクティベーションを行います。 詳細については、ライセンス アクティベーションを参照してください。


SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）

SolidNetWork License Managerは、ネットワーク上のクライアントにライセンスを配布することで複数のライセンス クライアントをサポートします。 フローティング ライセンスを使用することにより、ユーザー数はライセンス数を上回ることが可能になります。

次のイメージは、SolidNetWorkライセンスのインストレーションを表しています。

このイメージは、以下を明らかにします。
  • SolidNetWork License Manager ソフトウェアは、ライセンス マネージャー コンピュータ上のみにインストールされ、アクティブ化されます。
  • ライセンス クラインアント コンピュータには、SolidNetWork特有のソフトウェアはインストールされていません。

    インストール時に SolidNetWork ライセンスのシリアル番号を指定すると、SOLIDWORKS Installation Manager はそのコンピュータを SolidNetWork ライセンス クライアントとして認識します。SOLIDWORKS Installation Manager はクライアントをライセンス マネージャーと接続するため、SolidNetWork License Manager コンピュータ名とポート番号を求めるプロンプトを表示します。

  • ライセンス マネージャーとすべてのライセンス クライアントは、TCP/IP（Transmission Control Protocol/Internet Protocol）接続を必要とします。

目次

  • SolidNetWork ライセンスのインストールの概要

    SOLIDWORKS Installation Manager を使用して SolidNetWork License Manager Server を少なくとも 1 台のコンピュータにインストールした後で、SOLIDWORKS クライアント ソフトウェアを任意のコンピュータにインストールします。その後、製品アクティベーション ウィザードを使用して、永久ライセンスおよび期間ライセンスのシリアル番号を追加および有効化できます。

  • SolidNetWork License Managerの開始（Starting the SolidNetWork License Manager）

    SolidNetWork License Manager は Windowsの スタート メニューから開始できます。

  • SolidNetWork License Managerのアップグレード（Upgrading the SolidNetWork License Manager）

    メジャー リリースの SOLIDWORKS の場合、ライセンス マネージャーをアップグレードするとき、古いライセンス マネージャーのアンインストール、新しいライセンス マネージャーのインストール、SolidNetWork ライセンスの再アクティブ化が行われます。

  • SolidNetWork ライセンスの移動

    SolidNetWork ライセンスを新しいまたはアップグレードしたコンピュータに移動するには、まずライセンスを非アクティブにして Dassault Systèmes SolidWorks Corporation のライセンス キー サーバーに戻し、続いて移動先のコンピュータ上で再度アクティブ化します。

  • SolidNetWork ライセンス ファイルの削除

    有効期限の切れた SolidNetWork ライセンス ファイルを、新しいライセンス ファイルにアップグレードする前に削除できます。

  • SolidNetWorkライセンスの借入と返却（Borrowing and Returning SolidNetWork Licenses）

    SolidNetWorkライセンスを借り、リモート位置からソフトウェアを使用することができます。ライセンスは使用可能なライセンスのプールから取り除かれるため、借りたライセンスを再び使用可能にするにはこれを戻す必要があります。

  • SOLIDWORKS の各種バージョンへのアクセスの管理

    SolidNetWork 環境で特定のバージョンの SOLIDWORKS を使用しないように制限できます。 この機能を使用して、さまざまなユーザー、プロジェクト、部門で使用される SOLIDWORKS のバージョンを管理できます。

  • ライセンスのアイドル状態の監視（Monitoring License Idle Time）

    SOLIDWORKS は SolidNetWork License Manager のアイドル状態を記録し、一定時間使用されていないライセンスをフリーのライセンス プールに戻すことができます。

  • 一時ライセンスを使用する

    一時的な「Any」ライセンスは、SolidNetWork ライセンスが使用できない場合に使用できます。

  • SolidNetWorkライセンスとアドイン製品の使用（Using SolidNetWork Licenses with Add-in Products）

    SolidNetWork License Manager を使用し、SOLIDWORKS コア アドイン製品のライセンスを配布できます。

  • SolidNetWork License での SOLIDWORKS Simulation ライセンスの選択

    SolidNetWork ライセンス ユーザーは、SOLIDWORKS Simulation に追加するときに、ライセンス プールにあるどの SOLIDWORKS® Simulation ライセンスを使用するかを制御できます。 また、より詳細なスタディには、より高いライセンス タイプが必要な場合に備えて、アドインをアンロードせずに SOLIDWORKS Simulation ライセンスをアップグレードすることもできます。

  • Flow Simulation モジュールのロード

    SolidNetWork ライセンスをお持ちのお客様は、2 つの方法を使用して、Flow Simulation の HVAC アドイン モジュールおよび Electronics Cooling アドイン モジュールをロードする方法を制御できます。

  • SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation、SOLIDWORKS Plastics の非アクティブ状態のタイムアウト

    SOLIDWORKS Simulation、Plastics、または Flow Simulation スタディを実行すると、ネットワーク ライセンスはアクティブなままになり、タイムアウトしません。計算プロセス中、SOLIDWORKS はライセンスを保持します。これはアクティブな状態と見なされます。

  • ライセンス マネージャーとアドミニストレーティブ イメージ インストレーションに向けた同じコンピュータの使用（Using the Same Computer for the License Manager and Administrative Image Installations）

    ネットワーク上の 1 台のコンピュータが SolidNetWork ライセンスを配布するライセンス マネージャー、およびユーザーがそこから SOLIDWORKS ソフトウェアをインストールできるアドミニストレーティブ イメージの位置として両方の機能を果たすように設定することも可能です。

  • SolidNetWork ライセンス マネージャーのアンインストール（Uninstalling the SolidNetWork License Manager）

    SolidNetWork License Managerのアップグレードを行うには、新しいライセンス マネージャーをインストールする前に古いライセンス マネージャーをアンインストールする必要があります。

  • FlexNet Publisher ライセンス管理（FlexNet Publisher License Management）

    SOLIDWORKS ライセンスは、FlexNet Publisher® ライセンス管理に基づいています。

親トピック ライセンス管理（License Administration）
個人ライセンスの管理（Administering Individual Licenses）


SolidNetWork ライセンスのインストールの概要

SOLIDWORKS Installation Manager を使用して SolidNetWork License Manager Server を少なくとも 1 台のコンピュータにインストールした後で、SOLIDWORKS クライアント ソフトウェアを任意のコンピュータにインストールします。その後、製品アクティベーション ウィザードを使用して、永久ライセンスおよび期間ライセンスのシリアル番号を追加および有効化できます。

SOLIDWORKS クライアント ソフトウェアをコンピュータにインストールするとき、SolidNetWork ライセンス シリアル番号を指定します。SOLIDWORKS Installation Manager はそのコンピュータを SolidNetWork ライセンス クライアントとして識別し、SolidNetWork License Manager Server のコンピュータ名とポート番号を入力するよう求めます。SolidNetWork License Manager Server がインストールされていない場合や名前またはポート番号が正しくない場合は、エラーが表示されます。

アクティベーション プロセス

ユーザーが SOLIDWORKS 製品を各自の個人コンピュータで実行する前に、SolidNetWork License Manager Server コンピュータで SolidNetWork ライセンスをアクティブ化する必要があります。

アクティベーションにはアクティブなインターネット接続または電子メールへのアクセスが必要です。アクティベーションが終了した後、製品を使用するには、オンライン上でつながっている必要はありません。製品を使用するコンピュータに電子メールの設定がない場合は、アクティベーション ファイルを保存し、それを別のコンピュータから送信できます。

このプロセスでは次を行います:
  • SOLIDWORKS 製品全体の SolidNetWork ライセンスと共に SOLIDWORKS SolidNetWork License Manager をアクティブ化します。
  • ある SolidNetWork License Manager コンピュータから別の SolidNetWork License Manager コンピュータへ SolidNetWork ライセンス権限を移動できます。
  • 1台のSolidNetWork License ManagerコンピュータにSolidNetWorkライセンス権限をインストールしてアクティブ化できるようにします。
  • SolidNetWorkライセンスを使用する前に、実行する必要があります。
  • ドングル（ハードウェア ロック）が不必要になります。このバージョンの SOLIDWORKS の SolidNetWork ライセンスをアクティブ化すると、前のバージョンの SOLIDWORKS の SolidNetWork ライセンスもアクティブ化されますドングルを保持する必要はなくなります。

目次

  • SolidNetWork License Manager Server のインストール

    SolidNetWork License Manager Server は、複数のラインセンス クライアントをサポートします。また、ネットワーク上のクライアント コンピュータにライセンスを配布します。

  • SolidNetWork ライセンスのアクティブ化

    ユーザーが SOLIDWORKS 製品を各自の個人コンピュータで実行する前に、SolidNetWork License Manager コンピュータで SolidNetWork ライセンスをアクティブ化する必要があります。

  • SolidNetWork License Manager Server での手動アクティベーション

    SolidNetWork License Manager Server をインストールまたはアップグレードするとき、ライセンスをアクティブ化または再アクティブ化する必要があります。ライセンスのアクティブ化や再アクティブ化は、インターネット経由でできますが、手動で行うことも選択できます。

  • SolidNetWork ライセンス クライアントのインストール

  • SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）

    コンピュータでファイアウォールを使用している場合は、SolidNetWork ライセンスをサポートするようにポートを構成する必要があります。

  • SolidNetWork ライセンスの再アクティブ化

    SolidNetwork License Manager Server をバージョン 2022 以降にアップグレードすると、SolidNetWork License 製品に再アクティブ化が適用されます。インストールされている製品が以前のリリースによる場合も、サーバー上のバージョン 2022 以降のライセンスは、年に 1 回再アクティブ化が必要です。

  • トライアド ライセンス マネージャーのインストレーション（Triad License Manager Installation）

    トライアド ライセンス マネージャーは安定性のために3台のコンピュータを使用します。ライセンス ファイルを管理しているコンピュータが使用できなくなった場合も、残りの2台のコンピュータの内の1台で処理できます。

親トピック SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）
SolidNetWork License Managerの開始（Starting the SolidNetWork License Manager）
SolidNetWork License Managerのアップグレード（Upgrading the SolidNetWork License Manager）
SolidNetWork ライセンスの移動
SolidNetWork ライセンス ファイルの削除
SolidNetWorkライセンスの借入と返却（Borrowing and Returning SolidNetWork Licenses）
SOLIDWORKS の各種バージョンへのアクセスの管理
ライセンスのアイドル状態の監視（Monitoring License Idle Time）
一時ライセンスを使用する
SolidNetWorkライセンスとアドイン製品の使用（Using SolidNetWork Licenses with Add-in Products）
SolidNetWork License での SOLIDWORKS Simulation ライセンスの選択
Flow Simulation モジュールのロード
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation、SOLIDWORKS Plastics の非アクティブ状態のタイムアウト
ライセンス マネージャーとアドミニストレーティブ イメージ インストレーションに向けた同じコンピュータの使用（Using the Same Computer for the License Manager and Administrative Image Installations）
SolidNetWork ライセンス マネージャーのアンインストール（Uninstalling the SolidNetWork License Manager）
FlexNet Publisher ライセンス管理（FlexNet Publisher License Management）


SolidNetWork License Manager Server のインストール

SolidNetWork License Manager Server は、複数のラインセンス クライアントをサポートします。また、ネットワーク上のクライアント コンピュータにライセンスを配布します。

ライセンスのアクティベーションにハードウェア ドングルを使用した以前のバージョンの SolidNetWork License Manager Server をアップグレードする場合、新しいバージョンの SolidNetWork License Manager Server をインストールする前にハードウェア ドングルを取り外してください。

  1. インストール メディアをダウンロード（Download Installation Media）の説明に従って、SOLIDWORKS Installation Manager を起動します。
  2. インストールのタイプについては、サーバー コンポーネントをインストール（Install server components）を選択して SolidNetWork License Manager（配布ライセンス）をこのコンピュータにインストールします。（Install SolidNetWork License Manager (distributed licensing) on this computer）をクリックします。
  3. 概要（Summary）ページで、インストール場所とバックグラウンド ダウンローダーを確認し、ライセンス条項に同意して、今すぐインストール（Install Now）をクリックします。
  4. SolidNetWork License Manager Server の SOLIDWORKS 製品アクティベーション ウィザードで、シリアル番号を追加して、少なくとも 1 つのライセンスをアクティブ化します。シリアル番号を追加して SolidNetWork Licenses をアクティブ化する（Adding Serial Numbers and Activating SolidNetWork Licenses）を参照してください。
親トピック SolidNetWork ライセンスのインストールの概要
SolidNetWork ライセンスのアクティブ化
SolidNetWork License Manager Server での手動アクティベーション
SolidNetWork ライセンス クライアントのインストール
SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）
SolidNetWork ライセンスの再アクティブ化
トライアド ライセンス マネージャーのインストレーション（Triad License Manager Installation）


SolidNetWork ライセンスのアクティブ化

ユーザーが SOLIDWORKS 製品を各自の個人コンピュータで実行する前に、SolidNetWork License Manager コンピュータで SolidNetWork ライセンスをアクティブ化する必要があります。

SolidNetWorkライセンスをアクティブ化するには、以下を行います。

  1. スタート（Start） > SOLIDWORKS ツール（SOLIDWORKS Tools）バージョン > SolidNetWork License Manager Serverバージョンをクリックして、SolidNetWork License Manager を起動します。
  2. オプション: まだ SolidNetWork ライセンスをアクティブ化していない場合は、ライセンスをアクティブ化するよう求めるメッセージが表示されます。はい(Yes)をクリックします。
    これにより、SOLIDWORKS 製品のアクティベーション（SOLIDWORKS Product Activation）ウィザードが開始されます。
  3. オプション: ファイアウォールが機能している場合は、このサーバーのファイアウォールは使用中です（A firewall is in use on this server）を選択します。
  4. SolidNetWork License Server 情報（SolidNetWork License Server Information）ページにポート番号を入力し、次へ（Next）をクリックします。
  5. シリアル番号:（Serial #:）で特定のシリアル番号を選択するか、すべて選択（Select All）をクリックして、すべての SOLIDWORKS シリアル番号をハイライト表示し、アクティブ化します。
    1. インターネットを自動的に使用（推奨）（Automatically over the internet (recommended)）をアクティブ化するオプションを選択します。
    2. 連絡情報（Contact Information）で電子メール アドレスを入力します。
    アクティベーション/再アクティベーションの成功（Activation/Reactivation Succeeded）ダイアログ ボックスにアクティブ化された製品の名前が表示されます。
  6. 完了（Finish）をクリックします。
親トピック SolidNetWork ライセンスのインストールの概要
SolidNetWork License Manager Server のインストール
SolidNetWork License Manager Server での手動アクティベーション
SolidNetWork ライセンス クライアントのインストール
SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）
SolidNetWork ライセンスの再アクティブ化
トライアド ライセンス マネージャーのインストレーション（Triad License Manager Installation）


SolidNetWork License Manager Server での手動アクティベーション

SolidNetWork License Manager Server をインストールまたはアップグレードするとき、ライセンスをアクティブ化または再アクティブ化する必要があります。ライセンスのアクティブ化や再アクティブ化は、インターネット経由でできますが、手動で行うことも選択できます。

手動でアクティブ化する場合:
  • 新しい SolidNetWork License Manager Server では、サーバーを正しく設定するために 2 度アクティブ化する必要があります。最初にアクティブ化すると、サーバー上のライセンス システムが初期化されます。この手順を 2 回目に繰り返すと、ライセンスはアクティブ化されます。
  • アップグレードされた SolidNetWork License Manager Server の場合は、既存のライセンスを再アクティブ化する必要があります。サーバーにアクティブ化されたライセンスがない場合は、代わりにサーバー アドミニストレーション タブの変更（Modify）を使用してアクティブ化を実行します。
親トピック SolidNetWork ライセンスのインストールの概要
SolidNetWork License Manager Server のインストール
SolidNetWork ライセンスのアクティブ化
SolidNetWork ライセンス クライアントのインストール
SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）
SolidNetWork ライセンスの再アクティブ化
トライアド ライセンス マネージャーのインストレーション（Triad License Manager Installation）


SolidNetWork ライセンス クライアントのインストール

SOLIDWORKS CAD ソフトウェアをコンピュータにインストールするとき、SolidNetWork ライセンスのシリアル番号を指定します。SOLIDWORKS Installation Manager はそのコンピュータを SolidNetWork ライセンス クライアントとして識別し、SolidNetWork License Manager のコンピュータ名と番号を入力するよう求めます。SolidNetWork License Manager Server がインストールされていない場合や名前またはポート番号が正しくない場合に、エラーが表示されます。

SolidNetWork ライセンスを使用して SOLIDWORKS をインストールするには:

  1. インストール メディアをダウンロード（Download Installation Media）の説明に従って、SOLIDWORKS Installation Manager を起動します。
  2. このメジャー リリースの SOLIDWORKS をこのコンピュータに今回初めてインストールする場合は、ようこそ（Welcome）ページでこのコンピュータにインストール（Install on this computer）をクリックします。
    既存のリリースからアップグレードして個人ライセンスから SolidNetWork ライセンスに変更する場合は、個人インストレーションの変更（このコンピュータ上で実行します）をクリックします。 詳細は、個人ライセンスからSolidNetWorkライセンスへのアップグレード（Upgrading from Individual Licensing to SolidNetWork Licensing） を参照してください。
  3. サーバーの追加（Add Server）ダイアログ ボックスで、SolidNetWork License Manager のアドレスを次の形式で入力します。

    port@ComputerName

    ポート番号は、ライセンス マネージャー コンピュータで使用している番号と同じでなければなりません。デフォルトは 25734 です。

    SOLIDWORKS Installation Manager は、この SolidNetWork License Manager がアクセス可能であることを検証しようとします。まだライセンス マネージャーをインストールしていない場合、この検証には失敗します。しかし、それでもライセンス クライアントのインストレーションは続行できます。
  4. SOLIDWORKS Installation Manager の指示に従い、SOLIDWORKS のインストレーションを完了します。
親トピック SolidNetWork ライセンスのインストールの概要
SolidNetWork License Manager Server のインストール
SolidNetWork ライセンスのアクティブ化
SolidNetWork License Manager Server での手動アクティベーション
SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）
SolidNetWork ライセンスの再アクティブ化
トライアド ライセンス マネージャーのインストレーション（Triad License Manager Installation）


SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）

コンピュータでファイアウォールを使用している場合は、SolidNetWork ライセンスをサポートするようにポートを構成する必要があります。

ファイアウォール ソフトウェアで、2 つの SolidNetWork ライセンス ポート（SNL-in-port と SNL-out-port など）をファイアウォールの例外リストに追加する必要があります。これらのポートを構成する方法の詳細については、システム管理者に相談してください。

サポートされている Windows オペレーティング システムで Windows ファイアウォールを使用している場合、SolidNetWork License Manager コンピュータ上でポートを変更し、SolidNetWork ライセンス ファイルを変更して、ライセンスをライセンス クライアント コンピュータに配布する必要があります。

Windowsファイアウォールのためのライセンス マネージャー コンピュータの変更（Modifying License Manager Computer Ports for Windows Firewall）

  1. スタート（Start）をクリックし、Windows セキュリティ（Windows Security）を開きます。
  2. ファイアウォールとネットワーク保護（Firewall & network protection） > 詳細設定（Advanced Settings）を選択し、はい（Yes）をクリックして変更を確定します。
  3. セキュリティが強化された Windows Defender ファイアウォール（Windows Defender Firewall with Advanced Security）ダイアログ ボックスで、受信の規則（Inbound Rules） > 新しい規則（New Rule）を選択します。
  4. 新規の受信の規則ウィザード（New Inbound Rule Wizard）で、規則の種類にポート（Port）を選択し、次へ（Next）をクリックします。
  5. 特定のローカル ポート:（Specific local ports:）にポート番号を入力します（たとえば、80, 25734, 443）を入力し、次へ（Next）をクリックします。
  6. 名前（Name）を選択します。名前（Name）を入力します（たとえば、SNL-in-port）。
  7. 完了（Finish）をクリックします。

WindowsファイアウォールのためのSolidNetWork License Manager設定の変更（Modifying SolidNetWork License Manager Settings for Windows Firewall）

  1. スタート（Start） > SOLIDWORKS ツール（SOLIDWORKS Tools）バージョン > SolidNetWork License Manager Server バージョンをクリックして、SolidNetWork License Manager を起動します。
  2. サーバー アドミニストレーション（Server Administration）タブのランセンス サーバー（License Server）で停止（Stop）をクリックします。はい（Yes）をクリックして確定し、OK をクリックしてライセンス サーバーを停止します。
  3. ライセンス情報（License Information）で 変更（Modify）をクリックします。
  4. サーバー タイプ（Server Type）でネットワークのサーバー配置（単一（Single）または 3 サーバー（Triad））を選択してから、次へ（Next）をクリックします。
  5. サーバー情報（Server Information）で以下を行います:
    1. このサーバーのファイアウォールは使用中です（A firewall is in use on this server）を選択します。
    2. ポート番号とベンダー デーモン ポート番号は、Windows ファイアウォール用に指定したポート番号を含む必要があります（詳細については、上記の手順を参照してください）。
    3. オプション ファイル（Options File）を選択し、参照（Browse）をクリックしてファイルを見つけます。編集（Edit）をクリックして、任意のパラメータを変更します。
    オプション ファイルを使用すると、ライセンス管理者は FlexNet ライセンスのさまざまな操作パラメータを制御できます。

    推奨事項：オプション ファイルは、SolidNetWork License Manager のインストレーション ディレクトリに配置します（SolidNetWork_License_Manager_install_dir\Licenses \sw_d.opt）。このファイルは、sw_d.lic ファイルと同じディレクトリに置く必要があります。

    オプション ファイルの詳細については、SolidNetWork License Manager インストレーション ディレクトリにある FlexNet Publisher License Administration Guide（ ）を参照してください。

    C:\Program Files\SOLIDWORKS SolidNetWork License Manager\Docs\flexuser\fnp_LicAdmin.pdf

親トピック SolidNetWork ライセンスのインストールの概要
SolidNetWork License Manager Server のインストール
SolidNetWork ライセンスのアクティブ化
SolidNetWork License Manager Server での手動アクティベーション
SolidNetWork ライセンス クライアントのインストール
SolidNetWork ライセンスの再アクティブ化
トライアド ライセンス マネージャーのインストレーション（Triad License Manager Installation）


SolidNetWork ライセンスの再アクティブ化

SolidNetwork License Manager Server をバージョン 2022 以降にアップグレードすると、SolidNetWork License 製品に再アクティブ化が適用されます。インストールされている製品が以前のリリースによる場合も、サーバー上のバージョン 2022 以降のライセンスは、年に 1 回再アクティブ化が必要です。

再アクティブ化の期限前 30 日以内になると、ネットワーク上の SOLIDWORKS 製品は、ライセンスの有効期限が切れることをユーザーに通知します。 管理者は、ライセンスを期限内に再アクティブ化するため有効期限を認識する必要があります。

SolidNetWork ライセンスを再アクティブ化するには:

  1. スタート（Start） > SOLIDWORKS ツール（SOLIDWORKS Tools）バージョン > SolidNetWork License Manager Server バージョンをクリックして、SolidNetWork License Manager Server を起動します。
  2. サーバー アドミニストレーション（Server Administration）タブで、ライセンス情報（License Information）の下にある再アクティブ化（Reactivate）をクリックします。

  3. シリアル（Serial）で、すべて（All）を選択してすべてのライセンスを表示するか、ライセンス番号を入力して特定のライセンスを検索します。

    ライセンスを再アクティブ化（Reactivate Licences）ダイアログ ボックスでは、30 日以内のライセンスの有効期限日と再アクティベーション日がすべて赤でハイライト表示されます。アスタリスクのマークが付くのは、更新が必要なライセンスです。

  4. 再アクティブ化（Reactivate）をクリックします。
親トピック SolidNetWork ライセンスのインストールの概要
SolidNetWork License Manager Server のインストール
SolidNetWork ライセンスのアクティブ化
SolidNetWork License Manager Server での手動アクティベーション
SolidNetWork ライセンス クライアントのインストール
SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）
トライアド ライセンス マネージャーのインストレーション（Triad License Manager Installation）


トライアド ライセンス マネージャーのインストレーション（Triad License Manager Installation）

トライアド ライセンス マネージャーは安定性のために3台のコンピュータを使用します。ライセンス ファイルを管理しているコンピュータが使用できなくなった場合も、残りの2台のコンピュータの内の1台で処理できます。

トライアド ライセンス マネージャーの使用条件は、以下のとおりです。
  • トライアド ライセンス マネージャーは、頻繁に再起動、またはシャットダウンがスケジュールされたコンピュータではなく、安定したコンピュータのみにインストールしてください。
  • トライアド ライセンス マネージャー コンピュータは同一のサブネット上になければなりません。トライアド ライセンス マネージャーは、通信状態の悪い状態、またはダイアルアップ リンクで構成しないでください。
  • ライセンス マネージャー コンピュータがダウンした場合、システム管理者が早急に検知でき、再起動できる状態になければなりません。
    2台のライセンス マネージャー コンピュータのみが実行されている場合、2台のコンピュータ共に問題があることになるため、ライセンス マネージャー コンピュータが1台のみの場合よりも好ましくない状況にあるといえます。

目次

  • 最初のトライアド ライセンス マネージャーのインストール（Installing the Initial Triad License Manager）

    この手順では、トライアドの最初のコンピュータに SolidNetWork License Manager をインストールする方法について説明します。

  • 残りのコンピュータのトライアド ライセンス マネージャーのインストール（Installing the Triad License Manager on Subsequent Computers）

    次の手順に従って、トライアドの 2 台目と 3 台目のコンピュータに SolidNetWork License Manager をインストールします。 この手順は、ステップ 2（f）と 2（i）以外は、このソフトウェアを最初のコンピュータにインストールする手順とほぼ同じです。

親トピック SolidNetWork ライセンスのインストールの概要
SolidNetWork License Manager Server のインストール
SolidNetWork ライセンスのアクティブ化
SolidNetWork License Manager Server での手動アクティベーション
SolidNetWork ライセンス クライアントのインストール
SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）
SolidNetWork ライセンスの再アクティブ化


最初のトライアド ライセンス マネージャーのインストール（Installing the Initial Triad License Manager）

この手順では、トライアドの最初のコンピュータに SolidNetWork License Manager をインストールする方法について説明します。

  1. 最初のトライアド ライセンス マネージャー コンピュータで、SOLIDWORKS Installation Manager を使用して SolidNetWork License Manager をインストールします。
    1. インストール メディアをダウンロード（Download Installation Media）の説明に従って、SOLIDWORKS Installation Manager を起動します。
    2. インストールのタイプについては、サーバー コンポーネントのインストール（Install server components）を選択して SolidNetWork License Manager（配布ライセンス）をこのコンピュータにインストール（Install SolidNetWork License Manager (distributed licensing) on this computer）をクリックします。
    3. サマリー（Summary）ページで、SolidNetWork License Manager のインストレーション先（Installation Location）、ダウンロード オプション（Download Options）を確認して、今すぐインストール（Install Now）をクリックし SOLIDWORKS Installation Manager のプロセスを完了します。
  2. SolidNetWork License Managerを使用し、最初のトライアド ライセンス マネージャー コンピュータを設定します。
    1. SolidNetWork License Managerを開始します。スタート（Start） > SOLIDWORKS ツール（SOLIDWORKS Tools）version > SolidNetWork License Manager Server version をクリックします。

      このコンピュータでSolidNetWork License Managerを実行するのは今回が初めてであるため、今すぐアクティブ化するかどうかを確認するプロンプトが表示されます。

    2. いいえ（No）をクリックします。

      SOLIDWORKS SolidNetWork License Manager のサーバー アドミニストレーション タブが表示されます。

    3. サーバー アドミニストレーション（Server Administration）タブの詳細設定オプション（Advanced Options）で、オプション（Options）をクリックします。
    4. SolidNetWork Server ライセンス モードで ライセンス ファイル使用 （Use a License File）をクリックし、OK をクリックします。
    5. ライセンス情報 （License Information）で 変更 （Modify）をクリックします。
      SolidNetWorkライセンス ファイル ウィザードが表示されます。
    6. サーバー タイプ （Server Type）で 3サーバー （Triad）を選択し、次へ （Next）をクリックします。
    7. サーバー情報パネルで最初のトライアド ライセンス マネージャー コンピュータのコンピュータ名、ポート番号が正しいことを確認し、次へ（Next）をクリックします。

      ネットワーク インターフェース カード（NIC）アドレスが SOLIDWORKS から受け取ったライセンス ファイルの情報と一致することと、トライアド ライセンス マネージャー コンピュータのポート番号が正しいことを確認します。 NIC アドレスは、MAC (Media Access Control Address) アドレスとも呼ばれます。 続いて、次へ (Next) をクリックしします。

      NIC アドレスを調べるには、コマンド プロンプト ウィンドウを開いて次のように入力します:

      ipconfig /all

      また、コンピュータでファイアウォールを使用している場合は、この画面で仕様を追加することが必要な場合があります。詳細は、SolidNetWork ライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）を参照してください。

    8. トライアド パートナー サーバー情報（Triad Partner Server Information） 画面で、他の 2 台のトライアド ライセンス マネージャー コンピュータのコンピュータ名とホスト ID の値を入力し、次へ（Next）をクリックします。
      これで、1 台のトライアド ライセンス マネージャーが使用できなくなった場合でも、クライアント コンピュータは残りの 2 台のサーバーからライセンスを取得できます。
    9. ライセンス （Licenses）画面で 読み取り （Read）をクリックし、SolidNetWork ライセンス ファイルまで参照し、これを開きます。
      SolidNetWork License File Wizard にライセンスが表示されます。このコンピュータに対しては、代理店もしくは Dassault Systèmes の SOLIDWORKS カスタマー サポートから受け取ったライセンス ファイルを使用します。
    10. 完了（Finish）をクリックします。
    11. OK をクリックして終了し、完了（Finish）をクリックして SolidNetWork License Manager を閉じます。
親トピック トライアド ライセンス マネージャーのインストレーション（Triad License Manager Installation）
残りのコンピュータのトライアド ライセンス マネージャーのインストール（Installing the Triad License Manager on Subsequent Computers）
SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）


残りのコンピュータのトライアド ライセンス マネージャーのインストール（Installing the Triad License Manager on Subsequent Computers）

次の手順に従って、トライアドの 2 台目と 3 台目のコンピュータに SolidNetWork License Manager をインストールします。 この手順は、ステップ 2（f）と 2（i）以外は、このソフトウェアを最初のコンピュータにインストールする手順とほぼ同じです。

既に別のコンピュータに少なくとも1つのトライアド ライセンス マネージャーがインストールされていることを前提とします。

  1. トライアド ライセンス マネージャー コンピュータに、SOLIDWORKS Installation Manager を使用して SolidNetWork License Manager をインストールします。
    1. インストール メディアをダウンロード（Download Installation Media）の説明に従って、SOLIDWORKS Installation Manager を起動します。
    2. インストールのタイプについては、サーバー コンポーネントをインストール（Install server components）を選択して、SolidNetWork License Manager（配布ライセンス）をこのコンピュータにインストールします（Install SolidNetWork License Manager (distributed licensing) on this computer）をクリックします。
    3. サマリー（Summary）ページで、SolidNetWork License Manager のインストレーション先（Installation Location）、ダウンロード オプション（Download Options）を確認して、今すぐインストール（Install Now）をクリックして SOLIDWORKS Installation Manager のプロセスを完了します。
  2. SolidNetWork License Managerを使用し、トライアド ライセンス マネージャー コンピュータを設定します。
    1. SolidNetWork License Managerを開始します。スタート（Start） > SOLIDWORKS ツール（SOLIDWORKS Tools）version > SolidNetWork License Manager Server version をクリックします。
      このコンピュータでSolidNetWork License Managerを実行するのは今回が初めてであるため、今すぐアクティブ化するかどうかを確認するプロンプトが表示されます。
    2. いいえ（No）をクリックします。
      SOLIDWORKS SolidNetWork License Manager のサーバー アドミニストレーション タブが表示されます。
    3. 詳細設定オプション で オプション をクリックします。
      詳細設定オプション（Advanced Options） ダイアログ ボックスが表示されます。
    4. SolidNetWork Server ライセンス モードで ライセンス ファイル使用 （Use a License File）をクリックし、OK をクリックします。
      詳細設定オプション（Advanced Options） ダイアログ ボックスが閉じます。
    5. ライセンス情報 （License Information）で 変更 （Modify）をクリックします。
      SolidNetWorkライセンス ファイル ウィザードが表示されます。
    6. サーバー タイプ （Server Type）で 3サーバー （Triad）と 同期サーバー/ライセンス情報 （Synchronize server/license information）を選択してから、次へ （Next）をクリックします。
    7. トライアド サーバー情報（Triad Server Information）画面で、コンピュータ名とホスト ID の値を入力します。続いて、次へ (Next) をクリックしします。
      この方法では、1 台のライセンス マネージャーが使用できなくなった場合でも、クライアント コンピュータは残りの 2 台のサーバーからライセンスを取得できます。
    8. ライセンス （Licenses）画面で 読み取り （Read）をクリックし、SolidNetWork ライセンス ファイルまで参照し、これを開きます。
      SolidNetWork ライセンス ファイル ウィザードにライセンスが表示されます。
    ライセンス ファイルは、構成した最初のトライアド ライセンス マネージャー コンピュータで生成されます。通常、ライセンス ファイルは \licenses\sw_d.lic にあります。例: C:\Program Files\SOLIDWORKS SolidNetWork License Manager\licenses\sw_d.lic
    1. 完了（Finish）をクリックします。
      SolidNetWorkライセンス ファイル ウィザードの警告が表示されます。
    2. OK をクリックし SolidNetWorkライセンス ファイル ウィザード （SolidNetWork License File wizard）を終了してから、終了 （Finish）をクリックして SolidNetWork License Manager を終了します。

3 台目のトライアド ライセンス マネージャー コンピュータに対しても、このプロセスを繰り返します。

親トピック トライアド ライセンス マネージャーのインストレーション（Triad License Manager Installation）
最初のトライアド ライセンス マネージャーのインストール（Installing the Initial Triad License Manager）


SolidNetWork License Managerの開始（Starting the SolidNetWork License Manager）

SolidNetWork License Manager は Windowsの スタート メニューから開始できます。

Windows で、スタート（Start） > SOLIDWORKS ツール（SOLIDWORKS Tools）バージョン > SolidNetWork License Manager Server バージョンをクリックします。

Windows のスタート（Start）メニューから同じパスを使用して SolidNetWork License Manager Client バージョンを開くことができます。

親トピック SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）
SolidNetWork ライセンスのインストールの概要
SolidNetWork License Managerのアップグレード（Upgrading the SolidNetWork License Manager）
SolidNetWork ライセンスの移動
SolidNetWork ライセンス ファイルの削除
SolidNetWorkライセンスの借入と返却（Borrowing and Returning SolidNetWork Licenses）
SOLIDWORKS の各種バージョンへのアクセスの管理
ライセンスのアイドル状態の監視（Monitoring License Idle Time）
一時ライセンスを使用する
SolidNetWorkライセンスとアドイン製品の使用（Using SolidNetWork Licenses with Add-in Products）
SolidNetWork License での SOLIDWORKS Simulation ライセンスの選択
Flow Simulation モジュールのロード
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation、SOLIDWORKS Plastics の非アクティブ状態のタイムアウト
ライセンス マネージャーとアドミニストレーティブ イメージ インストレーションに向けた同じコンピュータの使用（Using the Same Computer for the License Manager and Administrative Image Installations）
SolidNetWork ライセンス マネージャーのアンインストール（Uninstalling the SolidNetWork License Manager）
FlexNet Publisher ライセンス管理（FlexNet Publisher License Management）


SolidNetWork License Managerのアップグレード（Upgrading the SolidNetWork License Manager）

メジャー リリースの SOLIDWORKS の場合、ライセンス マネージャーをアップグレードするとき、古いライセンス マネージャーのアンインストール、新しいライセンス マネージャーのインストール、SolidNetWork ライセンスの再アクティブ化が行われます。

新しいリリース用のライセンス マネージャーは、以前のリリースを保持しているクライアント コンピュータのライセンスも配布できます。

  1. スタート（Start） > SOLIDWORKS ツール（SOLIDWORKS Tools）バージョン > SolidNetWork License Manager Server バージョンをクリックして、SolidNetWork License Manager を起動します。
  2. ライセンスの使用状況（License Usage）タブで、SOLIDWORKS を実行しているクライアント コンピュータがネットワーク上にないことを確認します。
  3. 古いライセンス マネージャーをアンインストールします。詳細は、SolidNetWork ライセンス マネージャーのアンインストール（Uninstalling the SolidNetWork License Manager）を参照してください。
  4. 新しいライセンス マネージャーをインストールし、ライセンス マネージャー コンピュータで SolidNetWork ライセンスを再アクティブ化します。詳細は、SolidNetWork License Manager Server のインストールを参照してください。

SOLIDWORKS アプリケーションを同時に実行しているコンピュータで SolidNetWork License Manager をアップグレードする場合は、そのコンピュータに SOLIDWORKS アプリケーションの新しいサービス パックをインストールする前に SolidNetWork License Manager とクライアントをアップグレードします。

アドミニストレーティブ イメージをホストするコンピュータでライセンス マネージャーをアップグレードする場合は、アドミニストレーティブ イメージをアップグレードする前にライセンス マネージャーをアップグレードします。 詳細は、ライセンス マネージャーとアドミニストレーティブ イメージ インストレーションに向けた同じコンピュータの使用（Using the Same Computer for the License Manager and Administrative Image Installations）を参照してください。

親トピック SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）
SolidNetWork ライセンスのインストールの概要
SolidNetWork License Managerの開始（Starting the SolidNetWork License Manager）
SolidNetWork ライセンスの移動
SolidNetWork ライセンス ファイルの削除
SolidNetWorkライセンスの借入と返却（Borrowing and Returning SolidNetWork Licenses）
SOLIDWORKS の各種バージョンへのアクセスの管理
ライセンスのアイドル状態の監視（Monitoring License Idle Time）
一時ライセンスを使用する
SolidNetWorkライセンスとアドイン製品の使用（Using SolidNetWork Licenses with Add-in Products）
SolidNetWork License での SOLIDWORKS Simulation ライセンスの選択
Flow Simulation モジュールのロード
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation、SOLIDWORKS Plastics の非アクティブ状態のタイムアウト
ライセンス マネージャーとアドミニストレーティブ イメージ インストレーションに向けた同じコンピュータの使用（Using the Same Computer for the License Manager and Administrative Image Installations）
SolidNetWork ライセンス マネージャーのアンインストール（Uninstalling the SolidNetWork License Manager）
FlexNet Publisher ライセンス管理（FlexNet Publisher License Management）


SolidNetWork ライセンスの移動

SolidNetWork ライセンスを新しいまたはアップグレードしたコンピュータに移動するには、まずライセンスを非アクティブにして Dassault Systèmes SolidWorks Corporation のライセンス キー サーバーに戻し、続いて移動先のコンピュータ上で再度アクティブ化します。

ライセンスを非アクティブにして Dassault Systèmes SOLIDWORKS Corporation に戻せない場合（ハード ディスク ドライブの故障など）でも、再アクティベーションはほとんどの場合に成功します。再アクティブ化できない場合は、代理店までご連絡ください。

SolidNetWork ライセンスを移動するには:

  1. スタート（Start） > SOLIDWORKS ツール（SOLIDWORKS Tools）バージョン > SolidNetWork License Manager Server バージョンをクリックして、SolidNetWork License Manager Server を起動します。
  2. サーバー アドミニストレーション（Server Administration）タブで、ライセンス情報（License Information）の下にある変更（Modify）をクリックします。SOLIDWORKS 製品のアクティベーション（SOLIDWORKS Product Activation）ウィザードが開始されます。
  3. 何を行いますか?（What would you like to do?）で、製品ライセンスを新しい/アップグレードしたコンピュータに移動（Move your product license(s) to a new/upgraded computer）を選択してから、次へ（Next）をクリックします。
  4. シリアル番号:（Serial #:）リストでシリアル番号を選択するか、すべての SOLIDWORKS シリアル番号をアクティブ化する場合はすべて選択（Select All）をクリックします。
    1. インターネットを自動的に使用（推奨）（Automatically over the internet (recommended)）オプションを選択します。
    2. 連絡情報（必須）:（Contact Information (Required):）で電子メール アドレスを指定します。
  5. 非アクティブ化に成功しました（Deactivation Succeeded）メッセージ ボックスが表示されます。
    製品ライセンスが非アクティブになります。
  6. 完了（Finish）をクリックします。
親トピック SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）
SolidNetWork ライセンスのインストールの概要
SolidNetWork License Managerの開始（Starting the SolidNetWork License Manager）
SolidNetWork License Managerのアップグレード（Upgrading the SolidNetWork License Manager）
SolidNetWork ライセンス ファイルの削除
SolidNetWorkライセンスの借入と返却（Borrowing and Returning SolidNetWork Licenses）
SOLIDWORKS の各種バージョンへのアクセスの管理
ライセンスのアイドル状態の監視（Monitoring License Idle Time）
一時ライセンスを使用する
SolidNetWorkライセンスとアドイン製品の使用（Using SolidNetWork Licenses with Add-in Products）
SolidNetWork License での SOLIDWORKS Simulation ライセンスの選択
Flow Simulation モジュールのロード
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation、SOLIDWORKS Plastics の非アクティブ状態のタイムアウト
ライセンス マネージャーとアドミニストレーティブ イメージ インストレーションに向けた同じコンピュータの使用（Using the Same Computer for the License Manager and Administrative Image Installations）
SolidNetWork ライセンス マネージャーのアンインストール（Uninstalling the SolidNetWork License Manager）
FlexNet Publisher ライセンス管理（FlexNet Publisher License Management）


SolidNetWork ライセンス ファイルの削除

有効期限の切れた SolidNetWork ライセンス ファイルを、新しいライセンス ファイルにアップグレードする前に削除できます。

  1. スタート（Start） > SOLIDWORKS ツール（SOLIDWORKS Tools）バージョン > SolidNetWork License Manager Serverをクリックして、SolidNetWork License Manager を起動します。
  2. サーバー アドミニストレーション（Server Administration）タブのライセンス情報（License Information）で、変更（Modify）をクリックし、次へ（Next）をクリックします。
  3. SOLIDWORKS製品のアクティブ化/非アクティブ化（Activate/Deactivate Your SOLIDWORKS Product）ページで、期限切れの SolidNetWork ライセンス ファイルを選択し、除去（Remove）をクリックします。
  4. 完了（Finish）をクリックし、OK をクリックして終了します。
親トピック SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）
SolidNetWork ライセンスのインストールの概要
SolidNetWork License Managerの開始（Starting the SolidNetWork License Manager）
SolidNetWork License Managerのアップグレード（Upgrading the SolidNetWork License Manager）
SolidNetWork ライセンスの移動
SolidNetWorkライセンスの借入と返却（Borrowing and Returning SolidNetWork Licenses）
SOLIDWORKS の各種バージョンへのアクセスの管理
ライセンスのアイドル状態の監視（Monitoring License Idle Time）
一時ライセンスを使用する
SolidNetWorkライセンスとアドイン製品の使用（Using SolidNetWork Licenses with Add-in Products）
SolidNetWork License での SOLIDWORKS Simulation ライセンスの選択
Flow Simulation モジュールのロード
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation、SOLIDWORKS Plastics の非アクティブ状態のタイムアウト
ライセンス マネージャーとアドミニストレーティブ イメージ インストレーションに向けた同じコンピュータの使用（Using the Same Computer for the License Manager and Administrative Image Installations）
SolidNetWork ライセンス マネージャーのアンインストール（Uninstalling the SolidNetWork License Manager）
FlexNet Publisher ライセンス管理（FlexNet Publisher License Management）


SolidNetWorkライセンスの借入と返却（Borrowing and Returning SolidNetWork Licenses）

SolidNetWorkライセンスを借り、リモート位置からソフトウェアを使用することができます。ライセンスは使用可能なライセンスのプールから取り除かれるため、借りたライセンスを再び使用可能にするにはこれを戻す必要があります。

借入ライセンスは、現在のユーザーおよび借りたコンピュータでのみ有効で、移動することはできません。

ライセンスは指定期間中（30日間まで）、（またはシステム管理者によって定義された日数）貸し出すことができ、ライセンスは使用可能なライセンスのプールから取り除かれます。

ライセンスの借用と返却は、その SOLIDWORKS ライセンスを使用中の場合は機能しません。

システム管理者はライセンスの借入を次のようにカスタマイズできます。
  • ライセンスを借りることのできるユーザーやグループを定義する
  • 借りることのできないライセンスの数を設定する

詳細については、SolidNetWork_License_Manager_install_dir\Docs\flexuser\licensingenduserguide.pdf を参照して下さい。

目次

  • SolidNetWorkライセンスの借入（Borrowing SolidNetWork Licenses）

  • 借りたSolidNetWorkライセンスを戻す（Returning a Borrowed SolidNetWork License）

    借りた SolidNetWork ライセンスは使用可能なライセンスのプールから取り除かれるため、その借りたライセンスを再び使用可能にするにはこれを戻す必要があります。

親トピック SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）
SolidNetWork ライセンスのインストールの概要
SolidNetWork License Managerの開始（Starting the SolidNetWork License Manager）
SolidNetWork License Managerのアップグレード（Upgrading the SolidNetWork License Manager）
SolidNetWork ライセンスの移動
SolidNetWork ライセンス ファイルの削除
SOLIDWORKS の各種バージョンへのアクセスの管理
ライセンスのアイドル状態の監視（Monitoring License Idle Time）
一時ライセンスを使用する
SolidNetWorkライセンスとアドイン製品の使用（Using SolidNetWork Licenses with Add-in Products）
SolidNetWork License での SOLIDWORKS Simulation ライセンスの選択
Flow Simulation モジュールのロード
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation、SOLIDWORKS Plastics の非アクティブ状態のタイムアウト
ライセンス マネージャーとアドミニストレーティブ イメージ インストレーションに向けた同じコンピュータの使用（Using the Same Computer for the License Manager and Administrative Image Installations）
SolidNetWork ライセンス マネージャーのアンインストール（Uninstalling the SolidNetWork License Manager）
FlexNet Publisher ライセンス管理（FlexNet Publisher License Management）


SolidNetWorkライセンスの借入（Borrowing SolidNetWork Licenses）

SolidNetWork License Manager は、常にスタート（Start）メニューから開始します。ライセンスを借用するには、SolidNetWork License Manager に接続する必要があります。

これらの手順は、システムの構成によって異なる場合があります。 追加の手順およびオプションについては、Microsoft Windows のドキュメントを参照してください。
  1. クライアント マシンで、スタート（Start） > SOLIDWORKS ツール（SOLIDWORKS Tools）バージョン > SolidNetWork License Manager Client バージョンをクリックして、SolidNetWork License Manager を起動します。
  2. ライセンスを借りる（License Borrowing）タブでは:
    1. 借りる期限 （Borrow until）で日付を指定します。
    2. 使用可能な製品ライセンス（Available product licenses）で、借りる製品を選択し、借りる（Borrow）をクリックします。
    3. ダイアログ ボックスのプロンプト、製品選択（Select Product）で、リストから製品を選択し、OK をクリックして確定します。
    4. ダイアログ ボックスの下部にある、更新（Refresh）をクリックします。
      借りる期限（Borrow until）列は、ライセンスの期限を示します。
  3. OK をクリックします。

ライセンスの使用状況（License Usage）タブでは、ライセンスの合計数（Total licenses）、未使用ライセンス（Free licenses）、ライセンス使用者（Licenses used by）ユーザー、および借りる期限（Borrow until）の日付も確認できます。

リモートで作業していて、SOLIDWORKS アプリケーションの開くのが遅い場合は、借りたライセンスのみを使用する（起動が速い）（Only use borrowed licenses (faster startup)）を選択します。

このオプションによりライセンス サーバーへのクエリがブロックされ、一部の環境で速度が遅くなることがあります。アプリケーションは、クエリを省略することで高速に起動できますが、借用ライセンスのみが使用されます。

アプリケーションを再起動してこのオプションを有効にします。

親トピック SolidNetWorkライセンスの借入と返却（Borrowing and Returning SolidNetWork Licenses）
借りたSolidNetWorkライセンスを戻す（Returning a Borrowed SolidNetWork License）


借りたSolidNetWorkライセンスを戻す（Returning a Borrowed SolidNetWork License）

借りた SolidNetWork ライセンスは使用可能なライセンスのプールから取り除かれるため、その借りたライセンスを再び使用可能にするにはこれを戻す必要があります。

  1. クライアント マシンで、スタート（Start） > SOLIDWORKS ツール（SOLIDWORKS Tools）バージョン > SolidNetWork License Manager Client バージョンをクリックして、SolidNetWork License Manager を起動します。
  2. ライセンスを借りる（License Borrowing）タブでは:
    1. 借用製品ライセンス（Borrowed product licenses）で、返却する製品を選択し、返却（Return）をクリックします。
    2. 更新 （Refresh）をクリックします。借りる期限（Borrow until）は空欄になり、ライセンスが返却されていることを示します。
  3. OK をクリックします。

ライセンスの使用状況（License Usage）タブでは、ライセンスの合計数（Total licenses）を確認することもできます。

有効期限が過ぎたライセンスを返却する必要はありません。有効期限日の真夜中になると、ライセンスは SolidNetWork License Manager のプールに戻され、リモート システム上にあるアプリケーションは実行できなくなります。
親トピック SolidNetWorkライセンスの借入と返却（Borrowing and Returning SolidNetWork Licenses）
SolidNetWorkライセンスの借入（Borrowing SolidNetWork Licenses）


SOLIDWORKS の各種バージョンへのアクセスの管理

SolidNetWork 環境で特定のバージョンの SOLIDWORKS を使用しないように制限できます。 この機能を使用して、さまざまなユーザー、プロジェクト、部門で使用される SOLIDWORKS のバージョンを管理できます。

FlexNet オプション ファイルを使用して SOLIDWORKS のバージョンに対するアクセスを管理するには:

  1. SolidNetWork License Manager インストレーション ディレクトリで次のテキスト ファイルを作成します。
    SolidNetWork_License_Manager_install_dir\Licenses\sw_d.opt
  2. ライセンス ファイルで特定の SOLIDWORKS バージョンに対するアクセスを管理するには、次の構文を SOLIDWORKS に追加します:
    :SWVERSION=xx xx は、管理する SOLIDWORKS 製品のバージョンを示します
  3. 複数のバージョンの SOLIDWORKS を管理するには、管理するバージョンごとに行を追加します。

    すべての FlexNet オプションがサポートされているわけではありません。 サポートされるバージョン フィルタのオプションは次のとおりです:

    INCLUDE | ユーザーまたはグループのみが、特定のバージョンを開始できます。 その他のすべてのユーザーは、このバージョンを開始できません。
    INCLUDE_BORROW | ユーザーまたはグループのみが、特定のバージョンを借用できます。 その他のすべてのユーザーは、このバージョンを借用できません。
    EXCLUDE | リストにあるユーザーまたはグループが特定のバージョンの SOLIDWORKS を開始することを禁止します。 EXCLUDE は INCLUDE よりも優先されます。
    EXCLUDE_BORROW | リストにあるユーザーまたはグループが特定のバージョンの SOLIDWORKS を借用することを禁止します。 EXCLUDE は INCLUDE よりも優先されます。
    例:
    1 | SWVERSION=32.0 SOLIDWORKS 2025 を参照します
    SWVERSION=31.0 SOLIDWORKS 2024 を参照します
    2 | INCLUDE solidworks:SWVERSION=32.0 USER jane
    INCLUDE_BORROW solidworks:SWVERSION=32.0 USER jane
    オプション ファイル内のこれらの行では、jane のみ SOLIDWORKS 2025 で実行できます。他のすべてのユーザーは SOLIDWORKS 2025 を実行および借用できませんが、他のバージョンの SOLIDWORKS の実行と借用は可能です。jane も他のバージョンの SOLIDWORKS を実行および借用できます。
    3 | GROUP chicago USER john robert eva
    EXCLUDE solidworks:SWVERSION=32.0 GROUP chicago
    EXCLUDE solidworks:SWVERSION=31.0 GROUP chicago
    EXCLUDE solidworks USER don
    これらの行は、chicago というユーザーの GROUP を定義しています。このグループは SOLIDWORKS 2025 と SOLIDWORKS 2024, へのアクセスを両方とも拒否されていますが、他のすべてのバージョンの SOLIDWORKS は実行できます。ユーザー don はどのバージョンの SOLIDWORKS も実行できません。
    4 | EXCLUDE swinspection_std:SWVERSION=32.0 HOST machine1
    この行により、machine1 のすべてのユーザーが SOLIDWORKS Inspection 2025 を起動することを禁止されます。

    FlexNet の詳細については、SolidNetWork License Manager のインストレーション ディレクトリにある FlexNet Publisher の『License Administration Guide』を参照してください（\Docs\flexuser\fnp_LicAdmin.pdf）。

親トピック SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）
SolidNetWork ライセンスのインストールの概要
SolidNetWork License Managerの開始（Starting the SolidNetWork License Manager）
SolidNetWork License Managerのアップグレード（Upgrading the SolidNetWork License Manager）
SolidNetWork ライセンスの移動
SolidNetWork ライセンス ファイルの削除
SolidNetWorkライセンスの借入と返却（Borrowing and Returning SolidNetWork Licenses）
ライセンスのアイドル状態の監視（Monitoring License Idle Time）
一時ライセンスを使用する
SolidNetWorkライセンスとアドイン製品の使用（Using SolidNetWork Licenses with Add-in Products）
SolidNetWork License での SOLIDWORKS Simulation ライセンスの選択
Flow Simulation モジュールのロード
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation、SOLIDWORKS Plastics の非アクティブ状態のタイムアウト
ライセンス マネージャーとアドミニストレーティブ イメージ インストレーションに向けた同じコンピュータの使用（Using the Same Computer for the License Manager and Administrative Image Installations）
SolidNetWork ライセンス マネージャーのアンインストール（Uninstalling the SolidNetWork License Manager）
FlexNet Publisher ライセンス管理（FlexNet Publisher License Management）


ライセンスのアイドル状態の監視（Monitoring License Idle Time）

SOLIDWORKS は SolidNetWork License Manager のアイドル状態を記録し、一定時間使用されていないライセンスをフリーのライセンス プールに戻すことができます。

  1. SolidNetWork License Managerインストレーション ディレクトリで次のテキスト ファイルを作成します。
    SolidNetWork_License_Manager_install_dir\Licenses\sw_d.opt
  2. ファイルに次のラインを追加します。
    TIMEOUTALL seconds

    ここで、secondsは900（15分）（許容最少時間）、またはそれ以上の数値となります。

親トピック SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）
SolidNetWork ライセンスのインストールの概要
SolidNetWork License Managerの開始（Starting the SolidNetWork License Manager）
SolidNetWork License Managerのアップグレード（Upgrading the SolidNetWork License Manager）
SolidNetWork ライセンスの移動
SolidNetWork ライセンス ファイルの削除
SolidNetWorkライセンスの借入と返却（Borrowing and Returning SolidNetWork Licenses）
SOLIDWORKS の各種バージョンへのアクセスの管理
一時ライセンスを使用する
SolidNetWorkライセンスとアドイン製品の使用（Using SolidNetWork Licenses with Add-in Products）
SolidNetWork License での SOLIDWORKS Simulation ライセンスの選択
Flow Simulation モジュールのロード
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation、SOLIDWORKS Plastics の非アクティブ状態のタイムアウト
ライセンス マネージャーとアドミニストレーティブ イメージ インストレーションに向けた同じコンピュータの使用（Using the Same Computer for the License Manager and Administrative Image Installations）
SolidNetWork ライセンス マネージャーのアンインストール（Uninstalling the SolidNetWork License Manager）
FlexNet Publisher ライセンス管理（FlexNet Publisher License Management）


一時ライセンスを使用する

一時的な「Any」ライセンスは、SolidNetWork ライセンスが使用できない場合に使用できます。

デフォルトでは、SolidNetWork License Manager がアクティブ化できるのは一度に 1 つのサーバーだけです。テスト環境で作業するには、一時ライセンス ファイルをテクニカル サポートから取得して、「Any」ライセンスを別のサーバーの SolidNetWork License Manager にロードします。オフライン サーバーを使用している場合は、同じ手順を使用して、アクティベーション免除ライセンスをロードできます。

「Any」ライセンス ファイルを使用することで、お客様は Dassault Systèmes SOLIDWORKS Corporation から SolidNetWork ライセンスを受け取り時にライセンスを実装することに同意したことになります。この場合も、ライセンス制限への応諾が必要となります。

「Any」ライセンスを使用するには:

  1. スタート（Start） > SOLIDWORKS ツール（SOLIDWORKS Tools）バージョン > SolidNetWork License Manager Server バージョンをクリックして、SolidNetWork License Manager を起動します。
  2. アクティブ化を求めるプロンプトが表示される場合は、いいえ（No）をクリックします。
  3. サーバー アドミニストレーション（Server Administration）タブで、詳細設定オプション（Advanced Options） > オプション（Options）をクリックします。
  4. SolidNetWork Server ライセンス モードで、ライセンス ファイル使用（Use a License File）をクリックし、OK をクリックします。
  5. サーバー アドミニストレーション（Server Administration）タブで、ライセンス情報（License Information）の下にある変更（Modify）をクリックします。
    SolidNetWorkライセンス ファイル ウィザードが表示されます。
  6. サーバー タイプ （Server Type）で 単一 （Single）を選択し、次へ （Next）をクリックします。
  7. ドングル ID（Dongle ID）を選択し、サーバー情報のAnyまたはNIC アドレス（NIC address）を入力します。続いて、次へ (Next) をクリックしします。

    次のメッセージが表示されたら、キャンセル（Cancel）をクリックします。ドングルの ID 番号が読み取れませんでした。（Could not read the dongle ID number.）

    コンピュータでファイアウォールを使用している場合は、この画面で追加の指定を行う必要があります。詳細は、SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls） を参照してください。
  8. ライセンス（Licenses）で、読み取り（Read）をクリックしてライセンス ファイルを読み取ります。
  9. 読み取り（Read）ダイアログ ボックスで、テクニカル サポートから提供された SNL_ANY.txt または SNL_(NIC Card Number).txt ファイルを参照し、開く（Open）をクリックします。OKをクリックします。
    SolidNetWork ファイル ライセンス ウィザードに、テキスト ファイルからのライセンスがリストされます。
    削除（Remove）をクリックして、リスト内の有効期限が切れた一時ライセンス エントリを削除します。
  10. 完了（Finish）をクリックして SolidNetWork License ファイル ウィザードを閉じます。
  11. 「Any」ライセンスをアクティブ化します。
    1. サーバー アドミニストレーション（Server Administration）タブで、詳細設定オプション（Advanced Options） > オプション（Options）をクリックします。
    2. SolidNetWork Server ライセンス モードで ライセンス ファイル使用（Use a License File）を選択し、OK をクリックします。
    3. サーバー アドミニストレーション タブで、変更（Modify） > 製品ライセンスのアクティブ化/非アクティブ化（Activate/Deactivate your product licenses）をクリックします。
    4. シリアル番号（Serial Number）を選択し、連絡先情報（Contact Information）を入力して、アクティベーション方法を選択します。手動アクティベーションを選択した場合は、指示に従ってください。
    5. 完了（Finish）をクリックして、アクティベーションを確定します
親トピック SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）
SolidNetWork ライセンスのインストールの概要
SolidNetWork License Managerの開始（Starting the SolidNetWork License Manager）
SolidNetWork License Managerのアップグレード（Upgrading the SolidNetWork License Manager）
SolidNetWork ライセンスの移動
SolidNetWork ライセンス ファイルの削除
SolidNetWorkライセンスの借入と返却（Borrowing and Returning SolidNetWork Licenses）
SOLIDWORKS の各種バージョンへのアクセスの管理
ライセンスのアイドル状態の監視（Monitoring License Idle Time）
SolidNetWorkライセンスとアドイン製品の使用（Using SolidNetWork Licenses with Add-in Products）
SolidNetWork License での SOLIDWORKS Simulation ライセンスの選択
Flow Simulation モジュールのロード
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation、SOLIDWORKS Plastics の非アクティブ状態のタイムアウト
ライセンス マネージャーとアドミニストレーティブ イメージ インストレーションに向けた同じコンピュータの使用（Using the Same Computer for the License Manager and Administrative Image Installations）
SolidNetWork ライセンス マネージャーのアンインストール（Uninstalling the SolidNetWork License Manager）
FlexNet Publisher ライセンス管理（FlexNet Publisher License Management）


SolidNetWorkライセンスとアドイン製品の使用（Using SolidNetWork Licenses with Add-in Products）

SolidNetWork License Manager を使用し、SOLIDWORKS コア アドイン製品のライセンスを配布できます。

  • SOLIDWORKS ソフトウェアのライセンス数と SOLIDWORKS アドインのライセンス数が同じである必要はありません。
  • アドイン製品のライセンスをチェックアウトするには、最初に SOLIDWORKS のライセンスをチェックアウトする必要があります。
  • アドイン製品ライセンスを借りるには、SOLIDWORKS ソフトウェア ライセンスと、アドイン製品を含む SOLIDWORKS 製品ライセンスの両方を借りる必要があります。デフォルトでは、SOLIDWORKS Standard ライセンスを借りますが、アドインを有効にするには、SOLIDWORKS Professional、SOLIDWORKS Premium、SOLIDWORKS Ultimate のいずれかの製品ライセンスを借りる必要があります。
  • アドイン製品ライセンスをリリースするには、以下を行います。
    • SOLIDWORKS で ツール（Tools） > アドイン（Add-ins）の順にクリックし、アドインを選択解除します。
    • SOLIDWORKS を終了します。
親トピック SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）
SolidNetWork ライセンスのインストールの概要
SolidNetWork License Managerの開始（Starting the SolidNetWork License Manager）
SolidNetWork License Managerのアップグレード（Upgrading the SolidNetWork License Manager）
SolidNetWork ライセンスの移動
SolidNetWork ライセンス ファイルの削除
SolidNetWorkライセンスの借入と返却（Borrowing and Returning SolidNetWork Licenses）
SOLIDWORKS の各種バージョンへのアクセスの管理
ライセンスのアイドル状態の監視（Monitoring License Idle Time）
一時ライセンスを使用する
SolidNetWork License での SOLIDWORKS Simulation ライセンスの選択
Flow Simulation モジュールのロード
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation、SOLIDWORKS Plastics の非アクティブ状態のタイムアウト
ライセンス マネージャーとアドミニストレーティブ イメージ インストレーションに向けた同じコンピュータの使用（Using the Same Computer for the License Manager and Administrative Image Installations）
SolidNetWork ライセンス マネージャーのアンインストール（Uninstalling the SolidNetWork License Manager）
FlexNet Publisher ライセンス管理（FlexNet Publisher License Management）


SolidNetWork License での SOLIDWORKS Simulation ライセンスの選択

SolidNetWork ライセンス ユーザーは、SOLIDWORKS Simulation に追加するときに、ライセンス プールにあるどの SOLIDWORKS® Simulation ライセンスを使用するかを制御できます。 また、より詳細なスタディには、より高いライセンス タイプが必要な場合に備えて、アドインをアンロードせずに SOLIDWORKS Simulation ライセンスをアップグレードすることもできます。

  1. 特定の SOLIDWORKS Simulation ライセンスを使用するには:
    1. SOLIDWORKS で、ツール（Tools） > アドイン（Add-Ins）をクリックし、アドイン（Add-in）ダイアログ ボックスでSOLIDWORKS Simulationを選択します。
    2. SOLIDWORKS Simulation（CommandManager）で、下向き（Down）矢印 [image] をクリックして、Simulation をサポートできるサーバー上のライセンスのリストを表示します。

    3. 適切な SOLIDWORKS Simulation ライセンスを選択します。
  2. 現在の SOLIDWORKS Simulation ライセンスをチェック、または変更するには、SOLIDWORKS Simulation（CommandManager）の下向き（Down）矢印 [image] をクリックします。

    使用中のライセンスにチェック マークが表示されます。 より高度なライセンス タイプが使用可能な場合は、アップグレードできます。
    SOLIDWORKS Simulation ライセンスは、ダウングレードできません。 SOLIDWORKS Simulation アドインを無効にし、ライセンスを下位レベルで再度追加します。
  3. オプション: アドインを無効にするには、SOLIDWORKS Simulation（CommandManager）をクリックするか、ツール（Tools） > アドイン（Add-Ins）から選択解除します。
次の場合は、引き続きライセンス注文を使用します。
  • SOLIDWORKS Simulation の実行が開始されたとき。
  • SOLIDWORKS Simulation がツール（Tools） > アドイン（Add-Ins）に追加された場合。
  • プルダウン リストからライセンスを指定せずに SOLIDWORKS Simulation をクリックした場合。
親トピック SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）
SolidNetWork ライセンスのインストールの概要
SolidNetWork License Managerの開始（Starting the SolidNetWork License Manager）
SolidNetWork License Managerのアップグレード（Upgrading the SolidNetWork License Manager）
SolidNetWork ライセンスの移動
SolidNetWork ライセンス ファイルの削除
SolidNetWorkライセンスの借入と返却（Borrowing and Returning SolidNetWork Licenses）
SOLIDWORKS の各種バージョンへのアクセスの管理
ライセンスのアイドル状態の監視（Monitoring License Idle Time）
一時ライセンスを使用する
SolidNetWorkライセンスとアドイン製品の使用（Using SolidNetWork Licenses with Add-in Products）
Flow Simulation モジュールのロード
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation、SOLIDWORKS Plastics の非アクティブ状態のタイムアウト
ライセンス マネージャーとアドミニストレーティブ イメージ インストレーションに向けた同じコンピュータの使用（Using the Same Computer for the License Manager and Administrative Image Installations）
SolidNetWork ライセンス マネージャーのアンインストール（Uninstalling the SolidNetWork License Manager）
FlexNet Publisher ライセンス管理（FlexNet Publisher License Management）


Flow Simulation モジュールのロード

SolidNetWork ライセンスをお持ちのお客様は、2 つの方法を使用して、Flow Simulation の HVAC アドイン モジュールおよび Electronics Cooling アドイン モジュールをロードする方法を制御できます。

最初の方法では、Flow Simulation をロードするときのアドインのデフォルト動作を指定できます。Flow Simulation アドイン モジュールが使用可能な場合は自動的にロードする（Automatically load Flow Simulation add-in modules if available）オプションは、SolidNetWork License Manager クライアント（SolidNetWork License Manager Client） > ライセンス順序（License Order）タブにあります。Flow Simulation アドインが不要な場合は、このオプションを選択解除します。既存の方法で Flow Simulation を追加した場合、HVAC アドイン モジュールおよび Electronics Cooling アドイン モジュールはロードされません。

2 番目の方法では、デフォルト動作を上書きし、Flow Simulation をロードするときに HVAC アドイン モジュールおよび Electronics Cooling アドイン モジュールを含めることができます。SOLIDWORKS Flow Simulation（SOLIDWORKS® アドイン ツールバー）で下矢印 [image] をクリックするか、ロードするアドイン モジュールのいずれかまたは両方を含む SOLIDWORKS Flow Simulation をクリックします。

これらの方法を使用しない場合、アドイン モジュールのライセンスは必要かどうかに関係なく消費され、ネットワーク上の他のユーザーに対して拒否される可能性があります。

親トピック SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）
SolidNetWork ライセンスのインストールの概要
SolidNetWork License Managerの開始（Starting the SolidNetWork License Manager）
SolidNetWork License Managerのアップグレード（Upgrading the SolidNetWork License Manager）
SolidNetWork ライセンスの移動
SolidNetWork ライセンス ファイルの削除
SolidNetWorkライセンスの借入と返却（Borrowing and Returning SolidNetWork Licenses）
SOLIDWORKS の各種バージョンへのアクセスの管理
ライセンスのアイドル状態の監視（Monitoring License Idle Time）
一時ライセンスを使用する
SolidNetWorkライセンスとアドイン製品の使用（Using SolidNetWork Licenses with Add-in Products）
SolidNetWork License での SOLIDWORKS Simulation ライセンスの選択
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation、SOLIDWORKS Plastics の非アクティブ状態のタイムアウト
ライセンス マネージャーとアドミニストレーティブ イメージ インストレーションに向けた同じコンピュータの使用（Using the Same Computer for the License Manager and Administrative Image Installations）
SolidNetWork ライセンス マネージャーのアンインストール（Uninstalling the SolidNetWork License Manager）
FlexNet Publisher ライセンス管理（FlexNet Publisher License Management）


SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation、SOLIDWORKS Plastics の非アクティブ状態のタイムアウト

SOLIDWORKS Simulation、Plastics、または Flow Simulation スタディを実行すると、ネットワーク ライセンスはアクティブなままになり、タイムアウトしません。計算プロセス中、SOLIDWORKS はライセンスを保持します。これはアクティブな状態と見なされます。

TIMEOUT オプションで定義された非アクティブ状態の期間は、スタディが計算を完了した後にのみ有効になります。

親トピック SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）
SolidNetWork ライセンスのインストールの概要
SolidNetWork License Managerの開始（Starting the SolidNetWork License Manager）
SolidNetWork License Managerのアップグレード（Upgrading the SolidNetWork License Manager）
SolidNetWork ライセンスの移動
SolidNetWork ライセンス ファイルの削除
SolidNetWorkライセンスの借入と返却（Borrowing and Returning SolidNetWork Licenses）
SOLIDWORKS の各種バージョンへのアクセスの管理
ライセンスのアイドル状態の監視（Monitoring License Idle Time）
一時ライセンスを使用する
SolidNetWorkライセンスとアドイン製品の使用（Using SolidNetWork Licenses with Add-in Products）
SolidNetWork License での SOLIDWORKS Simulation ライセンスの選択
Flow Simulation モジュールのロード
ライセンス マネージャーとアドミニストレーティブ イメージ インストレーションに向けた同じコンピュータの使用（Using the Same Computer for the License Manager and Administrative Image Installations）
SolidNetWork ライセンス マネージャーのアンインストール（Uninstalling the SolidNetWork License Manager）
FlexNet Publisher ライセンス管理（FlexNet Publisher License Management）


ライセンス マネージャーとアドミニストレーティブ イメージ インストレーションに向けた同じコンピュータの使用（Using the Same Computer for the License Manager and Administrative Image Installations）

ネットワーク上の 1 台のコンピュータが SolidNetWork ライセンスを配布するライセンス マネージャー、およびユーザーがそこから SOLIDWORKS ソフトウェアをインストールできるアドミニストレーティブ イメージの位置として両方の機能を果たすように設定することも可能です。

クライアント コンピュータはライセンス マネージャーからライセンスを入手し、次に同じコンピュータから SOLIDWORKS をインストールできます。

この構成では、同じコンピューターにライセンス マネージャーとアドミニストレーティブ イメージ の両方をインストールする必要があります。最初にライセンス マネージャーのインストールを行い、次にアドミニストレーティブ イメージの作成と展開を行います。
詳細は次を参照してください：
  • SolidNetWork License Manager Server のインストール
  • 複数クライアントへの展開（Deploying to Multiple Clients）
親トピック SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）
SolidNetWork ライセンスのインストールの概要
SolidNetWork License Managerの開始（Starting the SolidNetWork License Manager）
SolidNetWork License Managerのアップグレード（Upgrading the SolidNetWork License Manager）
SolidNetWork ライセンスの移動
SolidNetWork ライセンス ファイルの削除
SolidNetWorkライセンスの借入と返却（Borrowing and Returning SolidNetWork Licenses）
SOLIDWORKS の各種バージョンへのアクセスの管理
ライセンスのアイドル状態の監視（Monitoring License Idle Time）
一時ライセンスを使用する
SolidNetWorkライセンスとアドイン製品の使用（Using SolidNetWork Licenses with Add-in Products）
SolidNetWork License での SOLIDWORKS Simulation ライセンスの選択
Flow Simulation モジュールのロード
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation、SOLIDWORKS Plastics の非アクティブ状態のタイムアウト
SolidNetWork ライセンス マネージャーのアンインストール（Uninstalling the SolidNetWork License Manager）
FlexNet Publisher ライセンス管理（FlexNet Publisher License Management）


SolidNetWork ライセンス マネージャーのアンインストール（Uninstalling the SolidNetWork License Manager）

SolidNetWork License Managerのアップグレードを行うには、新しいライセンス マネージャーをインストールする前に古いライセンス マネージャーをアンインストールする必要があります。

  1. スタート（Start） > SOLIDWORKS ツール（SOLIDWORKS Tools）バージョン > SolidNetWork License Manager Server バージョンをクリックして、SolidNetWork License Manager を起動します。
  2. SOLIDWORKS を実行しているクライアント コンピュータがネットワーク上にないことを確認します。
    ライセンスの使用状況（License Usage）タブは SOLIDWORKS を実行しているクライアントを示します。
  3. SolidNetWork ライセンスを別のコンピュータに移動する場合は、そのコンピュータに対するライセンスを非アクティブにしてから、SolidNetWork License Manager を除去してください。
    SolidNetWork ライセンスの移動については、SolidNetWork ライセンスの移動を参照してください。
  4. ライセンス サーバー（License Server）のサーバー アドミニストレーション（Server Administration）タブで停止（Stop）をクリックします。
  5. OK をクリックし、ライセンス マネージャーを閉じます。
  6. Windows で、コントロール パネル（Control Panel） > プログラムと機能（Programs and Features）を開きます。
  7. SOLIDWORKS SolidNetWork License Manager を選択し、アンインストール（Uninstall）をクリックしてアンインストールを確定します。
  8. Windows ファイル エクスプローラで SOLIDWORKS SolidNetWork License Manager のフォルダを削除します
    （通常、このフォルダは SOLIDWORKS インストレーション ディレクトリの Program Files (x86) にあります）。

これで、新しいバージョンのライセンス マネージャーのインストールを行う準備が整いました。詳細は、SolidNetWork License Manager Server のインストール（Installing the SolidNetWork License Manager Server）を参照してください。

SolidNetWork License Manager コンピュータにハードウェア ドングルが取り付けられている場合は、新しいバージョンの SolidNetWork License Manager をインストールする前に、ハードウェア ドングルを取り外します。
親トピック SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）
SolidNetWork ライセンスのインストールの概要
SolidNetWork License Managerの開始（Starting the SolidNetWork License Manager）
SolidNetWork License Managerのアップグレード（Upgrading the SolidNetWork License Manager）
SolidNetWork ライセンスの移動
SolidNetWork ライセンス ファイルの削除
SolidNetWorkライセンスの借入と返却（Borrowing and Returning SolidNetWork Licenses）
SOLIDWORKS の各種バージョンへのアクセスの管理
ライセンスのアイドル状態の監視（Monitoring License Idle Time）
一時ライセンスを使用する
SolidNetWorkライセンスとアドイン製品の使用（Using SolidNetWork Licenses with Add-in Products）
SolidNetWork License での SOLIDWORKS Simulation ライセンスの選択
Flow Simulation モジュールのロード
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation、SOLIDWORKS Plastics の非アクティブ状態のタイムアウト
ライセンス マネージャーとアドミニストレーティブ イメージ インストレーションに向けた同じコンピュータの使用（Using the Same Computer for the License Manager and Administrative Image Installations）
FlexNet Publisher ライセンス管理（FlexNet Publisher License Management）
SolidNetWork License Manager Server のインストール


FlexNet Publisher ライセンス管理（FlexNet Publisher License Management）

SOLIDWORKS ライセンスは、FlexNet Publisher® ライセンス管理に基づいています。

FlexNet Publisher ライセンス管理の詳細については、SolidNetWork License Manager インストレーション ディレクトリにある FlexNet Publisher License Administration Guide（C:\Program Files\SOLIDWORKS SolidNetWork License Manager\Docs\flexuser\fnp_LicAdmin.pdf）を参照してください。

FlexNet Publisher ライセンス管理の最新情報については、Flexera® Software までお問い合わせください。

FlexNet のバージョンは、ライセンス サーバーのログで確認できます。SolidNetWork License Manager Server を開き、サーバー アドミニストレーション（Server Administration） > ログを表示（View Log）をクリックします。ログの先頭に FlexNet Licensing のバージョンが括弧で囲まれて表示されます。

親トピック SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）
SolidNetWork ライセンスのインストールの概要
SolidNetWork License Managerの開始（Starting the SolidNetWork License Manager）
SolidNetWork License Managerのアップグレード（Upgrading the SolidNetWork License Manager）
SolidNetWork ライセンスの移動
SolidNetWork ライセンス ファイルの削除
SolidNetWorkライセンスの借入と返却（Borrowing and Returning SolidNetWork Licenses）
SOLIDWORKS の各種バージョンへのアクセスの管理
ライセンスのアイドル状態の監視（Monitoring License Idle Time）
一時ライセンスを使用する
SolidNetWorkライセンスとアドイン製品の使用（Using SolidNetWork Licenses with Add-in Products）
SolidNetWork License での SOLIDWORKS Simulation ライセンスの選択
Flow Simulation モジュールのロード
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation、SOLIDWORKS Plastics の非アクティブ状態のタイムアウト
ライセンス マネージャーとアドミニストレーティブ イメージ インストレーションに向けた同じコンピュータの使用（Using the Same Computer for the License Manager and Administrative Image Installations）
SolidNetWork ライセンス マネージャーのアンインストール（Uninstalling the SolidNetWork License Manager）


トラブルシューティング（Troubleshooting）

インストレーションの問題のトラブルシューティングに役立てるため、これらのトピックを参考にしてください。

目次

  • ネットワーク ライセンスの使用状況（Network License Usage）

  • SOLIDWORKS Installation Manager ログ ファイル（SOLIDWORKS Installation Manager Log Files）

    SOLIDWORKS Installation Manager ログ ファイルを使用し、インストレーションの問題のトラブルシューティングに役立てられます。

  • SOLIDWORKS Installation Manager ダウンロード フォルダ（SOLIDWORKS Installation Manager Download Folder）

    SOLIDWORKS Installation Manager では、必要なインストレーション ファイルを指定フォルダにダウンロードできます。 このトピックには、ダウンロード フォルダに関するよくある質問（FAQ）とそれに対する回答が掲載されています。

  • SolidNetWorkライセンスのトラブルシューティング（Troubleshooting SolidNetWork Licenses）

    SolidNetWork License Managerのインストレーションに失敗した場合は、これらの考えられる説明を確認してください。

  • アップグレードのトラブル シューティング（Troubleshooting Upgrades）

    新しい SOLIDWORKS リリースへのアップグレード中に問題が発生した場合は、これらの考えられる説明を確認してください。

  • インストール時またはアップグレード時のグラフィック カードの検証

    マシン上への SOLIDWORKS のインストールまたはアップグレードを完了したら、SOLIDWORKS Rx を実行して、マシン上でサポート対象のグラフィック カードとグラフィック カード ドライバが実行されていることを確認します。


ネットワーク ライセンスの使用状況（Network License Usage）

このダイアログ ボックスは、サーバーで製品のライセンスが不足している場合に開きます。

製品 ボックスの矢印をクリックし、選択可能なすべての製品を表示します。 製品の選択アイテムには、SOLIDWORKS、および購入可能なすべてのアドインが含まれています。

ライセンスの合計数（Total licences）は、購入したライセンスの合計数です。

利用可能なライセンス（Free licenses）は、使用されていないライセンスの数です。

ライセンス使用者（Licenses used by）ボックスには、ライセンスを使用している各ユーザーに関する情報が表示されます。

親トピック トラブルシューティング（Troubleshooting）
SOLIDWORKS Installation Manager ログ ファイル（SOLIDWORKS Installation Manager Log Files）
SOLIDWORKS Installation Manager ダウンロード フォルダ（SOLIDWORKS Installation Manager Download Folder）
SolidNetWorkライセンスのトラブルシューティング（Troubleshooting SolidNetWork Licenses）
アップグレードのトラブル シューティング（Troubleshooting Upgrades）
インストール時またはアップグレード時のグラフィック カードの検証


SOLIDWORKS Installation Manager ログ ファイル（SOLIDWORKS Installation Manager Log Files）

SOLIDWORKS Installation Manager ログ ファイルを使用し、インストレーションの問題のトラブルシューティングに役立てられます。

これらのログ ファイルは、その他の SOLIDWORKS アプリケーションのログ ファイルと同じ場所にあります。

  • C:\Users\username\AppData\Roaming\SOLIDWORKS\Installation Logs\installed_version

Installation Manager をシステム アカウントから実行する場合、ログは次のフォルダに配置されます。
  • C:\Windows\SysWOW64\config\systemprofile\AppData\Roaming\SOLIDWORKS\Installation Logs\installed_version
ログ ファイルのディレクトリを表示するには、Windowsのフォルダ オプションをすべてのファイルとフォルダを表示する（Show hidden files and folders）に設定する必要があるかもしれません。

アプリケーション データが C: 以外のドライブにある場合は、これに応じて適切にディレクトリ パスを調整してください。

このディレクトリには、SOLIDWORKS Installation Manager プログレスの全般的なログである SummaryIMLog_nnnnn_nnnnn_nnnn_nnnnn.txt ファイルがあります。

Other Logsサブディレクトリには、より詳細なインストレーション ログ情報が含まれています。

親トピック トラブルシューティング（Troubleshooting）
ネットワーク ライセンスの使用状況（Network License Usage）
SOLIDWORKS Installation Manager ダウンロード フォルダ（SOLIDWORKS Installation Manager Download Folder）
SolidNetWorkライセンスのトラブルシューティング（Troubleshooting SolidNetWork Licenses）
アップグレードのトラブル シューティング（Troubleshooting Upgrades）
インストール時またはアップグレード時のグラフィック カードの検証


SOLIDWORKS Installation Manager ダウンロード フォルダ（SOLIDWORKS Installation Manager Download Folder）

SOLIDWORKS Installation Manager では、必要なインストレーション ファイルを指定フォルダにダウンロードできます。 このトピックには、ダウンロード フォルダに関するよくある質問（FAQ）とそれに対する回答が掲載されています。

質問 答え
このフォルダにあるファイルをインストールするには？

setup.exeを実行します。 以前ダウンロードされたことの無いアイテムをインストールするように選択した場合は、追加ファイルのダウンロードが必要な場合があります。

インストールには msiexec を使用しないでください（下記参照）。
msiexec や他のアプリケーションを使用して MSI ファイルをこのフォルダからマニュアルでインストールできますか?

いいえ。 Installation Manager では msiexec の実行に必要なファイルの一部がダウンロードされません。
各々のバージョンのインストールに同じダウンロード フォルダを選択して良いですか？

ダウンロード フォルダはバージョン固有のものです。 SOLIDWORKS Installation Manager は指定されたフォルダ内にバージョン固有のサブフォルダを自動的に作成します。

一部の製品は Dassault Systèmes SOLIDWORKS Corporation Web サイトからダウンロードしてあります。 これらもInstallation Managerでインストールできますか?
マニュアルでダウンロードしたファイルを SOLIDWORKS Installation Manager で使うことができます。 しかし、ファイルをダウンロードするオプションを選択して、SOLIDWORKS Installation Manager を実行するほうが適切です。 SOLIDWORKS Installation Manager は各ファイルをダウンロードするためにリンクを提供し、インストールしているものに基づいてどのファイルを必要とするかを表示します。 ダウンロード ページが機能しないとき、このオプションを使用してください（ほとんどの場合、プロキシ サーバーによるダウンロード制限が原因です）。
ダウンロード時またはインストール時にファイルを保存するか実行するかをダイアログボックスで確認された場合、必ず保存（Save）を指定してください。
ダウンロードしたファイルは他のユーザーと共有できますか?

Yes そのためには、共有ネットワーク上にダウンロードします。 続いて、各クライアントが共有ネットワークから SOLIDWORKS Installation Manager を実行し、インストールすることができます。

ダウンロードの追加が必要ないのは、初期のダウンロードに含まれていないアイテムがユーザーによって選択されていない場合、またはこのダウンロードを使用してインストールするコンピュータに、ファイルをダウンロードしたコンピュータと異なる前提条件のセットがない場合です。

インストールは行わず、他のユーザーのためにダウンロードを行う場合は、インストール時にダウンロードのみ（Download Only）オプションを選択します。 このオプションにより、システム上に何をインストールするかに関わらず製品を選択できます。 ただし、パッチをダウンロードする場合、またはアドミニストレーティブ イメージを作成する場合は、このオプションを使用できません。
いつ新しいバージョンの SOLIDWORKS を使用できるか知りたいのですが?
次の場合、新しいバージョンが使用できるようになると通知されます。
  • アップデート チェックを実行した場合（スタート > SolidWorks Installation Manager > アップデート チェック（Check For Updates））
  • SOLIDWORKS バックグラウンド ダウンローダーを有効にした場合
  • Windows のプログラムの追加と削除でインストールされている SOLIDWORKS のバージョンを選択し、変更をクリックした場合
  • ダウンロード フォルダで古いバージョンの Installation Manager（sldIM.exe）を実行した場合
これらの場合、新しいバージョンのダウンロードを選択することができます。 SOLIDWORKS Installation Manager は新しいバージョンの Installation Manager （インストレーション ファイルでは無く）をダウンロードし、実行します。 新しいバージョンの SOLIDWORKS Installation Manager が実行された後、インストレーションの詳細を指定することができます。 SOLIDWORKS Installation Manager によって必要なインストレーション ファイル（で、これまでにダウンロードされていないファイル）が判別され、それらのファイルのダウンロードが提示されます。
SOLIDWORKS Installation Manager で別の製品の ServicePack のインストールを選択できないのはなぜですか。

それぞれのバージョンの SOLIDWORKS Installation Manager は、特定バージョンの SOLIDWORKS 製品のみをインストールするように設計されています。 別のバージョンの ServicePack をインストールするには、そのバージョンの SOLIDWORKS Installation Manager を実行する必要があります。 使用可能な最新バージョンを確認するには、前の項目を参照してください。
SOLIDWORKS Installation Manager によるファイルのダウンロードが妨げられるのはなぜですか。

プロキシ サーバーによってアプリケーションによるファイルのダウンロードが制限さていれる場合、SOLIDWORKS Installation Manager は自動的にファイルをダウンロードすることができません。

マニュアルでファイルをダウンロードして、次に SOLIDWORKS Installation Manager を使ってそれらをインストールすることができます。個々のファイルをダウンロードするには、SOLIDWORKS Installation Manager でオプションを選択します（例: ダウンロード オプション（Download Options）ページの手動ダウンロード方法（manual download method））。製品選択とシステム必要条件に基づいて、マニュアルでダウンロードするすべての必要なファイルのリンクを含むWebページが、別のウィンドウに表示されます。
一部の SOLIDWORKS 製品が最新の ServicePack バージョンまでアップデートされません。 アップデート チェックに最新バージョンであると示されるのはなぜですか。

アップデート チェック（Check For Updates）は最新バージョンの SOLIDWORKS Installation Manager がインストールされているか（あるいは実行されているか）のみ通知します。

すべての製品を、コントロール パネル（Control Panel） > プログラム（Programs） > プログラムと機能（Programs and Features）でインストールされている最新バージョンに更新する場合は、インストールされている最新バージョンの SOLIDWORKS を選択し、変更（Change）をクリックします。
DVD をダウンロード フォルダにコピーして良いですか?

はい、しかし該当するプラットフォームにリリースされた各 DVD の全内容をコピーしない限り、インストレーションが失敗する場合があります。 SOLIDWORKS Installation Manager はバージョンを判別するためにファイル swdata*.id を探します。 これらのファイルが無い場合、コピーしたインストール ファイルを認識できず、ダウンロードが要求されます。
親トピック トラブルシューティング（Troubleshooting）
ネットワーク ライセンスの使用状況（Network License Usage）
SOLIDWORKS Installation Manager ログ ファイル（SOLIDWORKS Installation Manager Log Files）
SolidNetWorkライセンスのトラブルシューティング（Troubleshooting SolidNetWork Licenses）
アップグレードのトラブル シューティング（Troubleshooting Upgrades）
インストール時またはアップグレード時のグラフィック カードの検証


SolidNetWorkライセンスのトラブルシューティング（Troubleshooting SolidNetWork Licenses）

SolidNetWork License Managerのインストレーションに失敗した場合は、これらの考えられる説明を確認してください。

親トピック トラブルシューティング（Troubleshooting）
ネットワーク ライセンスの使用状況（Network License Usage）
SOLIDWORKS Installation Manager ログ ファイル（SOLIDWORKS Installation Manager Log Files）
SOLIDWORKS Installation Manager ダウンロード フォルダ（SOLIDWORKS Installation Manager Download Folder）
アップグレードのトラブル シューティング（Troubleshooting Upgrades）
インストール時またはアップグレード時のグラフィック カードの検証

SolidNetWorkライセンス ログ ファイルへのアクセス（Accessing the SolidNetWork License log files）

ライセンス エラーの原因は、ほとんどの場合、 SNL_Manager_インストール_ディレクトリ\lmgrd.logファイルに表示されています。

SOLIDWORKS のライセンスを取得できない場合。 ライセンス サーバーに接続できない場合。

一般に、この問題はポートの設定によって生じます。

  • SolidNetWorkライセンス マネージャーとライセンス クライアントとで一致していないポート設定を使用している場合が考えられます。
  • 複数バージョンの SolidNetWork ライセンス マネージャーで必要な追加のポート設定が指定されていない場合が考えられます。
  • サーバー名が指定されている場合に、クライアント マシンがサーバーを正確に解決してサーバーにルートできることを確認します。
SolidNetWork ライセンス マネージャーとクライアントのポート設定に関する詳細については、SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls） を参照してください。
SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）


アップグレードのトラブル シューティング（Troubleshooting Upgrades）

新しい SOLIDWORKS リリースへのアップグレード中に問題が発生した場合は、これらの考えられる説明を確認してください。

親トピック トラブルシューティング（Troubleshooting）
ネットワーク ライセンスの使用状況（Network License Usage）
SOLIDWORKS Installation Manager ログ ファイル（SOLIDWORKS Installation Manager Log Files）
SOLIDWORKS Installation Manager ダウンロード フォルダ（SOLIDWORKS Installation Manager Download Folder）
SolidNetWorkライセンスのトラブルシューティング（Troubleshooting SolidNetWork Licenses）
インストール時またはアップグレード時のグラフィック カードの検証

移動したソースの変更または修復

SOLIDWORKS がインストールされると、SOLIDWORKS Installation Manager はインストレーション ソース（ディスク メディア、ネットワーク上のディスク イメージなど）の場所を記憶します。変更または修復の際には、このソースが同じ場所でアクセス可能であることが前提となります。

ソースが移動/削除されている、あるいはソース メディアが変更されている場合、SOLIDWORKS Installation Manager はエラー メッセージを表示します。ただし、別の場所に同じファイルとフォルダの構造がすべて含まれていれば、その場所を参照してインストレーション ソースを変更または修復できます。


インストール時またはアップグレード時のグラフィック カードの検証

マシン上への SOLIDWORKS のインストールまたはアップグレードを完了したら、SOLIDWORKS Rx を実行して、マシン上でサポート対象のグラフィック カードとグラフィック カード ドライバが実行されていることを確認します。

インストール時またはアップグレード時にグラフィック カードを検証するには:

  1. Installation Manager がインストールを完了し、完了（Finish）ページが表示されたら、システムを確認（Check Your System）の下で、システム診断ツールの実行（Run System Diagnostics）をクリックします。

    SOLIDWORKS Rx が起動し、診断を実行します。

  2. SOLIDWORKS Rx は、グラフィック カードとグラフィック カード ドライバがサポートされているか確認します。
    グラフィック カードがサポートされているが、ドライバがサポートされていない場合は、ドライバの更新を示すステータス メッセージが表示される場合があります。

SOLIDWORKS を 10 回起動するごとに、システムを確認（Check Your System）メッセージが表示され、もう一度システム診断を実行するように推奨されます。これらの通知を抑制するには、Windows 通知領域で SOLIDWORKS Resource Monitor [image] を右クリックして、グラフィックスに関する通知を閉じる（Dismiss Graphics Notifications）をクリックします。

Windows 通知領域で SOLIDWORKS Resource Monitor を右クリックすれば、いつでもグラフィック カードとドライバを検証できます。メニューを使用して、次の作業を行うこともできます。
  • SOLIDWORKS Resource Monitor のヘルプ（Help）へのアクセス
  • システム診断ツールの実行（Run System Diagnostics）
  • グラフィックに関する通知を閉じる（Dismiss Graphics Notifications）
  • サブスクリプションに関する通知を閉じる（Dismiss Subscription Notifications）
  • 認定グラフィック ドライバを表示（View Certified Graphics Drivers）
親トピック トラブルシューティング（Troubleshooting）
ネットワーク ライセンスの使用状況（Network License Usage）
SOLIDWORKS Installation Manager ログ ファイル（SOLIDWORKS Installation Manager Log Files）
SOLIDWORKS Installation Manager ダウンロード フォルダ（SOLIDWORKS Installation Manager Download Folder）
SolidNetWorkライセンスのトラブルシューティング（Troubleshooting SolidNetWork Licenses）
アップグレードのトラブル シューティング（Troubleshooting Upgrades）


SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）

SOLIDWORKS Installation Manager は SOLIDWORKS 製品をインストール/更新する、スタンドアロン アプリケーションです。

SOLIDWORKS Installation Manager は SOLIDWORKS ソフトウェアのダウンロード、インストール、変更、更新、修復、削除を行うための主要なツールです。

SOLIDWORKS Installation Manager は、次のように実行することができます:
  • SOLIDWORKS DVD、共有ソース、またはダウンロード フォルダ（新規バージョンのインストール時）
  • コントロール パネルのプログラムの追加と削除ページ（既存のバージョンの変更または削除時）から
  • スケジュールまたはマニュアルによるアップデート チェック（新規リリース バージョンの検出、ダウンロード、インストール時）を介して

各バージョンの SOLIDWORKS には、そのバージョン特有の SOLIDWORKS Installation Manager があります。

目次

  • SOLIDWORKS バックグラウンド ダウンローダー（SOLIDWORKS Background Downloader）

    SOLIDWORKS バックグラウンド ダウンローダーは、新しいサービス パックが見つかった場合等に、バックグラウンド プロセスを用いてファイルのダウンロードを自動的に行います。これにより、ダウンロード中にも他の作業を継続することが可能となります。 ダウンロードが完了すると、直ちにインストールするか、ダウンロードを延期するか、あるいはダウンロードを削除するかを決定できます。

  • Installation Manager のオプションの指定

    これらのオプションには、ログ、インターネット アクセス、Installation Manager で使用する言語の設定が含まれます。

  • アップデート チェックの結果（Check for Updates Results）

    アップデート チェックは、SOLIDWORKS の最新バージョンを探します。

  • アドミニストレーティブ イメージ位置（Administrative Image Location）

    アドミニストレーティブ イメージのインストール場所を指定します。

  • ダウンロード オプション（Download Options）

    ダウンロード ファイルの場所、ファイルをダウンロードする方法、ダウンロード ファイルをインストールするかどうかなど、ダウンロード処理を完了するための詳細を指定します。

  • SOLIDWORKS Installation Manager ファイルのダウンロード オプション (Download Options for SOLIDWORKS Installation Manager Files)

    より新しいバージョンの SOLIDWORKS Installation Manager をダウンロードします。 この画面で、ファイルをどこからどのようにダウンロードするかを指定します。

  • 製品のインストレーション ファイルをダウンロード（Download Product Installation Files）

    指定された製品の欠けているファイルをどこで、どのように、ダウンロードするべきか指定してください。

  • ダウンロードの進捗状況（Download Progress）

    このプロセスで、SOLIDWORKS Installation Manager はすべてのファイルのダウンロード、検証、抽出を同時に行います。

  • ダウンロード結果（Download Results）

    ダウンロードが正常に終了したか、処理中に失敗したか、または中止されたかを示します。

  • インストレーション エラー/インストールのキャンセル（Installation Errors / Installation Cancelled）

    インストレーションでエラーが発生し、キャンセルされました。

  • インストレーション完了（Installation Is Complete）

    SOLIDWORKS Installation Manager は、その処理を完了しました。

  • インストール先（Installation Location）

  • 更新オプション（Upgrade Options）

    このコンピュータには 1 つまたは複数の古い SOLIDWORKS メジャー バージョンがインストールされています。 新規インストレーションを作成して、古いバージョンと共存させることも、アップグレードして古いバージョンを削除することもできます。

  • インストールの進行状況（Installation Progress）

    この画面にはインストレーションの進捗状況が表示されます。

  • インストレーション タイプ（Installation Type）

    実行するインストール操作を指定できます。 たとえば、新規インストレーションの作成、既存インストレーションの変更または修復、アドミニストレーティブ イメージの作成、アドミニストレーティブ サーバー製品のインストール、ファイルのダウンロードなどを行い、他のコンピュータで共有およびインストールできるようにします。

  • 複数コンピュータのインストールと管理（Installing and Managing Multiple Computers）

    SOLIDWORKS Installation Manager は、複数の SOLIDWORKS コンピュータのインストールと管理のために次のツールを提供します。

  • マニュアル ダウンロード（Manual Download）

    ファイルを手動操作でダウンロードすることを選択しました（または最後に SOLIDWORKS Installation Manager を実行したときに手動操作でダウンロードすることを選択しました）。

  • 利用可能なより新しいバージョン（Newer Version Available）

    Installation Manager は、より新しいバージョンの SOLIDWORKS 製品を検知します。 オリジナルのインストレーションDVDまたはダウンロードに含まれるバージョンのインストールを選択できます。または、新しいバージョンをダウンロードしてインストールすることを選ぶことも可能です。

  • 利用可能な新しいバージョンはありません（No New Versions Available）

    ダウンロードできる利用可能なより新しいバージョンはありません。指定されたバージョンのインストールを開始してください。

  • 検出されたプロセス（Processes Detected）

    SOLIDWORKS Installation Manager は正常なインストレーションを妨げる可能性のあるプロセスを検出しました。

  • 製品選択（Product Selection）

    インストール、変更、ダウンロード、または削除する製品コンポーネントを指定できます。

  • ダウンロードする製品（Products to Download）

    指定された場所にダウンロードするように SOLIDWORKS 製品を選択します。

  • 修復する製品（Products to Repair）

    このインストレーションを修復 (Repair this installation) を指定すると、画面にはこのバージョンの SOLIDWORKS Installation Manager で修復可能な SOLIDWORKS 製品とバージョン番号が表示されます。

  • シリアル番号（Serial Numbers）

    購入した SOLIDWORKS 製品にコンピュータが、シリアル番号によって関連付けられます。

  • サーバー インストール（Server Installation）

    インストールを試みているサーバー製品が、インストレーションの結果と共に表示されます。

  • サマリー（Summary）

    SOLIDWORKS Installation Manager には、インストレーション作業を完了するために必要な情報がすべてあります。

  • システム チェックの警告（System Check Warnings）

    システム チェックは、インストレーションの継続に影響する可能性のある問題を報告します。 ほとんどの場合は、SOLIDWORKS Installation Manager を続行できるはずです。

  • 穴ウィザード/Toolbox オプション（Hole Wizard/Toolbox Options）

    SOLIDWORKS Toolbox をインストールすると、穴タイプとハードウェアの標準ライブラリが SOLIDWORKS に含まれます。

  • 製品のアンインストール（Uninstall Products）

    削除 (Remove) または アンインストール (Uninstall) を コントロール パネル から選択すると、画面にはこのバージョンの SOLIDWORKS Installation Manager でアンインストールできる SOLIDWORKS 製品がバージョン番号と共に表示されます。 一般的なアンインストール、カスタム アンインストール、完全なアンインストールを選択します。


SOLIDWORKS バックグラウンド ダウンローダー（SOLIDWORKS Background Downloader）

SOLIDWORKS バックグラウンド ダウンローダーは、新しいサービス パックが見つかった場合等に、バックグラウンド プロセスを用いてファイルのダウンロードを自動的に行います。これにより、ダウンロード中にも他の作業を継続することが可能となります。 ダウンロードが完了すると、直ちにインストールするか、ダウンロードを延期するか、あるいはダウンロードを削除するかを決定できます。

バックグラウンド ダウンローダーは、SOLIDWORKS のインストール時にデフォルトで有効になります。

インストールやダウンロードのために Installation Manager を実行している間は、バックグラウンド ダウンローダーは一時停止します。 たとえば、実行中のダウンロードを一時停止し、新たなダウンロードの開始やダウンロード フォルダ指定の変更等を禁止します。

インストール中のバックグラウンド ダウンローダーを無効にすることができます。 サマリー（Summary）ページのダウンロード オプション（Download Options）で、今後、バックグラウンド ダウンローダーを使用して Service Pack をダウンロードします（Use the background Downloader for future service packs）オプションを選択解除します。

有効な場合には、ツールバーの Windows 通知領域に次のアイコンが表示されます:

このアイコンをクリックすると、次のオプションが有効になります:
  • バックグラウンド ダウンローダー ヘルプ（Help with Background Downloader）
  • ダウンロード一時停止（Pause Download）
  • ダウンロード再開（Resume Download）
  • ダウンロードのキャンセル（Cancel Download）
  • インストレーション オプション（Installation Options）
  • ダウンロード設定の変更
  • アップデート チェック（Check for updates）
  • アップデート自動チェック（Automatically Check for Updates）
  • アップデート自動ダウンロード（Automatically Download Updates）
  • バックグラウンド ダウンローダー無効化（Disable Background Downloader）

バックグラウンド ダウンローダー ヘルプ（Help with Background Downloader）

SOLIDWORKS インストレーション ガイド（SOLIDWORKS Installation Guide）内のバックグラウンド ダウンローダーに対する本ヘルプ トピックを開きます。

ダウンロード一時停止/再開（Pause/Resume Download）

バックグラウンドでダウンロードしている場合は、ダウンロード一時停止（Pause Download）をクリックすることでダウンロードを一時停止できます。このダウンロードはダウンロード再開（Resume Download）をクリックすることで再開できます。

ダウンロード キャンセル（Cancel Download）

実行中のダウンロードを停止し、バックグラウンド ダウンローダーがダウンロードしたすべてのファイルを削除します。
キャンセルしたダウンロードは再開できません。

インストレーション オプション（Installation Options）

ダウンロードが完了したら、次のオプションを選択できます:
  • 今すぐインストール（Install now）: ダウンロードしたファイルをインストールします。
  • 後で通知（Remind me later）: ダウンロードしたファイルをインストールせず、後から実行を促すための通知メッセージを設定します。
  • このダウンロードを削除（Delete this download）: ダウンロードしたファイルをインストールせずに削除します （本機能は、ダウンロードしたファイルのインストールが無用となった場合に有効です）。

ﾀﾞｳﾝﾛｰﾄﾞ設定の変更

バックグラウンド ダウンローダーがファイルをダウンロードするフォルダーを変更します。

ダウンロードの実行中や一時停止中には、本オプションは利用できません。
更新チェックの間隔日数（Number of days between update checks）を指定することもできます。

アップデート チェック（Check for Updates）

SOLIDWORKS Installation Manager のアップデート チェック (Check for Updates)機能を実行します。

アップデートを自動的にチェック（Automatically Check for Updates）

アップデート チェック（Check for Updates）を定期的に実行し、アップデートがダウンロード可能な場合には通知します。

アップデート自動ダウンロード（Automatically Download Updates）

アップデート チェック（Check for Updates）を定期的に実行し、アップデートがダウンロード可能な場合には、それらをダウンロードします。

SOLIDWORKS バックグラウンド ダウンローダーの無効化と再有効化（Disabling and Re-Enabling SOLIDWORKS Background Downloader）

バックグラウンド ダウンローダーを無効にするには、Windows システム トレイのアイコンをクリックし、バックグラウンド ダウンローダー無効化（Disable Background Downloader）を選択します。

バックグラウンド ダウンローダーを再度有効にするには、スタート（Start） > SOLIDWORKS Installation Manager > SOLIDWORKS バックグラウンド ダウンローダー（SOLIDWORKS Background Downloader）をクリックします。

親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


Installation Manager のオプションの指定

これらのオプションには、ログ、インターネット アクセス、Installation Manager で使用する言語の設定が含まれます。

ソフトウェアをインストールする前に Installation Manager オプションを指定するには:

  1. Installation Manager でタイトルバーの SOLIDWORKS アイコンを右クリックし、次を選択します:
    オプション | 説明
    インストレーション ログ レベル ログ レベルを、高、中、または低に指定します。レベルが高いほど、トラブルシューティング用により多くのデータが収集されますが、インストールに時間がかかる場合があります。低（速い）がデフォルトで、パフォーマンスと安定性が最高になります。

    Windows インストーラー ログ作成（遅い）（Create Windows Installer Logs (Slow)）を使用すると、ログが他のインストール ログと同じフォルダに保存されます。
    アドミニストレーティブ イメージ オプション（Administrative Image Options） | 短いファイル名の使用（8.3 フォーマット）（Use short file names（8.3 format）） または フォルダとファイル名全体の使用（Use full folder and file names）を選択します。
    インストール ログの収集 | インストール・ログの保存場所を指定します。 これらのファイルは Installation Manager によって IM_Logs.zip に格納されます。
    インターネット アクセスを無効にする
    言語 | Installation Manager で使用する言語を指定します。 デフォルトは英語です。
  2. 閉じる（Close）をクリックします。
親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


アップデート チェックの結果（Check for Updates Results）

アップデート チェックは、SOLIDWORKS の最新バージョンを探します。

マシンの管理者権限があれば、アップデート チェック（Check for Updates） を手動で実行できます。
  • Windows で、スタート（Start） > SOLIDWORKS Installation Manager > アップデート チェック（Check for Updates）をクリックします
  • SOLIDWORKS で、 [image] > アップデート チェック（Check for Updates）をクリックします
アップデート チェックは、アドミニストレーティブ イメージからインストールしたクライアントでは利用できません。

利用可能な新しいバージョン

SOLIDWORKS Installation Manager は、より新しいバージョンの SOLIDWORKS 製品を検知します。 より新しいバージョンの SOLIDWORKS Installation Manager を選択することで、新しいバージョンに更新できます。

より新しいバージョンでは、インストレーションで指定した製品に基づいてインストレーション ファイルをダウンロードできます。 ダウンロードしたファイルは SOLIDWORKS Installation Manager を使用してインストールを行う他のユーザーと共有することができます。

これらのダウンロードは、SOLIDWORKS Installation Manager のみで利用できます。
次のオプションを利用できます。
  • 複数のバージョンが利用可能な場合、リストから選択できます。
  • このバージョンの詳細については、アップグレードに含まれるアイテムのチェック（Check to see what this upgrade includes）をクリックします。
次へ（Next） をクリックして、選択したバージョンの SOLIDWORKS Installation Manager を入手して実行します。

利用可能な新しいダウンロードはありません/新しいバージョンをチェックすることができません（No New Downloads Available/Unable To Check for New Versions）

SOLIDWORKS Installation Manager は SOLIDWORKS 製品の新しいバージョンを見つけられません。これは、利用可能な最新のバージョンがインストール済みであるか、または SOLIDWORKS のサイトに接続してチェックできなかったかのどちらかです。

親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


アドミニストレーティブ イメージ位置（Administrative Image Location）

アドミニストレーティブ イメージのインストール場所を指定します。

アドミニストレーティブ イメージの作成時は、以下のオプションが適用されます。
新規イメージ位置 | これは、SOLIDWORKS Installation Manager が新規イメージを作成するディレクトリ位置です。 | この位置には、既存のアドミニストレーティブ イメージを含められません。 アドミニストレーティブ イメージは、クライアント向けに共有可能なフォルダにある必要があります。
イメージ作成に必要なスペースの推定サイズ | これは、アドミニストレーティブ イメージに必要となる追加スペースです。 | インストール先のディスクにイメージの要件をサポートするのに十分な空きスペースがあることを確認してください。
イメージ作成元 | これは、SOLIDWORKS 製品のインストール元となるディレクトリ位置です。 このオプションは、インストールのみ（Install Only）オプションを指定した場合のみに表示されます。 詳細は、ダウンロード オプション（Download Options）を参照してください。
親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


ダウンロード オプション（Download Options）

ダウンロード ファイルの場所、ファイルをダウンロードする方法、ダウンロード ファイルをインストールするかどうかなど、ダウンロード処理を完了するための詳細を指定します。

SOLIDWORKS Installation Manager は 電子ソフトウェア配布 (ESD) をサポートします。 SOLIDWORKS DVD からインストールしない場合は、インストールする SOLIDWORKS 製品のソースを指定する必要があります。

ダウンロード フォルダに関する質問の答えについては、SOLIDWORKS Installation Manager ダウンロード フォルダ（SOLIDWORKS Installation Manager Download Folder）を参照してください。

何を行いますか?

次のいずれかを選択します。

ダウンロードとインストール/ダウンロードとイメージ作成

ダウンロードの完了後、SOLIDWORKS Installation Manager はダウンロード ファイルを使用してインストレーションを実行します。

ダウンロードのみ。 ダウンロードを 1 度行い、ダウンロード ファイルを複数コンピュータで共有できます。

SOLIDWORKS Installation Manager はダウンロードの完了後にインストレーションを実行しません。

通常、このオプションは複数のコンピュータ間で共有するインストレーション ファイル セットを構成するためにファイルをダウンロードする場合のみに指定します。

このオプションを指定すると、ダウンロードする 2 つのファイル セットからの選択を求められます。
  • 当コンピュータ用のファイル: ダウンロードには、現在コンピュータ上にあるインストレーション ファイル セットにないファイルのみが含められます。
    このダウンロードには以下が含まれるため、そのサイズは小さくなるはずです。
    • 製品選択ページで選択した製品のファイルのみ
    • コンピュータに必要な未インストールの前提条件ファイルのみ

    しかし、このダウンロード ファイル セットを別のコンピュータで使用してインストレーションを実行しようとすると、いくつかのファイルが見つからないかもしれません（なぜなら、別のコンピュータ上のインストレーション ファイル セットがこのコンピュータのものと異なる可能性があるからです）。 このダウンロード ファイルを使用して別のコンピュータへインストールすることは可能ですが、インストレーションの実行時に追加のファイルをダウンロードし、そのコンピュータのインストレーション ファイル セットを完全にする必要があるかもしれません。

  • 任意のコンピュータで共有できるファイル: ダウンロードには、このバージョンを任意のコンピュータにインストールするために使用できる完全なインストレーション ファイル セットが含まれます。

    このダウンロードには、このバージョンの任意の製品を任意のコンピュータにインストールするために使用できる完全なファイル セットが含まれているため、そのサイズは大きくなります。

    限られた製品セットをダウンロードするように指定している場合、このオプションはその指定を無視して製品リリースに含まれるすべての製品をダウンロードします。

    ダウンロードには、個人インストレーションを実行するために必要となるファイルだけでなく、アドミニストレーティブ イメージを作成するために必要となるすべてのファイルが含まれます。

インストールのみ/イメージ作成のみ。 必要なインストレーション ファイルは既にすべて持っています。

SOLIDWORKS Installation Manager はファイルをいっさいダウンロードしないで、選択したディレクトリにあるファイルを使用します。

参照（Browse）をクリックすると、別の場所にナビゲートできます。 たとえば、インストレーション DVD またはダウンロード フォルダに必要なファイルがすべて含まれている場合は、その場所を参照できます。

すべてのインストレーション ファイルがその場所にあると思われたのに、フォルダが不完全であるとするメッセージが表示される場合は、以下が考えられます。
  • 前にダウンロードされなかったインストーレーションのコンポーネントを選択したか、またはそのコンポーネントがデフォルトで選択された。
  • ファイルはシステム必要条件の異なる設定で別のコンピュータにダウンロードされた。
  • 以前はクライアント インストレーションを実行しており、今回は多くのファイル セットが必要となるアドミニストレーティブ イメージを作成している。

すべてのファイルを含むフォルダ（例えば、DVD）まで参照するか、またはダウンロード オプションのいずれかを選択できます。

必要なファイルをどこにダウンロードしますか?

これは、ダウンロード フォルダーの場所です。

場合によっては、このオプションが無効になった状態で表示されることもあります。 たとえば、インストールのみ（Install only）を指定した場合、SOLIDWORKS Installation Manager は個別のダウンロード フォルダを使用するのではなく、そのオプションに対して指定されたディレクトリのダウンロード ファイルをインストールします。

これらのファイルをダウンロードする場合、あるいは独自の位置からアクセスしている場合でも、すべてのファイルを同じダウンロード フォルダーにダウンロードする必要があります。

推定ダウンロード サイズ

推定ダウンロードの必要なディスク スペースは、これが新規のダウンロードであるか、または前のセッションからのダウンロードを再開しているかどうかにかかわらず、選択された完全なコンポーネント リストに基づいています。

たとえば、もし前回のダウンロードを再開している場合、SOLIDWORKS Installation Manager はダウンロードされなかったファイルだけを処理します。 ダウンロード時間は推定より短くなる可能性があります。

前回のダウンロードでファイルのダウンロードが完了している場合も、そのサイズは推定に含められません。したがって、推定は実際のダウンロード サイズよりも大きい可能性があります。

どのようにダウンロードしますか?

マニュアル ダウンロード実行

場合によっては、プロキシ サーバーによって SOLIDWORKS Installation Manager からの自動ダウンロードが禁止されていることもあります。

このオプションを選択することで、Web ページからファイルをマニュアルでダウンロードしてから SOLIDWORKS Installation Manager を続行し、インストレーション動作を完了できます。この Web ページは、インストレーションの完了に必要なファイルのみがダウンロードされるように SOLIDWORKS Installation Manager によってユーザー定義されます。

SOLIDWORKS バックグラウンド ダウンローダーの使用

ダウンロード処理の完全実行や、SOLIDWORKS のサービスパックがリリースされた際のダウンロードには、SOLIDWORKS バックグラウンド ダウンローダーを使用できます。

SOLIDWORKS バックグラウンド ダウンローダーでは、新しいサービスパックの検出とダウンロードをバックグラウンドで実行することが可能です。ダウンロードが完了し、ファイルのインストール準備が整うと通知されます。 詳細は、SOLIDWORKS バックグラウンド ダウンローダー（SOLIDWORKS Background Downloader）を参照してください。

親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


SOLIDWORKS Installation Manager ファイルのダウンロード オプション (Download Options for SOLIDWORKS Installation Manager Files)

より新しいバージョンの SOLIDWORKS Installation Manager をダウンロードします。 この画面で、ファイルをどこからどのようにダウンロードするかを指定します。

ダウンロード フォルダに関する質問の答えについては、SOLIDWORKS Installation Manager ダウンロード フォルダ（SOLIDWORKS Installation Manager Download Folder）を参照してください。

この画面はデフォルトのダウンロード フォルダーに問題がある場合のみに表示されます（例えば、書き込みアクセスまたはネットワーク アクセスを利用できない場合など）。通常、続行するには代替のダウンロード ディレクトリをただ指定するだけです。

ダウンロード ディレクトリ（Download Directory）

SOLIDWORKS Installation Manager ファイルの保存先まで参照します。

ダウンロード サイズと必要とされるスペースが表示されます。必要とされるスペースはある特定のダウンロードを圧縮解除するために必要とされる余分のスペースを含み、実際のダウンロードの大きさより大きくなります。

親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


製品のインストレーション ファイルをダウンロード（Download Product Installation Files）

指定された製品の欠けているファイルをどこで、どのように、ダウンロードするべきか指定してください。

SOLIDWORKS Installation Manager はすべてのファイルのダウンロード、検証、抽出を同時に行います。

このスクリーンをキャンセルすると、残りのインストレーション シーケンスもキャンセルされます。

キャンセルの影響や、中断されたインストレーションを完了するための手順は、インストレーション エラー/インストールのキャンセル（Installation Errors / Installation Cancelled）を参照してください。

ダウンロード ディレクトリ（Download Directory）

ダウンロード ファイルの保存先まで参照します。

ダウンロード サイズと必要とされるスペースが表示されます。必要とされるスペースはある特定のダウンロードを圧縮解除するために必要とされる余分のスペースを含み、実際のダウンロードの大きさより大きくなります。

ダウンロード フォルダーに関する質問の答えについては、SOLIDWORKS Installation Manager ダウンロード フォルダ（SOLIDWORKS Installation Manager Download Folder）を参照してください。

親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）
インストレーション エラー/インストールのキャンセル（Installation Errors / Installation Cancelled）
SOLIDWORKS Installation Manager ダウンロード フォルダ（SOLIDWORKS Installation Manager Download Folder）


ダウンロードの進捗状況（Download Progress）

このプロセスで、SOLIDWORKS Installation Manager はすべてのファイルのダウンロード、検証、抽出を同時に行います。

ダウンロードを実行中にキャンセルするにはキャンセルをクリックします。

ダウンロードをキャンセルするかまたはダウンロードに失敗すると、ダウンロード中止（Download Canceled）またはダウンロードの問題（Download Problem）画面にどのダウンロードが完了されていないかが表示され、ダウンロードを再開するかまたはアプリケーションを終了できるようになります。

ダウンロード フォルダに関する質問の答えについては、SOLIDWORKS Installation Manager ダウンロード フォルダ（SOLIDWORKS Installation Manager Download Folder）を参照してください。
親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


ダウンロード結果（Download Results）

ダウンロードが正常に終了したか、処理中に失敗したか、または中止されたかを示します。

ダウンロードの問題/ダウンロード中止（Download Problem/Download Cancelled）

ダウンロードの問題 は、SOLIDWORKS Installation Manager がダウンロードの完了を妨げる問題と遭遇した場合に表示されます。

ダウンロード中止（Download Cancelled）は、ユーザーがダウンロードが完了する前に中止した場合に表示されます。

続行するには、以下を行います。

自動ダウンロードの再試行/再開 | 中止した時点から自動ダウンロードを再開するには、このオプションを選択してダウンロードを再試行（Retry Download）またはダウンロードを再開（Resume Download）をクリックします。
Webブラウザで個々のファイルをダウンロード | 場合によっては、プロキシ サーバーによって SOLIDWORKS Installation Manager からの自動ダウンロードが禁止されていることもあります。 | このオプションを選択することで、Web ページからファイルをマニュアルでダウンロードしてから SOLIDWORKS Installation Manager を続行し、インストレーション動作を完了できます。 この Web ページは、インストレーションの完了に必要なファイルのみがダウンロードされるように SOLIDWORKS Installation Manager によってユーザー定義されます。

ダウンロード完了（Download Complete）

ダウンロード完了画面は、ダウンロードのみ（Download Only）オプションを指定した場合にダウンロードが完了すると表示されます。

終了 (Finish) をクリックし、SOLIDWORKS Installation Manager を終了します。

これらの製品のマニュアル インストールは試みないでください。 必ず SOLIDWORKS Installation Manager を使用してダウンロードしたファイルをインストールしてください。
親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


インストレーション エラー/インストールのキャンセル（Installation Errors / Installation Cancelled）

インストレーションでエラーが発生し、キャンセルされました。

エラーまたはキャンセルが発生した場合は:
  • エラーまたはキャンセルが発生する前にインストールされた製品はコンピュータに残ります。
  • エラーまたはキャンセルが発生した際にインストールされていた製品は、可能な場合はロールバックされ、部分的なインストレーションが残らないようにします。
  • 残りの製品はインストールされないか、またはアンインストールされます。まだ実行されていません（Not Yet Attempted）の下にリストが表示されます。

    これらの製品をインストールを再開するか、またはアンインストールするには、表示されたリンクをクリックします。

SOLIDWORKS Installation Manager はまずコンピュータにインストールされていない前提条件 (たとえば .NET Framework など) をインストールします。

目次

  • 失敗またはキャンセルされたインストレーションからの回復

    インストレーション中にエラーまたはキャンセルが発生した場合は、インストレーションを再実行することでその時点から回復できます。

  • インストールの修復（Repairing an Installation）

    もしインストールされた SOLIDWORKS 製品の問題があるならば、SOLIDWORKS インストール マネージャーをインストールを修復するために使うことができます。

  • 代理店までご連絡する場合（Contacting the SOLIDWORKS Reseller）

    インストレーションの変更/修復に失敗した場合は、この画面に表示される情報をお客様の SOLIDWORKS 代理店までご連絡ください。 SOLIDWORKS Installation Manager ログ ファイルの Zip ファイル提供が必要な場合があります。

親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


失敗またはキャンセルされたインストレーションからの回復

インストレーション中にエラーまたはキャンセルが発生した場合は、インストレーションを再実行することでその時点から回復できます。

  1. インストレーションが失敗した場合は、インストレーション エラー（Installation Errors）またはインストレーションのキャンセル（Installation Canceled）画面に表示されるエラー メッセージと製品コードを記録してください。
    既存の SOLIDWORKS インストレーションを変更していないときにソース ファイルに対するプロンプトが表示される場合は、インストレーションまたはコンピュータが破損している可能性があります。 お客様の代理店までご連絡ください。
  2. コンピューターを再起動します。
  3. Windows で SOLIDWORKS 製品が実行されていないことを確認するには、Ctr+Alt+Del キーを押してタスク マネージャーを開きます。
  4. プロセス タブで、次のいずれかのプロセスが イメージ名 に表示される場合、選択して プロセスの終了 をクリックします。
    • SLDWORKS.exe
    • EModelViewer.exe
    • PDMworks.exe
    • pdmwVault.exe
    • SWViewer.exe
    • swlmwiz.exe
    • SWBoengine.exe
    • SWVBAServer.exe
    • Sldshellextserver.exe
  5. アプリケーションが既にインストールされており、変更/削除する場合は、インストレーションの修復を試みます。詳細は インストールの修復(Repairing an Installation)を参照してください。
  6. Windows で、スタート（Start） > コントロール パネル（Control Panel） > プログラムと機能（Programs and Features）をクリックします。
  7. 失敗したバージョンの SOLIDWORKS を選択します。
    インストールする SOLIDWORKS のバージョンが表示されない場合は、インストレーション プロセスを繰り返してください。
  8. 次のいずれかを行います：
    • 再試行するには、変更 （Change）をクリックし、インストールに失敗した、あるいはインストレーション中にスキップされたすべての製品を選択します。

    • 失敗したインストレーションをスキップするには、変更 （Change）をクリックし、インストレーション中にスキップされたすべての製品を選択します。 インストールに失敗した製品を選択解除します。

    • インストレーションを中止するには、削除 （Remove）をクリックし、インストールされたすべての製品を選択します。
    このプロセスでは、アップグレードしていた製品の前バージョンまでは回復されません。
親トピック インストレーション エラー/インストールのキャンセル（Installation Errors / Installation Cancelled）
インストールの修復（Repairing an Installation）
代理店までご連絡する場合（Contacting the SOLIDWORKS Reseller）


代理店までご連絡する場合（Contacting the SOLIDWORKS Reseller）

インストレーションの変更/修復に失敗した場合は、この画面に表示される情報をお客様の SOLIDWORKS 代理店までご連絡ください。 SOLIDWORKS Installation Manager ログ ファイルの Zip ファイル提供が必要な場合があります。

  1. ログ ファイルを探します。 Windows の場合:
    C:\Users\ユーザー名\AppData\Roaming\SOLIDWORKS\Installation Logs\installed_version\をクリックします。
    フォルダーが見つからない場合は、隠しフォルダーになっている場合があります。ファイル エクスプローラで、ツール（Tools） > フィルタ オプション（Folder Options）をクリックします。表示（View）タブの詳細設定（Advanced Settings）で、ファイルとフィルタの表示（Hidden files and folders）の隠しファイル、隠しフィルタ、および隠しドライブを表示する（Show hidden files, folders, and drives）を選択します。
  2. サブフォルダを含め、このフォルダの内容全体を Zip 圧縮します。
親トピック インストレーション エラー/インストールのキャンセル（Installation Errors / Installation Cancelled）
失敗またはキャンセルされたインストレーションからの回復
インストールの修復（Repairing an Installation）


インストレーション完了（Installation Is Complete）

SOLIDWORKS Installation Manager は、その処理を完了しました。

以下の1つまたは複数のオプションが表示されるかもしれません。

新機能（What's New）

個人インストレーションの場合は、インストレーション手順を完了した際に、SOLIDWORKS とアドイン製品の新機能を説明するドキュメントが表示されます。

アドミニストレーティブ イメージ インストレーションの場合は、クライアントがインストレーションを完了した際に、クライアントのコンピュータ上にドキュメントが表示されます。

SOLIDWORKS ユーザー パフォーマンス フィードバック プログラム (Join the SOLIDWORKS Customer Experience Improvement Program)

パフォーマンス インフォメーションが、製品改善の手助けの為に SOLIDWORKS Corporation に送られます。このプロセスでは透明性と機密情報が確保されます。次のいずれかのオプションを選択します:
  • はい、参加します（Yes, I want to join）
  • いいえ、参加しません（No, thank you）
  • 後で通知（Remind me later）
詳細については、ユーザー パフォーマンス フィードバック プログラム Web サイトを参照してください。

アドミニストレーティブ イメージの作成が完了しました（Administrative Image Creation Is Complete）

アドミニストレーティブ イメージの作成が完了したら、イメージのカスタマイズ（Customize Image）をクリックすることによりアドミニストレーティブ イメージ オプション エディタを起動し、イメージをカスタマイズすることが可能です。

オプション エディタの使用方法を表示するには、クライアントにイメージをインストールする方法を表示します。（Show me how to install this image on a client.）をクリックしてください。

オプション エディタを使用してアドミニストレーティブ イメージを設定する方法の詳細については、アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）を参照してください。

アドミニストレーティブ イメージ オプション エディタを起動し、アドミニストレーティブ イメージに対するオプション設定をカスタマイズするには、イメージのカスタマイズ（Customize Image）をクリックします。
オプション エディタを後で起動するには、 SOLIDWORKS Admin フォルダにある sldAdminOptionEditor.exe をダブルクリックします。

目次

  • SOLIDWORKS に対するアップデート チェック（Checking for Updates to SOLIDWORKS）

    マシンの管理者権限を持つユーザーは、SOLIDWORKS Installation Manager を使用し、マニュアルでアップデートをチェックするか、またはアップデートの定期的な自動チェックを設定できます。

  • SOLIDWORKS ユーザー パフォーマンス フィードバック プログラム（SOLIDWORKS Customer Experience Improvement Program）

    SOLIDWORKS のインストール時には、SOLIDWORKS Corporation にパフォーマンス情報を送信し製品改良に役立てることが選べます。

親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）
アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）


SOLIDWORKS に対するアップデート チェック（Checking for Updates to SOLIDWORKS）

マシンの管理者権限を持つユーザーは、SOLIDWORKS Installation Manager を使用し、マニュアルでアップデートをチェックするか、またはアップデートの定期的な自動チェックを設定できます。

  1. 次のいずれかを実行して SOLIDWORKS Installation Manager を開始します:

    • SOLIDWORKS アプリケーションで、ヘルプ（Help） > アップデート チェック（Check for Updates）をクリックします。

    • Windows で、スタート（Start） > プログラム（Programs） > SOLIDWORKS Installation Manager > アップデート チェック（Check for Updates）をクリックします。

    スタート（Start） > SOLIDWORKS Installation Manager > SOLIDWORKS バックグラウンド ダウンローダー（SOLIDWORKS Background Downloader）をクリックすることもできます。Windows の通知領域で、SOLIDWORKS バックグラウンド ダウンローダー（SOLIDWORKS Background Downloader）を右クリックして、アップデート チェック（Check for Updates）をクリックします。
    SOLIDWORKS Installation Manager は利用できるアップデートがあるかどうかを通知します。
  2. 利用できるアップデートがある場合は、ダウンロードしてインストールするかどうかを選びます。
  3. 定期的な自動アップデート チェックを有効にするには、SOLIDWORKS Installation Manager がそのプロセスを完了したときに ___日毎に更新をチェックします (Check for Updates every __ days) を選択し、チェックの頻度を指定します。
親トピック インストレーション完了（Installation Is Complete）
SOLIDWORKS ユーザー パフォーマンス フィードバック プログラム（SOLIDWORKS Customer Experience Improvement Program）


SOLIDWORKS ユーザー パフォーマンス フィードバック プログラム（SOLIDWORKS Customer Experience Improvement Program）

SOLIDWORKS のインストール時には、SOLIDWORKS Corporation にパフォーマンス情報を送信し製品改良に役立てることが選べます。

SOLIDWORKS はこの情報を製品の使用と品質の評価の傾向を確定するために使用します。 パフォーマンス ログは、最も高品質な製品を提供するために役立ちます。

このプロセスでは透明性が確保されています。ログ ファイルに含まれるすべての情報は機密情報として扱われます。その他の目的で使用されることは無く、お客様に連絡が入ることもありません。

詳細については、ユーザー パフォーマンス フィードバック プログラム Web サイトを参照してください。

親トピック インストレーション完了（Installation Is Complete）
SOLIDWORKS に対するアップデート チェック（Checking for Updates to SOLIDWORKS）


インストール先（Installation Location）

アドミニストレーティブ イメージの作成を除いて、インストレーションには以下のオプションが適用されます。
選択製品を次へインストールします | これは、SOLIDWORKS をインストールするディレクトリの場所です。 インストレーションのアップグレードまたは変更時には、すべてのファイルをそのインストレーションの既存の場所にインストールする必要があります。この場合、既存の SOLIDWORKS インストレーションの場所は変更できません。
インストレーションに必要なスペースの推定サイズ | これは、インストレーションまたは変更のために選択された製品に対して必要となる追加スペースです。 | インストール先のディスクにインストレーションの要件をサポートするのに十分な空きスペースがあることを確認してください。
インストール元 | これは、SOLIDWORKS のインストール元となるディレクトリ位置です。 このオプションは、インストールのみ（Install Only）オプションを指定した場合のみに表示されます。詳細は、ダウンロード オプションを参照してください。
どちらの SOLIDWORKS インストール位置についても変更する前に、システム管理者に相談してください。

アドミニストレーティブ イメージの位置（Administrative Image Locations）

アドミニストレーティブ イメージの作成時は、以下のオプションが適用されます。
新規イメージ位置 | これは、SOLIDWORKS Installation Manager が新規イメージを作成するディレクトリ位置です。 | この位置には、既存のアドミニストレーティブ イメージを含められません。
イメージ作成に必要なスペースの推定サイズ | これは、アドミニストレーティブ イメージに必要となる追加スペースです。 | インストール先のディスクにイメージの要件をサポートするのに十分な空きスペースがあることを確認してください。
イメージ作成元 | これは、SOLIDWORKS 製品のインストール元となるディレクトリ位置です。 このオプションは、インストールのみ（Install Only）オプションを指定した場合のみに表示されます。詳細については、「ダウンロード オプション（Download Options）」を参照してください。
既存イメージ位置 | 既存のアドミニストレーティブ イメージをアップグレードするとき、SOLIDWORKS Installation Manager は既存のイメージの設定に基づいて新規イメージを作成します。この既存のイメージは変更されません。これは、ようこそ画面で指定した元のイメージの場所を示します。

特定のバージョンのディレクトリ パスの使用回避（Avoid Using Version-Specific Directory Paths)

インストレーション ディレクトリの位置にバージョン番号を指定してから（たとえば、C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS 2023\）、このインストレーションを SOLIDWORKS 2024 にアップグレードすると、SOLIDWORKS 2024 のインストレーション ディレクトリに SOLIDWORKS 2023 というラベルが付きます。

親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）
ダウンロード オプション（Download Options）


更新オプション（Upgrade Options）

このコンピュータには 1 つまたは複数の古い SOLIDWORKS メジャー バージョンがインストールされています。 新規インストレーションを作成して、古いバージョンと共存させることも、アップグレードして古いバージョンを削除することもできます。

SOLIDWORKS version の新規インストレーションを作成します。

新規インストレーションを作成する場合は、インストールする SOLIDWORKS 製品を選択できます。

選択した製品ごとに、このメジャー バージョンの新規インストレーションが作成されます。 古いメジャー バージョンは、SOLIDWORKS Electrical と SOLIDWORKS PDM Client を除き、マシン上に残ります。

製品を選択解除すると、その新しいバージョンはインストールされません。

新規インストレーションの作成は、新しいバージョンのインストール後も古いバージョンの SOLIDWORKS にアクセスしたい場合に役立ちます。 たとえば、古いバージョンを実行し続けている他のユーザーとファイルを共有する場合、新しいバージョンを使用して保存したファイルのバージョンの互換性の問題を回避できます。

SOLIDWORKS previous_major_version を SOLIDWORKS current_major_version にアップグレード

アップグレードする場合は、アップグレードする SOLIDWORKS 製品を選択できます。 選択した製品ごとに、新規インストレーションが作成され、古いバージョンが削除されます。

製品を選択解除すると、その新しいバージョンはインストールされず、マシンには古いバージョンが残ります。

SOLIDWORKS Electrical と SOLIDWORKS PDM Client の考慮事項

1 つのマシンにインストールできる SOLIDWORKS Electrical のバージョンは 1 つだけです。 SOLIDWORKS の新規インストレーションを作成している場合、インストールする製品の 1 つとして SOLIDWORKS Electrical を選択したときは、古いバージョンの SOLIDWORKS Electrical は削除されます。

新しいバージョンをインストールする前に、既存の SOLIDWORKS Electrical 環境をバックアップしてください。 SOLIDWORKS Electrical Schematic 内からファイル（File）アーカイブ環境（Archive Environment）を選択するか、SOLIDWORKS Electrical 3D 内から SOLIDWORKS Electrical > ツール（Tools） > アーカイブ環境（Archive Environment）を選択します。

SOLIDWORKS PDM Client のメジャー バージョンは SOLIDWORKS PDM Server のメジャー バージョンと一致させる必要があります。 SOLIDWORKS PDM Server をアップグレードするつもりがない場合は、アップグレードで SOLIDWORKS PDM Client を選択しないでください。

Windows で製品を削除するには、プログラムの追加と削除（Add/Remove Programs）を使用します。詳細は、インストレーションの削除（Removing an Installation）を参照してください。
親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）
インストレーションの削除（Removing an Installation）


インストールの進行状況（Installation Progress）

この画面にはインストレーションの進捗状況が表示されます。

インストレーションの開始後にキャンセルするには、キャンセル（Cancel）をクリックします。

キャンセルの影響や、中断されたインストレーションを完了するための手順は、インストレーション エラーを参照してください。

親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


インストレーション タイプ（Installation Type）

実行するインストール操作を指定できます。 たとえば、新規インストレーションの作成、既存インストレーションの変更または修復、アドミニストレーティブ イメージの作成、アドミニストレーティブ サーバー製品のインストール、ファイルのダウンロードなどを行い、他のコンピュータで共有およびインストールできるようにします。

SOLIDWORKS ソフトウェアの最新のリリース版が既にコンピュータにインストールされている場合、それを修正または修復するオプションが表示されます。

個人（Individual）

SOLIDWORKS 製品をこのコンピュータへインストールします。

このオプションは、このバージョンが現在このコンピュータにインストールされていない場合のみに表示されます。

個人インストレーションの変更（Modify the Individual Installation）

既存の SOLIDWORKS インストレーションをこのコンピュータ上で変更します。

このオプションは、このバージョンがこのコンピュータにインストールされている場合のみに表示されます。
変更には以下が含まれます。
  • SOLIDWORKS 製品コンポーネントの追加または削除
  • 異なる SOLIDWORKS パッケージへの変更（たとえば、SOLIDWORKS Professional、SOLIDWORKS Premium、SOLIDWORKS Ultimate など）
  • SOLIDWORKS シリアル番号設定の変更
    前回のインストレーションで SOLIDWORKS シリアル番号を既に指定している場合、SOLIDWORKS Installation Manager ではシリアル番号の指定を求められないことがあります。シリアル ナンバーを変更するには、このオプションを選択する必要があります。

個人インストレーションの修復（Repair the Individual Installation）

既存の SOLIDWORKS インストレーションをこのコンピュータ上で修復します。

このオプションは、このバージョンがこのコンピュータにインストールされている場合のみに表示されます。
修復は、すべてのファイルが存在し、正しく登録されていることを確認し、見つかった問題を修正します。 ユーザーが作成したデータは影響されません。
  • 特定の製品を修復する場合、その製品が選択されていることを確認してください。
  • 修復しない製品は選択解除してください。
個人インストレーションは修復できます。アドミニストレーティブ イメージ インストレーションは修復できません。アドミニストレーティブ イメージを使用して再インストールする必要があります。

アドミニストレーティブ イメージ

アドミニストレーティブ イメージを作成または更新し、複数のコンピュータに展開します。

アドミニストレーティブ イメージを使用して複数のクライアントに SOLIDWORKS をインストールする方法については、アドミニストレーティブ イメージの使用を参照してください。

アドミニストレーティブ イメージを作成またはアップデートするときは、以下を行えます。
  • 既存イメージのインストレーション設定を使用し、新規またはアップデートされたイメージを設定するか、デフォルトの SOLIDWORKS インストレーション設定を使用できます。
  • 既存のイメージをアップデートする場合:
    • アップデートする場合も、SOLIDWORKS Installation Manager はイメージの新規コピーを作成します。 元のイメージは変更されません。
    • アップデートする既存のイメージのファイルを使用し、アップデートされたイメージを作成できます。この結果、ダウンロード サイズが小さくなります。
    以前のイメージをアップデートするためにServicePackリリースを利用できるイメージを指定しなかった場合、サイズの小さいダウンロードを利用することはできません。

サーバー製品

SOLIDWORKS サーバー製品には、SOLIDWORKS Electrical、SOLIDWORKS PDM と SolidNetWork License Manager が含まれます。

SOLIDWORKS Electrical と SOLIDWORKS PDM については、クライアント ツールとサーバー ツールを同じコンピュータにインストールするか、別々のコンピュータにインストールするかを選べます。

これらのサーバーのインストールについての詳細は、ヘルプで対応するトピックを参照してください。

すべてのファイルをダウンロードして共有します

製品をインストールしないで、選択した SOLIDWORKS 製品のインストレーション ファイルをダウンロードします。

このオプションは DVD からインストレーションを行っているときは表示されません。
ダウンロード ファイルの内容は、SOLIDWORKS インストレーション DVD で利用できるファイルと同じものです。 このオプションを選択すると、どのファイルが既にコンピュータにインストールされているかにかかわらず、インストール ファイルの完全なセットがダウンロードされます。 その後、ファイルをポータブル デバイスまたはネットワーク ディレクトリにコピーし、それらを使用して他のコンピュータに SOLIDWORKS ソフトウェアをインストールすることができます。 またこの方法を使用してサーバーをセット アップし、このサーバーからユーザーはインストレーションを実行できます。
この方法は、アドミニストレーティブ イメージの作成とは異なります。
親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）
アドミニストレーティブ イメージの使用（Using Administrative Images）
SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）
SOLIDWORKS Electrical


複数コンピュータのインストールと管理（Installing and Managing Multiple Computers）

SOLIDWORKS Installation Manager は、複数の SOLIDWORKS コンピュータのインストールと管理のために次のツールを提供します。

SOLIDWORKS アドミニストレーティブ イメージ（SOLIDWORKS Administrative Images）

SOLIDWORKS を複数コンピュータにインストールする場合は、アドミニストレーティブ イメージを作成し、アプリケーションを他のコンピュータで展開できます。

SOLIDWORKS PDM

SOLIDWORKS PDM は、SOLIDWORKS Enterprise PDM と同じクライアント/サーバー アーキテクチャに基づくドキュメント管理製品です。 次の 2 つのバージョンで使用できます。 Standard および Professional。 SOLIDWORKS PDM は Microsoft SQL Server データベースを使用してファイル ボルトを管理します。

SolidNetWork License Manager

SolidNetWork License Managerでは、ライセンスの使用をフロートすることにより、実際のライセンス数よりも多数のユーザーを許可します。 使用されていないクライアント ライセンスは、他の SOLIDWORKS ユーザーが使用できます。

また、SolidNetWork License Manager を使用し、SOLIDWORKS コア アドイン製品（たとえば、FeatureWorks）のライセンスを配布できます。

親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


マニュアル ダウンロード（Manual Download）

ファイルを手動操作でダウンロードすることを選択しました（または最後に SOLIDWORKS Installation Manager を実行したときに手動操作でダウンロードすることを選択しました）。

リンクをクリックし、ダウンロードを完了するために必要なファイルの完全なリストを含む自動生成されたWebページを開きます。

サマリー ページで指定したフォルダーにダウンロードする必要があります。インストレーションは、すべてのファイルがフォルダーにダウンロードされるまで開始できません。

マニュアル ダウンロードを終えたら、次へ（Next）をクリックして続行します。

自動的にダウンロードしたい場合は、サマリー ページに戻ってダウンロード オプションを変更することでオプションを変更できます。

親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


利用可能なより新しいバージョン（Newer Version Available）

Installation Manager は、より新しいバージョンの SOLIDWORKS 製品を検知します。 オリジナルのインストレーションDVDまたはダウンロードに含まれるバージョンのインストールを選択できます。または、新しいバージョンをダウンロードしてインストールすることを選ぶことも可能です。

ダウンロードからインストールする場合（If You Are Installing from a Download）

次のいずれかを選択します。
  • versionのインストールを続行します（Continue installing）。

    初回ダウンロードに含まれるバージョンのインストールを続行する場合は、このオプションを選択します。

  • 新しいバージョンのダウンロードとインストール（Download and install a new version）: version。

    新しいバージョンをダウンロードしてインストールする場合は、このオプションを選択します。 複数の新しいバージョンがある場合は、ダウンロードしてインストールするバージョンを選択できます。

DVDからインストールする場合（If You Are Installing from a DVD）

より新しいバージョンを使用しますか? (Would you like to use the newer version?) で以下のいずれかを選択します。
  • いいえ、この DVD からの version のインストールを継続します。 その後で更新することができます。（No, continue installing version from this DVD. You can update afterwards.）

    このオプションは、現在のInstallation Managerを使用してインストレーションを続行する場合に選択します。

    インストレーションが完了した後は、Installation Managerを使用してアップデートをチェックしてインストールすることができます。 アップデートをチェックするには、スタート（Start） > SOLIDWORKS Installation Manager > アップデート チェック（Check for Updates）を実行します。
    マシンの管理者権限を持つユーザーのみ、アップデート チェック（Check for Updates）を使用できます。

    この場合の利点は、ダウンロードが最小限になることです。 不利な点は、これが 2 ステップの過程になり、ダウンロードしたファイルが特定のバージョン用になる点です（他のバージョンを使用しているユーザーと共有はできません）。

  • はい、このDVDを使用してインストールを行います。続いて、ダウンロードして次までのアップデートを行います version（Yes, perform installation using this DVD, then download and update to version）

    SOLIDWORKS　製品の最新のバージョンをインストールするために、このオプションを選択し、最新のバージョンの Installation Manager をダウンロードして起動します。

    小さな ServicePack リリースを利用して DVD バージョンをアップデートできる場合、Installation Manager は DVD から元のバージョンをインストールし、次に ServicePack アップデートを適用します。 この結果、ダウンロード サイズが小さくなります。

    DVDからインストールを続行するオプションを選択してから、後日アップデートを適用しても同じ結果を得られます。

    このオプションの利点は、これが1ステップの過程であることです。

親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


利用可能な新しいバージョンはありません（No New Versions Available）

ダウンロードできる利用可能なより新しいバージョンはありません。指定されたバージョンのインストールを開始してください。

インストレーションを続けるには次へ（Next）をクリックします。

親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


検出されたプロセス（Processes Detected）

SOLIDWORKS Installation Manager は正常なインストレーションを妨げる可能性のあるプロセスを検出しました。

  • インストレーションを続行するには、以下のいずれかを行います。
    • 例えば、Microsoft Windowsタスク マネージャを使用してプロセスを終了してから、再試行（Retry）をクリックします。
    • 無視（Ignore）をクリックし、プロセスを終了しないまま続行します。
  • インストレーションを中止するには、キャンセル（Cancel）をクリックします。
親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


製品選択（Product Selection）

インストール、変更、ダウンロード、または削除する製品コンポーネントを指定できます。

製品リストは以下のようになります。
  • 製品リストは、製品リスト上で指定されたパッケージで利用できる製品の完全なリストです。
  • 特定のコンポーネントに対して計画された動作を確認するには、コンポーネント名（チェックボックスではなく）をクリックします。 製品リストの下部にある情報フィールドに意図されたインストール動作が表示されます。
  • 製品コンポーネントに対するインストール動作を変更するには、コンポーネントの隣にあるチェックボックスをクリックします。 （たとえば、コンポーネントのインストールや削除を行っている場合は、チェックボックスを選択すると対応するコンポーネントがインストールまたは削除の対象となり、チェックボックスの選択を解除すると対応するコンポーネントがインストールまたは削除の対象から外れます。）
  • インストレーションの変更を行っている場合、製品選択で変更を行うとアスタリスク（*）がコンポーネントの左に表示されます。
  • コンポーネント内にサブコンポーネントがある場合には、コンポーネントの隣に + アイコンが表示されます。 利用可能なサブコンポーネントを確認するには、+ アイコンをクリックしてください。
  • コンポーネントが展開されサブコンポーネントが表示されている場合は、コンポーネントの隣に - アイコンが表示されます。 サブコンポーネントへの展開を解除するには、- アイコンをクリックしてください。

ServicePack を適用している場合、SOLIDWORKS の下に表示される FeatureWorks などの SOLIDWORKS 機能は選択できません。 これは、このタイプの更新を行う時に、機能の追加/削除ができないためです。

SOLIDWORKS Installation Manage は製品の共存ルール（product coexistence rules）に従って機能します。詳細は、製品の共存ルール（Product Coexistence Rules）を参照してください。

SOLIDWORKS Installation Manager は以下の製品をデフォルトで選択します。
  • アップグレードまたは Service Pack アップデートを実行している場合、SOLIDWORKS Installation Manager は現在インストールされている製品を選択します。
  • そうでない場合、SOLIDWORKS Installation Manager は権限のあるすべての製品を選択します。
インストレーションまたはダウンロードの時間と必要なディスク スペースを減らすために、製品コンポーネントを展開して不要なコンポーネントのチェック ボックスを選択解除します。

SOLIDWORKS Installation Manager が、権限のある製品を確認できない場合、別のパッケージ/製品の選択（Select different packages or products）をクリックして、インストールまたは変更する製品のパッケージ（SOLIDWORKS Professional、SOLIDWORKS Premium、SOLIDWORKS Ultimate など）のリストを変更できます。SOLIDWORKS Installation Manager は、選択するパッケージと互換性があるすべての インストレーションメディア上の SOLIDWORKS 製品をリストします。購入した、または評価する権限のある任意の製品を選択できます。

SOLIDWORKS 検索

SOLIDWORKS 検索機能は、SOLIDWORKS ドキュメントの強力な全文検索を提供します。検索機能は、プレビューとファイルの場所と名前を示します。

インストレーションの後で、SOLIDWORKS 検索は、より速い検索のために SOLIDWORKS ドキュメントにインデックスを付けます。 デフォルトでは、SOLIDWORKS ファイルのインデックス ファイルのみが作成されます。

言語サポート（Language Support）

SOLIDWORKS 製品と 言語 コンポーネントを展開し、インストール可能な言語版を表示します。

言語（Languages）仕様はインストールされる言語を SOLIDWORKS 製品でのみ限定します。その他の製品のインストレーションはこの仕様では影響されません。たとえば、eDrawings® および SOLIDWORKS PDM ではすべての言語がインストールされます。

必要なスペース（Space Needed）

SOLIDWORKS Installation Manager はページの一番下に合計のインストレーション サイズ、あるいは、合計のダウンロード サイズを表示します。

  • ダウンロードのみ （Download Only）オプションを選択した場合は、ダウンロード サイズが表示されます。ダウンロード サイズは、ダウンロードされたすべてのファイルで必要とされるディスク スペースの合計量です（ダウンロード完了後の解凍に必要な追加のスペースは含まれません）。この数字は推定です。
    インストレーションに必要なすべてのファイルは、合計のダウンロード サイズに含まれます。一部のファイルが既に現在のダウンロード フォルダにダウンロードされている場合、それらのファが再度ダウンロードされることはありません。結果として、実際のダウンロード サイズは表示された合計サイズより小さくなることがあります。または、まったくファイルのダウンロードが必要ないときもあります。
  • そうでない場合、インストレーション サイズ(installation size)が表示されます。 インストレーション サイズは、このインストレーションを完了したときに生じるディスク スペース使用量で変わります。 ファイル圧縮のため、これらの数字は推定です。

    既存のインストレーションをアップグレード、または削除する場合、インストレーション サイズは0（ゼロ）になります。

    表示される数字は、インストレーションに必要である場合もファイルをダウンロードする、または解凍するために必要なスペースを含みません。

    ダウンロードが必要で、同じドライブにダウンロードしている場合、実際に必要とされるディスク スペースは表示されるインストレーション サイズよりも著しく大きくなります。

    将来の更新作業でのダウンロード時間、またはインストレーション時間を減らすために、インストレーションのあとのダウンロード ファイルを削除しないでください。 一般に、次の更新作業とパッチを当てる作業は前回の完全なインストレーション ファイル セットにアクセスすることが必要です。

親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）
製品の共存ルール（Product Coexistence Rules）


ダウンロードする製品（Products to Download）

指定された場所にダウンロードするように SOLIDWORKS 製品を選択します。

ダウンロードで利用可能な製品は与えられたシリアルナンバーによって決まります：

  • 各コンポーネントに対して行われるアクションは、各項目の右側に表示されます。
  • コンポーネント内にサブコンポーネントがある場合には、コンポーネントの隣に + アイコンが表示されます。 利用可能なサブコンポーネントを確認するには、+ アイコンをクリックしてください。
  • コンポーネントが展開されサブコンポーネントが表示されている場合は、コンポーネントの隣に - アイコンが表示されます。 サブコンポーネントへの展開を解除するには、- アイコンをクリックしてください。
  • 各コンポーネントの左にあるチェックボックスをクリックし、SOLIDWORKS Installation Manager が行う処理を指定します。
指定しない場合、SOLIDWORKS Installation Manager は使用権があるすべての製品のコンポーネントをダウンロードします。ダウンロード時間と必要なディスク スペースを減らすために、製品コンポーネントを展開し、ダウンロードする必要のないコンポーネントを指定します。

SOLIDWORKS Installation Manager が権限のある製品を確認できない場合、SOLIDWORKS パッケージをダウンロードするように選ぶことができます。 SOLIDWORKS Installation Manager は、選択するパッケージと互換性があるすべての SOLIDWORKS 製品をリストします。

SOLIDWORKS Installation Manager が、権限のある製品を確認できない場合、別のパッケージ/製品の選択（Select different packages or products）をクリックして、インストールまたは変更する製品のパッケージ（SOLIDWORKS Professional、SOLIDWORKS Premium、SOLIDWORKS Ultimate など）のリストを変更できます。SOLIDWORKS Installation Manager は、選択するパッケージと互換性があるすべての インストレーションメディア上の SOLIDWORKS 製品をリストします。購入した、または評価する権限のある任意の製品を選択できます。

言語サポート（Language Support）

言語 (Languages)仕様はインストールされる言語を SOLIDWORKS 製品でのみ限定します。 その他の製品のインストレーションはこの仕様では影響されません。 たとえば、eDrawings® ではすべての言語版がインストールされます。

必要なスペース（Space Needed）

選択する製品に基づいて、ダウンロードを行なうために必要なスペースが表示されます。 ダウンロード サイズはすべてのダウンロードされたファイルの必要とするディスク スペースの合計です（ダウンロード完了後の解凍に必要な追加のスペースは含まれていません）。 この数字は推定です。

将来の更新やパッチを当てる作業でダウンロード時間、またはインストレーション時間を減らすために、インストレーションのあとのダウンロード ファイルを削除しないでください。 一般に、次の更新作業とパッチを当てる作業は前回の完全なインストレーション ファイル セットにアクセスすることが必要です。
親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


修復する製品（Products to Repair）

このインストレーションを修復 (Repair this installation) を指定すると、画面にはこのバージョンの SOLIDWORKS Installation Manager で修復可能な SOLIDWORKS 製品とバージョン番号が表示されます。

修復は、すべてのファイルが存在し、正しく登録されていることを確認し、見つかった問題を修正します。ユーザーが作成したデータは影響されません。
  • 特定の製品を修復する場合、その製品が選択されていることを確認してください。
  • 修復しない製品は選択解除してください。

修復（Repair）をクリックし、選択した製品の修復を開始します。

個人インストレーションは修復できます。アドミニストレーティブ イメージ インストレーションは修復できません。アドミニストレーティブ イメージを再インストールする必要があります。
親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


シリアル番号（Serial Numbers）

購入した SOLIDWORKS 製品にコンピュータが、シリアル番号によって関連付けられます。

SOLIDWORKS 製品が既にコンピュータにインストールされている場合は、それらの製品のシリアル番号がデフォルトで表示されます。
  • 表示されない場合、SOLIDWORKS シリアル番号を入力してください。
  • SOLIDWORKS ライセンスに含まれていない製品のシリアル番号がある場合は、適切なフィールドに入力します。

インターネットに接続している場合、インストレーション プロセスを進めると、入力したシリアル番号によって権利を得た製品が決まります。

SOLIDWORKS 製品を購入するには複数の方法があるため、一部のシリアル番号は複数の製品に対応している場合があります。 たとえば、 SOLIDWORKS シリアル番号は、個々の SOLIDWORKS Simulation シリアル番号を入力しないで SOLIDWORKS Simulation のインストールを可能にします。 また、一部の製品はシリアル番号を必要としません。 シリアル番号に関する質問は、お客様の代理店までご連絡ください。

親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


サーバー インストール（Server Installation）

インストールを試みているサーバー製品が、インストレーションの結果と共に表示されます。

サーバー インストレーション ステータス（Server Installation Status）

サーバー製品のインストレーションは、外部インストレーション アプリケーションによって実行されます。このアプリケーションを開いていない場合はインストレーションを完了するため、このアプリケーションに切り替える必要があります。

サーバー製品のインストレーションを中止するには、キャンセル（Cancel）をクリックします。

サーバー インストレーション完了（Server Installation Complete）

外部インストレーション アプリケーションは正常に終了しました。

終了 あるいは 次へをクリックします。
  • その他のアドミニストレーティブ製品をインストールする場合（たとえば、SOLIDWORKS アドミニストレーティブ イメージ）、そのインストレーションが続きます。
  • インストレーション作業がサーバー製品のインストレーションのみの場合、SOLIDWORKS Installation Manager は閉じられます。

サーバー インストレーションのキャンセルまたは失敗（Server Installation Cancelled or Failed）

サーバー製品のインストレーションが失敗したか、開始後にキャンセルされた場合、インストールが完了しなかったサーバーがリストに表示されます。

閉じる あるいは 次へをクリックします。
  • 別のアドミニストレーティブ製品のインストレーションが指定されている場合、SOLIDWORKS Installation Manager は再開されます。
  • インストレーション作業がサーバー製品のインストレーションのみの場合、SOLIDWORKS Installation Manager は閉じられます。

詳しい情報

SolidNetWork License Manager のインストール、構成、使用の詳細については、SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）を参照してください。

親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


サマリー（Summary）

SOLIDWORKS Installation Manager には、インストレーション作業を完了するために必要な情報がすべてあります。

続行するには: | 今すぐアクションをクリックしてインストレーション作業を開始します（たとえば、今すぐインストール（Install Now）、今すぐ作成（Create Now）、すぐにダウンロード（Download Now）、今すぐ変更（Modify Now））。
インストレーション設定を変更するには: | 変更するセクションに対して変更（CHANGE） [image] をクリックします（たとえば、製品（Products）、インストレーション先（Installation Location）、Toolbox オプション（Toolbox Options））。
キャンセルするには: | インストレーション コンポーネントを変更せずに SOLIDWORKS Installation Manager を終了するには、キャンセルをクリックします。
前のページに戻るには: | SOLIDWORKS Installation Manager の前のページに戻るには、戻るをクリックします。
特定のインストレーション オプション セット（たとえば、製品、インストール先、Toolbox オプション など）の情報については、以下を行います。
  1. 情報が必要なセクションの横にある変更（CHANGE） [image] をクリックします。
  2. 表示される詳細ページでヘルプをクリックし、これらのインストレーション オプションの設定に関する情報を入手します。
親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


システム チェックの警告（System Check Warnings）

システム チェックは、インストレーションの継続に影響する可能性のある問題を報告します。 ほとんどの場合は、SOLIDWORKS Installation Manager を続行できるはずです。

下記にこの段階で遭遇する可能性のある警告を解決方法と共に一覧します。

シリアル番号検証に関する問題

シリアル番号の検証ができなかったので、InstallationManagerは新しいバージョンをチェックすることができませんでした。 接続しており、正しいシリアル番号を入力している場合は、ご使用のサーバーの一時的な問題である可能性があります。 後でまた試してみてください。

シリアル番号認証: InstallationManager は使用権をお持ちの製品を自動的に確定するために必要なシリアル番号の認証ができませんでした。インストールする製品を選ぶことはできますが、インストレーション ファイルをダウンロードすることはできません。インストールするためにはダウンロード ソース ファイルの全セットか DVD が必要です。

解決策:
  • インターネットの接続を確認してください。シリアル番号のチェックには、有効なインターネット接続が必要です。
  • 入力したシリアル番号が、インストールを試みている製品に対して正しいことを確認してください。
  • 一部のインストールでは、バージョンのリリース時に適切な契約を交わす必要があります。 詳細は、SOLIDWORKS 代理店までお問い合わせください。
  • 大部分のケースでは、DVDまたは以前にダウンロードしたファイル セットからインストールすることで、インストールを続行できます。

より新しいバージョンの存在

利用可能なより新しいバージョン

利用可能な新しいバージョン

製品のより新しいバージョンをダウンロードして利用できます。

解決策: アップデート チェックの実行時には、SOLIDWORKS からのダウンロードにより利用可能な新しいバージョンのインストールを促される場合があります。 この処理は最初に指定したバージョンを用い継続することも、あるいは利用可能なより新しいバージョンをダウンロードし、そのバージョンを用いて継続することも可能です。

最新バージョンの存在

これはご利用可能な最新のバージョンです。「次へ」をｸﾘｯｸして続行してください。

利用可能な新しいﾀﾞｳﾝﾛｰﾄﾞはありません

解決策:このメッセージには、インストールや変更の間、アップデートをチェックしている際に遭遇する可能性があります。このメッセージは、利用可能な最新バージョンをインストール中であること、あるいは最新バージョンが既にインストール済みであることを示すものです。

インターネット接続に関する問題

インターネット接続: InstallationManager は使用権をお持ちの製品を確定するために必要な SOLIDWORKS サーバーへ接続できませんでした。 インストールを行う製品を選択することは可能ですが、しかしインストレーションファイルをダウンロードすることはできません。 ソース ファイルの DVD あるいは以前にダウンロードしたファイル セットが必要です。

新しいバージョンをチェックすることができません

サーバーに接続することができなかったので、InstallationManager は新しいバージョンをチェックすることができませんでした。

解決策:
  • インターネットの接続を確認してください。
  • DVDまたは以前にダウンロードしたファイル セットからインストールすることで、インストールを続行できます。

親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


穴ウィザード/Toolbox オプション（Hole Wizard/Toolbox Options）

SOLIDWORKS Toolbox をインストールすると、穴タイプとハードウェアの標準ライブラリが SOLIDWORKS に含まれます。

SOLIDWORKS Toolbox の設定、拡張、使用の詳細については、SOLIDWORKS でヘルプ（Help）をクリックし、「Toolbox」セクションを参照してください。

SOLIDWORKS Toolbox を使用する前に、企業やグループのポリシーに従って適切に設定されていることを確認してください。ほとんどの場合は、グループが中央 Toolbox を設定および管理します。SOLIDWORKS のインストレーション中に Toolbox を指定する方法のガイダンスについては、SOLIDWORKS 管理者に確認してください。

選択した SOLIDWORKS Toolbox は、インストレーション後に変更できます。 SOLIDWORKS で ツール（Tools） > オプション（Options）をクリックします。システム オプション（System Options）タブの穴ウィザード/Toolbox（Hole Wizard/Toolbox）をクリックします。

次のセクションでは、この画面に表示されるすべての設定に対するすべてのオプションについて説明します。実際に表示される Toolbox オプションは、このコンピュータ上にある既存の SOLIDWORKS と Toolbox の設定や、これまでに指定した SOLIDWORKS Installation Manager の選択内容によって異なります。

新しいnew-version Toolboxの作成

このコンピュータで SOLIDWORKS Toolbox の新しいバージョンを作成します。

新しいバージョンを作成する場合は、製品選択（Product Selection）画面で、SOLIDWORKS > SOLIDWORKS Toolbox の順に展開し、Toolbox に対してどの規格をサポートするかを選択します。 デフォルトでは、すべての規格が選択されます。

このコンピュータにある既存のToolboxは、いっさい変更されません。

既存のToolbox の参照またはアップグレード

既存のToolboxを使用します。 参照（Browse）をクリックし、このインストレーションで使用する Toolbox の位置を指定します。

  • Toolbox が以前の SOLIDWORKS メジャー リリース バージョン用に設定されている場合は、現在のバージョンにアップグレードされます。 前のToolboxに対して行われたユーザー定義はすべて、アップグレードされたToolboxでも保持されます。
    Toolbox を新しい SOLIDWORKS メジャー リリース バージョンにアップグレードすると、この Toolbox は以前の SOLIDWORKS メジャー リリース バージョンを実行しているコンピュータとの互換性がなくなります。
  • Toolbox が現在の SOLIDWORKS バージョン用に設定されている場合（既にアップグレードされた共有ネットワーク Toolbox を指定した場合など）、その Toolbox に対するアップグレードは行われません。
  • SOLIDWORKS PDM 環境で Toolbox をアップグレードする場合には、さらに手順を実行する必要があります。詳細は、SOLIDWORKS Toolbox の設定に関する注記（Notes About Configuring SOLIDWORKS Toolbox）を参照してください。

このオプションは、アドミニストレーティブ イメージの作成を除く、すべてのインストレーション シナリオで表示されます。

previous-version Toolboxのアップグレード（Upgrade a previous-version Toolbox）

以前のメジャー リリース バージョン用に設定されたToolboxを新しい位置にコピーし、このコピーを現在のバージョンにアップグレードします。

このオプションは、以前の SOLIDWORKS メジャー リリース バージョンがコンピュータにインストールされているが、そのインストレーションを現在のリリースにアップグレードしないことを選択した場合に表示されます。
このオプションの目的は、古いバージョンの Toolbox を使用しているユーザーに影響を与えずに、以前の SOLIDWORKS メジャー リリース バージョン用の Toolbox をアップグレードすることです。

SOLIDWORKS PDM 環境で Toolbox をアップグレードする場合には、さらに手順を実行する必要があります。詳細は、SOLIDWORKS Toolbox の設定に関する注記（Notes About Configuring SOLIDWORKS Toolbox）を参照してください。

インストールされている previous-version Toolbox のアップグレード（Upgrade This Installed previous-version Toolbox）

より新しいバージョンにToolboxをアップグレードします。
Toolbox を新しい SOLIDWORKS メジャー リリース バージョンにアップグレードすると、この Toolbox は以前の SOLIDWORKS メジャー リリース バージョンを実行しているコンピュータとの互換性がなくなります。

このオプションは、以前の SOLIDWORKS メジャー リリース バージョンを現在のバージョンにアップグレードする際に、以前のリリース用に設定された Toolbox がコンピュータ上で見つかった場合に表示されます。

SOLIDWORKS PDM 環境で Toolbox をアップグレードする場合には、さらに手順を実行する必要があります。詳細は、SOLIDWORKS Toolbox の設定に関する注記（Notes About Configuring SOLIDWORKS Toolbox）を参照してください。

インストールされている current-version Toolbox の使用（Use the Installed current-version Toolbox）

SOLIDWORKS Installation Manager は、このコンピュータ上に現在の SOLIDWORKS メジャー リリース バージョン用に設定された Toolbox があることを検出しました。

このオプションを選択すると、SOLIDWORKS はこの Toolbox を使用します。 アップグレードは行われません。

このオプションは、以前の SOLIDWORKS メジャー リリース バージョンがコンピュータにインストールされているが、Toolbox は現在のバージョン用に設定されている場合に表示されます。 このような状況は、古い SOLIDWORKS バージョンを実行し続けているコンピュータに共有 Toolbox が作成された場合に生じる可能性があります。

クライアント コンピュータの Toolbox 位置を指定（Specify the Toolbox Location for the Client Computer）

アドミニストレーティブ イメージからのクライアント インストール時に、デフォルトの Toolbox 位置としてネットワークまたはディレクトリ位置を指定します。
クライアント インストレーションの実行時に、この位置に以前の SOLIDWORKS メジャー リリース バージョン用に設定された Toolbox が存在する場合、SOLIDWORKS Installation Manager はその Toolbox をアップグレードします。

このオプションは、新しいアドミニストレーティブ イメージを作成するときに表示されます。

アップグレードするか、クライアント コンピュータ用の既存のイメージで参照されている Toolbox を使用（Upgrade or Use the Toolbox Referenced in the Existing Image for the Client Computer）

アップデート中の既存のアドミニストレーティブ イメージで指定された Toolbox 位置を使用します。
クライアント インストレーションの実行時に、この位置に以前の SOLIDWORKS メジャー リリース バージョン用に設定された Toolbox が存在する場合、SOLIDWORKS Installation Manager はその Toolbox をアップグレードします。

クライアント コンピュータ用に別の Toolbox 位置を選択（Select a Different Toolbox Location for the Client Computer）

アップデート中の既存のアドミニストレーティブ イメージで指定されたものとは異なる Toolbox 位置を指定します。
クライアント インストレーションの実行時に、この位置に以前の SOLIDWORKS メジャー リリース バージョン用に設定された Toolbox が存在する場合、SOLIDWORKS Installation Manager はその Toolbox をアップグレードします。

目次

  • SOLIDWORKS Toolbox の設定に関する注記（Notes About Configuring SOLIDWORKS Toolbox）

    SOLIDWORKS Toolbox は、強力かつ複雑な機能です。ここでは、SOLIDWORKS Installation Manager を使用して Toolbox を設定する前に、考慮する必要のあるいくつかの概念をまとめています。

  • UNCフォーマット（UNC Format）

    UNC（UniformまたはUniversal Naming Convention、命名規則）フォーマットは、共有ファイルの場所を記述するためにファイル名の構文フォーマットを指定します。

親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）
SOLIDWORKS Toolbox の設定に関する注記（Notes About Configuring SOLIDWORKS Toolbox）


SOLIDWORKS Toolbox の設定に関する注記（Notes About Configuring SOLIDWORKS Toolbox）

SOLIDWORKS Toolbox は、強力かつ複雑な機能です。ここでは、SOLIDWORKS Installation Manager を使用して Toolbox を設定する前に、考慮する必要のあるいくつかの概念をまとめています。

SOLIDWORKS Toolbox の詳細情報（Finding More Information About SOLIDWORKS Toolbox）

SOLIDWORKS Toolbox の設定、拡張、使用の詳細については、SOLIDWORKS で [image] ヘルプ（Help）をクリックし、「Toolbox」セクションを参照してください。

共有Toolboxの使用（Using a Shared Toolbox）

Toolbox をインストールするとき、ローカルコンピュータ上、あるいは共有されたネットワーク上でToolbox データを持つことができます。 Toolbox データをネットワーク上に保管することが推奨されます。 共通の場所を使うことによって、すべての SOLIDWORKS ユーザーは一貫したファスナー情報を共有します。

今回が最初のインストールである場合、Toolbox をインストールする新しい共有された場所を参照してください。

既存のToolboxのアップグレード（Upgrading an Existing Toolbox）

Toolbox を新しい SOLIDWORKS メジャー リリース バージョンにアップグレードすると、この Toolbox は以前の SOLIDWORKS メジャー リリース バージョンを実行しているコンピュータとの互換性がなくなります。

他のコンピュータが以前のメジャー リリースのままであり、そのリリース用に設定された Toolbox を引き続き必要とする場合は、この Toolbox のコピーを作成し、そのコピーをアップグレードします。新しい SOLIDWORKS インストレーションでは Toolbox のコピーがアップグレードされ、以前の SOLIDWORKS インストレーションでは引き続き古い Toolbox が使用されます。

Toolboxアクセスの設定（Configuring Toolbox Access）

インストール後に Toolbox コンポーネントにアクセスすると、SOLIDWORKS は Toolbox の構成をチェックし、アクセスとパフォーマンスを向上させるための提案を行います。

共有ネットワーク Toolbox にアクセスする場合は（推奨）、共有 Toolbox がインストールされているサーバーに対する UNC パスを使用します。詳細は、UNCフォーマット（UNC Format）を参照してください。

アドミニストレータ（管理者）はToolboxのパスワードを作成し、ワークグループの権限と優先権を設定できます。構成へのアクセスを限定し、共通プリファレンスを設定することは、安定した Toolbox データを保証します。

SOLIDWORKS PDM 環境での Toolbox のアップグレード

SOLIDWORKS ソフトウェアをアップグレードする際、Toolbox に部品が追加されていれば Toolbox もアップグレードされます。 Toolbox ルート フォルダが SOLIDWORKS PDM ボルト内にある場合、SOLIDWORKS のアップグレードを開始する前に、Toolbox フォルダの準備をする必要があります。

アップグレードを行う最初のシステムで、最新バージョンの取得 を使用して Toolbox ファイルをローカル キャッシュにダウンロードし、Toolbox データベースをチェックアウトする必要があります。 アップグレードする他のシステムでは、Toolboxファイルをダウンロードするだけです。

アップグレードをはじめる前に:
  • ボルト データベースおよびアーカイブの最新の完全バックアップがあることを確認してください。
  • Toolbox 部品がチェックアウトされておらず、チェックアウトされているアセンブリで使用されていないことを確認してください。

Toolbox をアップグレードするには:

  1. ファイル エクスプローラで、全権限（チェックアウト、チェックイン、追加、削除）を持つユーザーとしてボルトにログインします。
  2. Toolbox フォルダを右クリックし、最新バージョンを取得をクリックして、すべての Toolbox ファイルおよび Toolbox データベースをローカル キャッシュにコピーします。
    アーカイブ サーバーがリモートの場合、この操作には数分かかることがあります。
  3. Toolbox データベース ファイル（SWBrowser.mdb）または（swbrowser.sldedb）を \Toolbox_folder_name\lang\your_lang からチェックアウトします。
  4. SOLIDWORKS Installation Manager を実行してアップグレードを行います。
  5. サマリー画面で、Toolbox オプションのインストレーションの位置がボルトにあることを確認します。

    無い場合は、変更をクリックし、既存の Toolbox の参照またはアップグレードを選択し、ボルトの Toolbox 位置を参照します。

  6. アップグレードが完了した後、ファイル エクスプローラで、新しい、または更新されたファイルをボルトへ追加するために Toolbox フォルダをチェックインし、他のユーザーが Toolbox を操作できるようにします。
  7. アップグレードするため、ボルト内の Toolbox フォルダに移動し、以下が存在することを確認します。
    • \Toolbox_folder_name\Updates
    • \Toolbox_folder_name\ToolboxStandards.xml
    • \Toolbox_folder_name\Browser\ToolboxFiles.index

      無い場合は、お客様の代理店までご連絡ください。

  8. Toolbox と SOLIDWORKS PDM 統合を使用する残りのコンピュータをアップグレードします。
    1. ファイル エクスプローラで、少なくとも Toolbox フォルダに対する読み取り権限を持つユーザーとしてボルトにログインします。
    2. Toolbox フォルダを右クリックし、最新バージョンを取得をクリックして Toolbox ファイルをローカル キャッシュにコピーします。
    3. SOLIDWORKS Installation Manager を実行してアップグレードを行います。

      Toolbox が既にアップグレードされていることが、インストーラによって検出されます。

SOLIDWORKS PDM における Toolbox コンフィギュレーションの詳細については、SOLIDWORKS PDM アドミニストレーション ツール ヘルプの Toolbox の設定（Configuring Toolbox）を参照してください。

親トピック 穴ウィザード/Toolbox オプション（Hole Wizard/Toolbox Options）
UNCフォーマット（UNC Format）


UNCフォーマット（UNC Format）

UNC（UniformまたはUniversal Naming Convention、命名規則）フォーマットは、共有ファイルの場所を記述するためにファイル名の構文フォーマットを指定します。

\\サーバー\ボリューム\パス

例えば:

\\Disk_Server\SOLIDWORKS\AdminImage

親トピック 穴ウィザード/Toolbox オプション（Hole Wizard/Toolbox Options）
SOLIDWORKS Toolbox の設定に関する注記（Notes About Configuring SOLIDWORKS Toolbox）


製品のアンインストール（Uninstall Products）

削除 (Remove) または アンインストール (Uninstall) を コントロール パネル から選択すると、画面にはこのバージョンの SOLIDWORKS Installation Manager でアンインストールできる SOLIDWORKS 製品がバージョン番号と共に表示されます。 一般的なアンインストール、カスタム アンインストール、完全なアンインストールを選択します。

一般的なアンインストールでは、SOLIDWORKS 製品のプログラム ファイルとフォルダが削除されます。 デフォルトで、選択したリリースのすべての SOLIDWORKS 製品のアンインストールが指定されます。

カスタム インストールでは、次のアイテムのいくつかを削除できます: プログラム ファイルとフォルダ、レジストリ キー、SOLIDWORKS Toolbox などのデータ フォルダ、元のダウンロード位置からのファイルとフォルダ。

完全なアンインストールではインストール ディレクトリ、レジストリ キー、データ フォルダが削除されます。

製品をアンインストールするには:
  1. アンインストール（Uninstall）の画面で、製品が選択されていることを確認してください。

    すべての製品をアンインストールすると、Solidworks Installation Manager もアンインストールされます。

  2. 削除したくない製品を選択解除します。

    1 つでも製品を保持すると、SOLIDWORKS Installation Manager も削除されません。

  3. カスタム アンインストールか完全なアンインストールを選択します。
    1. 変更（Change）を詳細設定オプション（Advanced Options）でクリックします。

      詳細設定オプション(Advanced Options)画面が表示されます。 プログラム ファイルとフォルダのオプションが選択されています。

    2. 希望のオプションを選択してカスタム アンインストールを行うか、すべてのオプションを選択して完全なアンインストールを行います。
    3. サマリーに戻る（Back to Summary）をクリックします。
    4. サマリー（Summary）の画面で、詳細設定オプション（Advanced Options）を展開し、アンインストールの方法を表示します。
  4. アイテムを削除 をクリックします。
アイテムを削除 (Remove Items) をクリックすると、SOLIDWORKS Installation Manager は直ちに製品の削除を開始します。
親トピック SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


SOLIDWORKS Visualize Boost

SOLIDWORKS Visualize Boost は、SOLIDWORKS Visualize Professional を実行しているコンピュータから、ネットワーク上の 1 台以上のコンピュータにレンダリングを配布できるアプリケーションです。

レンダリングがバックグラウンドで行われている間に、マシン上で他のタスクを実行でき、最終的なレンダリング イメージが早く使用できるようになります。Visualize Boost を実行している 1 台のマシン、または複数マシンのクラスタ上で、イメージをレンダリングできます。

SOLIDWORKS Visualize Professional のアクティブな各サブスクリプションには、SOLIDWORKS Visualize Boost の無償ライセンスが 1 つ含まれています。

レンダリング時間の高速化などのパフォーマンスの向上は、Visualize Boost コンピュータの能力に依存します。GPU の性能が高いほど、マシンのパフォーマンスが向上します。


個人ライセンスからSolidNetWorkライセンスへのアップグレード（Upgrading from Individual Licensing to SolidNetWork Licensing）

SOLIDWORKS 個人ライセンスから SolidNetWork ライセンスにコンピュータをアップグレードするには、SOLIDWORKS Installation Manager で SolidNetWork ライセンスのシリアル番号を指定します。

コンピュータに SOLIDWORKS がインストールされていない場合は、SOLIDWORKS Installation Manager でインストールするときに SolidNetWork シリアル番号を入力することで SolidNetWork ライセンスを指定できます。

SOLIDWORKS が既にインストールされたコンピュータで個人ライセンスから SolidNetWork ライセンスに切り替える場合は、クライアント コンピュータのインストレーションの変更を行い、SOLIDWORKS Installation Manager の実行時に個人ライセンスのシリアル番号の代わりに SolidNetWork ライセンスのシリアル番号を指定します。詳細は、インストレーションの変更（Modifying an Installation）を参照してください。
アドミニストレーティブ イメージから SOLIDWORKS をインストールした場合、変更のオプションは使用できません。アドミニストレーティブ イメージ オプション エディタでアドミニストレーティブ イメージを変更し、クライアントをアンインストール後、インストールを再実行してください。


Visualize Boost での作業

分散レンダリングを有効にするには、SOLIDWORKS Visualize を設定した後で Visualize Boost に接続する必要があります。

Boost への接続には、SOLIDWORKS Visualize のコーディネータ IP アドレス（Coordinator IP Address）とブースト ポート（Boost Port）の値が必要です。

Visualize Boost と SOLIDWORKS Visualize は、次のステップのために開いたままにします。

SOLIDWORKS Visualize を Visualize Boost に接続するには:

  1. デスクトップ ショートカット [image] をダブルクリックして Visualize Boost を開きます。
  2. Visualize Boost でコーディネータ IP アドレス（Coordinator IP Address）をダブルクリックし、クリップボードにコピーします。
  3. SOLIDWORKS Visualize でツール（Tools） > オプション（Options） > Boost をクリックし、CTRL+V を押してコーディネータ IP アドレス（Coordinator IP Address）を貼り付けます。
  4. ステップ 2 と 3 を繰り返して、ブースト ポート（Boost Port）を Visualize Boost から SOLIDWORKS Visualize にコピーします。
    Visualize Boost と SOLIDWORKS Visualize Boost で指定したブースト ポート（Boost Port）は同一でなければなりません。
    Boost ステータス（Boost Status）コントロールが SOLIDWORKS Visualize に表示されます。
  5. OK をクリックしてオプション（Options）ダイアログ ボックスを閉じます。
  6. Boost に接続するには、Boost ステータス（Boost Status）コントロール [image] をクリックするか、次のインターフェイスで [image] を切断します。
    • ヘッドアップ表示
    • レンダリング ウィザードの品質ページ
    • ツール（Tools）オプション（Options） Boost タブ

Boost コンフィギュレーションの詳細については、SOLIDWORKS Visualize Boost を参照してください。


新しい SolidNetWork License Server の初期化

新しい SolidNetWork License Server を初期化するには:

  1. SolidNetWork License Manager Server をインストールして開いた後、アクティブ化を求めるメッセージが表示されたらはい（Yes）をクリックします。
  2. SolidNetWork ライセンス サーバー情報（SolidNetWork License Server Information）ダイアログ ボックスで、ファイアウォールとポートを確認して、次へ（Next）をクリックします。
  3. 製品アクティベーション ウィザードで、アクティブ化するシリアル番号を選択し、電子メール経由で手動（Manually via E-mail）をアクティベーション方法に選択して、電子メール連絡先情報（Email Contact Information）を入力します。

    手動の方法では、要求ファイルを作成して activation@solidworks.com に電子メール送信する必要があります。ライセンス応答ファイルを含む電子メールを受信したら、そのファイルを取り出し、開く（Open）をクリックしてサーバーにロードします。

    製品アクティベーション ウィザードを閉じて再実行して、応答ファイルを開いてロードできます。

  4. 初期化が正常に完了したことを示すメッセージ ボックスが表示されたら、OK をクリックし、製品アクティベーション ウィザードで完了（Finish）をクリックします。


新しい SolidNetWork License Manager Server の手動アクティブ化

SolidNetWork License Manager Server を初期化した後、SolidNetWork License Manager Server を開いて、アクティブ化を完了するための 2 番目の要求を作成します。

新しい SolidNetWork License Manager Server を手動でアクティブ化するには:

  1. 次のいずれかの操作を行います:
    • アクティブ化を求めるメッセージが表示されたら、はい（Yes）をクリックします。
    • メッセージが表示されない場合は、サーバー アドミニストレーション（Server Administration）タブで変更（Modify）をクリックします。
    詳細設定オプションはデフォルトでアクティブ化を使用（Use Activation）モードに設定されています。
  2. SolidNetWork ライセンス サーバー情報（SolidNetWork License Server Information）ダイアログ ボックスでファイアウォールとポートを確認して、次へ（Next）をクリックします。
  3. 製品アクティベーションウィザードで、アクティブ化するシリアル番号を選択し、Email Contact Information（電子メール連絡先情報）を入力して、電子メール経由で手動（Manually via E-mail）をアクティベーション方法として選択します。
  4. 手順に従って要求ファイルを作成して、activation@solidworks.com に送信します。ライセンス応答ファイルを受け取り、開く（Open） をクリックしてロードします。
  5. アクティベーションが完了したら、完了（Finish）をクリックします。


アップグレードされた SolidNetWork License Manager Server を手動でアクティブ化

SolidNetWork License Manager Server を SOLIDWORKS Installation Manager でアップグレードした後、SolidNetWork License Manager Server を開きます。

アップグレードされた SolidNetWork License Manager Server を手動でアクティブ化するには:

  1. サーバー アドミニストレーション（Server Administration）タブで、ライセンス情報（License Information）の下にある再アクティブ化（Reactivate）をクリックします。
    SolidNetWork License Manager Server をアンインストールしてアップグレードする前にライセンスを非アクティブ化した場合は、サーバー アドミニストレーション（Server Administration）タブで変更（Modify）をクリックします。再アクティブ化（Reactivate）を選択できるのは、サーバー上にアクティブ化されたライセンスがある場合のみです。

    ステップ 3 へ進みます。

  2. Reactivate（再アクティブ化）ダイアログ ボックスで、インストールされているシリアル番号を選択すると関連付けられているライセンスが表示されるので、Reactivate（再アクティブ化）をクリックします。
  3. SolidNetWork ライセンス サーバー情報（SolidNetWork License Server Information）ダイアログ ボックスでファイアウォールとポートを確認して、次へ（Next）をクリックします。
  4. 製品アクティベーションウィザードで、アクティブ化するシリアル番号を選択し、Email Contact Information（電子メール連絡先情報）を入力して、電子メール経由で手動（Manually via E-mail）をアクティベーション方法として選択します。
    手動アクティベーションは簡単な手順です。製品のアクティベーション（Product Activation）ウィザードの指示に従い、手順を行います。
  5. アクティベーションが完了したら、完了（Finish）をクリックします。