Instalace a správa SOLIDWORKS

Tato nápověda obsahuje informace o instalaci, licencích a správě produktů SOLIDWORKS pro individuální instalace i pro vícenásobné instalace.

Individuální instalace | Zavádění násobných instalací
Instalace Instalace na jednom nebo na více počítačích. | Instalace Vytvoření administrativní kopie, která se zavádí na více klientských počítačů.
Licencování Aktivace v počítači nebo síťové licence. | Licencování Aktivace v počítači nebo síťové licence.
Inovace Instalace nové verze na individuálních počítačích. | Inovace Instalace nové verze na více počítačích aktualizací administrativní kopie používané k instalaci na těchto počítačích.
Správa systému Změny, opravy a odstraňování instalací, upgrady na nové verze. | Správa systému Upgradování administrativních kopií a klientů, a správa síťových licencí.

Manažer instalací SOLIDWORKS vám umožní konfigurovat nastavení pro součásti produktů SOLIDWORKS, mezi které patří SOLIDWORKS, SOLIDWORKS Toolbox, SOLIDWORKS Electrical, SOLIDWORKS Manage, SOLIDWORKS PDM, SOLIDWORKS Visualize a Manažer licencí SOLIDWORKS SolidNetWork License Manager.

SolidNetWork License Manager podporuje násobné licenční klienty pomocí distribuce licencí klientům na síti. To umožňuje počtu uživatelů rozšířit počet licencí použitím plovoucích licencí.

Obsah

  • Individuální instalace nebo administrativní kopie

    Měli byste nainstalovat produkty SOLIDWORKS na každý počítač zvlášť, nebo vytvořit administrativní kopii a rozšířit instalaci na klienty pomocí jednoho příkazu?

  • Kontrola požadavků na systém a software

    Před instalací se ujistěte, že systém splňuje požadavky na hardware, operační systém a produkty Microsoft. Doplňkové moduly, jako je SOLIDWORKS Electrical, SOLIDWORKS Visualize a eDrawings mají další požadavky.

  • Stažení souborů z instalačních médií

    Veškeré soubory z instalačních médií jsou dostupné na stránce Stahování na portálu SOLIDWORKS.

  • Instalace aplikací 3DEXPERIENCE

    Pokud data spravujete pomocí platformy 3DEXPERIENCE Platform, můžete zakoupit roli Collaborative Designer for SOLIDWORKS pro připojení desktopového prostředí k platformě.


Individuální instalace nebo administrativní kopie

Měli byste nainstalovat produkty SOLIDWORKS na každý počítač zvlášť, nebo vytvořit administrativní kopii a rozšířit instalaci na klienty pomocí jednoho příkazu?

Volba je závislá na počtu počítačů, na kterých provádíte instalaci. U nerozhodných situací zvažte následující porovnání.

Individuální instalace | Administrativní kopie
Uživatelé mohou provádět vlastní správu SOLIDWORKS. | Správce systému může upravit vícečetné instalace za použití Editoru možností. Určuje přitom možnosti instalace jako je vytvoření nové instalace nebo aktualizace stávající instalace, spuštění instalace jako administrativní uživatel, spuštění externích povelů před nebo po instalaci, různé seskupení produktů atd.
Počítače musí být fyzicky přístupné uživateli, který provádí instalaci. | Klientské počítače nemusí být fyzicky dostupné, ale musí být dostupné ze stejné sítě.
Můžete nainstalovat různé verze, aktualizace Service Pack, nebo produkty na různých počítačích s rozdílnými nastaveními. | S použitím Editoru možností mohou administrativní kopie udržet konzistentní verze, aktualizace Service Pack, produkty a nastavení pro vícečetné instalace.
Dané počítače musí mít přístup k síti nebo k e-mailu. Pro aktivaci softwaru SOLIDWORKS a stažení souborů je nutné síťové připojení nebo přístup k e-mailu. Síťový přístup je nutný také při shromažďování licencí ze síťového licenčního serveru.

Ke spuštění programu je vyžadováno připojení k místní síti. Zdrojové médium není vyžadováno na klientských počítačích.

Klientské počítače mohou být aktualizovány automaticky. Klientské počítače, na nichž je program nainstalován ze stejné administrativní kopie, používají stejnou aktualizaci service pack. Pokud chcete udržovat různé verze, můžete vytvořit různé administrativní kopie.

Lze nastavit automatickou aktivaci licence.

Administrativní kopie vyžaduje dodatečné místo na disku na serveru. Klienti vyžadují stejné místo jako individuální instalace.

Nadřazené téma Instalace a správa SOLIDWORKS
Kontrola požadavků na systém a software
Stažení souborů z instalačních médií
Instalace aplikací 3DEXPERIENCE


Kontrola požadavků na systém a software

Před instalací se ujistěte, že systém splňuje požadavky na hardware, operační systém a produkty Microsoft. Doplňkové moduly, jako je SOLIDWORKS Electrical, SOLIDWORKS Visualize a eDrawings mají další požadavky.

Aby jste zajistili úspěšnou instalaci a optimální výkon, viz. Systémové požadavky.

Nadřazené téma Instalace a správa SOLIDWORKS
Individuální instalace nebo administrativní kopie
Stažení souborů z instalačních médií
Instalace aplikací 3DEXPERIENCE


Stažení souborů z instalačních médií

Veškeré soubory z instalačních médií jsou dostupné na stránce Stahování na portálu SOLIDWORKS.

Pokud nemáte ke stránce Stahování SOLIDWORKS přístup, kontaktujte prodejce VAR, od kterého získáte disky DVD.

Postup stažení instalačního média:

  1. Přihlaste se na stránce Stahování SOLIDWORKS jako zákazník s předplatným, s použitím vaší e-mailové adresy a hesla, nebo použijte sériové číslo SOLIDWORKS.
  2. Na stránce Stahování v části Vybrat verzi vyberte rok.
  3. Vyberte záložku SOLIDWORKS pro Produkty SOLIDWORKS.
  4. V části Produkt, vyberte service pack.
    Jako poslední hlavní verzi vyberte Produkty SOLIDWORKS verze 0.0.
  5. Kliknutím na možnost Přijmout souhlas a pokračovat přijměte podmínky licenční smlouvy.
  6. Klepněte na Download (Stáhnout).
    Webový prohlížeč stáhne soubor SolidworksSetup.exe do výchozí složky C:\Users\Username\Downloads.
  7. Rozbalte soubor SolidworksSetup.exe do složky Downloads.
    Můžete také rozbalit soubor SolidworksSetup.exe na preferované místo.
  8. Spusťte soubor setup.exe s oprávněními správce.
  9. V Manažeru instalací klikněte na možnost Stáhnout a sdílet všechny soubory.
    Vytvořte jednotlivé instalace nebo administrativní kopie na více počítačích pomocí jednoho stahování a poté dokončete proces podle pokynů.

    Manažer instalací stáhne instalační médium za vás.

    Tato možnost je k užitečná v následujících případech:
    • Instalace softwaru na malý počet počítačů
    • Stahování pomocí přenosné jednotky nebo síťové jednotky
    • Instalace aktualizací service pack
    Chcete-li stáhnout instalační soubory selektivně, vyberte v nabídkách možnost ručního stažení.
Nadřazené téma Instalace a správa SOLIDWORKS
Individuální instalace nebo administrativní kopie
Kontrola požadavků na systém a software
Instalace aplikací 3DEXPERIENCE


Instalace aplikací 3DEXPERIENCE

Pokud data spravujete pomocí platformy 3DEXPERIENCE Platform, můžete zakoupit roli Collaborative Designer for SOLIDWORKS pro připojení desktopového prostředí k platformě.

Role Collaborative Designer for SOLIDWORKS nabízí přístup k aplikacím 3DEXPERIENCE, které desktopovým produktům SOLIDWORKS umožňují ukládat, vyhledávat a spravovat data uložená na platformě.

Tyto aplikace nainstalujete a licenci k nim získáte z platformy 3DEXPERIENCE Platform, nikoli z Manažera instalací SOLIDWORKS. Pokyny k instalaci naleznete v nápovědě k softwaru SOLIDWORKS v článcích Práce s platformou 3DEXPERIENCE Platform a aplikacemi 3DEXPERIENCE > Instalace aplikací 3DEXPERIENCE.

Nadřazené téma Instalace a správa SOLIDWORKS
Individuální instalace nebo administrativní kopie
Kontrola požadavků na systém a software
Stažení souborů z instalačních médií
https://help.solidworks.com


Individuální instalace

Obsah

  • Instalace na individuálních počítačích

    SOLIDWORKS můžete do individuálního počítače nainstalovat za použití několika instalačních metod.

  • Správa individuálních instalací

    Administrace individuálních instalací se obvykle skládá ze změny, opravy, odebrání nebo aktualizace instalací.


Instalace na individuálních počítačích

SOLIDWORKS můžete do individuálního počítače nainstalovat za použití několika instalačních metod.

Manažer instalací SOLIDWORKS přizpůsobí instalaci produktům, které jste zakoupili. Před instalací:

  • Pokud instalujete samostatnou verzi SOLIDWORKS, mějte připravená sériová čísla SOLIDWORKS.
  • Ujistěte se, že máte připojení k internetu. Pro kontrolu oprávnění je nutné připojení k síti.
  • Vytvořte 3DEXPERIENCE ID. Podrobnosti o vytvoření 3DEXPERIENCE ID naleznete v tématu https://www.3ds.com/support.
  • Zkontrolujte, zda máte pod svým účtem roli správce nebo zda vás správce označil jako kontaktní osobu.

Manažer instalací SOLIDWORKS instaluje různé systémové součásti od společnosti Microsoft: Microsoft Visual Studio Tools for Applications, Visual Basic a .NET Framework. Pokud nejsou nainstalovány správné verze nutných součástí Windows, Manažer instalací SOLIDWORKS je automaticky nainstaluje před instalací produktů SOLIDWORKS.

Nástroj SOLIDWORKS Chromium Embedded Framework (CEF) je další součást instalovaná Manažerem instalací SOLIDWORKS. Jeho účelem je zobrazit obsah pro aplikace SOLIDWORKS a platformu 3DEXPERIENCE Platform.

Nástroj SOLIDWORKS Login Manager se nainstaluje spolu s aplikací SOLIDWORKS Installation Manager. Umožňuje přihlášení ke službě 3DEXPERIENCE Marketplace a k aplikacím 3DEXPERIENCE.

Metoda instalace Stručné souhrnné informace o postupu
Stahování ze stránky Stahování SOLIDWORKS

Veškeré soubory z instalačních médií jsou dostupné na stránce Stahování na portálu SOLIDWORKS.

  1. Přejděte na stránku Stahování SOLIDWORKS.
  2. Přihlaste se pomocí svého 3DEXPERIENCE ID.
  3. Na stránce Stahování v části Vybrat verzi vyberte rok.
  4. Klikněte na kartu SOLIDWORKS pro Produkty SOLIDWORKS a pod položkou Produkt vyberte service pack.
  5. Kliknutím na možnost Přijmout smlouvu a pokračovat přijměte podmínky licenční smlouvy.
  6. Klikněte na Stáhnout.
Musíte mít funkční připojení k internetu s přístupem k přihlášení na stránce Downloads (Stažené soubory).

Pokud nemáte přístup na stránku Stahování, kontaktujte prodejce VAR, od kterého získáte instalační médium.
Použití adresáře pro stahování na serveru V adresáři pro stahování poklepejte na setup.exe.

Tento adresář pro stahování musí být přístupný z počítače, na který instalujete produkty SOLIDWORKS, a před zahájením instalace musí obsahovat všechny instalační soubory SOLIDWORKS. Manažer instalací SOLIDWORKS vám může pomoci najít chybějící soubory, pokud máte přístup na internet a oprávnění k zápisu do adresáře pro stahování.
Aktualizace existující instalace SOLIDWORKS pomocí příkazu Zjistit aktualizace Proveďte jednu z následujících operací:
  • V SOLIDWORKS klikněte na položku [image] > Zkontrolovat aktualizace.
  • V systému Windows klikněte na Start > Manažer instalací SOLIDWORKS > Zkontrolovat aktualizace.
Můžete také kliknout na tlačítko Start > Manažer instalací SOLIDWORKS > SOLIDWORKS Nástroj pro stahování na pozadí. V oznamovací oblasti systému Windows klikněte pravým tlačítkem myši na nástroj SOLIDWORKS Nástroj pro stahování na pozadí a klikněte na možnost Zkontrolovat aktualizace.
Je vyžadováno fungující internetové připojení a oprávnění správce pro počítač.

V Manažeru instalací SOLIDWORKS můžete rovněž vybrat možnost Stažení a sdílení všech souborů, což zahrnuje vyžadované součásti softwaru. Tato možnost je užitečná, pokud instalujete software na pár počítačů a potřebujete zkopírovat stažené soubory s použitím externího disku nebo síťové jednotky. To je rovněž užitečné při instalaci balíčků oprav, protože plná verze softwaru a balíčky oprav jsou obsaženy v jedné instalaci.

Po dokončení instalace, spusťte program SOLIDWORKS a aktivujte licenci.

Chcete-li zobrazit seznam produktů nainstalovaných v počítači, v hlavní nabídce SOLIDWORKS:
  • Klikněte na [image] > Moje produkty
  • Klikněte na tlačítko Domů v podokně úloh Zdroje SOLIDWORKS > Moje produkty
  • Klikněte na tlačítko Start > Nástroje SOLIDWORKSVerze > Moje produkty.

Zaškrtnutí v dialogovém okně označuje produkty, které vy nebo vaše organizace momentálně vlastníte na základě aktivace a síťových licencí. Více o produktech SOLIDWORKS se rovněž dozvíte kliknutím na odkaz v horní části každé kategorie produktů.

Chcete-li si zobrazit používané licence SOLIDWORKS, v systému Windows klikněte na kartu Start > SOLIDWORKS Nástroje<version> > SolidNetWork License Manager Client > Využití licencí.

Nadřazené téma Individuální instalace
Správa individuálních instalací


Správa individuálních instalací

Administrace individuálních instalací se obvykle skládá ze změny, opravy, odebrání nebo aktualizace instalací.

Obsah

  • Změna instalace

    Instalaci můžete upravit, chcete-li nainstalovat produkty, které nebyly nainstalovány, nebo odstranit produkty – ovšem za předpokladu, že předchozí instalace byla dokončena s úplnou sadou instalačních souborů. Tato možnost není k dispozici, pokud jste předchozí instalace upgradovali pomocí aktualizace Service Pack.

  • Oprava instalace

    Pokud zaznamenáte problém s nainstalovaným produktem SOLIDWORKS, můžete pomocí Manažera instalací SOLIDWORKS instalaci opravit.

  • Vrácení samostatné instalace na předchozí servisní balíček

  • Odstranění instalace

    Instalaci můžete odstranit ze individuálního počítače, nebo z prostředí klient/server.

  • Upgrade na novou verzi

    Upgrade individuální instalace nové verze SOLIDWORKS lze provést několika způsoby.

  • Pravidla koexistence produktu

    Pravidla koexistence produktů určuje, jak jsou instalovány nové produkty a aktualizovány stávající produkty.

Nadřazené téma Individuální instalace
Instalace na individuálních počítačích


Změna instalace

Instalaci můžete upravit, chcete-li nainstalovat produkty, které nebyly nainstalovány, nebo odstranit produkty – ovšem za předpokladu, že předchozí instalace byla dokončena s úplnou sadou instalačních souborů. Tato možnost není k dispozici, pokud jste předchozí instalace upgradovali pomocí aktualizace Service Pack.

Pokud jste nainstalovali SOLIDWORKS a později zakoupili doplňkový modul, instalaci můžete změnit a zahrnout tento nový doplňkový modul. Doplňkový modul musíte nainstalovat na každém počítači zvlášť.

  1. Přesvědčte se, že žádné relace SOLIDWORKS nejsou aktivní.
  2. Otevřete nabídku Aplikace systému Windows a vyberte možnost Nainstalované aplikace.
  3. Vyberte instalaci SOLIDWORKS, kterou chcete změnit, a klepněte na Změnit.
  4. Na obrazovce Vítejte v instalaci SOLIDWORKS klikněte na příkaz Upravit instalaci.
  5. Na obrazovce Sériové číslo ověřte, že jsou určena správná sériová čísla.
  6. Na obrazovce Výběr produktu vyberte produkty k instalaci nebo odstranění.
    Když upravujete instalaci:
    • Standardně nejsou instalovány nebo odstraněny žádné produkty, dokonce ani když určíte nové sériové číslo. Musíte změnit instalační operaci každého produktu nebo součásti.
    • Pokud chcete zobrazit promítnutou akci pro konkrétní součást, klikněte na název součásti (ale ne na zaškrtávací políčko). Plánovaná akce instalace se objeví v informačním poli pod seznamem produktů.
    • Chcete-li změnit akci instalace pro danou součást, můžete kliknout na zaškrtávací políčko vedle součásti produktu. (Pokud například instalujete nebo odebíráte součást, výběrem zaškrtávacího políčka určíte, že se má součást nainstalovat nebo odebrat a zrušením výběru tohoto políčka určíte, že se daná součást instalovat nebo odebírat nemá.)
    • Pokud změníte akci instalace součásti oproti původní specifikaci, zobrazí se vedle této součásti v seznamu hvězdička (*).
    • Pokud je u součásti k dispozici volitelná instalace dílčích součástí, zobrazí se vedle součásti ikona [image] . Chcete-li zobrazit dostupné dílčí součásti pro danou součást, klikněte na ikonu [image] .
    • V případě rozbalení součásti a zobrazení volitelných dílčích součástí se vedle součásti zobrazí ikona [image] . Chcete-li sbalit výpis dílčích součástí, klikněte na ikonu [image] .
  7. Na obrazovce Souhrn klepněte na Nyní upravit.
  8. Na obrazovce Instalace je dokončena klepněte na Dokončit.
Nadřazené téma Správa individuálních instalací
Oprava instalace
Vrácení samostatné instalace na předchozí servisní balíček
Odstranění instalace
Upgrade na novou verzi
Pravidla koexistence produktu


Oprava instalace

Pokud zaznamenáte problém s nainstalovaným produktem SOLIDWORKS, můžete pomocí Manažera instalací SOLIDWORKS instalaci opravit.

Chcete-li opravit instalaci, musí váš počítač obsahovat všechny zdrojové soubory z předchozí instalace a veškeré aktualizace Service Pack, které byly použity. Všechny komponenty musí být ve stejném umístění, kde byly původně nainstalovány.

Je možné opravit individuální instalaci. Administrativní kopii nelze opravit. Musíte ji nejprve odinstalovat a pak nainstalovat novou administrativní kopii.
  1. Otevřete nabídku Ovládací panely systému Windows a klikněte na nabídku Programy > Programy a funkce.
  2. Klikněte pravým tlačítkem na verzi SOLIDWORKS, kterou chcete opravit, a klikněte na Změnit.
  3. Na obrazovce Vítejte v Manažeru instalací SOLIDWORKS klikněte na možnost Opravit tuto instalaci a potom na tlačítko Další.
  4. Na obrazovce Produkty k opravě vyberte produkty, které chcete opravit.
  5. Zrušte výběr všech ostatních produktů.
  6. Klepněte na Opravit.
Nadřazené téma Správa individuálních instalací
Nadřazené téma Chyby během instalace / Instalace byla zrušena
Změna instalace
Vrácení samostatné instalace na předchozí servisní balíček
Odstranění instalace
Upgrade na novou verzi
Pravidla koexistence produktu
Obnovení po nezdařené nebo zrušené instalaci
Kontaktování prodejce SOLIDWORKS


Vrácení samostatné instalace na předchozí servisní balíček

Chcete-li vrátit individuální instalaci na předchozí verzi servisního balíčku v aktuálním souhrnu hlavní verze, odinstalujte aktuální verzi servisního balíčku na počítači a pak znovu nainstalujte předchozí verzi.
Nadřazené téma Správa individuálních instalací
Změna instalace
Oprava instalace
Odstranění instalace
Upgrade na novou verzi
Pravidla koexistence produktu


Odstranění instalace

Instalaci můžete odstranit ze individuálního počítače, nebo z prostředí klient/server.

  1. Přesvědčte se, že žádné relace SOLIDWORKS nejsou aktivní.
  2. Chcete-li přesunout licenci SOLIDWORKS na jiný počítač, nejprve ji deaktivujte a pak odstraňte instalaci SOLIDWORKS z původního počítače.
    Další informace viz Přenos licence.
  3. Otevřete Ovládací panely Windows a klikněte na Programy a funkce.
  4. Vyberte součást produktu, kterou chcete odebrat, a klikněte na možnost Odinstalovat.
    V některých případech možná najdete několik součástí aktualizace Service Pack SOLIDWORKS pro danou hlavní verzi. Pro odstranění hlavní verze softwaru SOLIDWORKS odstraňte všechny prvky aktualizace Service Pack pro tuto hlavní verzi.
  5. Na obrazovce Odinstalace proveďte následující:
    1. Vyberte produkty, které chcete odebrat.
      Všechny instalované produkty jsou standardně vybrány .
    2. Zrušte výběr produktů, které nechcete odstranit.
    3. Klepněte na Změnit v Upřesňující možnosti.
      Zobrazí se okno Upřesňující možnosti a je vybrána možnost Programové soubory a složky.
    4. Vyberte jednu nebo více možností, chcete-li provést vlastní odinstalaci, nebo všechny položky, pokud chcete provést úplnou odinstalaci.
      Ve výchozím nastavení provede Manažer instalací SOLIDWORKS úplnou odinstalaci a odstraní všechny soubory a složky, které byly přidány při instalaci.
    5. Klepněte na Zpět na souhrnné informace.
    6. V okně Souhrnné informace rozbalte položku Upřesňující možnosti; zobrazí se metoda a údaje o odinstalaci.
    7. Klepněte na Odstranit položky.
Nadřazené téma Správa individuálních instalací
Nadřazené téma Správa násobných instalací
Změna instalace
Oprava instalace
Vrácení samostatné instalace na předchozí servisní balíček
Upgrade na novou verzi
Pravidla koexistence produktu
Upgrade administrativních kopií na novou verzi
Správa aktualizace produktu servisního balíčku
Přenos licence


Upgrade na novou verzi

Upgrade individuální instalace nové verze SOLIDWORKS lze provést několika způsoby.

Můžete provést upgrade na novou verzi, když:
  • obdržíte nové instalační médium
  • při spuštění SOLIDWORKS obdržíte oznámení o upgradech
  • Zjistit aktualizace ručně
  • spustíte novou instanci Manažera instalací SOLIDWORKS

Když instalujete novou verzi programu, můžete upgradovat předchozí hlavní verzi nebo paralelně nainstalovat novou verzi. Pokud je instalována verze servisního balíčku pro předchozí finální hlavní verzi, tato verze se aktualizuje automaticky.

Nadřazené téma Správa individuálních instalací
Změna instalace
Oprava instalace
Vrácení samostatné instalace na předchozí servisní balíček
Odstranění instalace
Pravidla koexistence produktu

Zjistit aktualizace ručně

Pokud máte na daném počítači oprávnění správce, můžete jedním z následujících způsobů zkontrolovat aktualizace pro instalovanou verzi softwaru SOLIDWORKS.

  • V SOLIDWORKS klikněte na položku [image] > Zkontrolovat aktualizace.
  • V systému Windows klikněte na Start > Manažer instalací SOLIDWORKS > Zkontrolovat aktualizace.
Můžete také kliknout na tlačítko Start > SOLIDWORKS Manažer instalací > SOLIDWORKS nástroj pro stahování na pozadí. V oznamovací oblasti systému Windows klikněte pravým tlačítkem myši na nástroj SOLIDWORKS nástroj pro stahování na pozadí a klikněte na možnost Zkontrolovat aktualizace.

Rizika upgradu

Produkty vyžadující několik instalací v rámci hlavních verzí nepodporují vždy hlavní upgrady, nebo schopnost provádět upgrade mezi hlavními verzemi prostřednictvím jedné operace.

V tomto případě Manažer instalací SOLIDWORKS simuluje upgrade tak, že nejprve nainstaluje novou verzi a pak odstraní starou. V současné době podporuje významné upgrady produkt jádra SOLIDWORKS, ale ostatní produkty ne.

Následky:
  • Když se provádí upgrade produktu jádra SOLIDWORKS mezi významnými verzemi:
    • Stávající umístění instalace se nemění.
    • Pokud dojde k chybě, nebo pokud upgrade zrušíte během upgradu, můžete ho vrátit zpět.
  • Když jsou ostatní produkty upgradovány mezi hlavními verzemi:
    • Každý produkt je nejprve nainstalován jako nový produkt do nového umístění a poté je původní instalace odstraněna.
    • Pokud dojde k chybě, nebo pokud upgrade zrušíte během upgradu, nelze ho vrátit zpět.


Pravidla koexistence produktu

Pravidla koexistence produktů určuje, jak jsou instalovány nové produkty a aktualizovány stávající produkty.

Pravidlo | Příklady
Je povoleno více hlavních verzí základního produktu SOLIDWORKS s výjimkou produktů uvedených níže. | Verze SOLIDWORKS 2024 SP3.0 a SOLIDWORKS 2025 SP0.0 mohou být nainstalovány na stejném počítači.
Více servisních balíčků z některých hlavních finálních verzí není povoleno. | Verze SOLIDWORKS 2025 SP0.0 a 2025 SP1.0 nemohou být nainstalovány na stejném počítači zároveň. Pokud nainstalujete verzi SOLIDWORKS 2025 SP1.0 do počítače, kde je již nainstalována verze SOLIDWORKS 2025 SP0.0, Manažer instalací SOLIDWORKS nahradí aktualizaci SP0.0 aktualizací SP1.0.
Na jednom počítači je povolena pouze jedna verze následujících produktů:
  • SolidNetWork License Manager
 Pokud nainstalujete aplikaci SolidNetWork License Manager 2024 SP3.0, bude aplikace SolidNetWork License Manager upgradována na verzi 2025 SP0.0, i když na počítači zůstane starší hlavní verze softwaru SOLIDWORKS.
Na jednom počítači je povolena pouze jedna verze následujících produktů:
  • SOLIDWORKS Electrical
 Pokud vytvoříte novou instalaci SOLIDWORKS Electrical 2025 SP1.0, Manažer instalací SOLIDWORKS z počítače automaticky odstraní dřívější verze softwaru SOLIDWORKS Electrical. Před upgradem zálohujte prostředí SOLIDWORKS Electrical.
Na jednom počítači je povolena pouze jedna verze následujících produktů:
  • Klient SOLIDWORKS PDM
  • SOLIDWORKS PDM Server

Pokud nainstalujete verzi SOLIDWORKS 2025 SP0.0 nebo SP1.0, měli byste provést upgrade na server PDM Server a klient PDM verze SOLIDWORKS 2025.

Pokud nainstalujete SOLIDWORKS 2025 PDM Server, měli byste použít proces instalace serveru PDM pro instalaci klienta SOLIDWORKS PDM Client. Neinstalujte klienta SOLIDWORKS PDM Client samostatně pomocí procesu instalace klienta.

Klient SOLIDWORKS PDM musí mít stejnou finální verzi a servisní balíček jako server SOLIDWORKS PDM ve stejném počítači.

Další informace viz SOLIDWORKS PDM a SOLIDWORKS Manage.

S jakoukoli hlavní verzí může být nainstalována pouze jedna verze produktu SOLIDWORKS. Verze zahrnutých produktů z různých hlavních verzí produktu SOLIDWORKS však mohou být nainstalovány společně. | Pokud se systém SOLIDWORKS 2025 SP0.0 upgraduje na verzi 2025 SP1.0 software SOLIDWORKS Composer 2025 SP0.0, se automaticky upgraduje na 2025 SP1.0. Software SOLIDWORKS Composer 2024 SP4.0 ale může koexistovat se softwarem SOLIDWORKS Composer 2025 SP0.0, nebo se softwarem SOLIDWORKS Composer 2025 SP1.0.
Nadřazené téma Správa individuálních instalací
Změna instalace
Oprava instalace
Vrácení samostatné instalace na předchozí servisní balíček
Odstranění instalace
Upgrade na novou verzi


Násobné instalace

Obsah

  • Zavádění více klientů

    Produkt SOLIDWORKS můžete nainstalovat na více klientů vytvořením administrativní kopie, kterou poté můžete nainstalovat na jednotlivé klienty.

  • Použití administrativní kopie

    Administrativní kopie umožňuje konfigurovatelné instalace produktů SOLIDWORKS z jediného místa v síti.

  • Zavedení pomocí příkazového řádku

    Administrativní kopii můžete automaticky zavést příkazového řádku nebo dávkového souboru (tichá instalace).

  • Správa násobných instalací

    Pro více instalací zahrnují administrativní úkoly provedení upgrade administrativních kopií na nové verze, aktualizaci nových verzí servisního balíčku a odstranění instalací.


Zavádění více klientů

Produkt SOLIDWORKS můžete nainstalovat na více klientů vytvořením administrativní kopie, kterou poté můžete nainstalovat na jednotlivé klienty.

Zavedení na klientské počítače probíhá následovně:
  1. Vytvoření administrativní kopie.
    • Vytvoření administrativní kopie pomocí Manažera instalací SOLIDWORKS
  2. Rozmístění administrativních kopií na klienty.
    • Nasazení administrativní kopie klientům prostřednictvím (e-mailové) metody Ruční / Technologie Pull
    • Nasazení administrativní kopie klientům prostřednictvím Automatické metody / Technologie Push
    • Instalace z administrativní kopie s použitím příkazového řádku
  3. Provedenísprávy licencí.
    • Správa jednotlivých součástí
    • Správa licencí za použití SolidNetWork License Manager
Nadřazené téma Násobné instalace
Použití administrativní kopie
Zavedení pomocí příkazového řádku
Správa násobných instalací


Použití administrativní kopie

Administrativní kopie umožňuje konfigurovatelné instalace produktů SOLIDWORKS z jediného místa v síti.

Administrativní kopii můžete nainstalovat z kteréhokoli počítače v síti, včetně klientského počítače.
  • Administrativní kopie se musí nacházet ve sdílené složce.
  • Pokud zahrnete všechny produkty, může požadavek na místo na disku administrativní kopie dosáhnout 17 GB a více.
  • Pokud aktualizujete název sdílení, když aktualizujete administrativní kopii, klient se automaticky aktualizuje při příštím spuštění aplikace. Podrobnosti najdete v Upgrade administrativní kopie.
  • Při zavádění administrativní kopie musí být cesta ke kopii kratší než 58 znaků.
  • Klienti musí mít oprávnění správce systému na svých počítačích. Pokud má klient nedostatečná oprávnění, může spustit instalaci jako odlišný uživatel. Tato volba je užitečná, když jednotliví uživatelé nemají na svých počítačích místní oprávnění správce, která jsou nutná k instalaci produktů SOLIDWORKS.

    Viz Zavádění instalací z editoru možností. Rovněž je zde popsán alternativní způsob instalace kopií, když má klient nedostatečná oprávnění.

  • Pokud je povoleno protokolování systému Windows nebo pokud používáte funkci stavu v Editoru možností administrativní kopie, musíte mít oprávnění pro čtení a zápis pro tuto složku: {Administrative image directory}\x64\Logs.

Po vytvoření administrativní kopie může Editor možností administrativní kopie spravovat nastavení možností instalace pro uživatele a skupiny, které provádí instalaci z dané kopie. Podrobnosti najdete v Editor možností administrativní kopie.

Obsah

  • Druhy administrativních kopií

    Editor možností administrativní kopie můžete použít k vytvoření několika typů snímků pro vzdálené uživatele a pro uživatele v síti.

  • Vytvoření administrativní kopie pomocí Manažera instalací SOLIDWORKS

    Pokud instalujete SOLIDWORKS na více počítačích, můžete vytvořit administrativní kopii a poté ji nainstalovat na ostatní počítače.

  • Editor možností administrativní kopie

    Editor možností administrativní kopie vám umožní přizpůsobit nastavení parametrů instalace v administrativní kopii pro jednotlivé počítače a pro skupiny počítačů.

  • Nástroj správce nastavení

Nadřazené téma Násobné instalace
Zavádění více klientů
Zavedení pomocí příkazového řádku
Správa násobných instalací
Upgradování klientů z administrativní kopie


Druhy administrativních kopií

Editor možností administrativní kopie můžete použít k vytvoření několika typů snímků pro vzdálené uživatele a pro uživatele v síti.

Typ administrativní kopie Popis
Standard

Tento obrázek je výchozí pro všechny nové administrativní kopie.

Jedná se o standardní administrativní kopii instalační služby systému Windows, která je ideální pro uživatele, kteří mají spolehlivý přístup k podnikové síti. Ukládá všechny soubory potřebné k instalaci vybraných produktů SOLIDWORKS do sdílené složky s kopiemi.

Když uživatelé provedou aktualizaci na nový Service Pack, mohou stahovat a používat soubory oprav a nemusí stahovat celou kopii.
Vzdálený klient

Tato kopie je určena pro vzdálené uživatele, kteří nemají spolehlivý přístup k podnikové síti.

Při instalaci tohoto typu kopie zdědí vzdálení uživatelé všechny zadané možnosti instalace, jako je sériové číslo a produkty k instalaci.

Uživatelé si tyto požadované soubory stahují přes internet ze stránky Stahování SOLIDWORKS. Přístup k těmto souborům a jejich instalace z internetu je spolehlivější než jejich stahování z firemní sítě a může snížit zatížení firemních sítí.

Vzdálení uživatele instalují tuto kopii pomocí stejných technik, které jsou podporovány standardní administrativní kopií. Instalace skriptů můžete stále provádět pomocí souborů sldim.exe a startwinstall.exe.

Instalační soubory se před instalací stahují do cesty zadané v Editoru možností administrativní kopie. Uživatelé musí mít přístup ke složce s administrativní kopií, aby mohli spustit instalaci a spustit všechny dávkové soubory nebo soubory nastavení hostované v této složce.

Vzdálení uživatelé musí mít dostatek volného místa na disku pro uložení všech souborů v kopii, i když uživatelé mohou po dokončení instalace kopii odstranit.
Komprimovaný

Komprimovaná administrativní kopie je určena pro organizace, které potřebují zkopírovat administrativní kopii pro více pracovišť nebo klientských počítačů a chtějí minimalizovat dopad na síť.

Tato kopie je o 60 % menší než standardní administrativní kopie, ale instaluje se ve stejném časovém intervalu. Podporuje všechny instalační operace, jako je úprava a oprava.

Komprimované administrativní kopie mají také krátké cesty k souborům. Tím se vyhnete problémům, když jsou kopie uloženy v hlubokých strukturách složek.

Když uživatelé upgradují na nový opravný balíček, musí stáhnout celou kopii, nejen opravy.
Nadřazené téma Použití administrativní kopie


Vytvoření administrativní kopie pomocí Manažera instalací SOLIDWORKS

Pokud instalujete SOLIDWORKS na více počítačích, můžete vytvořit administrativní kopii a poté ji nainstalovat na ostatní počítače.

  1. Spusťte Manažer instalací SOLIDWORKS.

    Viz Stažení souborů z instalačních médií.

  2. Na obrazovce Uvítání vyberte možnost Vytvořit administrativní kopie pro nasazení do více počítačů a zvolte jednu z následujících možností:
    Volba | Popis
    Vytvořit novou kopii pomocí výchozích nastavení. | Vytvořit kopii pomocí výchozích nastavení konfigurace (tj. nikoli na základě nastavení určených pro stávající administrativní kopii na vašem serveru).
    Vytvořte novou kopii pomocí nastavení a souborů ze stávající kopie. | Vytvořit kopii pomocí nastavení konfigurace určených pro stávající administrativní kopii na vašem serveru. Klepněte na Procházet a určete instalační adresář pro stávající administrativní kopii.
  3. Zadejte Sériová čísla SOLIDWORKS.
  4. Klikněte na Změnit a upravte produkty nebo výchozí možnosti, které zahrnují:
    • Umístění administrativní kopie
    • Typ administrativní kopie
  5. Přijměte licenční smlouvu a klikněte na Vytvořit nyní.
  6. Klikněte na Přizpůsobit kopii, čímž otevřete a zobrazíte nastavení v editoru možností administrativní kopie.
  7. Volitelné: Klikněte na možnost Vytvořit zástupce na ploše, abyste ke kopii měli přístup na ploše.
Nadřazené téma Použití administrativní kopie


Editor možností administrativní kopie

Editor možností administrativní kopie vám umožní přizpůsobit nastavení parametrů instalace v administrativní kopii pro jednotlivé počítače a pro skupiny počítačů.

Když vytváříte administrativní kopii, Manažer instalace SOLIDWORKS vás vyzve ke spuštění Editoru možností. Editor možností můžete také spustit poklepáním na sldAdminOptionEditor.exe ve složce administrativní kopie.

Chcete-li určit různé konfigurace instalace pro skupiny strojů nebo jednotlivé stroje, vyberte v Editoru možností stroje. Potom určete možnosti instalace pro tyto počítače.

Všechna dialogová okna, která žádají cestu složky nebo souboru, obsahují možnost mapování vybrané složky k proměnné prostředí. Pokud například vyberete možnost C:\Program Files\SOLIDWORKS Corp, je cesta k souboru mapována na umístění %ProgramFiles%\SOLIDWORKS Corp. Nejběžnější proměnné jsou %ProgramFiles% a %SystemDrive%.

Všechny cesty nelze mapovat na proměnné prostředí. Například nemůžete mapovat cestu Z:\SOLIDWORKS Data na proměnnou prostředí.

Obsah

  • Probíhá přidávání a odstraňování skupin a počítačů

    Editor možností administrativní kopie vám umožní určit různé konfigurační instalace pro skupiny počítačů a jednotlivé počítače.

  • Zobrazení a úpravy nastavení možnosti

    Editor možností administrativní kopie SOLIDWORKS umožňuje prohlížet a měnit nastavení možností pro skupiny a počítače určené pro danou kopii.

  • Zavádění instalací z editoru možností

    Instalace můžete zavádět přímo z Editoru možností, a to manuálně nebo automatickým spuštěním instalace.

  • Ukončení editoru možností

    Editor možností můžete ukončit kliknutím na tlačítko OK nebo Zavřít.

  • Vytvoření zástupce pro Editor možností na ploše

    Z aplikace můžete vytvořit zástupce Windows pro Editor možností na ploše pro konkrétní administrativní kopii.

  • Oznámení o administrativní kopii klientům e-mailem

    Po vytvoření sdíleného adresáře pro administrativní kopii můžete informovat klienty mailem.

Nadřazené téma Použití administrativní kopie


Probíhá přidávání a odstraňování skupin a počítačů

Editor možností administrativní kopie vám umožní určit různé konfigurační instalace pro skupiny počítačů a jednotlivé počítače.

Například můžete konfigurovat několik počítačů pro použití podskupiny součástí produktu, které jsou dostupné v kopii, zatímco jiná skupina může použít jinou podskupinu součástí. I když používáte administrativní kopii, nastavení skupina Editora možností vám umožní instalovat různé podskupiny produktů pro různé skupiny počítačů. Můžete přesouvat nastavení mezi skupinami a upravovat skupiny počítačů.

Také můžete skupiny počítačů rozdělovat do podskupin. Podskupiny zdědí nastavení po rodičovské skupině, ale individuální nastavení jednotlivých podskupin můžete změnit.

Chcete-li přidat skupinu:
  1. Klepněte pravým tlačítkem naGlobální nastavení a pak klepněte na Přidat skupinu.
  2. Zadejte název souboru.

Přidat počítače:
  1. Klepněte pravým tlačítkem na stávající skupinu nebo Globální nastavení a pak klepněte na Přidat počítač.
    Pokud klepnete pravým tlačítkem na existující skupinu, budou k této skupině přidány počítače. Jinak jsou přidány na nejvyšší úroveň.
  2. Proveďte jednu z následujících operací:
    • Vyberte Podle názvu počítače a zadejte název počítače.
      Název počítače nemůže zahrnovat kvalifikátor domény. Například název pluto.solidworks.com je chybný.
    • Vyberte Podle IP adresy a zadejte IP adresu počítače.
    • Vyberte Podle rozsahu IP adres a zadejte počáteční a koncovou IP adresu rozsahu.
    • Klikněte na položku Přidat počítače a zapište názvy počítačů. Názvy počítačů oddělte koncem řádku, mezerou, tabulátorem, čárkou, tečkou, dvojtečkou nebo středníkem. Seznam názvů počítačů můžete také zkopírovat a vložit ze souboru s oddělovačem položek, například *.xls nebo *.cvs do dialogového okna.

    Pokud přidáte počítače podle názvu, IP adresy a rozsahu IP adres, bude instalační zařízení hledat shodu v tomto pořadí: Název počítače, IP adresa a poté Rozsah IP adres. Možnosti instalace budou na daném počítači použity na základě první nalezené shody.

Návod na přesunutí existujícího počítače do skupiny nebo podskupiny:

Přetáhněte počítač do skupiny nebo podskupiny.

Návod na přesunutí počítače ze skupiny nebo podskupiny:

Přetáhněte počítač na Globální nastavení nebo do jiné skupiny či podskupiny.

Chcete-li odstranit skupinu, podskupinu nebo počítač:

Klikněte pravým tlačítkem na skupinu, podskupinu nebo počítač a klikněte na Odstranit skupinu nebo Odstranit počítač.

Pokud odstraníte skupinu, budou smazány všechny počítače uvnitř této skupiny.

Pro odstranění všech skupin a počítačů:

Klepněte pravým tlačítkem naGlobální nastavení a pak klepněte na Odstranit vše.

Nadřazené téma Editor možností administrativní kopie
Zobrazení a úpravy nastavení možnosti
Zavádění instalací z editoru možností
Ukončení editoru možností
Vytvoření zástupce pro Editor možností na ploše
Oznámení o administrativní kopii klientům e-mailem


Zobrazení a úpravy nastavení možnosti

Editor možností administrativní kopie SOLIDWORKS umožňuje prohlížet a měnit nastavení možností pro skupiny a počítače určené pro danou kopii.

  • Když poprvé spustíte editor možností, zobrazí se nastavení možností v režimu jen pro čtení. Ikona Změnit [image] není stínovaná.

    Klepnutím na Globální nastavení se pro skupinu nebo počítač zobrazí shrnutí nastavení možností pro danou položku:

    Rozsah | Zobrazené nastavení možností
    Globální nastavení | Všechna nastavení možností zadaná pro administrativní kopii
    Skupina | Změny v nastavení skupin vzhledem ke globálním nastavením
    Počítač | Změny v nastavení počítače vzhledem ke skupině
  • Chcete-li změnit nastavení možnosti, klikněte na příkaz Změnit [image]. Ikona se změní na stínovanou a zobrazí se podrobnější výpis nastavení možností.

    Po klepnutí na Globální nastavení budete moci pro skupinu nebo počítač změnit nastavení možností pro danou položku. Když provedete změnu nastavení možností, která se liší od zděděných globálních nastavení nebo nastavení skupiny, toto nastavení možností se zvýrazní.

    Když znovu kliknete na příkaz Změnit [image], zobrazení se vrátí zpět do režimu jen pro čtení.

    Když provedete změny, Editor možností vás vyzve, abyste je před skončením uložili nebo zrušili.

Obsah

  • Určení nastavení možností pro skupiny a počítače

    Můžete určit nastavení možnosti pro všechny počítače (Globální nastavení), skupiny počítačů a jednotlivé počítače.

  • Možnost nastavení administrativní kopie

    Editor možností vám umožňuje zadat možnosti pro individuální klienty nebo skupiny, včetně sériových čísel, možností klientské instalace, jaké součásti softwaru mají být instalovány a umístění toolbox.

  • Dědičnost globálních nastavení a nastavení možností skupin

    Nastavení možností pro Globální nastavení nebo skupiny dědí položky pod nimi.

  • Úprava nastavení v jednotlivých počítačích

    Nastavení, které se použije v jednotlivých počítačích, je možné upravit kliknutím pravým tlačítkem na název příslušného počítače.

Nadřazené téma Editor možností administrativní kopie
Probíhá přidávání a odstraňování skupin a počítačů
Zavádění instalací z editoru možností
Ukončení editoru možností
Vytvoření zástupce pro Editor možností na ploše
Oznámení o administrativní kopii klientům e-mailem


Určení nastavení možností pro skupiny a počítače

Můžete určit nastavení možnosti pro všechny počítače (Globální nastavení), skupiny počítačů a jednotlivé počítače.

  1. Klepněte na objekt, který chcete změnit (například Globální nastavení, skupinu, nebo počítač).
  2. Po pravé straně klikněte na příkaz Změnit [image].
    Ikona se změní na stínovanou a zobrazí se podrobnější výpis nastavení možností.
  3. Proveďte změny nastavení možností klepnutím na nastavení možností vpravo pro položku vybranou vlevo.
    Změny v nastavení možností, které potlačí Globální nastavení nebo nastavení skupin, jsou zvýrazněny.
  4. Klepnutím na OK nebo Zavřít uložte provedené změny.
    Volba | Popis
    OK | Editor možností uloží vaše změny a ukončí aplikaci.
    Zavřít | Editor možností zobrazí dotaz, zda chcete provedené změny uložit, a poté ukončí aplikaci.
Nadřazené téma Zobrazení a úpravy nastavení možnosti
Možnost nastavení administrativní kopie
Dědičnost globálních nastavení a nastavení možností skupin
Úprava nastavení v jednotlivých počítačích


Možnost nastavení administrativní kopie

Editor možností vám umožňuje zadat možnosti pro individuální klienty nebo skupiny, včetně sériových čísel, možností klientské instalace, jaké součásti softwaru mají být instalovány a umístění toolbox.

Sériová čísla

Zadejte sériová čísla pro instalaci produktů na klientských počítačích.
Některá sériová čísla mohou sloužit pro dva nebo více produktů, protože existuje několik způsobů zakoupení produktů SOLIDWORKS. Například sériové číslo SOLIDWORKS vám umožní nainstalovat SOLIDWORKS Simulation bez zadání sériového čísla SOLIDWORKS Simulation. Navíc některé produkty nevyžadují sériové číslo. Pokud máte jakékoli dotazy ohledně sériových čísel, kontaktujte místního prodejce (VAR).
Pokud spravujete licence pomocí správy licencí SolidNetWork:
  • Do prvního pole pro sériové číslo zadejte sériové číslo SolidNetWork.
  • Do pole SNL Server port@server zadejte název serveru SolidNetWork License Manager a port ve formátu nnnnn@název serveru. Více položek oddělte středníkem.

Více informací o správě licencí SolidNetWork viz Přehled instalace licencí SolidNetWork.

Možnosti klientské instalace

Jakým způsobem provést klientské instalace hlavních verzí? Můžete určit, jak budou klientské instalace nakládat se stávající instalací hlavní verze:
  • Upgradovat stávající hlavní verzi (pokud existuje).

    Určete tuto možnost, pokud chcete nahradit předchozí hlavní verzi instalací nové verze.

  • Vytvořit novou hlavní verzi.

    Tuto možnost zvolte, pokud chcete zachovat předchozí hlavní verzi a vytvořit novou instalaci pro novou hlavní verzi. Chcete-li zadat umístění pro instalaci nové verze, klepněte na Procházet.
Chcete nejprve odinstalovat předchozí verzi než nainstalujete novou hlavní verzi? Můžete určit, zda se má odinstalovat stávající instalace předchozí hlavní verze:
  • Neodinstalovat.

    Tuto možnost vyberte, chcete-li zachovat předchozí instalaci hlavní verze.

  • Odinstalovat nejnovější verzi.
  • Odinstalovat všechny verze.
Jakým způsobem se mají aplikovat nastavení programu SOLIDWORKS? Soubor nastavení můžete určit při spuštění softwaru. Klientské instalace odkazují na soubor nastavení. Soubor nastavení (*.sldsettings) je vhodné uložit do sdíleného umístění UNC, které je viditelné pro všechny instalace. Před instalací SOLIDWORKS zadejte cestu k souboru *.sldsettings. Klientské instalace detekují cestu k souboru *.sldsettings během instalace.
Zabezpečte soubor *.sldsettings určením takových oprávnění systému Windows, aby byl přístup pro zápis povolen pouze určeným uživatelům.

Když chcete vytvořit nebo upravit soubor *.sldsettings, klikněte na možnost Spustit správce nastavení. Nástroj SOLIDWORKS Správce nastavení umožňuje definovat, které možnosti systému SOLIDWORKS použít a volitelně uzamknout pro koncové uživatele. Můžete také určit, jak a kdy se nastavení použijí na individuální instalace, a kdykoli upravit soubor *.sldsettings prostřednictvím spuštění nástroje Správce nastavení a přepsáním existujícího souboru.

Můžete použít různé soubory *.sldsettings pro různé počítače nebo skupiny.

Cesta k souboru *.sldsettings se nastavuje při instalaci. Po instalaci se soubor *.sldsettings nesmí přejmenovat ani přesunout.

Ke spuštění nástroje Správce nastavení potřebujete existující instalaci SOLIDWORKS [aktuální hlavní verze].
Jak aktivovat klientské instalace? Můžete určit, zda chcete dokončit aktivaci produktu automaticky po spuštění instalace, nebo zda má aktivaci produktu provést po instalaci ručně uživatel.
  • Aktivovat automaticky po dokončení každé klientské instalace.

    Výběr této možnosti určuje, že se aktivace produktu spustí automaticky. Zadejte e-mailovou adresu, která bude informována při spuštění aktivace v klientském počítači.

  • Neaktivovat automaticky.

    Výběr této možnosti znamená, že nedojde k žádné automatické aktivaci produktu. Uživatel klienta provede aktivaci produktu po instalaci.

Možnosti správy

Vytvořit diagnostický protokol během každé instalace. | Klientská instalace může vytvořit diagnostický protokol pro odstraňování problémů s instalací. Vytvoření tohoto protokolu může zpomalit klientskou instalaci. Soubor protokolu je uložen v umístění složka administrativní kopie}\x64\Logs\<název_počítače>.
Spustit instalaci jako jiný uživatel.

Můžete určit jiného uživatele s oprávněními správce, který bude spouštět instalaci namísto přihlášeného uživatele. Tato volba může být užitečná, když jednotliví uživatelé nemají na svých počítačích místní oprávnění správce, která jsou nutná k instalaci produktů SOLIDWORKS.

Pro případ, že klienti nemají oprávnění správce, je k dispozici alternativní metoda rozmístění a instalace. Viz Zavádění instalací z editoru možností.
Spustit program před nebo po instalaci. | Můžete určit, že se má před klientskou instalací nebo po ní spustit vlastní program.
Chcete se zúčastnit Programu zkušeností zákazníka SOLIDWORKS? | Můžete určit, že se klientské počítače mají účastnit Programu zkušeností zákazníků SOLIDWORKS. Informace o výkonu jsou zasílány společnosti SOLIDWORKS Corporation, aby pomáhaly zlepšovat produkt. Tento proces je transparentní a důvěrný. Více informací viz Webová stránka Programu na zlepšení zkušeností zákazníků.

Omezení možností Spustit program před a po instalaci.

Tyto možnosti umožňují spustit v klientských počítačích další instalační programy nebo skripty před nebo po nasazení SOLIDWORKS, například skript, který nainstaluje Microsoft Office.

Použití těchto možností je určitým způsobem omezeno. Dojde k selhání při použití této možnosti pro instalaci programu nebo skriptu, který zobrazuje uživatelské rozhraní, například skriptu, který zobrazí dialogová okna. Pokud je spuštěno automatické zavádění SOLIDWORKS, nepodaří se software SOLIDWORKS nainstalovat do cílových počítačů.

Jestliže chcete použít možnosti Spustit program před instalací a Spustit program po instalaci, vyberte pouze programy, které lze instalovat v bezobslužném režimu.

Software k instalaci

Můžete určit, které součásti produktu SOLIDWORKS se mají nainstalovat.
  • Výběrem zaškrtávacího políčka vedle součásti produktu určíte, že se má daná součást nainstalovat během klientské instalace.
  • Je-li výběr zaškrtávacího políčka zrušen, příslušná součást nebude nainstalována.
  • Pokud je u součásti k dispozici volitelná instalace dílčích součástí, zobrazí se vedle součásti ikona +. Chcete-li zobrazit dostupné dílčí součásti pro danou součást, klepněte na ikonu +.
  • V případě rozbalení součásti a zobrazení volitelných dílčích součástí se vedle součásti zobrazí ikona -. Chcete-li sbalit výpis dílčích součástí, klepněte na ikonu -.
Specifikace Jazyky omezuje jazyky, které jsou nainstalovány jen pro produkt SOLIDWORKS. Toto nastavení nemá vliv na instalace ostatních produktů. Například aplikace eDrawings® instaluje všechny jazyky.

Možnosti Toolbox

Můžete určit, které normy mají být podporovány, a výchozí umístění Toolbox pro klientské instalace.

Je běžné, že má více uživatelů přístup ke sdílené knihovně Toolbox, typicky prostřednictvím síťového umístění (například cesty UNC, sdílené složky nebo určené obecné síťové jednotky).

Pokud umístění obsahuje starší hlavní verzi Toolbox, klientská instalace upgraduje Toolbox na novou hlavní verzi. Soubory již nebudou kompatibilní s předchozími hlavními verzemi SOLIDWORKS.
Pokud někteří klienti nadále používají starší verzi SOLIDWORKS, musíte určit odlišné síťové umístění systému Toolbox pro klienty, kteří upgradují na novější verzi.

Podrobnosti o správě SOLIDWORKS Toolbox viz informace o Toolbox v Nápovědě SOLIDWORKS.

Instalace softwaru Toolbox bez instalace dat Toolbox

Pokud vaše prostředí obsahuje systém PDM nebo sdílené umístění nástroje Toolbox/Průvodce dírami, můžete nastavit klientské instalace tak, aby neinstalovaly ani neupgradovaly data nástroje Toolbox v příslušném umístění.

Udělejte to v těchto případech:
  • Ještě jste nenakonfigurovali místní pohled SOLIDWORKS PDM před instalací softwaru SOLIDWORKS.
  • Soubory v tomto umístění se používají a mohou blokovat dokončení instalací SOLIDWORKS.
  • Umístění není dostupné a může blokovat dokončení instalací SOLIDWORKS.

Když nakonfigurujete klientské instalace tak, aby neinstalovaly data nástroje Toolbox, software SOLIDWORKS a nastavení budou odkazovat na umístění nástroje Toolbox/Průvodce dírami, ale data musíte nainstalovat do centrálního umístění později.

Jak nainstalovat software SOLIDWORKS bez dat Toolbox/průvodce dírami:
  • Když budete požádáni, zda chcete, aby tento klient instaloval/upgradoval soubory Toolbox, vyberte Ne, instalovat software Toolbox bez souborů dat.

Alespoň jedna osoba, typicky správce CAD, musí instalovat nebo upgradovat data Toolbox/Průvodce dírami v centrálním umístění, jinak nebude software fungovat správně. Kdokoli v organizaci tuto úlohu zvládne s použitím jediné manuální instalace softwaru SOLIDWORKS. Pokud spravujete nástroj Toolbox v softwaru SOLIDWORKS PDM, proveďte instalaci nebo upgrade dat Toolbox podle kroků uvedených v části Toolbox v Průvodci správou SOLIDWORKS PDM.

Možnosti klienta SOLIDWORKS PDM

Následující možnosti pro nasazení klientů a doplňkových modulů SOLIDWORKS PDM lze změnit:

  • Typ produktu PDM
  • Typ klienta PDM
  • Prvky
  • Pohled úschovny.

    Chcete-li otevřít Průvodce nastavením pohledu, musíte spustit Editor možností administrativní kopie na počítači s nainstalovaným klientem SOLIDWORKS PDM.

    Chcete-li vytvořit pohled úschovny v klientském počítači, potřebujete soubor nastavení pohledu Conisio (.cvs), který definuje parametry pro konfiguraci pohledu úschovny v klientském počítači. Můžete odkazovat na existující soubor .cvs nebo jej vytvořit z Editoru možností administrativní kopie.

Další informace o těchto klientech a doplňkových modulech najdete v části SOLIDWORKS PDM Nápovědy SOLIDWORKS.

Možnosti Electrical

Pro administrativní součásti softwaru SOLIDWORKS Electrical můžete zadávat následující parametry:
  • Cesta k datům
  • Název počítače a číslo portu Collaborative Server
  • Název počítače a číslo portu serveru SQL

Další informace o těchto součástech viz SOLIDWORKS Electrical .

Nadřazené téma Zobrazení a úpravy nastavení možnosti
Určení nastavení možností pro skupiny a počítače
Dědičnost globálních nastavení a nastavení možností skupin
Úprava nastavení v jednotlivých počítačích
Přehled instalace licencí SolidNetWork
Zavádění instalací z editoru možností
SOLIDWORKS Electrical


Dědičnost globálních nastavení a nastavení možností skupin

Nastavení možností pro Globální nastavení nebo skupiny dědí položky pod nimi.

Například:
  • Nastavení definovaná pro Globální nastavení dědí všechny skupiny a počítače.
  • Nastavení definovaná pro skupiny dědí všechny podskupiny a počítače uvnitř této skupiny.

Můžete změnit nastavení možností pro skupinu, podskupinu nebo počítač tak, aby se přepsala výchozí nebo zděděná nastavení. Když změníte nastavení možností z výchozí nebo zděděné hodnoty, volba je zvýrazněna.

Chcete-li vrátit nastavení možností na původní zděděné hodnoty, klikněte pravým tlačítkem myši na skupinu, podskupinu nebo zařízení a poté klikněte na jednu z následujících možností:
  • Obnovit globální nastavení (pro skupinu nebo počítač, který není členem skupiny)
  • Obnovit skupinová nastavení (pro počítač, který je členem skupiny)
  • Vrátit členy na nastavení skupiny (pro všechny členy této skupiny najednou)
Nadřazené téma Zobrazení a úpravy nastavení možnosti
Určení nastavení možností pro skupiny a počítače
Možnost nastavení administrativní kopie
Úprava nastavení v jednotlivých počítačích


Úprava nastavení v jednotlivých počítačích

Nastavení, které se použije v jednotlivých počítačích, je možné upravit kliknutím pravým tlačítkem na název příslušného počítače.

V místní nabídce můžete u jednotlivých počítačů provést tyto úlohy:
  • Přejmenovat
  • Odstranit počítač
  • Obnovit globální nastavení
  • Upravit poznámky
  • Možnosti úpravy

V nabídce Upravit možnosti můžete upravit jednotlivé možnosti počítače, například možnosti klientské instalace nebo možnosti správy.

Nadřazené téma Zobrazení a úpravy nastavení možnosti
Určení nastavení možností pro skupiny a počítače
Možnost nastavení administrativní kopie
Dědičnost globálních nastavení a nastavení možností skupin


Zavádění instalací z editoru možností

Instalace můžete zavádět přímo z Editoru možností, a to manuálně nebo automatickým spuštěním instalace.

  • Ze stránky Zavést manuálně v Editoru možností můžete zaslat uživatelům e-mail s pokyny o tom, jak instalaci spustit. Tento způsob použijte v případě, že uživatelé mají ve svých klientských počítačích oprávnění správce.
    V části Možnosti správy můžete uživatelům přiřadit oprávnění správce výběrem položky Spustit instalaci jako jiný uživatel.
  • Ze stránky Zavést automaticky v Editoru možností můžete instalaci na cílových počítačích spouštět automaticky. Tuto metodu použijte, pokud uživatelé nemají oprávnění potřebná pro instalaci softwaru v jejich systému. Tímto způsobem je také možné provést vlastní instalace.

Chcete-li nasazení provést ručně nebo automaticky, musíte uložit instalační adresář administrativní kopie do sdíleného adresáře Windows, aby byla dostupná prostřednictvím síťového umístění, např. \\machine\shared_directory. Kopii můžete také zpřístupnit zkopírováním do místního adresáře na každém počítači, např. C:\SOLIDWORKS Admin\SOLIDWORKS 2025 SP0.

Obsah

  • Použití cesty UNC k zavedení administrativní kopie

    Namísto mapování umístění síťových jednotek použijte při určení síťového umístění pro adresář instalace administrativní kopie cestu UNC (\\machine_name\share_name).

  • Zavedení administrativní kopie pomocí příkazu StartSWInstall.exe

  • Manuální zavádění softwaru

    Tuto metodu lze použít, pokud mají uživatelé oprávnění potřebná pro instalaci v jejich systému.

  • Předpoklady pro automatické zavedení

    Automatické nasazení je užitečné pro uživatele bez oprávnění správce, protože zajistí hladký průběh instalace softwaru.

  • Automatické zavádění softwaru

  • Testování instalace pro nabízené nasazení

    Záložka Zavést automaticky v editoru možností administrativní kopie obsahuje zkušební funkci.

Nadřazené téma Editor možností administrativní kopie
Probíhá přidávání a odstraňování skupin a počítačů
Zobrazení a úpravy nastavení možnosti
Ukončení editoru možností
Vytvoření zástupce pro Editor možností na ploše
Oznámení o administrativní kopii klientům e-mailem


Použití cesty UNC k zavedení administrativní kopie

Namísto mapování umístění síťových jednotek použijte při určení síťového umístění pro adresář instalace administrativní kopie cestu UNC (\\machine_name\share_name).

Mapované síťové jednotky nejsou kompatibilní s metodou instalace s technologií push a automatickou instalací, stejně jako s možností Spustit jako jiný uživatel v metodě s technologií pull a ruční instalací.

Nadřazené téma Zavádění instalací z editoru možností


Zavedení administrativní kopie pomocí příkazu StartSWInstall.exe

Na klientské počítače můžete nainstalovat nebo z nich odinstalovat administrativní kopii spuštěním příkazu admin_image_install_dir\ StartSWInstall.exe. Při použití této metody dojde k instalaci SOLIDWORKS s možnostmi, počítači a skupinami definovanými v Editoru možností administrativní kopie.

K příkazu StartSWInstall.exe můžete připojit následující přepínače:
Přepínač | Popis
/install | Nainstaluje administrativní kopii na klientské počítače.
/uninstall Odebere instalaci softwaru z klientských počítačů. Zde jsou k dispozici dva volitelné přepínače:

/removedata

Přepínač je k dispozici pouze pro odebrání instalace. Během odebrání instalace odstraní datové soubory a složky SOLIDWORKS.

/removeregistry

Přepínač je k dispozici pouze pro odebrání instalace. Během odebrání instalace odstraní položky registru SOLIDWORKS.
/showui | Zobrazí okno Manažera instalací SOLIDWORKS s informacemi o průběhu. V ostatních případech je Manažer instalací SOLIDWORKS uživateli skrytý.
/now | Spustí instalaci nebo odebrání instalace okamžitě. V tomto případě se nezobrazí dialogové okno s upozorněním na 5minutový interval do spuštění.

Příkaz StartSWInstall.exe se doporučuje použít namísto příkazu StartSWInstall.hta v případech, kdy chcete, aby instalace probíhala bez zásahu uživatele, ale nechcete použít automatické zavedení pomocí Editoru možností administrativní kopie.

Nadřazené téma Zavádění instalací z editoru možností


Manuální zavádění softwaru

Tuto metodu lze použít, pokud mají uživatelé oprávnění potřebná pro instalaci v jejich systému.

Chcete-li zavést instalaci manuálně přes e-mail, postupujte takto:

  1. V Editoru možností klepněte na Zavést.
    Objeví se dostupnost instalace a stav pro jednotlivé počítače.
  2. Klepněte na Odeslat e-mail.
  3. Zadejte síťovou cestu k instalačnímu adresáři administrativní kopie.
    Typicky se cesta k instalačnímu adresáři administrativní kopie zobrazuje nejprve jako cesta k souboru Windows (například C:\SOLIDWORKS Admin\SOLIDWORKS 2025 SP0). V dialogovém okně se zobrazí Tato cesta není síťová cesta.
    1. Klepněte na Procházet a určete síťové umístění pro tento instalační adresář pro administrativní kopii.
    2. Vyhledejte počítač, na němž je nainstalována administrativní kopie a vyberte sdílený adresář Windows, který jste specifikovali jako instalační adresář pro administrativní kopii.
      Nepřecházejte do sdíleného adresáře administrativní kopie (například do podadresářů 64bit).
    3. Klepněte na tlačítko OK.
      V dialogovém okně se zobrazí Tato cesta je síťová cesta.
    Vygeneruje se e-mail s pokyny pro majitele počítače ohledně instalace z administrativní kopie v síťovém umístění pro soubor administrativní kopie StartSWInstall.hta.
  4. Odešlete tento e-mail uživatelům odpovědným za instalaci SOLIDWORKS.

Uživatelé mohou nainstalovat SOLIDWORKS z administrativní kopie poklepáním na odkaz na síťové umístění pro soubor StartSWInstall.hta v e-mailu.

V Editoru možností se pod položkou Stav instalace zobrazí:
Čeká na vyřízení | Uživatel zatím nespustil na tomto počítači instalaci.
Úspěšný | Uživatel úspěšně dokončil instalaci na tomto počítači.
Neúspěšný | Uživatel spustil instalaci na tomto počítači, ale ta selhala.
Ostatní stavové zprávy, které se mohou zobrazit: Instalace úspěšně dokončena, Odinstalace úspěšně dokončena, Instalace, Odinstalování, Je vyžadován restart systému, Instalace se nezdařila a Odinstalace se nezdařila.
Kliknutím na zelenou šipku v horní části sloupce Stav obnovíte a zobrazíte aktualizované informace.
Nadřazené téma Zavádění instalací z editoru možností


Předpoklady pro automatické zavedení

Automatické nasazení je užitečné pro uživatele bez oprávnění správce, protože zajistí hladký průběh instalace softwaru.

Chcete-li automatické nasazení použít, musí klient i server patřit do stejné domény služby Active Directory. Tato konfigurace umožňuje delegovat úlohy instalace na cílové počítače, kde je potom provádí Plánovač úloh Microsoft, aniž by uživatel musel provádět jakékoli akce.

Při push instalaci plánovač úloh spustí úlohu, která spustí Manažera instalací SOLIDWORKS na klientském počítači s použitím ověřovacích údajů zadaných správcem v Editoru možností. Plánovač úloh se spouští s použitím účtu LocalSystem. Tento účet je reprezentován v síti jako objekt zabezpečení počítače. Objekt zabezpečení počítače musí mít následující přístup:
  • Přístup ke čtení ke složce Admin Images.
  • Přístup pro čtení a zápis ke složce Admin Images\x64\logs.

Když ve službě Active Directory přidáte počítač do skupiny sdílené složky, vyberte Typy objektů a Počítače.

Kromě toho musí být počítač hostující administrativní kopii i cílové klientské počítače členy stejné domény Active Directory.

Nadřazené téma Zavádění instalací z editoru možností


Automatické zavádění softwaru

Chcete-li provést automatické zavedení spuštěním instalace v systémech uživatelů, postupujte takto:

  1. V Editoru možností klepněte na záložku Automaticky zavést.
    Objeví se dostupnost instalace a stav pro jednotlivé počítače.
  2. Ve sloupci Zavést vyberte cílové klientské počítače a skupiny ve sloupci Zavést.
    Před zahájením procesu nasazení vyberte ve sloupci Zavést alespoň jeden počítač nebo skupinu.
  3. Položku Čas instalace nastavte na Nyní, pokud chcete instalaci provést ihned, nebo Později, pokud chcete instalaci naplánovat na určité datum a čas.
  4. V části Možnosti klienta vyberte jednu z následujících možností:
    • Instalace nebo upgrade softwaru SOLIDWORKS 2025
    • Odinstalace softwaru SOLIDWORKS 2025
      Vyberete-li odinstalaci, můžete nastavit, zda mají být spolu se soubory a složkami softwaru odstraněny i záznamy v registru a datové soubory.
  5. Vyberte Automaticky restartovat počítač pokud je požadováno restartování jednoho nebo více cílových počítačů během instalace nebo po instalaci.
  6. Zadejte Přihlašovací údaje klienta jednoho nebo více cílových počítačů.
  7. Kliknutím na Zavést zahájíte proces instalace.
V Editoru možností se zobrazí tento Stav instalace:
Čeká na vyřízení | Instalace zatím nebyla na tomto počítači spuštěna.
Úspěšný | Instalace na tomto počítači byla úspěšně dokončena.
Neúspěšný | Instalace na tomto počítači se nezdařila.

Ostatní stavové zprávy, které se mohou zobrazit: Instalace úspěšně dokončena, Odinstalace úspěšně dokončena, Plánování, Připojování, Instalace, Odinstalace, Je vyžadován restart systému, Instalace naplánována, Odinstalace naplánována, Instalace se nezdařila, Odinstalace se nezdařila, Připojení se nezdařilo a Plánování se nezdařilo.

Nadřazené téma Zavádění instalací z editoru možností


Testování instalace pro nabízené nasazení

Záložka Zavést automaticky v editoru možností administrativní kopie obsahuje zkušební funkci.

Můžete spustit simulovanou instalaci, která ověřuje systémy použité při nasazení, mezi které patří:
  • Připojení k cílovému počítači.
  • Vytvoření úlohy instalace na tomto počítači.
  • Dokončení úlohy instalace na tomto počítači.
  • Aktualizace stavu a protokolů administrativní kopie.
  • Detekce programu, který se má spustit před instalací nebo po instalaci.

Test ověřuje cesty k souborům, oprávnění a ohlásí, že instalace byla úspěšně dokončena. Přitom se neinstaluje žádný software ani nemodifikuje registr počítače. Pokud systém selže na jakémkoli cílovém počítači, test indikuje, který systém selhal.

Místní popisy poskytují více informací o selháních. Výsledky můžete exportovat do tabulky .xml (nebo souboru .csv), což je užitečné, pokud se řeší více selhání nebo při sdílení výsledků s jinými pracovníky podpory.

Postup ověření instalace nabízeného oznamování:

  1. S použitím Manažera instalací vytvořte administrativní kopii.
  2. Spusťte editor možností administrativní kopie.

    Editor možností můžete spustit, potom co Manažer instalací dokončí vytváření administrativní kopie, nebo poklikáním na sldAdminOptionEditor.exe ve složce administrativní kopie.

  3. Na záložce Instalace přidejte jeden nebo více počítačů.
  4. Klikněte na Zavést automaticky:
    1. Zadejte uživatelské jméno a heslo správce domény.
    2. Vyberte jeden nebo více počítačů k otestování.
    3. Klepněte na Test.
  5. Jakmile se objeví Test instalace klikněte na Spustit test.
  6. Vyčkejte na dokončení testu (může trvat i několik minut) nebo můžete kdykoli stisknout Zrušit test.
  7. Zkontrolujte a opravte jakékoli problémy s instalací.
Nadřazené téma Zavádění instalací z editoru možností


Ukončení editoru možností

Editor možností můžete ukončit kliknutím na tlačítko OK nebo Zavřít.

  • Kliknutím na tlačítko OK aplikujete změny nastavení možností a ukončíte Editor možností.
  • Kliknutím na tlačítko Zavřít v aplikaci Windows ukončíte Editor možností. Pokud software zjistí neuložené změny, vyzve vás k uložení.
Nadřazené téma Editor možností administrativní kopie
Probíhá přidávání a odstraňování skupin a počítačů
Zobrazení a úpravy nastavení možnosti
Zavádění instalací z editoru možností
Vytvoření zástupce pro Editor možností na ploše
Oznámení o administrativní kopii klientům e-mailem


Vytvoření zástupce pro Editor možností na ploše

Z aplikace můžete vytvořit zástupce Windows pro Editor možností na ploše pro konkrétní administrativní kopii.

  1. Spusťte Editor možností.
    V Průzkumníku souborů vyhledejte instalační adresář administrativní kopie a poklepejte na soubor sldAdminOptionEditor.exe.
  2. Klepněte na Vytvořit zástupce na ploše pro tento Editor možností.
    Na ploše Windows se objeví zástupce Editoru možností administrativní kopie.
Nadřazené téma Editor možností administrativní kopie
Probíhá přidávání a odstraňování skupin a počítačů
Zobrazení a úpravy nastavení možnosti
Zavádění instalací z editoru možností
Ukončení editoru možností
Oznámení o administrativní kopii klientům e-mailem


Oznámení o administrativní kopii klientům e-mailem

Po vytvoření sdíleného adresáře pro administrativní kopii můžete informovat klienty mailem.

Nakonfigurujte adresář administrativní kopie tak, aby byl sdílen na počítači, který je přístupná jiným počítačům (například pomocí cesty UNC).

Můžete zaslat všem klientům e-mail obsahující odkaz na instalační_adresář_administrativní_kopie\StartSWInstall.hta pro všechny klienty. Klienti poté mohou klepnutím na tento odkaz a výběrem Nyní instalovat SOLIDWORKS spustit instalaci z administrativní kopie.

Chcete-li upgradovat administrativní kopii na novou verzi SOLIDWORKS, můžete konfigurovat místo vaší administrativní kope a sdílené vlastnosti tak, že všichni klienti, kteří byli nainstalováni předtím za použití kopie, budou upgradováni automaticky. Podrobné informace najdete pod odkazem Upgrade klientů z administrativních kopií.
Nadřazené téma Editor možností administrativní kopie
Probíhá přidávání a odstraňování skupin a počítačů
Zobrazení a úpravy nastavení možnosti
Zavádění instalací z editoru možností
Ukončení editoru možností
Vytvoření zástupce pro Editor možností na ploše


Nástroj správce nastavení

Nástroj pro správu nastavení můžete použít ke stanovení možností systému, které se použijí při nasazení nebo upgradu softwaru SOLIDWORKS, a zabránění uživatelům ve změně těchto možností. Tento nástroj nahrazuje Průvodce nastavením SOLIDWORKS pro zavádění nastavení. Starší nástroj ale zůstává stále dostupný pro kopírování nastavení.

Tři kroky používání Nástroje pro správu nastavení pomocí Editoru možností administrativní kopie:
  1. Vytvořte administrativní kopii pro přístup k nástroji.
  2. Použijte Nástroj pro správu nastavení k vytvoření souboru *.sldsettings, který obsahuje vámi vybrané možnosti SOLIDWORKS.
  3. Přidejte soubor *.sldsettings do instalací SOLIDWORKS.
Jestliže používáte doplněk 3DEXPERIENCE, můžete také nasadit soubor *.sldsettings mimo administrativní kopii. Výhodou použití této metody je, že se nastavení automaticky nasadí při přihlášení.
  1. Pro přístup k nástroji pro správu nastavení postupujte podle kroků uvedených v části Otevření Nástroje správce nastavení.
  2. Pomocí pokynů použijte a uzamkněte nastavení.
  3. V části 3DEXPERIENCE Kompas rozbalte část Moje role a klikněte na aplikaci Platform Manager. Přejděte do části Obsah > Centrum konfigurace prostorů pro spolupráci > Spolupráce CAD > SOLIDWORKS > Nastavení > Zdroje > Nastavení CAD.
  4. V části Nastavení CAD procházením najděte, nahrajte a stáhněte soubor *.sldsettings.

Obsah

  • Otevření Nástroje správce nastavení

    Pro přístup k nástroji Správce nastavení musíte nejprve vytvořit administrativní kopii.

  • Použití Nástroje správce nastavení

  • Použití a uzamykání možností

  • Dokončení nastavení možností

  • Zahrnutí souboru sldsettings do instalací SOLIDWORKS

Nadřazené téma Použití administrativní kopie


Otevření Nástroje správce nastavení

Pro přístup k nástroji Správce nastavení musíte nejprve vytvořit administrativní kopii.

Nástroj správce pro nastavení spustíte z administrativní kopie.

Postup otevření Nástroje správce nastavení:

  1. Spusťte soubor sldAdminOptionEditor.exe ve složce administrativní kopie.
  2. V Editoru možností administrativní kopie klikněte na příkaz Změnit [image].
  3. V části Možnosti klientské instalace proveďte následující:
    1. Klikněte na možnost Použít soubor nastavení exportovaný ze správce nastavení SOLIDWORKS.
    2. Klikněte na možnost Spustit správce nastavení.
      Chcete-li získat přístup ke Správci nastavení spuštění, musí být v počítači se spuštěnou aplikací SOLIDWORKS <version> nainstalován software sldAdminOptionEditor.exe.
Nadřazené téma Nástroj správce nastavení


Použití Nástroje správce nastavení

Postup použití Nástroje správce nastavení:

  1. Na záložce Vítejte vyberte následující možnosti:
    • Výchozí sada možností pro spuštění pro tuto verzi SOLIDWORKS.
    • Importovat možnosti SOLIDWORKS 2025 z tohoto počítače.
    • Vyhledat stávající soubor sldreg.
    • Vyhledejte stávající soubor .sldsettings.
    Soubor *.sldreg je generován Průvodcem nastavením SOLIDWORKS a soubor *.sldsettings je generován Nástrojem správce nastavení.
  2. Klikněte na tlačítko Další.
Nadřazené téma Nástroj správce nastavení


Použití a uzamykání možností

Na kartě Možnosti systému jsou dva sloupce zaškrtávacích políček, kde můžete určit, jaké možnosti budou platit a které z nich budou uzamknuty, aby je uživatelé nemohli změnit.

Když uživatel otevře kartu Možnosti systému v softwaru SOLIDWORKS, uzamknuté možnosti nebudou dostupné a budou označeny ikonou zámku [image]. Můžete však vytvořit heslo, které uživatelům umožní si možnosti odemknout. Když uživatel umístí ukazatel nad uzamknutou možnost, zobrazí se tip s vaším jménem a e-mailovou adresou, aby vás mohli kontaktovat a vyžádat si heslo.

Postup použití a uzamknutí možností:

  1. Na kartě Možnosti systému proveďte toto:
    1. Chcete-li použít systémovou možnost, vyberte ji a zaškrtněte odpovídající políčko ve sloupci Použít.
    2. Chcete-li uzamknout možnost, vyberte ji a zaškrtněte odpovídající políčka v obou sloupcích Použít a Zamknout.
      Když uživatel otevře kartu Možnosti systému, tyto možnosti se zobrazí s ikonou zámku [image].
  2. V závislosti na možnosti můžete určit další parametry pro příslušnou možnost.
  3. Uživatelům také můžete zakázat zrušit zobrazení zpráv použitím ovládacích prvků ve skupině Zprávy/chyby/upozornění.
    1. Klikněte na položku Zprávy/chyby/upozornění.
    2. Vyberte možnost Použít a volitelně vyberte položku Uzamknout u těch zpráv, jejichž správu chcete provádět.
    3. Nastavte, zda se zprávy mají Zobrazovat nebo Nezobrazovat.

      Když vyberte položku Zobrazovat, je zpráva odebrána ze seznamu zrušených zpráv uživatele a v příslušný okamžik se uživateli zobrazí. Když vyberte položku Nezobrazovat, zpráva se automaticky přidá do seznamu zrušených zpráv uživatele a nezobrazí se, když uživatel pracuje na modelu.

      Tato tabulka popisuje chování v softwaru:
      Použít | Zámek | Zobrazit | Nezobrazovat | Chování
      X | X | Vynuceně zprávu zobrazí.
      X | X | Přestane brát zprávu do úvahy a přidá ji do seznamu zrušených zpráv uživatele.
      X | X | X | Vynuceně zprávu zobrazí a deaktivuje možnost Nezobrazovat. v oknu zprávy.
      X | X | X | Přestane brát zprávu do úvahy zakáže uživateli ji aktivovat v dialogovém okně Nástroje > Možnosti > Zprávy/chyby/upozornění.
  4. Na kartě Možnosti systému klikněte na tlačítko Další.
Nadřazené téma Nástroj správce nastavení


Dokončení nastavení možností

Postup dokončení nastavení možností:

  1. Na záložce Dokončit vyberte, kdy se mají použít možnosti systému:
    • poprvé když uživatel spustí software.
    • při každém spuštění softwaru.
    • a zda se mají současně použít přizpůsobení.
  2. Můžete vybrat, zda se mají použít uzamknuté možnosti, když uživatel není v síti a povolit API přepsání uzamknutých možností.
  3. V případě uzamknutých možností systému musíte poskytnout vaše Jméno a e-mailovou adresu. Software SOLIDWORKS zobrazí tyto informace v popisu, který se objeví při najetí myší na uzamknutou možnost.
  4. Můžete také umožnit uživatelům přepsat uzamknuté možnosti. Musíte určit heslo, které můžete sdělit uživatelům.
  5. Kliknutím na Uložit generujete soubor *.sldsettings pro nasazení.
Nadřazené téma Nástroj správce nastavení


Zahrnutí souboru sldsettings do instalací SOLIDWORKS

Postup zahrnutí souboru *.sldsettings do instalace:

  1. Dvakrát klikněte na soubor sldAdminOptionEditor.exe ve složce administrativní kopie.
  2. V Editoru možností administrativní kopie klikněte na příkaz Změnit.
  3. V části Možnosti klientské instalace proveďte následující:
    1. Klikněte na možnost Použít soubor nastavení exportovaný ze správce nastavení SOLIDWORKS.
    2. Klikněte na příkaz Upravit cestu a vyhledejte soubor *.sldsettings.
    Můžete vytvořit a použít různé soubory *.sldsettings pro různé skupiny nebo počítače.
  4. Proveďte nasazení a instalaci softwaru SOLIDWORKS.

Po nasazení můžete zopakovat krok 2 a kdykoli změnit existující soubor *.sldsettings. Software SOLIDWORKS načte změněný soubor *.sldsettings při příštím spuštění.

Nadřazené téma Nástroj správce nastavení


Zavedení pomocí příkazového řádku

Administrativní kopii můžete automaticky zavést příkazového řádku nebo dávkového souboru (tichá instalace).

Chcete-li nasadit administrativní obraz pomocí příkazového řádku pro klienty SOLIDWORKS PDM, informace najdete v průvodci instalací SOLIDWORKS PDM.

Obsah

  • Příprava klientů na instalaci z příkazového řádku z administrativní kopie

    Po vytvoření administrativní kopie a před tím, než budete informovat klienty, musíte nainstalovat komponenty Microsoft Windows, které nelze nainstalovat prostřednictvím administrativní kopie a které je nutno nainstalovat za použití příkazového řádku nebo Microsoft Active Directory.

  • Instalace z administrativní kopie s použitím příkazového řádku

    Můžete rozmístit instalace z administrativní kopie za použití příkazového řádku.

  • Vlastnosti v příkazovém řádku

    Vlastnosti v příkazovém řádku zde popisují vlastnosti funkcí, globální vlastnosti, produktově specifické vlastnosti a konvence umístění Windows.

  • Zavádění administrativní kopie pomocí Microsoft Active Directory

    Rozmístění pomocí služby Microsoft Active Directory se používá pro instalaci hlavních produktů SOLIDWORKS na klientské počítače.

Nadřazené téma Násobné instalace
Zavádění více klientů
Použití administrativní kopie
Správa násobných instalací


Příprava klientů na instalaci z příkazového řádku z administrativní kopie

Po vytvoření administrativní kopie a před tím, než budete informovat klienty, musíte nainstalovat komponenty Microsoft Windows, které nelze nainstalovat prostřednictvím administrativní kopie a které je nutno nainstalovat za použití příkazového řádku nebo Microsoft Active Directory.

Ruční instalace těchto součástí Windows je nutná pouze tehdy, pokud instalaci provádíte z administrativní kopie prostřednictvím příkazového řádku nebo služby Microsoft Active Directory. Pokud použijete Manažera instalací SOLIDWORKS k vytvoření a instalaci administrativní kopie, tyto komponenty Windows se instalují automaticky.
Zde je souhrn souborů požadovaných softwarem SOLIDWORKS v součástech systému Windows:
Windows Performance Toolkit | Umožňuje rozšířené protokolování v SOLIDWORKS Rx.
Balíček Visual C++ 2022 Redistributable | Obsahuje komponenty typu runtime pro Microsoft Visual C++. Musí být nainstalována verze 2022.
Visual Basic for Applications 7.1 | Zajišťuje podporu maker v jazyce Visual Basic.
Visual Studio Tools for Application 2022 | Volitelné. Obsahuje sadu nástrojů podporující aplikace Visual Studio 2022 (VSTA17).
Rozhraní .NET Framework 4.8 | Obsahuje společný jazykový modul runtime a součásti .NET Framework, které jsou zapotřebí pro spouštění aplikací .NET Framework 4.8.
SWCEF | K zobrazení obsahu platformy 3DEXPERIENCE platform se používá technologie CEF (Chromium Embedded Framework).
Webový prohlížeč Microsoft Edge Web View2 | Vyžadováno k zobrazení webového obsahu.
Aplikace SOLIDWORKS Login Manager | Umožňuje přihlášení ke službě 3DEXPERIENCE Marketplace a k dalším aplikacím 3DEXPERIENCE.
Balíček Visual C++ Redistributable a rozhraní .NET Framework 4.8 jsou nutné pro všechny produkty SOLIDWORKS, nikoli pouze pro hlavní program SOLIDWORKS.

Tyto součásti musí být zahrnuty v podsložkách administrativní kopie.

Následující tabulka určuje konkrétní soubory požadované pro každý podporovaný operační systém.
Operační systém: Windows Server 2019 64bitová verze a Windows Server 2022 64bitová verze
Instalace v systému Windows Server 2019 a 2022 je podporována u softwaru SOLIDWORKS PDM Server a SOLIDWORKS SolidNetWork License Manager.
Windows Performance Toolkit: | WPTx64-x86_en-us.msi
Balíček k opětovné distribuci Visual C++ 2022: | vc_redist.x86.exe vc_redist.x64.exe Oba musí být nainstalovány.
Visual Basic 7.1: | vba71_1033.msi K tomu volitelný jazykový balíček.
Rozhraní .NET Framework 4.8: | ndp48-x86-x64-allos-enu.exe
SWCEF | Nástroj CEF for SOLIDWORKS Applications.msi
Webový prohlížeč Microsoft Edge Web View2 | MicrosoftEdgeWebView2RuntimeInstallerX64.exe
Operační systém: Windows 10 nebo Windows 11, 64bitová verze
Windows Performance Toolkit: | WPTx64-x86_en-us.msi
Balíček k opětovné distribuci Visual C++ 2022: | vc_redist.x86.exe vc_redist.x64.exe Oba musí být nainstalovány.
Visual Basic 7.1: | vba71_1033.msi K tomu volitelný jazykový balíček.
Rozhraní .NET Framework 4.8: | Rozhraní .NET 4.8 je součástí operačního systému, čímž je tento požadavek splněn.
SWCEF | Nástroj CEF for SOLIDWORKS Applications.msi
Webový prohlížeč Microsoft Edge Web View2 | MicrosoftEdgeWebView2RuntimeInstallerX64.exe

Obsah

  • Předpoklady instalace ve Windows z příkazového řádku na 64bitových operačních systémech

    Při instalaci předpokladů v systému Windows pro instalaci administrativní kopie za použití příkazového řádku na 64bitových verzích Windows můžete postupovat podle těchto pokynů.

Nadřazené téma Zavedení pomocí příkazového řádku
Instalace z administrativní kopie s použitím příkazového řádku
Vlastnosti v příkazovém řádku
Zavádění administrativní kopie pomocí Microsoft Active Directory


Předpoklady instalace ve Windows z příkazového řádku na 64bitových operačních systémech

Při instalaci předpokladů v systému Windows pro instalaci administrativní kopie za použití příkazového řádku na 64bitových verzích Windows můžete postupovat podle těchto pokynů.

Pokud chcete jednou instalační operací nainstalovat několik součástí, vytvořte dávkový soubor s příkazy obsaženými v následujících pokynech. Poté tento soubor použijte k instalaci součástí na klientské počítače.

  1. Ujistěte se, že je na cílovém počítači alespoň 620 MB volného místa na disku a platná složka TEMP.
  2. Nainstalujte balíček k opětovné distribuci Visual C++ RELEASE. Musíte nainstalovat 32bitovou i 64bitovou verzi každého balíčku.
    Nainstalujte balíček pro RELEASE = 2022.

    administrative_image_directory\Microsoft_C++_RELEASE_Redistributable_(x64)\vc_redist.x64.exe /Q

    administrative_image_directory\Microsoft_C++_RELEASE_Redistributable\vc_redist.x86.exe /Q

  3. Nainstalujte rozhraní Microsoft .NET Framework 4.8:
    administrative_image_directory\.Net_Framework_4.8\ndp48-x86-x64-allos-enu.exe
  4. Nainstalujte komponentu Visual Studio Tools for Applications 2022:
    administrative_image_directory\Microsoft_VSTA17\vsta_setup.exe
  5. Nainstalujte Visual Basic 7.1:
    adresář_administrativní_kopie\Microsoft_VBA\vba71.msi a adresář_administrativní_kopie\Microsoft_VBA\vba71_1033.msi jsou soubory nutné pro všechny jazyky.
    Je přitom třeba nainstalovat pouze 64bitovou verzi tohoto balíčku.

    Dále nainstalujte následující balíček pro požadovaný jazyk:

    vba71_1028.msi | Čínština
    vba71_1031.msi | Němčina
    vba71_1036.msi | Francouzština
    vba71_1040.msi | Italština
    vba71_1041.msi | Japonština
    vba71_1042.msi | Korejština
    vba71_1046.msi | Portugalština – brazilská
    vba71_2052.msi | Čínština – zjednodušená
    vba71_3082.msi | Španělština
    Angličtina, čeština, polština, ruština a turečtina další jazykové balíčky nevyžadují.
    Nainstalujte další předpokládaný program: Msiexec.exe /p vba71-kb27832-x64.msp.
  6. Instalace softwaru SOLIDWORKS Chromium Embedded Framework (SWCEF):
    administrative_image_directory\swcef\CEF for SOLIDWORKS Applications.msi.
  7. Instalace aplikace SOLIDWORKS Login Manager
    administrative_image_directory\swloginmgr\SOLIDWORKS Login Manager.msi.
Nadřazené téma Příprava klientů na instalaci z příkazového řádku z administrativní kopie


Instalace z administrativní kopie s použitím příkazového řádku

Můžete rozmístit instalace z administrativní kopie za použití příkazového řádku.

Návod na tichou instalaci:

  1. Otevřete okno příkazového řádku (klikněte ve Windows na Start > Spustit).
  2. Zadejte příkaz msiexec.exe s /i a /qb a nastavte vlastnosti pro jakékoli možnosti, které nejsou součástí výchozích hodnot zobrazených níže.

    msiexec /i "administrative_image_directory\64bit\SWFileUtilities\SOLIDWORKS File Utilities.msi" INSTALLDIR="C:\Program Files\your_folder /qb

Vlastnosti příkazového řádku individuální instalace součásti zahrnuji:
  • Vlastnosti funkcí v příkazovém řádku
  • Globální vlastnosti v příkazovém řádku
  • Vlastnosti příkazového řádku eDrawings
  • Vlastnosti příkazového řádku aplikace SOLIDWORKS Flow Simulation

Použijte následující příklady jako šablony pro bezobslužnou (tichou) instalaci.

SOLIDWORKS klient

  • SOLIDWORKS (hlavní část) (anglicky)
  • Doplňkový modul Toolbox
  • Účast v programu zpětné vazby zákazníků
  • Francouzština

SOLIDWORKS:

msiexec /i "administrative_image_directory\64bit\SOLIDWORKS\SOLIDWORKS.Msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=4 ADDLOCAL=SolidWorks, SolidWorksToolbox TOOLBOXFOLDER="toolbox path for example C:\SolidWorks Data\" /qb

Součást instalace SOLIDWORKS ve francouzštině musí být instalována zvlášť:

msiexec /i "administrative_image_directory\64bit\SOLIDWORKS French\french.msi" /qb

Při zadávání povelů jazykové součásti instalace SOLIDWORKS nezadávejte argumenty v příkazovém řádku.

eDrawings klient

  • Všechny funkce

msiexec /i
            "administrative_image_directory\64bit\eDrawings\eDrawings.msi"
          INSTALLDIR="C:\Program Files\your_folder"
            SNLSERVER=eDrawings_SNL_server TRANSFORMS=1040.mst
          ADDLOCAL=All /qb

SOLIDWORKS Electrical

Z důvodu technické komplikovanosti instalace softwaru SOLIDWORKS Electrical se serverem Microsoft SQL Server jsou příklady příkazů pro příkazový řádek pro software SOLIDWORKS Electrical z dokumentace vynechány.

SOLIDWORKS Visualize a Visualize Boost

Software SOLIDWORKS Visualize:

msiexec. /i “administrative_image_directory\64bit\SOLIDWORKS Visualize.msi” ACTIVSERIALNUMBER=”1234123412341234ABCDEFGH” INSTALLDIR=”C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS Visualize” /qb

SOLIDWORKS Visualize Boost:

msiexec /i “administrative_image_directory\64bit\SOLIDWORKS Visualize Boost.msi” ACTVISERIALNUMBER=”1234123412341234ABCDEFGH” INSTALLDIR=”C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS Visualize Boost” /qb

Nadřazené téma Zavedení pomocí příkazového řádku
Příprava klientů na instalaci z příkazového řádku z administrativní kopie
Vlastnosti v příkazovém řádku
Zavádění administrativní kopie pomocí Microsoft Active Directory


Vlastnosti v příkazovém řádku

Vlastnosti v příkazovém řádku zde popisují vlastnosti funkcí, globální vlastnosti, produktově specifické vlastnosti a konvence umístění Windows.

Obsah

  • Vlastnosti funkcí v příkazovém řádku

    Instalace SOLIDWORKS podporuje tyto vlastnosti ADDLOCAL pro zavedení pomocí příkazového řádku.

  • Globální vlastnosti v příkazovém řádku

    Každý parametr je definován pro administrativní nebo individuální instalace, není-li uvedeno jinak. Sériová čísla mohou být pomocí globálních parametrů předána administrativní i individuální instalaci.

  • Vlastnosti příkazového řádku eDrawings

    Tyto vlastnosti příkazového řádku jsou specifické pro aplikaci eDrawings ®.

  • SOLIDWORKS Composer/Composer Player – parametry v příkazovém řádku

    Tyto vlastnosti v příkazovém řádku jsou specifické pro aplikace SOLIDWORKS Composer a SOLIDWORKS Composer Player.

  • Vlastnosti příkazového řádku aplikace SOLIDWORKS Flow Simulation

    Tyto vlastnosti příkazového řádku jsou specifické pro SOLIDWORKS Flow Simulation.

  • SOLIDWORKS Inspection – vlastnosti v příkazovém řádku

    Tyto vlastnosti příkazového řádku jsou specifické pro SOLIDWORKS Inspection.

  • SOLIDWORKS Visualize – vlastnosti příkazového řádku

    Tyto vlastnosti příkazového řádku jsou specifické pro SOLIDWORKS Visualize.

  • Umístění souboru MSI administrativní kopie

    Pro vytvoření administrativních kopií z příkazového řádku se soubory součástí produktu .msi nacházejí v následujících umístěních na médiu SOLIDWORKS.

Nadřazené téma Zavedení pomocí příkazového řádku
Příprava klientů na instalaci z příkazového řádku z administrativní kopie
Instalace z administrativní kopie s použitím příkazového řádku
Zavádění administrativní kopie pomocí Microsoft Active Directory


Vlastnosti funkcí v příkazovém řádku

Instalace SOLIDWORKS podporuje tyto vlastnosti ADDLOCAL pro zavedení pomocí příkazového řádku.

  • CircuitWorks
  • CoreSolidWorksTaskScheduler
  • ExampleFiles
  • FeatureWorks
  • HelpFiles
  • Manuals
  • Motion
  • ScanTo3D
  • Simulace
  • SolidWorksCosting
  • SolidWorksDesignChecker
  • SolidWorksRoutedsystems
  • SolidWorksToolbox
  • SolidWorksUtilities
  • TolAnalyst
Při zadávání vlastností pro instalaci příkazového řádku:
  • SOLIDWORKS nepodporuje instalaci produktu pomocí možnosti ADDSOURCE.
  • Parametry rozlišují malá a velká písmena, nesmějí obsahovat mezery nebo pomlčky a musí být odděleny čárkami.
Nadřazené téma Vlastnosti v příkazovém řádku
Globální vlastnosti v příkazovém řádku
Vlastnosti příkazového řádku eDrawings
SOLIDWORKS Composer/Composer Player – parametry v příkazovém řádku
Vlastnosti příkazového řádku aplikace SOLIDWORKS Flow Simulation
SOLIDWORKS Inspection – vlastnosti v příkazovém řádku
SOLIDWORKS Visualize – vlastnosti příkazového řádku
Umístění souboru MSI administrativní kopie


Globální vlastnosti v příkazovém řádku

Každý parametr je definován pro administrativní nebo individuální instalace, není-li uvedeno jinak. Sériová čísla mohou být pomocí globálních parametrů předána administrativní i individuální instalaci.

Vlastnost | Popis
ENABLEPERFORMANCE Určuje, zda má aplikace automaticky odeslat emailem data o výkonu společnosti SOLIDWORKS Corporation.

1

Data o výkonu budou odeslána.

0

Data o výkonu nebudou odeslána.
INSTALLDIR | Instalační složka pro SOLIDWORKS.
MBDSERIALNUMBER | Sériové číslo pro produkt SOLIDWORKS Model Based Definition.
MOTIONSERIALNUMBER | Sériové číslo pro produkt SOLIDWORKS Motion.
OFFICEOPTION Určete produktový balíček, který chcete nainstalovat:
0 | SOLIDWORKS Standard
1 | SOLIDWORKS Office
2 | SOLIDWORKS Professional
3 | SOLIDWORKS Premium
4 | SOLIDWORKS Ultimate
NOVÁ INSTALACE Vyberte Vyberte pro aktualizace všech funkcí, které byly nyní instalovány.
Tuto vlastnost zadejte pouze tehdy, když aktualizujete na nový Service Pack v rámci stávající verze (například při aktualizaci stávající instalace SOLIDWORKS 2025 SP01 na SOLIDWORKS 2025 SP02).
REINSTALLMODE Možnosti nové instalace aplikace Microsoft Installer.

Když například aktualizujete instalaci z jedné verze Service Pack na jinou v rámci té samé hlavní verze, měli byste specifikovat REINSTALLMODE=vomus.

Podrobnosti o nastavení REINSTALLMODE najdete v dokumentaci aplikace Windows Installer na stránce www.microsoft.com.

Tuto vlastnost zadejte pouze tehdy, když aktualizujete na nový Service Pack v rámci stávající verze (například při aktualizaci stávající instalace SOLIDWORKS 2025 SP01 na SOLIDWORKS 2025 SP02). Nezadávejte tuto vlastnost, pokud poprvé instalujete hlavní verzi SOLIDWORKS.
SERVERLIST Určuje seznam serverů SolidNetWork.
Seznam serverů SolidNetWork je seznam oddělených řetězců, z nichž každý je přiřazen číslu portu na serveru v následujícím formátu:
  • Triáda (odděleno čárkou) =xxxxx@název_serveru1,yyyyy@název_serveru2,zzzzz@název_serveru3
  • Mimo triádu (odděleno středníkem) = xxxxx@název_serveru1;yyyyy@název_serveru2;zzzzz@název_serveru3
X a Y jsou jednomístná čísla. Za poslední server v seznamu nedávejte oddělovač.
SIMULATIONSERIALNUMBER | Sériové číslo pro produkt SOLIDWORKS Simulation.
SOLIDWORKSSERIALNUMBER | Sériové číslo pro produkt SOLIDWORKS, které zahrnuje všechny doplňkové moduly.
SWMIGRATE Určuje verzi SOLIDWORKS pro upgrade, jak by byla zobrazena v seznamu v okně Výběr instalace SOLIDWORKS. Například:

SWMIGRATE="SOLIDWORKS 2025 x64 Edition SP01"

Zadejte tuto vlastnost, pouze když instalujete novou hlavní verzi na nově instalovanou předchozí hlavní verzi. Nezadávejte tuto vlastnost, když aktualizujete z jedné verze Service Pack na jinou v rámci té samé hlavní verze.
TOOLBOXFOLDER Instalační složka pro soubory SOLIDWORKS Toolboxu.

Například: TOOLBOXFOLDER = "C:\SOLIDWORKS Data"

Pokud vaše prostředí obsahuje systém PDM nebo sdílené umístění nástroje Toolbox/Průvodce dírami, můžete nastavit klientské instalace, aby neinstalovaly ani neupgradovaly data Toolbox v příslušném umístění s použitím vlastnosti NOTTOOLBOXSETUP. Zadejte:

0 | Instalovat soubory Toolbox.
1 | Neinstalovat soubory Toolbox.
TRANSFORMS Obsahuje položky specifické pro jazyk v podobě:
TRANSFORMS number.mst
  • Chinese (1028)
  • Chinese-Simplified (2052)
  • Czech (1029)
  • English (1033)
  • French (1036)
  • German (1031)
  • Italian (1040)
  • Japanese (1041)
  • Korean (1042)
  • Polish (1045)
  • Portuguese-Brazilian (1046)
  • Russian (1049)
  • Spanish (1034)
  • Turkish (1055)
UPGRADESWINSTALL
Určuje, zda je nutné provést upgrade stávající verzi SOLIDWORKS na aktuální verzi.
0 | Nová instalace, neprovádějte upgrade.
1 | Aktualizovat
Zadejte tuto vlastnost, pouze když instalujete novou hlavní verzi na nově instalovanou předchozí hlavní verzi. Nezadávejte tuto vlastnost, když aktualizujete z jedné verze aktualizace Service Pack na jinou v rámci té samé hlavní verze.
Nadřazené téma Vlastnosti v příkazovém řádku
Vlastnosti funkcí v příkazovém řádku
Vlastnosti příkazového řádku eDrawings
SOLIDWORKS Composer/Composer Player – parametry v příkazovém řádku
Vlastnosti příkazového řádku aplikace SOLIDWORKS Flow Simulation
SOLIDWORKS Inspection – vlastnosti v příkazovém řádku
SOLIDWORKS Visualize – vlastnosti příkazového řádku
Umístění souboru MSI administrativní kopie


Vlastnosti příkazového řádku eDrawings

Tyto vlastnosti příkazového řádku jsou specifické pro aplikaci eDrawings ®.

Vlastnost | Popis
ADDLOCAL Určuje, která část aplikace eDrawings se má nainstalovat.
All je doporučená možnost.
Syntaxe příkazového řádku | Prvek
All | Nainstaluje všechny funkce. Aplikace eDrawings hledá nainstalované aplikace SOLIDWORKS a AutoCAD Publisher a ověří instalaci.
CALS | Zobrazení souborů CAL v prohlížeči eDrawings
Inventor | Tvorba souborů eDrawings z aplikace Autodesk Inventor.
eDrawingsViewer | Zobrazení souborů eDrawings a ostatních souborů.
ProE | Zobrazení souborů ProE v prohlížeči eDrawings
DXFDWGTranslator | Zobrazení souborů DXF/DWG v prohlížeči eDrawings.
Shortcuts | Instalace zástupce na ploše.
XML3D | Zobrazení souborů 3DXML v prohlížeči eDrawings.
INSTALLDIR | Určuje instalační složku pro eDrawings
SNLSERVER Zadejte číslo_portu@název_serveru pro váš licenční server SolidNetWork. Jednotlivé kombinace hodnot číslo_portu@název_serveru oddělte středníky.

Název portu serveru pro SNLSERVER a SERVERLIST je požadován jen pro konfiguraci serveru SOLIDWORKS SNL.

Seznam serverů SolidNetWork je seznam oddělených řetězců, z nichž každý je přiřazen číslu portu na serveru v následujícím formátu:
  • Triáda (odděleno čárkami)

    = xxxx@server_name1,yyyy@server_name2,zzzz@server_name3

  • Mimo triádu (odděleno středníkem)

    = xxxx@server_name1,yyyy@server_name2,zzzz@server_name3

X a Y jsou jednomístná čísla. Za poslední server v seznamu nedávejte středník.
Nadřazené téma Vlastnosti v příkazovém řádku
Vlastnosti funkcí v příkazovém řádku
Globální vlastnosti v příkazovém řádku
SOLIDWORKS Composer/Composer Player – parametry v příkazovém řádku
Vlastnosti příkazového řádku aplikace SOLIDWORKS Flow Simulation
SOLIDWORKS Inspection – vlastnosti v příkazovém řádku
SOLIDWORKS Visualize – vlastnosti příkazového řádku
Umístění souboru MSI administrativní kopie


SOLIDWORKS Composer/Composer Player – parametry v příkazovém řádku

Tyto vlastnosti v příkazovém řádku jsou specifické pro aplikace SOLIDWORKS Composer a SOLIDWORKS Composer Player.

SOLIDWORKS Composer:

Vlastnost | Popis
ACTIVSERIALNUMBER | Sériové číslo softwaru SOLIDWORKS Composer.
ACTIVSERIALNUMBERPLAYERPRO | Volitelné. Sériové číslo softwaru SOLIDWORKS Composer Player Pro.
ADDLOCAL Volitelné. Instalujete-li kompletní aplikaci, není nutné zadávat vlastnost ADDLOCAL.
V případě vlastní instalace použijte ADDLOCAL s následujícími požadovanými položkami:
  • Licensing
  • CLOSA
  • InterOps
  • LicenseSupportFiles
  • PlugIns
  • SWComposerCommon
  • SWPlayer
Můžete použít také ADDLOCAL se Sync3Dvia, ale není to vyžadováno.
INSTALLDIR | Určuje instalační složku softwaru SOLIDWORKS Composer.

SOLIDWORKS Composer Player:

Vlastnost | Popis
ACTIVSERIALNUMBERPLAYERPRO | Volitelné. Sériové číslo softwaru SOLIDWORKS Composer Player Pro.
INSTALLDIR | Určuje instalační složku softwaru SOLIDWORKS Composer Player.
Na počítačích, na kterých není instalován software SOLIDWORKS, je nutné k importu souborů SOLIDWORKS do aplikace SOLIDWORKS Composer použít SOLIDWORKS Translator. K nasazení nástroje SOLIDWORKS Translator je nutné použít Manažer instalací SOLIDWORKS, nelze použít příkazový řádek.
Nadřazené téma Vlastnosti v příkazovém řádku
Vlastnosti funkcí v příkazovém řádku
Globální vlastnosti v příkazovém řádku
Vlastnosti příkazového řádku eDrawings
Vlastnosti příkazového řádku aplikace SOLIDWORKS Flow Simulation
SOLIDWORKS Inspection – vlastnosti v příkazovém řádku
SOLIDWORKS Visualize – vlastnosti příkazového řádku
Umístění souboru MSI administrativní kopie


Vlastnosti příkazového řádku aplikace SOLIDWORKS Flow Simulation

Tyto vlastnosti příkazového řádku jsou specifické pro SOLIDWORKS Flow Simulation.

Vlastnost | Popis
ACTIVSERIALNUMBER Sériové číslo samostatné licence aplikace SOLIDWORKS Flow Simulation.

(Individuální instalace a klientské instalace z administrativní kopie)

CWUPGRADEINSTALL Upgraduje existující verzi určité aplikace SOLIDWORKS Flow Simulation.
1 | Aktualizovat
2 | Nová instalace; nainstalovat v novém adresáři

(Individuální instalace a klientské instalace z administrativní kopie)

INSTALLDIR Určuje instalační složku pro instalaci určité aplikace SOLIDWORKS Flow Simulation.

(Pouze pro individuální instalace)
SERVERLIST | Seznam řetězců oddělených středníkem, z nichž každý se odkazuje na číslo portu na serveru v následujícím formátu: xxxxx@název_serveru1; yyyyy@název_serveru2;& kde x a y jsou jednomístná čísla. Za poslední server v seznamu nedávejte středník.
SOLIDWORKSPATH Určuje složku, ve které je nainstalován software SOLIDWORKS.

(Individuální instalace a klientské instalace z administrativní kopie)

Nadřazené téma Vlastnosti v příkazovém řádku
Vlastnosti funkcí v příkazovém řádku
Globální vlastnosti v příkazovém řádku
Vlastnosti příkazového řádku eDrawings
SOLIDWORKS Composer/Composer Player – parametry v příkazovém řádku
SOLIDWORKS Inspection – vlastnosti v příkazovém řádku
SOLIDWORKS Visualize – vlastnosti příkazového řádku
Umístění souboru MSI administrativní kopie


SOLIDWORKS Inspection – vlastnosti v příkazovém řádku

Tyto vlastnosti příkazového řádku jsou specifické pro SOLIDWORKS Inspection.

Parametr | Komentář
ACTIVSERIALNUMBER | Sériové číslo softwaru SOLIDWORKS Inspection. (Individuální instalace a klientské instalace z administrativní kopie)
INSTALLDIR | Určuje instalaci softwaru SOLIDWORKS Inspection. (Pouze pro individuální instalace)
SERVERLIST | Seznam řetězců oddělených středníkem, z nichž každý se odkazuje na číslo portu na serveru v následujícím formátu: xxxxx@název_serveru1; yyyyy@název_serveru2;& kde x a y jsou jednomístná čísla. Za poslední server v seznamu nedávejte středník.
Nadřazené téma Vlastnosti v příkazovém řádku
Vlastnosti funkcí v příkazovém řádku
Globální vlastnosti v příkazovém řádku
Vlastnosti příkazového řádku eDrawings
SOLIDWORKS Composer/Composer Player – parametry v příkazovém řádku
Vlastnosti příkazového řádku aplikace SOLIDWORKS Flow Simulation
SOLIDWORKS Visualize – vlastnosti příkazového řádku
Umístění souboru MSI administrativní kopie


SOLIDWORKS Visualize – vlastnosti příkazového řádku

Tyto vlastnosti příkazového řádku jsou specifické pro SOLIDWORKS Visualize.

Parametr | Popis
ACTIVSERIALNUMBER | Sériové číslo SOLIDWORKS Visualize. (Individuální instalace a klientské instalace z administrativní kopie)
INSTALLDIR | Určuje instalaci softwaru SOLIDWORKS Visualize. (Pouze pro individuální instalace)
SERVERLIST | Seznam řetězců oddělených středníkem, z nichž každý se odkazuje na číslo portu na serveru v následujícím formátu: xxxxx@název_serveru1; yyyyy@název_serveru2;& kde x a y jsou jednomístná čísla. Za poslední server v seznamu nedávejte středník.
Nadřazené téma Vlastnosti v příkazovém řádku
Vlastnosti funkcí v příkazovém řádku
Globální vlastnosti v příkazovém řádku
Vlastnosti příkazového řádku eDrawings
SOLIDWORKS Composer/Composer Player – parametry v příkazovém řádku
Vlastnosti příkazového řádku aplikace SOLIDWORKS Flow Simulation
SOLIDWORKS Inspection – vlastnosti v příkazovém řádku
Umístění souboru MSI administrativní kopie


Umístění souboru MSI administrativní kopie

Pro vytvoření administrativních kopií z příkazového řádku se soubory součástí produktu .msi nacházejí v následujících umístěních na médiu SOLIDWORKS.

SOLIDWORKS (hlavní produkt, angličtina)

swwi\data\SOLIDWORKS.msi

SOLIDWORKS (neanglické jazykové součásti)

Tradiční čínština | swwi\lang\chinese\chinese.msi
Čínština - zjednodušená | swwi\lang\chinese-simplified\chinese-simplified.msi
čeština | swwi\lang\czech\czech.msi
francouzština | swwi\lang\french\french.msi
němčina | swwi\lang\german\german.msi
italština | swwi\lang\italian\italian.msi
Japonština | swwi\lang\japanese\japanese.msi
korejština | swwi\lang\korean\korean.msi
polština | swwi\lang\polish\polish.msi
Portugalština – brazilská | swwi\lang\portuguese-brazilian\portuguese-brazilian.msi
ruština | swwi\lang\russian\russian.msi
španělština | swwi\lang\spanish\spanish.msi
turečtina | swwi\lang\turkish\turkish.msi

DocManager APIs

swdocmgr\SOLIDWORKS Document Manager API.msi

eDrawings

eDrawings\eDrawings.msi

eDrawingsAPI SDK

eDrwAPISDK\eDrawings API SDK.msi

Simulace toku

Flow Simulation\SOLIDWORKS Flow Simulation.msi

3DExperience Marketplace pro SOLIDWORKS

marketplace\3dexperience marketplace.msi

SolidNetWork License Manager

swlicmgr\SOLIDWORKS SolidNetWork License Manager.msi

SOLIDWORKS API SDK

apisdk\SOLIDWORKS API SDK.msi

SOLIDWORKS CAM

cam\SOLIDWORKS CAM.msi

SOLIDWORKS Composer

swComposer\SOLIDWORKS Composer.msi

SOLIDWORKS Composer Player

swComposerPlayerSOLIDWORKS Composer Player.msi

SOLIDWORKS Electrical

swelectric\SOLIDWORKS Electrical.msi

Nástroje SOLIDWORKS File Utilities

SWFileUtilities\SOLIDWORKS File Utilities.msi

SOLIDWORKS Inspection

Inspection\SOLIDWORKS Inspection.msi

Klient aplikace SOLIDWORKS Manage

SWManageClient\SOLIDWORKS Manage Client.msi

SOLIDWORKS PDM

SOLIDWORKS PDM Professional poskytuje rozhraní API, které je ale k dispozici pouze pro klienta a není k dispozici v souboru .msi. Informace najdete v příručce k rozhraní API v adresáři SOLIDWORKS PDM Client install\API.

SOLIDWORKS Plastics

plastics\SOLIDWORKS Plastics.msi

SOLIDWORKS Visualize

visualize\SOLIDWORKS Visualize.msi

SOLIDWORKS Visualize Boost

visualizeboost\SOLIDWORKS Visualize Boost.msi
Nadřazené téma Vlastnosti v příkazovém řádku
Vlastnosti funkcí v příkazovém řádku
Globální vlastnosti v příkazovém řádku
Vlastnosti příkazového řádku eDrawings
SOLIDWORKS Composer/Composer Player – parametry v příkazovém řádku
Vlastnosti příkazového řádku aplikace SOLIDWORKS Flow Simulation
SOLIDWORKS Inspection – vlastnosti v příkazovém řádku
SOLIDWORKS Visualize – vlastnosti příkazového řádku


Zavádění administrativní kopie pomocí Microsoft Active Directory

Rozmístění pomocí služby Microsoft Active Directory se používá pro instalaci hlavních produktů SOLIDWORKS na klientské počítače.

Služba Microsoft Active Directory je adresářová služba ke správě klientů a serverů na síti. Zjednodušuje správu, přenesení a zavádění.

Informace o instalaci softwaru SOLIDWORKS prostřednictvím Microsoft Active Directory si vyžádejte u svého prodejce.

Nadřazené téma Zavedení pomocí příkazového řádku
Příprava klientů na instalaci z příkazového řádku z administrativní kopie
Instalace z administrativní kopie s použitím příkazového řádku
Vlastnosti v příkazovém řádku


Správa násobných instalací

Pro více instalací zahrnují administrativní úkoly provedení upgrade administrativních kopií na nové verze, aktualizaci nových verzí servisního balíčku a odstranění instalací.

Obsah

  • Upgrade administrativních kopií na novou verzi

    Chcete-li aktualizovat klienty, kteří byli nainstalování z administrativní kopie, musíte nejprve aktualizovat samotnou administrativní kopii a pak konfigurovat klienty, aby měli odkaz na novou kopii.

  • Správa aktualizace produktu servisního balíčku

    Aktualizace produktu servisního balíčku mohou obsahovat aktualizace spolehlivosti systému, kompatibility programu, zabezpečení, atd.

  • Odstranění instalace

    Instalaci můžete odstranit ze individuálního počítače, nebo z prostředí klient/server.

Nadřazené téma Násobné instalace
Zavádění více klientů
Použití administrativní kopie
Zavedení pomocí příkazového řádku


Upgrade administrativních kopií na novou verzi

Chcete-li aktualizovat klienty, kteří byli nainstalování z administrativní kopie, musíte nejprve aktualizovat samotnou administrativní kopii a pak konfigurovat klienty, aby měli odkaz na novou kopii.

Spusťte Manažera instalací SOLIDWORKS ze stránky Stahování SOLIDWORKS, aby byly k odkazům použity správné soubory.

Poté, co aktualizujete administrativní kopii (čímž se vytvoří nová kopie), můžete aktualizovat klienty tak, že je odkážete na nově vytvořenou administrativní kopii.

Pokud klienti odkazují na původní administrativní kopii pomocí sdíleného adresáře, můžete znovu definovat tento sdílený adresář pomocí nově aktualizované administrativní kopie.

Obsah

  • Stažení aktualizovaných instalačních souborů pro administrativní kopie

    Manažer instalací SOLIDWORKS může rozpoznat, když při upgrade administrativní kopie potřebujete aktualizované instalační soubory.

  • Upgrade administrativní kopie

    Pro upgrade administrativní kopie vytvoří Manažer instalací SOLIDWORKS nový adresář kopie. Klienty pak instruujete, aby pro upgrade této verze produktu použili nový adresář pro administrativní kopii.

  • Upgradování klientů z administrativní kopie

    Manažer instalací SOLIDWORKS může automaticky aktualizovat klientské počítače instalované z administrativní kopie.

Nadřazené téma Správa násobných instalací
Správa aktualizace produktu servisního balíčku
Odstranění instalace


Stažení aktualizovaných instalačních souborů pro administrativní kopie

Manažer instalací SOLIDWORKS může rozpoznat, když při upgrade administrativní kopie potřebujete aktualizované instalační soubory.

  1. Spusťte Manažer instalací SOLIDWORKS.
  2. Na obrazovce Vítejte vyberte položku Administrativní kopie.
  3. Na obrazovce Sériové číslo zadejte sériové číslo SOLIDWORKS.
    Manažer instalací SOLIDWORKS na webové stránce SOLIDWORKS zjistí vaše licencované produkty a dostupné aktualizace Service Pack.
  4. Pokud se zobrazí obrazovka Je k dispozici novější verze zvolte Ano, stáhnout a nainstalovat novější verzi: verze.
    Manažer instalace SOLIDWORKS spustí novou relaci a nainstaluje novější verzi.
  5. Pokud se vyskytne problém se složkou pro stahování , může se objevit okno Možnosti instalace – v takovém případě odsouhlaste výchozí složku pro nové instalační soubory nebo zadejte název nového adresáře.
    Pokud se zobrazí zpráva, že adresář neexistuje, vytvořte ho klepnutím na Ano.
  6. Na obrazovce Stahování dokončeno klepnutím na Zavřít ukončete aktuální instalační službu a spusťte instalační službu pro novou verzi.
Nadřazené téma Upgrade administrativních kopií na novou verzi
Upgrade administrativní kopie
Upgradování klientů z administrativní kopie


Upgrade administrativní kopie

Pro upgrade administrativní kopie vytvoří Manažer instalací SOLIDWORKS nový adresář kopie. Klienty pak instruujete, aby pro upgrade této verze produktu použili nový adresář pro administrativní kopii.

Předpokladem tohoto postupu je, že máte stažené všechny aktualizované instalační soubory v administrativní kopii. Podrobné informace naleznete v Stažení aktualizovaných instalačních souborů pro administrativní kopie.

  1. Spusťte Manažer instalací SOLIDWORKS.
  2. Na obrazovce Vítejte vyberte položku Administrativní kopie.
    Objeví se možnosti pro vytvoření administrativní kopie:
    Volba | Popis
    Vytvořit novou kopii pomocí výchozích nastavení. | Vytvořit kopii pomocí výchozích nastavení konfigurace (tj. nikoli na základě nastavení určených pro stávající administrativní kopii na vašem serveru).
    Vytvořte novou kopii pomocí nastavení a souborů ze stávající kopie. | Vytvořit kopii pomocí nastavení konfigurace určených pro stávající administrativní kopii na vašem serveru. Klepněte na Procházet a určete instalační adresář pro stávající administrativní kopii.
  3. Na obrazovce Sériové číslo zadejte sériové číslo.
  4. Na obrazovce Souhrn (Připraveno k vytvoření kopie), zkontrolujte, že jsou možnosti administrativní kopie správné.
    Podrobnosti o individuální administrativní kopii a možnostech instalace získáte, když klepnete na ZMĚNA a dostanete se na stránku možností a pak klepnete na Nápověda.
  5. Pro vytvoření nové verze administrativní kopie klepněte na Vytvořit nyní.

Nyní můžete upgradovat klienty na tuto novou verzi administrativní kopie. Detaily najdete na odkazu Upgrade klientů z administrativních kopií.

Nadřazené téma Upgrade administrativních kopií na novou verzi
Stažení aktualizovaných instalačních souborů pro administrativní kopie
Upgradování klientů z administrativní kopie


Upgradování klientů z administrativní kopie

Manažer instalací SOLIDWORKS může automaticky aktualizovat klientské počítače instalované z administrativní kopie.

Obvykle jsou administrativní kopie na serveru umístěné ve složkách. Administrativní kopie musí být ve sdílené složce, aby mohlo dojít k automatické aktualizaci klientů.

Po provedení upgradu administrativní kopie, bude původní instalace v jedné složce a upgradovaná instalace ve druhé složce. Chcete-li použít upgradovanou instalační službu, musíte nejprve odstranit možnost sdílení ze složky původní administrativní kopie a poté umožnit sdílení složky s upgradovanou administrativní kopií.

Po spuštění SOLIDWORKS na klientském počítači, který byl instalován z originální administrativní kopie, software zaznamená novou verzi a upgraduje klienta.
Rovněž když SOLIDWORKS vyvolá aktualizaci, automaticky se aktualizují ostatní produkty instalované z administrativní kopie.
Nadřazené téma Upgrade administrativních kopií na novou verzi
Stažení aktualizovaných instalačních souborů pro administrativní kopie
Upgrade administrativní kopie

Odstranění možnosti sdílení ze složky s původní administrativní kopií

Když provádíte upgrade administrativní kopie, na kterou je přístup ze sdílené složky, musíte odstranit možnost sdílení z původní složky.

  1. Vyhledejte složku, ve které jsou umístěny soubory původní administrativní kopie.
  2. Pravým tlačítkem klepněte na složku a vyberte Vlastnosti.
  3. Na záložce Sdílení vyberte Nesdílet tuto složku a klepněte na OK.

Nyní přidejte možnost sdílení pro složku s upgradovanou administrativní kopií podle popisu vPřidání možnosti sdílení ze složky s upgradovanou administrativní kopií.

Přidání možnosti sdílení ze složky s upgradovanou administrativní kopií

Poté, co jste vytvořili nebo aktualizovali složku administrativní kopie a deaktivovali sdílení původní složky administrativní kopie, musíte přidat možnost sdílení nové složce, aby se administrativní kopie znovu aktivovala.

  1. Vyhledejte složku, ve které jsou umístěny soubory upgradované administrativní kopie.
  2. Pravým tlačítkem klepněte na složku a vyberte Vlastnosti.
  3. Na záložce Sdílení určete vlastnosti sdílení vhodné pro vaši společnost nebo skupinu a změňte název sdílení na název používaný pro původní složku administrativní kopie.
Na počítačích s instalací z původního sdíleného umístění administrativní kopie se provede upgrade na novou verzi automaticky, když spustíte SOLIDWORKS.


Správa aktualizace produktu servisního balíčku

Aktualizace produktu servisního balíčku mohou obsahovat aktualizace spolehlivosti systému, kompatibility programu, zabezpečení, atd.

Aktualizace produktů můžete provést dvěma způsoby:
  • Pomocí Manažera instalací SOLIDWORKS zjistit, stáhnout a nainstalovat aktualizace.

    Manažera instalací SOLIDWORKS můžete spustit ručně nebo jej můžete nastavit tak, aby pravidelně zjišťoval aktualizace.

  • Ručním stažením aktualizací Service Pack z webové stránky podpory SOLIDWORKS.

    Aktualizace service pack je instalována jako oprava existující verze softwaru. Například SOLIDWORKS 2025 SP1.0 je aktualizace Service Pack pro SOLIDWORKS 2025 SP0.0. Tyto aktualizace Service Pack můžete nainstalovat pomocí Manažera instalací SOLIDWORKS 2025 ale nemůžete je nainstalovat pomocí Manažera instalací SOLIDWORKS verze SOLIDWORKS 2024.

    Nápovědu ke stahování a instalaci aktualizace Service Pack najdete v dokumentaci pro verzi programu SOLIDWORKS, kterou se snažíte aktualizovat.

Obsah

  • Návrat na předchozí aktualizaci Service Pack v administrativní kopii

    Administrativní kopii můžete vrátit zpět na předchozí nainstalovanou aktualizaci service pack. Pokud jste program SOLIDWORKS nainstalovali pomocí disků, budete je pro aktualizaci Service Pack potřebovat. Podmínkou je také, že jste uložili kopii předchozí administrativní kopie.

Nadřazené téma Správa násobných instalací
Upgrade administrativních kopií na novou verzi
Odstranění instalace


Návrat na předchozí aktualizaci Service Pack v administrativní kopii

Administrativní kopii můžete vrátit zpět na předchozí nainstalovanou aktualizaci service pack. Pokud jste program SOLIDWORKS nainstalovali pomocí disků, budete je pro aktualizaci Service Pack potřebovat. Podmínkou je také, že jste uložili kopii předchozí administrativní kopie.

Upgradované administrativní kopie nelze vrátit na předchozí aktualizaci Service Pack. Administrativní kopie vytvořené jiným způsobem, než pomocí Manažera instalací SOLIDWORKS, nelze vrátit zpět na předchozí verzi. Klienti instalovaní z této administrativní kopie musí být odinstalováni a pak znovu nainstalováni pomocí administrativní kopie vytvořené z dřívější verze.
  1. Odstraňte složku obsahující aktuální administrativní kopii. Postupujte tak, že otevřete okno s Příkazovým řádkem a zadejte:
    rmdir /s/q cesta_k_aktuální_administrativní_kopii
  2. Přesuňte záložní kopii administrativní kopie na místo, ze kterého jste odstranili aktuální administrativní kopii. Postupujte tak, že otevřete okno s Příkazovým řádkem a zadejte:
    move cesta_k_záložní_administrativní_kopii cesta_k_aktuální_administrativní_kopii
    Po vrácení administrativní kopie zpět na předchozí verzi se klientské počítače aktualizují při příštím spuštění programu SOLIDWORKS.
Nadřazené téma Správa aktualizace produktu servisního balíčku


SOLIDWORKS PDM a SOLIDWORKS Manage

SOLIDWORKS PDM je produkt pro správu dokumentů založený na architektuře klient/server, dříve známý pod názvem SOLIDWORKS Enterprise PDM. Software SOLIDWORKS PDM je k dispozici ve dvou typech:
  • SOLIDWORKS PDM Standard
  • SOLIDWORKS PDM Professional

SOLIDWORKS PDM používá pro správu úschoven databázi Microsoft SQL Server.

Tato tabulka uvádí databázové systémy, serverové komponenty a možnosti klientských aplikací, které jsou k dispozici pro daný typ produktu.
 | PDM Standard | PDM Professional
Určeno pro: | Menší až střední sítě, obvykle s méně než 20 současně aktivními uživateli. | Velké podnikové sítě s velkým počtem uživatelů pracujících současně
Omezení | Méně než 1 procesor nebo 4 jádra, 1 GB RAM, velikost databáze 10 GB. | Limity systému SQL Standard: Méně než 4 procesory nebo 16 jader, 128 GB RAM, velikost databáze 524 PB.
Systém pro správu databází | Microsoft SQL Server Express 2019 nebo novější verze až po 2022. | Microsoft SQL Server 2019 nebo novější verze až po 2022.
Vyžaduje SolidNetWork License Manager? | Ano | Ano
Zahrnuje archivní a databázový server? | Ano | Ano
Zahrnuje software SOLIDWORKS PDM Web2 Server a Web API Server? | Ne | Ano
Typ klienta | Nativní | Nativní, založený na prohlížeči
Klient a doplňkové moduly pro CAD Editory | SOLIDWORKS, DraftSight | SOLIDWORKS, DraftSight, Microsoft Office Integration
Klient a doplňkové moduly pro přispěvatele | DraftSight | DraftSight, Microsoft Office Integration
Klient a doplňkové moduly pro prohlížeče |  | Integrace Microsoft Office

SOLIDWORKS Manage Professional přidává k SOLIDWORKS PDM Professional pokročilé nástroje pro správu dat. Nabízí funkce pro pokročilou správu verzí a pro správu projektů, procesů a položek. Interaktivní panely a zprávy pomáhají sledovat položky, aktivity a průběh dokončení projektů.

SOLIDWORKS Manage Professional má podobnou architekturu jako SOLIDWORKS PDM Professional. Používá architekturu klient-server s databází Microsoft SQL Server pro správy položek a dat projektu. Používají se tři služby pro databázi, souborový server, a webový server, které podporují současně silné klienty i webový prohlížeč jako klient. Tyto tři služby je možné hostovat na stejném serveru nebo samostatných serverech. Uživatelé, kteří mají licenci SOLIDWORKS Manage Professional Editor, mohou používat doplňkový modul SOLIDWORKS Manage pro přístup k datům Manage přímo ze softwaru SOLIDWORKS.

Manažera instalací SOLIDWORKS můžete použít k instalaci serveru a klienta SOLIDWORKS Manage Professional.

Pokyny pro instalaci softwaru SOLIDWORKS Manage Professional najdete v Průvodci instalací SOLIDWORKS PDM/SOLIDWORKS Manage.

Obsah

  • Zobrazení seznamu serverových součástí PDM

  • Vysvětlení rozdílů mezi klienty PDM

    Potřebné klienty je nutno před instalací softwaru klientu vybrat podle vašeho prostředí PDM.

  • Před instalací softwaru PDM Serveru

    Před instalací serverových součástí PDM mějte na paměti následující požadavky:

  • Instalace PDM serveru s použitím Manažera instalací SOLIDWORKS

    Když instalujete server PDM pro verzi PDM Standard, můžete nainstalovat archivní server, databázový server a klienta PDM CAD Editor na jednom počítači. Není nutné spouštět instalaci klienta samostatně.

  • Instalace klienta PDM s použitím Manažera instalací SOLIDWORKS


Zobrazení seznamu serverových součástí PDM

V této tabulce je uveden přehled serverových součástí softwaru SOLIDWORKS PDM Server.

Server | Funkce | Instalace
Microsoft SQL Server Express pro PDM Standard | Spravuje data v datových úschovnách softwaru SOLIDWORKS PDM. | Lze jej nainstalovat společně s verzí PDM Standard nebo použít předchozí licencovanou a instalovanou verzi.
Microsoft SQL Server pro PDM Professional | Spravuje data v datových úschovnách softwaru SOLIDWORKS PDM. | Povinné. Je možno rovněž použít dříve licencovanou a instalovanou verzi.
Klient SolidNetWork License Manager | Spravuje licence SOLIDWORKS PDM. | Musí být nainstalováno před vytvářením nových úschoven. Pokud se používá SOLIDWORKS Installation Manager, lze nainstalovat se součástmi serveru SOLIDWORKS PDM.
Archivní server | Spravuje přenos souborů mezi klienty a archivem úschovny souborů a dále uživatele a jejich přihlašovací údaje. | Povinné. Instaluje se s verzí PDM Standard nebo Professional.
Databázový server | Vyhledává v databázích PDM aktualizace a spravuje pravidla importu a exportu dat. Spravuje systém zpráv a plánuje replikace a rezervní úložiště. | Povinné. Instaluje se s verzí PDM Standard nebo Professional.
Webový server 2 | Umožňuje přístup do úschoven souborů přes síť Internet z klientů založených na webových prohlížečích. | Volitelné. Instaluje se pouze s verzí PDM Professional.
Web API Server | Uživatelé aplikace EXALEAD OnePart mohou používat server Web API k indexování a načítání dat SOLIDWORKS PDM. | Volitelné. Instaluje se pouze s verzí PDM Professional.

Archivní servery běží jako služby pod systémovým účtem na počítačích, kde jsou nainstalovány. Na jednom archivním serveru může být více úschoven souborů, a to na stejném počítači.

V případě samostatné instalace může být archivní server, databázový server, licenční server a server Web API, jakož i databáze SQL Express nebo SQL Server nainstalována na stejném počítači.

V případě distribuovaného prostředí mohou být serverové součásti umístěny na různých počítačích. SOLIDWORKS PDM Professional podporuje také replikaci archivů úschoven souborů a databáze SQL Serveru zlepšuje výkon ve vzdálených umístěních. Více podrobností najdete v dokumentu Průvodce replikací SOLIDWORKS PDM Professional.

Nadřazené téma SOLIDWORKS PDM a SOLIDWORKS Manage


Vysvětlení rozdílů mezi klienty PDM

Potřebné klienty je nutno před instalací softwaru klientu vybrat podle vašeho prostředí PDM.

V této tabulce je uveden přehled klientů pro software SOLIDWORKS PDM Standard:
Typ standardního klienta | Popis
CAD Editor | Podporuje práci s formátem SOLIDWORKS, DWG/DXF, a soubory Microsoft Word a Microsoft Excel. Soubory všech formátů zpracovatelných ve formátu Office se chovají v softwaru SOLIDWORKS PDM Standard stejně, s výjimkou funkce Náhled.
Přispěvatel | Podporuje práci s formátem SOLIDWORKS, DWG/DXF, a soubory Microsoft Word a Microsoft Excel.
Divák | Umožňuje přístup do úschoven jen pro čtení. Uživatel může provést přechod souborů prostřednictvím pracovního postupu, ale nemůže přidávat nebo upravovat (vyzvedávat, odevzdávat, aktualizovat hodnoty) soubory.
V této tabulce je uveden přehled klientů pro software SOLIDWORKS PDM Professional:
Typ profesionálního klienta | Komentář
CAD Editor & Web | Podporuje práci se všemi typy souborů, včetně pokročilé správy a náhledů formátů CAD, například aplikace SOLIDWORKS. Doplňkové moduly CAD umožňují uživatelům přistupovat k SOLIDWORKS PDM Professional z aplikací CAD. Vzdálení uživatelé mohou hledat v úschovnách a využívat základní funkce přes internet pomocí klientů Web2.
Contributor & Web | Podporuje práci se všemi typy souborů, včetně CAD souborů. Doplňkové moduly CAD však nejsou na tomto typu klienta podporovány. Vzdálení uživatelé mohou hledat v úschovnách a využívat základní funkce přes internet pomocí klientů Web2.
Viewer | Umožňuje přístup do úschoven jen pro čtení. Uživatel může provést přechod souborů prostřednictvím pracovního postupu, ale nemůže přidávat nebo upravovat (vyzvedávat, odevzdávat, aktualizovat hodnoty) soubory ani používat doplňkové moduly CAD.
Nadřazené téma SOLIDWORKS PDM a SOLIDWORKS Manage


Před instalací softwaru PDM Serveru

Před instalací serverových součástí PDM mějte na paměti následující požadavky:

  • Obstarejte si úplná oprávnění správce pro počítače, na kterých budete instalovat servery a klienty.
  • Ověřte, že má databázový server přístup na archivační server přes TCP, port 3030 a SQL server přes TCP, port 1433.
  • Hodláte-li použít stávající databázi SQL Server Express nebo SQL Server, požádejte o název databáze SQL Serveru a přihlašovací ID a heslo správce nebo vlastníka databáze SQL s přístupem pro čtení/zápis do databáze. Uživatele tew nelze použít.
  • Pokud je již v systému nainstalován klient PDM, odinstalujte jej. Pokud chcete mít na jednom systému Server PDM i klient PDM, můžete je oba nainstalovat ze stránky Serverové produkty v nástroji SOLIDWORKS Installation Manager.
Nadřazené téma SOLIDWORKS PDM a SOLIDWORKS Manage


Instalace PDM serveru s použitím Manažera instalací SOLIDWORKS

Když instalujete server PDM pro verzi PDM Standard, můžete nainstalovat archivní server, databázový server a klienta PDM CAD Editor na jednom počítači. Není nutné spouštět instalaci klienta samostatně.

Při instalaci serveru PDM pro verzi PDM Professional můžete zahrnout uvedené součásti a rovněž server Web2 a Web API.

Instalace serveru PDM a jeho součástí:

  1. Spusťte manažer instalací SOLIDWORKS Installation Manager.
  2. Na stránce Vítejte vyberte možnost Instalovat serverové komponenty a klikněte na následující možnosti:
    • Instalovat součásti SOLIDWORKS PDM Server na tomto počítači.
    • Instalovat SolidNetWork License Manager na tomto počítači.

      Pokud je na tomto nebo jiném počítači nainstalovaný nástroj SolidNetWork License Manager, tato možnost se nezobrazí.

  3. Pokud se zobrazí stránka Možnosti SolidNetwork License Manager, zadejte sériové číslo, určete umístění adresáře a klikněte na tlačítko Další.
  4. Postupujte podle pokynů pro systémová varování a klikněte na tlačítko Další.
  5. Na stránce Souhrnné informace v části SOLIDWORKS PDM Server klikněte na tlačítko Změnit.
  6. Na stránce Možnosti SOLIDWORKS PDM Serveru:
    1. Pod položkou Vyberte serverový produkt klikněte na možnost SOLIDWORKS PDM Standard nebo Professional.
    2. Pod položkou Umístění instalace klikněte na položku Procházet a zadejte cestu k souboru.
    3. V okně Vybrat prvky:
      1. Klikněte na položku Archivní server, Databázový server a Klient a nainstalujte tyto součásti na jeden počítač. Pokud jste v distribuovaném prostředí, lze nainstalovat archivní server a databázový server spuštěním Správce instalací na jiném počítači.
        • Pokud je v počítači již nainstalován klient PDM, je nutné zrušit instalaci a klienta odinstalovat. Pak lze spustit Manažera instalací SOLIDWORKS a nainstalovat server PDM společně s klientem.
        • Součást klientu SOLIDWORKS PDM, která je součástí instalace serveru SOLIDWORKS PDM, zahrnuje Průzkumníka položek, který nelze vyloučit z instalace.
      2. Pokud instalujete verzi PDM Professional, můžete rovněž kliknout na položky Web2 server a Web API Server.
        Pokud instalujete Web API server, můžete zadat hodnotu pro Číslo portu HTTP, která je mezi 0 a 65535. Výchozí hodnota je 65453.
    4. V aplikaci Server SQL lze nainstalovat novou instanci databázových nástrojů, dodávaných se serverem PDM (SQL Server Express pro verzi PDM Standard), nebo lze zadat název databáze, uživatelské jméno a heslo stávající instance.
      Pro SOLIDWORKS PDM Professional musí být nainstalována plná verze systému SQL Server.
    5. Klepněte na Zpět na souhrnné informace.
  7. Na stránce Souhrnné informace odsouhlaste podmínky licenční smlouvy SOLIDWORKS a klikněte na tlačítko Nainstalovat.

    Když Manažer instalací SOLIDWORKS dokončí instalaci, spustí se Nástroj pro konfiguraci archivního serveru. Podle pokynů v průvodci nakonfigurujete archivní server.

Informace o nastavení, konfiguraci a odstraňování problémů s archivním serverem, databázovým serverem, Web2 serverem a databázemi serveru SQL Server naleznete v příslušných tématech v Průvodci instalací SOLIDWORKS PDM

Obsah

  • Změna instalace produktu SOLIDWORKS PDM Server

Nadřazené téma SOLIDWORKS PDM a SOLIDWORKS Manage


Změna instalace produktu SOLIDWORKS PDM Server

Ke změně instalace produktu SOLIDWORKS PDM Server a jeho součástí použijte panel Programy a Funkce v Ovládacích panelech Windows. Instalaci produktu nelze změnit pomocí nástroje SOLIDWORKS Installation Manager (SLDIM), i když jste ho použili k instalaci produktu SOLIDWORKS PDM Server.

Nadřazené téma Instalace PDM serveru s použitím Manažera instalací SOLIDWORKS


Instalace klienta PDM s použitím Manažera instalací SOLIDWORKS

Hlavní verze aplikace SOLIDWORKS PDM Client musí odpovídat hlavní verzi softwaru SOLIDWORKS PDM Server. Při instalaci nebo upgradu aplikace SOLIDWORKS PDM Client se ujistěte, že verze souhlasí.

Při instalaci klienta PDM postupujte takto:

  1. Spusťte Manažer instalací SOLIDWORKS.
  2. Na stránce Vítejte vyberte Instalovat do tohoto počítače.
  3. Na stránce Sériové číslo klikněte na tlačítko Další.
    Klienty SOLIDWORKS PDM nevyžadují vlastní sériové číslo.
  4. Postupujte podle pokynů pro systémová varování a klikněte na tlačítko Další.
  5. Na stránce Souhrnné informace v části Produkty klikněte na tlačítko Změnit.
  6. Na stránce Výběr produktu klikněte na možnost Vybrat jiný balíček nebo produkty.
  7. V okně Vyberte balíček, který se má zobrazit vyberte verzi SOLIDWORKS. Potom klikněte na OK.
  8. Na stránce Výběr produktu vyberte položku SOLIDWORKS PDM Client. Pak vyberte eDrawings a povolte tak funkčnost náhledu PDM. Máte-li verzi SOLIDWORKS PDM Professional, můžete také vybrat možnost Průzkumník položek.
  9. Na stránce Souhrnné informace rozbalte položku Možnosti SOLIDWORKS PDM a klikněte na tlačítko Změnit.
  10. Na stránce Možnosti klienta SOLIDWORKS PDM vyberte následující možnosti a klikněte na tlačítko Zpět na souhrnné informace:
    • Typ produktu PDM
    • Typ klienta PDM
    • Doplňkové moduly
  11. Na stránce Souhrnné informace odsouhlaste podmínky licenční smlouvy SOLIDWORKS a klikněte na tlačítko Nainstalovat.
Správci také mohou pomocí Editoru možností administrativní kopie vytvořit a zavést obrazy klientů PDM. Podrobnosti najdete v Použití administrativní kopie.
Nadřazené téma SOLIDWORKS PDM a SOLIDWORKS Manage


SOLIDWORKS Electrical

Aplikace SOLIDWORKS Installation Manager vám umožní instalovat všechny součásti SOLIDWORKS Electrical v samostatném režimu nebo režimu klient/server.

SOLIDWORKS Electrical používá několik součástí. Během instalace musíte tyto součásti vybrat v závislosti na typu instalace, který chcete použít.
  • SOLIDWORKS Electrical Schematic - 2D aplikace k vytváření a správě elektrických schémat.
  • SOLIDWORKS Electrical 3D - doplňkový modul SOLIDWORKS pro integraci 2D schémat a 3D modelů. Součást SOLIDWORKS Electrical 3D vám dovoluje provádět správu rozvržení elektrických zařízení a trasovat vodiče, kabely a kabelové svazky.
  • Data - součást Data seskupí všechna data, která software vyžaduje. Tato data jsou grafická (například soubory představující symboly a rohová razítka) nebo technická (například katalogy výrobců a údaje související se symboly). Data můžete sdílet, aby byla přístupná všem uživatelům.
  • Collaborative Server - Nástroj pro správu otevírání a aktualizací výkresů elektrických projektů.
  • SQL Server - aplikace SOLIDWORKS Electrical vyžaduje databázi serveru Microsoft SQL Server. Během instalace můžete vytvořit novou databázi nebo vybrat stávající.

Typ instalace

Všechny součásti aplikace SOLIDWORKS Electrical můžete nainstalovat do jednoho počítače. Jedná se o samostatnou instalaci. Všechna data programu, například projektové výkresy a zprávy, jsou uložena na pracovní stanici.

Součásti aplikace SOLIDWORKS Electrical můžete také nainstalovat ve verzi klient/server. Tento typ instalace použijte, pokud chcete data ukládat na síťovém serveru. Instalace typu klient/server umožní několika uživatelům pracovat na stejném projektu. Klientské systémy musí mít síťový přístup k serveru a oprávnění pro čtení i zápis, aby mohly vytvářet projekty, knihovny a symboly.

Informace

Nezávisle na zvoleném typu instalace (samostatné nebo klient/server) musíte mít plná oprávnění správce systému Windows, abyste mohli instalovat software SOLIDWORKS Electrical.

Na počítači může být instalována pouze jedna verze softwaru SOLIDWORKS Electrical. Když instalujete SOLIDWORKS a jako jeden z produktů k instalaci vyberete SOLIDWORKS Electrical, odebere instalační program starší verzi aplikace SOLIDWORKS Electrical.

Aplikace SOLIDWORKS Installation Manager po svém spuštění automaticky rozpozná stávající verze SOLIDWORKS Electrical, které jsou instalovány na pracovní stanici nebo serveru.

Před instalací nové verze prostředí SOLIDWORKS Electrical vždy zálohujte stávající verzi. V aplikaci SOLIDWORKS Electrical Schematic vyberte Soubor > Archivovat prostředínebo v aplikaci SOLIDWORKS Electrical 3D vyberte SOLIDWORKS Electrical > Nástroje > Archivovat prostředí.

Obsah

  • Požadavky na instalaci aplikace SOLIDWORKS Electrical

  • Samostatná instalace nebo instalace klient/server

    Software SOLIDWORKS Electrical můžete nainstalovat ve dvou režimech. V samostatném režimu instalujte software na pracovní stanici. V režimu typu klient/server uživatelé sdílejí data.

  • Konfigurace Collaborative Sever

  • Konfigurace Microsoft SQL Serveru

  • Nastavení umístění dat


Požadavky na instalaci aplikace SOLIDWORKS Electrical

Aktuální systémové požadavky najdete v části Systémové požadavky.

Nadřazené téma SOLIDWORKS Electrical
Samostatná instalace nebo instalace klient/server
Konfigurace Collaborative Sever
Konfigurace Microsoft SQL Serveru
Nastavení umístění dat


Samostatná instalace nebo instalace klient/server

Software SOLIDWORKS Electrical můžete nainstalovat ve dvou režimech. V samostatném režimu instalujte software na pracovní stanici. V režimu typu klient/server uživatelé sdílejí data.

Software SOLIDWORKS Electrical musí být vždy připojený k instanci SQL Server.

Nadřazené téma SOLIDWORKS Electrical
Požadavky na instalaci aplikace SOLIDWORKS Electrical
Konfigurace Collaborative Sever
Konfigurace Microsoft SQL Serveru
Nastavení umístění dat

Samostatná licence

Při první instalaci je nutné do pracovní stanice instalovat všechny součásti.

  • SOLIDWORKS Electrical Schematic
  • SOLIDWORKS Electrical 3D
  • Collaborative Server
  • Data aplikace
  1. Na záložce Souhrn klikněte na Změnit v části Výběr produktu a vyberte všechny součásti SOLIDWORKS Electrical.
  2. Pokud chcete upravit možnosti instalace, na záložce Souhrn klikněte na Změnit v části Možnosti Electrical. Je možné vytvořit novou instanci systému SQL Server nebo využít existující instanci. Další informace najdete v konkrétních kapitolách Data a Microsoft SQL Server v této dokumentaci. Pokud ne, ponechejte výchozí možnosti.
  3. Pokračujte klepnutím na Nainstalovat.
Pokud je aplikace SOLIDWORKS Electrical již instalována v pracovní stanici, Manažer instalací SOLIDWORKS instalaci automaticky vyhledá a vyzve vás k její aktualizaci. Instalace všech součástí bez změny Možností Electrical.

Instalace typu klient/server

Instalace typu klient/server umožňuje sdílet data mezi více uživateli.

Na serveru potřebujete nainstalovat následující součásti:
  • Collaborative Server
  • Data aplikace
  • SQL Server
V klientech potřebujete nainstalovat následující součásti:
  • SOLIDWORKS Electrical Schematic
  • SOLIDWORKS Electrical 3D
  1. Na serveru instalujte součásti serveru.
  2. Na záložce Vítejte v Manažeru instalací SOLIDWORKS klikněte na Instalovat součást serveru.
  3. Vyberte možnost SOLIDWORKS Electrical.
  4. Na záložce Souhrn můžete upravovat možnosti instalace. Další informace najdete v konkrétních kapitolách Data a Microsoft SQL Server v této dokumentaci. Pokud ne, ponechejte výchozí možnosti.
  5. Pokračujte klepnutím na Nainstalovat.
  6. V klientech instalujte aplikace.
  7. Na záložce Vítejte v Manažeru instalací SOLIDWORKS klikněte na Instalovat na tento počítač.
  8. Na záložce Souhrn klikněte na Změnit v části Výběr produktu a zrušte možnost Server Electrical.
  9. Na záložce Souhrn klikněte na Změnit v části Možnosti Electrical a upravte nastavení pro připojení k serveru.
  10. Pokračujte klepnutím na Nainstalovat.
Pokud je aplikace SOLIDWORKS Electrical již instalována v pracovní stanici nebo na serveru, Manažer instalací SOLIDWORKS instalaci automaticky vyhledá a vyzve vás k její aktualizaci. Aktualizujte software s použitím stejného procesu jako u první instalace.


Konfigurace Collaborative Sever

Collaborative Server je služba Windows, která musí být stále spuštěna a musí mít trvale k dispozici nepřerušovanou obousměrnou komunikaci s klienty skrz brány firewall a antivirové systémy.

Pokud chcete nakonfigurovat Collaborative Server v individuálním nebo serverovém režimu, určete následující parametry:
  • Název počítače (například LOCALHOST nebo MujPocitac) nebo jeho IP adresa (například 127.0.0.1 nebo 192.168.999.999).
  • Číslo portu (ve výchozím nastavení 26666).

Collaborative Server můžete nakonfigurovat během instalace nebo později pomocí příkazu Nástroje > Nastavení aplikace.

Aby byla k dispozici nepřerušovaná obousměrná komunikace, je třeba zajistit, aby v systému, kde je nainstalován Collaborative Server, byla k dispozici čísla portů 26666 až 26676 (když je současně připojeno 10 uživatelů). Pokud tento port není k dispozici požádejte správce systému, aby nakonfiguroval jiný port pro aplikaci SOLIDWORKS Electrical.

Nadřazené téma SOLIDWORKS Electrical
Požadavky na instalaci aplikace SOLIDWORKS Electrical
Samostatná instalace nebo instalace klient/server
Konfigurace Microsoft SQL Serveru
Nastavení umístění dat


Konfigurace Microsoft SQL Serveru

Zajistěte, aby pro každý typ instalace aplikace SOLIDWORKS Electrical byla k dispozici instance databáze SQL Serveru. Můžete použít stávající databázi SQL Serveru, je-li již v systému nainstalována, nebo nainstalovat novou instanci v rámci instalace aplikace SOLIDWORKS Electrical.

Při instalaci nové instance SQL Serveru poskytuje instalace SOLIDWORKS bezplatnou verzi aplikace Microsoft SQL Express 2022. Tato verze je omezena na 1 procesor, 1 GB paměti a 10 GB dat. Při takovém omezení paměti a procesoru může současně pracovat maximálně 10 uživatelů.

Pokud instalujete SQL Express 2022, dbejte na to, aby software i hardware serveru splňovaly požadavky uvedené v části Systémové požadavky.

Pokud je na stejném serveru více než 10 současně pracujících uživatelů, měli byste si zakoupit a nainstalovat plnou verzi SQL serveru. Použijte pracovní postup popsaný pro instalaci softwaru SOLIDWORKS Electrical se stávající instancí SQL Serveru.

Bližší informace o produktu SQL Express 2022 naleznete v dokumentaci pro Microsoft SQL Server.

Nadřazené téma SOLIDWORKS Electrical
Požadavky na instalaci aplikace SOLIDWORKS Electrical
Samostatná instalace nebo instalace klient/server
Konfigurace Collaborative Sever
Nastavení umístění dat

Správa dat v aplikaci SOLIDWORKS Electrical

Mnoho programů používá jednu databázi, která obsahuje všechna programová data. Aplikace SOLIDWORKS Electrical je v tomto jiná. Každý projekt v aplikaci SOLIDWORKS Electrical dostane přiřazeno jedinečné číslo ID a každý projekt má svou vlastní databázi, kterou lze identifikovat podle příslušného ID. Pokud například ve správci projektů aplikace SOLIDWORKS Electrical naleznete projekt s označením ID#112, pak je jeho vlastní databáze označena „tew_project_data_112“.

Důvodem pro vytváření samostatných databází pro jednotlivé projekty je významná úspora času při zpracování. Také v případě kritického selhání databáze dojde k poškození pouze jediného projektu a integrita většiny programových informací zůstane zachována.

Některé společnosti však mají omezení, která se vztahují na vytváření nových databází. Aby mohla aplikace SOLIDWORKS Electrical fungovat, nesmí pro vytváření nových databází uživateli platit žádná omezení. Ověřte si u správce systémů nebo databází, zda nejsou v platnosti omezení, která by uživatelům bránila ve vytváření nových databází.

Nové instance serveru SQL

Chcete-li nainstalovat novou instanci serveru SQL, musíte mít úplná přístupová práva správce k serveru i ke všem klientským systémům. Musíte také zajistit, aby klienti měli k databázi přístupová oprávnění pro čtení i zápis, aby mohli vytvářet a upravovat projekty, knihovny, symboly a další data projektů.

Když instalujete novou instanci serveru SQL, vyberte pro ni jiný název než výchozí.

Stávající instance serveru SQL

Chcete-li nainstalovat novou databázi aplikace SOLIDWORKS Electrical nebo se připojit k instalaci SOLIDWORKS Electrical na stávající instanci SQL Serveru, musíte mít uživatelský účet s úplným přístupovým oprávněním správce k danému SQL Serveru.

Aby aplikace SOLIDWORKS Electrical fungovala správně, je třeba nastavit SQL Server na smíšený režim ověření. Smíšený režim ověření umožňuje používání ověřovacích údajů Windows nebo serveru SQL.

Pro připojení ke stávající databázi serveru SQL můžete použít ověření Windows nebo serveru SQL. Zadejte uživatelské jméno a heslo účtu Windows nebo serveru SQL, který má úplná přístupová práva správce k serveru SQL.

Chcete-li se připojit k serveru SQL z důvodu instalace, nelze použít uživatele „tew“. Přihlašovací údaje s dostatečným oprávněním pro přístup k serveru SQL získáte u svého správce serveru SQL nebo u správce systému.

Databáze aplikace SOLIDWORKS Electrical

Poté, co nainstalujete aplikaci SOLIDWORKS Electrical, vytvoří instalační program v instanci SQL Serveru následující databáze.

  • TEW_APP_DATA
  • TEW_APP_MACRO
  • TEW_APP_PROJECT
  • TEW_CATALOG
  • TEW_CLASSIFICATION


Nastavení umístění dat

Vyberte adresář, kam se budou ukládat programová data, například díly, šablony nebo 2D či 3D symboly. Mělo by se jednat o vyhrazenou složku. Nesmí to být kořenový adresář ani stejný adresář, který se používá pro ukládání dat aplikace SOLIDWORKS.

Výchozí složka je C:\ProgramData\SOLIDWORKS Electrical.

V případě instalace client/server potřebujete sdílet složku Data.

Instalační program vytvoří ve výchozí složce novou složku s názvem Update pro ukládání nových dat.

Při prvním spuštění aplikace SOLIDWORKS Electrical program automaticky sloučí data uložená ve složce Update se stávajícími daty. V průvodci Aktualizovat data můžete vybrat data, která se přidají do aplikace a databáze systému SQL Server.

Nadřazené téma SOLIDWORKS Electrical
Požadavky na instalaci aplikace SOLIDWORKS Electrical
Samostatná instalace nebo instalace klient/server
Konfigurace Collaborative Sever
Konfigurace Microsoft SQL Serveru


SOLIDWORKS Visualize a SOLIDWORKS Visualize Boost

SOLIDWORKS® Visualize poskytuje sadu samostatných nástrojů, které kombinují pokročilé funkce vykreslování s konstrukčně orientovanými funkcemi a pracovními postupy a umožňují vytvářet vysoce realistické obrázky 3D CAD modelů.

Produkty SOLIDWORKS Visualize jsou dostupné ve dvou balíčcích:
  • Standard
  • Professional

Součástí licence SOLIDWORKS Professional a Premium s aktivním předplatným je bezplatná licence SOLIDWORKS Visualize Standard. Pro samostatnou aktivaci zákazníků SOLIDWORKS potřebujete další sériové číslo. Neznáte-li sériové číslo softwaru SOLIDWORKS Visualize, obraťte se na správce softwaru SOLIDWORKS nebo na svého prodejce.

Aplikace SOLIDWORKS Visualize rovněž podporuje licence typu SolidNetWork (SNL), jako je plovoucí licence, a také offline aktivaci.

S použitím Manažera instalací SOLIDWORKS (SLDIM) nainstalujete aplikaci SOLIDWORKS Visualize jako součást individuální instalace (Instalovat na tento počítač). Software lze instalovat jako samostatnou aplikaci, což je výhoda, pokud se chystáte používat různé počítače pro modelování a vykreslování. Software nepoužívá licenci SOLIDWORKS.

SOLIDWORKS Visualize Boost je služba umožňující distribuovat vykreslování z počítače se softwarem SOLIDWORKS Visualize Professional do jednoho nebo více počítačů v síti. Zatímco se vytváří vykreslený obrázek, můžete na počítači provádět jiné úlohy, a obrázek v konečném vykreslení bude dostupný dříve. Software Visualize Boost můžete instalovat také v rámci individuální instalace (Instalovat na tento počítač) v Manažeru instalací SOLIDWORKS.

Součástí licence SOLIDWORKS Visualize Professional s aktivním předplatným je bezplatná licence SOLIDWORKS Visualize Boost.
Visualize Boost je doplňkový modul výhradně pro Visualize Professional. Visualize Boost nefunguje s aplikací Visualize Standard.

Obsah

  • Systémové požadavky pro SOLIDWORKS Visualize

  • Instalace SOLIDWORKS Visualize pomocí Manažera instalací SOLIDWORKS

  • Instalace Visualize Boost pomocí Manažera instalací SOLIDWORKS


Systémové požadavky pro SOLIDWORKS Visualize

Pro optimální výkon a instalaci aplikací SOLIDWORKS Visualize a SOLIDWORKS Visualize Boost postupujte před instalací podle následujících pokynů:
  • Před instalací aplikací SOLIDWORKS Visualize a SOLIDWORKS Visualize Boost zkontrolujte, zda máte pro každý produkt samostatné sériové číslo.
  • Zkontrolujte, zda každý počítač se softwarem SOLIDWORKS Visualize nebo SOLIDWORKS Visualize Boost splňuje požadavky uvedené v části Systémové požadavky.
  • Nainstalujte aplikaci SOLIDWORKS Visualize Boost na vyhrazené vykreslovací počítače umístěné v téže síti. Tyto počítače by se měly lišit od počítačů se softwarem SOLIDWORKS Visualize Professional; toto uspořádání umožňuje snížit zatížení při vykreslování.
  • Pokud není nalezen příslušný grafický procesor, nastaví se software SOLIDWORKS Visualize a SOLIDWORKS Visualize Boost na výchozí procesor (CPU). Více informací ohledně konkrétních grafických karet a ovladačů viz Hardwarová certifikace SOLIDWORKS.

Podpora grafické karty při použití modulu 3DS Stellar Physically Correct

Přesný režim vykreslování Stellar:
  • Grafická karta NVIDIA minimálně s mikro-architekturou Maxwell
  • Doporučená verze ovladače: 538.78 s podporou CUDA 12.2.
  • Minimálně 4 GB grafické paměti
Rychlý režim vykreslování Stellar:
  • Grafická karta NVIDIA minimálně s mikro-architekturou Turing (s jádry RT)
  • Využívá stejnou verzi ovladače a má stejné požadavky na paměť jako Přesný režim

Podpora grafické karty využívající technologii AMD ProRender

Rychlý a Přesný režim vykreslování AMD ProRender:
  • Grafický procesor a ovladač podporující standard Vulkan
  • Podpora OpenCL 1.2 nebo vyšší
Nadřazené téma SOLIDWORKS Visualize a SOLIDWORKS Visualize Boost


Instalace SOLIDWORKS Visualize pomocí Manažera instalací SOLIDWORKS

Postup instalace SOLIDWORKS Visualize:

  1. Spusťte Manažer instalací SOLIDWORKS.
  2. Na stránce Vítejte vyberte Instalovat do tohoto počítače.
  3. Pokračujte následovně:
    1. Na stránce Sériové číslo rozbalte položku Vizualizace.
    2. Vyberte SOLIDWORKS Visualize a zadejte sériové číslo.
    3. Klikněte na tlačítko Další.
  4. Postupujte podle pokynů pro systémová varování a klikněte na tlačítko Další.
  5. Na stránce Souhrnné informace odsouhlaste podmínky licenční smlouvy SOLIDWORKS a klikněte na tlačítko Nainstalovat.
Postupujte podle pokynů v průvodci aktivací produktu a aktivujte produkt.

Po aktivaci spusťte aplikaci dvojím kliknutím na ikonu SOLIDWORKS Visualize na pracovní ploše, nebo v nabídce Start systému Windows klikněte na SOLIDWORKS verze > SOLIDWORKS Visualize verze.

Obsah

  • Úlohy po instalaci

Nadřazené téma SOLIDWORKS Visualize a SOLIDWORKS Visualize Boost


Úlohy po instalaci

Po instalaci je několik úkolů, které byste měli provést pro konfiguraci softwaru SOLIDWORKS Visualize.

Další informace najdete v části Začínáme s aplikací SOLIDWORKS Visualize v Nápovědě k softwaru SOLIDWORKS Visualize.

Obsah

  • Vytvoření obsahové složky

  • Používání nápovědy, výukových lekcí, informací o systému a licencování

Nadřazené téma Instalace SOLIDWORKS Visualize pomocí Manažera instalací SOLIDWORKS


Vytvoření obsahové složky

Při prvním spuštění softwaru vás SOLIDWORKS Visualize vyzve k zadání umístění pro vytvoření složky Obsah.

Složka Obsah obsahuje následující podsložky, kde můžete ukládat materiály pro své projekty:
Podsložky | Úložiště
Kamery | Výchozí kamery a kamery, které jste si uložili
Prostředí | Obrázky s vysokým dynamickým rozsahem (HDR)
Palety | Obrázky pozadí
Obrázky | Vykreslování a snímky
Vzhledy | Materiály ve vaší složce Vzhledy Po přidání vzhledu do knihovny se obsah aktualizuje.
Modely | Souborů modelu Software SOLIDWORKS Visualize při importu modelu pomocí příkazu Soubor > Import prohledá tuto složku.
Desky | Standardní 2D obrázky pro použití v pozadích.
Projekty | Nativní soubory projektu ve formátu .SVPJ
Textury | 2D textury pro použití ve vzhledech
Nadřazené téma Úlohy po instalaci


Používání nápovědy, výukových lekcí, informací o systému a licencování

Nabídka Nápověda obsahuje dokumentaci a možnosti pro aktualizaci softwaru a řešení problémů se systémem.

Nápověda k aplikaci Visualize | Otevře online nápovědu softwaru SOLIDWORKS Visualize.
Výukové lekce k aplikaci Visualize | Otevře web MySolidWorks a poskytne vám přístup k výukovým lekcím softwaru SOLIDWORKS Visualize.
Poznámky k verzi | Zobrazí online poznámky k verzi pro aktuální verzi.
Co je nového. | Zobrazí nové funkce produktů SOLIDWORKS.
Informace o systému | Provede kontrolu systému softwaru SOLIDWORKS Visualize s hardwarem vašeho počítače a v případě potřeby navrhne upgrady.
Zkontrolovat aktualizace. | Prověří dostupnost nejnovější aktualizace softwaru SOLIDWORKS Visualize na serveru.
Aktivovat licenci | (Licence pro uzamknutý uzel) Aktivuje váš produkt pomocí průvodce Aktivace produktu SOLIDWORKS.
Deaktivovat licenci | (Licence pro uzamknutý uzel) Deaktivuje váš produkt pomocí průvodce Aktivace produktu SOLIDWORKS.
Správce licencí SolidNetWork | Deaktivuje váš produkt pomocí průvodce Aktivace produktu SOLIDWORKS.
O aplikaci Visualize | Zobrazí číslo verze a licenční informace vaší kopie softwaru SOLIDWORKS Visualize.
Nadřazené téma Úlohy po instalaci


Instalace Visualize Boost pomocí Manažera instalací SOLIDWORKS

Software Visualize Boost nainstalujete s použitím Manažera instalací SOLIDWORKS. Vyžaduje samostatné sériové číslo.

Software Visualize Boost je nutno instalovat na jiný počítač, než na kterém se používá aplikace SOLIDWORKS Visualize Professional. Výkon při vykreslování je v případě počítače s více grafickými procesory (GPU) možné maximalizovat instalací nástroje Visualize Boost.

Postup instalace SOLIDWORKS Visualize Boost:

  1. Spusťte Manažer instalací SOLIDWORKS.
  2. Na stránce Vítejte vyberte Instalovat do tohoto počítače.
  3. Pokračujte následovně:
    1. Na stránce Sériové číslo rozbalte položku Vizualizace.
    2. Vyberte SOLIDWORKS Visualize Boost a zadejte sériové číslo.
    3. Klikněte na tlačítko Další.
  4. Postupujte podle pokynů pro systémová varování a klikněte na tlačítko Další.
  5. Na stránce Souhrnné informace odsouhlaste podmínky licenční smlouvy SOLIDWORKS a klikněte na tlačítko Nainstalovat.
Postupujte podle pokynů v průvodci aktivací produktu a aktivujte produkt.

Po aktivaci aplikaci spusťte dvojím kliknutím na zástupce SOLIDWORKS Visualize Boost na pracovní ploše [image].

Obsah

  • Konfigurace aplikace Visualize Boost

    Primární počítač s aplikací Visualize Boost můžete konfigurovat jako koordinátora a ostatní počítače jako uzly.

Nadřazené téma SOLIDWORKS Visualize a SOLIDWORKS Visualize Boost


Konfigurace aplikace Visualize Boost

Primární počítač s aplikací Visualize Boost můžete konfigurovat jako koordinátora a ostatní počítače jako uzly.

Aplikace Visualize Boost umožňuje vykreslovat snímky na jednom počítači nebo s využitím více počítačů. Nastavení je jednoduché a intuitivní. Primární počítač – Koordinátor – spravuje cluster a distribuuje úlohy vykreslování ze softwaru SOLIDWORKS Visualize. Ostatní počítače neboli Uzly lze propojit s koordinátorem, aby pomáhaly s těmito úlohami po síti. Aplikace Visualize Boost běží nepřetržitě na každém počítači ve vykreslovací farmě.

Konfiguraci aplikace Visualize Boost provedete takto:

  1. Spusťte aplikaci Visualize Boost:
    • Klikněte dvakrát na zástupce Visualize Boost na pracovní ploše [image].
    • V nabídce Start systému Windows klikněte na možnost SOLIDWORKS <verze> > SOLIDWORKS Visualize Boost <verze>.
    Po aktivaci aplikace Visualize Boost identifikuje a zobrazí název a IP adresu počítače s licencí.
  2. Klikněte v aplikaci Visualize Boost na nabídku Soubor > Nastavení.
  3. V okně Nastavení proveďte následující:
    1. Vyberte jeden počítač jako Koordinátor. Při konfiguraci ostatních počítačů jako Uzly ponechte políčko Koordinátor nezaškrtnuté.
    2. Přijměte výchozí hodnoty 8001 v nastavení Port Boost a 8002 v nastavení Port DStellar.
      Tyto porty můžete upravit podle požadavků sítě. Nezapomeňte přidat výjimky pro komunikaci s uzly v nastavení brány firewall. V případě dotazů se obraťte na správce sítě.
  4. Volitelné: Další parametry jsou následující:
    Volba | Popis
    Jazyk | Počítač používá automaticky jazyk operačního systému.
    Motiv | Vyberte možnost Světlý nebo Tmavý v nastavení Motiv. Toto nastavení ovlivňuje aplikaci SOLIDWORKS Visualize, pokud je nainstalována na stejném počítači jako nástroj Visualize Boost.
    Upozornění jsou povolena | Zobrazuje hlášení z nástroje DStellar.Boost v oznamovací oblasti systému Windows.
    Exportovat | Uloží konfigurací nástroje Visualize Boost do souboru .json.
    Import | Načte již existující nastavení ze souboru .json do instance aplikace Visualize Boost.
  5. Klepněte na Použít.
Chcete-li dokončit nastavení, postupujte podle pokynů v tématu Práce s aplikací Visualize Boost.
Nadřazené téma Instalace Visualize Boost pomocí Manažera instalací SOLIDWORKS


Administrace licencí

Po instalaci můžete aktivovat licence SOLIDWORKS buď aktivací individuálních počítačů (aktivace v počítači), nebo instalací a aktivací plovoucích síťových licencí na serveru (Licence SolidNetWork).

Zpravidla instalace na individuálních počítačích používají aktivaci licence, ale je také možné nainstalovat program samostatně a poté spravovat licence pomocí SolidNetWork License Manager. V opačném případě můžete zavést instalace z administrativní kopie a poté aktivovat sériová čísla na jednotlivých počítačích, i když na velkých pracovištích zpravidla používají plovoucí síťové licence.

Obsah

  • Správa jednotlivých součástí

    Můžete zadat individuální licenci k použití aktivace stroje.

  • Správa licencí za použití SolidNetWork License Manager

    SolidNetWork License Manager podporuje násobné licenční klienty pomocí distribuce licencí klientům na síti. To umožňuje počtu uživatelů rozšířit počet licencí použitím plovoucích licencí.


Správa jednotlivých součástí

Můžete zadat individuální licenci k použití aktivace stroje.

Správa individuálních licencí obvykle sestává z aktivace a deaktivace licencí přímo ze softwaru SOLIDWORKS.

Aktivace je licencování produktu a registrační proces pro licence samostatného softwaru SOLIDWORKS (ne pro síťové licence SolidNetWork). Pokud jste ještě neaktivovali licenci pro tento počítač, SOLIDWORKS se obvykle pokouší ji aktivovat, když spustíte SOLIDWORKS.

Počínaje produkty SOLIDWORKS 2022 a novějšími platí, že pokud jste si zakoupili doživotní licenci SOLIDWORKS, musíte ji jednou za rok znovu aktivovat. Doživotní licenci nikdy neskončí platnost, ale je nutné ji znovu aktivovat. SOLIDWORKS vás vyzve k opětovné aktivaci doživotní licence před požadovaným datem opětovné aktivace.

Můžete také deaktivovat individuální licence tím, že v SOLIDWORKS kliknete na [image] > Licence > Deaktivovat.

Nadřazené téma Administrace licencí
Správa licencí za použití SolidNetWork License Manager

Aktivace licence

Abyste mohli spustit produkty SOLIDWORKS na konkrétním počítači, musíte pro tento počítač aktivovat licenci.

K aktivaci je potřeba připojení k internetu nebo přístup k e-mailu. Po aktivaci již nemusíte být připojení k internetu při používání produktů. Pokud na počítači, na kterém instalujete tento produkt, nemáte přístup k emailové službě, můžete aktivační soubor uložit a odeslat ho z jiného počítače.

Tento proces:
  • Aktivuje všechny programové licence pro celou řadu SOLIDWORKS produktů.
  • Vám umožní přenést licenční práva z jednoho počítače na druhý.
  • Můžete provést ihned (doporučujeme) nebo nejpozději do 30 dnů po instalaci.
  • Vyloučí potřebu používat hardwarové klíče. Pokud však stále používáte starší verze produktů SOLIDWORKS, které nepoužívají aktivaci, musíte si ponechat hardwarový klíč.

Správci systému, kteří spravují několik sériových čísel, mohou najít užitečné informace na odkazu Editor možností administrativní kopie. Podrobnosti najdete v Editor možností administrativní kopie.

Návod na aktivaci licence:

  1. Spusťte software SOLIDWORKS.
  2. Spusťte Aktivaci produktu SOLIDWORKS za použití jedné z těchto metod:
    • Pokud jste ještě neaktivovali licenci pro tento počítač, objeví se při spuštění softwaru SOLIDWORKS automaticky okno Aktivace produktu SOLIDWORKS.
    • Pokud se okno Aktivace produktu SOLIDWORKS neobjeví automaticky, spusťte aktivaci kliknutím na položky [image] > Licence > Aktivovat.
  3. Klikněte na seznam Produkt a určete produkt, jehož licenci chcete aktivovat.
  4. Určete automatickou aktivaci přes internet nebo ruční aktivaci za použití e-mailu.
  5. Zadejte kontaktní e-mailovou informaci.
  6. Klepněte na Další.
    • Internet: K aktivaci dojde automaticky.:
    • Email: Kliknutím na tlačítko Uložit vytvořte soubor s požadavkem a odešlete jej na adresu activation@solidworks.com. Když obdržíte e-mail se souborem s odpovědí, soubor z e-mailu klepnutím na Otevřít načtěte.
      Pokud je to potřeba, můžete tento krok ukončit a novu spustit aktivační postup pro otevření souboru s odpovědí.
  7. Klepněte na Dokončit.
Editor možností administrativní kopie

Opětovné aktivování licence

Pokud máte doživotní licence pro komerční a vzdělávací účely na produkty SOLIDWORKS 2022 a novější, musíte tyto licence jednou ročně znovu aktivovat. Nástroj Aktivace produktu SOLIDWORKS vás k tomu vyzve ještě před požadovaným datem opětovné aktivace.

Postup opětovné aktivace licence:

  1. Spusťte software SOLIDWORKS.
    Nástroj Aktivace produktu SOLIDWORKS vás vyzve k opětovné aktivaci. Pro každou licenci na produkt SOLIDWORKS se zobrazí následující:
    • Datum, kdy vyprší platnost aktuální aktivace
    • Akce vyžadovaná pro pokračování v používání produktu, jako je opětovná aktivace doživotní licence nebo obnovení a opětovná aktivace dočasné nebo zkušební licence
  2. Kliknutím na možnost Znovu aktivovat nyní spustíte průvodce Aktivace produktu.

    Pokud nechcete licenci aktivovat znovu ihned, klikněte na možnost Připomenout později. Například v softwaru SOLIDWORKS spustíte průvodce Aktivace produktu kliknutím na možnost [image] > Licence > Aktivovat. Viz Aktivace licence.

Přenos licence

Při přenosu licence SolidNetWork na jiný počítač nebo upgradovaný počítač musíte nejprve deaktivovat na serveru licenčních klíčů společnosti Dassault Systèmes SolidWorks Corporation . Poté ji znovu aktivujte na druhém počítači.

Pokud nelze deaktivovat licenci od společnosti Dassault Systèmes SolidWorks Corporation (například v důsledku selhání disku), ve většině případech je reaktivace přesto úspěšná. Pokud to nelze, obraťte se na svého prodejce produktů.

Přesunutí licence:

  1. V SOLIDWORKS klepněte na [image] > Licence > Deaktivace a postupujte podle pokynů.
  2. Reaktivaci proveďte na novém nebo upgradovaném počítači a aktivujte licenci jako v počáteční aktivaci. Podrobnosti naleznete v části Aktivace licence.


Správa licencí za použití SolidNetWork License Manager

SolidNetWork License Manager podporuje násobné licenční klienty pomocí distribuce licencí klientům na síti. To umožňuje počtu uživatelů rozšířit počet licencí použitím plovoucích licencí.

Tento obrázek znázorňuje typickou instalaci správy licencí SolidNetWork

Tento obrázek ilustruje:
  • SolidNetWork License Manager je instalován a aktivován pouze na počítači manažera licencí.
  • Počítače licenční klientů nemají nainstalován žádný dodatečný program patřící SolidNetWork.

    Pokud určujete při instalaci sériové číslo licence SolidNetWork, Manažer instalací SOLIDWORKS identifikuje počítač jako klienta s licencí SolidNetWork. Manažer instalací SOLIDWORKS vás vyzve, abyste zadali název počítače a číslo portu nástroje SolidNetWork License Manager pro spojení klienta s manažerem licencí.

  • Manažer licencí a všichni klienti s licencí musí mít spojení TCP/IP (Transmission Control Protocol/Internet Protocol).

Obsah

  • Přehled instalace licencí SolidNetWork

    Manažer instalace SOLIDWORKS se používá k instalaci serveru SolidNetWork License Manager alespoň na jednom počítači před instalací klientského softwaru SOLIDWORKS na jakémkoli počítači. Poté můžete pomocí Průvodce aktivací produktu přidat a aktivovat sériová čísla pro trvalé a termínované licence.

  • Spuštění SolidNetWork License Manager

    Můžete spustit SolidNetWork License Manager z nabídky Windows Start.

  • Upgrade SolidNetWork License Manager

    V případě významných verzí programu SOLIDWORKS se upgrade manažera licencí skládá z odinstalování starého manažera licencí, instalace nového a z opakované aktivace licence SolidNetWork.

  • Přenos licence SolidNetWork

    Při přenosu licence na jiný počítač musíte nejprve deaktivovat licenci a vrátit ji zpět na server licenčních klíčů společnosti Dassault Systèmes SOLIDWORKS Corporation a poté ho znovu aktivovat na jiném počítači.

  • Odstranění licenčních souborů SolidNetWork

    Před provedením upgradu na nové licence můžete odstranit neplatné licenční soubory SolidNetWork.

  • Zapůjčení a navrácení licencí SolidNetWork

    Můžete si půjčit licenci SolidNetWork, aby jste mohli používat tento program ze vzdáleného umístění. Protože je licence je odstraněna ze souhrnu dostupných licencí, zapůjčenou licenci je nutno vrátit, aby byla opět k dispozici.

  • Řízení přístupu k verzím SOLIDWORKS

    Máte možnost zabránit uživatelům v přístupu k určitým verzím SOLIDWORKS v prostředí SolidNetWork. Tato funkce umožňuje spravovat verze SOLIDWORKS používané různými osobami, projekty a organizačními jednotkami.

  • Monitorování doby nečinnosti licence

    SOLIDWORKS může registrovat dobu nečinnosti SolidNetWork License Manager na serveru, aby byly licence, které nejsou používány po určitou dobu, vráceny do fondu volných licencí.

  • Používání dočasné licence

    Můžete použít dočasnou licenci „any“, když není k dispozici licence SolidNetWork.

  • Použití licencí SolidNetWork a doplňkových modulů

    K rozdělení licencí pro doplňkové moduly jádra SOLIDWORKS můžete použít manažer licencí SolidNetWork License Manager.

  • Výběr licence SOLIDWORKS Simulation s licencí SolidNetWork License

    Uživatelé licence SolidNetWork mohou určit, kterou z licencí SOLIDWORKS® Simulation v jejich fondu licencí použít při spuštění doplňkového modulu SOLIDWORKS Simulation. Také mohou upgradovat licenci SOLIDWORKS Simulation bez uvolnění doplňkového modulu v případě, že potřebují vyšší typ licence pro pokročilé studie.

  • Načítání modulů Flow Simulation

    Jako licenční zákazník SolidNetWork můžete ovládat způsob načítání doplňkových modulů HVAC a Electronics Cooling pro Flow Simulation pomocí dvou metod.

  • Časový limit nečinnosti v softwaru SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation a SOLIDWORKS Plastics

    Když spustíte studii v softwaru SOLIDWORKS Simulation, Plastics nebo Flow Simulation, zůstanou síťové licence aktivní a nejsou časově omezené. Software SOLIDWORKS zachová licence v platnosti během procesu výpočtu, který je považován za aktivitu.

  • Použití stejného počítače pro manažera licencí a instalace administrativní kopie

    Jeden počítač v síti můžete nakonfigurovat tak, aby fungoval jako manažer licencí, který distribuuje licence SolidNetWork, a zároveň jako umístění kopie, z níž si uživatelé mohou instalovat aplikaci SOLIDWORKS.

  • Odinstalování SolidNetWork License Manager

    Pokud provádíte upgrade SolidNetWork License Manager, musíte odinstalovat starého manažera licencí před instalací nového.

  • Správa licencí FlexNet Publisher

    Správa licencí SolidNetWork je založena na správě licencí FlexNet Publisher®.

Nadřazené téma Administrace licencí
Správa jednotlivých součástí


Přehled instalace licencí SolidNetWork

Manažer instalace SOLIDWORKS se používá k instalaci serveru SolidNetWork License Manager alespoň na jednom počítači před instalací klientského softwaru SOLIDWORKS na jakémkoli počítači. Poté můžete pomocí Průvodce aktivací produktu přidat a aktivovat sériová čísla pro trvalé a termínované licence.

Při instalaci klientského softwaru SOLIDWORKS do počítače zadejte sériové číslo licence SolidNetWork. Manažer instalace SOLIDWORKS identifikuje tento počítač jako klient licence SolidNetWork a vyzve vás k zadání názvu počítače a čísla portu serveru SolidNetWork License Manager. Zobrazí chybu, pokud není nainstalován server SolidNetWork License Manager nebo pokud jsou název nebo číslo portu nesprávné.

Proces aktivace

Abyste mohli na jednotlivých počítačích spustit produkty SOLIDWORKS, musíte v počítači serveru SolidNetWork License Manager aktivovat licenci SolidNetWork.

K aktivaci je potřeba aktivní připojení k internetu nebo přístup k e-mailu. Po aktivaci již nemusíte být připojení k internetu při používání produktů. Pokud na počítači, na kterém instalujete tento produkt, nemáte přístup k emailové službě, můžete aktivační soubor uložit a odeslat ho z jiného počítače.

Tento proces:
  • Aktivuje SolidNetWork License Manager pomocí licencí SolidNetWork pro jednotlivé produkty SOLIDWORKS.
  • Umožní vám přenést licenční práva SolidNetWork z jednoho počítače SolidNetWork License Manager na druhý.
  • Umožní vám instalovat a aktivovat licenční práva SolidNetWork na počítači SolidNetWork License Manager.
  • Musí být provedena než začnete používat licence SolidNetWork.
  • Vyloučí potřebu používat hardwarové klíče. Pokud aktivujete licenci SolidNetWork pro tuto verzi SOLIDWORKS, licence SolidNetWork pro dřívější verze SOLIDWORKS jsou aktivovány. Už si nemusíte nechávat hardwarový klíč.

Obsah

  • Instalace serveru nástroje SolidNetWork License Manager

    Server nástroje SolidNetWork License Manager podporuje více klientů licence. Tento server distribuuje licence klientům na síti.

  • Aktivace licencí SolidNetWork

    Abyste mohli na jednotlivých počítačích spustit produkty SOLIDWORKS, musíte v počítači SolidNetWork License Manager aktivovat licenci SolidNetWork.

  • Ruční aktivace pomocí serveru nástroje SolidNetWork License Manager

    Při instalaci nebo upgradu serveru nástroje SolidNetWork License Manager je třeba aktivovat nebo znovu aktivovat licenci. Licenci můžete aktivovat nebo znovu aktivovat přes internet nebo se to můžete rozhodnout udělat ručně.

  • Instalace licenčních klientů SolidNetWork

  • Použití licencí SolidNetWork s firewall

    Pokud je na vašem počítači nainstalována bezpečnostní brána firewall, musíte konfigurovat porty správy licencí SolidNetWork následovně:

  • Opětovná aktivace licence SolidNetWork

    Opětovná aktivace se vztahuje na licenční produkty SolidNetWork poté, co organizace provede upgrade serveru nástroje SolidNetWork License Manager na verzi 2022 nebo novější. I když budou nainstalované produkty pocházet ze starších verzí, licence počínaje verzí 2022 na serveru budou vyžadovat každoroční aktivaci.

  • Instalace Manažera licencí triády

    Manažer licencí triády používá tři počítače pro zajištění dodatečné stability. Pokud není počítač, který spravuje licenční soubor, dostupný převezme jeho operace jeden ze dvou dalších počítačů.

Nadřazené téma Správa licencí za použití SolidNetWork License Manager
Spuštění SolidNetWork License Manager
Upgrade SolidNetWork License Manager
Přenos licence SolidNetWork
Odstranění licenčních souborů SolidNetWork
Zapůjčení a navrácení licencí SolidNetWork
Řízení přístupu k verzím SOLIDWORKS
Monitorování doby nečinnosti licence
Používání dočasné licence
Použití licencí SolidNetWork a doplňkových modulů
Výběr licence SOLIDWORKS Simulation s licencí SolidNetWork License
Načítání modulů Flow Simulation
Časový limit nečinnosti v softwaru SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation a SOLIDWORKS Plastics
Použití stejného počítače pro manažera licencí a instalace administrativní kopie
Odinstalování SolidNetWork License Manager
Správa licencí FlexNet Publisher


Instalace serveru nástroje SolidNetWork License Manager

Server nástroje SolidNetWork License Manager podporuje více klientů licence. Tento server distribuuje licence klientům na síti.

Pokud upgradujete z předchozí verze serveru nástroje SolidNetWork License Manager, která používala hardwarové klíče pro aktivaci licence, odstraňte je před instalací nové verze serveru nástroje SolidNetWork License Manager.

  1. Spusťte Manažer instalací SOLIDWORKS podle postupu v tématu Stažení instalačního média.
  2. Jako typ instalace vyberte Instalovat serverové komponenty a klikněte na možnost Nainstalovat SolidNetWork License Manager (distribuované licencování) v tomto počítači.
  3. Na stránce Souhrn zkontrolujte umístění instalace a nástroj pro stahování na pozadí, potvrďte souhlas s licenčními podmínkami a klikněte na možnost Instalovat nyní.
  4. V Průvodci aktivací produktu SOLIDWORKS ze serveru nástroje SolidNetWork License Manager přidejte sériové číslo a aktivujte alespoň jednu licenci. Viz dokument Přidání sériových čísel a aktivace licencí SolidNetWork.
Nadřazené téma Přehled instalace licencí SolidNetWork
Aktivace licencí SolidNetWork
Ruční aktivace pomocí serveru nástroje SolidNetWork License Manager
Instalace licenčních klientů SolidNetWork
Použití licencí SolidNetWork s firewall
Opětovná aktivace licence SolidNetWork
Instalace Manažera licencí triády


Aktivace licencí SolidNetWork

Abyste mohli na jednotlivých počítačích spustit produkty SOLIDWORKS, musíte v počítači SolidNetWork License Manager aktivovat licenci SolidNetWork.

Návod na aktivaci licence SolidNetWork:

  1. Spusťte nástroj SolidNetWork License Manager kliknutím na Start > Nástroje SOLIDWORKSverze > Server SolidNetWork License Managerverze.
  2. Volitelné: Pokud jste ještě neaktivovali licenci SolidNetWork, zobrazí software dotaz, zda ji chcete aktivovat. Klikněte na Ano.
    Spustí se průvodce Aktivace produktu SolidWorks.
  3. Volitelné: Pokud používáte bránu firewall, vyberte možnost Na tomto serveru se používá brána firewall.
  4. Zadejte čísla portů na stránce Informace o serveru SolidNetWork License a klikněte na tlačítko Další.
  5. V seznamu Sériové č.: vyberte daná sériová čísla nebo klikněte na Vybrat vše, abyste zvýraznili a aktivovali všechna sériová čísla SOLIDWORKS.
    1. Vyberte možnost aktivace Automaticky přes internet (doporučeno).
    2. V části Kontaktní informace zadejte e-mailovou adresu.
    V dialogu Aktivace/Reaktivace byla úspěšná se zobrazí produkty, které byly aktivovány.
  6. Klikněte na Dokončit.
Nadřazené téma Přehled instalace licencí SolidNetWork
Instalace serveru nástroje SolidNetWork License Manager
Ruční aktivace pomocí serveru nástroje SolidNetWork License Manager
Instalace licenčních klientů SolidNetWork
Použití licencí SolidNetWork s firewall
Opětovná aktivace licence SolidNetWork
Instalace Manažera licencí triády


Ruční aktivace pomocí serveru nástroje SolidNetWork License Manager

Při instalaci nebo upgradu serveru nástroje SolidNetWork License Manager je třeba aktivovat nebo znovu aktivovat licenci. Licenci můžete aktivovat nebo znovu aktivovat přes internet nebo se to můžete rozhodnout udělat ručně.

Při ruční aktivaci:
  • Pro nový server nástroje SolidNetWork License Manager je třeba aktivovat dvakrát, aby byl server správně nakonfigurován. Při první aktivaci inicializujete licenční systém na serveru. Při druhém opakování postupu aktivujete licenci.
  • Pro upgradovaný server nástroje SolidNetWork License Manager je třeba znovu aktivovat stávající licenci. Pokud server nemá aktivované licence, spusťte aktivaci pomocí možnosti Změnit na kartě Správa serveru.
Nadřazené téma Přehled instalace licencí SolidNetWork
Instalace serveru nástroje SolidNetWork License Manager
Aktivace licencí SolidNetWork
Instalace licenčních klientů SolidNetWork
Použití licencí SolidNetWork s firewall
Opětovná aktivace licence SolidNetWork
Instalace Manažera licencí triády


Instalace licenčních klientů SolidNetWork

Při instalaci softwaru CAD SOLIDWORKS do počítače určujete sériové číslo licence SolidNetWork. Manažer instalací SOLIDWORKS identifikuje tento počítač jako licenční klient SolidNetWork a vyzve vás k zadání názvu a čísla počítače nástroje SolidNetWork License Manager. Jestliže není nainstalován server nástroje SolidNetWork License Manager nebo pokud je název nebo číslo portu nesprávné, zobrazí se chyba.

Instalace softwaru SOLIDWORKS s licencí SolidNetWork:

  1. Spusťte Manažer instalací SOLIDWORKS podle postupu v tématu Stažení instalačního média.
  2. Pokud je to první instalace SOLIDWORKS na tomto počítači pro tuto hlavní verzi, klikněte na uvítací stránce na možnost Instalovat na tomto počítači.
    Jestliže provádíte upgrade existující verze a měníte z individuální licence na licenci SolidWorks, klepněte na Změnit individuální instalaci (na tomto počítači). Podrobnosti najdete v Provedení upgrade z individuální licence na licenci SolidNetWork .
  3. V dialogovém okně Přidat server zadejte adresu SolidNetWork License Manager v tomto tvaru:

    port@NázevPočítače

    Číslo portu se musí shodovat s číslem použitým pro počítač s Manažerem licencí. Výchozí je 25734.

    Manažer instalace SOLIDWORKS se pokusí ověřit, jestli je SolidNetWork License Manager dostupný. Pokud jste ještě neinstalovali Manažera licencí, tato validace se nepodaří; ovšem můžete dále instalovat klienta s licencí.
  4. Dokončete instalaci SOLIDWORKS podle následujících pokynů Manažera instalace SOLIDWORKS.
Nadřazené téma Přehled instalace licencí SolidNetWork
Instalace serveru nástroje SolidNetWork License Manager
Aktivace licencí SolidNetWork
Ruční aktivace pomocí serveru nástroje SolidNetWork License Manager
Použití licencí SolidNetWork s firewall
Opětovná aktivace licence SolidNetWork
Instalace Manažera licencí triády


Použití licencí SolidNetWork s firewall

Pokud je na vašem počítači nainstalována bezpečnostní brána firewall, musíte konfigurovat porty správy licencí SolidNetWork následovně:

V softwaru brány firewall musíte přidat dva porty licencí SolidNetWork (například SNL-in-port a SNL-out-port) do seznamu výjimek firewall. O bližší informace o konfiguraci těchto portů požádejte správce vaší sítě.

Pokud používáte bránu firewall podporovaného systému Windows, musíte změnit porty na počítači s nástrojem SolidNetWork License Manager upravit licenční soubor SolidNetWork pro distribuci licencí na klientské počítače licence.

Úprava portů počítače Manažera licencí pro Windows Firewall

  1. Klepněte na tlačítko Start a otevřete položku Zabezpečení Windows.
  2. Vyberte možnost Firewall a ochrana sítě > Upřesnit nastavení a klepnutím na tlačítko Ano potvrďte změny.
  3. V dialogovém okně Firewall v programu Windows Defender s pokročilým zabezpečením vyberte možnost Příchozí pravidla > Nové pravidlo.
  4. V Průvodci vytvořením nového příchozího pravidla vyberte typ pravidla Port a klikněte na tlačítko Další.
  5. Zadejte číslo portu do pole Konkrétní místní porty: (například 80, 25734, 443) a poté klepněte na tlačítko Další.
  6. Vyberte pole Název. Zadejte název (například SNL-in-port).
  7. Klikněte na Dokončit.

Úprava SolidNetWork License Manager pro Windows Firewall

  1. Spusťte nástroj SolidNetWork License Manager kliknutím na Start > Nástroje SOLIDWORKSverze > Server SolidNetWork License Manager verze.
  2. Na záložce Správa serveru v poli Licenční server klepněte na Zastavit. Klikněte na Ano pro potvrzení a na OK pro zastavení licenčního serveru.
  3. Pod možností Informace o licenci klepněte na Upravit.
  4. Pod Typem serveru zvolte uspořádání serveru pro vaši síť (Samostatný nebo Triáda) a pak klepněte na Další.
  5. Pod Informace o serveru:
    1. Vyberte Na tomto serveru se používá brána firewall.
    2. Číslo portu a číslo portu Vendor Daemon by měla obsahovat čísla portu určená pro Windows Firewall (podrobnosti viz postup výše).
    3. Vyberte Soubor možností, klepněte na tlačítko Procházet a vyhledejte požadovaný soubor. Klepněte na Upravit a podle potřeby změňte jeho parametry.
    Soubor možností dovoluje správci licencí kontrolovat různé provozní parametry licencování softwaru FlexNet.

    Doporučení: Umístění souboru možností je v instalační složce aplikace SolidNetWork License Manager (SolidNetWork_License_Manager_install_dir\Licenses \sw_d.opt). Tento soubor je třeba uložit do stejné složky jako soubor sw_d.lic.

    Více informací o souboru možností najdete v Průvodci správou licencí k softwaru FlexNet Publisher v instalačním adresáři nástroje SolidNetWork License Manager:

    C:\Program Files\SOLIDWORKS SolidNetWork License Manager\Docs\flexuser\fnp_LicAdmin.pdf

Nadřazené téma Přehled instalace licencí SolidNetWork
Instalace serveru nástroje SolidNetWork License Manager
Aktivace licencí SolidNetWork
Ruční aktivace pomocí serveru nástroje SolidNetWork License Manager
Instalace licenčních klientů SolidNetWork
Opětovná aktivace licence SolidNetWork
Instalace Manažera licencí triády


Opětovná aktivace licence SolidNetWork

Opětovná aktivace se vztahuje na licenční produkty SolidNetWork poté, co organizace provede upgrade serveru nástroje SolidNetWork License Manager na verzi 2022 nebo novější. I když budou nainstalované produkty pocházet ze starších verzí, licence počínaje verzí 2022 na serveru budou vyžadovat každoroční aktivaci.

Během 30 dnů před datem opětovné aktivace produkty SOLIDWORKS v síti upozorní uživatele, že licencím skončí platnost. Správci si musí být vypršení platnosti vědomi, aby licenci mohli znovu aktivovat včas.

Návod na opětovnou aktivaci licence SolidNetWork:

  1. Spusťte server SolidNetWork License Manager kliknutím na Start > Nástroje SOLIDWORKSverze > Server SolidNetWork License Manager verze.
  2. Na kartě Správa serveru v části Informace o licenci klikněte na možnost Znovu aktivovat.

  3. V poli Sériové číslo vyberte možnost Vše pro všechny licence nebo zadejte číslo licence pro vyhledání konkrétní licence.

    Dialogové okno Znovu aktivovat licence červeně zvýrazní všechna data vypršení licence a reaktivace do 30 dnů. Hvězdičky označují licence, které vyžadují obnovení.

  4. Klikněte na možnost Znovu aktivovat.
Nadřazené téma Přehled instalace licencí SolidNetWork
Instalace serveru nástroje SolidNetWork License Manager
Aktivace licencí SolidNetWork
Ruční aktivace pomocí serveru nástroje SolidNetWork License Manager
Instalace licenčních klientů SolidNetWork
Použití licencí SolidNetWork s firewall
Instalace Manažera licencí triády


Instalace Manažera licencí triády

Manažer licencí triády používá tři počítače pro zajištění dodatečné stability. Pokud není počítač, který spravuje licenční soubor, dostupný převezme jeho operace jeden ze dvou dalších počítačů.

Požadavky pro použití manažera licencí triády:
  • Nainstalujte triády na stabilní počítače, které nevyžadují časté restartování.
  • Všechny tři počítače manažera licencí by měly být na stejné dílčí síti. Nikdy nekonfigurujte triády prostřednictvím pomalého nebo telefonického připojení.
  • Správce systému by měl zjistit, když počítač manažera licencí selže a měl by jej okamžitě restartovat.
    Pokud jsou spuštěny dva počítače manažera licencí, situace je horší než pokud je spuštěn jeden server, protože může dojít k selhání na dvou místech.

Obsah

  • Instalace prvního manažera licencí triády

    Tento postup představuje, jak instalovat nástroj SolidNetWork License Manager na prvním počítači triády.

  • Instalaci manažera licencí triád na následných počítačích

    Podle těchto pokynů instalujete software SolidNetWork License Manager na druhém a třetím počítači triády. Tento postup je téměř stejný jako u instalace softwaru na první počítač, s výjimkou kroků 2(f) a 2(i).

Nadřazené téma Přehled instalace licencí SolidNetWork
Instalace serveru nástroje SolidNetWork License Manager
Aktivace licencí SolidNetWork
Ruční aktivace pomocí serveru nástroje SolidNetWork License Manager
Instalace licenčních klientů SolidNetWork
Použití licencí SolidNetWork s firewall
Opětovná aktivace licence SolidNetWork


Instalace prvního manažera licencí triády

Tento postup představuje, jak instalovat nástroj SolidNetWork License Manager na prvním počítači triády.

  1. Nainstalujte SolidNetWork License Manager na prvním počítači manažera licencí triády za použití Manažera instalací SOLIDWORKS:
    1. Spusťte Manažer instalací SOLIDWORKS podle postupu v tématu Stažení instalačního média.
    2. Jako typ instalace vyberte Instalovat serverové komponenty a klikněte na možnost Nainstalovat SolidNetWork License Manager (distribuované licencování) v tomto počítači.
    3. Na stránce Shrnutí zkontrolujte Umístění instalace aplikace SolidNetWork License Manager, Možnosti stahování a kliknutím na možnost Nainstalovat dokončete proces Manažera instalací SOLIDWORKS.
  2. Za použití SolidNetWork License Manager nakonfigurujte první počítač manažera licencí triády:
    1. Spusťte aplikaci SolidNetWork License Manager. V systému Windows klikněte na Start > Nástroje SOLIDWORKS verze > Server SolidNetWork License Manager verze.

      Protože je to poprvé, kdy spouštíte SolidNetWork License Manager na tomto počítači, zeptá se vás, jestli ho chcete nyní aktivovat.

    2. Klepněte na Ne.

      Zobrazí se záložka Správa serveru aplikace SOLIDWORKS SolidNetWork License Manager.

    3. Na kartě Správa serveru klikněte v části Upřesňující možnosti na položku Možnosti.
    4. V režimu licencí serveru SolidNetWork klepněte na Použít licenční soubora klepněte na OK.
    5. Pod možností Informace o licenci klepněte na Upravit.
      Objeví se průvodce licenčním souborem SolidNetWork.
    6. Pod položkou Typ serveru vyberte Triáda a klepněte na Další.
    7. Na stránce s informacemi o serveru zkontrolujte správný název počítače a číslo portu pro počáteční počítač manažera licencí triády a klikněte na Další.

      Zkontrolujte, že adresa síťové karty odpovídá údajům v licenčním souboru přijatém ze SOLIDWORKS a že číslo portu počítače manažera licencí triády je správné. Adrese síťové karty se také říká adresa MAC (Media Access Control). Potom klepněte na Další.

      Adresu síťové karty zjistíte tak, že otevřete příkazový řádek a zadáte:

      ipconfig /all

      Pokud váš počítač používá bránu firewall, budete zřejmě potřebovat přidat specifikace na této obrazovce. Další informace najdete v části Použití licencí SolidNetWork s firewall.

    8. Na obrazovce Informace o serveru partnerské triády zadejte název počítače a ID hostitele pro druhé dva počítače manažera licencí triády a klikněte na možnost Další.
      Tímto je zajištěno, že pokud není jeden server manažera licencí triády k dispozici, klient může získat licenci z jednoho ze dvou dalších serverů.
    9. Na obrazovce Licence klepněte na Číst pro vyhledání a otevření licenčního souboru SolidNetWork.
      Licence se zobrazí v průvodci Licenčním souborem SolidNetWork. Pro tento počítač používáte licenční soubor, který jste obdrželi od prodejce VAR nebo zákaznické podpory k systému SOLIDWORKS společnosti Dassault Systèmes.
    10. Klepněte na Dokončit.
    11. Kliknutím na možnost OK akci ukončete a pak pomocí možnosti Dokončit aplikaci SolidNetWork License Manager zavřete.
Nadřazené téma Instalace Manažera licencí triády
Instalaci manažera licencí triád na následných počítačích
Použití licencí SolidNetWork s firewall


Instalaci manažera licencí triád na následných počítačích

Podle těchto pokynů instalujete software SolidNetWork License Manager na druhém a třetím počítači triády. Tento postup je téměř stejný jako u instalace softwaru na první počítač, s výjimkou kroků 2(f) a 2(i).

Předpokladem je, že jste již instalovali alespoň jednoho manažera licencí triády na jiném počítači.

  1. Nainstalujte SolidNetWork License Manager na počítači manažera licencí triády za použití Manažera instalací SOLIDWORKS:
    1. Spusťte Manažer instalací SOLIDWORKS podle postupu v tématu Stažení instalačního média.
    2. Jako typ instalace vyberte Instalovat serverové komponenty a klikněte na možnost Nainstalovat SolidNetWork License Manager (distribuované licencování) v tomto počítači.
    3. Na stránce Shrnutí ověřte Umístění instalace aplikace SolidNetWork License Manager, Možnosti stahování a kliknutím na možnost Nainstalovat dokončete proces Manažera instalací SOLIDWORKS.
  2. Za použití SolidNetWork License Manager nakonfigurujte počítač manažera licencí triády:
    1. Spusťte aplikaci SolidNetWork License Manager. V systému Windows klikněte na Start > Nástroje SOLIDWORKS verze > Server SolidNetWork License Manager verze.
      Protože je to poprvé, kdy spouštíte SolidNetWork License Manager na tomto počítači, zeptá se vás, jestli ho chcete nyní aktivovat.
    2. Klepněte na Ne.
      Zobrazí se záložka Správa serveru aplikace SOLIDWORKS SolidNetWork License Manager.
    3. V nabídce Upřesňující možnosti vyberte Možnosti.
      Zobrazí se dialogové okno Upřesňující možnosti.
    4. V režimu licencí serveru SolidNetWork klepněte na Použít licenční soubora klepněte na OK.
      Dialogové okno Upřesňující možnosti se zavře.
    5. Pod možností Informace o licenci klepněte na Upravit.
      Objeví se průvodce licenčním souborem SolidNetWork.
    6. Pod položkou Typ serveru vyberte Triáda a Synchronizujte serverové/licenční informacea pak klepněte na Další.
    7. Na obrazovce Informace o serveru triády zadejte název počítače a ID hostitele. Potom klepněte na Další.
      Tímto je zajištěno, že pokud není jeden server k dispozici, klient může získat licenci z jednoho ze dvou dalších serverů.
    8. Na obrazovce Licence klepněte na Číst pro vyhledání a otevření licenčního souboru SolidNetWork.
      Licence se zobrazí v průvodci Licenčním souborem SolidNetWork.
    Soubor licencí se vygeneruje na prvním počítači manažera licencí triády, který jste nakonfigurovali. Obvykle je soubor s licencemi uložen ve složce \licenses\sw_d.lic. Například: C:\Program Files\SOLIDWORKS SolidNetWork License Manager\licenses\sw_d.lic
    1. Klikněte na Dokončit.
      Objeví se průvodce licenčním souborem SolidNetWork.
    2. Klepnutím na OK ukončíte průvodce Licenčním souborem SolidNetWork a pak klepnutím na Ukončitopustíte SolidNetWork License Manager.

Zopakujte tento postup pro třetí počítač manažera licencí triády.

Nadřazené téma Instalace Manažera licencí triády
Instalace prvního manažera licencí triády


Spuštění SolidNetWork License Manager

Můžete spustit SolidNetWork License Manager z nabídky Windows Start.

V systému Windows klikněte na Start > Nástroje SOLIDWORKS verze > Server SolidNetWork License Manager verze.

Stejnou cestu můžete použít z nabídky Start systému Windows, abyste otevřeli klienta SolidNetWork License Manager verze.

Nadřazené téma Správa licencí za použití SolidNetWork License Manager
Přehled instalace licencí SolidNetWork
Upgrade SolidNetWork License Manager
Přenos licence SolidNetWork
Odstranění licenčních souborů SolidNetWork
Zapůjčení a navrácení licencí SolidNetWork
Řízení přístupu k verzím SOLIDWORKS
Monitorování doby nečinnosti licence
Používání dočasné licence
Použití licencí SolidNetWork a doplňkových modulů
Výběr licence SOLIDWORKS Simulation s licencí SolidNetWork License
Načítání modulů Flow Simulation
Časový limit nečinnosti v softwaru SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation a SOLIDWORKS Plastics
Použití stejného počítače pro manažera licencí a instalace administrativní kopie
Odinstalování SolidNetWork License Manager
Správa licencí FlexNet Publisher


Upgrade SolidNetWork License Manager

V případě významných verzí programu SOLIDWORKS se upgrade manažera licencí skládá z odinstalování starého manažera licencí, instalace nového a z opakované aktivace licence SolidNetWork.

Manažer licence pro novější verzi může distribuovat licence pro klientské počítače, které také zůstávají u předchozí verze.

  1. Spusťte nástroj SolidNetWork License Manager kliknutím na Start > Nástroje SOLIDWORKSverze > Server SolidNetWork License Manager verze.
  2. Na záložce Použití licencí ověřte, že žádný klientský počítač na sítí nemá spuštěný SOLIDWORKS.
  3. Návod na odinstalování starší licence manažera. Podrobnosti najdete v Odinstalování SolidNetWork License Manager.
  4. Nainstalujte nového manažera licencí a znovu aktivujte licenci SolidNetWork na počítači manažera licencí. Podrobnosti najdete v Instalace serveru nástroje SolidNetWork License Manager.

Pokud provádíte upgrade SolidNetWork License Manager v počítači, ve kterém běží také aplikace SOLIDWORKS, proveďte upgrade nástrojů SolidNetWork License Manager a klientů SolidNetWork ještě předtím, než budete do tohoto počítače instalovat jakoukoliv novou aplikaci servisního balíčku SOLIDWORKS.

Pokud provádíte upgrade manažera licencí na počítači, na němž jsou umístěny administrativní kopie, proveďte upgrade manažera licencí než provedete upgrade administrativních kopií. Podrobnosti najdete v Použití stejného počítače pro manažera licencí a instalace administrativní kopie.

Nadřazené téma Správa licencí za použití SolidNetWork License Manager
Přehled instalace licencí SolidNetWork
Spuštění SolidNetWork License Manager
Přenos licence SolidNetWork
Odstranění licenčních souborů SolidNetWork
Zapůjčení a navrácení licencí SolidNetWork
Řízení přístupu k verzím SOLIDWORKS
Monitorování doby nečinnosti licence
Používání dočasné licence
Použití licencí SolidNetWork a doplňkových modulů
Výběr licence SOLIDWORKS Simulation s licencí SolidNetWork License
Načítání modulů Flow Simulation
Časový limit nečinnosti v softwaru SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation a SOLIDWORKS Plastics
Použití stejného počítače pro manažera licencí a instalace administrativní kopie
Odinstalování SolidNetWork License Manager
Správa licencí FlexNet Publisher


Přenos licence SolidNetWork

Při přenosu licence na jiný počítač musíte nejprve deaktivovat licenci a vrátit ji zpět na server licenčních klíčů společnosti Dassault Systèmes SOLIDWORKS Corporation a poté ho znovu aktivovat na jiném počítači.

Pokud se vám nepodaří deaktivovat a vrátit licenci společnosti Dassault Systèmes SOLIDWORKS Corporation (například v důsledku selhání pevného disku), ve většině případech je reaktivace stále úspěšná. Pokud to nelze, obraťte se na svého prodejce produktů.

Přenos licence SolidNetWork:

  1. Spusťte server SolidNetWork License Manager kliknutím na Start > Nástroje SOLIDWORKSverze > Server SolidNetWork License Manager verze.
  2. Na záložce Správa serveru v poli Licenční server klikněte na tlačítko Spustit. Spustí se průvodce Aktivace produktu SOLIDWORKS.
  3. V části Co chcete udělat? vyberte možnost Přesunout licence produktu na nový/upgradovaný počítač a poté klikněte na tlačítko Další.
  4. V seznamu Sériové č.: vyberte sériová čísla nebo klepnutím na tlačítko Vybrat vše aktivujte všechna sériová čísla SOLIDWORKS.
    1. Vyberte možnost Automaticky přes internet (doporučeno).
    2. V části Kontaktní informace (povinné) zadejte e-mailovou adresu.
  5. Zobrazí se okno se zprávou Deaktivace byla úspěšná.
    Deaktivace licence produktu se dokončí.
  6. Klikněte na Dokončit.
Nadřazené téma Správa licencí za použití SolidNetWork License Manager
Přehled instalace licencí SolidNetWork
Spuštění SolidNetWork License Manager
Upgrade SolidNetWork License Manager
Odstranění licenčních souborů SolidNetWork
Zapůjčení a navrácení licencí SolidNetWork
Řízení přístupu k verzím SOLIDWORKS
Monitorování doby nečinnosti licence
Používání dočasné licence
Použití licencí SolidNetWork a doplňkových modulů
Výběr licence SOLIDWORKS Simulation s licencí SolidNetWork License
Načítání modulů Flow Simulation
Časový limit nečinnosti v softwaru SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation a SOLIDWORKS Plastics
Použití stejného počítače pro manažera licencí a instalace administrativní kopie
Odinstalování SolidNetWork License Manager
Správa licencí FlexNet Publisher


Odstranění licenčních souborů SolidNetWork

Před provedením upgradu na nové licence můžete odstranit neplatné licenční soubory SolidNetWork.

  1. Spusťte nástroj SolidNetWork License Manager kliknutím na Start > Nástroje SOLIDWORKSverze > Server SolidNetWork License Manager.
  2. Na kartě Správa serveru v poli Informace o licenci klikněte na možnost Upravit a poté klikněte na možnost Další.
  3. Na stránce Aktivovat/deaktivovat produkt SOLIDWORKS vyberte licenční soubory SolidNetWork s prošlou platností a klikněte na možnost Odebrat.
  4. Kliknutím na možnost Dokončit a OK vše dokončete.
Nadřazené téma Správa licencí za použití SolidNetWork License Manager
Přehled instalace licencí SolidNetWork
Spuštění SolidNetWork License Manager
Upgrade SolidNetWork License Manager
Přenos licence SolidNetWork
Zapůjčení a navrácení licencí SolidNetWork
Řízení přístupu k verzím SOLIDWORKS
Monitorování doby nečinnosti licence
Používání dočasné licence
Použití licencí SolidNetWork a doplňkových modulů
Výběr licence SOLIDWORKS Simulation s licencí SolidNetWork License
Načítání modulů Flow Simulation
Časový limit nečinnosti v softwaru SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation a SOLIDWORKS Plastics
Použití stejného počítače pro manažera licencí a instalace administrativní kopie
Odinstalování SolidNetWork License Manager
Správa licencí FlexNet Publisher


Zapůjčení a navrácení licencí SolidNetWork

Můžete si půjčit licenci SolidNetWork, aby jste mohli používat tento program ze vzdáleného umístění. Protože je licence je odstraněna ze souhrnu dostupných licencí, zapůjčenou licenci je nutno vrátit, aby byla opět k dispozici.

Vypůjčené licence jsou platné pouze pro aktuálního uživatele a počítač, na kterém byly zapůjčeny. Vypůjčené licence nelze přesouvat.

Daná licence je zapůjčena na vymezené časové období až do 30 dnů (nebo na jiný počet dnů definovaný správcem systému) a odebrána z fondu dostupných licencí.

Zapůjčení a vrácení licence nefunguje, pokud se používá licence SOLIDWORKS.

Správci systému mohou upravit půjčování za účelem:
  • Definovat uživatele nebo skupiny uživatelů, kteří si mohou půjčovat licence.
  • Nastavit počet licencí, které nelze půjčovat.

Bližší údaje najdete v dokumentu instalační_adresář_SolidNetWork_License_Manager\Docs\flexuser\licensingenduserguide.pdf.

Obsah

  • Zapůjčení licencí SolidNetWork

  • Vrácení půjčené licence SolidNetWork

    Protože je licence SolidNetWork odstraněna ze souhrnu dostupných licencí, zapůjčenou licenci je nutno vrátit, aby byla opět k dispozici.

Nadřazené téma Správa licencí za použití SolidNetWork License Manager
Přehled instalace licencí SolidNetWork
Spuštění SolidNetWork License Manager
Upgrade SolidNetWork License Manager
Přenos licence SolidNetWork
Odstranění licenčních souborů SolidNetWork
Řízení přístupu k verzím SOLIDWORKS
Monitorování doby nečinnosti licence
Používání dočasné licence
Použití licencí SolidNetWork a doplňkových modulů
Výběr licence SOLIDWORKS Simulation s licencí SolidNetWork License
Načítání modulů Flow Simulation
Časový limit nečinnosti v softwaru SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation a SOLIDWORKS Plastics
Použití stejného počítače pro manažera licencí a instalace administrativní kopie
Odinstalování SolidNetWork License Manager
Správa licencí FlexNet Publisher


Zapůjčení licencí SolidNetWork

Pokaždé spusťte SolidNetWork License Manager z nabídky Windows Start. Připojení k SolidNetWork License Manager je nutné při vyzvednutí licence, ale k používání není vyžadováno.

Tyto kroky se mohou lišit v závislosti na konfiguraci systému. Další pokyny a možnosti najdete v dokumentaci k systému Microsoft Windows.
  1. Spusťte nástroj SolidNetWork License Manager na klientském počítači kliknutím na Start > Nástroje SOLIDWORKS verze > Klient SolidNetWork License Manager verze.
  2. Na záložce Půjčování licence:
    1. Zadejte datum v poli Vypůjčit do.
    2. V části Dostupné licence k produktům vyberte produkty, které si chcete půjčit, a klikněte na možnost Vypůjčit.
    3. V dialogovém okně Vybrat produkt vyberte produkt ze seznamu a potvrďte kliknutím na tlačítko OK.
    4. V dolní části dialogového okna klepněte na Obnovit.
      Sloupec Vypůjčit do označuje datum, do kterého se licence musí vrátit.
  3. Klepněte na tlačítko OK.

Na kartě Použití licencí můžete také zobrazit údaje Licencí celkem, Volné licence a Licence používá a data vrácení v části Vypůjčené do.

Vyberte možnost Použít pouze vypůjčené licence (rychlejší spuštění) v případě, že pracujete vzdáleně a aplikace SOLIDWORKS se otevírají pomalu.

Tato možnost blokuje dotazy na licenční servery, které mohou být v některých prostředích pomalé. Aplikace mohou začít rychleji vynecháním dotazů, ale budou používat pouze licence, které jste si vypůjčili.

Restartujte aplikace, aby se tato možnost projevila.

Nadřazené téma Zapůjčení a navrácení licencí SolidNetWork
Vrácení půjčené licence SolidNetWork


Vrácení půjčené licence SolidNetWork

Protože je licence SolidNetWork odstraněna ze souhrnu dostupných licencí, zapůjčenou licenci je nutno vrátit, aby byla opět k dispozici.

  1. Spusťte - nástroj SolidNetWork License Manager na klientském počítači kliknutím na Start > Nástroje SOLIDWORKS verze > Klient SolidNetWork License Manager verze.
  2. Na záložce Půjčování licence:
    1. V části Vypůjčené licence na produkt vyberte produkty, které chcete vrátit, a klikněte na Vrátit.
    2. Klepněte na Obnovit. Prázdný sloupec Vypůjčené do označuje, že byly licence vráceny.
  3. Klepněte na tlačítko OK.

Na kartě Použití licencí můžete také zobrazit počet licencí celkem.

Vypůjčené licence nemusí být po vypršení lhůty vráceny zpět. O půlnoci ve dne uplynutí půjčení licence SolidNetWork licenční soubor na vzdáleném počítači již neumožní spuštění programu SolidWorks a licence je automaticky vrácena do fondu volných licencí v SolidNetWork License Manager.
Nadřazené téma Zapůjčení a navrácení licencí SolidNetWork
Zapůjčení licencí SolidNetWork


Řízení přístupu k verzím SOLIDWORKS

Máte možnost zabránit uživatelům v přístupu k určitým verzím SOLIDWORKS v prostředí SolidNetWork. Tato funkce umožňuje spravovat verze SOLIDWORKS používané různými osobami, projekty a organizačními jednotkami.

Správa přístupu k verzím SOLIDWORKS pomocí souboru možností FlexNet se provádí takto:

  1. V manažeru licencí SolidNetWork vytvořte textový soubor:
    instalační_složka_SolidNetWork_License_Manageru\Licenses\sw_d.opt
  2. Chcete-li spravovat přístup k určité verzi softwaru SOLIDWORKS v licenčním souboru, přidejte za výraz SOLIDWORKS následující syntax:
    :SWVERSION=xx kde xx je verze produktu SOLIDWORKS, kterou chcete spravovat.
  3. Chcete-li spravovat více verzí softwaru SOLIDWORKS, přidejte řádek pro každou verzi.

    Nejsou podporovány všechny možnosti FlexNet. Podporované možnosti filtrů verzí jsou následující:

    INCLUDE | Danou verzi může spouštět pouze tento uživatel nebo skupina. Ostatní uživatelé nebudou moci tuto verzi spustit.
    INCLUDE_BORROW | Danou verzi si může vypůjčit pouze tento uživatel nebo skupina. Ostatní uživatelé si nebudou moci tuto verzi vypůjčit.
    EXCLUDE | Zakáže uvedenému uživateli nebo skupině spustit danou verzi SOLIDWORKS. Výraz EXCLUDE má přednost před výrazem INCLUDE.
    EXCLUDE_BORROW | Zakáže uvedenému uživateli nebo skupině vypůjčit si danou verzi SOLIDWORKS. Výraz EXCLUDE má přednost před výrazem INCLUDE.
    Příklady:
    1 | SWVERSION=32.0 označuje SOLIDWORKS 2025
    SWVERSION=31.0 označuje SOLIDWORKS 2024
    2 | INCLUDE solidworks:SWVERSION=32.0 USER jane
    INCLUDE_BORROW solidworks:SWVERSION=32.0 USER jane
    Tyto řádky v souboru možností povolují spuštění softwaru SOLIDWORKS 2025, pouze uživateli jane. Ostatní uživatelé nemohou software SOLIDWORKS 2025 spustit ani si jej vypůjčit; mohou ale spouštět a vypůjčovat si ostatní verze SOLIDWORKS. Uživatel jane dále může spouštět a vypůjčovat si i ostatní verze SOLIDWORKS.
    3 | GROUP chicago USER john robert eva
    EXCLUDE solidworks:SWVERSION=32.0 GROUP chicago
    EXCLUDE solidworks:SWVERSION=31.0 GROUP chicago
    EXCLUDE solidworks USER don
    Na těchto řádcích je definována skupina (GROUP) uživatelů s názvem chicago, jejíž členové nemají přístup k verzím SOLIDWORKS 2025 a SOLIDWORKS 2024. Mohou ale spustit libovolnou jinou verzi softwaru SOLIDWORKS. Uživatel don nemůže spustit žádnou verzi softwaru SOLIDWORKS.
    4 | EXCLUDE swinspection_std:SWVERSION=32.0 HOST machine1
    Tento řádek brání komukoli na počítači machine1 ve spuštění softwaru SOLIDWORKS Inspection 2025.

    Více informací o softwaru FlexNet naleznete v Průvodci správou licencí k softwaru FLEXnet Publisher v instalačním adresáři SolidNetWork License Manager (\Docs\flexuser\fnp_LicAdmin.pdf).

Nadřazené téma Správa licencí za použití SolidNetWork License Manager
Přehled instalace licencí SolidNetWork
Spuštění SolidNetWork License Manager
Upgrade SolidNetWork License Manager
Přenos licence SolidNetWork
Odstranění licenčních souborů SolidNetWork
Zapůjčení a navrácení licencí SolidNetWork
Monitorování doby nečinnosti licence
Používání dočasné licence
Použití licencí SolidNetWork a doplňkových modulů
Výběr licence SOLIDWORKS Simulation s licencí SolidNetWork License
Načítání modulů Flow Simulation
Časový limit nečinnosti v softwaru SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation a SOLIDWORKS Plastics
Použití stejného počítače pro manažera licencí a instalace administrativní kopie
Odinstalování SolidNetWork License Manager
Správa licencí FlexNet Publisher


Monitorování doby nečinnosti licence

SOLIDWORKS může registrovat dobu nečinnosti SolidNetWork License Manager na serveru, aby byly licence, které nejsou používány po určitou dobu, vráceny do fondu volných licencí.

  1. V SolidNetWork License Manager vytvořte textový soubor:
    instalační_složka_SolidNetWork_License_Manageru\Licenses\sw_d.opt
  2. Do souboru vložte následující řádek:
    TIMEOUTALL seconds

    kde seconds je číslo větší nebo rovno 900 (15 minut), což je minimální povolená doba.

Nadřazené téma Správa licencí za použití SolidNetWork License Manager
Přehled instalace licencí SolidNetWork
Spuštění SolidNetWork License Manager
Upgrade SolidNetWork License Manager
Přenos licence SolidNetWork
Odstranění licenčních souborů SolidNetWork
Zapůjčení a navrácení licencí SolidNetWork
Řízení přístupu k verzím SOLIDWORKS
Používání dočasné licence
Použití licencí SolidNetWork a doplňkových modulů
Výběr licence SOLIDWORKS Simulation s licencí SolidNetWork License
Načítání modulů Flow Simulation
Časový limit nečinnosti v softwaru SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation a SOLIDWORKS Plastics
Použití stejného počítače pro manažera licencí a instalace administrativní kopie
Odinstalování SolidNetWork License Manager
Správa licencí FlexNet Publisher


Používání dočasné licence

Můžete použít dočasnou licenci „any“, když není k dispozici licence SolidNetWork.

Ve výchozím nastavení může nástroj SolidNetWork License Manager aktivovat pouze jeden server najednou. Chcete-li pracovat v testovacím prostředí, můžete získat dočasný licenční soubor prostřednictvím technické podpory a načíst dočasnou licenci „any“ do nástroje SolidNetWork License Manager na jiném serveru. Při práci s offline serverem můžete pro načtení licence osvobozené od aktivace použít stejné pokyny.

Instalováním licenčního souboru „any“ souhlasíte s tím, že licenci SolidNetWork použijete hned, jakmile ji obdržíte od společnosti Dassault Systèmes SOLIDWORKS Corporation. Musíte stále dodržovat licenční podmínky.

Návod na použití dočasné licence „any“:

  1. Spusťte nástroj SolidNetWork License Manager kliknutím na Start > Nástroje SOLIDWORKSverze > Server SolidNetWork License Manager verze.
  2. Pokud vás software vyzve k aktivaci, klikněte na Ne.
  3. Na kartě Správa serveru klikněte na Upřesňující možnosti > Možnosti.
  4. V režimu licencí serveru SolidNetWork klikněte na Použít licenční soubora na OK.
  5. Na záložce Správa serveru v poli Licenční server klikněte na tlačítko Spustit.
    Objeví se průvodce licenčním souborem SolidNetWork.
  6. Pod položkou Typ serveru vyberte Samostatný a klepněte na Další.
  7. Vyberte možnost ID hardwarového klíče a jako informace o serveru zadejte Jakýkoli nebo Adresa NIC. Potom klepněte na Další.

    Klikněte na Storno, když uvidíte tuto zprávu: Nelze načíst ID hardwarového klíče.

    Pokud vás počítač používá bránu firewall, budete zřejmě muset provést dodatečné úpravy na této obrazovce. Další informace viz Použití licencí SolidNetWork s firewall.
  8. V nabídce Licence klikněte na Číst, čímž si přečtete licenční soubor.
  9. V dialogovém okně Číst přejděte k souboru SNL_ANY.txt nebo SNL_(NIC Card Number).txt poskytnutému technickou podporou a klikněte na možnost Otevřít. Potom klikněte na OK.
    Průvodce licenčním souborem SolidNetWork obsahuje seznam licencí z textového souboru.
    Kliknutím na Odebrat odstraníte ze seznamu záznamy dočasných licencí, jejichž platnost vypršela.
  10. Kliknutím na Dokončit ukončíte Průvodce licenčním souborem SolidNetWork.
  11. Aktivace dočasné licence „any“:
    1. Na kartě Správa serveru klikněte na Upřesňující možnosti > Možnosti.
    2. V režimu licencí serveru SolidNetWork zvolte možnost Použít licenční soubor a klikněte na možnost OK.
    3. Na kartě Správa serveru klikněte na možnost Změnit > Aktivovat/deaktivovat licence produktu.
    4. Vyberte Sériové číslo, zadejte Kontaktní údaje a vyberte způsob aktivace. Pokud zvolíte ruční aktivaci, postupujte podle pokynů.
    5. Kliknutím na možnost Dokončit aktivaci potvrďte.
Nadřazené téma Správa licencí za použití SolidNetWork License Manager
Přehled instalace licencí SolidNetWork
Spuštění SolidNetWork License Manager
Upgrade SolidNetWork License Manager
Přenos licence SolidNetWork
Odstranění licenčních souborů SolidNetWork
Zapůjčení a navrácení licencí SolidNetWork
Řízení přístupu k verzím SOLIDWORKS
Monitorování doby nečinnosti licence
Použití licencí SolidNetWork a doplňkových modulů
Výběr licence SOLIDWORKS Simulation s licencí SolidNetWork License
Načítání modulů Flow Simulation
Časový limit nečinnosti v softwaru SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation a SOLIDWORKS Plastics
Použití stejného počítače pro manažera licencí a instalace administrativní kopie
Odinstalování SolidNetWork License Manager
Správa licencí FlexNet Publisher


Použití licencí SolidNetWork a doplňkových modulů

K rozdělení licencí pro doplňkové moduly jádra SOLIDWORKS můžete použít manažer licencí SolidNetWork License Manager.

  • Není vyžadován stejný počet licencí programu SOLIDWORKS a licencí doplňkových modulů.
  • Chcete-li vyzvednout licenci pro doplňkový modul, musíte nejprve vyzvednout licenci pro program SOLIDWORKS.
  • Pokud si vypůjčíte licenci doplňkového modulu, musíte si vypůjčit obě licence: licenci softwaru SOLIDWORKS a licenci produktu SOLIDWORKS, ve které je tento doplňkový modul obsažen. Jako výchozí bude zapůjčena licence SOLIDWORKS Standard. Pro povolení doplňkových modulů je potřeba zapůjčit licenci produktu SOLIDWORKS Professional, SOLIDWORKS Premium nebo SOLIDWORKS Ultimate.
  • Návod na uvolnění licence doplňkového modulu:
    • V softwaru SOLIDWORKS klikněte na nabídku Nástroje > Doplňkové moduly a zrušte výběr doplňkového modulu.
    • Ukončete aplikaci SOLIDWORKS.
Nadřazené téma Správa licencí za použití SolidNetWork License Manager
Přehled instalace licencí SolidNetWork
Spuštění SolidNetWork License Manager
Upgrade SolidNetWork License Manager
Přenos licence SolidNetWork
Odstranění licenčních souborů SolidNetWork
Zapůjčení a navrácení licencí SolidNetWork
Řízení přístupu k verzím SOLIDWORKS
Monitorování doby nečinnosti licence
Používání dočasné licence
Výběr licence SOLIDWORKS Simulation s licencí SolidNetWork License
Načítání modulů Flow Simulation
Časový limit nečinnosti v softwaru SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation a SOLIDWORKS Plastics
Použití stejného počítače pro manažera licencí a instalace administrativní kopie
Odinstalování SolidNetWork License Manager
Správa licencí FlexNet Publisher


Výběr licence SOLIDWORKS Simulation s licencí SolidNetWork License

Uživatelé licence SolidNetWork mohou určit, kterou z licencí SOLIDWORKS® Simulation v jejich fondu licencí použít při spuštění doplňkového modulu SOLIDWORKS Simulation. Také mohou upgradovat licenci SOLIDWORKS Simulation bez uvolnění doplňkového modulu v případě, že potřebují vyšší typ licence pro pokročilé studie.

  1. Postup použití specifické licence SOLIDWORKS Simulation:
    1. V SOLIDWORKS klikněte na Nástroje > Doplňkové moduly a v dialogu Doplňkový modul vyberte SOLIDWORKS Simulation.
    2. V SOLIDWORKS Simulation (CommandManager) si kliknutím na šipku Dolů [image] zobrazíte seznam licencí na serveru, které podporují aplikaci Simulation.

    3. Vyberte odpovídající licenci SOLIDWORKS Simulation.
  2. Chcete-li zobrazit nebo změnit aktuální licenci SOLIDWORKS Simulation, klikněte na šipku Dolů [image] v aplikaci SOLIDWORKS Simulation (CommandManager).

    U licence, která se používá, se zobrazí symbol zaškrtnutí. Pokud je k dispozici více typů rozšířených licencí, můžete upgradovat.
    Licenci SOLIDWORKS Simulation nelze downgradovat. Zakažte doplňkový modul SOLIDWORKS Simulation a znovu přidejte licenci na nižší úrovni.
  3. Volitelné: Doplňkový modul zakážete tak, že kliknete na SOLIDWORKS Simulation (CommandManager) nebo příslušnou možnost zrušíte v nabídce Nástroje > Doplňkové moduly.
V následujících případech se stále používá pořadí licencí:
  • Při spuštění aplikace SOLIDWORKS Simulation.
  • Když se přidá SOLIDWORKS Simulation v nabídce Nástroje > Doplňkové moduly.
  • Pokud kliknete na SOLIDWORKS Simulation bez určení licence z rozevírací nabídky.
Nadřazené téma Správa licencí za použití SolidNetWork License Manager
Přehled instalace licencí SolidNetWork
Spuštění SolidNetWork License Manager
Upgrade SolidNetWork License Manager
Přenos licence SolidNetWork
Odstranění licenčních souborů SolidNetWork
Zapůjčení a navrácení licencí SolidNetWork
Řízení přístupu k verzím SOLIDWORKS
Monitorování doby nečinnosti licence
Používání dočasné licence
Použití licencí SolidNetWork a doplňkových modulů
Načítání modulů Flow Simulation
Časový limit nečinnosti v softwaru SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation a SOLIDWORKS Plastics
Použití stejného počítače pro manažera licencí a instalace administrativní kopie
Odinstalování SolidNetWork License Manager
Správa licencí FlexNet Publisher


Načítání modulů Flow Simulation

Jako licenční zákazník SolidNetWork můžete ovládat způsob načítání doplňkových modulů HVAC a Electronics Cooling pro Flow Simulation pomocí dvou metod.

První metoda umožňuje určit výchozí chování doplňkových modulů při načítání aplikace Flow Simulation. Možnost Automaticky načíst doplňkové moduly Flow Simulation, pokud jsou k dispozici je na záložce Klient SolidNetWork License Manager > Pořadí licence. Tuto možnost vypněte, pokud nepotřebujete doplňkové moduly Flow Simulation. Doplňkové moduly HVAC a Electronics Cooling se nenačítají, když je aplikace Flow Simulation přidána se stávajícími metodami.

Druhá metoda umožňuje potlačit výchozí chování a zahrnout doplňkové moduly HVAC a Electronics Cooling při načtení aplikace Flow Simulation. Klikněte na šipku dolů [image] v části SOLIDWORKS Flow Simulation (panel nástrojů Doplňkové moduly SOLIDWORKS®) nebo SOLIDWORKS Flow Simulation s jedním či oběma doplňkovými moduly, které chcete načíst.

Bez těchto metod jsou licence pro doplňkové moduly spotřebovány bez ohledu na to, zda je potřebujete či ne, a mohou být odmítnuty jiným uživatelům ve vaší síti.

Nadřazené téma Správa licencí za použití SolidNetWork License Manager
Přehled instalace licencí SolidNetWork
Spuštění SolidNetWork License Manager
Upgrade SolidNetWork License Manager
Přenos licence SolidNetWork
Odstranění licenčních souborů SolidNetWork
Zapůjčení a navrácení licencí SolidNetWork
Řízení přístupu k verzím SOLIDWORKS
Monitorování doby nečinnosti licence
Používání dočasné licence
Použití licencí SolidNetWork a doplňkových modulů
Výběr licence SOLIDWORKS Simulation s licencí SolidNetWork License
Časový limit nečinnosti v softwaru SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation a SOLIDWORKS Plastics
Použití stejného počítače pro manažera licencí a instalace administrativní kopie
Odinstalování SolidNetWork License Manager
Správa licencí FlexNet Publisher


Časový limit nečinnosti v softwaru SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation a SOLIDWORKS Plastics

Když spustíte studii v softwaru SOLIDWORKS Simulation, Plastics nebo Flow Simulation, zůstanou síťové licence aktivní a nejsou časově omezené. Software SOLIDWORKS zachová licence v platnosti během procesu výpočtu, který je považován za aktivitu.

Doba nečinnosti nastavená v možnosti ČASOVÝ LIMIT se projeví až po dokončení výpočtu studie.

Nadřazené téma Správa licencí za použití SolidNetWork License Manager
Přehled instalace licencí SolidNetWork
Spuštění SolidNetWork License Manager
Upgrade SolidNetWork License Manager
Přenos licence SolidNetWork
Odstranění licenčních souborů SolidNetWork
Zapůjčení a navrácení licencí SolidNetWork
Řízení přístupu k verzím SOLIDWORKS
Monitorování doby nečinnosti licence
Používání dočasné licence
Použití licencí SolidNetWork a doplňkových modulů
Výběr licence SOLIDWORKS Simulation s licencí SolidNetWork License
Načítání modulů Flow Simulation
Použití stejného počítače pro manažera licencí a instalace administrativní kopie
Odinstalování SolidNetWork License Manager
Správa licencí FlexNet Publisher


Použití stejného počítače pro manažera licencí a instalace administrativní kopie

Jeden počítač v síti můžete nakonfigurovat tak, aby fungoval jako manažer licencí, který distribuuje licence SolidNetWork, a zároveň jako umístění kopie, z níž si uživatelé mohou instalovat aplikaci SOLIDWORKS.

Klientské počítače obdrží licence od manažera licencí a pak instalují SOLIDWORKS z téhož počítače.

Tato konfigurace vyžaduje, aby manažer licencí a administrativní kopie byly na stejném počítači. Nainstalujte nejprve manažera licencí a pak vytvořte a distribuujte administrativní kopii.
Podrobnosti najdete na odkazu:
  • Instalace serveru nástroje SolidNetWork License Manager
  • Zavádění více klientů
Nadřazené téma Správa licencí za použití SolidNetWork License Manager
Přehled instalace licencí SolidNetWork
Spuštění SolidNetWork License Manager
Upgrade SolidNetWork License Manager
Přenos licence SolidNetWork
Odstranění licenčních souborů SolidNetWork
Zapůjčení a navrácení licencí SolidNetWork
Řízení přístupu k verzím SOLIDWORKS
Monitorování doby nečinnosti licence
Používání dočasné licence
Použití licencí SolidNetWork a doplňkových modulů
Výběr licence SOLIDWORKS Simulation s licencí SolidNetWork License
Načítání modulů Flow Simulation
Časový limit nečinnosti v softwaru SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation a SOLIDWORKS Plastics
Odinstalování SolidNetWork License Manager
Správa licencí FlexNet Publisher


Odinstalování SolidNetWork License Manager

Pokud provádíte upgrade SolidNetWork License Manager, musíte odinstalovat starého manažera licencí před instalací nového.

  1. Spusťte nástroj SolidNetWork License Manager kliknutím na Start > Nástroje SOLIDWORKS Verze > Server SolidNetWork License Manager verze.
  2. Ověřte, zda žádný z klientských počítačů na síti nemá spuštěnou aplikaci SOLIDWORKS.
    Záložka Použití licencí zobrazí klienty se spuštěným SOLIDWORKS.
  3. Chcete-li přenést licenci SolidNetWork na jiný počítač, nejprve ji deaktivujte a pak odstraňte nástroj SolidNetWork License Manager z původního počítače.
    Informace o přenosu licencí SolidNetWork naleznete v části Přenos licence SolidNetWork.
  4. Na záložce Správa serveru v poli Licenční server klepněte na Zastavit.
  5. Klepnutím na OK ukončíte Manažera licencí.
  6. V systému Windows jděte do nabídky Ovládací panely > Programy a funkce.
  7. Vyberte položku SOLIDWORKS SolidNetWork License Manager, klikněte na tlačítko Odstranit a potvrďte odinstalování.
  8. V Průzkumníku souborů odstraňte složku SOLIDWORKS SolidNetWork License Manager.
    (Tato složka je obvykle umístěna pod Program Files (x86) v instalačním adresáři SOLIDWORKS).

Nyní můžete instalovat novou verzi manažera licencí. Podrobné informace naleznete v tématu Instalace serveru nástroje SolidNetWork License Manager.

Pokud má počítač s SolidNetWork License Manager připojený hardwarový klíč, odstraňte jej před instalací nové verze SolidNetWork License Manager.
Nadřazené téma Správa licencí za použití SolidNetWork License Manager
Přehled instalace licencí SolidNetWork
Spuštění SolidNetWork License Manager
Upgrade SolidNetWork License Manager
Přenos licence SolidNetWork
Odstranění licenčních souborů SolidNetWork
Zapůjčení a navrácení licencí SolidNetWork
Řízení přístupu k verzím SOLIDWORKS
Monitorování doby nečinnosti licence
Používání dočasné licence
Použití licencí SolidNetWork a doplňkových modulů
Výběr licence SOLIDWORKS Simulation s licencí SolidNetWork License
Načítání modulů Flow Simulation
Časový limit nečinnosti v softwaru SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation a SOLIDWORKS Plastics
Použití stejného počítače pro manažera licencí a instalace administrativní kopie
Správa licencí FlexNet Publisher
Instalace serveru nástroje SolidNetWork License Manager


Správa licencí FlexNet Publisher

Správa licencí SolidNetWork je založena na správě licencí FlexNet Publisher®.

Více informací ohledně správy licencí FlexNet Publisher viz Průvodce správou licencí FlexNet Publisher v instalačním adresáři správce SolidNetWork License Manager: C:\Program Files\SOLIDWORKS SolidNetWork License Manager\Docs\flexuser\fnp_LicAdmin.pdf

Nejnovější informace o správě licencí FlexNet Publisher obdržíte u společnosti Flexera® Software.

Verzi FlexNet můžete zkontrolovat v protokolu na licenčním serveru. Otevřete server SolidNetwork License Manager a klikněte na nabídku Správa serveru > Zobrazit protokol. Na začátku protokolu je uvedena verze licence FlexNet v závorkách.

Nadřazené téma Správa licencí za použití SolidNetWork License Manager
Přehled instalace licencí SolidNetWork
Spuštění SolidNetWork License Manager
Upgrade SolidNetWork License Manager
Přenos licence SolidNetWork
Odstranění licenčních souborů SolidNetWork
Zapůjčení a navrácení licencí SolidNetWork
Řízení přístupu k verzím SOLIDWORKS
Monitorování doby nečinnosti licence
Používání dočasné licence
Použití licencí SolidNetWork a doplňkových modulů
Výběr licence SOLIDWORKS Simulation s licencí SolidNetWork License
Načítání modulů Flow Simulation
Časový limit nečinnosti v softwaru SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation a SOLIDWORKS Plastics
Použití stejného počítače pro manažera licencí a instalace administrativní kopie
Odinstalování SolidNetWork License Manager


Řešení potíží

Zkonzultujte tato témata, která vám pomohou při odstranění potíží při instalaci.

Obsah

  • Využití síťových licencí

  • Soubory protokolu Manažera instalací SOLIDWORKS

    Soubory protokolu Manažera instalací SOLIDWORKS jsou k dispozici jako pomoc při odstranění instalačních problémů.

  • Složka pro stažení Manažera instalací SOLIDWORKS

    Manažer instalací SOLIDWORKS stáhne potřebné instalační soubory do složky, kterou určíte. Toto téma obsahuje odpovědi na časté otázky o této složce pro stažení.

  • Odstranění potíží s licencemi SolidNetWork

    Pokud se instalace aplikace SolidNetWork License Manager nezdaří, zkontrolujte následující možná vysvětlení.

  • Řešení potíží s upgrady

    Pokud se setkáte s problémy během provádění upgrade nové verze SOLIDWORKS, zkontrolujte tato možná vysvětlení.

  • Ověřování grafických karet při instalaci nebo upgradu

    Při dokončování instalace nebo upgradu softwaru SOLIDWORKS na vašem počítači spusťte nástroj SOLIDWORKS Rx, abyste se ujistili, že je počítač vybaven podporovanou grafickou kartou s ovladačem.


Využití síťových licencí

Toto dialogové okno se otevře v případě, že server nemá další licence na určitý produkt.

Klepnutím na šipku v poli Produkt zobrazíte všechny produktové volby. K volbám patří produkty SOLIDWORKS a všechny doplňkové moduly, které lze zakoupit.

Celkový počet licencí obsahuje celkový počet licencí, které jste zakoupili.

Volné licence obsahuje počet licencí, které nejsou v současné době používány.

Pole Licence používá poskytuje informace o každé osobě, která právě používá licenci.

Nadřazené téma Řešení potíží
Soubory protokolu Manažera instalací SOLIDWORKS
Složka pro stažení Manažera instalací SOLIDWORKS
Odstranění potíží s licencemi SolidNetWork
Řešení potíží s upgrady
Ověřování grafických karet při instalaci nebo upgradu


Soubory protokolu Manažera instalací SOLIDWORKS

Soubory protokolu Manažera instalací SOLIDWORKS jsou k dispozici jako pomoc při odstranění instalačních problémů.

Tyto soubory protokolu jsou umístěné společně se soubory protokolu jiných aplikací SOLIDWORKS.

  • C:\Users\username\AppData\Roaming\SOLIDWORKS\Installation Logs\installed_version

Pokud spustíte Manažera instalací ze systémového účtu, nacházejí se protokoly v této složce:
  • C:\Windows\SysWOW64\config\systemprofile\AppData\Roaming\SOLIDWORKS\Installation Logs\installed_version
Pro zobrazení adresářů souborů protokolu budete možná muset nakonfigurovat možnosti složky Windows na Zobrazit skryté soubory a složky.

Pokud jsou data aplikací umístěna na jiné jednotce než C:, přizpůsobte podle toho trasu.

Tento adresář obsahuje soubor SummaryIMLog_nnnnn_nnnnn_nnnn_nnnnn.txt, všeobecný protokol o průběhu procesů Manažera instalací SOLIDWORKS.

Podadresář Jiné protokoly obsahuje soubory protokolů s podrobnějšími informacemi.

Nadřazené téma Řešení potíží
Využití síťových licencí
Složka pro stažení Manažera instalací SOLIDWORKS
Odstranění potíží s licencemi SolidNetWork
Řešení potíží s upgrady
Ověřování grafických karet při instalaci nebo upgradu


Složka pro stažení Manažera instalací SOLIDWORKS

Manažer instalací SOLIDWORKS stáhne potřebné instalační soubory do složky, kterou určíte. Toto téma obsahuje odpovědi na časté otázky o této složce pro stažení.

Otázka Odpověď
Jakým způsobem nainstalovat soubory v této složce?

Spuštěním souboru setup.exe. Pokud zvolíte instalaci položek, které ještě nebyly staženy, budete muset stáhnout některé soubory.

Neinstalujte pomocí msiexec (viz níže).
Je možné z této složky ručně nainstalovat soubory MSI pomocí msiexec nebo jiné aplikace?

Ne. Manažer instalací nestahuje určité soubory, které jsou vyžadovány při spuštění souboru msiexec.
Je možné zadat stejnou složku pro stažení pro každou nainstalovanou verzi?

Složky stažení jsou specifické podle verze. Manažer instalací SOLIDWORKS automaticky vytvoří uvnitř zadané složky podsložku specifickou pro tuto verzi.

Některé produkty byly ručně staženy z webové stránky Dassault Systemes SOLIDWORKS Corporation. Může je Manažer instalací také nainstalovat?
Manažer instalací SOLIDWORKS může použít soubory stažené ručně. Ovšem lepší je spustit Manažera instalací SOLIDWORKS a vybrat možnost pro stažení souborů. Manažer instalací SOLIDWORKS ukáže na základě toho, co instalujete, který soubor potřebujete, a poskytne odkazy pro stažení každého souboru. Tuto možnost můžete použít, když stránka pro stahování nefunguje (zřejmě z důvodu stahování i přes omezení uplatňovaná proxy serverem).
Pokud se dialogové okno zeptá, jestli chcete uložit nebo provést soubory během spuštění nebo instalace, vždy vyberte Uložit.
Mohou být stažené soubory sdílené s jinými uživateli?

Ano. Pokud chcete soubory sdílet, stáhněte je na místo v síti. Každý klient může spustit Manažera instalací SOLIDWORKS z tohoto sdíleného umístění v síti.

Nebude již potřeba stáhnout další soubory, pokud uživatel nevybere k instalaci položky, které nebyly během počátečního stažení vybrány nebo pokud počítač, který to využívá k instalaci, má jinou sadu předpokladů než počítač, na který soubory stahujete.

Pokud provádíte pouze stažení za jiné, ale ne instalaci, vyberte při instalaci možnost Pouze stáhnout. Tato možnost vám umožní vybrat produkty nezávisle na tom, co je nainstalováno na vašem počítači. Tuto možnost však nelze použít pro instalaci oprav nebo pro vytvoření administrativních kopií.
Jak je možné zjistit, že jsou dostupné nové verze produktů SOLIDWORKS?
V těchto případech budete informování o nové verzi:
  • Pokud spustíte příkaz Zjistit aktualizace (Start > Manažer instalací SOLIDWORKS > Zjistit aktualizace)
  • Pokud jste povolili SOLIDWORKS Nástroj pro stahování na pozadí
  • Pokud vyberete nainstalovanou verzi programu SOLIDWORKS ve Windows v části Přidat/Odstranit programy a klepnete na Změnit
  • Pokud ze složky pro stažení spustíte starší verzi Manažera instalací (sldIM.exe).
V těchto případech můžete stáhnout novější verzi. Manažer instalací SOLIDWORKS stáhne a spustí novou verzi manažera, ale ne žádné instalační soubory. Po spuštění nové verze Manažera instalací SOLIDWORKS můžete vybrat ze sady instalačních operací. Manažer instalací SOLIDWORKS určuje, které instalační soubory jsou potřebné (a soubory, které ještě nebyly staženy), a nabídne je ke stažení.
Proč Manažer instalací SOLIDWORKS neumožňuje výběr jiné aktualizace service pack produktu k instalaci?

Každá verze Manažera instalací SOLIDWORKS je určena k instalaci pouze konkrétní verze produktů SOLIDWORKS. Pokud chcete instalovat jinou aktualizaci service pack, musíte spustit Manažera instalací SOLIDWORKS odpovídající verze. Potřebujete-li vyhledat poslední dostupnou verzi, přečtěte si předchozí odpověď.
Proč Manažer instalací SOLIDWORKS nemůže stáhnout soubory?

Pokud omezení proxy serveru zabraňují programům ve stahování souborů, Manažer instalací SOLIDWORKS nemůže automaticky stahovat soubory.

Soubory můžete stáhnout ručně a pak je instalovat pomocí Manažera instalací SOLIDWORKS. Zvolte v Manažeru instalací SOLIDWORKS možnost pro stažení individuálních souborů (například ruční stažení na stránce Možnosti instalace). Podle vašeho výběru produktu a požadavků systému se objeví webová stránka ve zvláštním okně a obsahuje odkazy pro manuální stažení všech požadovaných souborů.
Ne všechny moje produkty SOLIDWORKS byly aktualizovány pomocí nejnovější aktualizace Service Pack. Proč příkaz Zjistit aktualizace uvádí, že mám poslední verzi?

Spuštěním příkazu Zjistit aktualizace se dozvíte, zda máte nainstalovanou anebo spuštěnou aktuální verzi Manažera instalací SOLIDWORKS.

Pokud chcete aktualizovat všechny produkty podle poslední verze, která byla instalována v Ovládacích panelech > Programy > Programy a funkce, zvolte poslední instalovanou verzi SOLIDWORKS a klikněte na tlačítko Změnit.
Je možné zkopírovat DVD do složky pro stažení?

Ano, ale instalace mohou selhat, pokud nezkopírujete celý obsah každého DVD vydaného pro odpovídající platformu. Manažer instalací SOLIDWORKS hledá soubory swdata*.id pro určení verze. Pokud tyto soubory nejsou k dispozici, nerozpozná žádný z instalačních souborů, které jste zkopírovali, a vyžádá jejich stažení.
Nadřazené téma Řešení potíží
Využití síťových licencí
Soubory protokolu Manažera instalací SOLIDWORKS
Odstranění potíží s licencemi SolidNetWork
Řešení potíží s upgrady
Ověřování grafických karet při instalaci nebo upgradu


Odstranění potíží s licencemi SolidNetWork

Pokud se instalace aplikace SolidNetWork License Manager nezdaří, zkontrolujte následující možná vysvětlení.

Nadřazené téma Řešení potíží
Využití síťových licencí
Soubory protokolu Manažera instalací SOLIDWORKS
Složka pro stažení Manažera instalací SOLIDWORKS
Řešení potíží s upgrady
Ověřování grafických karet při instalaci nebo upgradu

Přístup na soubory protokolu licencí SolidNetWork

Když dojde k chybě v licenci, většinou se odpověď zobrazí v souboru protokolu SNL_Manager_install_dir\lmgrd.log .

Nepodařilo se získat licenci pro SOLIDWORKS. Nepodařilo se připojit k licenčnímu serveru.

Tento problém je většinou způsoben nastaveními portu.

  • Nastavení portu mezi manažerem licencí SolidNetWork a licenčním klientem se zřejmě neshoduje.
  • Další nastavení portu pro násobné verze Manažera licence SolidNetWork nebyly pravděpodobně určeny.
  • Zkontrolujte, zda klientský počítač dokáže správně dešifrovat název serveru a přesměrovat se na něj na základě uvedeného názvu serveru.
Bližší informace o nastavení portu pro manažery licencí SolidNetWork a klienty, viz Použití licencí SolidNetWork s firewall.
Použití licencí SolidNetWork s firewall


Řešení potíží s upgrady

Pokud se setkáte s problémy během provádění upgrade nové verze SOLIDWORKS, zkontrolujte tato možná vysvětlení.

Nadřazené téma Řešení potíží
Využití síťových licencí
Soubory protokolu Manažera instalací SOLIDWORKS
Složka pro stažení Manažera instalací SOLIDWORKS
Odstranění potíží s licencemi SolidNetWork
Ověřování grafických karet při instalaci nebo upgradu

Změna nebo opětovné spárování zdroje, který se přesunul

Při instalaci programu SOLIDWORKS si Manažer instalací SOLIDWORKS zapamatuje umístění zdrojů (disk, kopie disku na síti atd.). Manažer instalací během úprav nebo aktualizace očekává tyto zdroje ve stejném umístění.

Pokud dojde k přemístění nebo odstranění zdroje, nebo pokud se změní médium zdroje, zobrazí Manažer instalace SOLIDWORKS chybovou hlášku. Instalační zdroje však můžete upravit nebo opravit tak, že přejdete do jiného umístění, pokud obsahuje stejnou strukturu souborů a složek.


Ověřování grafických karet při instalaci nebo upgradu

Při dokončování instalace nebo upgradu softwaru SOLIDWORKS na vašem počítači spusťte nástroj SOLIDWORKS Rx, abyste se ujistili, že je počítač vybaven podporovanou grafickou kartou s ovladačem.

Postup ověření grafických karet při instalaci nebo aktualizaci:

  1. Když Manažer instalací dokončí instalaci a zobrazí stránku Dokončit, v nabídce Zkontrolovat systém klepněte na položku Spustit diagnostiku systému.

    Spustí se Nástroj SOLIDWORKS Rx a provede diagnostiku.

  2. Nástroj SOLIDWORKS Rx potvrdí, zda jsou grafická karta a její ovladač podporovány.
    Pokud je podporována grafická karta, ale ovladač ne, stavová zpráva může nabídnout odkaz na podporovaný ovladač.

Při každém desátém spuštění softwaru SOLIDWORKS se zobrazí zpráva Zkontrolovat systém s doporučením spustit znovu diagnostiku systému. Pokud chcete tato oznámení potlačit, klepněte v oznamovací oblasti systému Windows pravým tlačítkem na SOLIDWORKS Resource Monitor [image] a vyberte Zrušit grafická oznámení.

Grafickou kartu a její ovladač lze ověřit kdykoli kliknutím pravým tlačítkem na položku SOLIDWORKS Resource Monitor v oznamovací oblasti systému Windows. Místní nabídka rovněž umožňuje:
  • Zobrazit Nápovědu pro SOLIDWORKS Resource Monitor
  • Spustit diagnostiku systému
  • Zrušit grafická oznámení
  • Zahodit oznámení o předplatném
  • Zobrazit certifikované ovladače grafické karty
Nadřazené téma Řešení potíží
Využití síťových licencí
Soubory protokolu Manažera instalací SOLIDWORKS
Složka pro stažení Manažera instalací SOLIDWORKS
Odstranění potíží s licencemi SolidNetWork
Řešení potíží s upgrady


Nápověda aplikace Manažer instalací SOLIDWORKS

Manažer instalací SOLIDWORKS je samostatný program, který nainstaluje a aktualizuje produkty SOLIDWORKS.

Manažer instalací SOLIDWORKS je primární nástroj pro stahování, instalaci, úpravu, aktualizaci, opravu a odstranění softwaru SOLIDWORKS.

Manažera instalací SOLIDWORKS můžete spustit následujícími způsoby:
  • Z disku DVD SOLIDWORKS nebo ze sdílené zdrojové složky nebo složky pro stažení (když instalujete novou verzi).
  • Ze stránky Ovládací panel Přidat nebo Odebrat programy (když měníte nebo odstraňujete stávající verzi)
  • Prostřednictvím naplánovaného nebo ručního zjišťování aktualizací (najít, stáhnout a nainstalovat nové finální verze).

Každá verze SOLIDWORKS má verzi Manažera instalací SOLIDWORKS, která je specifická pro danou verzi SOLIDWORKS.

Obsah

  • SOLIDWORKS Nástroj pro stahování na pozadí

    SOLIDWORKS Nástroj pro stahování na pozadí provádí automatizované stahování souborů (když je například nalezena nová verze aktualizace Service Pack) pomocí procesů na pozadí, přičemž umožňuje během stahování pokračovat v práci. Po dokončení stahování se můžete rozhodnout, zda chcete instalovat nyní, odložit nebo odstranit stahování.

  • Nastavení možností manažera instalací

    Mezi tyto možnosti patří nastavení protokolování, přístup k internetu a jazyk používaný v Manažeru instalací.

  • Výsledky zjištění aktualizací

    Funkce Zjistit aktualizace hledá novější verze SOLIDWORKS.

  • Umístění administrativní kopie

    Určete umístění instalace administrativní kopie.

  • Možnosti stažení

    Zadejte podrobnosti pro dokončení operace stažení, jako je umístění staženıch souborů, jakım způsobem soubory stáhnout a jestli chcete stažené soubory instalovat.

  • Možnosti stažení pro soubory Manažera instalací SOLIDWORKS

    Zvolili jste stažení novější verze Manažera instalací SOLIDWORKS. Na této obrazovce zadejte, kde a jakým způsobem mají být soubory staženy.

  • Stažení instalačních souborů produktu

    Určete kam a jak se mají stáhnout chybějící soubory určitého produktu.

  • Průběh stahování

    Během tohoto procesu Manažer instalací SOLIDWORKS paralelně stáhne, ověří a extrahuje všechny soubory.

  • Výsledky stahování

    Zobrazuje, jestli bylo stažení dokončeno úspěšně, jestli byla operace úspěšná nebo jestli byla zrušena.

  • Chyby během instalace / Instalace byla zrušena

    Při instalaci došlo k chybě nebo byla instalace zrušena.

  • Instalace je dokončena

    Manažer instalací SOLIDWORKS dokončil proces instalace.

  • Umístění instalace

  • Možnosti upgradu

    V tomto počítači je nainstalována jedna nebo více starších hlavních verzí SOLIDWORKS. Můžete vytvořit novou instalaci, která bude nainstalována souběžně se starší verzí, nebo můžete provést upgrade, čímž se starší verze odstraní.

  • Průběh instalace

    Tato obrazovka uvádí průběh instalace.

  • Typ instalace

    Můžete určit operaci instalace, kterou chcete provést. Například vytvoření nové instalace, změna nebo oprava existující instalace, vytvoření administrativní kopie, instalace produktů administrativního serveru nebo stažení souborů, které pak budete moci sdílet a instalovat na ostatní počítače.

  • Instalace a správa několika počítačů

    Manažer instalací SOLIDWORKS poskytuje následující nástroje na instalaci a správu několika počítačů SOLIDWORKS.

  • Ruční stahování

    Zvolili jste stáhnout soubory ručně (nebo jste možná vybrali ruční stažení, když jste naposledy spustili Manažera instalací SOLIDWORKS).

  • K dispozici je novější verze

    Manažer instalací zaznamenal novější verzi produktů SOLIDWORKS. Můžete buď nainstalovat verzi obsaženou na původním instalačním DVD nebo ve stažení, nebo můžete stáhnout a nainstalovat novou verzi.

  • Nejsou k dispozici novější verze

    Novější verze nejsou k dispozici pro stažení. Pokračovat v instalaci určené verze.

  • Zjištěné procesy

    Manažer instalací SOLIDWORKS zjistil procesy na tomto počítači, které by mohly zabránit úspěšné instalaci.

  • Výběr produktu

    Můžete určit součásti produktu, které chcete nainstalovat, upravit nebo odebrat.

  • Produkty ke stažení

    Vyberte produkty SOLIDWORKS, které se mají stáhnout do určitého umístění.

  • Produkty k opravě

    Když vyberete možnost Opravit tuto instalaci, zobrazí se obrazovka obsahující produkty SOLIDWORKS spolu s čísly verzí, které je možné opravit pomocí Manažera Instalací SOLIDWORKS.

  • Sériová čísla

    Sériová čísla přidružují váš počítač k produktům SOLIDWORKS, které jste zakoupili.

  • Instalace serveru

    Produkty serveru, které instalujete, jsou uvedeny v seznamu s výsledkem instalace.

  • Souhrnné informace

    Manažer instalací SOLIDWORKS má všechny potřebné informace pro dokončení instalace.

  • Upozornění kontroly systému

    Kontrola systému prověřuje oznámené problémy, které by mohly mít dopad na průběh instalace. Ve většině případů byste měli být schopni pokračovat dále s Manažerem instalací SOLIDWORKS.

  • Možnosti Průvodce dírami/Toolbox

    Pokud je SOLIDWORKS Toolbox instalován, obsahuje software SOLIDWORKS knihovnu standardních typů děr stejně jako hardware.

  • Odinstalování produktů

    Zvolíte-li v Ovládacích panelech možnosti Odebrat nebo Odinstalovat program, zobrazí se tato obrazovka s produkty SOLIDWORKS (s čísly verze), které lze odinstalovat pomocí této verze Manažera instalací SOLIDWORKS. Můžete určit, zda se má provést standardní, vlastní nebo úplná odinstalace.


SOLIDWORKS Nástroj pro stahování na pozadí

SOLIDWORKS Nástroj pro stahování na pozadí provádí automatizované stahování souborů (když je například nalezena nová verze aktualizace Service Pack) pomocí procesů na pozadí, přičemž umožňuje během stahování pokračovat v práci. Po dokončení stahování se můžete rozhodnout, zda chcete instalovat nyní, odložit nebo odstranit stahování.

Když instalujete SOLIDWORKS, je SOLIDWORKS Nástroj pro stahování na pozadí ve výchozím nastavení povolen.

Když běží Manažer instalací SOLIDWORKS, je SOLIDWORKS Nástroj pro stahování na pozadí pozastaven, bez ohledu na to, zda provádí instalaci nebo stahování. Dojde tak například k pozastavení všech probíhajících stahování, nepovolí se zahájení nových stahování a není možné změnit určení složky pro stahování.

Během instalace můžete zakázat stahování na pozadí. Na stránce přehledu v části Možnosti stahování zrušte zaškrtnutí možnosti Pro budoucí aktualizace service pack použijte Nástroj pro stahování na pozadí.

Když je nástroj povolen, objeví se v oznamovací oblasti Windows v hlavním panelu tato ikona:

Klepnutím na tuto ikonu aktivujete následující operace:
  • Nápověda pro Nástroj pro stahování na pozadí
  • Pozastavit stahování
  • Obnovit stahování
  • Zrušit stahování
  • Možnosti instalace
  • Změnit nastavení stahování
  • Zkontrolovat aktualizace.
  • Zjišťovat aktualizace automaticky
  • Automaticky stáhnout aktualizace
  • Zakázat nástroj pro stahování na pozadí

Nápověda pro Nástroj pro stahování na pozadí

Otevřete toto téma nápovědy pro Nástroj pro stahování na pozadí pomocí Průvodce instalací SOLIDWORKS.

Pozastavit/obnovit stahování

Pokud běží na pozadí stahování, klepnutím na Pozastavit stahování je pozastavíte a můžete je později kdykoli znovu obnovit klepnutím na Obnovit stahování.

Zrušit stahování

Pokud probíhá stahování, můžete je zastavit a odstranit veškeré soubory, které již Nástroj pro stahování na pozadí stáhl.
Zrušené stahování nemůžete obnovit.

Možnosti instalace

Jakmile se stahování dokončí, můžete vybrat z následujících možností:
  • Nainstalovat: Nainstaluje stažené soubory.
  • Připomenout později: Nenainstaluje stažené soubory, ale sestaví zprávu, kterou vám připomene instalaci později.
  • Odstranit stažení: Nenainstaluje stažené soubory a odstraní je. (To je užitečné zejména v případě, že jste se rozhodli, že stažené soubory již nechcete instalovat.)

Změnit nastavení stahování

Změní umístění složky, do níž Nástroj pro stahování na pozadí stahuje soubory.

Tato volba není dostupná, pokud stahování buď běží nebo je pozastaveno.
Můžete také zadat Počet dní mezi kontrolami aktualizací.

Zjistit aktualizace

Spusťte funkci Zjistit aktualizace Manažera instalací SOLIDWORKS.

Zjišťovat aktualizace automaticky

Pravidelně spouští příkaz Zjistit aktualizace a upozorňuje, že jsou k dispozici aktualizace ke stažení.

Automaticky stáhnout aktualizace

Pravidelně spouští příkaz Zjistit aktualizace a stahuje dostupné aktualizace.

Vypnutí a opětovné zapnutí SOLIDWORKS Nástroje pro stahování na pozadí

Nástroj pro stahování na pozadí můžete vypnout kliknutím na jeho ikonu v oznamovací oblasti Windows a výběrem možnosti Zakázat nástroj pro stahování na pozadí.

Chcete-li Nástroj pro stahování na pozadí znovu povolit, klepněte na Start > Manažer instalace SOLIDWORKS > SOLIDWORKS Nástroj pro stahování na pozadí.

Nadřazené téma Nápověda aplikace Manažer instalací SOLIDWORKS


Nastavení možností manažera instalací

Mezi tyto možnosti patří nastavení protokolování, přístup k internetu a jazyk používaný v Manažeru instalací.

Nastavení možností Manažera instalací před instalací softwaru:

  1. V Manažeru instalací klikněte pravým tlačítkem na ikonu SOLIDWORKS v záhlaví a následně vyberte:
    Volba | Popis
    Úrovně protokolování instalace Určuje úroveň protokolování: vysoká, střední nebo nízká. Vyšší úrovně shromažďují více dat pro odstraňování potíží, ale rovněž mohou zpomalit instalaci. Nízká (nejrychlejší) je výchozí, přičemž poskytuje nejlepší výkon a stabilitu.

    Možnost Vytvořit soubory protokolování instalační služby systému Windows (pomalé) uloží protokoly do stejné složky jako ostatní instalační protokoly.
    Možnosti administrativní kopie | Vyberte možnost Použít krátké názvy souborů (formát 8.3) nebo Použít úplné názvy složek a souborů.
    Shromažďování protokolů o instalaci | Určuje, kam se ukládají protokoly instalací. Manažer instalací tyto soubory uchovává v souboru IM_Logs.zip.
    Zakázat přístup k internetu
    Jazyk | Určuje jazyk používaný v manažeru instalací. Výchozí jazyk je angličtina.
  2. Klepněte na Zavřít.
Nadřazené téma Nápověda aplikace Manažer instalací SOLIDWORKS


Výsledky zjištění aktualizací

Funkce Zjistit aktualizace hledá novější verze SOLIDWORKS.

Pokud máte oprávnění správce pro počítač, můžete spustit Zjistit aktualizace ručně:
  • V systému Windows klikněte na Start > Manažer instalací SOLIDWORKS > Zkontrolovat aktualizace.
  • V SOLIDWORKS klikněte na položku [image] > Zkontrolovat aktualizace
Funkce Zjistit aktualizace není k dispozici u klientů instalovaných z administrativních kopií.

Dostupná nová verze

Manažer instalací SOLIDWORKS zaznamenal novější verzi produktů SOLIDWORKS. Vyberte Manažera instalací SOLIDWORKS pro tuto verzi, což vám umožní aktualizovat na novější verzi.

Tato novější verze může stáhnout instalační soubory založené na produktech, které jste určili v instalaci. Stažené soubory můžete sdílet s ostatními uživateli, kteří používají k instalaci Manažera instalací SOLIDWORKS.

Tato stažení lze použít pouze v Manažeru instalací SOLIDWORKS.
K dispozici jsou tyto možnosti:
  • Pokud je k dispozici několik verzí, vyberte požadovanou verzi ze seznamu.
  • Detaily o verzi najdete v odkazu Zkontrolujte, co tento upgrade obsahuje.
Klepnutím na Další bude stažena a spuštěna nová verze Manažera instalací SOLIDWORKS.

Žádná nová stažení/Nové verze není možné zjistit

Manažer instalací SOLIDWORKS nezjistil nové verze produktů SOLIDWORKS, protože jste instalovali nejnovější dostupnou verzi, nebo se nemohl připojit k serveru SOLIDWORKS, aby provedl kontrolu.

Nadřazené téma Nápověda aplikace Manažer instalací SOLIDWORKS


Umístění administrativní kopie

Určete umístění instalace administrativní kopie.

Když vytváříte administrativní kopii, jsou použity tyto možnosti:
Umístění nové kopie | Toto je umístění adresáře, ve kterém Manažer instalací SOLIDWORKS vytvoří novou kopii. | Toto umístění nemůže obsahovat existující administrativní kopii. Administrativní kopie musí být ve složce, kterou lze sdílet za účelem zavedení na klienty.
Odhadované místo na disku požadované pro vytvoření kopie | Toto je doplňkové místo požadované pro administrativní kopii. | Ověřte si, zda je na disku, na který chcete instalovat, dostatek volného místa pro podporu požadavků instalace.
Vytvořit kopii z | Toto je umístění adresáře, ze kterého instalujete produkty SOLIDWORKS. Tato volba se objeví jen tehdy, pokud je určena možnost Pouze instalovat. Podrobnosti najdete v Možnosti stažení.
Nadřazené téma Nápověda aplikace Manažer instalací SOLIDWORKS


Možnosti stažení

Zadejte podrobnosti pro dokončení operace stažení, jako je umístění staženıch souborů, jakım způsobem soubory stáhnout a jestli chcete stažené soubory instalovat.

Manažer instalací SOLIDWORKS podporuje způsob distribuce softwaru označovaný jako electronic software distribution (ESD). Pokud neprovádíte instalaci z disku DVD SOLIDWORKS, budete vyzváni k zadání zdroje pro produkty SOLIDWORKS, které instalujete.

Odpovědi na otázky o složce pro stažení najdete v Složka pro stažení Manažera instalací SOLIDWORKS.

Co chcete udělat?

Vyberte jednu z následujících možností:

Stáhnout a instalovat/stáhnout a vytvořit kopii

Po dokončení stahování spustí Manažer instalací SOLIDWORKS instalaci za použití stažených souborů.

Pouze stáhnout. Můžete stáhnout soubor jednou a pak sdílet stažené soubory s více počítači.

Manažer instalací SOLIDWORKS nespustí instalaci po dokončení stažení.

Obvykle byste zadali tuto možnost, když byste stahovali soubory ke konfiguraci sady instalačních souborů, kterou použijete na více počítačích.

Pokud tuto možnost zvolíte, budete vyzváni, abyste si vybrali mezi dvěma sadami souborů, které chcete stáhnout:
  • Soubory pro TENTO počítač: Stažení bude obsahovat jen ty soubory, které chybí v sadě instalačních souborů aktuálně instalovaných na tomto počítači.
    Toto stažení by mělo být menší, protože obsahuje:
    • Pouze soubory pro produkty vybrané na stránce Výběr produktu
    • Pouze soubory předpokladů, které jsou požadovány pro váš počítač, ale ještě nejsou instalovány

    Pokud se ale pokusíte použít tuto stáhnutou sadu souborů na jiném počítači pro provedení instalace, některé soubory by mohly chybět (protože sada instalačních souborů na jiném počítači by mohla být rozdílná). Můžete použít tyto stažené soubory pro instalaci na jiném počítači, ale když instalace běží, budete možná muset stáhnout další soubory pro doplnění sady instalačních souborů na tomto počítači.

  • Soubory ke sdílení s JAKÝMKOLIV počítačem: Stažení bude obsahovat kompletní sadu instalačních souborů, kterou je možno použít k instalaci této verze na jakémkoliv počítači.

    Toto stažení je delší, protože obsahuje kompletní sadu souborů, kterou je možno použít k instalaci této verze jakéhokoliv produktu na jakémkoliv počítači.

    Pokud určíte omezenou sadu produktů, které se mají stáhnout, bude tato možnost toto určení ignorovat a stáhne všechny produkty obsažené v této verzi produktu.

    Stažení bude obsahovat všechny soubory nutné pro vytvoření administrativní kopie, nejenom ty soubory, které jsou nutné pro provedení individuální instalace.

Pouze instalovat/Vytvořit pouze kopii. Mám již všechny soubory, které jsou nutné k instalaci.

Manažer instalací SOLIDWORKS nestahuje žádné soubory, ale používá soubory ve vybraném adresáři.

Vyhledejte jiné umístění klepnutím na Vyhledat. Můžete například přejít k instalačnímu DVD nebo ke složce stažení, za předpokladu, že toto místo obsahuje všechny požadované soubory.

Pokud obdržíte chybovou hlášku, že složka není kompletní a předpokládali jste, že obsahuje všechny instalační soubory, vysvětlení mohou být následující:
  • Vybrali jste k instalaci produkt, který nebyl ještě stažen, nebo byl vybrán automaticky.
  • Soubory byly staženy na jiném počítači s jinou sadou systémových požadavků.
  • Nejprve jste provedli klientskou instalaci a nyní vytváříte administrativní kopii, která vyžaduje větší sadu souborů.

Můžete buď vyhledat složku obsahující všechny tyto soubory (například DVD) nebo vyberte jednu z možností stažení.

Kam se mají stáhnout požadované soubory?

Toto je složka pro umístění stažení.

V některých případech může být tato možnost viditelná, ale vypnutá. Pokud je například zadáno Pouze instalovat, Manažer instalací SOLIDWORKS nainstaluje jakékoliv stažené soubory z adresáře určeného pro tuto možnost a nepoužije samostatnou složku pro stažení.

Ať již stahujete tyto soubory nebo k nim máte přístup z vašeho vlastního umístění, všechny soubory musí být staženy do stejné složky.

Odhadovaná velikost stažení

Odhadovaný požadavek na místo na disku při stažení je založen na vybraném celkovém seznamu součástí, bez ohledu na to, zda se jedná o nové stažení nebo o obnovení předchozí relace.

Jestliže například obnovíte předchozí stažení, Manažer instalací SOLIDWORKS zpracuje pouze ty soubory, které ještě nebyly staženy. Doba stažení může být kratší než odhadovaná doba.

Pokud soubor dokončil stahování v předchozím stažení, jeho velikost není zahrnuta v tomto odhadu. Proto může být odhad vyšší než aktuální velikost stažení.

Jakým způsobem se má provést stažení?

Provést ruční stažení

V některých případech může proxy server zabránit automatickým stažením z Manažera instalací SOLIDWORKS.

Když zvolíte tuto možnost, můžete stáhnout soubory ručně pomocí webové stránky a pak pokračovat v rámci Manažera instalace SOLIDWORKS a dokončit instalaci. Tato webová stránka je Manažerem instalací SOLIDWORKS přizpůsobena pro stahování pouze těch souborů, které jsou nutné pro dokončení instalace.

Používání SOLIDWORKS Nástroje pro stahování na pozadí

SOLIDWORKS Nástroj pro stahování na pozadí slouží k dokončení této operace stahování, nebo ke stažení budoucích aktualizací service pack pro program SOLIDWORKS, až budou k dispozici.

SolidWorks Nástroj pro stahování na pozadí automaticky zaznamená a stáhne nové aktualizace service pack na pozadí a upozorní vás, že je stahování dokončeno a soubory jsou připraveny k instalaci. Podrobnosti najdete v SOLIDWORKS Nástroj pro stahování na pozadí.

Nadřazené téma Nápověda aplikace Manažer instalací SOLIDWORKS


Možnosti stažení pro soubory Manažera instalací SOLIDWORKS

Zvolili jste stažení novější verze Manažera instalací SOLIDWORKS. Na této obrazovce zadejte, kde a jakým způsobem mají být soubory staženy.

Odpovědi na otázky o složce pro stažení najdete v Složka pro stažení Manažera instalací SOLIDWORKS.

Tato obrazovka se objeví pouze tehdy, když existuje problém s výchozí složkou pro stažení (například pokud není přístup ke čtení nebo síti k dispozici). Obvykle můžete sami určit alternativní adresář pro stažení pro pokračování.

Složka pro stažení

Vyhledejte cílovou složku pro soubory Manažera instalace SOLIDWORKS.

Zobrazí se požadované místo a aktuálně dostupné místo na disku. Toto číslo zahrnuje dodatečné místo pro dekomprimaci stažených souborů a je větší než velikost stažení.

Nadřazené téma Nápověda aplikace Manažer instalací SOLIDWORKS


Stažení instalačních souborů produktu

Určete kam a jak se mají stáhnout chybějící soubory určitého produktu.

Během stahování Manažer instalací SOLIDWORKS paralelně stáhne, ověří a extrahuje všechny soubory.

Zrušením této obrazovky zrušíte zbytek posloupnosti instalace.

Další informace o zrušených instalacích a pokyny k dokončení přerušených instalací najdete na odkazu Chyby během instalace / Instalace byla zrušena.

Složka pro stažení

Vyhledejte cílovou složku pro stažené soubory.

Je také zobrazena velikost stahovaných dat a požadované místo. Požadované místo zahrnuje jakékoliv místo navíc, které je zapotřebí pro dekomprimaci určitých stahování a je větší než aktuální stahovaná velikost.

Odpovědi na otázky o složce pro stažení najdete zde Složka pro stažení Manažera instalací SOLIDWORKS.

Nadřazené téma Nápověda aplikace Manažer instalací SOLIDWORKS
Chyby během instalace / Instalace byla zrušena
Složka pro stažení Manažera instalací SOLIDWORKS


Průběh stahování

Během tohoto procesu Manažer instalací SOLIDWORKS paralelně stáhne, ověří a extrahuje všechny soubory.

Chcete-li v průběhu zrušit stahování, klepněte na Storno.

Pokud stahování zrušíte nebo se stahování nepodaří, obrazovka Stahování zrušeno nebo Problém při stahování vám oznámí, které stažení nebylo dokončeno a umožní vám obnovit stahování, nebo ukončit program.

Odpovědi na otázky o složce pro stažení najdete v Složka pro stažení Manažera instalací SOLIDWORKS.
Nadřazené téma Nápověda aplikace Manažer instalací SOLIDWORKS


Výsledky stahování

Zobrazuje, jestli bylo stažení dokončeno úspěšně, jestli byla operace úspěšná nebo jestli byla zrušena.

Problém se stahováním/Stahování zrušeno

Pokud vidíte Problém se stahováním, Manažer instalací SOLIDWORKS narazil na problémy, které brání v dokončení stahování.

Pokud vidíte Stahování zrušeno, zrušili jste stahování před tím, než bylo dokončeno.

Pokračujte následovně:

Opakovat/Obnovit automatická stahování | Pro obnovení automatického stahování z místa, kde bylo zrušeno, zvolte tuto možnost a klepněte na Opakovat staženínebo Obnovit stažení.
Stáhnout soubory individuálně ve webovém prohlížeči | V některých případech může proxy server zabránit automatickým stažením z Manažera instalací SOLIDWORKS. | Když zvolíte tuto možnost, můžete stáhnout soubory ručně pomocí webové stránky a pak pokračovat v rámci Manažera instalace SOLIDWORKS a dokončit instalaci. Tato webová stránka je Manažerem instalací SOLIDWORKS přizpůsobena pro stahování pouze těch souborů, které jsou nutné pro dokončení instalace.

Stahování dokončeno

Obrazovka Stahování dokončeno se objeví, když je stahování dokončeno, pokud jste určili možnost Pouze stáhnout.

Klepnutím na Dokončit ukončíte Manažera instalací SOLIDWORKS.

Neinstalujte žádný z těchto produktů ručně. K instalaci stažených souborů vždy používejte Manažera instalací SOLIDWORKS.
Nadřazené téma Nápověda aplikace Manažer instalací SOLIDWORKS


Chyby během instalace / Instalace byla zrušena

Při instalaci došlo k chybě nebo byla instalace zrušena.

Pokud dojde k chybě, nebo ke zrušení:
  • Produkty, které byly nainstalovány než došlo k chybě nebo ke zrušení, zůstanou na počítači.
  • Instalace produktu, která probíhala v době zrušení, je vrácena zpět, je-li to možné, aby na počítači nebyly částečné instalace.
  • Zbylé produkty nejsou nainstalovány nebo odinstalovány. Seznam je k dispozici pod Nebyl proveden pokus.

    Chcete-li obnovit instalaci nebo tyto produkty odinstalovat, klepněte na odkazy, které jsou k dispozici.

Manažer instalací SOLIDWORKS nejprve nainstaluje nutné požadované součásti, které nejsou instalované na počítači, například .NET framework.

Obsah

  • Obnovení po nezdařené nebo zrušené instalaci

    Pokud dojde k chybě nebo ke zrušení během instalace, můžete obnovit instalaci z tohoto bodu opětovného spuštění instalace.

  • Oprava instalace

    Pokud zaznamenáte problém s nainstalovaným produktem SOLIDWORKS, můžete pomocí Manažera instalací SOLIDWORKS instalaci opravit.

  • Kontaktování prodejce SOLIDWORKS

    Pokud změna nebo oprava instalace selže, obraťte se na místního prodejce SOLIDWORKS a poskytněte mu informace z této obrazovky. Možná bude potřebovat také komprimovanou složku souborů protokolu Manažera instalací SOLIDWORKS.

Nadřazené téma Nápověda aplikace Manažer instalací SOLIDWORKS


Obnovení po nezdařené nebo zrušené instalaci

Pokud dojde k chybě nebo ke zrušení během instalace, můžete obnovit instalaci z tohoto bodu opětovného spuštění instalace.

  1. Zaznamenejte chybovou hlášku a kód produktu pro každou nezdařenou instalaci tak, jak je zobrazeno na obrazovce Chyby během instalace nebo Instalace byla zrušena.
    Pokud software zobrazí výzvu pro zdrojový soubor a neupravujete stávající instalaci SOLIDWORKS, mohou být počítač nebo instalace poškozené. Obraťte se na prodejce SOLIDWORKS.
  2. Restartujte počítač.
  3. Abyste se ujistili, že nejsou spuštěny žádné produkty SOLIDWORKS, stiskněte v systému Windows kombinaci kláves Ctr+Alt+Del. Otevře se Správce úloh.
  4. Pokud se na záložce Procesy objeví pod položkou Název obrázku jakékoliv následující procesy, vyberte je a klepněte na Ukončit proces.
    • SLDWORKS.exe
    • EModelViewer.exe
    • PDMworks.exe
    • pdmwVault.exe
    • SWViewer.exe
    • swlmwiz.exe
    • SWBoengine.exe
    • SWVBAServer.exe
    • Sldshellextserver.exe
  5. Pokud je program již nainstalován a snažíte se ho změnit, nebo odstranit, zkuste opravit instalaci. Podrobnosti viz Opravování instalace.
  6. V systému Windows klikněte na Start > Ovládací panely > Programy a funkce.
  7. Vyberte verzi programu SOLIDWORKS, která selhala.
    Pokud pro verzi SOLIDWORKS, kterou se snažíte nainstalovat, neexistuje žádná položka, zopakujte instalaci.
  8. Proveďte jeden z následujících úkonů:
    • Chcete-li instalaci zopakovat, klepněte na Změnit a vyberte všechny produkty, které během instalace selhaly, nebo byly přeskočeny.

    • Chcete-li přeskočit instalaci, která selhala, klepněte na Změnit a vyberte všechny produkty, které byly během instalace přeskočeny. Zrušte výběr produktů, které se nepodařilo nainstalovat.

    • Chcete-li instalaci přerušit, klepněte na Odstranit a vyberte produkty, které byly nainstalovány.
    Tímto se neobnoví předchozí verze produktů, u které jste chtěli provést upgrade.
Nadřazené téma Chyby během instalace / Instalace byla zrušena
Oprava instalace
Kontaktování prodejce SOLIDWORKS


Kontaktování prodejce SOLIDWORKS

Pokud změna nebo oprava instalace selže, obraťte se na místního prodejce SOLIDWORKS a poskytněte mu informace z této obrazovky. Možná bude potřebovat také komprimovanou složku souborů protokolu Manažera instalací SOLIDWORKS.

  1. Vyhledejte soubory protokolu. Pro Windows:
    C:\Users\uživatelské jméno\AppData\Roaming\SOLIDWORKS\Installation Logs\nainstalovaná_verze\.
    Pokud složku nemůžete najít, může být skryta. V Průzkumníku Windows klikněte na Nástroje. > Možnosti složky. Na záložce Zobrazení v části Upřesnit nastavení vyberte možnost Zobrazovat skryté soubory a složky pro Skryté soubory a složky.
  2. Komprimujte veškerý obsah této složky včetně podsložek.
Nadřazené téma Chyby během instalace / Instalace byla zrušena
Obnovení po nezdařené nebo zrušené instalaci
Oprava instalace


Instalace je dokončena

Manažer instalací SOLIDWORKS dokončil proces instalace.

Jedna nebo více těchto možností se zobrazí.

Co je nového

V případě individuálních instalací se po dokončení instalace zobrazí dokument popisující nové funkce v programu SOLIDWORKS a v jeho doplňkových modulech.

V případě instalací administrativní kopie se tato příručka zobrazí na klientských počítačích po dokončení jejich instalací.

Zúčastněte se programu na zlepšení zkušeností SOLIDWORKS zákazníka

Informace o výkonu jsou zasílány společnosti SOLIDWORKS Corporation, aby pomáhaly zlepšovat produkt. Tento proces je transparentní a důvěrný. Vyberte jednu z následujících možností:
  • Ano, chci se účastnit
  • Ne, děkuji
  • Připomenout později
Více informací viz Webová stránka Programu na zlepšení zkušeností zákazníků.

Administrativní kopie byla dokončena

Po dokončení vytváření administrativní kopie, můžete klepnutím na Přizpůsobit kopii spustit Editor možností administrativní kopie a upravit ji.

Klepnutím na Zobrazit návod, jak instalovat kopii na klientském počítači. se zobrazí návod na používání Editoru možností.

Detaily o konfiguraci administrativní kopie za použití Editoru možností, viz Editor možností administrativní kopie.

Klepnutím na Přizpůsobit kopii spustíte Editor možností administrativní kopie, v němž můžete upravit nastavení možností pro danou administrativní kopii.
Editor možností můžete spustit později dvojím kliknutím na složku sldAdminOptionEditor.exe v SOLIDWORKS Admin.

Obsah

  • Zjistit aktualizace SOLIDWORKS

    Pokud máte oprávnění správce pro počítač, můžete použít Manažera instalací SOLIDWORKS k ruční kontrole aktualizací nebo nakonfigurovat automatickou pravidelnou kontrolu aktualizací.

  • Program na zlepšení zkušeností zákazníků SOLIDWORKS

    Při instalaci SOLIDWORKS můžete zadat, že se mají společnosti SOLIDWORKS Corporation odesílat informace o výkonu za účelem vylepšení produktu.

Nadřazené téma Nápověda aplikace Manažer instalací SOLIDWORKS
Editor možností administrativní kopie


Zjistit aktualizace SOLIDWORKS

Pokud máte oprávnění správce pro počítač, můžete použít Manažera instalací SOLIDWORKS k ruční kontrole aktualizací nebo nakonfigurovat automatickou pravidelnou kontrolu aktualizací.

  1. Spusťte Manažera instalací SOLIDWORKS jedním z následujících způsobů:

    • V programu SOLIDWORKS klikněte na nabídku Nápověda > Zkontrolovat aktualizace.

    • V systému Windows klikněte na nabídku Start > Programy > Manažer instalací SOLIDWORKS > Zkontrolovat aktualizace.

    Můžete také kliknout na tlačítko Start > Manažer instalací SOLIDWORKS > SOLIDWORKS Nástroj pro stahování na pozadí. V oznamovací oblasti systému Windows klikněte pravým tlačítkem na nástroj SOLIDWORKS Nástroj pro stahování na pozadí a klikněte na možnost Zkontrolovat aktualizace.
    Manažer instalací SOLIDWORKS vám sdělí, jestli jsou nějaké aktualizace k dispozici.
  2. Pokud existují nějaké aktualizace, zvolte zda je chcete stáhnout a nainstalovat.
  3. Pokud chcete umožnit automatické pravidelné kontroly aktualizací, zvolte poté, když Manažer instalací SOLIDWORKS dokončí proces, Kontrolovat aktualizace každých ___ dní a určete frekvenci kontrol.
Nadřazené téma Instalace je dokončena
Program na zlepšení zkušeností zákazníků SOLIDWORKS


Program na zlepšení zkušeností zákazníků SOLIDWORKS

Při instalaci SOLIDWORKS můžete zadat, že se mají společnosti SOLIDWORKS Corporation odesílat informace o výkonu za účelem vylepšení produktu.

Společnost SOLIDWORKS používá tyto informace k určení trendů týkajících se používání produktu a jeho kvality. Naším cílem je poskytovat produkt nejlepší kvality a soubory protokolu o výkonu jsou velmi užitečným nástrojem v tomto procesu.

Tento proces je transparentní. Všechny informace obsažené v těchto souborech protokolu jsou zpracovávány důvěrně. Tyto soubory neslouží k jiným účelům a nikdo vás nebude kontaktovat.

Více informací viz Webová stránka Programu na zlepšení zkušeností zákazníků.

Nadřazené téma Instalace je dokončena
Zjistit aktualizace SOLIDWORKS


Umístění instalace

Pro instalace kromě vytvoření administrativní kopie tyto možnosti zahrnují:
Nainstalovat vybrané produkty do | Toto je umístění adresáře, do kterého instalujete SOLIDWORKS. Když provádíte upgrade nebo měníte instalaci, všechny soubory musí být nainstalovány do existujícího místa pro tuto instalaci. V tomto případě nemůžete změnit místo stávající instalace SOLIDWORKS.
Odhadované místo na disku požadované pro instalaci | Toto je doplňkové místo na disku potřebné pro instalaci nebo změnu vybraných součástí. | Ověřte, zda je na disku, na který chcete instalovat, dostatek volného místa pro podporu požadavků instalace.
Instalovat z | Toto je umístění adresáře, ze kterého instalujete SOLIDWORKS. Tato volba se objeví jen tehdy, pokud je určena možnost Pouze instalovat. Podrobnosti naleznete v části Možnosti stahování.
Než změníte umístění instalace SOLIDWORKS, kontaktujte správce systému.

Umístění administrativní kopie

Když vytváříte administrativní kopii, jsou použity tyto možnosti:
Umístění nové kopie | Toto je umístění adresáře, ve kterém Manažer instalací SOLIDWORKS vytvoří novou kopii. | Toto umístění nemůže obsahovat existující administrativní kopii.
Odhadované místo na disku požadované pro vytvoření kopie | Toto je doplňkové místo požadované pro administrativní kopii. | Ověřte si, zda je na disku, na který chcete instalovat, dostatek volného místa pro podporu požadavků instalace.
Vytvořit kopii z | Toto je umístění adresáře, ze kterého instalujete produkty SOLIDWORKS. Tato volba se objeví jen tehdy, pokud je určena možnost Pouze instalovat. Podrobnosti naleznete v části Možnosti stahování.
Umístění stávající kopie | Když provádíte upgrade administrativní kopie, Manažer instalace SOLIDWORKS vytvoří novou kopii založenou na nastaveních pro tuto existující kopii. Tato existující kopie se nemění. To ukazuje umístění původní kopie, kterou jste určili na obrazovce Uvítání.

Zabránění použití cest adresáře specifických pro verzi

Pokud určíte číslo verze v umístění adresáře instalace (například C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS 2023\), a pak provedete upgrade této instalace na SOLIDWORKS 2024, bude instalační adresář SOLIDWORKS 2024 označen jako SOLIDWORKS 2023.

Nadřazené téma Nápověda aplikace Manažer instalací SOLIDWORKS
Možnosti stažení


Možnosti upgradu

V tomto počítači je nainstalována jedna nebo více starších hlavních verzí SOLIDWORKS. Můžete vytvořit novou instalaci, která bude nainstalována souběžně se starší verzí, nebo můžete provést upgrade, čímž se starší verze odstraní.

Vytvořte novou instalaci SOLIDWORKS verze.

Pokud se rozhodnete vytvořit novou instalaci, můžete si vybrat, které produkty SOLIDWORKS chcete instalovat.

Pro každý z vybraných produktů se vytvoří nová instalace této hlavní verze. Starší hlavní verze zůstávají v počítači kromě aplikací SOLIDWORKS Electrical a klient SOLIDWORKS PDM.

Pokud zrušíte výběr produktu, nová verze se neinstaluje.

Vytvoření nové instalace je užitečné, pokud chcete mít přístup ke starší verzi SolidWorks i poté, co byla nainstalována novější verze. Pokud například sdílíte soubory s jinými uživateli, kteří stále používají starší verzi, můžete tak zabránit problému s kompatibilitou se soubory, uloženými s použitím novější verze.

Upgrade softwaru SOLIDWORKS předchozí hlavní verze na SOLIDWORKS aktuální hlavní verze.

Pokud se rozhodnete upgradovat, můžete vybrat produkty SOLIDWORKS, které chcete upgradovat. Pro každý z vybraných produktů se vytvoří nová instalace a starší verze se odstraní.

Pokud zrušíte výběr produktu, nová verze se neinstaluje a starší verze zůstane instalována v počítači.

Pokyny pro SOLIDWORKS Electrical a SOLIDWORKS PDM Client

Na počítači může být instalována pouze jedna verze softwaru SOLIDWORKS Electrical. Pokud vytváříte novou instalaci SOLIDWORKS a vyberete SOLIDWORKS Electrical jako jeden z instalovaných produktů, starší verze softwaru SOLIDWORKS Electrical se odstraní.

Před instalací nové verze prostředí SOLIDWORKS Electrical zálohujte stávající verzi. V aplikaci SOLIDWORKS Electrical Schematic vyberte Soubor Archivovat prostředí nebo v aplikaci SOLIDWORKS Electrical 3D vyberte SOLIDWORKS Electrical > Nástroje > Archivovat prostředí.

Hlavní verze aplikace SOLIDWORKS PDM Client musí odpovídat hlavní verzi softwaru SOLIDWORKS PDM Server. Pokud neplánujete upgradovat software SOLIDWORKS PDM Server, nevybírejte upgrade aplikace SOLIDWORKS PDM Client.

K odebrání produktu v systému Windows použijte funkci Přidat nebo odebrat programy. Podrobnosti najdete v Odstranění instalace.
Nadřazené téma Nápověda aplikace Manažer instalací SOLIDWORKS
Odstranění instalace


Průběh instalace

Tato obrazovka uvádí průběh instalace.

Chcete-li v průběhu zrušit instalaci, klepněte na Storno.

Další informace o zrušených instalacích a pokyny k dokončení přerušených instalací najdete v tématu Chyby během instalace.

Nadřazené téma Nápověda aplikace Manažer instalací SOLIDWORKS


Typ instalace

Můžete určit operaci instalace, kterou chcete provést. Například vytvoření nové instalace, změna nebo oprava existující instalace, vytvoření administrativní kopie, instalace produktů administrativního serveru nebo stažení souborů, které pak budete moci sdílet a instalovat na ostatní počítače.

Pokud je na počítač již nainstalována poslední verze softwaru SOLIDWORKS, máte možnost změnit instalaci nebo ji opravit.

Individuální

Nainstalovat produkty SOLIDWORKS na tento počítač.

Tato volba se objeví jen tehdy, pokud tato verze není instalována na tomto počítači.

Změnit individuální instalaci

Změnit stávající instalaci SOLIDWORKS v tomto počítači.

Tato volba se objeví jen tehdy, pokud tato verze je instalována na tomto počítači.
Změny zahrnují:
  • Přidání nebo odebrání součástí produktu SOLIDWORKS
  • Změna na jiný balíček SOLIDWORKS (například SOLIDWORKS Professional, SOLIDWORKS Premium, SOLIDWORKS Ultimate atd.)
  • Změna nastavení sériového čísla SOLIDWORKS
    Pokud jste již zadali sériové číslo SOLIDWORKS během předchozí instalace, Manažer instalací SOLIDWORKS vás k tomu znovu nevyzve. Chcete-li změnit sériové číslo, musíte vybrat tuto možnost.

Opravit individuální instalaci

Opravit stávající instalaci SOLIDWORKS v tomto počítači.

Tato volba se objeví jen tehdy, pokud tato verze je instalována na tomto počítači.
Při opravě dojde k ověření, zda jsou přítomny všechny soubory a zda jsou správně zaregistrovány. Opravy nemají vliv na vytvořená data.
  • Chcete-li produkt opravit, ujistěte se, že je vybraný.
  • Zrušte výběr produktů, které nechcete opravit.
Je možné opravit individuální instalaci. Instalaci administrativní kopie nelze opravit; musíte ji znovu nainstalovat za použití nové administrativní kopie.

Administrativní kopie

Vytvořit nebo aktualizovat administrativní kopie pro nasazení do více počítačů.

Podrobnosti o instalaci SOLIDWORKS pro více klientů za pomoci administrativních kopií viz Používá administrativních kopií.

Když vytváříte nebo aktualizujete administrativní kopie:
  • Můžete použít nastavení instalace z existující kopie pro konfiguraci nové nebo aktualizované kopie nebo můžete použít výchozí nastavení instalace SOLIDWORKS.
  • Pokud aktualizujete existující kopii:
    • Manažer instalací SOLIDWORKS vytvoří novou kopii kopie, dokonce i pokud aktualizujete. Původní kopie se nemění.
    • Můžete vytvořit nebo aktualizovat kopii za použití souborů z existující kopie, kterou aktualizujete. Výsledkem je menší stažení.
    Pokud neurčíte kopii, pro kterou je k dispozici verze servisního balíčku pro aktualizaci předchozí kopie, nemůžete využít předností menšího stahování.

Serverové produkty

Mezi serverové produkty SOLIDWORKS patří SOLIDWORKS Electrical, SOLIDWORKS PDM a SolidNetWork License Manager.

U aplikace SOLIDWORKS Electrical a SOLIDWORKS PDM je možné zvolit instalaci nástrojů klienta a serveru na stejný počítač nebo na různé počítače.

Podrobnosti o instalaci na tyto servery najdete v odpovídajících tématech nápovědy.

Stažení a sdílení všech souborů

Stáhnout soubory instalací pro vybrané produkty SOLIDWORKS bez jejich instalace.

Tato možnost není k dispozici, když instalujete z disku DVD.
Obsah stažených souborů je stejný jako souborů, které jsou k dispozici na instalačních discích DVD SOLIDWORKS. Pokud vyberete tuto možnost, stáhne se plná sada instalačních souborů bez ohledu na to, které soubory již případně byly nainstalovány na vašem počítači. Můžete si stáhnout kopii souborů do přenosného zařízení nebo síťové složky a použít ke k instalaci softwaru SOLIDWORKS na ostatní počítače. Tento způsob je rovněž vhodný pro nastavení serveru, ze kterého mohou uživatelé provádět instalace.
Tento způsob se liší od vytvoření administrativní kopie.
Nadřazené téma Nápověda aplikace Manažer instalací SOLIDWORKS
Použití administrativní kopie
Správa licencí za použití SolidNetWork License Manager
SOLIDWORKS Electrical


Instalace a správa několika počítačů

Manažer instalací SOLIDWORKS poskytuje následující nástroje na instalaci a správu několika počítačů SOLIDWORKS.

Administrativní kopie SOLIDWORKS

Pokud instalujete SOLIDWORKS na více počítačích, můžete vytvořit administrativní kopii a poté ji nainstalovat na ostatní počítače.

SOLIDWORKS PDM

SOLIDWORKS PDM je produkt pro správu dokumentů založený na stejné architektuře jako SOLIDWORKS Enterprise PDM. Je dostupný ve dvou verzích: Standard a Professional. SOLIDWORKS PDM používá pro správu úschoven databázi Microsoft SQL Server.

SolidNetWork License Manager

SolidNetWork License Manager umožňuje, aby počet uživatelů přesáhl počet licencí, pomocí plovoucích licencí. Pokud není klientská licence využívána, je k dispozici pro jiného uživatele SOLIDWORKS.

K rozdělení licencí pro doplňkové moduly jádra SOLIDWORKS (například FeatureWorks) můžete také použít SolidNetWork License Manager.

Nadřazené téma Nápověda aplikace Manažer instalací SOLIDWORKS


Ruční stahování

Zvolili jste stáhnout soubory ručně (nebo jste možná vybrali ruční stažení, když jste naposledy spustili Manažera instalací SOLIDWORKS).

Klepněte na odkaz pro otevření automaticky generované webové stránky, která obsahuje kompletní seznam souborů, které potřebujete ke stažení.

Musíte je stáhnout do složky určené na stránce Souhrn. Instalace nemůže začít dokud nejsou všechny soubory stažené do této složky.

Jakmile jste dokončili ruční stahování, klepněte na Další pro pokračování.

Pokud chcete provést stahování automaticky, můžete změnit možnost návratem na stránku Souhrn a změnou možnosti stažení.

Nadřazené téma Nápověda aplikace Manažer instalací SOLIDWORKS


K dispozici je novější verze

Manažer instalací zaznamenal novější verzi produktů SOLIDWORKS. Můžete buď nainstalovat verzi obsaženou na původním instalačním DVD nebo ve stažení, nebo můžete stáhnout a nainstalovat novou verzi.

Instalace ze stažení

Vyberte jednu z následujících možností:
  • Pokračovat v instalaci verze.

    Vyberte tuto možnost a pokračujte v instalaci verze obsažené v počátečním stažení.

  • Stáhnout a nainstalovat novou verzi: verze.

    Vyberte možnost ke stažení a instalujte novou verzi. Pokud je k dispozici několik nových verzí, můžete vybrat verzi ke stažení a nainstalovat ji.

Instalace z DVD

V části Chcete používat novější verzi?, vyberte následující:
  • Ne, pokračovat v instalaci verze z tohoto disku DVD. Je možné aktualizovat později.

    Vyberte tuto možnost, pokud chcete pokračovat v instalaci prostřednictvím stávajícího Manažera instalací.

    Po dokončení instalace můžete zkontrolovat a nainstalovat aktualizace pomocí Manažera instalací. Chcete-li zjistit aktualizace, spusťte z nabídkyStart > Manažer instalací SOLIDWORKS > Zjistit aktualizace.
    Možnost Zjistit aktualizace je dostupná, pouze pokud máte oprávnění správce pro příslušný počítač.

    Výhodou této možnosti je, že materiály ke stažení jsou menší. Nevýhodou je, že se jedná o dvoustupňový proces a stažené soubory jsou specifické pro určitou verzi (a nelze je sdílet s ostatními uživateli, kteří používají jiné verze).

  • Ano, provést instalaci pomocí tohoto DVD, pak stáhnout a aktualizovat na verzi.

    Tato možnost slouží ke stažení a spuštění starší verze Manažera instalací, aby bylo možné nainstalovat produkty SOLIDWORKS pro tuto verzi.

    Pokud je pro aktualizaci verze DVD k dispozici malá verze servisního balíčku, Manažer instalací nainstaluje původní verzi z DVD a pak použije aktualizaci servisního balíčku. Výsledkem jsou menší materiály ke stažení.

    Můžete dosáhnout stejného výsledku výběrem možnosti pokračovat v instalaci z DVD a pak později použít aktualizaci.

    Výhodou této možnosti je, že jde o jednorázový postup.

Nadřazené téma Nápověda aplikace Manažer instalací SOLIDWORKS


Nejsou k dispozici novější verze

Novější verze nejsou k dispozici pro stažení. Pokračovat v instalaci určené verze.

Pro pokračování v instalaci klepněte na Další.

Nadřazené téma Nápověda aplikace Manažer instalací SOLIDWORKS


Zjištěné procesy

Manažer instalací SOLIDWORKS zjistil procesy na tomto počítači, které by mohly zabránit úspěšné instalaci.

  • Pro pokračování v instalaci proveďte jednu z následujících možností:
    • Ukončete tyto procesy (například za použití Správce úloh Microsoft Windows) a pak stiskněte Opakovat.
    • Klepněte na Ignorovat a pokračujte bez uzavření procesů.
  • Pro zastavení instalace stiskněte Storno.
Nadřazené téma Nápověda aplikace Manažer instalací SOLIDWORKS


Výběr produktu

Můžete určit součásti produktu, které chcete nainstalovat, upravit nebo odebrat.

V seznamu produktů:
  • Seznam produktů je kompletní seznam, který je k dispozici v balíčku určeném nad seznamem produktů.
  • Pokud chcete zobrazit promítnutou akci pro konkrétní součást, klepněte na název součásti (ale ne na zaškrtávací políčko). Plánovaná akce instalace se objeví v informačním poli pod seznamem produktů.
  • Chcete-li změnit akci instalace pro danou součást, můžete klepnout na zaškrtávací políčko vedle součásti produktu. (Pokud například instalujete nebo odebíráte součást, výběrem zaškrtávacího políčka určíte, že se má součást nainstalovat nebo odebrat a zrušením výběru tohoto políčka určíte, že se daná součást instalovat nebo odebírat nemá.)
  • Pokud provádíte instalaci Úpravy, nalevo od součástí se objeví (*), když provedete jakoukoliv změnu u vybraného produktu.
  • Pokud je u součásti k dispozici volitelná instalace dílčích součástí, zobrazí se vedle součásti ikona +. Chcete-li zobrazit dostupné dílčí součásti pro danou součást, klepněte na ikonu +.
  • V případě rozbalení součásti a zobrazení volitelných dílčích součástí se vedle součásti zobrazí ikona -. Chcete-li sbalit výpis dílčích součástí, klepněte na ikonu -.

Pokud používáte servisní balíček, nelze vybrat funkce SOLIDWORKS, které se zobrazují pod položkou SOLIDWORKS (například FeatureWorks). Pokud vyberete tento typ upgradu, není možné přidat nebo odstranit jednotlivé funkce.

Akce provedené Manažerem instalací SOLIDWORKS jsou ovládané sadou pravidel koexistence produktu. Podrobnosti najdete v Pravidla koexistence produktu.

Manažer instalací SOLIDWORKS vybere standardně tyto součásti produktu:
  • Pokud provádíte upgrade nebo aktualizaci Service Pack, Manažer instalací SOLIDWORKS zvolí produkty, které jsou v současnosti nainstalovány.
  • Jinak Manažer instalací SOLIDWORKS vybere všechny produkty, ke kterým máte oprávnění.
Pro zkrácení doby stahování a zmenšení požadovaného místa na disku rozbalte součásti produktu a zrušte zaškrtnutí políčka u součástí, které nepotřebujete.

Pokud aplikace SOLIDWORKS Installation Manager není schopna ověřit produkty, které jste oprávněni používat, klikněte na možnost Vybrat jiný balíček nebo produkty a změňte balíček produktů (např. SOLIDWORKS Professional, SOLIDWORKS Premium nebo SOLIDWORKS Ultimate) v seznamu položek k instalaci nebo změně. Manažer instalací SOLIDWORKS zobrazí seznam všech produktů SOLIDWORKS na vašem instalačním médiu, jenž jsou kompatibilní s vybraným balíčkem. Můžete vybrat jakékoli produkty, které jste zakoupili nebo jste oprávněni vyzkoušet.

Vyhledávání v SOLIDWORKS

Vyhledávání v SOLIDWORKS poskytuje výkonné fulltextové vyhledávání dokumentů SOLIDWORKS. Vyhledávání zobrazí náhled, umístění souborů a název.

Po dokončení instalace SOLIDWORKS vyhledávání indexuje dokumenty SOLIDWORKS pro rychlejší vyhledávání. Pouze soubory SOLIDWORKS jsou indexovány automaticky.

Jazyková podpora

Rozbalením produktu SOLIDWORKS a součásti Jazyky se zobrazí jazyky, které lze nainstalovat.

Specifikace Jazyky omezuje jazyky, které jsou nainstalovány jen pro produkt SOLIDWORKS. Toto nastavení nemá vliv na instalace ostatních produktů. Například: aplikace eDrawings® a SOLIDWORKS PDM nainstaluje všechny jazyky.

Potřebné místo na disku

Manažer instalací SOLIDWORKS dole na stránce hlásí buď celkovou velikost instalace, nebo celkovou velikost stažení.

  • Pokud jste vybrali možnost Pouze stáhnout, objeví se velikost stažení. Velikost stažení je celkové množství místa na disku vyžadovaného pro všechny stahované soubory (nezahrnuje místo požadované pro dekomprimaci souborů po dokončení stažení). Toto číslo je pouze odhad.
    V celkové velikosti stažení jsou zahrnuty všechny soubory potřebné k instalaci. Nebudou znovu staženy soubory, které jsou již obsaženy v aktuální složce pro stažení. To znamená, že velikost stažení může být menší než zobrazená celková velikost stažení, nebo nebudete muset stáhnout žádné soubory.
  • Jinak se zobrazí velikost instalace. Velikost instalace se rovná změně ve využití místa na disku, ke kterému dojde po dokončení instalace. V důsledku komprimace souboru se jedná pouze o odhady.

    Pokud upgradujete, nebo odstraňujete stávající instalaci, může se velikost instalace rovnat nule.

    Zobrazené číslo nezahrnuje místo potřebné ke stažení, nebo k extrahování souborů požadovaných k instalaci.

    Pokud je vyžadováno stažení a stahujete do stejné jednotky, mohou být požadavky na místo na disku daleko větší než je uvedená velikost instalace.

    Pokud chcete u budoucích aktualizací a oprav snížit dobu na stažení a instalaci, neodstraňujte po instalaci stažené soubory. Následující aktualizace a opravy většinou vyžadují přístup k poslední sadě souborů úplné instalace.

Nadřazené téma Nápověda aplikace Manažer instalací SOLIDWORKS
Pravidla koexistence produktu


Produkty ke stažení

Vyberte produkty SOLIDWORKS, které se mají stáhnout do určitého umístění.

V závislosti na zadaném sériovém čísle se zobrazí odpovídající produkty ke stažení:

  • Operace, která má být provedena pro každou součást, se zobrazí na pravé straně.
  • Pokud je u součásti k dispozici volitelná instalace dílčích součástí, zobrazí se vedle součásti ikona +. Chcete-li zobrazit dostupné dílčí součásti pro danou součást, klepněte na ikonu +.
  • V případě rozbalení součásti a zobrazení volitelných dílčích součástí se vedle součásti zobrazí ikona -. Chcete-li sbalit výpis dílčích součástí, klepněte na ikonu -.
  • Klepnutím na ikonu umístěnou vlevo od součásti vyberte způsob, jakým ji Manažer instalací SOLIDWORKS má zpracovat.
Pokud neurčíte jinak, Manažer instalací SOLIDWORKS stáhne všechny součásti produktu, ke kterým máte oprávnění. Pro zkrácení doby stahování a zmenšení požadovaného místa na disku rozbalte součásti produktu a vyberte součásti, které nepotřebujete.

Pokud Manažer instalací SOLIDWORKS nebyl schopen ověřit produkty, které jste oprávněni používat, můžete ke stažení vybrat balík SOLIDWORKS. Manažer instalací SOLIDWORKS zobrazí seznam všech produktů SOLIDWORKS, jenž jsou kompatibilní s vybraným balíčkem.

Pokud aplikace SOLIDWORKS Installation Manager není schopna ověřit produkty, které jste oprávněni používat, klikněte na možnost Vybrat jiný balíček nebo produkty a změňte balíček produktů (např. SOLIDWORKS Professional, SOLIDWORKS Premium nebo SOLIDWORKS Ultimate) v seznamu položek k instalaci nebo změně. Manažer instalací SOLIDWORKS zobrazí seznam všech produktů SOLIDWORKS na vašem instalačním médiu, jenž jsou kompatibilní s vybraným balíčkem. Můžete vybrat jakékoli produkty, které jste zakoupili nebo jste oprávněni vyzkoušet.

Jazyková podpora

Specifikace Jazyky omezuje jazyky, které jsou nainstalovány jen pro produkt SOLIDWORKS. Toto nastavení nemá vliv na instalace ostatních produktů. Například aplikace eDrawings® instaluje všechny jazyky.

Potřebné místo na disku

V závislosti na vybraném produktu se zobrazí požadované místo ke stažení. Velikost stažení je celkové množství místa na disku vyžadovaného pro všechny stahované soubory (nezahrnuje místo požadované pro dekomprimaci souborů po dokončení stažení). Toto číslo je pouze odhad.

Pokud chcete u budoucích aktualizací a oprav snížit dobu na stažení a instalaci, neodstraňujte po instalaci stažené soubory. Následující aktualizace a opravy většinou vyžadují přístup k poslední sadě souborů úplné instalace.
Nadřazené téma Nápověda aplikace Manažer instalací SOLIDWORKS


Produkty k opravě

Když vyberete možnost Opravit tuto instalaci, zobrazí se obrazovka obsahující produkty SOLIDWORKS spolu s čísly verzí, které je možné opravit pomocí Manažera Instalací SOLIDWORKS.

Při opravě dojde k ověření, zda jsou přítomny všechny soubory a zda jsou správně zaregistrovány. Opravy nemají vliv na vytvořená data.
  • Chcete-li produkt opravit, ujistěte se, že je vybraný.
  • Zrušte výběr produktů, které nechcete opravit.

Klepnutím na Opravit zahájíte opravu vybraných produktů.

Je možné opravit individuální instalaci. Instalaci administrativní kopie nelze opravit; musíte znovu nainstalovat administrativní kopii.
Nadřazené téma Nápověda aplikace Manažer instalací SOLIDWORKS


Sériová čísla

Sériová čísla přidružují váš počítač k produktům SOLIDWORKS, které jste zakoupili.

Pokud jsou ve vašem počítači již nainstalované produkty SOLIDWORKS, budou jejich sériová čísla podle výchozího nastavení zobrazena:
  • Zadejte své sériové číslo SOLIDWORKS, pokud ještě není zobrazeno.
  • Pokud máte pro produkty sériová čísla, která nejsou součástí vaší licence SOLIDWORKS, zadejte je do vhodných polí.

Pokud máte připojení k internetu, použijí se sériová čísla během instalace k zobrazení produktů, ke kterým máte oprávnění, abyste mohli vybrat produkty k instalaci.

Některá sériová čísla mohou sloužit pro dva nebo více produktů, protože existuje několik způsobů zakoupení produktů SOLIDWORKS. Například sériové číslo SOLIDWORKS vám umožní nainstalovat SOLIDWORKS Simulation bez zadání sériového čísla SOLIDWORKS Simulation. Navíc některé produkty nevyžadují sériové číslo. Pokud máte jakékoliv dotazy ohledně sériových čísel, kontaktujte místního prodejce.

Nadřazené téma Nápověda aplikace Manažer instalací SOLIDWORKS


Instalace serveru

Produkty serveru, které instalujete, jsou uvedeny v seznamu s výsledkem instalace.

Stav instalace serveru

Instalace produktů serveru se provádějí pomocí externí instalační aplikace. Pokud se právě v této aplikaci nenacházíte, musíte na ni přepnout, abyste instalaci dokončili.

Klepněte na Storno pro ukončení instalace produktů serveru.

Instalace serveru byla dokončena

Externí instalační aplikace byla úspěšně dokončena.

Klepněte na Dokončit nebo Další.
  • Pokud instalujete jiné administrativní produkty (například administrativní kopii SOLIDWORKS ), tato instalace pokračuje.
  • Pokud instalace produktů serveru byla jediná instalační operace, Manažer instalací SOLIDWORKS se zavře.

Instalace serveru byla zrušena nebo se nepodařila

Pokud se instalace serveru nepodařila nebo byla zrušena, na seznamu budou uvedeny servery, které nebyly nainstalovány.

Klepněte na Zavřít nebo Další.
  • Pokud jste zadali jiné administrativní instalace produktů, Manažer instalací SOLIDWORKS se obnoví.
  • Pokud instalace produktů serveru byla jediná instalační operace, Manažer instalací SOLIDWORKS se zavře.

Pro více informací

Více informací o instalaci, konfiguraci a používání manažera licencí SolidNetWork License Manager viz Správa licencí za použití SolidNetWork License Manager.

Nadřazené téma Nápověda aplikace Manažer instalací SOLIDWORKS


Souhrnné informace

Manažer instalací SOLIDWORKS má všechny potřebné informace pro dokončení instalace.

Chcete-li pokračovat: | Klepnutím na tlačítko Akce Nyní zahájíte instalaci (například Instalovat nyní, Vytvořit nyní, Stáhnout nyní, Upravit nyní).
Postup při změně nastavení instalace: | Klikněte na ZMĚNA [image] pro část, kterou chcete změnit (například Produkty, Umístění instalace, Možnosti Toolbox).
Pro zrušení: | Klepněte na Storno pro ukončení Manažera instalací SOLIDWORKS bez změny součástí instalace.
Pokud se chcete vrátit na předchozí stránku: | Klepnutím na Zpět se v Manažeru instalací SOLIDWORKS vrátíte na předchozí stránku.
Další informace o určité sadě možností instalace (například Produkty, Umístění instalace, Možnosti Toolbox atd.):
  1. Klikněte na tlačítko ZMĚNA [image] vedle části, pro kterou potřebujete informace.
  2. Na podrobné stránce, která se objeví, klepněte na Nápověda pro získání informací o příslušném nastavení možností instalace.
Nadřazené téma Nápověda aplikace Manažer instalací SOLIDWORKS


Upozornění kontroly systému

Kontrola systému prověřuje oznámené problémy, které by mohly mít dopad na průběh instalace. Ve většině případů byste měli být schopni pokračovat dále s Manažerem instalací SOLIDWORKS.

Níže jsou uvedena varování, s nimiž se můžete v této fázi setkat, spolu s doporučením, jak pokračovat.

Problém s ověřením sériového čísla

Manažer instalací nezjistil nové verze, protože nemohl ověřit vaše sériové číslo. Pokud jste připojeni a zadali jste platné sériové číslo, může se jednat o dočasný problém na našem serveru. Zkuste to znovu později.

Ověření sériového čísla: Manažer instalací nemohl ověřit vaše sériové číslo, a tím určit, které produkty jste oprávněni nainstalovat. Budete si i nadále moci zvolit produkty, které chcete nainstalovat, ale nebudete moci stáhnout žádné instalační soubory. K instalaci budete muset poskytnout kompletní sadu zdrojových souborů nebo DVD.

Rozlišení:
  • Zkontrolujte připojení k internetu. Kontrola sériového čísla vyžaduje platné internetové připojení.
  • Zkontrolujte, zda vámi zadané sériové číslo je platné pro produkty, které chcete instalovat.
  • Některé instalace vyžadují, abyste měli v době vydání příslušné verze aktivní předplatitelskou službu., Podrobnosti vám sdělí váš prodejce SOLIDWORKS.
  • Ve většině případů můžete pokračovat v instalaci, za předpokladu, že ji provádíte z DVD nebo z dříve stažené sady souborů.

Dostupná novější verze

Dostupná novější verze

Jsou k dispozici novější verze.

Novější verze tohoto produktu je k dispozici pro stažení.

Rozlišení: Když se provádí operace Zjistit aktualizace, instalační program může zobrazit výzvu k instalaci novější verze, která je dostupná ke stažení ze SOLIDWORKS. V této operaci můžete pokračovat s použitím verze, kterou jste na počátku specifikovali, nebo můžete stáhnout tuto novější verzi a pokračovat v operaci s použitím této verze.

Nejnovější dostupná verze

Toto je nejnovější dostupná verze. Pokračujte klepnutím na Další.

Žádná nová stažení

Řešení: Tato zpráva se může objevit, když kontrolujete aktualizace během instalace nebo změny. Informuje o tom, že právě instalujete (nebo jste nainstalovali) nejnovější dostupnou verzi.

Problémy s internetovým připojením

Internetové připojení: Manažer instalací se nemohl připojit k serveru SOLIDWORKS a určit, které produkty jste oprávněni nainstalovat. Budete si i nadále moci zvolit produkty, které chcete nainstalovat, ale nebudete moci stáhnout žádné instalační soubory. Bude potřeba poskytnout zdrojové soubory na DVD nebo z dříve stažené sady souborů.

Nepodařilo se zjistit nové verze

Manažer instalací nezjistil nové verze, protože se nemohl připojit k serveru.

Řešení:
  • Zkontrolujte připojení k internetu.
  • Můžete pokračovat v instalaci za předpokladu, že ji provádíte z DVD nebo z dříve stažené sady souborů.

Nadřazené téma Nápověda aplikace Manažer instalací SOLIDWORKS


Možnosti Průvodce dírami/Toolbox

Pokud je SOLIDWORKS Toolbox instalován, obsahuje software SOLIDWORKS knihovnu standardních typů děr stejně jako hardware.

Chcete-li získat podrobné informace o konfiguraci, rozšiřování a používání SOLIDWORKS Toolboxu, klikněte v SOLIDWORKS na nabídku Nápověda a prostudujte její část Toolbox.

Než začnete používat SOLIDWORKS Toolbox, ujistěte se, že je správně nakonfigurovaný podle zásad vaší společnosti nebo skupiny. V mnoha případech bude centrální Toolbox konfigurovat a spravovat skupina. Požádejte správce SOLIDWORKS o radu, jak při instalaci SOLIDWORKS zadat Toolbox.

Zvolený SOLIDWORKS Toolbox můžete po instalaci změnit. V SOLIDWORKS klikněte na Nástroje > Možnosti. Na záložce Možnosti systému klikněte na Průvodce dírami/Toolbox.

Následující sekce popisují všechny možnosti, se kterými se můžete setkat na této obrazovce, pro všechny konfigurace. Aktuální možnosti Toolboxu, které vidíte, závisejí na předchozích konfiguracích SOLIDWORKS a Toolboxu na tomto počítači a možnostech manažera instalací SOLIDWORKS Installation Manager, které jste v tomto bodě určili.

Vytvořit nový Toolbox nová verze

Vytvořte novou verzi SOLIDWORKS Toolboxu na tomto počítači.

Při vytváření nové verze rozbalte na obrazovce Výběr produktu SOLIDWORKS > SOLIDWORKS Toolbox a vyberte, které normy bude Toolbox podporovat. Všechny normy jsou standardně vybrány.

Jakékoliv již stávající Toolboxy na tomto počítači se nezmění.

Vytvořit odkaz nebo provést upgrade u stávajícího Toolbox

Použít stávající Toolbox Klikněte na Procházet pro určení místa Toolbox, který chcete použít s touto instalací.

  • Pokud je Toolbox konfigurován pro předchozí hlavní finální verzi SOLIDWORKS, provede se upgrade na tuto verzi. Jakékoliv přizpůsobení provedené na tomto Toolbox je v upgradovaném Toolbox zachováno.
    Pokud provedete upgrade Toolboxu na novou hlavní finální verzi SOLIDWORKS, není už Toolbox kompatibilní s počítači, na kterých běží předchozí hlavní finální verze SOLIDWORKS.
  • Pokud je Toolbox konfigurován pro tuto verzi SOLIDWORKS (což může být v případě, že jste určili sdílenou síť Toolboxu, u které byl již proveden upgrade), na tomto Toolboxu se upgrade neprovede.
  • Pokud provádíte upgrade na Toolbox v prostředí SOLIDWORKS PDM, je nutno provést další postupy. Podrobnosti najdete v Poznámky o konfiguraci SOLIDWORKS Toolboxu.

Tato možnost se objeví ve všech instalačních scénářích kromě vytvoření administrativní kopie.

Provést upgrade Toolbox předchozí-verze

Nakopírujte Toolbox konfigurovaný pro předchozí hlavní verzi do nového umístění a proveďte upgrade této kopie na tuto verzi.

Tato možnost se objeví, pokud je předchozí hlavní verze SOLIDWORKS instalována na tomto počítači, ale vy jste se rozhodli, že u této instalace na tuto verzi upgrade neprovedete.
Účelem této možnosti je provést upgrade Toolboxu pro předchozí hlavní verzi SOLIDWORKS, která je instalována, aniž by to mělo dopad na uživatele starší verze Toolboxu.

Pokud provádíte upgrade na Toolbox v prostředí SOLIDWORKS PDM, je nutno provést další postupy. Podrobnosti najdete v Poznámky o konfiguraci SOLIDWORKS Toolboxu.

Provést upgrade tohoto nainstalovaného Toolbox předchozí-verze

Proveďte upgrade tohoto Toolbox na novější verzi.
Pokud provedete upgrade Toolboxu na novou hlavní finální verzi SOLIDWORKS, není už Toolbox kompatibilní s počítači, na kterých běží předchozí hlavní finální verze SOLIDWORKS.

Tato možnost se objeví, pokud provádíte upgrade předchozí hlavní verze SOLIDWORKS na tuto verzi a na počítači je nalezen Toolbox konfigurovaný pro tuto verzi.

Pokud provádíte upgrade na Toolbox v prostředí SOLIDWORKS PDM, je nutno provést další postupy. Podrobnosti najdete v Poznámky o konfiguraci SOLIDWORKS Toolboxu.

Použít nainstalovaný Toolbox aktuální-verze

Manažer instalací SOLIDWORKS Installation Manager zjistil na tomto počítači Toolbox konfigurovaný pro tuto hlavní verzi SOLIDWORKS.

Pokud vyberete tuto možnost, SOLIDWORKS tento Toolbox použije. Nedojde k žádnému upgrade.

Tato možnost se objeví, pokud je předchozí hlavní verze SOLIDWORKS instalována na tomto počítači, ale Toolbox je konfigurován pro tuto verzi. K tomu může dojít, pokud je Toolbox vytvořen na počítači, na kterém stále běží starší verze SOLIDWORKS.

Zadat umístění Toolbox pro klientský počítač

Zadejte síť nebo adresář jako výchozí umístění Toolboxu, když klienti instalují z administrativní kopie.
Pokud umístění obsahuje Toolbox konfigurovaný pro předchozí hlavní verzi SOLIDWORKS v době, kdy dochází ke klientské instalaci, Manažer instalací SOLIDWORKS provede upgrade tohoto Toolboxu.

Tato možnost se objeví, pokud vytváříte novou administrativní kopii.

Proveďte upgrade nebo použijte Toolbox, na nějž se odkazuje ve stávající kopii pro klientský počítač

Použijte umístění Toolbox určené ve stávající administrativní kopii, kterou jste aktualizovali.
Pokud umístění obsahuje Toolbox konfigurovaný pro předchozí hlavní verzi SOLIDWORKS v době, kdy dochází ke klientské instalaci, Manažer instalací SOLIDWORKS provede upgrade tohoto Toolboxu.

Výběr jiného umístění Toolbox pro klientský počítač

Zadejte jiné umístění Toolboxu než to, které je zadáno ve stávající administrativní kopii, kterou aktualizujete.
Pokud umístění obsahuje Toolbox konfigurovaný pro předchozí hlavní verzi SOLIDWORKS v době, kdy dochází ke klientské instalaci, Manažer instalací SOLIDWORKS provede upgrade tohoto Toolboxu.

Obsah

  • Poznámky o konfiguraci SOLIDWORKS Toolboxu

    SOLIDWORKS Toolbox obsahuje velice užitečné a komplexní funkce. Toto téma shrnuje určité koncepty, které je nutno zohlednit před konfigurací Toolbox za použití Manažera instalací SOLIDWORKS.

  • Formát UNC

    Jednotný (nebo univerzální) formát pro konvence názvů určuje syntax názvů souborů pro popis sdíleného umístění souboru.

Nadřazené téma Nápověda aplikace Manažer instalací SOLIDWORKS
Poznámky o konfiguraci SOLIDWORKS Toolboxu


Poznámky o konfiguraci SOLIDWORKS Toolboxu

SOLIDWORKS Toolbox obsahuje velice užitečné a komplexní funkce. Toto téma shrnuje určité koncepty, které je nutno zohlednit před konfigurací Toolbox za použití Manažera instalací SOLIDWORKS.

Zdroje dodatečných informací o SOLIDWORKS Toolboxu

Chcete-li získat podrobné informace o konfiguraci, rozšiřování a používání SOLIDWORKS Toolboxu, klikněte v softwaru SOLIDWORKS na možnost [image] Nápověda.

Použití sdíleného Toolbox

Když instalujete Toolbox, můžete mít data Toolbox na lokálním počítači nebo na sdíleném místě na síti. Doporučujeme uložení dat Toolbox na síti. Když použijete společné místo, všichni uživatelé SOLIDWORKS používají společně konzistentní sadu informací o šroubech.

Pokud je to první instalace, přejděte k nově sdílenému umístění, kam chcete provést instalaci Toolbox.

Provedení upgrade existujícího Toolbox

Pokud provedete upgrade Toolboxu na novou hlavní finální verzi SOLIDWORKS, není už Toolbox kompatibilní s počítači, na kterých běží předchozí hlavní finální verze SOLIDWORKS.

Pokud na jiných počítačích zůstane tato předchozí finální verze a software bude vyžadovat, aby byl Toolbox nakonfigurován na tuto verzi, vytvořte kopii tohoto Toolboxu a na této kopii pak proveďte upgrade. Nová instalace softwaru SOLIDWORKS upgraduje kopii Toolboxu a předchozí instalace softwaru SOLIDWORKS budou nadále používat starou sadu Toolbox.

Konfigurace přístupu do Toolbox

Když po instalaci použijete součást Toolbox, zkontrolujte software SOLIDWORKS konfiguraci sady Toolbox a nabídne doporučení pro zlepšení přístupu a výkonu.

Pro přístup k sadě Toolbox ve sdílené síti (doporučené řešení) použijte cestu UNC k serveru, na kterém je sdílený Toolbox nainstalován. Podrobnosti najdete v Formát UNC.

Správce může vytvořit heslo pro Toolbox a nastavit oprávnění a předvolby pro pracovní skupinu. Omezení přístupu ke konfiguraci a nastavení všeobecných předvoleb zajišťuje konzistentní data sady Toolbox.

Upgrade modulu Toolbox v prostředí SOLIDWORKS PDM

Když upgradujete software SOLIDWORKS, bude upgradován i Toolbox, pokud přidáte nějaké díly. Pokud se kořenová složka Toolbox nachází v úschovně SOLIDWORKS PDM, musíte před zahájením upgradu SOLIDWORKS připravit složku Toolbox.

U prvního systému, na kterém provádíte upgrade, musíte zkontrolovat databázi Toolbox a příkazem Načíst aktuální verzi stáhnout soubory Toolbox do lokální vyrovnávací paměti. U dalších systémů, které se upgradují, je jediným požadavkem stažení souborů Toolfix.

Než provedete upgrade:
  • Zkontrolujte, zda máte úplnou aktuální zálohu databáze úschovny a archivu.
  • Zkontrolujte, zda nejsou díly Toolbox vyzvednuté nebo nejsou použité v žádných aktuálně vyzvednutých sestavách.

Postup upgradu Toolbox:

  1. V Průzkumníku souborů se přihlaste do úschovny jako uživatel s plným oprávněním (vyzvednutí, odevzdání, přidání, mazání).
  2. Klepněte pravým tlačítkem na složku Toolbox a příkazem Načíst aktuální verzi zkopírujte všechny soubory Toolbox a databázi dílů do lokální vyrovnávací paměti.
    Pokud pracujete se vzdáleným archivním serverem, můžete tato operace několik minut trvat.
  3. Zkontrolujte soubor databáze Toolbox (SWBrowser.mdb) nebo (swbrowser.sldedb) ve složce \Toolbox_folder_name\lang\your_lang.
  4. Spusťte Manažera instalací SOLIDWORKS a proveďte upgrade.
  5. V okně Souhrnné informace zkontrolujte, zda je umístění instalace v nastavení Možnosti Toolbox nastaveno na úschovnu.

    Pokud ne, klepněte na Změnit, vyberte možnost Vytvořit odkaz nebo provést upgrade u stávajícího nástroje Toolbox a vyhledejte umístění Toolbox v úschovně.

  6. Po dokončení upgradu odevzdejte v Průzkumníku souborů složku Toolbox; tím budou do úschovny přidány veškeré nové a aktualizované soubory, takže ostatní uživatelé budou moci pracovat s nástrojem Toolbox.
  7. Přejděte do složky Toolbox v úschovně a zkontrolujte, zda obsahuje následující soubory pro upgrade:
    • \Toolbox_folder_name\Updates
    • \Toolbox_folder_name\ToolboxStandards.xml
    • \Toolbox_folder_name\Browser\ToolboxFiles.index

      Pokud je nenajdete, obraťte se na svého prodejce produktů SolidWorks.

  8. Proveďte upgrade ostatních počítačů, které využívají integraci softwaru SOLIDWORKS PDM s modulem Toolbox:
    1. V Průzkumníku souborů se přihlaste do úschovny jako uživatel alespoň s oprávněním ke čtení ze složky Toolbox.
    2. Klepněte pravým tlačítkem na složku Toolbox a příkazem Načíst aktuální verzi zkopírujte soubory Toolbox do lokální vyrovnávací paměti.
    3. Spusťte správce instalací SOLIDWORKS a proveďte upgrade.

      Instalační program zjistí, zda již nebyl Toolbox upgradován.

Pro podrobnosti o konfiguraci modulu Toolbox v SOLIDWORKS PDM viz Konfigurace Toolboxu v SOLIDWORKS PDM Nástroji pro správu.

Nadřazené téma Možnosti Průvodce dírami/Toolbox
Formát UNC


Formát UNC

Jednotný (nebo univerzální) formát pro konvence názvů určuje syntax názvů souborů pro popis sdíleného umístění souboru.

\\server\volume\path

Příklad:

\\Disk_Server\SOLIDWORKS\AdminImage

Nadřazené téma Možnosti Průvodce dírami/Toolbox
Poznámky o konfiguraci SOLIDWORKS Toolboxu


Odinstalování produktů

Zvolíte-li v Ovládacích panelech možnosti Odebrat nebo Odinstalovat program, zobrazí se tato obrazovka s produkty SOLIDWORKS (s čísly verze), které lze odinstalovat pomocí této verze Manažera instalací SOLIDWORKS. Můžete určit, zda se má provést standardní, vlastní nebo úplná odinstalace.

Při standardní odinstalaci budou odstraněny programové soubory a složky produktu SOLIDWORKS. Ve výchozím nastavení jsou k odinstalování určeny všechny produkty SOLIDWORKS pro vybranou verzi.

Při vlastní odinstalaci bude odstraněna jedna nebo více z následujících položek: programové soubory a složky, klíče registru a datové složky (např. SOLIDWORKS Toolbox) a soubory a složky z původního umístění stažených dat.

Při úplné odinstalaci budou odstraněny instalační adresáře, klíče registru a datové složky.

Chcete-li odinstalovat produkt, postupujte takto:
  1. Zkontrolujte na obrazovce Odinstalace, zda je produkt vybrán.

    Pokud odinstalujete všechny produkty, bude odinstalován i Manažer instalací.

  2. Zrušte výběr produktů, které nechcete odstranit.

    Pokud zachováte kterýkoli produkt, Manažer instalací SOLIDWORKS odinstalován nebude.

  3. Určete, zda se má provést vlastní nebo úplná odinstalace.
    1. Klepněte na možnost Změnit v části Upřesňující možnosti.

      Zobrazí se okno Upřesňující možnosti. Je zaškrtnuta možnost Programové soubory a složky.

    2. Vyberte jednu nebo více možností, chcete-li provést vlastní odinstalaci, nebo všechny položky, pokud chcete provést úplnou odinstalaci.
    3. Klepněte na Zpět na souhrnné informace.
    4. V okně Souhrnné informace rozbalte položku Upřesňující možnosti; zobrazí se metoda a údaje o odinstalaci.
  4. Klepněte na Odstranit položky.
Když klepnete na Odstranit položky, Manažer instalací SOLIDWORKS začne okamžitě odstraňovat produkty.
Nadřazené téma Nápověda aplikace Manažer instalací SOLIDWORKS


SOLIDWORKS Visualize Boost

SOLIDWORKS Visualize Boost je aplikace umožňující distribuovat vykreslování z počítače se softwarem SOLIDWORKS Visualize Professional na jeden či více počítačů v síti.

Na počítači můžete provádět další úlohy, zatímco vykreslování probíhá na pozadí, a konečné vykreslené snímky jsou tak hotové dříve. Obrázky je možné vykreslovat na jednom počítači nebo v clusteru více počítačů se softwarem Visualize Boost.

Každé aktivní předplatné softwaru SOLIDWORKS Visualize Professional obsahuje jednu bezplatnou licenci SOLIDWORKS Visualize Boost.

Zvýšení výkonu – například zrychlení vykreslování – závisí na výkonu počítačů se softwarem Visualize Boost. Počítače s lepšími grafickými kartami umožňují větší zlepšení.


Provedení upgrade z individuální licence na licenci SolidNetWork

Můžete provést upgrade počítače z individuální licence SOLIDWORKS na licenci SolidNetWork zadáním sériového čísla licence SolidNetWork v Manažeru licencí SOLIDWORKS.

Pokud v počítači nebyl nainstalován program SOLIDWORKS, můžete určit licenci SolidNetWork zadáním sériového čísla licence SolidNetWork při instalaci pomocí Manažera instalace SOLIDWORKS.

Pokud je již v počítači nainstalován SOLIDWORKS a přecházíte z individuální licence na licenci SolidNetWork, můžete upravit instalaci pro klientský počítač a zadat sériové číslo licence SolidNetWork místo sériového čísla individuální licence, když spouštíte Manažera instalací SOLIDWORKS. Podrobnosti viz Změna instalace.
Jestliže byl software SOLIDWORKS nainstalován z administrativní kopie, není možnost změn k dispozici. V administrativní kopii proveďte změny pomocí Editoru možností administrativní kopie, odinstalovat klientskou aplikaci a spustit instalaci znovu.


Práce s nástrojem Visualize Boost

Chcete-li povolit distribuované vykreslování, musíte připojit software po konfiguraci propojit s nástrojem SOLIDWORKS Visualize Boost.

K tomuto připojení je nutno v softwaru SOLIDWORKS Visualize zadat parametry IP adresa koordinátora a Port Boost.

Nechte software Visualize Boost i SOLIDWORKS Visualize spuštěný.

Propojení softwaru SOLIDWORKS Visualize s nástrojem Visualize Boost provedete takto:

  1. Otevřete nástroj Visualize Boost dvojím kliknutím na jeho ikonu na pracovní ploše [image].
  2. V aplikaci Visualize Boost klikněte dvakrát na hodnotu IP adresa koordinátora a zkopírujte ji do schránky.
  3. Klikněte na nabídku Nástroje > Možnosti > Boost v softwaru SOLIDWORKS Visualize a stisknutím kláves CTRL+V vložte hodnotu do pole IP adresa koordinátora.
  4. Opakováním kroků 2 a 3 zkopírujte hodnotu Port Boost z nástroje Visualize Boost do softwaru SOLIDWORKS Visualize.
    Hodnota Port Boost zadaná v nástroji Visualize Boost a v softwaru SOLIDWORKS Visualize Boost musí být stejná.
    V SOLIDWORKS Visualize se zobrazí ovládací prvek Stav Boost.
  5. Dialogové okno Možnosti zavřete klepnutím na OK.
  6. Chcete-li se připojit k aplikaci Boost, klikněte na možnost Stav nástroje Boost [image] nebo odpojte možnost [image] v těchto rozhraních:
    • Průhledový displej
    • Stránka Kvalita Průvodce vykreslováním
    • Záložka Nástroje > Možnosti > Boost

Podrobnosti o konfiguraci nástroje Boost naleznete v části SOLIDWORKS Visualize Boost.


Inicializace nového licenčního serveru SolidNetWork

Inicializace licenčního serveru SolidNetWork:

  1. Po instalaci a otevření serveru nástroje SolidNetWork License Manager klikněte po výzvě k aktivaci na možnost Ano.
  2. V dialogovém okně Informace o licenčním serveru SolidNetWork ověřte možnosti Firewall a Porty a klikněte na možnost Další.
  3. V Průvodci aktivací produktu vyberte Sériová čísla, která chcete aktivovat, vyberte jako způsob aktivace možnost Ručně prostřednictvím e-mailu a zadejte Kontaktní údaje e-mailu.

    Ruční metoda vyžaduje, abyste vytvořili soubor požadavku a jeho odeslání e-mailem na adresu activation@solidworks.com. Když obdržíte e-mail obsahující soubor s odpovědí na licenci, extrahujte soubor a kliknutím na možnost Otevřít jej načtěte na server.

    Průvodce aktivací produktu můžete zavřít a znovu spustit, aby se otevřel a načetl soubor odezvy.

  4. Když se zobrazí okno se zprávou, že inicializace proběhla úspěšně, klikněte na možnost OK a v Průvodci aktivací produktu klikněte na možnost Dokončit.


Ruční aktivace nového serveru nástroje SolidNetWork License Manager

Po inicializaci serveru nástroje SolidNetWork License Manager otevřete server nástroje SolidNetWork License Manager a vytvořte druhý požadavek na dokončení aktivace.

Ruční aktivace nového serveru nástroje SolidNetWork License Manager:

  1. Proveďte jednu z následujících operací:
    • Pokud se zobrazí výzva k aktivaci, klikněte na možnost Ano.
    • Pokud se výzva nezobrazí, klikněte na možnost Změnit na kartě Správa serveru.
    Ve výchozím nastavení jsou Pokročilé možnosti nastaveny na režim Použít aktivaci.
  2. Ověřte položky Firewall a Porty v dialogovém okně Informace o licenčním serveru SolidNetWork a klikněte na možnost Další.
  3. V Průvodci aktivací produktu vyberte Sériová čísla, která chcete aktivovat, zadejte Kontaktní e-mailové údaje a jako způsob aktivace vyberte možnost Ručně prostřednictvím e-mailu.
  4. Podle pokynů vytvořte soubor požadavku a odešlete jej na adresu activation@solidworks.com. Jakmile obdržíte soubor s licenční odpovědí, kliknutím na možnost Otevřít soubor načtěte.
  5. Po dokončení aktivace klikněte na možnost Dokončit.


Ruční aktivace upgradovaného serveru SolidNetWork License Manager

Po upgradu serveru SolidNetWork License Manager Server pomocí Manažera instalací SOLIDWORKS otevřete server SolidNetWork License Manager.

Ruční aktivace upgradovaného serveru SolidNetWork License Manager:

  1. Na kartě Správa serveru v části Informace o licenci klikněte na možnost Znovu aktivovat.
    Pokud jste deaktivovali licence před odinstalováním a upgradem serveru SolidNetWork License Manager, klikněte místo toho na kartě Správa serveru na možnost Změnit. Dialogové okno Znovu aktivovat je k dispozici pouze v případě, že jsou na serveru aktivovány licence.

    Pokračujte krokem 3.

  2. V dialogovém okně Znovu aktivovat vyberte nainstalovaná sériová čísla pro zobrazení příslušných licencí a klikněte na možnost Znovu aktivovat.
  3. Ověřte položky Firewall a Porty v dialogovém okně Informace o licenčním serveru SolidNetWork a klikněte na možnost Další.
  4. V Průvodci aktivací produktu vyberte Sériová čísla, která chcete aktivovat, zadejte Informace kontaktního e-mailu a jako způsob aktivace vyberte možnost Ručně pomocí e-mailu.
    Ruční aktivace je snadný proces. Celým postupem vás provedou pokyny v průvodci Aktivace produktu.
  5. Po dokončení aktivace klikněte na možnost Dokončit.